Aunque el equipo de Lightroom siempre tiene en mente incrementar el rendimiento, las funciones nuevas y mejoradas siguen requiriendo recursos del sistema. 

Los problemas de rendimiento aparecidos en línea se han recibido con sugerencias muy diversas. El equipo de Lightroom desea ofrecer a los clientes soluciones eficaces. Asimismo, el equipo recalca que el usuario debe tener en cuenta los riesgos que conllevan algunas de las soluciones facilitadas. 

Esta nota técnica es una serie de sugerencias poco habituales relativas a los problemas de rendimiento comentados por los clientes en las páginas de las redes sociales. El contenido se actualizará a medida que quede obsoleto o que se encuentren soluciones. Para acceder a soluciones y sugerencias más tradicionales, consulte esta nota técnica.

Reiniciar Lightroom

La primera sugerencia es actualizar la memoria del equipo reiniciando Lightroom. Esta acción reduce muchas disminuciones de rendimiento.

Actualizar a la versión más reciente de Lightroom

Para actualizar Lightroom, en dicho programa elija Ayuda > Buscar actualizaciones.

En Lightroom 5.6, reducir la cantidad de ajustes preestablecidos de Revelar

El rendimiento puede disminuir si en Lightroom 5.6 se han cargado muchos ajustes preestablecidos de Revelar. La cantidad exacta de ajustes preestablecidos depende de cada equipo. Lightroom se sometió a pruebas con 1000; así pues, empiece por reducir a 1000 y ver si, de este modo, mejora el rendimiento. Si funciona, vaya incrementando los ajustes preestablecidos hasta determinar cuál es la cantidad adecuada para el equipo.

Hardware

RAM: el requisito mínimo del sistema es 2 GB. Ahora bien, 16 GB pueden mejorar el rendimiento de manera considerable, en especial si se utilizan varias aplicaciones simultáneamente, por ejemplo Photoshop.

Unidades de SSD: si tiene una unidad de estado sólido, Lightroom funciona con más rapidez si coloca el catálogo (archivo .lrcat) y las previsualizaciones de imágenes (archivo .lrdata file) en la unidad de SSD.

Actualizar el controlador de vídeo

Los controladores de pantalla actualizados pueden corregir muchos problemas como bloqueos, objetos interpretados incorrectamente y problemas de rendimiento.

Para actualizar el controlador de pantalla en Windows 7 o Vista, consulte esta nota técnica.

En Mac OS, la mayoría de las actualizaciones del controlador de vídeo se instalan con las actualizaciones del sistema operativo. Aun así, Nvidia proporciona algunos controladores. Para las tarjetas de vídeo Nvidia, diríjase al sitio web de Nvidia.

La ubicación predeterminada del catálogo es la carpeta Mis imágenes > Lightroom (Windows) o la carpeta Imágenes > Lightroom (Mac OS). El archivo de previsualizaciones de imagen, [(nombre de catálogo Previews.lrdata], se encuentra en la misma ubicación que el catálogo. El catálogo y el archivo de previsualizaciones se pueden trasladar a cualquier otra ubicación. Ahora bien, en tal caso, anote bien el nombre y la ubicación del catálogo y del archivo de previsualizaciones.

Tras mover el catálogo, haga que Lightroom tenga en cuenta su nueva ubicación. Al volver a abrir Lightroom, se le solicitará buscar el catálogo. Seleccione Elegir un catálogo diferente:

Ubicación del catálogo de Lightroom

A continuación, aparece el cuadro de diálogo Seleccionar catálogo. Seleccione el catálogo. Si el catálogo no aparece en la lista, seleccione Elegir un catálogo diferente. A continuación, en la ventana del Finder que se abre, acceda a la nueva ubicación.

Cuadro de diálogo Elegir un catálogo diferente de Lightroom

Si se abre el cuadro de diálogo siguiente, seleccione Elegir un catálogo diferente hasta que se abra la ventana del Finder. Acceda a la nueva ubicación del catálogo.

Cuadro de diálogo Elegir un catálogo diferente de Lightroom

Si utiliza Photoshop con Lightroom, compruebe la configuración de la memoria RAM de Photoshop

Consulte las secciones sobre optimización y ajuste del uso de memoria de esta nota técnica para determinar la configuración de RAM más adecuada para el equipo. Para cambiar la configuración de la memoria en Photoshop, elija Apple > Preferencias > Rendimiento (Mac OS) o Edición > Preferencias > Rendimiento (Windows).

Pantallas de alta resolución

Dibujar en la pantalla puede ser un proceso lento si Lightroom se utiliza a pantalla completa en una pantalla de alta resolución. Una pantalla de alta resolución tiene una resolución nativa aproximada de 2560 x 1600, y es la que suelen presentar los monitores de 30 pulgadas y los equipos Retina MacBook. Para incrementar el rendimiento en tales pantallas, reduzca el tamaño de la ventana de Lightroom, o bien utilice las vistas 1:2 o 1:3 en el panel Navegador.

Módulo Revelar

Herramienta Eliminación de tinta plana, correcciones locales y panel Historial

La herramienta Eliminación de tinta plana y el pincel de correcciones locales no son aptos para realizar de centenares a miles de correcciones. Si la imagen contiene centenares de ajustes locales, para ese nivel de corrección lo aconsejable es una aplicación de edición basada en píxeles como Photoshop.

Si tiene muchas correcciones, compruebe el panel Historial. El panel Historial no tiene límites y no se elimina a menos que se especifique lo contrario. Si ha creado demasiadas correcciones locales o de tinta plana, es posible que el historial sea largo, lo cual puede repercutir en el rendimiento general de Lightroom.

Borre el panel Historial; para ello, haga clic en la X que hay a la derecha del encabezado de dicho panel.

Orden de las operaciones de Revelar

Para incrementar el rendimiento, este es el orden óptimo que deben tener las operaciones de Revelar:

  1. Corrector puntual.
  2. Las correcciones de Geometría, por ejemplo los perfiles de Corrección de lente y las correcciones de Manual, incluidas las correcciones del efecto keystone o deformación de la imagen en forma de trapecio mediante el regulador Vertical.
  3. Correcciones que no son de detalles globales, por ejemplo Exposición y Equilibrio de blancos. Si es conveniente, estas correcciones también pueden hacerse primero.
  4. Correcciones locales, por ejemplo Filtro degradado y trazos de Pincel de ajuste.
  5. Correcciones de detalles, por ejemplo Reducción de ruido y Enfoque.

Nota: ejecutar el corrector puntual en primer lugar mejora su precisión y asegura que los contornos de las áreas corregidas coincidan con la ubicación del foco.

Evitar correcciones innecesarias

Esta sugerencia se refiere sobre todo a las correcciones locales. Cada regulador cambiado al aplicar correcciones locales o el filtro de degradado se aplica a toda esa corrección. Además, cada opción utiliza recursos y afecta al rendimiento.

Al aplicar degradados y correcciones locales, asegúrese de que las todas correcciones seleccionadas son necesarias.

Si no necesita que un trazado de pincel o un degradado realice una determinada clase de corrección, ajuste su regulador a cero.

Asimismo, evite correcciones globales superfluas, sobre todo las opciones que utilizan recursos como Reducción de ruido, Enfoque y Corrección de lente.

Algunos reguladores tienden a tener un valor predeterminado que los activa de manera automática. En el caso de las opciones que utilizan muchos recursos, el valor de cero desactiva el regulador.

Opciones de zoom

Si las opciones de zoom Ajustar y Relleno funcionan con lentitud, utilice las opciones 1:2, 1:3 o 1:4 en el panel Navegador.

Versión del proceso que utilizar

La versión del proceso 2012 necesita más recursos que la versión del proceso 2010, de modo que en algunos casos podría funcionar con más lentitud. Sin embargo, es conveniente equilibrar la ganancia de rendimiento con la calidad de imagen y edición disponibles con la versión del proceso 2012.

Incrementar la caché de Camera Raw

El incremento de la caché de Camera Raw en las preferencias de Lightroom puede mejorar el rendimiento del módulo Revelar si se trabaja varias veces en el mismo conjunto de imágenes.

Para restablecer la caché de Camera Raw:

  1. En Lightroom, seleccione Edición > Preferencias > Administración de archivos (Windows) o Lightroom > Preferencias > Administración de archivos (Mac OS).
  2. Incremente la caché de Camera Raw. Si no tiene claro el incremento que aplicar, comience aplicando de 2 a 3 GB, según la cantidad de espacio en el disco duro y el modo de utilizar Lightroom.
  3. Si lo desea, también puede cambiar la ubicación de la caché.

Eliminar la caché de previsualizaciones de Lightroom

Si bien es infrecuente, a veces pueden producirse uno o más de los problemas siguientes; de ser a así, quizá se debe eliminar el archivo de caché de previsualizaciones:

  • El disco duro se queda repentinamente sin espacio.
  • Se obtiene un error de caché en Lightroom.
  • Se obtienen defectos (líneas, puntos o áreas de color imprevistos) en las imágenes.

El archivo que contiene los datos de miniaturas y previsualizaciones se denomina [nombre_catálogo] Previews.lrdata, y se ubica en la misma carpeta que el catálogo.

Las miniaturas, las previsualizaciones pequeñas y las previsualizaciones 1:1 (tamaño completo) se guardan en el archivo Previews.lrdata. En las preferencias de Lightroom, es posible establecer cuándo se eliminan las previsualizaciones 1:1, que son las de mayor tamaño. Al eliminar las previsualizaciones 1:1, disminuye el tamaño del archivo Previews.lrdata. Si no elimina las previsualizaciones 1:1, el archivo de las previsualizaciones puede tener un tamaño muy grande. 

De forma predeterminada, las previsualizaciones 1:1 se eliminan en una semana. El tamaño del archivo de previsualizaciones se reduce al eliminar estas previsualizaciones grandes; sin embargo, el archivo propiamente dicho no se elimina a menos que se haga de forma manual. El archivo no adquiere un tamaño enorme a menos que las previsualizaciones 1:1 no se eliminen nunca o casi nunca; sin embargo, afecta a la unidad de disco duro según el espacio de que disponga. Para cambiar la frecuencia de eliminación de las previsualizaciones 1:1, seleccione Edición > Ajustes de catálogo > Administración de archivos (Windows) o Lightroom > Ajustes de catálogo > Administración de archivos  (Mac OS). 

Nota: el archivo Previews.lrdata explicado en esta nota técnica no debe confundirse con el archivo [nombre_catálogo] Smart Previews.lrdata, que contiene todas las previsualizaciones inteligentes. Cuando hay muy poco espacio en el disco duro, quizá haga falta eliminar este archivo; no obstante, si tiene tan poco espacio que obtiene errores de poco espacio disponible, trate de vaciar la papelera, archive varios archivos y reorganice los datos para obtener más espacio. 

Si elimina el archivo Previews.lrdata, las previsualizaciones vuelven a crearse para cada carpeta o colección que abre en Lightroom; por lo tanto, al trabajar por primera vez en una carpeta, puede que haya algo de retraso mientras se vuelven a crear las previsualizaciones.

Si la opción Descartar automáticamente previsualizaciones 1:1 se define en Después de 30 días o Nunca, el archivo de previsualizaciones puede tener un tamaño muy grande. Puede llegar a ocupar varios GB de espacio. Si de repente la unidad de disco duro está llena, compruebe el tamaño de este archivo. A continuación, puede eliminar el archivo. 

Puede obtener un mensaje de error en Lightroom que indica una problema con la caché; este es otro caso en el que podría tener que eliminar el archivo Previews.lrdata.

Si en las imágenes aparecen defectos, por ejemplo líneas o puntos de color, o áreas con un color inesperado, es posible que el archivo de previsualizaciones esté dañado. En este caso, la única solución es eliminar el archivo Previews.lrdata. 

Si se han incluido previsualizaciones de imágenes en el catálogo de imágenes archivadas, estas previsualizaciones también se perderán. 

Si el problema no se soluciona con la eliminación del archivo Previews.lrdata, intente depurar el archivo de caché de Camera Raw. 

  1. En Lightroom, elija Edición > Preferencias > Administración de archivos (Windows) o Lightroom > Preferencias > Administración de archivos (Mac OS).
  2. En Ajustes de caché de Camera Raw, haga clic en Depurar caché

Si lo desea, también puede cambiar la ubicación de esta caché haciendo clic en Elegir. Esta caché la utiliza únicamente el módulo Revelar. 

Reducir el número de ajustes preestablecidos

Incorporar ajustes preestablecidos en Lightroom puede disminuir el rendimiento porque el módulo Revelar genera miniaturas en el panel Navegador para cada ajuste preestablecido. Esto sucede claramente cuando hay 2000 o más ajustes preestablecidos. Reduzca la cantidad de ajustes preestablecidos cargados en Lightroom únicamente a los que use con más frecuencia para evitar esta clase de disminución del rendimiento.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea