Brukere av Ubuntu 10.x og 11.x Linux OS får av og til en blank eller svart skjerm når de spiller av beskyttet videoinnhold i Flash Player 11. (Dette problemet oppstår for eksempel med tjenester som Amazon Instant Video.) Det er en manglende Ubuntu HAL (Hardware Abstraction Layer)-modul, som ikke er installert som standard, som forårsaker dette problemet. Hvis forhandleren avslører feilmeldingen, ser brukerne DRM-feil 3323 eller 3322.

Krav for avspilling av beskyttet innhold

For Ubuntu 10.04 eller nyere: sørg for at Hardware Abstraction Layer-modulen installerer først, via apt-get.
(Hold nøye utkikk etter "hal"-installasjonsfeil. En skadet installasjonspakke kan fortsette å påvirke videoavspilling.)

sudo apt-get install hal

Når "libhal" (HAL)-biblioteket er installert, lukker du nettleseren og tømmer Adobe Access-katalogene ved å utføre følgende skallkommandoer:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Merk:

Flash Player fungerer selv om Hardware Abstraction Layer-modulen mangler. Men det kan ikke spille av innhold som krever Adobe Flash Access DRM (Digital Rights Management)-modulen.

Støtte for utvalgte 64-biters versjoner av Linux

Adobe publiserer platformstøtte for 32-biters og 64-biters Linux i systemkrav-delen av nettstedet til Flash Player 11. Distribusjonene som støttes for øyeblikket (32-biters og 64-biters) er Redhat Enterprise Linux 5.6 og nyere og Ubuntu 10.04 og nyere.

openSuse støttes også.

Installer riktig 32-biters eller 64-biters Flash Player-tillegg

Gå til http://www.adobe.com/go/flashplayer for å installere nyeste versjon av Flash Player for din plattform og arkitektur.

Hvis du ikke er sikker på hvilken Linux-versjon du skal installere, klikker du på Har du et annet operativsystem eller nettleser? for flere OS-valg.

openSuse og andre Linux-versjoner

Noen Linux-distributører har egne metoder for å administrere pakker, først og fremst openSUSE. openSUSE bruker RPM som lokalt pakkeformat. Men, det har sitt eget verktøy på høyt nivå for å administrere installasjon av systemprogramvare. 
.rpm-installasjoner i openSuse (32 biter og 64 biter) kan være litt "sære". Av og til gir de den generelle feilen "Message did not receive a reply (timeout by message bus)".

Hvis dette skjer, laster du ned arkivet .tar.gz i stedet for, og plasserer Flash Player (libflashplayer.so) her:

/usr/lib/adobe-flashplugin/libflashplayer.so

Test avspilling beskyttet videoinnhold med demospilleren

  1. Start demoversjonen av Adobe videoavspiller-beholderen: http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html

    Legg merke til Adobe Flash Player-versjonen nederst til venstre i demovideo-vinduet. Sørg for at versjonen er 11.2 eller høyere
  2. Spill av en prøve på beskyttet innhold.

    Tast inn følgende URL-adresse i feltet "Input the video URL: (case-sensitive)
    http://drmtest2.adobe.com:8080/Content/anonymous.f4v
  3. Klikk på [Play]-knappen nederst i videobeholderen.

Det beskyttede innholdet anonymous.f4v spilles av. (Denne videoen kalles "Getty train"-videoen.)

 

Dette gjelder følgende produkter

Adobe Flash Player 11, Flash Access (FAXS), Ubuntu 10.x & 11.x Linux

Dette produktet er lisensiert i henhold til Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Innlegg på Twitter™ og Facebook dekkes ikke av Creative Commons-vilkår.

Juridiske merknader   |   Regler for personvern på nettet