Learn how to create titles and motion graphics with the Graphics workspace in Premiere Pro.

The Graphics workspace and Essential Graphics panel in Premiere Pro provide a powerful workflow that allows you to create titles, brand identities, and other graphics directly within Premiere Pro.

You can also use the Essential Graphics panel to customize Motion Graphics templates (.mogrt files) that have been created in After Effects or Premiere Pro. For more information on Motion Graphics templates, see Using Motion Graphics templates in Premiere Pro

Essential Graphics Panel in Premiere Pro

Essential Graphics Panel in Premiere Pro
Watch this video to learn about how to use the Essential Graphics Panel in Premiere Pro (2 mins)

Create graphics in Premiere Pro

You can create graphics such as titles, lower thirds, and bumpers directly within Premiere Pro using the Graphics workspace. Graphics can be created directly in the Program monitor using the Type tool and shape tools, then refined with the features in the Essential Graphics panel.

To use the graphics workflow in Premiere Pro:

  1. Open the Graphics workspace. 

    Click Graphics in the workspace bar at the top of the screen or select Window > Workspaces > Graphics from the main menu. 

  2. You can also open the Essential Graphics panel directly from Window > Essential Graphics if you prefer to arrange your own workspace.

Adjust text and appearance
Adjust text and appearance
  • Graphic clips can contain multiple text and shape layers, similar to layers in Photoshop, and can be edited as a single clip in your sequence. When you first create a text or shape layer, a graphic clip containing that layer gets created in your timeline at the playhead location. If you already have a graphic clip selected in your sequence, then the text or shape layer you created gets added to the existing graphic clip.
  • Use the Edit tab of the Essential Graphics panel to see your layers and adjust your graphic, including adjusting the appearance of individual layers, changing layer order, and taking advantage of the Responsive Design features for time and position.
  • Add animation to your graphics by keyframing the layers in the Effect Controls panel. You can also toggle animation for each transform property using the Edit tab of the Essential Graphics panel.
  • Any graphics you create in Premiere Pro can be exported as a Motion Graphics template (.mogrt) to Creative Cloud libraries or your local disk for sharing or reuse. 
  • The Essential Graphics panel also allows you to browse Motion Graphics templates (.mogrt) saved locally or in your Creative Cloud Libraries and search Adobe Stock for Motion Graphics templates. For more information, see Using Motion Graphics templates in Premiere Pro.

Create text layers

Type tool in Premiere Pro

Type tool in Premiere Pro
Watch this video to learn about the type tool in Premiere Pro (2 mins)

  1. Select the Type tool (T) or Vertical Type tool from the tools panel. 

  2. Click the Program Monitor where you want to position your text, and start typing. A single click creates text on a point, while a click drag creates text in a box, which allows the text to wrap automatically within the border of the box. This behavior is the same as the Area text tool in the legacy Titler.

  3. Use the Selection tool (V) to manipulate text and shape layers directly in the Program Monitor. You can adjust the position of a layer, change the anchor point, change the scale, change the size of the text box, and rotate. 

  4. Adjust the appearance of your text using the Edit tab of the Essential Graphics panel, including font, font size, and other format and appearance controls.

    Type Tool
    Type Tool

Create shape layers

Premiere Pro has a Rectangle tool, an Ellipse tool, and a Pen tool for creating free-form shapes and paths.

  1. Click and hold on the Pen tool to expose the Rectangle and Shape tools. Then, select the desired shape tool from the tool bar and draw a shape. 

    Merk:

    Hold down the shift key while dragging to create a shape with locked dimensions such as a square or circle.

    Shape Tool
    Shape Tool
  2. Use the Selection tool (V) to directly manipulate your shape, including changes to position, scale, rotation, and anchor point. 

  3. The Pen tool (P) can be used to manipulate the vertices and handles of a shape.

  4. Adjust the appearance of shapes using the Edit tab of the Essential Graphics panel.

Create clip layers

You can add image and video sources as layers within your graphic. 

You can create clip layers using one of the following methods:

  • In the Edit pane of the Essential Graphics panel, select the New Item icon and choose From file.
  • In the application menu bar, select Graphics > New Layer > From file.
  • Select a graphic clip in your timeline, and drag the video or image master clip from your Project panel into the layer pane of the Essential Graphics panel

Align and distribute graphic layers

You can select multiple layers within a graphic clip and align or distribute them in the Essential Graphics Panel.

You can align layers by their top edges, vertical centers, bottom edges, left edges, horizontal centers, or right edges. 

You can distribute layers horizontally or vertically.

Options to align and distribute layers in the Essential Graphics panel
Options to align and distribute layers in the Essential Graphics panel

Merk:

When you have only one layer selected, using the align buttons aligns the shape or text layer to the video frame. When you have two or more layers selected, the buttons align the layers in relation to each other.

Distribute commands are disabled (greyed out) until three or more layers are selected.

Animate layers in your graphics

Text layers, shape layers, and paths can be animated using keyframes. You can add animation directly from within the Essential Graphics panel, or by using the Effect Controls panel.

Animating using the Essential Graphics panel

To add animation to your graphics using the Essential Graphics panel:

  1. Select the layer you want to animate in the Essential Graphics panel.

  2. Click the icon next to the property you want to animate (Position, Anchor Point, Scale, Rotation, or Opacity).

    This action toggles on animation for the property. The icon for the selected property turns blue to indicate that animation is active.

    Toggle animation for graphic layers
    Toggle animation for graphic layers

    Merk:

    Clicking the icon in Essential Graphics panel is the same as clicking on the Stopwatch in Effect Controls panel. If you toggle on animation in one location, it appears active in the other view too.

  3. Move your playhead and adjust this property in the Essential Graphics panel or directly in the Program Monitor to record the keyframes.

  4. Refine your animation using the Effect Controls panel or by adjusting the keyframes in your timeline using the Show Clip Keyframes option.

Animating using the Effects Control panel

To add animation to your graphics using the Effect Controls panel:

  1. Locate the layer you want to animate in the Effect Controls panel.

  2. Click the Stopwatch icon to toggle animation for the desired property.

  3. Click Add/Remove keyframes to achieve the effect you want. 

  4. Right click a keyframe to access interpolation settings such as Bezier curves and Ease In/Ease Out.

Edit and transform vector graphics

You can edit and transform vector graphics without rasterizing them using vector motion controls. This prevents pixelation and eliminates boundaries caused by undesired cropping.

You can edit vector graphics directly from within the Essential Graphics panel, or by using the Effect Controls panel.

  1. Double click in the Program Monitor to apply changes to the whole graphic using Vector Motion.

    Make sure you do not click on one graphic layer item in specific, otherwise you select the layer and not the whole graphic.

  2. You can apply changes to the whole graphic using Vector Motion in the Effect Controls Panel. You can also use Motion, but this will rasterize graphics and pixelate them when scaled.

  3. You can edit parameters for Position, Scale, Rotation and/or Anchor Points.

  4. Refine your animation using the Effect Controls panel or by adjusting the keyframes in your timeline using the Show Clip Keyframes option.

Add Responsive Design features to your graphics

Responsive Design for Motion Graphics makes it possible to design rolls and graphics that respond intelligently to changes in duration and layer positioning.

Responsive Design - Time

Create rolls

You can create title or credit rolls that move vertically over the screen by enabling Roll. When Roll is enabled, you see a transparent blue scroll bar in the Program Monitor.

This scroll bar allows you to scroll the text and graphics in your credit roll for easier editing, without having to move the playhead in the timeline to a specific position.

To enable rolls for your graphics:

Merk:

The length of the title clip in the sequence determines the speed of the roll. The more you increase the graphic clip length, the slower the movement.

  1. Select the graphic clip in your timeline and navigate to the Edit tab of the Essential Graphics panel.

    Enable Rolls
    Enable Rolls
  2. Make sure that the graphic you selected has none of its individual  layers selected.

  3. Select the check-box next to Roll to enable credit rolls.

  4. Specify whether you want the graphics to start or end offscreen.

  5. Adjust the timing for preroll, postroll, ease in, and ease out using the timecode for each property.

    Roll scroll bar
    Roll scroll bar

Preserve Intro and Outro Animations

You can define segments of your graphics that preserve intro and outro animations, even when the overall duration of the graphic changes. Keyframes that fall within these time ranges get pinned to the beginning and end of the clip. Because the keyframes are pinned, you can change the overall duration of the graphic clip, while maintaining its entrance and exit animations.

A transparent white overlay on your graphic clip in the timeline and in the Effect Controls panel indicate the intro and outro segments of the clip. These segments can be defined either in the Essential Graphics panel or in the Effect Controls panel. You can also use keyboard shortcuts to specify intro and outro duration.

Set Responsive Design - Time
Set Responsive Design - Time

Define intro and outro segments and preserve animations using the Essential Graphics panel

  1. Select the graphic in your timeline and navigate to the Edit tab of the Essential Graphics panel.

  2. Make sure that the graphic that you just selected has none of its individual layers selected.

  3. Under Intro duration, specify the amount of time that you want to define as the intro/entrance section using the timecode controls.       

  4. Under outro duration, specify the amount of time that you want to define as the outro/exit section using the timecode controls.

Define intro and outro segments and preserve animations using the Effect Controls panel

  1. Select the graphic in your timeline and navigate to the Effect Controls panel.

  2. At the top of the Effects Control panel is a small blue handle at the beginning and end of the selected clip.

  3. Drag the left handle out to define the intro/entrance segment. You see a transparent white overlay that covers all of the keyframes that fall within the specified time range.

  4. Drag the right handle out to define the outro/exit segment. You see a transparent white overlay that covers all of the keyframes that fall within the specified time range.

Specify intro and outro duration using keyboards shortcuts

You can set keyboard shortcuts for specifying Intro and Outro duration using the keyboard shortcut map under Premiere Pro CC > Keyboard Shortcuts. These keyboard shortcuts are not assigned by default. These commands are used to assign keyboard shortcuts:

  • Set Intro End
  • Set Outro Start

To use your keyboard shortcuts for Intro and Outro duration:

  1. Select the graphic clip in the timeline for which you want to preserve an intro or outro animation.

  2. Position the playhead to the position that you want to set the Intro or Outro setting and click the keyboard shortcut that was assigned.

    Merk:

    The keyboard shortcuts are enabled only when the timeline is selected.

Responsive Design - Position

You can design your graphics to automatically adapt to changes in the video frame aspect ratio, or to the position or scale properties of another graphic layer (such as when changing the number of characters in your title or lower third).

Small blue pins on the Program Monitor indicate whether the currently selected layer is pinned to another layer.

To define positional relationships between layers:

  1. Select the graphic clip in your timeline and navigate to the Edit tab of the Essential Graphics panel.

  2. Select a layer that you want to make responsive to the changes in another layer.

  3. Under Responsive Design – Position>Pin To, specify which layer the currently selected layer should be pinned to. The currently selected layer gets parented by the layer you choose from the drop-down list.

  4. Use the diagram on the right side to define which edge the child layer should be pinned to - Top, Bottom, Left or Right of the parent. 

    Merk:

    Use the square in the center to quickly toggle on or off pinning for all edges.

  5. The selected layer now responds in position, length/width, and scale based on changes to its parent layer. When you select this layer in the program monitor, its parent layer displays small blue pins on the pinned edges. 

    Set Responsive Design - Position
    Set Responsive Design - Position

Create Master Styles

Master Styles allow you to define text properties such as font, color, and size as presets. This feature enables you to apply the same style quickly across multiple layers in different graphics in your timeline.

Once you apply a Master Style to a graphic clip or to a text layer within a graphic clip, the text automatically inherits all changes to the Master Style, allowing you to change multiple graphics at once.

Update Layer to Master Styles
Update Layer to Master Styles

To create a Master Style:

  1. Select the graphic clip in your timeline and navigate to the Edit tab of the Essential Graphics panel.      

  2. Select a text layer and give it the stylistic properties that you want for font, size, and appearance.

  3. When you have the desired look, select Create Text Style under the Master Styles section from the drop-down list.

  4. Name your text style and click OK.

  5. The Master Style appears in your project panel and is available in the Master Style drop-down list. You can then apply this style to other text layers and graphic clips in your project.

    Applying Master Styles on Graphics
    Applying Master Styles on Graphics

When you create a Master Style, a thumbnail image of the style gets added to your project panel. Click drag this thumbnail onto one or more graphic objects in the timeline to update all the text layers in that graphics at once.

You can also update individual text layers of a title to a particular style by selecting the text layer in the Essential Graphics panel, then choosing the desired Master Style from the drop-down list.

Create Master Graphics

You can use the Upgrade to Master Graphic option to create a Master Clip item in your Project Panel from a graphic clip in your sequence. Any graphic clips made from that Master Graphic, including the one you upgraded it from, are duplicates of each other. Any changes made to the text, style, or contents in an instance of a Master Graphic get reflected in all other instances of the Master Graphic.

To create a Master Graphic, select Graphics > Upgrade to Master Graphic.

Export your graphic as a Motion Graphics template

Export your graphic clip, including all layers and animation, as a Motion Graphics template for future reuse or sharing. 

  1. Select Graphics>Export Motion Graphics template, or right-click the graphic clip in your sequence and select Export As Motion Graphics Template.

    Merk:

    This export feature is only available for graphics created in Premiere Pro, not for .mogrt files that were originally created in After Effects. 

    Export as Motion Graphics Template
    Export as Motion Graphics Template

TIP:

If you are creating a Motion Graphics template for your own future reuse, save your Motion Graphics template to the Local Templates folder. It is automatically available in the Browse tab of the Essential Graphics panel and you do not have to install it. 

Dette produktet er lisensiert i henhold til Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Innlegg på Twitter™ og Facebook dekkes ikke av Creative Commons-vilkår.

Juridiske merknader   |   Regler for personvern på nettet