Troubleshooting instructions for error code 191 when installing XD on Windows.

Error details

2 fatal error(s), 2 error(s), 0 warnings(s)

FATAL: Error (Code = 191) executing in command 'AddUWPAppxCommand' for package: 'UWPAssets', version:9.1.12.3
FATAL: Error occurred in install of package (Name: UWPAssets Version: 9.1.12.3). Error code: '191'
ERROR: hdhelper exe at C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop Common\HDBox\HDHelper.exe failed to install UWP app with xml
with error code 1
ERROR: Failed to install UWP Appx Package

Root cause

This error occurs either due to the lack of administrator privileges on your computer login account when installing XD, or if the machine environment does not meet the requirements to install a Universal Windows Platform (UWP) app.

Troubleshooting

Sequentially work through the following solutions and proceed to the next solution if necessary.

Solution 1- Change your user account as an administrator account

  1. Press Windows + keys on your keyboard.
  2. Type netplwiz and click OK.
  3. Click the Users tab.
  4. Select the account you want to change within Users for this computer.
  5. Click Properties.
  6. Select Administrator as user account type within the Group Membership tab.
  7. Click Apply and OK.
  8. Try to install XD.

Solution 2- Enable sideloading on Windows

Adobe XD is a UWP app which is not installed from Microsoft Store. Hence sideloading should be enabled on your machine. To enable sideloading:

  1. Click the Windows icon in the lower-left corner of the desktop and select Settings.
  2. In the Settings window, search for For developers settings window.
  3. Within For developers settings window, select Sideload Apps.
  4. Try to install XD.

Note:

If you are in an IT-managed environment, contact your IT team to enable sideloading on your machine.

Solution 3- Acquire developer license for Windows

  1. Refer to the following link to acquire a developer license for your Windows machine: http://go.microsoft.com/fwlink/?LinkId=233074.
  2. Try to install XD.

Note:

If you are in an IT-managed environment, contact your IT team to acquire developer license.

Solution 4- Unblock XD from Applocker

  1. AppLocker helps IT-managed organizations to control the apps and files which users run. Reach out to your IT support to check if they have placed any restrictions on UWP apps or Microsoft Store apps. You can also refer to https://docs.microsoft.com/en-us/windows/security/threat-protection/windows-defender-application-control/applocker/applocker-overview.
  2. Try to install XD.

Solution 5- Enable Windows firewall

  1. Enable Windows firewall if it is disabled. To enable Windows firewall, follow these instructions: https://support.microsoft.com/en-in/help/4028544/windows-10-turn-windows-defender-firewall-on-or-off.
  2. Try to install XD.

Solution 6- Reset Microsoft store

To fix issues related to Microsoft Store, follow these steps:

  1. Type cmd in Windows search to open the command prompt window.
  2. In the command prompt window, type wsreset.exe and press Enter.
  3. Wait for Microsoft Store to launch.
  4. Try to install XD from the Creative Cloud Desktop app.

Solution 7- Correct Windows registry keys

  1. Type regedit in Windows search.
  2. Navigate to HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Appx and change the value of AllowAllTrustedApps to 1.
  3. Try to install XD.

Solution 8- Uninstall higher or prerelease versions of XD

Check if there is a higher or prerelease version of XD already installed. If yes, uninstall it by following the steps below:

  1. Click the Windows icon in the lower-left corner of the desktop.
  2. Look for Adobe XD in the list of installed software.
  3. Right click XD and select uninstall.
  4. Try to install XD.

Solution 9- Correct the permissions on XD folders

1. Make sure that you have read and write access on the following folders:
  • C:\Windows\temp
  • C:\Program Files\ WindowsApp
  • C:\Users\<User Name>\AppData\Local\Temp
  • C:\Users\<User Name>\AppData\Local\Packages

2.  Try to install XD.

Solution 10- Reset or format Windows

  1. If none of the above mentioned steps works, format or reset Windows. For more information, refer to the link: https://support.microsoft.com/en-in/help/4026528/windows-reset-or-reinstall-windows-10.
  2. Try to install XD.

Note:

Back up your machine data before you perform reset.

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