Legal notices
Contents

About the Quick Start Tutorials ......................................................... 1
  Creating a purchase order form .................................................. 1
  Creating a purchase order form that has a flowable layout ............... 1
  Creating and using fragments in form designs ............................... 1

Creating a purchase order form .................................................... 2
  About creating a purchase order form ......................................... 2
  Starting the form design .................................................................. 3
  Starting the form design .................................................................. 3
  Adding a Print button ..................................................................... 4
  Adding a logo ................................................................................. 5
  Adding a logo ................................................................................. 5
  Adding the purchase order title ..................................................... 5
  Adding a text field for the P.O. Number ........................................ 6
  Adding a date field for P.O. Date ................................................... 7
  Previewing your work ....................................................................... 7
  Saving the form design ................................................................... 8
  Adding an address block .................................................................. 8
  Adding the purchase order details ................................................. 9
  Moving the purchase order table ................................................... 10
  Sizing the purchase order table .................................................... 11
  Entering labels in the header row .................................................. 11
  Specifying the Part No. and Description cells as text fields ........... 12
  Changing the cells to numeric fields ............................................. 12
  Naming the fields .......................................................................... 13
  Performing a calculation in the Amount column ........................... 13
  Performing a calculation in the Amount column ........................... 14
  Adding rows to the purchase order table ...................................... 15
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Renaming the contents of your form</td>
<td>15</td>
</tr>
<tr>
<td>Inserting the subtotal at the bottom of the table</td>
<td>16</td>
</tr>
<tr>
<td>Inserting the Tax fields</td>
<td>18</td>
</tr>
<tr>
<td>To insert the State Tax % field</td>
<td>19</td>
</tr>
<tr>
<td>To insert the State Tax field</td>
<td>19</td>
</tr>
<tr>
<td>To insert the Federal Tax % and Federal Tax fields</td>
<td>19</td>
</tr>
<tr>
<td>Inserting the Shipping Charge field</td>
<td>20</td>
</tr>
<tr>
<td>Inserting the Grand Total field</td>
<td>20</td>
</tr>
<tr>
<td>Adding the Terms and Conditions section</td>
<td>21</td>
</tr>
<tr>
<td>Adding the Authorized By Signature field object</td>
<td>21</td>
</tr>
<tr>
<td>What’s next</td>
<td>22</td>
</tr>
<tr>
<td>Creating a purchase order form that has a flowable layout</td>
<td>23</td>
</tr>
<tr>
<td>About creating a purchase order form that has a flowable layout</td>
<td>23</td>
</tr>
<tr>
<td>Opening the purchase order form</td>
<td>24</td>
</tr>
<tr>
<td>Enhancing the format of the form</td>
<td>24</td>
</tr>
<tr>
<td>Organizing the form</td>
<td>25</td>
</tr>
<tr>
<td>Formatting the footer</td>
<td>28</td>
</tr>
<tr>
<td>Setting the table to dynamically grow</td>
<td>28</td>
</tr>
<tr>
<td>Fixing the calculation for the Total field</td>
<td>29</td>
</tr>
<tr>
<td>Setting the fields to read-only</td>
<td>30</td>
</tr>
<tr>
<td>Connecting to a data source</td>
<td>30</td>
</tr>
<tr>
<td>Connecting to a data source in the form</td>
<td>31</td>
</tr>
<tr>
<td>Binding the data to fields and table cells</td>
<td>33</td>
</tr>
<tr>
<td>To bind the data to fields in the form</td>
<td>33</td>
</tr>
<tr>
<td>To bind the data to table cells in the form</td>
<td>34</td>
</tr>
<tr>
<td>Specifying a data file</td>
<td>35</td>
</tr>
<tr>
<td>Specifying a data file</td>
<td>36</td>
</tr>
<tr>
<td>(Optional) To test the Purchase Order form to ensure it that is flows the merged data properly</td>
<td>36</td>
</tr>
<tr>
<td>What’s next</td>
<td>38</td>
</tr>
<tr>
<td>Creating and using fragments in form designs</td>
<td>39</td>
</tr>
<tr>
<td>About Creating and using fragments in form designs</td>
<td>39</td>
</tr>
<tr>
<td>About the sample forms</td>
<td>39</td>
</tr>
<tr>
<td>Opening the sample fragment in the Fragment Library palette</td>
<td>40</td>
</tr>
<tr>
<td>Opening the sample fragment library in the Fragment Library palette</td>
<td>41</td>
</tr>
<tr>
<td>Creating a fragment</td>
<td>41</td>
</tr>
<tr>
<td>Editing a fragment</td>
<td>46</td>
</tr>
<tr>
<td>Editing a fragment</td>
<td>51</td>
</tr>
<tr>
<td>Using fragments that contain script</td>
<td>52</td>
</tr>
<tr>
<td>To test a sample script fragment</td>
<td>53</td>
</tr>
</tbody>
</table>
To view the script in the countryScript fragment ........................................... 54
To view the script in the countryScript fragment ........................................... 54
Using fragments when controlling the display of subforms .............................. 55
Using fragments when controlling the display of subforms .............................. 56
To view the FooterCanada and FooterUS fragments ....................................... 57
To view the choice section in the Purchase Order footer ................................. 57
What’s next ......................................................................................................... 58
About the Quick Start Tutorials

The Quick Start tutorials are designed to get you started with Designer.

NOTE: This document uses terms Adobe Experience Manager Forms, AEM Forms, AEM Forms on JEE, and LiveCycle interchangeably.

Creating a purchase order form

This tutorial takes you through the process of creating an interactive purchase order form that includes a Print Form button. When the person filling the form clicks this button, the form is printed. The person then returns the printed form to you. In addition to adding objects, you will learn how to add simple calculations. See Creating a purchase order form.

Creating a purchase order form that has a flowable layout

This tutorial takes you through the process of changing a form’s fixed layout to a flowable layout, sometimes called a dynamic layout. By using subforms, that the form displays all the orders that one of your clients requested. This tutorial also shows you how to merge a form with data. See Creating a purchase order form that has a flowable layout.

Creating and using fragments in form designs

This tutorial takes you through the process of creating and using fragments to simplify the process of creating collections of forms. See Creating and using fragments in form designs.
Creating a purchase order form

In this tutorial, you use Designer to create an interactive purchase order form that includes a Print Form button.

When the person filling the form clicks this button, the form is printed. The person then returns the printed form to you. In addition to basic concepts, you will learn how to add simple calculations. No matter what type of form you create later, you will find this tutorial a useful introduction.

About creating a purchase order form

During the course of a workday, you may deal with many different types of forms, such as order forms, invoices, paychecks, and time sheets:

- Forms you fill directly, either by hand or electronically.
- Forms you fill in conjunction with a server-based process that merges the form with data.
- Forms are a combination of both.

When you have completed this tutorial, the form you create will look like this purchase order.

Click to continue: Starting the form design
Starting the form design

The requirement for the purchase order form is that it be a single page in PDF. Users will fill the form electronically using Adobe® Reader®, print it using the Print button included on the form, and then manually return the form.

Designer offers several ways to get started quickly when creating a form design. For this tutorial, you will use the New Form Assistant to create the purchase order form design. The New Form Assistant simplifies the process of starting a form design by guiding you through the steps of how the form is distributed and how users return the filled form.

1) Select File > New.
   The New Form Assistant appears.
2) Click Next.
3) In the Page Size list, select Letter.
4) Click Finish.
   The new form design appears in the Layout Editor.

Click to continue: Adding a Print button

Starting the form design

You create a form design in the Designer workspace.

- To add a Print button, in the Object Library palette, click the Standard category and then drag the Print Button object onto the form in the upper right corner.

Click to continue: Adding a logo
Adding a Print button

Next, you will add a Print button to the purchase order.

- To add a Print button, in the Object Library palette, click the Standard category and then drag the PrintButton object onto the form design in the upper right corner.

Designer adds a Print Form button to the form design. When a user finishes filling the form, they click the Print Form button to print the form.

Click to continue: Adding a logo

Adding a logo

In this section, you will add a logo to the purchase order.

1) In the Object Library palette, click the Standard category and then drag the Image object onto the form design in the upper left corner.

2) Double-click the placeholder and locate an image file.

For example, if you installed the samples that come with Designer, locate the Designer install folder and open the following image file:

EN\Samples\Forms\Purchase Order\Images\Purchase Order.tif.

3) In the Object palette, select Use Original Size from the Sizing list.

Click to continue: Adding the purchase order title
Adding a logo

In this section, you will add a logo to the purchase order.

1) In the Object Library palette, click the Standard category and then drag the Image object onto the form design in the upper left corner.

   **NOTE:** If you are using Designer in ABAP Workbench or SAP NetWeaver Developer Studio, locate an image you can use as a logo.

2) In the Object palette, select Use Original Size from the Sizing list.

   Click to continue: Adding the purchase order title

Adding the purchase order title

In this section, you will add a title to the purchase order.

1) In the Object Library palette, click the Standard category and then drag the Text object below the logo.

2) Select the text in the Text object and type `Purchase Order`.

3) Select the text in the Text object and, in the Font palette, select 20 from the Size list, and Bold from the Style list.
**TIP:** You can set the default font for objects. For example, if you want to set the default font for all Text objects to Arial, insert a text object in your form, change the font to Arial, and then drag the Text object into the Standard category of the Object Library palette. In the Add Library Object dialog box, type **Text** and click OK. Designer asks you to confirm that you want to replace the existing Text object. Click Yes.

Click to continue: Adding a text field for the P.O. Number

---

**Adding a text field for the P.O. Number**

Next, you need to use a text field for the P.O. Number. In this form, it consists of 10 numbers.

1) In the Object Library palette, click the Standard category and then drag the Text Field object onto the form in the upper right corner.

2) Select the text in the Text Field object and type **P.O. Number**.

**TIP:** After the Text Field is selected, you can change the font, font size, and style of both the caption and the value. The caption (the field’s label) is beside the value (where the person filling the form enters the data). In the Font palette, use the palette menu to change the fonts for the caption and value.

Next, you must set the field length to 10 numbers.

3) In the Object palette, click the Field tab and select the Limit Length option. Type **10** in the Max Chars box.

Click to continue: Adding a date field for P.O. Date
Adding a date field for P.O. Date

You can use the Date Field object to make it easy for your users to pick a date. This calendar is what users see in the form when they click the drop-down list for P.O. Date when viewing the form in Adobe® Acrobat®.

1) In the Object Library palette, click the Standard category and then drag the Date Field object onto the form under the P.O. Number.

2) Select the text in the Date Field object and type P.O. Date.

Click to continue: Previewing your work

Previewing your work

As you work, you can preview your form design to see how it will look to the form filler. For example, here is how your form should look now.

1) Click the Preview PDF tab.

2) Click the Design View tab to continue editing the form design.
Saving the form design

It is a good idea to save your form now. You will save the form design as a PDF file so that people can fill it out electronically and then print it using the Print Form button.

1) Click File > Save As.
2) Select a location for the form design and type a name in the File Name box.
3) In the Save As Type list, select Adobe Static PDF Form (*.pdf).

Adding an address block

Designer includes some predefined custom objects that you can use to quickly create forms. For example, in this tutorial, we will use the Address Block custom library object to insert several fields at once.

1) In the Object Library palette, click the Custom category and then drag the Address Block field object onto the form under the Purchase Order title.
2) Rename the Name text field to Ordered By.
3) In the Object Library palette, click the Standard category and then drag the Text Field object onto the form under the Country field.
4) Name the Text Field object Phone Number.
5) Add another Text Field object for Fax Number.
6) Add another Text Field object onto the form under the fax number.
7) Name the Text Field object Contact Name.
8) To be able to insert a second address block beside this one, drag to select all the fields created in steps 1 to 7 and reduce the width of them by about half an inch using the sizing handle on the right side.

9) Copy and paste the selected fields next to the Ordered By address block.

10) Rename the second Ordered By field to Deliver To.

Your form should look like this now.

You can preview your form with the Preview PDF tab again.

**TIP:** To improve the appearance of the form, you can change the look of the sunken box fields. To do this, select the object, and then in the Object palette, click the Field tab and select Underlined from the Appearance list.

Click to continue: Adding the purchase order details

---

### Adding the purchase order details

Now, you need to add a table that will contain the part numbers, item descriptions, quantities, unit prices, and amounts of each item. Using tables helps you build this section quickly. The table will have five columns.

The Table Assistant is an easy way to create a new table if you are new to creating tables in Designer.

1) Select Table > Insert Table.

2) Select the Create Table Using Assistant option and click OK.

3) Under Body Has Fixed Dimensions, type 5 for the number of columns and 1 for the number of body rows, and then click Next.

4) Select the Has Header Row option and click Next.

5) Ensure the No Footer Row option is selected and click Next.

6) Select the Has Body Rows And No Sections option and click Next.

7) Clear the Alternating Row Colors option and click Finish.
Click to continue: Moving the purchase order table

Moving the purchase order table

Here is the table that you just inserted.

A. Cursor for moving the whole table
B. Header row
C. Body row

Now you need to position the table under the address blocks.

1) If the table is not selected, move the cursor to the upper left corner until you see the following cursor:

TIP: Another way to select the whole table is to select a cell, then select Table > Select, and then select Table, or you can click and drag to select.

2) Click to select the whole table.

3) Move the mouse to the upper left corner of the table until the move cursor + appears.

4) Drag the table to the new location.

Click to continue: Sizing the purchase order table
Sizing the purchase order table

You can size the table so that it spans the width of the page. By default, it is centered on the page.

1) Select the table.

2) Move the cursor to the middle handle on the right so that the move cursor appears (shown in the previous step).

3) Drag to make the table fill the width of the page.

   **TIP:** To make the width of all the columns the same, select Table > Distribute Columns Evenly.

Click to continue: Entering labels in the header row

Entering labels in the header row

1) Double-click the first cell in the table and type Part No.

2) Repeat step 1 for the remaining cells in the header row so that it looks like this.

   **TIP:** You can apply a color fill to this row to make it distinctive. To do this, select the row by moving the cursor to the left of the row until this cursor appears 🔄. Then, in the Border palette, select Solid from the Background Fill Style list. Finally, choose a color from the Color picker 🟢.

Your form should look like this now.

Click to continue: Specifying the Part No. and Description cells as text fields
Specifying the Part No. and Description cells as text fields

By default, the cells in tables are set as text objects. Now you must set the Description column cell as a text field. Text fields enable users to type, select, edit, cut, copy, paste, and delete any of the text inside the field. (Text objects present read-only text that end users cannot edit.)

1) Select the cell under Part No.
2) In the Object palette, click the Cell tab and in the Type list select Text Field.
3) From the Appearance list, select None.
4) Select the Allow Multiple Lines option.
5) Repeat steps 1 to 4 for the Description cell.

Click to continue: Changing the cells to numeric fields

Changing the cells to numeric fields

Now you must set Quantity, Unit Price, and Amount as numeric fields.

1) Select the first cell under Quantity.
2) In the Object palette, click the Cell tab and select Numeric Field in the Type list.
3) In the Cell tab, select None from the Appearance list.
4) Repeat steps 1 to 3 for Unit Price and Amount.
5) The Unit Price and Amount fields show currency. To format the data to show numbers as currency, drag to select the cells in the Unit Price and Amount columns. Then in the Object palette, click the Cell tab, click the Patterns button, and in the Pattern box, type \$z, zz9.99.
6) Click OK.
Naming the fields

To make your form more readable and usable, and to be able to perform calculations, it is a good idea to rename the fields. If you want to perform calculations, you will need to know the exact name of the field.

*NOTE: Designer is case-sensitive.*

1) Select the cell under Part No.
2) In the Object palette, click the Binding tab and type `partNo` in the Name box.
3) Repeat steps 1 and 2 for the remaining columns and name them as follows:
   - description
   - quantity
   - unitPrice
   - amount

Performing a calculation in the Amount column

The Amount column must show the number of items ordered multiplied by the unit price. You perform calculations in Designer using FormCalc or JavaScript™. We will use FormCalc for this calculation. FormCalc is a simple yet powerful calculation language modeled on common spreadsheet software. Its purpose is to facilitate fast and efficient form design without requiring a knowledge of traditional scripting techniques or languages. You use the Script Editor to enter calculations for the different objects on the form.

1) If the Script Editor is not already showing, select Window > Script Editor.
2) If you want, drag the Script Editor palette bar until the palette is larger.
3) Select the cell under Amount.
4) Select Calculate from the Show list.
5) Select FormCalc from the Language list and Client from the Run At list.
6) In the Script Source field, type the following calculation:
   
   ```
   quantity * unitPrice
   ```
7) Deselect the cell to add the script to your form.

8) To set this column as read-only, select the cell again, then in the Object palette, click the Value tab and select Calculated - Read Only from the Type list.

Click to continue: Adding rows to the purchase order table

**Performing a calculation in the Amount column**

The Amount column must show the number of items ordered multiplied by the unit price. You perform calculations in Designer using FormCalc or JavaScript. We will use FormCalc for this calculation. FormCalc is a simple yet powerful calculation language modeled on common spreadsheet software. Its purpose is to facilitate fast and efficient form design without requiring a knowledge of traditional scripting techniques or languages. You use the Script Editor to enter calculations for the different objects on the form.

1) If the Script Editor is not already showing, select Palette > Script Editor.

2) If you want, drag the Script Editor palette bar until the palette is larger.

3) Select the cell under Amount.

4) Select Calculate from the Show list.

5) Select FormCalc from the Language list and Client from the Run At list.

6) In the Script Source field, type the following calculation:

   `quantity * unitPrice`

7) Deselect the cell to add the script to your form.

8) To set this column as read-only, select the cell again, then in the Object palette, click the Value tab and select Calculated - Read Only from the Type list.

Click to continue: Adding rows to the purchase order table
Adding rows to the purchase order table

For this form, you need seven rows in which users can enter the items they want to purchase. A quick way to add several rows at once is to use the Copy Multiple command.

1) Drag to select the body row.
2) Select Edit > Copy Multiple.
3) In the Number of Copies box, type 6.
4) Select the Place Below option.
5) Ensure the Touching option is selected in the Vertical Spacing box.

Your form should look like this now:

![Image of the form with seven rows added]

Click to continue: Renaming the contents of your form

Renaming the contents of your form

It is a good idea to rename the objects in your form to organize it and identify the different areas of the form. To do this, the easiest way is to use the Hierarchy palette. The Hierarchy is a graphical representation of the contents of your form.

1) Select Window > Hierarchy.
2) Select the first object in the hierarchy, form1.
3) Press F2 or right-click and select Rename Object.
4) Type the new name, PurchaseOrderForm.
5) Rename *(untitled Subform) (page 1)* to **PurchaseOrder**.

You can rename the rest of the contents of your form, if you want, but it is not necessary to complete this tutorial.

**TIP:** You can also move objects around in the Hierarchy by selecting them and dragging them up or down.

Click to continue: Inserting the subtotal at the bottom of the table

---

**Renaming the contents of your form**

It is a good idea to rename the objects in your form to organize it and identify the different areas of the form. To do this, the easiest way is to use the Hierarchy palette. The Hierarchy is a graphical representation of the contents of your form.

1) Select Palette > Hierarchy.
2) Select the first object in the hierarchy, *form1*.
3) Press F2 or right-click and select Rename Object.
4) Type the new name, **PurchaseOrderForm**.
5) Rename *(untitled Subform) (page 1)* to **PurchaseOrder**.

You can rename the rest of the contents of your form, if you want, but it is not necessary to complete this tutorial.

**TIP:** You can also move objects around in the Hierarchy by selecting them and dragging them up or down.

Click to continue: Inserting the subtotal at the bottom of the table

---

**Inserting the subtotal at the bottom of the table**

To perform calculations, FormCalc needs to know what object to use in the calculation. In this step, we want to find out the total of all the data in the Amount column. If you select a cell in the Amount column, you can see the internal name in the Script Editor (if you resize the Script Editor to be larger).

What you see in the internal name relates to what you see in the hierarchy. “**PurchaseOrderForm**” is at the top, followed by “**PurchaseOrder**”, and so on.

All the rows in the table are named “**Row1**” followed by a default instance number. To be able to add the data in one column, all the rows have to be named the same.
Now, you will add the calculation for the subtotal at the bottom of the table.
1) In the Object Library palette, click the Standard category and then drag the Numeric Field object onto the form below the table under the Amount column.

2) Select the caption text in the Numeric Field object and type Total.

3) In the Object palette, click the Field tab and select Solid Box form the Appearance list.

4) In the Script Editor, select Calculate from the Show list.

5) Select FormCalc from the Language list and Client from the Run At list.

6) In the Script Source field, type the following calculation:
   \[ \text{sum(Table1.Row1[*].amount[*])} \]
   The wildcard character (*) tells Designer to collect all the data in the rows labeled Row1 and all the data in the Amount column.

7) Deselect the Numeric Field object to add the script to your form, then select it again.

8) In the Object palette, click the Binding tab and type total in the Name box.

9) Click the Field tab, click the Patterns button, and in the Pattern box, type $z,zz9.99.

10) Click OK.

11) Click the Value tab and in the Type list, select Calculated - Read Only.

Click to continue: Inserting the Tax fields

**Inserting the Tax fields**

The purchase order needs to calculate the appropriate state and federal taxes. To do this, you create a field that shows the tax rate and a calculated field that shows the tax amount.
To insert the State Tax % field

1) In the Object Library palette, click the Standard category and then drag the Numeric Field object onto the form below the Total field.
2) Select the caption text in the Numeric Field object and type State Tax %.
   You may want to resize the field to make it smaller.
3) In the Object palette, click the Field tab and select Solid Box in the Appearance list.
4) Click the Patterns button and in the Pattern box, type z9.99%.
5) Click the Binding tab and type stateTaxPercent in the Name box.
6) Click the Value tab and in the Default box, type 6.

To insert the State Tax field

1) Copy the State Tax % field and position the new field beside the State Tax % field.
2) Select the text and type State Tax.
3) In the Script Editor, select Calculate from the Show list.
4) Select FormCalc from the Language list and Client from the Run At list.
5) In the Script Source field, type the following calculation:
   \[(total * stateTaxPercent / 100)\]
6) Deselect the Numeric Field object to add the script to your form, then select it again.
7) In the Object palette, click the Binding tab and type stateTax in the Name box.
8) Click the Field tab, click the Patterns button and in the Pattern box, type $z,zz9.99.
9) Click the Value tab and in the Type list, select Calculated - Read Only.

To insert the Federal Tax % and Federal Tax fields

1) Repeat the procedure for inserting the State Tax % field.
2) Repeat the procedure for inserting the State Tax field.
3) Ensure the following changes to make the fields applicable for Federal Tax:
   - Change all instances of the word state to federal.
   - Set the default value for the federal tax percent to 8.
Set the calculation for federalTax to:

\[(total \times \text{federalTaxPercent} / 100)\]

Click to continue: Inserting the Shipping Charge field

**Inserting the Shipping Charge field**

By default, a shipping charge of $50.00 applies. However, this form lets users enter a different shipping charge if required.

1) In the Object Library palette, click the Standard category and then drag the Numeric Field object onto the form below the federal tax field.
2) Select the caption text in the Numeric Field object and type Shipping Charge.
3) In the Object palette, click the Binding tab and type shippingCharge in the Name box.
4) Click the Field tab and in the Appearance list, select Solid Box.
5) Click the Patterns button and in the Pattern box, type $z,zz9.99.
6) Click the Value tab and in the Default box, type 50.

Click to continue: Inserting the Grand Total field

**Inserting the Grand Total field**

You now need to add a Grand Total field that shows the total for the items, taxes, and shipping charges.

1) In the Object Library palette, click the Standard category and then drag the Numeric Field object onto the form below the Shipping Charge field.
2) Select the caption text in the Numeric Field object and type Grand Total.
3) In the Object palette, click the Binding tab and type grandTotal in the Name box.
4) Click the Field tab and in the Appearance list, select Solid Box.
5) Click the Patterns button and in the Pattern box, type $z,zz9.99.
6) Click the Value tab and in the Type list, select Calculated - Read Only.
7) In the Script Editor, select Calculate from the Show list.
8) In the Script Source field, type the following calculation:
\[
\text{sum (total, stateTax, federalTax, shippingCharge)}
\]
9) Deselect the Numeric Field object to add the script to your form.

Click to continue: Adding the Terms and Conditions section

**Adding the Terms and Conditions section**

Now you can add the terms and conditions explaining how the items will be paid for.

1) In the Object Library palette, click the Standard category and then drag the Text Field object onto the form under the table beside the calculations.
2) Name it Terms and Conditions.
   You may have to resize the field so that you can fit the caption. To do this, move the cursor over the left border of the field. Click and drag to resize.
3) In the Object palette, click the Field tab and select the Allow Multiple Lines option.
4) Select Solid Box from the Appearance list.
5) In the Layout palette, select Top from the Caption Position list.
6) Drag to resize the box and make it bigger.

Click to continue: Adding the Authorized By Signature field object

**Adding the Authorized By Signature field object**

If you want the person filling the form to use the Acrobat Signature feature to sign the document, you add a Signature Field object to the form design.
1) In the Object Library palette, click the Standard category and then drag the Signature Field object onto the form below the Terms and Conditions section.

2) Select the Signature Field object text and type Authorized By.

3) In the Object palette, select Underlined from the Appearance list.

4) Drag to resize the field and make it bigger.

Your form should look like this now.

Click to continue: What’s next

What’s next

This type of form is just one of many types that you can create using Designer.

RELATED LINKS:
  Creating a purchase order form that has a flowable layout
Creating a purchase order form that has a flowable layout

In this tutorial, you learn how to change a form’s fixed layout to a flowable layout by using subforms so that the form displays all the orders that one of your clients requested. You will also learn how to merge a form with data.

Start this tutorial with the form created in the Creating a purchase order form tutorial. You will rework the form to have a flowable layout. A flowable layout means that the form will adjust to accommodate data so that it displays all the orders that one of your clients requested.

The form design in this tutorial presents information from a data source. The resulting form is a non-interactive form that you can print or store electronically.

About creating a purchase order form that has a flowable layout

When you finish working through this tutorial, the form you create will look like this purchase order form merged with data.

To complete this tutorial, you need a schema and a data file. You can use those that come with Designer if you have installed the samples. The schema and data file are in the following location, by default:

- \EN\Samples\Forms\Purchase Order\Schema\Forms\Purchase Order.xsd
- \EN\Samples\Forms\Purchase Order\Schema\Data\Purchase Order.xml
Click to continue: Opening the purchase order form

**Opening the purchase order form**

To start, you will open the Purchase Order form that you saved in the previous tutorial.

1) Select File > Open.
2) Locate the form that you saved in the previous tutorial and click Open.
3) Select File > Save As and select Adobe Dynamic XML Form (*.pdf) from the Save As Type list.
4) Change the name of the file.
5) Click Save.

*TIP: If you plan to create more forms that have a flowable layout instead of forms that have a fixed layout, you can set the default file type for new forms to Dynamic PDF Form file in the Tools > Options dialog box (Document Handling tab).*

Click to continue: Enhancing the format of the form

**Enhancing the format of the form**

To enhance the format of the form for printing, you can make the field objects above the table an underline instead of a sunken box.
1) Select the P.O. Number field.
2) In the Object palette, click the Field tab and, in the Appearance list, select Underlined.
3) Repeat for the remaining field objects above the table.
   
   **TIP:** You can change selected objects of the same type all at once.

4) Select all the field objects above the table, except for the Print Button, Logo, and Purchase Order title.
5) In the Paragraph palette, click Align Bottom.
6) View the form in the Preview PDF tab.
7) Click the Design View tab to continue editing the form design.

Click to continue: Organizing the form

**Organizing the form**

To create a form that has a flowable layout, you must organize the sections into subforms to merge with data. Subforms are objects that act as containers for other objects, including fields, boilerplate
objects, and other subforms. They help to position objects relative to each other and provide structure in form designs that have a flexible layout.

1) In the Hierarchy palette, select all the items that appear above the table.

2) Select Insert > Wrap in Subform.

3) Select the (untitled Subform), right-click, and select Rename Object.

4) Type Header and press Enter.
5) To ensure that the Header subform has space above it, make sure that the Layout palette is displayed and, in the Height box under Size & Position, type 4.5 in.

6) Collapse all the items in the hierarchy.

7) Repeat steps 1 and 2 for all the items below the table (total to SignatureField1) and rename this new (untitled Subform) Footer.

8) To ensure that there is space before the Footer subform, make sure that the Layout palette is displayed and, in the Top box under Margins, type 0.25in.

   This is what you should see in the Hierarchy palette if you collapse everything under PurchaseOrder.

Click to continue: Formatting the footer
Formatting the footer

To enhance the format of the footer, you can make the fields below the table show an underline instead of a sunken box. You can also set the captions and values to be bottom-aligned and set just the values in the fields to be center-aligned.

1) Drag to select the fields in the footer, except for the Terms and Conditions and the Authorized By fields.

   TIP: If you try to drag to select the fields and you have the Move pointer, click anywhere along the edge of the form design to change the pointer to an arrowhead shape.

2) In the Object palette, click the Field tab and, in the Appearance list, select Underlined.
3) In the Paragraph palette, click Align Bottom.
4) In the Currently Editing palette, select Edit Value to change the paragraph alignment of just the value.
5) Click Align Center.

Click to continue: Setting the table to dynamically grow

Setting the table to dynamically grow

In a form that has a flowable layout, you may not know how much data the data source contains; therefore, you cannot specify how many rows the table should have. You have to set the table to be dynamic. To do this, you include only one body row that is set to repeat, depending on how much data there is in the data source.

1) Drag to select the rows that are below the first row.

2) Select Table > Delete > Row.
3) In the Hierarchy palette, select Table1.
4) Select Insert > Wrap in Subform.

This action creates a section in the form that contains the table. You need to separate this section from the remainder of the form to make it dynamically grow to fit the data.

5) With the (untitled Subform) selected in the Hierarchy palette, in the Object palette, click the Subform tab and, in the Content list, select Flowed.

6) Rename the (untitled Subform) to Table.

7) In the Hierarchy palette, select HeaderRow.

8) In the Object palette, click the Binding tab and select Repeat Row For Each Data Item.

Now you need to set the entire form to flow.

9) In the Hierarchy palette, select the PurchaseOrder subform.

10) In the Object palette, click the Subform tab and, in the Content list, select Flowed.

Setting the entire form to flow, formats each subform in the form, one after another, leaving no space between them.

Click to continue: Fixing the calculation for the Total field

**Fixing the calculation for the Total field**

Now that you have reorganized the contents of your form, the calculation for the total needs to reference the new Table subform.

1) Select the Total field.

2) Drag the Script Editor palette bar until the palette is the required size to show multiple lines.
3) In the Script Source field, revise the script to show the following calculation:

```
sum(Table.Table1.Row1[*].amount[*])
```

4) Deselect the Total field to add the script to your form design.

Click to continue: Setting the fields to read-only

**Setting the fields to read-only**

For a printable form, you do not want users to edit the fields; therefore, you must set the fields to read-only.

1) In the Hierarchy palette, open the Header subform and select all the text fields (such as PONumber, OrderedBy, OrderedByAddress).

2) In the Object palette, click the Value tab and, in the Type list, select Read Only.

3) In the Hierarchy palette, open the Table subform and select the text fields (partNo and description).

4) In the Object palette, click the Value tab and, in the Type list, select Read Only.

5) Repeat for quantity, unitPrice, and amount.

6) Repeat for the items in the Footer subform (except for the SignatureField).

Click to continue: Connecting to a data source

**Connecting to a data source**

To merge data with your form, you need to connect to a data source. After you connect, you need to bind the data to a field in your form design.

When you bind the fields in a form design to a data source, you create an association between the form design and the data source that allows you to capture, present, move, process, output, and print information associated with the form design.

1) Select File > New Data Connection.

2) Select XML Schema and click Next.

3) If you or your administrator installed the samples that come with Designer, locate the schema named Purchase Order.xsd and click Open.

   This file is located in \EN\Samples\Forms\Purchase Order\Schema\Schema.
4) Click Finish.

The data appears in the Data View palette.

The Data View palette displays a hierarchy view of each data source. The top node in the hierarchy represents the data connection and displays the name that you assigned when you created the connection.

Click to continue: Binding the data to fields and table cells

**Connecting to a data source**

To merge data with your form, you need to connect to a data source. After you connect, you need to bind the data to a field in your form design.
When you bind the fields in a form design to a data source, you create an association between the form design and the data source that allows you to capture, present, move, process, output, and print information associated with the form design.

1) Select Edit > New Data Connection.

2) Select XML Schema and click Next.

3) If you or your administrator installed the samples that come with Designer, locate the schema named Purchase Order.xsd and click Open.

   This file is located in \EN\Samples\Forms\Purchase Order\Schema\Schema.

4) Click Finish.

   The data appears in the Data View palette.

The Data View palette displays a hierarchy view of each data source. The top node in the hierarchy represents the data connection and displays the name that you assigned when you created the connection.
Click to continue: Binding the data to fields and table cells

**Binding the data to fields and table cells**

After you connect to a data source, you need to indicate where you want to see the data in the form design:

- To bind single fields, such as the P.O. Number and P.O. Date, you can use the drag and drop method.

- To bind repeating objects, such as the row in the purchase order table, to repeating items in the schema, use the Data Binding box in the Binding tab of the Object palette. After the row is bound, you can bind cells in the row to nodes in the schema, which makes these bindings relative to the row binding.

**To bind the data to fields in the form design**

1) In the Data View palette, select poNum and drag it to the P.O. Number field.

2) In the Binding Properties dialog box, select Don’t Update Any Related Properties, and then click OK.

Binding associates an existing form field with an item from the data source. In the image, the icon to the right of poNum shows that the node is bound. Because you chose not to update any related properties, Designer keeps the formatting you have already applied to the field object intact.
3) Repeat for the remaining items in the Data View palette (except for partNum, description, quantity, and unitPrice).

For example, companyName should be bound to the Ordered By field.

**To bind the data to table cells in the form**

1) In the Hierarchy palette, select Row1.
2) In the Object palette, click the Binding tab.
3) Click the triangle beside the Data Binding (Open, Save, Submit) box and select a binding. For example, select DataConnection > item > item.
The following string appears in the Data Binding (Open, Save, Submit) box:

\$item.item[\*].

**TIP:** You can type this string into the Data Binding (Open, Save, Submit) box instead of selecting it.

4) Open the Data View palette.

5) To ensure that the binding is set the way you prefer, bind each node to a cell by using the drag and drop method. For example, in the Data View palette, select partNum, and drag it to the cell under the heading Part No.

6) In the Binding Properties dialog box that appears, select Don’t Update Any Related Properties and click OK.

7) Repeat for the remaining items in the Data View palette under item (description, quantity, and unitPrice).

Click to continue: Specifying a data file

### Specifying a data file

The last task is to point to a data file to merge with the form.

1) Select File > Form Properties and click the Preview tab.

2) In the Preview area, browse for the location of the data file you want to use.

   For example, if you or your administrator installed the samples that come with Designer, locate the data file named Purchase Order.xml, which is located in `\EN\Samples\Forms\Purchase Order\Schema\Data`.

3) Click Open and then click OK.

4) View the form in the Preview PDF tab.
Specifying a data file

The last task is to point to a data file to merge with the form.

1) Select Edit > Form Properties and click the Preview tab.
2) In the Preview area, browse for the location of the data file you want to use.

   For example, if you or your administrator installed the samples that come with Designer, locate the data file named Purchase Order.xml, which is located in \EN\Samples\Forms\Purchase Order\Schema\Data.

3) Click Open and then click OK.
4) View the form in the Preview PDF tab.

Your form should now look like this illustration.

![Purchase Order form illustration](image)

**TIP:** The Purchase Order.xml data file that comes with Designer contains four records. You can modify this XML file so that you can test the layout of the form to verify that it adjusts to accommodate data by using a data file that contains more data.

(Optional) To test the Purchase Order form to ensure it that is flows the merged data properly:

1) Open the XML file and find the following lines:

   ```xml
   <item>
   <partNum>00300-896</partNum>
   <description>Address book</description>
   <quantity>2</quantity>
   ```
<item><unitPrice>15.00</unitPrice>
</item>

Below the previous lines, you can add more items. For example, you can add these lines:
<item><partNum>00300-300</partNum><description>Clipboard</description><quantity>3</quantity><unitPrice>5.00</unitPrice>
</item>
<item><partNum>00300-325</partNum><description>Paper Punch</description><quantity>1</quantity><unitPrice>8.00</unitPrice>
</item>
<item><partNum>00300-350</partNum><description>Ruler</description><quantity>5</quantity><unitPrice>1.00</unitPrice>
</item>
<item><partNum>00300-400</partNum><description>Scissors</description><quantity>2</quantity><unitPrice>2.00</unitPrice>
</item>
<item><partNum>00300-425</partNum><description>Tape</description><quantity>2</quantity><unitPrice>2.50</unitPrice>
</item>
<item><partNum>00300-450</partNum><description>Glue Stick</description><quantity>2</quantity><unitPrice>1.00</unitPrice>
</item>
<item><partNum>00300-475</partNum><description>Stapler</description><quantity>2</quantity><unitPrice>4.00</unitPrice>
</item>
<item><partNum>00300-500</partNum><description>Highlighters</description><quantity>1</quantity><unitPrice>5.00</unitPrice>
</item>
<item><partNum>00300-550</partNum>
<item>
<partNum>00300-575</partNum>
<description>Composition Notebook</description>
<quantity>5</quantity>
<unitPrice>8.00</unitPrice>
</item>

2) Save the revised data file with a new name.

3) In the Form Properties dialog box, click the Preview tab and find the revised data file.

4) Click OK and view the form in the Preview PDF tab again.

Click to continue: What’s next?

**What’s next?**

If you have worked through the tutorials, you know the basics of how to set up a form. You may now want to include the header row in the table on subsequent pages. You also may want to add page numbering.
Creating and using fragments in form designs

In this tutorial, you will learn about creating and using fragments to simplify the process of creating collections of forms.

Before you start, you may want to view a video tutorial that walks you through the steps of working with form fragments. See Form Fragments VideoTutorial.

About Creating and using fragments in form designs

You are tasked with creating a collection of forms. From experience, you know that the first form that you create normally involves some trial and error before you get it just right. However, after you create that first form, you begin to find areas where you can create shortcuts to speed up and improve the process so that the remaining forms you create go together much faster.

For example, you discover that the majority of the forms you are creating include a delivery address part. Instead of creating the delivery address subform in each new form, you copy the first delivery address subform you created and paste it into a separate XDP file. That way, you can easily copy the delivery address subform and paste it into the other forms that you create. When you have to change the delivery address part, either you make the change in every form, or you make the change in the separate XDP file and then replace the delivery address part in every form.

In Designer, these reusable parts are called fragments, and instead copying the part from a separate file each time you need to use the part, you can insert a reference to the required fragment and the fragment appears in the form. Then, when you update a fragment, all forms that reference the fragment reflect the changes.

All fragments are included in the form when it is saved as a PDF file.

About the sample forms

Designer includes a selection of complete sample forms. Each one includes a form design, sample data, and/or schema, and the final version of the form.

The sample forms that are installed in EN\Samples\Forms\Purchase Order\Form Fragments\Forms, under the Designer installation folder, illustrate simple and complex ways in which fragments may be used.

The ...\Form Fragments\Forms folder includes three form designs:

- Purchase Order Interactive.pdf
- Purchase Order Dynamic Interactive.pdf
- Purchase Order Dynamic.xdp
The fragments that are referenced in these sample form designs are installed in EN\Samples\Forms\Purchase Order\Form Fragments\Fragments.

You will use the form designs, fragments, and sample data in the Form Fragments folder for this tutorial. Therefore, it is recommended that you make a backup copy of this folder before you begin.

Click to continue: Opening the sample fragment in the Fragment Library palette

**Opening the sample fragment in the Fragment Library palette**

The Fragment Library palette contains fragment libraries. A *fragment library* corresponds to a folder in your file system that contains the fragment source XDP files.

The My Fragments library contains sample fragments that you can insert into a form design or use to create new fragments.

Next, you will open the fragment library for the sample forms for easy access to the fragments.

1) Select Window > Fragment Library to display the Fragment Library palette.
2) In the Fragment Library palette menu, select Open Fragment Library.
3) Select Fragments in EN\Samples\Forms\Purchase Order\Form Fragments\Fragments.
4) Click OK.

Click to continue: Creating a fragment
Opening the sample fragment library in the Fragment Library palette

The Fragment Library palette contains fragment libraries. A fragment library corresponds to a folder in your file system that contains the fragment source XDP files.

The My Fragments library contains sample fragments that you can insert into a form design or use to create new fragments.

Next, you will open the fragment library for the sample forms for easy access to the fragments.

1) Select Palettes > Fragment Library to display the Fragment Library palette.
2) In the Fragment Library palette menu, select Open Fragment Library.
3) Select Fragments in EN\Samples\Forms\Purchase Order\Form Fragments.
4) Click OK.

Creating a fragment

In this section, you will learn how to create a fragment.

You can create a fragment in a separate file or in the current form design.

1) Open the Purchase Order Interactive.pdf sample form located in \EN\Samples\Forms\Purchase Order\Form Fragments\Forms.
2) At the top of the form, select the P.O. Number and P.O. Date Text Field objects.
3) Select Edit > Fragments > Create Fragment.

4) In the Name box, type POInfo as the name for the fragment.

5) Type Purchase Order Number and Date as the description of the fragment.

6) To define the fragment in a separate XDP file that is stored in the Fragment Library, select Create New Fragment In Fragment Library.

7) In the Fragment Library list, select Open Fragment Library, and then navigate to and select the Fragments folder in EN\Samples\Forms\Purchase Order\Form Fragments\Fragments.

8) In File Name, leave the file name as POInfo.xdp.

9) Leave the Replace Selection With Reference To New Form Fragment option selected so that the P.O. Number and P.O. Date Text Field objects in the form design will be replaced with the new form fragment.

10) Click OK.

11) Save the form design as My PO Interactive.PDF.

Notice that the look of the P.O. Number and P.O. Date objects has changed. The change is because a reference to the newly created PO Info fragment has replaced the objects.
A fragment icon appears in the upper-left corner of a fragment reference and uses the color of the object boundary borders. The objects within a fragment reference have gray borders to indicate that you cannot edit them from the fragment reference.

Clicking anywhere within a fragment reference selects it, and dragging anywhere on a fragment reference moves it. You cannot select any of the objects in a fragment reference.

Similarly, the objects in a fragment reference are not available in the Hierarchy palette because you cannot select or edit them in a fragment reference.
A. Fragment reference icon on a subform

B. The objects in a fragment are not available

You can move a fragment reference and its contents in the Hierarchy palette in the same way that you move other form objects. However, you cannot drag objects into a fragment reference.

Click to continue: Editing a fragment

**Creating a fragment**

In this section, you will learn how to create a fragment.

You can create a fragment in a separate file or in the current form design.

1) Open the Purchase Order Interactive.pdf sample form located in \EN\Samples\Forms\Purchase Order\Form Fragments\Forms.

2) At the top of the form, select the P.O. Number and P.O. Date Text Field objects.

3) Select Edit > Fragments > Create Fragment.
4) In the Name box, type **PO Info** as the name for the fragment.

5) Type **Purchase Order Number and Date** as the description of the fragment.

6) To define the fragment in a separate XDP file that is stored in the repository, select Create New Fragment In Repository.

7) To define the fragment in the current document, select Create New Fragment In Current Document.

8) To define the fragment in a separate XDP file that is stored in the Fragment Library, select Create New Fragment In Fragment Library.

9) To define the fragment in the current document, select Create New Fragment In Current Document.

10) In the Fragment list, select Open Fragment Library, and then navigate to and select the Fragments folder in EN\Samples\Forms\Purchase Order\Form Fragments\Fragments.

11) Leave the Replace Selection With Reference To New Form Fragment option selected so that the P.O. Number and P.O. Date Text Field objects in the form design will be replaced with the new form fragment.

12) Click OK.

13) Save the form design.

14) Save the form design as **My PO Interactive.PDF**.

Notice that the look of the P.O. Number and P.O. Date objects has changed. The change is because a reference to the newly created PO Info fragment has replaced the objects.
A fragment icon appears in the upper-left corner of a fragment reference and uses the color of the object boundary borders. The objects within a fragment reference have gray borders to indicate that you cannot edit them from the fragment reference.

Clicking anywhere within a fragment reference selects it, and dragging anywhere on a fragment reference moves it. You cannot select any of the objects in a fragment reference.

Similarly, the objects in a fragment reference are not available in the Hierarchy palette because you cannot select or edit them in a fragment reference.
A.

Fragment reference icon on a subform

B.

The objects in a fragment are not available

You can move a fragment reference and its contents in the Hierarchy palette in the same way that you move other form objects. However, you cannot drag objects into a fragment reference.

Click to continue: Editing a fragment

**Editing a fragment**

One of the main advantages of fragments is that you can add them to many forms, but when you need to make a change, you only need to make it in one place. In this section, we will edit the POInfo fragment.

First, you will add the fragment to the Purchase Order Dynamic Interactive.pdf form so that you can see the effect on more than one form design when you edit the PO Info fragment.

1) Open Purchase Order Dynamic Interactive.pdf.
2) Select and delete the P.O. Number and P.O. Date objects.
3) In the Fragment Library palette, drag the POInfo fragment onto the form design.
4) Save the form design as **My PO Dynamic Interactive.PDF**.
5) Right-click the POInfo fragment reference and select Fragments > Edit Fragment. The POInfo fragment source file opens and you can now edit the fragment.
6) Replace P.O. Number with P.O. No and then save the fragment.
7) Open the My PO Interactive.pdf and My PO Dynamic Interactive.PDF sample forms. The fragment reference in both forms is updated.

You have just learned how to create and modify a fragment. In addition, you can convert a fragment reference to an embedded object or create an override on a fragment reference that only affects the fragment reference in the current form.

Next, we will take a closer look at the sample forms and review some interesting things that you can do with fragments.
Editing a fragment

One of the main advantages of fragments is that you can add them to many forms, but when you need to make a change, you only need to make it in one place. In this section, we will edit the PO Info fragment.

First, you will add the fragment to the Purchase Order Dynamic Interactive.pdf form so that you can see the effect on more than one form design when you edit the PO Info fragment.

1) Open Purchase Order Dynamic Interactive.pdf.
2) Select and delete the P.O. Number and P.O. Date objects.
3) In the Fragment Library palette, drag the PO Info fragment onto the form design.
4) In the Fragment Library palette, drag the PO Info fragment onto the form design.
5) Save the form design as My PO Dynamic Interactive.PDF.
6) Save the form design.
7) Right-click the PO Info fragment reference and select Fragments > Edit Fragment. The PO Info fragment source file opens in Workbench and you can now edit the fragment.
8) Replace P.O. Number with P.O. No.
9) Open the My PO Interactive.pdf and My PO Dynamic Interactive.PDF sample forms. The fragment reference in both forms is updated.

You have just learned how to create and modify a fragment. In addition, you can convert a fragment reference to an embedded object or create an override on a fragment reference that only affects the fragment reference in the current form.

Next, we will take a closer look at the sample forms and review some interesting things that you can do with fragments.

Click to continue: Using fragments that contain script
Using fragments that contain script

Fragments can contain reusable JavaScript functions or values that are stored separately from any particular script object. You use these fragments to create custom functions and properties that you want to use in many locations on a form or that you want to use in many forms.

For example, the countryScript sample fragment controls the interaction between the Country and State/Province drop-down lists in the sample forms. The options that appear in the State/Province drop-down list depend on the country selected in the Country drop-down list.

To test a sample script fragment

1) Open the My PO Interactive.pdf sample form and click the Preview PDF tab in the Layout Editor.

2) Under the Ordered By section in the form, select Canada from the Country drop-down list and then click the State/Province drop-down list. The list displays provinces to select from.

3) Next, select United States from the Country drop-down list and then click the State/Province drop-down list. The list displays states to select from.

Next, we will take a closer look at the countryScript fragment in the sample forms.
To view the script in the countryScript fragment

1) In the Fragment Library palette, right-click countryScript and select Edit Fragment.

   Notice that the fragment is a child of Variables in the Hierarchy palette. Fragments cannot
   contain scripts that are associated with other form objects, such as event scripts like validate,
   calculate, or initialize.

2) Select the countryScript script object in the Hierarchy palette.

3) Expand the Script Editor to view the script.

   The countryScript fragment is referenced by the drpDeliverToCountry and drpDeliverTo-
   StatePrv Drop-down list objects in the OrderedByAddress and DeliverToAddress fragments in
   the sample forms.

4) In the Fragment Library palette, right-click DeliverToAddress and select Edit Fragment.

5) Select the drpDeliverToCountry Drop-down list object in the Hierarchy palette and view the
   script in the Script Editor. Notice how the countryScript fragment is referenced in the Script
   Editor.

Click to continue: Using fragments when controlling the display of subforms

To view the script in the countryScript fragment

1) In the Fragment Library palette, right-click countryScript and select Edit Fragment.

2) Open the countryScript.xdp file.

3) In the Fragment Library palette, right-click countryScript and select Edit Fragment.

   Notice that the fragment is a child of Variables in the Hierarchy palette. Fragments cannot
   contain scripts that are associated with other form objects, such as event scripts like validate,
   calculate, or initialize.
4) Select the countryScript script object in the Hierarchy palette.

5) Expand the Script Editor to view the script.

The countryScript fragment is referenced by the drpDeliverToCountry and drpDeliverToStatePrv Drop-down list objects in the OrderedByAddress and DeliverToAddress fragments in the sample forms.

6) In the Fragment Library palette, right-click DeliverToAddress and select Edit Fragment.

7) Open the DeliverToAddress.xdp file.

8) In the Fragment Library palette, right-click DeliverToAddress and select Edit Fragment.

9) Select the drpDeliverToCountry Drop-down list object in the Hierarchy palette and view the script in the Script Editor. Notice how the countryScript fragment is referenced in the Script Editor.

Click to continue: Using fragments when controlling the display of subforms

Using fragments when controlling the display of subforms

The Purchase Order Dynamic.xdp sample form uses fragments to configure the footer to display the correct address, depending on the data being merged with the form. When the sample form is merged with the Purchase Order Canada.xml file, the FooterCanada fragment is instantiated; however, when the form is merged with the Purchase Order US.xml file, the FooterUS is instantiated.

1) Open Purchase Order Dynamic.xdp and click File > Form Properties > Preview.

2) In the Data File field, click the Browse button and select the Purchase Order US.xml data file located in EN\Samples\Forms\Purchase Order\Form Fragments\Data.
3) Click Open and then click OK.
4) Click the Preview PDF tab in the Layout Editor. Notice that the corporate address in the footer shows an American address.

5) Click File > Form Properties > Preview.
6) In the Data File field, click the Browse button and select the Purchase Order Canada.xml data file located in EN\Samples\Forms\Purchase Order\Form Fragments\Data.
7) Click Open and then click OK.
8) Click the Preview PDF tab in the Layout Editor. Notice that the corporate address in the footer now shows a Canadian address.

Next, we will view how this choice section was created.

**Using fragments when controlling the display of subforms**

The Purchase Order Dynamic.xdp sample form uses fragments to configure the footer to display the correct address, depending on the data being merged with the form. When the sample form is merged with the Purchase Order Canada.xml file, the FooterCanada fragment is instantiated; however, when the form is merged with the Purchase Order US.xml file, the FooterUS is instantiated.

1) Open Purchase Order Dynamic.xdp and click Edit > Form Properties > Preview.
2) In the Data File field, click the Browse button and select the Purchase Order US.xml data file located in EN\Samples\Forms\Purchase Order\Form Fragments\Data.
3) Click Open and then click OK.
4) Click the Preview PDF tab in the Layout Editor. Notice that the corporate address in the footer shows an American address.

5) Click Edit > Form Properties > Preview.
6) In the Data File field, click the Browse button and select the Purchase Order Canada.xml data file located in EN\Samples\Forms\Purchase Order\Form Fragments\Data.
7) Click Open and then click OK.
8) Click the Preview PDF tab in the Layout Editor. Notice that the corporate address in the footer now shows a Canadian address.

Click to continue: What’s next

To view the FooterCanada and FooterUS fragments

1) Right-click the FooterCanada fragment in the Hierarchy palette.

2) Select the Fragments > Edit Fragment option. You can see that the fragment consists of two Static Text objects, one displaying the Canadian address.

3) Repeat the same procedure to view the FooterUS fragment.

To view the choice section in the Purchase Order footer

1) In the Purchase Order Dynamic.xdp sample form, click the Master Pages tab in the Layout Editor.

2) Scroll to the bottom of the page where the footer is located. Notice that both the FooterCanada and FooterUS fragment references are placed one on top of the other in the subform set. However, depending on the data, only one footer appears when the form is rendered. Also,
because the size was adjusted to fit the bottom of the page, a small icon appears to notify you that there are property overrides on the fragment references.

3) In the Hierarchy palette, select the subform set and, in the Subform Set tab of the Object palette, click Edit Alternatives. The Edit Data Nominated Subforms shows the binding, language, and expression for the alternative footer fragments.

4) Open the Purchase Order US.xml and Purchase Order Canada.xml files using a text editor. Notice that the value for <americas> </americas> is **US** in Purchase Order US.xml and **Canada** in Purchase Order Canada.xml. It is this value that determines which fragment is instantiated when the data is merged in the form.

Click to continue: What’s next

**What’s next**

You have just seen the various ways in which fragments can simplify and speed up the creation and maintenance of a collection of forms.

For additional information about fragments, see Using Designer.