Adobe RoboHelp (2019 release) Help
Legal notices

# Contents

**Chapter 1: Introduction to RoboHelp**  
What is Adobe RoboHelp (2019 release) .................................................. 1  
RoboHelp (2019 release) FAQs .................................................................. 5  
RoboHelp system requirements .................................................................. 14  
Get to know the RoboHelp workspace ....................................................... 17  
Adobe RoboHelp manual (PDF) ................................................................. 21  
RoboHelp keyboard shortcuts ................................................................... 21

**Chapter 2: Projects**  
Plan your RoboHelp project ................................................................. 24  
Create a project ...................................................................................... 26  
Import Word documents into a project .................................................... 32  
Work with topics and folders ................................................................. 35  
Work with context-sensitive help ............................................................ 40  
Generate reports ..................................................................................... 43

**Chapter 3: Editing and formatting**  
Format your content ............................................................................ 48  
Work with images and multimedia .......................................................... 54  
Create and manage links ....................................................................... 58  
Create and use variables for easy updates .......................................... 61  
Single-source with snippets .................................................................. 62  
Use Find and Replace ............................................................................ 63

**Chapter 4: TOCs, indexes, and glossaries**  
Create and manage a Table of Contents ............................................ 65  
Create and manage an index ................................................................. 69  
Create and manage a glossary ............................................................... 73  
Create and manage browse sequences ............................................. 75

**Chapter 5: Conditional content**  
What is conditional content ................................................................. 79  
Create and apply condition tags .......................................................... 81  
Configure output presets for conditional content .................................. 89  
Optimize and manage conditional content ........................................ 94

**Chapter 6: Skins and master pages**  
Work with skins .................................................................................. 96  
Work with master pages ...................................................................... 99  
Work with labels ............................................................................... 104

**Chapter 7: Generating output**  
Generate output .................................................................................. 106  
Generate Responsive HTMLS output ...................................................... 109

Last updated 2/20/2019
Generate PDF output .......................................................... 112
Generate Microsoft HTML Help output .................................. 115
Generate WebHelp output .................................................. 117
Generate Mobile App output ................................................. 120
Generate eBook output ...................................................... 123
Generate iOS app using RoboHelp (2019 release) .................... 126
Generate Android app ....................................................... 129

Chapter 8: Publish output
Import FrameMaker documents into a project ....................... 131
Publish to a RoboHelp Server .......................................... 135
Publish to an FTP server, a Secure FTP server, or a File System 137

Chapter 9: Collaborate with authors
Collaborate using Git .................................................... 140
Collaborate using SharePoint Online .................................. 142
Collaborate using Team Foundation Server .......................... 143
Chapter 1: Introduction to RoboHelp

What is Adobe RoboHelp (2019 release)

Adobe RoboHelp (2019 release) is a powerful and intuitive application for creating and publishing content. Easily and efficiently develop Help systems, e-learning content, policies, procedures, and knowledge bases with RoboHelp. You can deliver personalized experiences for different audiences and on a wide range of devices - with minimal effort by using out-of-the-box capabilities. Sophisticated content editing, layout creation, formatting, and search capabilities in RoboHelp help you create and deliver impactful, easy-to-manage content experiences.

RoboHelp provides modern, responsive HTML5, and device-friendly output presets for creating fluid and personalized content; your output looks stunning and is easy to consume. Use condition tags and expressions to create interactive and filtered content in several formats and for different screens. You can cater to a wider or more targeted audience.

Get started with RoboHelp (2019 release)


Feature summary

Responsive HTML5 and CSS3 authoring support
Create highly immersive content experiences using text and multimedia with the out-of-the-box HTML5 and CSS3 authoring support. Easily add videos from YouTube and Vimeo, audio, images, text effects, symbols, and other elements and make your content engaging. The powerful preview capability helps you experience the impact of the content while authoring. For step-by-step Help, see Format your content and Work with images and multimedia.

Enrich your content with SVG support
Make your content look super-sharp across mobile, web, and print by using SVGs. You can import and use multiple visuals in SVG files to make your end users experience a smooth output.

Intelligent content reuse
Save time and effort by efficiently using variables and snippets for content reuse across topics in your project. Any update to a variable or snippet is reflected everywhere you have used that variable or snippet. You can even add a snippet within an existing snippet by drag-and-drop. For step-by-step Help, see Create and use variables for easy updates and Single-source with snippets.

Conditional content definition and publishing
Easily create rules and apply them to a topic, paragraph, or word using condition tags. With condition tags, you can control the content for the different Help systems you want to generate from the same project. You can also specify the foreground and background colors of conditions and manage them easily. For step-by-step Help, see the following:

What is conditional content
2 Create and apply condition tags
3 Configure output presets for conditional content
4 Optimize and manage conditional content

Cleaner project structure
RoboHelp maintains all your project contents in a clean and organized structure. Whether it is in the RoboHelp workspace or in the Explorer view of your computer, you find the project assets such as style sheets, skins, and snippets, are all organized in separate folders. For more information, see Get to know the RoboHelp workspace and Create a project.

Switch between multiple views
Switch between author, code, and preview views at ease when you use the icons in the upper-right corner of the screen. This way, you can quickly see a preview of your content output or its HTML. For more information, see Get to know the RoboHelp workspace.

Intuitive interface for configuring object properties
While authoring your content, adjust the properties of the various objects you add with optimal accuracy and unprecedented ease. You can watch them transform in real time with every change. When you select the object you have added, the Properties panel on the right displays all the properties of the selected object. Tweak a value and see the change instantly. For more information, see Get to know the RoboHelp workspace and Format your content.

Powerful skin editor
Customize skins to give a unique appearance to your output. With the powerful skin editor of RoboHelp, you can create modern interfaces that are more engaging and user friendly. For step-by-step Help, see Work with skins.
Optimized search engine
Deliver best-in-class search results to end users with a search engine powered by a smart algorithm and highlighting of the searched word. Each output preset comes with configurable search settings. For more information about the search settings of a type of output preset, navigate to the relevant article from Generate output.

Multiformat publishing
Use Quick Generate to instantly publish content to a wide range of output formats - Responsive HTML5, Microsoft HTML Help (CHM), WebHelp, Mobile App, and more.

Easily generate content-centric mobile apps for iOS and Android with one click, with a PhoneGap Build license. For more information, start with Generate output.

Next-generation Responsive HTML5 layouts
Deliver personalized content experiences with new Responsive HTML5 layouts that provide intuitive navigation and best-in-class search. You can easily show or hide widgets such as glossary and TOC. For step-by-step, see Generate Responsive HTML5 output.

Greater content accessibility
Deliver content to accommodate the special needs of your end users. Use 508-compliant HTML5 layouts to create content that is accessible to all users, on multiple platforms, such as web, mobile, and print.

Optimized HTML5 output
Experience as much as a 50% reduction in loading time compared to the previous RoboHelp version and a file size savings of about 20 KB per topic. You can also experience smoother transitions between pages with faster and more responsive HTML5 output. For step-by-step Help, see Generate Responsive HTML5 output.

Dynamic content filters
Deliver more relevant and highly personalized content experiences with dynamic content filters. Use condition tags and expressions to enable end users to filter content easily. For step-by-step Help, see Configure output presets for conditional content.

Ability to add thumbnails
You can publish images as thumbnails that expand on clicking. This makes content viewing on mobile devices easier for end users.

Single-click mobile app generation
Easily generate content-centric mobile apps for iOS and Android with one click, with a PhoneGap Build license. For step-by-step Help, see Generate Mobile App output.

Favorites in Responsive HTML5 output
In Responsive HTML5 output, provide end users the option to mark topics as favorites. This saves them time and effort to locate their frequently used content. For step-by-step Help, see Generate Responsive HTML5 output.

Git support
Empower your team members with the ability to collaborate on projects of any size with speed and efficiency using Git support.
SharePoint Online support
Ensure everyone stays on the same page by enabling sharing and collaboration across your organization with SharePoint Online.

Get Adobe RoboHelp (2019 release)
Visit the Adobe RoboHelp product page to license RoboHelp.

To know the product better before you license it, you can install a 30-day free trial from the product page and even request a demo.

If you are an existing user of an earlier version of RoboHelp, you can easily upgrade to Adobe RoboHelp (2018 release). Visit Adobe RoboHelp (2019 release) to know more.

See RoboHelp system requirements to check if your computer supports Adobe RoboHelp (2018 release).

Basic workflow

Create a project
A project is like a container for all your content and the various components, such as Table of Contents, snippets, skins, and more, for building the right output. To know more, see Create a project.

Author the content
In the powerful editor of RoboHelp, you can author your content with all the elements you need, to make your output engaging. Create topics for authoring and add text, images, and multimedia, format the content with text effects, tables, lists, and more. You can preview the content in your desired layout while you are authoring. To know about how to work with a topic, see Work with topics and folders.

Import content
You can import content from other sources such as Microsoft Word files (.docx) into your project. For step-by-step Help, see Import Word documents into a project.

Build the navigation
You can link text and images to other content and decide the content hierarchy or organization scheme in your Help system. Create links among different sets of content (topics) and to content that is external to your Help system (such as YouTube videos). For step-by-step Help, see Create and manage a Table of Contents and Create and manage a Table of Contents.
Configure the output

You can select a type of output preset (for example, Responsive HTML5 and PDF) in RoboHelp and configure the settings to customize the appearance and capabilities of your output. You can also implement conditional content to show or hide content depending on the end user interest, skill level, and other factors. For more information, see Generate output and What is conditional content.

Generate the output

Generate or publish the output for multiple platforms, such as web, mobile, and print. You can choose from a variety of output presets, such as Responsive HTML5, PDF, Microsoft HTML Help (CHM), WebHelp, Mobile App, and more. For step-by-step Help, see Generate output.

To download and start using RoboHelp (2019 release), see Get started with RoboHelp (2019 release).

RoboHelp (2019 release) FAQs

Basic FAQs

• **What is Adobe RoboHelp (2019 release)?**
  
  Adobe RoboHelp (2019 release) allows you create, design, and deliver Help, policy, and knowledgebase content. You can work faster with a reimagined user interface. Create media-rich experiences using HTML5 and CSS3. Easily customize layouts and templates with a powerful CSS and skin editor. Publish content as Responsive HTML5, PDF, Mobile App, and more to serve users across all platforms. Personalize experiences using dynamic content filters. Make search easier for your users with a new algorithm, search autocomplete and autocorrect. Take collaboration to the next level using Git, SharePoint Online, and more.

• **Who should use Adobe RoboHelp (2019 release)?**
  
  RoboHelp (2019 release) is designed for:

  • **Help authors, knowledgebase experts, Help developers for mobile applications, user assistance designers, and content strategists** Produce Help systems, professional knowledgebases, technical support information, user guides, maintenance manuals, and mobile app Help content. RoboHelp is a scalable authoring and publishing solution that enables you to single-source content and publish it to multiple channels, devices, and platforms like mobile, web, desktop, and print.

  • **Policies and procedures specialists** Produce documentation that helps government and corporate organizations achieve compliance with accounting, privacy, accessibility, and other regulatory statutes. RoboHelp allows you to write structured and searchable documents that can be easily accessed by a member of an organization.

  • **Instructional designers and eLearning professionals** Create document-based learning materials for real and virtual classrooms and self-study programs. RoboHelp is an authoring and publishing tool that is comprehensive yet easy to use and integrates specialist tools like Adobe Captivate. Use RoboHelp to develop and maintain instructionally sound eLearning courses that integrate with LMSs. Work in a collaborative environment with multiple review cycles and follow up quickly. You can deliver more in less time, with fewer people and at a lower cost.

  • **Technical subject matter experts and engineers** Create comprehensive technical documentation, including test plans, designs, reports, and product specifications. Use RoboHelp to include 3D models and simulations in your documents with rich media capabilities.
• What is the difference between Adobe RoboHelp (2019 release) and Adobe Technical Communication Suite (2019 release)?

Adobe RoboHelp (2019 release)

Adobe Technical Communication Suite (2019 release)
- Easily author long, complex XML and non-XML documents.
- Deliver highly personalized interactive Help experiences with best-in-class search.
- Create responsive eLearning content and transform presentations to enable on-demand learning.
- Publish content across channels, formats, and devices.
- Collaborate in real time with shared PDF reviews.

Adobe Technical Communication Suite (2019 release) combines the following:
- Adobe FrameMaker (2019 release)
- Adobe RoboHelp (2019 release)
- Adobe Captivate (2019 release)
- Adobe Acrobat Pro 2017
- Adobe Presenter 11.1

Additional components:
- Adobe RoboScreenCapture

• I already have a license for an older version of RoboHelp. What are my upgrade options?
Special upgrade pricing is available to users who have eligible licenses for Adobe RoboHelp and want to upgrade to Adobe RoboHelp (2019 release) or Adobe Technical Communication Suite (2019 release).

• What are the new features in RoboHelp (2019 release)?
Adobe RoboHelp (2019 release) lets you design and deliver exceptional Help, policy, and knowledgebase content. Work faster with a reimagined user interface. Create media-rich experiences using HTML5 and CSS3. Easily customize layouts and templates with a powerful CSS and skin editor. Publish content across screens as Responsive HTML5, PDF, Mobile App, and more to serve users across platforms. Personalize experiences using dynamic content filters. Make search easier for your users with a new algorithm, search autocomplete, and autocorrect. Take collaboration to the next level using Git, SharePoint Online, and more.

See the feature summary of Adobe RoboHelp (2019 release).

• What is Responsive HTML5 publishing in RoboHelp (2019 release)?
Responsive HTML5 is an output type in RoboHelp (2019 release). It is based on a single responsive layout that automatically scales to different screen sizes. Generate Responsive HTML5 output with RoboHelp (2019 release) as easily as you generate WebHelp. This is because you don't need to configure anything — just select the responsive layout as you select a WebHelp skin.

• Does RoboHelp (2019 release) have international language support?
Yes, RoboHelp (2019 release) supports Unicode, which enables you to author and edit Help topics in several languages. You can publish Help systems in Brazilian Portuguese, Bulgarian, Canadian French, Catalan, Croatian, Czech, Danish, Dutch, English, Estonian, Finnish, French, German, Greek, Hungarian, Italian, Japanese, Korean, Latvian, Lithuanian, Norwegian, Polish, Portuguese, Romanian, Russian, Simplified Chinese, Slovenian, Spanish, Swedish, Swiss German, Thai, Traditional Chinese, Turkish, and Vietnamese. Adobe RoboHelp (2019 release) checks spelling, auto-corrects words, and creates a keyword index in any of these languages. The generated Help system, including navigation, appears in the selected language. Full text search is also operational in all these languages.

- **Which browsers support the output generated by RoboHelp (2019 release)?**
  The following browsers support output generated by RoboHelp (2019 release):
  - Google Chrome 65.0 or above
  - Mozilla Firefox 59.0 or above
  - Microsoft Edge 40.0 or above

- **Which versions of Acrobat are compatible with RoboHelp (2019 release)?**
  Acrobat X, XI, Pro DC (2015 release), and Pro 2017 are compatible.

- **Which versions of Adobe Captivate are compatible with RoboHelp (2019 release)?**

- **Can I submit a feature request for a future version of RoboHelp?**
  Adobe appreciates any suggestions for new features. Submit your request to the RoboHelp Help Community.

- **How can I participate in future RoboHelp beta programs?**
  To participate in future RoboHelp beta programs, send an email to the RoboHelp Beta Community.

- **Can I import a project created in other Help authoring tools, for example, AuthorIT, Component One, or Flare?**
  You can import the final Help system output, but you cannot import proprietary file formats from third-party authoring tools.

- **What is the difference between Adobe WebHelp and Adobe WebHelp Pro?**
  You can easily generate Adobe WebHelp with Adobe RoboHelp (2019 release). WebHelp Pro is the server-based version of WebHelp and enables authors to publish a Help system to Adobe RoboHelp Server 10 software.

- **When I install RoboHelp, I can see RoboHelp (2019 release) and RoboHelp Classic (2019 release). What is the difference between them?**
  The RoboHelp (2019 release) installer installs both RoboHelp (2019 release), an all-new application, and RoboHelp Classic (2019 release), which retains the experience of older versions of RoboHelp with updates. You can migrate existing RoboHelp projects into RoboHelp (2019 release). However, once you migrate and edit the projects, those projects cannot be imported back to older versions or RoboHelp Classic (2019 release).

- **Can I continue to use both RoboHelp Classic (2019 release) and RoboHelp (2019 release) simultaneously?**
  The RoboHelp (2019 release) installer installs both RoboHelp (2019 release), an all-new application, and RoboHelp Classic (2019 release), which retains the experience of older versions of RoboHelp with updates. You can migrate existing RoboHelp projects into RoboHelp (2019 release). However, once you migrate and edit the projects, those projects cannot be imported back to older versions or RoboHelp Classic (2019 release).

- **Can I publish to RoboHelp Server 10 from RoboHelp (2019 release)?**

Last updated 2/20/2019

Pricing and purchasing information

- How much does it cost to purchase a RoboHelp (2019 release) or RoboHelp Server 10 license?
  
  The full version of RoboHelp (2019 release) costs US$999. The full version of RoboHelp Server 10 costs US$9,999.†
  
  You can also buy a subscription to RoboHelp at $29.99/month per user. To know more, see all buying options.
  
  †Prices listed are the Adobe direct store prices. Actual price can vary depending on the country and currency of purchase, product language, and applicable local taxes.

- I own an older version of RoboHelp or RoboHelp Server. What is your upgrade policy?
  
  - If you own RoboHelp (2017 release), you can upgrade to RoboHelp (2019 release) for US$399.†
  
  - If you own RoboHelp (2015 release), you can upgrade to RoboHelp (2019 release) for US$599.†
  
  - If you own RoboHelp (2019 release) or older, you can upgrade to Adobe Technical Communication Suite (2019 release) for US$1199.†
  
  - If you own RoboHelp Server 9, you can upgrade to RoboHelp Server 10 for US$4,999.†
  
  †Prices listed are the Adobe direct store prices. Actual price can vary depending on the country and currency of purchase, product language, and applicable local taxes.

- Can I try RoboHelp before I buy it?
  
  Yes. You can download a fully functional, 30-day complimentary trial version.

- Does Adobe have a maintenance program for RoboHelp?
  
  Yes. Adobe provides maintenance programs for users who participate in the volume licensing programs.

- Where can I buy RoboHelp (2019 release)?
  
  You can buy RoboHelp (2019 release) through the online Adobe Store or by calling: +1-866-647-1213 (Monday to Friday, 8 AM ET – 5 PM ET). Learn about other ways to buy RoboHelp (2019 release), including buying through authorized resellers or purchasing with education or government discounts.

- Does Adobe offer educational pricing for RoboHelp (2019 release)?
  
  Adobe does offer educational pricing for RoboHelp (2019 release), but only via licensing and not via retail. Learn more about special education pricing.

- How do I find an Adobe Technical Communication Partner in my country or region?
  
  You can find an Adobe Technical Communication Partner to assist you in your country or region by visiting the Partner Portal.

Support information

- Where do I go if I have customer service questions?
  
  For any customer service questions, write to us at techcomm@adobe.com.

- Where do I go if I have technical support questions?
  
  For any technical support questions, visit the Customer Support page.

- What is activation?
Activation is a mandatory process that requires the software to connect to Adobe servers via the Internet and associates the products you have bought from Adobe with the computers on which you use those products. Activation helps protect your computers and environment from malicious code by ensuring you are using genuine Adobe software.

- **What information is passed to Adobe during activation?**
  Adobe does not gather, transmit, or use personally identifiable information during activation, other than the computer's IP address.

- **How many times or how often will I have to connect to the Internet?**
  You need to connect the machine with RoboHelp (2019 release) to the Internet at least once within 30 days of the first launch of your serialized product.

- **Do I need to do anything to activate the software?**
  Activation occurs silently in the background after installation when the system detects an Internet connection. You don't have to do anything proactively to activate.

- **How long can I use the product before I need to activate?**
  The product must connect to the Internet at least one time within 30 days of the first launch of your serialized product. If the product has not been activated after 30 days, the application does not launch until an Internet connection is detected and the software can be activated.

- **What happens if I do not have an Internet connection or do not activate my product?**
  The software silently tries to connect to the Internet to activate for the first 7 days after the first launch of your serialized product. If the software has not activated within the first 7 days, you receive a reminder for the next 23 days on every launch that the machine must connect to the Internet and activate the software. As soon as the software detects an Internet connection, it silently activates the product.

- **If I don't have an Internet connection, can I call Customer Support for phone activation?**
  No. Activation of the product via the Internet is required for RoboHelp (2019 release). If your system is connected to the Internet and you receive an activation reminder, contact your local Customer Support for assistance. Customer Support, however, cannot activate your software over the phone if you don't have an Internet connection.

- **I have an Internet connection, but received a reminder that I still need to activate my product. What do I need to do?**
  If your system is connected to the Internet and you have received a reminder asking you to activate your product, contact your local Customer Support. To access phone numbers for Customer Support, see Adobe Customer Support.

- **I work for a company that has a volume license agreement with Adobe. Do I still need to activate?**
  Yes. All RoboHelp (2019 release) users need to activate their product. If your company has firewall restrictions that prevent the machines from connecting to the Internet, have your IT Administrator contact your local Customer Support. The phone numbers for Customer Support are available at Adobe Customer Support.

- **I work for a company that has a license with Adobe and I've already activated one of my computers. Do I need to activate the others?**
  Yes. Every computer that has RoboHelp (2019 release) installed must activate in order to continue using the software.

- **I work for a company that has a license with Adobe and our company systems do not connect to the Internet due to firewall restrictions. What do I need to do to make sure the software doesn't stop working?**
If your company has firewall restrictions that prevent the machines from connecting to the Internet, have your IT administrator contact your local Customer Support. The phone numbers for Customer Support are available at www.adobe.com/support/contact.

- **Can I choose not to activate Adobe RoboHelp (2019 release)?**
  Activation of RoboHelp (2019 release) is required via the Internet to continue using the product. Activating RoboHelp helps protect your computer, your environment, and ensures that you use a genuine Adobe product. The machine with RoboHelp (2019 release) installed must connect to the Internet at least once within 30 days of the first launch of your serialized product or the product stops working. If you work in a company that has a firewall that prevents your system from connecting to the Internet, have your IT Administrator contact Customer Service.

- **I didn't know I needed to have an Internet connection when I purchased Adobe RoboHelp (2019 release)? Is there a way to activate without having an Internet connection?**
  No. Activation of RoboHelp (2019 release) is required via the Internet. Each machine with RoboHelp installed must connect to the Internet at least once within 30 days of the first launch of your serialized product to continue use of the product.

- **I didn't know I needed to have an Internet connection when I purchased Adobe RoboHelp (2019 release)? What is the return policy?**
  For details on Adobe return policies in your region, see this Return or exchange a non-subscription product.

- **Are activation and registration the same thing?**
  No. Activation is a mandatory process that requires the software to connect to Adobe servers via the Internet and associates the products you have bought from Adobe with the computers on which you use those products. Activation helps protect your computers and environments from malicious code by verifying that you have genuine Adobe software. Registration is an optional process that gives you access to a wide range of benefits and options, including access to support, notification of product updates, newsletters, special offers, and invitations to Adobe events.

- **I have registered my product but am still being asked to activate. What do I need to do?**
  Registration and activation are completely different. Activation is a mandatory process that requires the software to connect to Adobe servers via the Internet and associates the products you buy from Adobe with the computers on which you use those products. Activation helps protect your computers and environments from malicious code by verifying that you have genuine Adobe software. Registration is an optional process that gives you access to a wide range of benefits and options, including access to support, notification of product updates, newsletters, special offers, and invitations to Adobe events.

- **I misplaced my product key. How can I get a new product key?**
  Contact Customer Service from 6am to 5pm, Pacific Time, Monday through Friday, at 800-833-6687, or submit a request online at any time. For faster service when calling, have your invoice number available.

**Subscription information and pricing**

- **What is an Adobe technical communication software subscription?**
  A subscription is a more flexible way to get the technical communication software. It gives ongoing access to the software for a low monthly fee and access to all upgrades at no additional charge, as long as your subscription remains active.

  **Note:**
The subscription plan requires an annual commitment, billed monthly or prepaid. There is no month-on-month subscription plan.

• Which Adobe technical communication software is available on a subscription basis?
The following Adobe Technical Communication software are available by subscription:
  • Adobe FrameMaker (2019 release)
  • Adobe RoboHelp (2019 release)
  • Adobe Technical Communication Suite (2019 release)

• Are there any differences in functionality between the Adobe Technical Communication software purchased as a subscription versus the traditional purchasing model?
No, there are no differences in the functionality or in the system requirements between the two. However, if you suspend or cancel your subscription, you cannot use the software.

• Is subscribing to Adobe Technical Communication software the best choice for me?
Subscribing is a great option to consider if you want to:
  • Always benefit from the latest capabilities and updates of the latest version.
  • Upgrade your software and move up to the current version at an affordable price.
  • Try out Adobe Technical Communication software.

• Do I install the subscription software on my computer or is it a cloud-based application that I log in to via the Internet?
The software installs locally on your computer. It's unnecessary to be online to use your subscription. Access to the Internet is required during installation and licensing of your software and once every 30 days thereafter. The software alerts you when a connection to the Internet is required for a license status check. You have access to the software as long as your subscription is current.

• Where can I purchase Adobe technical communication software subscription editions?
Adobe Technical Communication software subscription plans are available exclusively through Adobe.com.

• I’m currently using a 30-day trial version. Can I convert that to a subscription?
Yes, you can convert the 30-day trial version into a subscription by purchasing a license from Adobe.com store. Select the subscription option when you add the product to your online cart. Once the order is complete, the subscription will start reflecting on your Adobe.com account. Please launch the product and choose the option to license this software, logon to your Adobe ID and the product will get activated.

• When I purchase my subscription, do I receive a box that contains the software?
No. When you purchase a subscription on Adobe.com, you immediately receive an email that contains a link to the electronic download of the software.

• I checked my credit card statement, and my subscription fee sometimes varies from one month to the next. Why is that?
If you live in a region where you purchase from the Adobe Store with a price quoted in U.S. dollars or euros (but you receive credit card statements with charges stated in your local currency), you could see different amounts charged from month to month. Changes in the currency exchange rates from one billing date to the next affect the charges.

• Will the cost of my subscription increase?
The cost of an annual subscription will not increase in the year you are subscribed.
What does my Adobe Technical Communication software subscription include?
Your subscription includes access to current and future versions of the Adobe technical communication application as long as your subscription remains active.

Are volume licenses available on subscription for Adobe Technical Communication software?
No, only individual subscription editions are available, and only on Adobe.com. For volume licensing needs kindly request a call back.

Is the pricing different for government or educational customers?
No. The pricing is same for all customers.

Subscription fees vary by product, plan, and your country of residence. Visit Adobe.com or the online Adobe Store in your respective country for pricing information.

How am I billed for the month-to-month or one-year plan?
Under an annual plan, paid monthly, you’ll be charged the rate stated at the time of purchase, plus applicable taxes (such as value added tax when the stated rate doesn’t include VAT), every month for the duration of your annual contract.

Under an annual plan that is prepaid, you’ll be charged the annual rate stated at the time of purchase as one lump sum, plus applicable taxes. Your contract will renew automatically, on your annual renewal date, until you cancel. See terms and conditions for more details.

Which language versions of Adobe technical communication software are available by subscription?

How do I purchase and get started with my Adobe Technical Communication subscription software?
You can quickly get started with a subscription: Visit the buying guide and choose your product and plan, and then complete the purchase. Immediately after purchase, check your email for a message from Adobe with your serial number and a link to download your software. After you download the product, double-click the installer and follow the onscreen instructions to install your product and start your subscription.

When does my subscription begin?
Your subscription begins as soon as your payment is processed.

What if I have problems downloading my software?
Visit the Adobe Store download forum, where you can find information about typical software download issues. You can also reach out to us at techcomm@adobe.com for any queries.

Where can I access my serial number on Adobe.com?
In the Adobe Store, select Your Purchases > Your Downloads. A column displays the serial number for your subscription, along with a link to download the product.

What is an Adobe ID and why do I need one to use my subscription edition product?
During your purchase and installation, you are required to create or enter an Adobe ID. An Adobe ID is your current email address with a password you create. Learn more about the benefits of an Adobe ID.

If I subscribe to multiple products, do I need to create multiple Adobe IDs to use them?
No. You can use the same Adobe ID with all your Adobe products, including subscriptions.

- **What are the terms and conditions for an Adobe Technical Communication software subscription?**
  
  See subscription terms and conditions.

- **How many computers can I install my subscription on?**

  You can install your subscription software on up to two computers. For more information, see the license agreement for the product that you want to subscribe to.

- **What is product activation?**

  When you buy a software product from Adobe, you are issued a serial number that represents your license to use that software. Activation is the process by which Adobe validates that your software and serial number are genuine and being used as allowed by your product license agreement. It is intended to protect both your rights as a consumer and Adobe's rights as a software developer. Activation helps confirm that the software you bought is not counterfeit. You cannot use your Adobe subscription edition software if it is not activated.

- **Is activation required to use a subscription edition product?**

  Yes. If Adobe cannot activate the product, you are warned when you launch the application. Blocking access to the activation server prevents the product from launching.

- **I started with a month-to-month plan and would like to change it to a one-year plan. How do I do that?**

  Call Adobe Customer Service for assistance in making this change.

- **Can I cancel my subscription?**

  Yes, you can cancel your subscription. If you cancel within 14 days of your initial order, you'll be fully refunded. Should you cancel after 14 days, you'll be charged 50% of your remaining contract obligation and your service will continue until the end of that month's billing period. Cancellations can be made at any time by visiting your Manage Account page* or by contacting Customer Support in your region.

  *Specific countries require cancellations to be made only by contacting Customer Support, see list of countries here.

- **My subscription has expired. How do I renew it?**

  If your subscription expires or is stopped for any reason (for example, due to an expired credit card), you are notified by email, and your software displays an alert that your subscription has ended. If it has been less than six months since the subscription ended, click the Renew button displayed with the alert to enter the information required to restart your subscription.

- **How do I cancel my annual subscription?**

  To cancel an annual subscription, you can either visit the Account page on www.creativecloud.com or contact Adobe Customer Service. If you cancel your membership before meeting the annual commitment date, you are charged 50% of the remaining amount left on your contract.

- **In which countries can I buy an Adobe Technical Communication subscription?**

  Subscriptions are available through Adobe.com in the following countries:

  Africa, Australia, Austria, Belgium, Brazil, Bulgaria, Canada, Cyprus, Czech Republic, Denmark, Estonia, Finland, France, Germany, Greece, Hungary, Ireland, Italy, Japan, Latvia, Lithuania, Luxembourg, Malta, Mexico, Netherlands, New Zealand, Norway, Poland, Portugal, Romania, Slovakia, Slovenia, Spain, Sweden, Switzerland, United Kingdom.

- **If I cancel my subscription, can I still use the software that I have?**
When you cancel your subscription after 14 days:

• For an annual contract paid monthly, your access will continue until the end of that month’s billing period.
• For a prepaid annual contract, your access will continue until the end of your contracted term.

• If I want to buy Adobe FrameMaker (2019 release), Adobe RoboHelp (2019 release), or Adobe Technical Communication Suite (2019 release), rather than continue to subscribe to it, do I receive a discount?

There are no discounts offered for moving from a subscription edition to a non-subscription purchase of Adobe Technical Communication software.

• How do I receive minor updates and full upgrades to my subscription product?

You are eligible to receive updates to Adobe Technical Communication software as long as your subscription remains active. Adobe notifies you by email of upgrades as they become available. This email contains instructions on how to access and install the upgrades.

Any ongoing bug fixes, security patches, and other update releases that do not require full upgrades are made available through the Updater in Adobe Application Manager.

• Who do I contact if I have problems related to managing my subscription, such as billing, installation, changing plans, or restarting a subscription?

If you have questions relating to managing your subscription, contact Adobe Customer Service.

• Who do I contact if I have issues with my Adobe technical communication software?

Contact Adobe Technical Communication support for issues with your Adobe software. You can also reach out to us at techcomm@adobe.com for any queries.

• Who do I contact if I have issues with my subscription?

If you have questions about your subscription, visit the Support page. You can also reach out to us at techcomm@adobe.com for any queries.

• Are service and support included with my subscription?

Similar to traditional licensing model of Technical Communication products, support is not a part of the license and needs to be purchased separately from Adobe.com.

†Prices listed are the Adobe direct store prices. Actual price can vary depending on the country and currency of purchase, product language and applicable local taxes.

‡This product may integrate with or allow access to certain Adobe or third-party hosted online services (“Online Services”). Online Services are available only to users 13 and older and require agreement to additional terms of use and Adobe’s online privacy policy (www.adobe.com/go/terms). Online Services are not available in all countries or languages, may require user registration, and may be discontinued or modified in whole or in part without notice. Additional fees or subscription charges may apply.

∑Adobe FrameMaker (2019 release) allows users to create content that is compliant to popular industry standards such as XML, DITA 1.2 and S1000

RoboHelp system requirements

Last updated 2/20/2019
RoboHelp (2019 release)
- Core i3 or faster processor
- Microsoft® Windows® 7, 8.1, or 10
- 4 GB of RAM or more is recommended
- 3 GB of hard-disk space is required for installation; additional space is required during installation (cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)
- 64-bit CPU and operating system

This software will not operate without activation. Broadband Internet connection and registration are required for software activation, validation of subscriptions, and access to Online Services. Phone activation is not available.

Note:
This product may integrate with or allow access to certain Adobe or third-party hosted online services ("Online Services"). Online Services are available only to users 13 and older and require agreement to additional terms of use and Adobe's online privacy policy. Online Services are not available in all countries or languages, may require user registration, and may be discontinued or modified in whole or in part without notice. Additional fees or subscription charges may apply.

Supported software
- Microsoft® Word 2016, 2013, 2010
- Adobe Acrobat Pro DC (2015 release), Pro 2017
- Adobe Captivate 2019*
- Microsoft SharePoint Online*

*These versions are supported with RoboHelp (2019 release) application. However, with RoboHelp Classic 2019, only SharePoint 2010 and Adobe Captivate 2017 are supported.

Language versions
RoboHelp (2019 release) is available in the following languages:
- English
- French
- German
- Japanese

Supported browsers for published output
- Google Chrome 65.0 or above
- Mozilla Firefox 59.0 or above
- Microsoft Edge 40.0 or above
- Microsoft Internet Explorer 11

RoboHelp (2017 release)
- Intel® Pentium® 4 or faster processor
- Microsoft® Windows® 10, 8.1 or 7
- 1 GB of RAM (2 GB recommended)
Introduction to RoboHelp

- 3 GB of available hard-disk space for installation; additional free space required during installation (cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)
- DVD-ROM drive
- Maximum supported screen resolution – 4K (3480 x 2160, 8.3 megapixel, aspect ratio 16:9)

This software does not operate without activation. A broadband Internet connection and registration are required for software activation, validation of subscriptions, and access to Online Services. Phone activation is not available.

Note:

This product may integrate with or allow access to certain Adobe or third-party hosted online services (“Online Services”). Online Services are available only to users age 13 years and older and require agreement to additional terms of use and Adobe’s online privacy policy (www.adobe.com/go/terms). Online Services are not available in all countries or languages, may require user registration, and may be discontinued or modified in whole or in part without notice. Additional fees or subscription charges may apply.

Supported software
- Microsoft® Office 365 (only documents downloaded from Office 365) or Microsoft® Word 2016, 2013, 2010
- Adobe Acrobat Pro DC (2015 release) or XI
- Microsoft® SharePoint Server® 2013 or 2010
- Adobe RoboHelp Server 10

Language versions
This product is available in the following languages:
- English
- French
- German
- Japanese

RoboHelp (2015 release)
- Intel® Pentium® 4 or faster processor
- Microsoft® Windows® 10, 8.1 or 7
- 1 GB of RAM (2 GB recommended)
- 3 GB of available hard-disk space for installation; additional free space required during installation (cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)
- DVD-ROM drive
- 1024x768 screen resolution (1280x800 recommended) with 16-bit video card

This software will not operate without activation. Broadband Internet connection and registration required for software activation, validation of subscriptions, and access to Online Services. Phone activation is not available.

Note:
This product may integrate with or allow access to certain Adobe or third-party hosted online services ("Online Services"). Online Services are available only to users age 13 and older and require agreement to additional terms of use and Adobe’s online privacy policy (www.adobe.com/go/terms). Online Services are not available in all countries or languages, may require user registration, and may be discontinued or modified in whole or in part without notice. Additional fees or subscription charges may apply.

**Supported software**
- Microsoft® Office 365 (only documents downloaded from Office 365) or Microsoft® Word 2016, 2013, 2010
- Adobe Acrobat Pro DC (2015 release) or XI
- Microsoft® SharePoint Server® 2013 or 2010
- Adobe RoboHelp Server 10

**Language versions**
This product is available in the following languages:
- English
- French
- German
- Japanese

**Get to know the RoboHelp workspace**
Packed with tons of powerful features, Adobe RoboHelp offers you a thoughtfully designed, clean, and easy-to-use workspace. Quickly create content with all the elements you need, build efficiency with single-sourcing and content reusability, and publish your project in a desired output type. You can also collaborate with multiple authors in a project.
Introduction to RoboHelp

The RoboHelp workspace
A Menu bar  B Author toolbar  C Project component panel (for example: Contents panel)  D Open topic  E Properties panel  F Standard toolbar

• Menu bar

The menu bar provides access to the File, Edit, View, Collaborate, and Help menus.

**File menu** Create, open, save, and close a project. You can also find options to import Word document and Captivate video, upgrade RoboHelp Classic project, configure project settings, and exit project.

**Edit menu** Cut, copy, paste, undo, and redo content. You can also find options to select all, copy and clear formatting, and edit application preferences.

**View menu** Find options to view Properties panel, starter screen, condition tags, variables, and view topics by title. You can also view options to Toggle Full Screen and change the application theme.

**Collaborate menu** You can find options to add and open connections to share your project for collaboration in a multi-author system.

**Help menu** You can find options to access Help resources, manage your account, sign out from RoboHelp, update your application, and view the RoboHelp About dialog box.

• Author toolbar

The Author toolbar appears at the left side of the screen, below the Standard toolbar. Easily manage your project by accessing various components of your project, such as Contents, Table of Contents, Condition Tags, Variables, Snippets, Reports, and more.
In the Author toolbar, click the desired project component to open its corresponding panel.

- **Project component panel**

  When you click a project component on the Author toolbar, the project component panel opens and allows you to manage that component. You can find the following project components in the Author toolbar:

  - **Contents panel** This panel lists the topics in a project and provides options to add, rename, and edit topic properties. You can also create folders and subfolders to organize the topics. To know more about how to work with topics, see [Work with topics and folders](#).

  - **Table of Contents panel** This includes the hierarchy of the folders, subfolders, and topics in a project. You can reorder the folders and organize your content in a strategic manner for easy user navigation in your output. You can edit, rename, and delete a Table of Contents. To know more, see [Create and manage a Table of Contents](#).

  - **Index panel** This panel lists the index in your project. You can add, rename, edit, and delete an index. To know more, see [Create and manage an index](#).

  - **Glossary panel** Lists the glossary terms in your project. You can add, edit, rename, or delete a glossary item. To know more, see [Create and manage a glossary](#).

  - **Condition Tags panel** This panel lists the assigned condition tags in your project. You can add, edit, and delete a conditional tag. To know more, see [Create and apply condition tags](#).

  - **Variables panel** This panel displays all the variables that are assigned values in your project. You can add, edit, or delete a variable. To know more, see [Create and use variables for easy updates](#).

  - **Snippets panel** This panel displays the snippets in your project. You can create, edit, or delete snippets. To know more, see [Single-source with snippets](#).

  - **Master Pages panel** This panel displays the master pages in your project. You can create, edit, duplicate, delete, import, or export master pages. To know more, see [Work with master pages](#).

  - **Browse Sequences panel** This panel displays the browse sequences in your project. You can create, edit, rename, or delete browse sequences. To know more, see [Create and manage browse sequences](#).
• **Reportspanel** Includes options to generate reports such as Topic List, Project Status, Variables, Condition Tags, Broken links, and more. You can edit, download, and print a desired report. To know more about reports, see [Generate reports](#).

• **Open topic**

Double-click a topic in the **Contents** panel to open a topic. You can then edit and format content in your topic. To know more about topics, see [Work with topics and folders](#).

• **Properties panel**

While authoring a topic in a project, the panel displayed on the right side of the screen is the **Properties** panel. This panel contains the following tabs:

  • **General** You can find options to edit font, alignment, border, layout, and background. To know more, see [Format your content](#).
  
  • **Styles** You can find options to edit various types of styles such as paragraph style, character style, hyperlink style, and more.
  
  • **Topic** You can find options to edit topic properties. To know more, see [Topic properties](#).

As you adjust a property of a selected object, like an image, you can see the content changes in real time. You can hide or display the **Properties** panel by choosing **View > Properties Panel** or click **Toggle Right Pane** on the Standard toolbar.

![Properties panel](#)

*Use the three tabs in the Properties panel to edit content properties.*

• **Standard toolbar**

The Standard toolbar appears below the menu bar and includes three toolsets:

  • The first toolset is a set of tabs and icons at the left side of the standard toolbar. This includes **Author** and **Output** tabs, and **Save All, Undo, Redo, Find Files**, and **Find and Replace** icons.
  
  • The second toolset is the set of icons at the center of the standard toolbar. This contains various options to quickly format content such as inserting bulleted and numbered lists, images, multimedia, and more. To know more, see [Format your content](#).
• The last toolset is the set of icons at the right side of the standard toolbar. This contains various view options such as **Author**, **Source**, and **Preview**. It also includes **Quick Generate** and **Toggle Right Pane**. The **Quick Generate** dialog box allows you to select and configure an output preset of your choice and generate your output. To know more about generating output, see [Generate output](#).

The three toolsets in the Standard toolbar.

### Adobe RoboHelp manual (PDF)

Find a PDF of articles to learn how to use Adobe RoboHelp (2019 release).

[Adobe RoboHelp manual (PDF)](#)

### RoboHelp keyboard shortcuts

Adobe RoboHelp provides shortcuts to help you quickly navigate and work on documents. Know the keyboard shortcuts that appear next to command names in menus and the ones not included in menus.

**Keys for project and file operations**

<table>
<thead>
<tr>
<th>Use these keys</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt + Ctrl + N</td>
<td>New project</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>Open project</td>
</tr>
<tr>
<td>Alt + Ctrl + S</td>
<td>Save</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Save all</td>
</tr>
<tr>
<td>Ctrl + F4</td>
<td>Close active editor</td>
</tr>
<tr>
<td>Alt + Ctrl + C</td>
<td>Close project</td>
</tr>
<tr>
<td>Ctrl + Shift + /</td>
<td>Project settings</td>
</tr>
<tr>
<td>Ctrl + Q</td>
<td>Exit application</td>
</tr>
<tr>
<td>Ctrl + W</td>
<td>Open topic preview</td>
</tr>
<tr>
<td>Ctrl + R</td>
<td>Open Source view</td>
</tr>
<tr>
<td>Ctrl + E</td>
<td>Open Author view</td>
</tr>
<tr>
<td>Ctrl + F</td>
<td>Find files</td>
</tr>
<tr>
<td>Ctrl + H</td>
<td>Find and replace text in topics and Table of Contents (Author and Source views, and Table of Contents panel)</td>
</tr>
<tr>
<td>Ctrl + Alt + C</td>
<td>Close project</td>
</tr>
</tbody>
</table>
# Keys for editing

<table>
<thead>
<tr>
<th>Use these keys</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Ctrl + Y, Ctrl + Shift + Z</td>
<td>Redo</td>
</tr>
<tr>
<td>Ctrl + X, Shift + Del</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl + C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl + V, Shift + Insert</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl + A</td>
<td>Select all</td>
</tr>
<tr>
<td>Ctrl + Shift + T</td>
<td>Application preferences</td>
</tr>
<tr>
<td>Shift + Arrow</td>
<td>Select text by letters</td>
</tr>
<tr>
<td>Ctrl + Shift + Arrow</td>
<td>Select text by words</td>
</tr>
<tr>
<td>Shift + Home</td>
<td>Select text from the cursor to the beginning of the line</td>
</tr>
<tr>
<td>Shift + End</td>
<td>Select text from the cursor to the end of the line</td>
</tr>
<tr>
<td>Ctrl + Shift + Home</td>
<td>Select text from the cursor to the beginning of the document</td>
</tr>
<tr>
<td>Ctrl + Shift + End</td>
<td>Select text from the cursor to the end of the document</td>
</tr>
<tr>
<td>Shift + Page Down</td>
<td>Select text downwards from the cursor to the length of the editing area</td>
</tr>
<tr>
<td>Shift + Page Up</td>
<td>Select text upwards from the cursor to the length of the editing area</td>
</tr>
<tr>
<td>Ctrl + Shift + C</td>
<td>Copy inline formatting from a text fragment and enable sticky mode</td>
</tr>
<tr>
<td>Ctrl + Shift + V</td>
<td>Apply the copied inline formatting to a text fragment</td>
</tr>
<tr>
<td>Esc</td>
<td>Disable sticky mode</td>
</tr>
<tr>
<td>Shift + Ctrl + V</td>
<td>Paste as plain text</td>
</tr>
<tr>
<td>Tab</td>
<td>Indent a list</td>
</tr>
<tr>
<td>Shift + Tab</td>
<td>Outdent a list</td>
</tr>
<tr>
<td>Ctrl + B</td>
<td>Make text bold</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete contextually</td>
</tr>
<tr>
<td>Ctrl + Alt + L</td>
<td>Auto indent Source view</td>
</tr>
<tr>
<td>Ctrl + Space</td>
<td>Show options in Source view</td>
</tr>
<tr>
<td>Ctrl + Up Arrow</td>
<td>Move selected Table of Contents items up</td>
</tr>
<tr>
<td>Ctrl + Down Arrow</td>
<td>Move selected Table of Contents items down</td>
</tr>
<tr>
<td>Ctrl + Left Arrow</td>
<td>Move selected Table of Contents items left</td>
</tr>
<tr>
<td>Ctrl + Right Arrow</td>
<td>Move selected Table of Contents items right</td>
</tr>
</tbody>
</table>
### Keys for insertion of items

<table>
<thead>
<tr>
<th>Use these keys</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + 1</td>
<td>Insert a variable</td>
</tr>
<tr>
<td>Ctrl + 2</td>
<td>Insert a snippet</td>
</tr>
<tr>
<td>Ctrl + 3</td>
<td>Insert a field</td>
</tr>
<tr>
<td>Ctrl + G</td>
<td>Insert an image</td>
</tr>
<tr>
<td>Ctrl + K</td>
<td>Insert a hyperlink</td>
</tr>
</tbody>
</table>

### Keys for navigation

<table>
<thead>
<tr>
<th>Use these keys</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Jump to the beginning of the line</td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td>Jump to the beginning of the document</td>
</tr>
<tr>
<td>End</td>
<td>Jump to the end of the line</td>
</tr>
<tr>
<td>Ctrl + End</td>
<td>Jump to the end of the document</td>
</tr>
<tr>
<td>Page Down</td>
<td>Scroll down the length of the editing area in a document</td>
</tr>
<tr>
<td>Page Up</td>
<td>Scroll up the length of the editing area in a document</td>
</tr>
<tr>
<td>Ctrl + Page Up</td>
<td>Switch to the next open tab in RoboHelp workspace</td>
</tr>
<tr>
<td>Ctrl + Page Down</td>
<td>Switch to the previous open tab in RoboHelp workspace</td>
</tr>
</tbody>
</table>

### Keys for other functions

<table>
<thead>
<tr>
<th>Use these keys</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>F11</td>
<td>Toggle full screen</td>
</tr>
<tr>
<td>F1</td>
<td>Online Help</td>
</tr>
</tbody>
</table>
Chapter 2: Projects

Plan your RoboHelp project

It’s always a good idea to first spend some time in planning your project and not jump straight into authoring. Think of the business goal you are trying to accomplish and the audience you need to serve. The resources you have for creating and delivering the content also impact the decisions you make while planning the project. If you would like multiple authors to collaborate on a project, planning the project is especially important to ensure quality and maximize resource usage.

Single-author or multi-author setup

The size of your authoring team is an important consideration for determining the type of processes and tools to put in place. For example, if multiple authors need to collaborate on creating and delivering your content, integrating a version control system is always a good idea. Similarly, creating and maintaining glossaries, common assets, and authoring and publishing guidelines helps ensure content quality in a multi-author setup.

Multi-role setup

If your publishing requirements are voluminous and varied, you might need to have authoring and output generation handled by separate groups of team members. In such a case, plan the processes and protocols in such a way that the team can use the power and built-in capabilities of RoboHelp to implement an efficient, frictionless system of delivery. If there are designers in the team, make sure that authors, designers, and publishing experts collaborate on creating master pages and skins for optimal layout design.

Output types and delivery

Identify the different output types you need. Would there be a need for additional output types later? If yes, what can you do now to make adding an output type later easier? If you plan to host the output on a server, do you need to work with your IT admin? If you plan to generate a Mobile App output, do you need to outline the guidelines for writing bite-sized topics? Do you need to maintain content for multiple versions of a product or deliver content for two co-existing experiences of a single feature? Plan whether you need to define condition tags and expressions so you can include conditional content in different types of output. Plan variable sets for different types of output.
Look and feel of the output

To ensure that the content experience meets the expectation of your target audience, spend time visualizing the look and feel of the output. Check out the skins that come with RoboHelp and see whether you need to tweak or touch up available skins or create skins. Plan to invest in creating a great style sheet so your end users have a great content consumption experience.

Leveraging external content

Do you have content available in other formats? For example, you might have FAQs, solutions, case studies, and other types of high-quality content authored by Subject Matter Experts in Microsoft Word. If yes, you can import this content easily in RoboHelp. However, make sure that you review the various Word import settings and make decisions about the style, formatting, and various other aspects of the imported content. If there are Adobe Captivate videos for the content you are delivering, you can integrate them in your content and provide users a rich, immersive content experience.

Navigation design

Before you create tons of content, make sure that you design how end users can navigate the content in the output. How do you want to organize the topics and the content inside each topic? How many levels of folders do you want to allow? How many levels of headings should be used to organize the content in a topic? Do you want different TOCs for different output types or variants? For example, you might want to plan for different TOCs if you want to generate output variants for PDF output and Responsive HTML output or for different Help systems for internal and external users. Similarly, if you want to create separate Help systems for beginners and advanced users from the same project, you will need to plan for different TOCs.

Reusable content

One of the key strengths of RoboHelp is the support for implementing content reusability. Identify the types of information that need to be consistently used across the project. If they change often or change late in your project cycle, use variables and snippets to author and update them in one place and use them several times in your project.

Content formatting and styling

Plan to implement a consistent and professional look-and-feel for the various elements of your content using styles. What’s best, RoboHelp lets you disallow inline formatting at a project level. So before you start authoring, make the decision to allow or disallow inline formatting. If you want to allow inline formatting, make sure that you define and follow some conventions so the content is consistently formatted. For example, if you want that all UI terms mentioned in the content should be in bold, make sure that you define this convention in the planning stage of your project and follow it consistently while authoring.

Glossary of terms

It’s always a good idea to invest in a glossary. Identifying the terms and providing clear descriptions of the terms helps your end users absorb the concepts and instructions. What’s more, the glossary helps authors to establish a consistent verbiage across the project and provide a seamless and authentic user experience. RoboHelp lets you create and maintain more than one glossary in a project. So you can even have a glossary that is only for authors and not included in the project output. You can also have multiple glossaries for users and choose to include or exclude from the specific types of output.
Content governance

Make use of RoboHelp’s built-in capabilities to define a governance framework for your content. Define the list of topic statuses and encourage the authors to use them consistently. Use the various RoboHelp reports effectively to identify errors and inconsistencies in different components and make global updates. Keep your projects clean and robust by removing unused assets and project components. You can even maintain your guidelines and author notes within the project in topics that you can exclude from project output.

Create a project

Note:

If you are a RoboHelp Classic user, upgrade your projects in a few simple steps. For more information, see Upgrade a RoboHelp Classic project.

A project is the core entity that you work with in Adobe RoboHelp. The basic element of a project is a topic. To start authoring your content, add topics to a project. Then, add navigation, configure project properties, and generate the desired output. A typical output of RoboHelp is a Help system in one or more formats, such as Responsive HTML5 and PDF. A RoboHelp project file has the .rhpj extension.

Besides the project file, RoboHelp maintains various project components, such as topics, Table of Contents, variables, skins, and master pages, in separate files. As an author, you need not manipulate the project file or the component files directly. Whenever you edit a project from within RoboHelp, the project file and any other affected project component file are updated automatically.

Project components

The following table lists the various components of a RoboHelp project:

<table>
<thead>
<tr>
<th>Project component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Topic</td>
<td>The basic element of your content structure in RoboHelp. A topic can contain text, multimedia such as images and videos, navigation links, and more. When you plan a topic, make sure that it is easy to consume and reuse. Avoid creating topics that are very long or very short. From the Author toolbar, click the Contents icon to work with topics. For more information, see Work with topics and folders.</td>
</tr>
<tr>
<td>Folder and subfolder</td>
<td>The components that help you organize the contents of your project. You can create folders and subfolders to organize topics and assets, such as images, videos, and style sheets. From the Author toolbar, click the Contents icon to create, rename, or delete folders and subfolders. For more information, see Work with topics and folders.</td>
</tr>
<tr>
<td>Image and multimedia</td>
<td>Graphics, audio, video, animation, and other audiovisual assets that you can add to a topic to enhance your content. In an open topic, you can find the Insert Image and Insert Multimedia icons in the toolbar on top of the authoring area. For more information, see Work with images and multimedia.</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Table of Contents (TOC)</strong></td>
<td>A TOC helps present a hierarchical outline of the content in a Help system. During authoring, you can browse the TOC and select folders or topics to view and edit. In the published output, end users can use the TOC to quickly view the scope and coverage of content in the Help system. A TOC also allows the end user to quickly jump to a topic of choice. From the Author toolbar, click the Table of Contents icon to work with TOC. For more information, see <a href="#">Create and manage a Table of Contents</a>.</td>
</tr>
<tr>
<td><strong>Index</strong></td>
<td>Allows the end user to navigate through a Help system using keywords or phrases that you’ve specified. These keywords or phrases require to be associated with specific topics. An index can include multiple levels of keywords and cross-references to other keywords. From the Author toolbar, click the Index icon to work with indexes. For more information, see <a href="#">Create and manage an index</a>.</td>
</tr>
<tr>
<td><strong>Glossary</strong></td>
<td>Displays the list of definitions for terms or phrases in a Help system. You can filter glossary terms with the help of conditions, link to a glossary file external to the project, and maintain multiple glossary files in a Help system. From the Author toolbar, click the Glossary icon to work with glossaries. For more information, see <a href="#">Create and manage a glossary</a>.</td>
</tr>
<tr>
<td><strong>Condition tags</strong></td>
<td>Allow you to define subsets of content and generate multiple Help systems from the same project. Condition tags help you manage your content for different needs, such as different target audiences and delivery formats. From the Author toolbar, click the Condition Tags icon to work with condition tags. For more information, see <a href="#">What is conditional content</a>.</td>
</tr>
<tr>
<td><strong>Variables</strong></td>
<td>Allow you to store text or a phrase that you can update in one place but use in many places across the project. Variables help you make quick global updates and ensure consistency. A good use case of variables is to store information such as product names and release dates. From the Author toolbar, click the Variables icon to work with variables. For more information, see <a href="#">Create and use variables for easy updates</a>.</td>
</tr>
<tr>
<td><strong>Snippets</strong></td>
<td>Allow you to create and manage reusable content. Global snippets help you to identify content and replace it across several topics in a single step, which saves times and facilitates efficient content changes. From the Author toolbar, click the Snippets icon to work with snippets. For more information, see <a href="#">Single-source with snippets</a>.</td>
</tr>
<tr>
<td><strong>Master pages</strong></td>
<td>Provide templates for the layout of a topic and help control the styling of content. You can apply a master page to a topic during topic creation or to an existing topic, and see the master page applied to the topic in preview. From the Author toolbar, click the Master Pages icon to work with master pages. For more information, see <a href="#">Work with master pages</a>.</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Browse sequences</strong></td>
<td>A browse sequence is a linear list of files that helps you logically navigate to the next relevant topic. You can add, edit, and delete browse sequences. In a browse sequence, you can drag-and-drop topics from the Contents panel and TOC, change the sequence of topics, and delete topics. From the Author toolbar, click the Browse Sequences icon to work with browse sequences. For more information, see Create and manage browse sequences.</td>
</tr>
<tr>
<td><strong>Reports</strong></td>
<td>You can generate various reports using the Reports icon on the Author toolbar. You can then view and share reports of broken links, unused files, missing topics, and more. From the Author toolbar, click the Reports icon to work with reports. For more information, see Generate reports.</td>
</tr>
<tr>
<td><strong>Output presets</strong></td>
<td>Allow you to define your preferred output format and content layout. You can also assign search-related settings for your output, such as Enable autocorrect in search box, Show definitions from glossary, and more. From the Output toolbar, click the Output Presets icon to work with output presets. For more information, see Generate output.</td>
</tr>
<tr>
<td><strong>Skins</strong></td>
<td>Allow you to define the appearance of your HTML output. Just as a website template comes with a unique appearance, a RoboHelp skin can add a unique appearance to your output. You can add a logo, choose the color of borders and headings, and do more to make your output look good. You can preview the output in a skin of your choice. From the Output toolbar, click the Skins icon to work with skins. For more information, see Work with skins.</td>
</tr>
<tr>
<td><strong>Labels</strong></td>
<td>Allow you to edit and delete language-specific labels, and undo or redo the edits. You can also export languagewise labels as XML for localization, and import a translated copy for a specific language. From the Output toolbar, click the Labels icon to work with labels.</td>
</tr>
<tr>
<td><strong>Variable sets</strong></td>
<td>A variable set enables you to customize variables (added using the Variables icon in the Author toolbar) for a specific output by overriding the values of the variables. In a newly created variable set, all the variables from the project are listed. From this list, you can override the values of the variables that you want to customize for a specific output. You can create different variable sets to customize the variables for different outputs. From the Output toolbar, click the Variable Sets icon to work with variable sets.</td>
</tr>
<tr>
<td><strong>Condition expressions</strong></td>
<td>A condition expression controls the inclusion of tagged source content or its exclusion from the output. Depending on the condition tags used in an expression, the corresponding source content is included in the output. You can define various tag combinations in the expression using OR, AND, and NOT operators to customize the inclusion or exclusion of content in the output. Condition expressions are not published along with the source content and do not appear in the output. From the Output toolbar, click the Condition Expressions icon to work with condition expressions. For more information, see Configure condition expressions and dynamic content filters.</td>
</tr>
</tbody>
</table>
Start a project
Do one of the following to start a project in RoboHelp:

- Create a project from scratch
- Upgrade a RoboHelp Classic project

Create a project from scratch
Once you've launched RoboHelp, follow these steps to create a project from scratch:

2. In the New Project dialog box, do the following:
   - Title Enter the name of the project.
   - Language From the drop-down list, select your preferred language for the project's content.
   - Save Location Specify the location to save your project. Click to browse your computer and select your preferred folder to save your project in that folder.
3. Click Create.
To add topics and start authoring content in your project, see Work with topics and folders.

**Upgrade a RoboHelp Classic project**

To open a RoboHelp Classic project (.xpj file) in RoboHelp, follow these steps:

1. Choose **File > Upgrade RoboHelp Classic Project**.
2. In the **Open** dialog box that appears, browse your computer, select the desired .xpj project file, and click **Open**.
3. In the **New Project** dialog box, click **Create**.

   The RoboHelp project is now saved as a .rhpj file.

**Save a project**

To save your project or file in RoboHelp, you can do the following:

- To save your project, choose **File > Save All** or press **Ctrl+S**.
- To save your topic, choose **File > Save** or press **Alt+Ctrl+S**.

Alternatively, you can click ☑️ in the upper-left corner of the standard toolbar to save your work.

**Configure project settings**

You can specify and edit the title and language of the project, along with settings such as topic status, colors, tag groups, and version control.

To access the **Project Settings** dialog box, follow these steps:

1. Once you've launched RoboHelp and opened your project, choose **File > Project settings** or press **Ctrl+Shift+/**.
2. In the **Project Settings** dialog box, you can specify settings in tabs such as **General**, **Topic Status**, **Colors**, and more.

   See **Project Settings** for more details.

3. Once you've entered your desired settings, click **Done**.

**Project Settings**

You can find the following tabs in the left panel of the **Projects Settings** dialog box.

- **General**
- **Topic Status**
- **Colors**
- **Tag Groups**
- **Version Control**

**General**

In the **Project Settings** dialog box, the **General** tab is selected by default. To configure the **General** tab, do the following:

1. Specify or edit the name of the project in **Project Title**.
2. In **Language**, click ☑️ to select the desired language for your project.
3. In **Default Stylesheet**, click ☑️ to select a desired style sheet for your project. When you create a topic in your current project, this style sheet is automatically applied to the topic.
In **Default Word Import Settings**, choose the file that contains the default settings for converting Word files to HTML files. To edit this file, choose **File > Import > Word Document** and configure the settings in the **General** tab of the **Word Import Settings** dialog box. For information about the **General** tab, see **General**.

Select **Do not allow inline formatting** to avoid applying new inline formatting. Previously applied inline formatting remains unchanged.

**Topic Status**
You can select a topic status such as **Draft**, **In Progress**, and **Ready for Review** to indicate the current stage of authoring of your topic. You can also add a custom status, rename and delete an existing status, and reorder the statuses. 

*Note:* *The topmost status in the list of statuses is considered as the default status for new topics.*

1. Select the **Topic Status** tab from the left panel of the **Project Settings** dialog box.
2. To create your own status, specify the name of the status in **Add a new status** and click ✪ against it.
   The new status is added to the list of statuses.
3. To rename a status, click its name and modify it.
4. To reorder statuses, click ✽ against a status and drag-and-drop it at the desired position.
5. To delete a status, click ✎ against it.

*Note:* *If you delete a status, all topics that are in the deleted status move to the default status. For example, the default (topmost) status in the **Topic Status** tab is **Draft** and some of your topics are in the **Review** status. If you delete the **Review** status, all topics that were previously in the **Review** status move to the **Draft** status.*

**Colors**
You can add a color and maintain a list of specified colors for your project. You can also rename or delete existing colors.

1. Select the **Colors** tab from the left panel of the **Project Settings** dialog box.
2. To add a color, click ✍ to choose a color, specify a name in **Color Name**, and click ✪.
   The new color is added to the list of colors.
3. To rename a color, click its name and modify it.
4. To reorder colors, click ✽ against a color and drag-and-drop it at the desired position.
5. To delete a color, click ✎ against it.

**Tag Groups**
Tag groups help you group multiple related **What is conditional content** to provide relevant content to a focus group. You can add a tag group to the list of default tag groups. You can also rename and delete existing tag groups.

1. Select the **Tag Groups** tab from the left panel of the **Project Settings** dialog box.
2. To add a tag group, specify its name in **Add a new tag group** and click ✪ against it.
   The new group is added to the list of tag groups.
3 To rename a tag group, click its name and modify it.
4 To delete a tag group, click against it.

Note:
A tag group cannot be deleted if it contains tags. Before you delete a tag group, ensure that all the tags grouped under that tag group are deleted. To delete a tag, in the Condition Tags panel, right-click the tag and click Delete.

Version Control
If your project is connected to Git or SharePoint Online version control system, information about your connection profile is displayed in the Version Control tab.

To configure your connection profile, choose Collaborate > Open Connection > New Connection and provide the necessary information in the Connection Profiles tab.

Import Word documents into a project
You can quickly import a Microsoft Word document into RoboHelp as one or multiple topics and work with it. While importing you can also configure several settings that RoboHelp provides to import and customize the topics based on your needs.

Import a Word document
To import the HTML version of a Word document in your open project, follow these steps:

1 In the Contents panel, do one of the following:
   • Select the desired folder in which you want to import the Word document. Then, select File > Import > Word Document.
   • Right-click the desired folder or click against it and select Import > Word Document.

2 In the Word Import Settings dialog box, select the desired Word document and edit the settings. See Word import settings to know more.

3 Once you've specified your desired settings, click Save Settings. RoboHelp saves these settings and applies them automatically when you import a Word document the next time.

4 Click Import. The HTML version of the selected Word document is generated with the specified settings and included as a topic in the selected folder. The topic is placed in the alphabetical order of topics in the folder, based on its file name. If you don't select a folder while importing, the Word document is imported as a root-level topic in the Contents panel.

Word import settings
When you choose File > Import > Word Document, you can view the Word Import Settings dialog box. Use the following tabs in this dialog box to configure the various settings:

Note:
The Character, Paragraph, Table, and List tabs are enabled only when these styles are applied in the selected Word document.

• General
General
The General tab is selected by default in the Word Import Settings dialog box. In this tab you can specify the following settings:

- **Word Document** Specify the Word document you want to import. To do this, click the icon, select your Word document, and click Open.
- **Load Settings** Select a file with predefined settings for the content you are importing. Click to do this.
- **CSS file for style mapping** Select the style sheet that RoboHelp can use to map styles in the Word document to RoboHelp styles. Click to do this. By default, RoboHelp uses the style sheet specified in project settings.
- **Start new topic from style** Use the following settings to create multiple topics from the content imported from the Word document:
  - **Word Style** Use the drop-down list to specify the style in the Word document that RoboHelp can use to create new topics. For example, to create a topic for every first level heading, select Heading1.
  - **Topic Name Pattern** Specify the naming pattern for the new topics. You can choose from the following options:
    - `<$filename_no_ext><n>` Creates the file names without extension (.docx) and includes a number in sequential order. For example: if the file is ABC.docx, the file names of the new topics will be ABC1, ABC2, and so on.
    - `<$filename_no_ext>-<$paratext>` Creates the file names without the extension (.docx) and includes the initial text of the first paragraph
    - `<$paratext>` Creates the file names with the initial text of the first paragraph
    - **Use only ASCII characters in the generated file names** Select this field to use ASCII characters for the file names.

Advanced
Select the Advanced tab in the Word Import Settings dialog box. In this tab you can specify the following:

- **Convert Word Lists to HTML Lists** Select this field to import numbered or bulleted lists in the Word document as HTML lists in your topic. If you don't select this setting, the look and feel of the Word lists are maintained in the imported content but they don't remain as lists.
- **Import inline styles** Select this field to import the inline styles applied to the content in the Word document.
- **User defined HTML tag** Use the following settings to specify the paragraph style and HTML tag for your imported content:
  - **Paragraph Style** Use the drop-down list to select your desired paragraph style.
  - **HTML Tag** Enter the desired HTML Tag or use the drop-down list to do this. For example, you can specify `<pre>` tag.
Character
Select the Character tab to specify character styles for your imported content. In this tab you can view the following columns:

- **Word Style** The style in the selected Word document.
- **Mapped Style** The style in the imported content. This style is automatically mapped to match its corresponding Word Style. This mapping is based on the css file that you have specified.

For each Mapped Style, you can click next to it and select your desired style. If there is no style to match with the corresponding Word style, RoboHelp provides two default style options - Import Word style and Discard style. Import Word style imports the content with the applied styles. Discard style imports the content without the applied styles. In this case, the default style of RoboHelp is applied.

You can preview the selected Word style and mapped style in **Word Preview** and **Mapped Style Preview**, respectively.

Paragraph
Select the Paragraph tab to specify paragraph styles for your imported content. In this tab you can view the following columns:

- **Word Style** The style in the selected Word document.
- **Mapped Style** The style in the imported content. This style is automatically mapped to match its corresponding Word Style. This mapping is based on the css file that you have specified.

For each Mapped Style, you can click next to it and select your desired style. If there is no style to match with the corresponding Word Style, RoboHelp provides two default style options - Import Word style and Discard style. Import Word style imports the content with the applied styles. Discard style imports the content without the applied styles. In this case, the default style of RoboHelp is applied.

You can preview the selected Word style and mapped style in **Word Preview** and **Mapped Style Preview**, respectively.

Table
Select the Table tab to specify the table styles for your imported content. In this tab you can view the following columns:

- **Word Style** The style in the selected Word document.
- **Mapped Style** The style in the imported content. This style is automatically mapped to match its corresponding Word Style. This mapping is based on the css file that you have specified.

For each Mapped Style, you can click next to it and select your desired style. If there is no style to match with the corresponding Word Style, RoboHelp provides two default style options - Import Word style and Discard style. Import Word style imports the content with the applied styles. Discard style imports the content without the applied styles. In this case, the default style of RoboHelp is applied.

You can preview the selected mapped style in **Mapped Style Preview**.

List
Select the List tab to specify the list styles for your imported content. In this tab you can view the following columns:

- **Word Style** The style in the selected Word document.
- **Mapped Style** The style in the imported content. This style is automatically mapped to match its corresponding Word Style. This mapping is based on the css file that you have specified.

You can preview the selected mapped style in **Mapped Style Preview**.
For each Mapped Style, you can click \( \text{✓} \) next to it and select your desired style. If there is no style to match with the corresponding Word Style, RoboHelp provides two default style options - **Import Word style** and **Discard style**. **Import Word style** imports the content with the applied styles. **Discard style** imports the content without the applied styles. In this case, the default style of RoboHelp is applied.

You can preview the selected Word style and mapped style in **Word Preview** and **Mapped Style Preview**, respectively.

**Work with topics and folders**

A topic is the basic element that contains your content (text, images, multimedia, links, and more) in a project. You can add, edit, format, and delete content in a topic. You can have multiple topics organized in a folder and have multiple folders in a project. This way you can easily maintain structured content in your project.

**Create a folder**

Folders store your topics. You can have multiple folders in a project.

You can create a folder at the root level in the **Contents** panel or a subfolder inside a folder.

To create a root-level folder in an open project:

1. In the Author toolbar, click **Contents**. The **Contents** panel opens.
2. In the **Contents** panel, click \( \text{✚} \) in the upper-right corner of the panel and then click **New Folder**.
3. In the **Folder Details** dialog box, specify the folder name in **Name**.
4. Click **Create**.

   The folder is created at the root level in the **Contents** panel.

   **Note:**

   To create a subfolder inside a folder, select the folder, click \( \text{✚} \) in the upper-right corner of the **Contents** panel, and then click **New Folder**. Or, right-click the folder or click \( \text{✚} \) against it, and choose **New > New Folder**.

**Create a topic**

You can create a topic inside a folder or at the root level in the **Contents** panel.

To create a topic in a folder:

1. In the Author toolbar, select **Contents**. The **Contents** panel opens.
2. In the **Contents** panel, do one of the following:
   - Select the desired folder, then click \( \text{✚} \) in the upper-right corner of the panel, and click **New Topic**.
   - Right-click the folder or click \( \text{✚} \) against it, and choose **New > New Topic**.

   **Note:**

   If you don’t select a folder, the topic is created at the root level in the **Contents** panel.

3. In the **New Topic** dialog box, specify the properties for the topic in different sections as required.

   The **New Topic** dialog box has the same sections as the **Topic Properties** dialog box, except for the File Info section, which is specific to topic properties. For more information, see **Topic properties**.

4. Click **Create**.
The topic is created inside the selected folder in the **Contents** panel. You can create multiple topics inside a folder or a subfolder.

**Add content to or edit a topic**

Once you’ve created a topic, to add or edit content:

1. In the Author toolbar, select **Contents**. The **Contents** panel opens.
2. In the **Contents** panel, expand the folder that contains your topic, and double-click a topic to open it.
   
   **Note:**
   
   To quickly search for the topic you want to edit, click on the top left toolbar or press `Ctrl+F`. In the search dialog box, type the topic title and filename. Double-click to open the relevant topic from the search results.
   
   You can open and work on several topics simultaneously. Each topic opens as a tab in the authoring workspace.
3. In an open topic, you can add or edit text, images, and multimedia content. You can also include expanding text, drop-down text, and create links within topics and to external content. You can also insert and customize a Mini TOC, variables, snippets, and fields.

   See the following resources for more details:
   
   - Work with images and multimedia
   - Format your content
   - Create and manage links
   - Insert and customize a Mini TOC

   **Note:**

   To toggle the display of paragraph markers in a topic, choose **View > Show > Paragraph Markers**.

4. To quickly run a spell check in an open topic, do the following:
   
   a. Choose **Edit > Preferences** or press `Ctrl+Shift+T`.
   
   b. In the **Application Settings** dialog box, select **Enable Spell Checking**.
   
   c. Click **Done**.

   RoboHelp highlights the misspelled words in the topic. Right-click a misspelled word to:
   
   - View suggested spellings. To correct the misspelled word, click the appropriate suggested spelling.
   
   - Ignore the instance of misspelled word by clicking **Ignore**.
   
   - Ignore all the instances of the misspelled word in the topic by clicking **Ignore All**.
   
   - Add the word to the dictionary by clicking **Add to Dictionary**.
   
   - Apply condition tags to the word by clicking **Apply Condition Tags**. In the left pane of the **Apply Condition Tags** dialog box, select the condition tags you want to apply. The selected tags are removed from the left pane and appear in the right pane. You can click against a tag to remove it from the right pane. Click **Apply**.
   
   - Create a snippet by clicking **Create Snippet**. For more information, see Create a snippet.
   
   - Locate the topic file in the **Contents** panel by clicking **Locate in Contents panel**.
   
   - Open the **Topic** tab in the **Properties** panel by clicking **Topic Properties**.

5. To close a topic tab, click **X**.

**Note:**
Save your work before closing a topic. When you click to close a tab, the Save Changes dialog box appears.

*In the Save Changes dialog box, do the following:*

- If your project is connected to a version control system, click Check-in the file and specify a version label. Then, click Save & Check-In.
- If your project is local, click Save to save your work and close the tab.

**Import files and folders**

You can import files and Word documents as topics in a project folder. You can also import folders and Adobe Captivate videos.

To import:

1. In the Author toolbar, select Contents. The Contents panel opens.
2. To import a file:
   - Right-click a folder or click against it, and choose Import > File.
   - In the Open dialog box, select the file you want to import and click Open.

   **Note:**

   The file type drop-down list in the Open dialog box displays the supported file types, for example, all files, topics, style sheets, and more. Use this drop-down list to filter files according to its type during file selection.

   The selected file is copied as a topic inside your project folder.

3. To import a folder:
   - Right-click a folder or click against it, and choose Import > Folder.
   - In the Open dialog box, select the folder you want to import and click Select Folder.

   The selected folder and its files are copied inside your project folder.

4. To import the HTML version of a Word document, see Import Word documents into a project.
5. To import an Adobe Captivate video, see Import and insert an Adobe Captivate video.

**Link files and folders**

You can link files and folders from your system to your project folder.

To link:

1. In the Author toolbar, select Contents. The Contents panel opens.
2. To link a file:
   - Right-click a folder or click against it, and choose Link > Link File.
   - In the Open dialog box, select the file you want to link and click Open.

   The file is copied inside the selected folder. RoboHelp notifies that the copied/project file is linked to the original/source file. A green arrow precedes the project file in the Contents panel, indicating in-sync status.

   **Note:**
If modifications are made in the project or the source version, the green color of the preceding arrow changes to red, indicating out-of-sync status. To sync linked files:

- From source to project: Right-click the topic or click against it, and click Sync > From Source to Project.
- From project to source: Right-click the topic or click against it, and click Sync > From Project to Source.

A sync success or failure notification appears.

To remove the link between the project and source versions, right-click the topic or click against it, and click Remove Link. This also removes the arrow preceding the project file in the Contents panel.

3 To link a folder:
   a Right-click a folder or click against it, and choose Link > Link Folder.
   b In the Open dialog box, select the folder you want to import and click Select Folder.

The selected folder and its files are copied inside your project folder.

4 To import the HTML version of a Word document, see Import Word documents into a project.

5 To import the HTML version of a FrameMaker document, see Import FrameMaker documents into a project.

6 To import an Adobe Captivate video, see Import and insert an Adobe Captivate video.

Create HTML topics

Note:
Applicable only for Word and FrameMaker files.

To create HTML topics:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 To create HTML topics from a Word or a FrameMaker file, right-click the file or click against it, and click Update HTML.

   RoboHelp creates a folder with the same name as the Word or FrameMaker file and places all HTML topics and referenced assets inside the new folder.

Note:
To create HTML topics, RoboHelp considers the settings specified in the following fields in the Project Settings dialog box (General tab):

- For Word documents: Default Word Import Settings
- For FrameMaker documents: Default FrameMaker Import Settings

If a folder has multiple files, use the following options to simultaneously create HTML topics from all files:

- For Word files, right-click the folder and choose Word Documents > Update All.
- For FrameMaker files, right-click the folder and choose FrameMaker Documents > Update All.

Rename a topic or a folder

You can rename a topic or a folder in your project without having to open it.

To rename:

1 In the Author toolbar, select Contents. The Contents panel opens.
2 To rename a folder, right-click it or click ⋯ against it, and click Rename.

To rename a topic’s filename, first expand the folder that contains the topic you want to rename. Then, right-click the topic or click ⋯ against it, and click Rename.

3 In the Rename dialog box, specify the new name and click Done.

Note:

To view the new filename of the topic you renamed, choose View > Show and deselect Topics by Title. From the default title view, RoboHelp switches to the filename view and displays all topics by filename.

Create a duplicate topic

To create a duplicate topic in the same folder:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 To create a duplicate topic, first expand the folder that contains the topic you want to duplicate. Then, right-click the topic or click ⋯ against it, and click Duplicate.

3 In the Duplicate dialog box, specify a title and filename for the duplicate topic, and click Done. The duplicate topic created in the same folder as the original topic.

Delete a topic or a folder

To delete a topic or a folder in your open project:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 To delete a folder, right-click it or click ⋯ against it, and click Delete.

To delete a topic, first expand the folder that contains the topic you want to delete. Then, right-click the topic or click ⋯ against it, and click Delete.

3 Click Yes in the Confirm dialog box. The topic or the folder is deleted.

Collapse all folders in the project

To collapse all expanded folders in your project:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 Right-click or click ⋯ against any expanded folder or any topic inside an expanded folder, and click Collapse All.

All expanded folders in your project collapse.

Locate a topic in a TOC

To locate a topic in a TOC:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 Right-click or click ⋯ against a topic and hover over Locate in TOC.

RoboHelp displays the TOCs to which the topic belongs. Click the TOC in which you want to locate the topic.

The Table of Contents panel displays the TOC in expanded view in which, the topic is highlighted.

Note:

*If a topic is not included in any TOC, the Locate in TOC option is not visible.*
Show topics or folders in Windows Explorer

To show the location of specific topics or folders in Windows Explorer:

1. In the Author toolbar, select Contents. The Contents panel opens.
2. Right-click or click against a folder or a topic inside an expanded folder, and click Show in Explorer.

Windows Explorer opens, displaying the location of the folder or the topic.

Set topic properties

For information about setting topic properties, see Set topic properties.

Topic tab context menu options

You can open and work on several topics simultaneously. Each topic opens as a tab in the authoring workspace. You can right-click a topic tab to use the following options:

Close Closes the current file.

Close Others Closes all open files except for the current file.

Close All Closes all open files.

While closing multiple open files, RoboHelp prompts you to save your changes. In the Save Changes dialog box, you can save a specific file or all files. By default, all open files are selected for saving. If you do not want to save a file, click to deselect it. Click Save.

Locate in Contents panel Opens the Contents panel if it’s not open already, and highlights the topic.

Work with context-sensitive help

What is context-sensitive help

A context-sensitive help topic provides information about the user interface of an application relative to the task your user performs. For example, context-sensitive help topics provide details about fields and controls in dialog boxes, descriptions of windows or screen objects, and explanations of messages. Your users access a context-sensitive help topic by pressing F1, clicking a Help button, selecting from a menu, or clicking a question-mark icon.

What is a map file

In RoboHelp, you work with context-sensitive help topics through map files in Output view. You can create, assign, unassign, edit, import, and export map files. A pairing of a map ID and map number for each topic is saved in map files.

<table>
<thead>
<tr>
<th>MAP ID</th>
<th>MAP NO</th>
<th>TOPIC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type and press enter to add</td>
<td>Map Number</td>
<td>+</td>
</tr>
<tr>
<td>ID_SetupScreen</td>
<td>101</td>
<td>SetupScreen</td>
</tr>
</tbody>
</table>

A map ID and map number pairing inside a map file
Map ID Assign a unique map ID to each topic to display it in the CSH. For example, ID_SetupScreen.

Map number A numeric value associated with a topic. Map numbers are used with applications to specify a topic for calling context-sensitive help. For example, 101.

Whether application developers use map numbers, map IDs, or both depends on the programming language they use.

Topic You can assign or unassign a topic against a map ID and number. For example, SetupScreen.

Author and developer tasks
Map files are used by authors and developers to build a context-sensitive help for an application.

- **Author** Writes the Help topics that describe how to use application components such as windows, dialog boxes, fields, and controls.
- **Developer** Builds the components (windows, dialogs, fields, controls) that make up the application.

An author can generate map files containing map IDs and give them to the developer. Or, an author can obtain map files from the developer.

To share map files, you can **Export a map file** as a .h file in this format:

```
#define ID_SetupScreen 101
```

Create a map file
To create a map file:

1. In the Output toolbar, click **Map Files**.
2. In the **Map Files** panel, click the top right corner and then click **New Map File**.
3. In the **New Map File** dialog box, specify the name of the map file.
   
   **Note:**
   
   *When creating filenames, use underscores instead of spaces, and avoid using these illegal characters: \ / : * ? < > | # "$ & [ ]
   
   4. Click **Done**.

RoboHelp places the map file in alphabetical order of filenames in the **Map Files** panel and opens the map file editor.

Edit a map file
To edit a map file:

1. In the Output toolbar, click **Map Files**.
2. In the **Map Files** panel, double-click the map file you want to edit. Or choose **Options > Edit** against the map file.

   RoboHelp opens the map file editor with **Contents** panel at the left and the fields **Map ID**, **Map No.**, and **Topic** at the right.

3. To map topics, you can follow two approaches.

   **Approach 1:** To let RoboHelp automatically assign map IDs and map numbers, from the **Contents** panel, drag a topic and drop it below the field names in the map file editor.
RoboHelp automatically maps the topic name as map ID. For the first topic, the default map number is 1. You can edit the map ID and map numbers.

Note:

*Specify map file settings, if specified, are applicable to all topics that are dragged and dropped.*

**Approach 2:** If you want to specify a custom map ID or map number and separately assign a topic, do the following:

a. Type a map ID in the **Map ID** field and press **Enter**.

b. Type a map number in the **Map No.** field and press **Enter**.

c. Assign a topic by clicking ✴ at the right side of the row.

d. In the **Insert Topic** dialog box, search for a topic or select it from the **Contents** or **Recently Used** drop-down sections.

e. Click **Insert**.

The topic is assigned to the map ID and number, and the topic filename appears under the **Topic** field.

To unassign a topic, click ✗ next to the topic name.

To delete an entire row of map ID, map number, and topic, click ❌ in that row.

Note:

*Specify map file settings, if specified, are not applicable to topics that are assigned separately or to mappings defined before the settings were specified.*

4 You can modify both Map ID and Map No. fields.

**Specify map file settings**

Map file settings apply to topics that are dragged and dropped in the map file editor. To specify map file settings:

1. In the Output toolbar, click **Map Files**.
2. In the Map Files panel, right-click a map file and click **Options**. Or, against the map file, choose ⋰七星 > **Options**.
3. In the Mapping Options dialog box, do the following:
   - **Prefix Map ID With** To automatically add a prefix to all new map IDs, specify the prefix in this field.
   - **Start Map Number From** To automatically start map numbers from a specific number, specify the number in this field.
   - **Create Map ID in uppercase** Select this field to automatically create map IDs in uppercase.
4. Click **Done**.

**Rename a map file**

To rename a map file:

1. In the Output toolbar, click **Map Files**.
2. In the Map Files panel, right-click a map file and click **Rename**. Or, against the map file, choose ⋰七星 > **Rename**.
3. In the **Rename** dialog box, specify a new name for the map file.
4. Click **Done**.

The updated name of the map file is shown in the Map Files panel.
**Import a map file**
You can import a map file received from Author and developer tasks. To import a map file:

1. In the Output toolbar, click Map Files.
2. In the Map Files panel, click + at the top right corner and click Import.
3. In the Import dialog box, select the map file you want to import.
4. Click Open.

RoboHelp places the imported map file in alphabetical order of filenames in the Map Files panel.

**Export a map file**
You can export a map file to share it with Author and developer tasks. To export a map file:

1. In the Output toolbar, click Map Files.
2. In the Map Files panel, right-click a map file and click Export. Or, against the map file, choose ⋮ ⋮ ⋮ > Export.
3. In the Export dialog box, select a location at which you want to save the map file.
4. Click Save.

RoboHelp exports the map file at the selected location.

**Delete a map file**
To delete a map file, press Delete. Or do the following:

1. In the Output toolbar, click Map Files.
2. In the Map Files panel, right-click a map file and click Delete. Or, against the map file, choose ⋮ ⋮ ⋮ > Delete.
3. In the Confirm dialog box, click Yes to confirm the deletion.

The map file is deleted.

**Locate a map file on your computer**
To see the location of a map file on your computer, do the following:

1. In the Output toolbar, click Map Files.
2. In the Map Files panel, right-click a map file and click Show in Explorer. Or, against the map file, choose ⋮ ⋮ ⋮ > Show in Explorer.

Windows Explorer opens to display the map file and its location.

**Generate reports**
In Adobe RoboHelp, you can generate a variety of reports to monitor, compare, and optimize the content of your project. You can customize your report and display the desired columns, reorder information, and filter project components. You can then quickly print a report or download it as a .csv file.
Types of reports
You can generate the following types of reports in RoboHelp:

- **Topic List**
  The **Topic List** report displays the list of topics in a project and allows you to view and manage topics. For each topic, you can view the filename, title, status, author, and the Table of Contents it belongs to. You can view the folder containing the topic, condition tags applied to a topic and its content, style sheets and master pages applied to a topic, see also added to a topic, and the last modified date and time. You can also view if a topic has index keyword tags associated with it and if the topic is included in search.

  In this report, you can edit, configure topic properties, and delete a topic or multiple topics. To do this, select the desired topics. Right-click the selected topics and choose **Edit** to open and edit them. You can also select **Properties** to configure the topic properties of the selected topics or select **Delete** to delete the topics.

- **Project Status**
  The **Project Status** report allows you to view the status of each topic in your project. This way you can generate information on the total number of topics completed, in progress, and ready for review.

- **Topic Properties**
  The **Topic Properties** report allows you to view the various topic properties associated to each topic in your project. You can view a topic’s status, author, condition tags, style sheet, Table of Contents, index keywords, and search keywords associated with it.

- **Topic References**
  In the **Topic References** report, you can view the incoming links in each topic. This way you can view the references that are leading to a topic.

- **External references**
  In the **External References** report, you can view the links that are referred to resources outside your project. This way you can test the links in topics that lead to external content.

- **Search Keywords**
  The **Search Keywords** report lists the keyword tags applied in each topic.

- **Table of Contents**
  The **Table of Contents** report lists the details of the selected Table of Contents in your project. You can view the links in the topics, the title and file type such as book or page, and if it is hidden or not in the Table of Contents output.

- **Index**
  The **Index** report lists all the index keyword tags applied across topics in your project. You can view the keywords and the topics that contain them.

- **Glossary**
The **Glossary** report lists the terms and their definitions in the selected glossary. You can also view the topics that the terms are added in and the file types.

- **Condition Tags**
  The **Condition Tags** report lists the condition tags in your project with the tag name and color. For each tag, you can view the group of condition tag, the topic, and file type that the condition tag is applied in.

- **Variables**
  The **Variables** report lists variables in your project with their values. For each variable and its value, you can view the topic and file type that the variable is used in. This way you can find variables that are used in a topic or those that are not used in any topic. Before you delete a variable, you can locate the topics in which the variable is used and delete references to that variable.

- **Snippets**
  The **Snippets** report lists the snippets defined in your project. You can view the topic and the file type each snippet is used in.

- **Images**
  The **Images** report lists the image file names that are used in your project. For each image file name, you can view the topic and the file type that it is in.

- **Multimedia**
  The **Multimedia** report lists the multimedia file names in your project. For each multimedia file name, you can view the topic and the file type it is in.

- **Stylesheets**
  Use the **Stylesheets** report to view the list of style sheets in your project. For each style sheet, you can view the topic and the file type it is in.

- **Broken Links**
  The **Broken Links** report lists topics that contain broken links. You can view the topic, broken link path, and link type for each broken link in your project.

  **Note:**
  
  *In a multi-author and version-controlled environment, ensure that you don’t link to topics that have been moved, renamed, or removed as these links are broken.*

- **Unused Files**
  The **Unused Files** report lists the various files that are not used in your project. For each unused file, you can view its file name and the folder it is in.

- **Unreferenced Topics**
  The **Unreferenced Topics** report lists the topics in your project that are not linked to in the Table of Contents, index, browse sequences, or in other topics. You can use this report to identify:

  - Inaccessible topics that are not linked from other topics
  - Topics excluded from the Table of Contents
  - Topics without index

  **Note:**
Few topics do not use references such as context-sensitive Help topics. For example, if you create window-level context-sensitive Help, topics are accessible only when you press F1 or click Help. In this case, you don't require references.

Open a report
To open or generate a report in RoboHelp, follow these steps:

1. In an open project, click Reports on the Author toolbar.
2. In the Reports panel, double-click the type of report that you want to generate. Alternatively, click Options next to the desired report type and choose Open. To know more about the various types of reports in RoboHelp, see Types of reports.

   Note:
   To view the latest report after you've edited your project, click the Refresh icon on the toolbar.

Customize a report
You can customize a report using the Filters panel on the right side of the screen. In this panel, you can view the type of report, select a criteria to order information, filter information, and select the columns to view in the report. To customize your report, use the following options in the Filters panel:

**Type**
Under Type, you can view the type of report that is open. To know more about the types of reports in RoboHelp, see Types of reports.

**Order By**
You can select a criteria to order the information in your report using the options under Order By. Based on the type of report, you can find different options such as Status, Keyword, Topic, and more.

**View**
By default, a report is viewed as a table. Reports such as Topic References and Project Status can also be viewed as a graph and pie chart, respectively. Use the options under View to change the appearance of the report.

**Filter**
Under Filter, use the drop-down lists of various project components to specify information in the report. You can also select multiple options in each drop-down list.

For Index, Glossary, Condition Tags, Variables, Snippets, Images, Multimedia, and Stylesheets reports, you can also select Used in <project component> to view the files that the project component is applied in.

**Columns**
You can add or remove columns in your report using the options in Columns. These columns are based on the type of report that you have selected. Select a column to view it and deselect it to remove it in the report.

Download a report
To download a report with the applied settings in RoboHelp, follow these steps:

1. Click Reports on the Author toolbar.
2. In the **Reports** panel, double-click the type of report you want to generate and open it. Alternatively, click **Options ***** next to the desired report type and choose **Open**.

3. To customize your report, use the **Filters** panel on the right side of the screen. For details, see [Customize a report](#).

4. To download your report, click **Download ↓** on the toolbar. You can also click **Options ***** next to the desired report type and choose **Download**.

   The report is then saved as a .csv file.

**Print a report**

To print a report with the applied settings in RoboHelp, follow these steps:

1. Click **Reports ⇨** on the Author toolbar.

2. In the **Reports** panel, double-click the type of report you want to generate and open it. Alternatively, click **Options ***** next to the desired report type and choose **Open**.

3. To customize your report, use the **Filters** panel on the right side of the screen. For details, see [Customize a report](#).

4. To print your report, click the **Print** icon ⇨ on the toolbar. You can also click **Options ***** next to the desired report type and choose **Print**.

---

*Last updated 2/20/2019*
Chapter 3: Editing and formatting

Format your content

Once you’ve created topics in Adobe RoboHelp, you are set to add text, images, tables, videos, links, and more. Format inline text, characters, paragraphs, and tables, and display them your way. You can also add symbols, HTML elements, expanding text, drop-down text, and more. You can format your content using the formatting options in the standard toolbar and the General tab in the Properties panel. To quickly preview your changes, click Preview in the Standard toolbar (upper-right corner of the screen).

Apply formatting

To format your content, use the formatting options available in the:

- Standard toolbar
- General tab in Properties panel

Standard toolbar

The standard toolbar contains the following options:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Formatting option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon" alt="Bulleted List Styles" /></td>
<td>Bulleted List Styles</td>
<td>Use this option to format content as an unordered list. For more information, see Work with lists.</td>
</tr>
<tr>
<td><img src="icon" alt="Numbered List Styles" /></td>
<td>Numbered List Styles</td>
<td>Use this option to format steps, activities, and tasks as an ordered list. For more information, see Work with lists.</td>
</tr>
<tr>
<td><img src="icon" alt="Multilevel List Styles" /></td>
<td>Multilevel List Styles</td>
<td>Use this option to format content as an unordered or ordered list of multiple levels. For more information, see Work with lists.</td>
</tr>
<tr>
<td><img src="icon" alt="Insert Table" /></td>
<td>Insert Table</td>
<td>Add tables to organize data and showcase content in a simplified format. You can organize text and multimedia in a table, highlight them using different colors, and do more. For more information, see Work with tables.</td>
</tr>
<tr>
<td><img src="icon" alt="Insert Image" /></td>
<td>Insert Image</td>
<td>Add images in various formats, such as PNG, JPEG, WEBP, and SVG, and enrich your content. You can add images from your project and local files, and web links. For more information, see Work with images and multimedia.</td>
</tr>
<tr>
<td><img src="icon" alt="Insert Multimedia" /></td>
<td>Insert Multimedia</td>
<td>Add videos, including Adobe Captivate videos, from your computer, YouTube, and Vimeo. For more information, see Add videos.</td>
</tr>
</tbody>
</table>
**Insert Link**
You can add hyperlinks to internal content (from other topics in your project) and to external content (from local files, emails, and web pages). For more information, see Create and manage links.

**Insert Bookmark**
You can select content and insert it as a bookmark by clicking Insert Bookmarks. You can use these bookmarks to create intra-topic links.

**Insert Variables/Snippet/Fields**
Add variables, snippets, and fields in your topic to single-source content and quickly update different types of outputs. For more information, see Create and use variables for easy updates and Single-source with snippets.

**Insert HTML Elements**
Add HTML elements, such as Horizontal Line, iframe, and Text Box to control the appearance and layout of content.

**Insert Symbol**
Add various symbols to your text. Choose from various fractional numbers, shapes, and icons.

**Create Expanding Text**
Use this option to add extra text adjacent to specific content portions. You can click the highlighted content portions in the output to show/hide the display of the additional text. For more information, see Work with expanding text.

**Create Drop-down Text**
Use this option to add drop-down text to specific content portions. You can click the highlighted content portions in the output to show/hide the display of the drop-down text. For more information, see Work with drop-down text.

**Insert Mini TOC Placeholder**
Use this option to insert a Mini TOC placeholder in your topic or master page. For more information, see Insert and customize a Mini TOC.

### General tab in Properties panel

Use the **General** tab in the **Properties** panel to format content. You can edit font type and style, character spacing, indent, color, and more. You can also add borders and customize backgrounds.

To format content:

1. In the Author toolbar, select **Contents**. The **Contents** panel opens.
2. In the **Contents** panel, double-click a topic to open it. You can view the **Properties** panel on the right side of the screen.

   **Note:**

   *If you are unable to view the **Properties** panel, select **View > Properties Panel**.

   In the **Properties** panel, the **General** tab is selected by default.

3. In your topic, click or select an element to view its type in the **Type** field. For example, selecting a topic title displays **h1** (Heading 1) as the type and a paragraph displays **p** as the type.
For a selected element displayed in the **Type** field:

- You can edit the formatting, and then apply the same formatting to all elements of the same nature across your project, and update the style sheet. To do so, click the **Update Style** icon next to the **Type** field. For example, the default font (according to the style sheet) of a topic title is Arial 20 points. You changed the font to Adobe Clean 24 points. To apply Adobe Clean 24 points font to all topic titles in your project, and update the style sheet, click **Update Style**.

- You can clear the current formatting by clicking the **Clear Formatting** icon next to the **Type** field. For example, the default font of a topic title (according to the style sheet), was Arial 20 points. You changed the font to Adobe Clean 24 points but did not update the style sheet. To restore the default font to Arial 20 points (according to the style sheet), click **Clear Formatting**.

4 To format text, click the **Font** drop-down section. This panel has the following options:

- **Font Family** Use the drop-down list to select your desired font type.
- **Font Style** Use the drop-down list to select your desired font style such as italic, oblique, and more.
- **Font Size** Enter your desired font size or use the increment and decrement buttons to automatically change the current size by .5 units. From the units drop-down list, you can choose the unit as pixel, percentage, and more.
- **Color** Click [ ] to choose your preferred font color. You can also enter the color code in this field. Black is the default text color.
- **Text Transform** Use the options in the drop-down list to easily capitalize, change upper or lowerscases, and more.
- **Inline formatting options** Select the content and click the icons to apply inline formatting such as strikethrough, underline, bold, italics, superscript, and subscript.
- **Character Spacing** Enter your desired character spacing or use the increment and decrement buttons to automatically increment the current spacing by .5 units. From the units drop-down list, you can choose the unit as pixel, percentage, and more.

5 To change the alignment of content, click the **Alignment** drop-down section. This panel has the following options:

- **Alignment options** Align your content left, center, right, or justify.
- **Line Height** Use the drop-down list to choose a line height.
- **Decrease/Increase Indent** Use the respective buttons to change the distance between margin and content.

6 To add and edit borders to your content, click the **Border** drop-down section. This panel has the following options:

- **Border Style** Use the drop-down list to select your preferred border style. You can find options such as dotted, dashed, double, and more.
- **Color** Click [ ] to select the preferred border color or specify RGB codes.
- **Width** Enter the numerical value for the width of your border and choose the unit from the **Unit** drop-down list.

Use the following icons to apply the border to specific content edges:

- Applies border to all four edges.
- Applies border only to the top edge.
- Applies border only to the right edge.
- Applies border only to the bottom edge.
- Applies border only to the left edge.
To format the layout of your content, click the Layout drop-down section. This panel has the following options:

- **Height** Specify the height of the content. You can also use the Increment and Decrement buttons to increase and decrease the height. Select the unit from the Unit drop-down list.

- **Width** Specify the width of the content. You can also use the Increment and Decrement buttons to increase and decrease the width. Select the unit from the Unit drop-down list.

- **Margin**
  - Select the unit of the margin from the Unit drop-down list.
  - You can also specify values for the top, bottom, left, and right margins, and use the Increment and Decrement buttons to increase and decrease each of the four margin values.
  - To link all four margin values so that updating the value of one margin syncs all margin values, click .
  - To keep four different margin values so that updating the value of one margin does not sync all margin values, click .

- **Padding**
  - Select the unit of the padding from the Unit drop-down list.
  - You can also specify top, bottom, left, and right padding values, and use the Increment and Decrement buttons to increase and decrease each of the four padding values.
  - To link all four padding values so that updating the value of one padding syncs all padding values, click .
  - To keep four different padding values so that updating the value of one padding does not sync all padding values, click .

- **Float** Used for positioning and layout on web pages. Select a float value from the drop-down list:
  - **inherit** Indicates that the element inherits the float value of its parent
  - **none** Indicates that the element does not float (is displayed where it occurs in the text)
  - **left** and **right** Indicate the direction of the container to which the content floats

- **Clear** Specifies which elements can float beside the cleared element and on which side. Select a clear value from the drop-down list:
  - **inherit** Indicates that the element inherits the clear value of its parent
  - **both** Indicates that no floating elements are allowed on either left or right side
  - **none** Indicates that floating elements are allowed on both the left and right sides
  - **left** and **right** Indicate that no floating elements are allowed on the left or the right side

To format your content background, click the Background drop-down section. This panel has the following options:

- **Shading** Click  to choose your preferred background color. You can also enter the color code in this field. Black is the default background color.

- **Image** Insert a background image by browsing through your computer.

- **Width** Specify the width of the background image.

- **Maintain aspect ratio icon** Click to maintain the aspect ratio of the background image. If you change one component (width/height) of the image, the other component (height/width) is automatically changed according to aspect ratio.

- **Height** Specify the height of the background image.
Editing and formatting

- **Reset to default icon** Click to reset to the original height and width of the background image.

9 To copy the formatting of selected content, choose *Edit > Copy Formatting*. Then, select the content to which you want to apply the copied formatting.

10 To remove the formatting of selected content, choose *Edit > Clear Formatting*. The selected content displays the default formatting.

11 To save the changes, click the *Save* icon in the standard toolbar.

**Work with lists**

You can create bulleted or numbered lists to present your content in a neat and easy-to-read manner. You can then adjust the indent, add color, add a paragraph within a list, and more. You can even match the bullet color to its text color.

To create a list:

1 Select the desired text and do one of the following:
   - To create a bulleted list, click *Bulleted List Styles* in the standard toolbar and choose a style from the drop-down list.
   - To create a numbered list, click *Numbered List Styles* in the standard toolbar and choose a style from the drop-down list.
   - To create a numbered or bulleted list containing multiple levels, do the following:
     1 Click *Multilevel List Styles* in the standard toolbar and choose a style from the drop-down list.
     2 To create a sublevel list, select the text and press *Tab*. Or, from the *Properties* panel > *General* tab > *Alignment* drop-down section, click the *Increase Indent* icon.
   3 To remove list formatting, click , , or in the standard toolbar, and select the *None* style.

**Work with tables**

In RoboHelp, you can insert tables to organize and present content in a structured manner. You can also edit colors, indent, customize borders, and more for tables.

To insert a table:

1 In an open topic, place the cursor at the desired location and click *Insert Table* in the standard toolbar.

2 To select the required number of rows and columns, drag your cursor over the drop-down table grid. The selected rows and columns are highlighted in blue. Click to insert the selected rows and columns in your topic.

3 Right-click the table to use the following options:
   - **Cell** To insert, delete, merge, and split cells.
   - **Row** To insert and delete rows.
   - **Column** To insert and delete columns.
   - **Delete Table** To delete the table.
   - **Select Table** To select all the cells that have content. Empty cells are not selected.
   - **Table Properties** To view table properties inside the *Properties* panel > *General* tab. You can specify, increase, or decrease the width and height of the table, column, and row. You can also choose to add a caption above or below the table.
• **Apply Condition Tags** Click to apply condition tags to the table. In the left pane of the **Apply Condition Tags** dialog box, select the condition tags you want to apply. The selected tags are removed from the left pane and appear in the right pane. You can click \* against a tag to remove it from the right pane. Click **Apply**.

**Work with expanding text**

In a content-heavy topic, you can use expanding text to add extra text adjacent to specific content portions. You can click the highlighted content portions in the output to show/hide the display of the additional text.

1 In an open topic, select the text you want to expand, and then click **Create Expanding Text** in the standard toolbar.

The selected text becomes the title of the expanding text. A placeholder for the content appears.

2 In the placeholder, specify the content of the expanding text.

3 Manage expanding texts in the following ways:
   - Toggle the display of the boundary of all expanding text placeholders in your topic: Choose **View > Show > Expanding/Drop-down Text Boundary**.
   - Toggle the display of a specific expanding text placeholder: Right-click the text header and click **Show Expanding Text** or **Hide Expanding Text**.
   - Remove an expanding text: Right-click the text header and click **Remove Expanding Text**.
   - Collapse or expand an expanding text: Double-click the text header.
   - Collapse or expand all expanding texts in your topic: Right-click any expanding text header and click **Collapse All Text** or **Expand All Text**.
   - Set separate text for the title of an expanding text in collapsed state: Click the expanding text. In the **Properties** panel > **General** tab > **Text when collapsed** field, type the new title. As expanding texts are collapsed by default, in your output, the new title is displayed in the collapsed state. On expanding the text, the original text on which the expanding text was created is displayed.

4 Click the **Save All** icon at the left side of the standard toolbar.

**Work with drop-down text**

In a content-heavy topic, you can add drop-down text to specific content portions. You can click the highlighted content portions in the output to show/hide the display of the drop-down text.

1 In an open topic, select the text you want to drop down, and then click **Create Drop-down Text** in the standard toolbar.

The selected text becomes the title of the drop-down text. A placeholder for the content appears below the selected text.

2 In the placeholder, specify the content of the drop-down text.

3 Manage drop-down texts in the following ways:
   - Toggle the display of the boundary of all drop-down text placeholders in your topic: Choose **View > Show > Expanding/Drop-down Text Boundary**.
   - Toggle the display of a specific drop-down text placeholder: Right-click the text header and click **Show Drop-down Text** or **Hide Drop-down Text**.
   - Remove a drop-down text: Right-click the text header and click **Remove Drop-down Text**.
• Collapse or expand an drop-down text: Double-click the text header.

• Collapse or expand all drop-down texts in your topic: Right-click any drop-down text header and click Collapse All Text or Expand All Text.

• Set separate text for the title of a drop-down text in collapsed state: Click the drop-down text. In the Properties panel > General tab > Text when collapsed field, type the new title. As drop-down texts are collapsed by default, in your output, the new title is displayed in the collapsed state. On expanding the text, the original text on which the drop-down text was created is displayed.

• Add or edit twisty images.

4 Click the Save All icon at the left side of the standard toolbar.

Add or edit twisty images

You can add twisty images–an image each for expanded and collapsed states–to expanding and drop-down texts, and topic TOCs. In preview and in your output, the respective images appear in expanded and collapsed states.

To add twisty images:

1 In an open topic, click an expanding or drop-down text, or the word Caption in a topic TOC.

2 In the Properties panel > Styles tab, select Hyperlink Styles from the drop-down list.

3 From the list of hyperlink styles displayed, click a style to apply it to the selected item. If the applied style has the twisty feature set, the twisty images are displayed in the preview and output.

4 Do one of the following:

• Click against the applied style to edit it. In the Styles panel of the style sheet editor, in Hyperlink Styles, the applied style opens for editing.

• From the Contents panel, expand assets > css. From the list of style sheets displayed, double-click one or click against it. Then, expand the Hyperlink Styles and click the applied style.

5 In the Properties panel of the style sheet editor, expand Twisties.

6 Against the Image when expanded and Image when collapsed fields, click to select and insert the required image.

7 Click to place images at the start of text (default) or to place images at the end of text.

8 Click the Save All icon at the left side of the standard toolbar.

Note:

After you set twisty images for a particular hyperlink style, you can apply the same twisty images to different items by just applying the same hyperlink style from the Styles panel.

Work with images and multimedia

Use RoboHelp’s powerful workspace to easily add images and multimedia to your topics. Insert images in various formats, videos from your computer, YouTube, and Vimeo, and audio clips. With the latest RoboHelp interface, you can insert and preview YouTube videos in a click. You can also add image thumbnails that can be zoomed when clicked in the output. Publish rich and creative content with images and multimedia while you experience the smoothest workflows of authoring, publishing, and viewing your project output.

Note:
If an image or video is available in the Contents panel, you can drag-and-drop it to the desired location in your open topic.

**Add images**

To add an image:

1. In the Author toolbar, select Contents. The Contents panel opens.
2. Double-click a topic in the Contents panel to open it. Place the cursor at the location in which you want to insert an image.
3. In the standard toolbar at the top of the screen, click the Insert Image icon to add an image.
4. In the Insert Image dialog box, select an image using one of the following options:
   - **Project Files** Browse through the project files in the Contents or the Recently Used drop-down section.
   - **Local Files** Browse through your computer or specify the path of the image file.
   - **Web Link** Specify the URL of the image.
   
   You can preview the selected image in the preview area of all three insert image options.

5. Click Insert. The selected image is added in the topic.

**Edit image properties**

To edit the properties of an image:

1. In an open topic, click the desired image.
2. On the right side of the screen, in the Properties panel > General tab, the Type field shows Img. Other fields in the panel display the properties of the image.
3. Use the following fields to modify the properties of the image:
   - **Source** Displays the path of the folder from which the image was uploaded.
   - **Alternate Text** Specify an alternate text for the image. Terms used in this field improve the searchability of the image.
   - **Image Title** Specify a title for the image, which is displayed when you hover over the image.
   - **Width** Specify the width of the image.
   - **Maintain aspect ratio icon** By default, RoboHelp maintains the aspect ratio of an image. If you change one component (width/height) of the image, the other component (height/width) is automatically changed according to aspect ratio. To disable maintain aspect ratio, click the icon.
   - **Height** Specify the height of the image.
   - **Reset to default icon** Click to reset to the original height and width of the image.
   - **Text wrapping** Click the Left or Right icons to choose the direction of alignment of the image with respect to text. The default is None.
   - **Use Thumbnail** Select to use the image as a thumbnail in the output and specify its width and height.

For information about the drop-down sections in the General tab, see General tab in Properties panel.

**Create an image link**

You can link an image to internal content, such as a topic in your project, and to external content such as websites and documents. For information about inserting a link, see Insert a link.
Add videos
You can add videos in a topic in the following ways:

- From your computer, YouTube, or Vimeo
- Import and insert an Adobe Captivate video

From your computer, YouTube, or Vimeo
1. In the Author toolbar, select Contents. The Contents panel opens.
2. Double-click a topic in the Contents panel to open it. Place the cursor at the location in which you want to insert a video.
3. In the standard toolbar, select the Insert Multimedia icon and one of the following options from the drop-down list:
   - Video File To select a video from your computer.
   - YouTube To select a YouTube video.
   - Vimeo To select a Vimeo video.
4. In the Insert Multimedia dialog box, select a video using one of the following options:
   - Project Files Browse through the project files in the Contents or the Recently Used drop-down section. Or, quickly search for a video by filename. RoboHelp searches for the specified filename in the Contents panel.
   - Local Files Browse through your computer or specify the path of the video.
   - Web Link Specify the URL of the video.
You can preview the selected video in the preview area of all three insert video options.
5. Click Insert. The selected video is added in the topic.

Import and insert an Adobe Captivate video

Note:
To be able to insert an Adobe Captivate video in your topic content, you must first import it in your project.

1. In the Author toolbar, select Contents. The Contents panel opens.
2. In the Contents panel, do one of the following to import a video in your project:
   - Select the desired folder and choose File > Import > Adobe Captivate Demo.
   - Right-click a folder or click *** against it, and choose Import > Adobe Captivate Demo.
3. In the Open dialog box, select the video you want to import.
Adobe Captivate stores video output as a collection of files and folders. To automatically import all the associated files as a zipped file, select index.html or index.htm from the output folder. Or, you can select the .zip or .cpz file of the entire output folder.
Click Open.
RoboHelp places the zipped video in .cpz format in alphabetical order of filenames in the folder.

Note:
If you don’t select a folder while importing, the video is placed at the root level in the Contents panel.

4. To insert the imported video in your content, double-click a topic in the Contents panel. In the open topic, place the cursor at the location in which you want to insert the video.
5 In the standard toolbar, select the Insert Multimedia icon and then select Adobe Captivate Demo from the drop-down list.

6 In the standard toolbar, select the Insert Multimedia icon and then select Adobe Captivate Demo from the drop-down list. In the Adobe Captivate Demo dialog box, from the Contents drop-down section, select the imported video.

   Note:

   If you insert an imported video once, it is listed under the Recently Used drop-down section in the Adobe Captivate Demo dialog box. You can quickly select videos from here as well.

7 Before inserting the selected video, you can preview it in the Adobe Captivate Demo dialog box. Click Insert. The video is inserted at the location of the cursor in the topic.

   Note:

   In the standard toolbar, click at the right corner of the toolbar to quickly play the entire video in Preview and check it before you publish your project.

Delete an image or video

To delete an image or video from a topic:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 In the Contents panel, open the topic that contains the image or video you want to delete.

3 Select the desired image or video, and then press Delete.

Supported image file formats

RoboHelp supports the following image file formats:

• BMP
• GIF
• ICO
• JPE
• JPEG
• JPG
• PNG
• SVG
• WEBP

Supported video file formats

RoboHelp supports the following audio and video file formats:

Audio file formats

• ASF
• ASX
Create and manage links

Links facilitate quick navigation from one content element to another with a simple click. While authoring in RoboHelp, you can add links to text or images and direct them to a project file, a file on your computer, webpage, or an email.
Types of links
The following types of links are available in RoboHelp to help build navigation in your output:

- **Hypertext link** Highlights the link in your text and opens the destination when you click it.
- **Image links** A link in an image that leads you to the destination or opens a pop-up when you click the image.
- **Bookmarks** A link that takes you to a specific location in a topic.
- **Browse sequence** The series of topics viewed in your output. For more information, see Create and manage browse sequences.
- **Searches** The topics that contain search keywords appear as links in the search results.

Insert a link
To create a link on text or an image, follow these steps:

1. In an open project, select the text or image on which you want to create the link.
2. In the standard toolbar, click the Insert Link icon 📖.
3. In the Link To dialog box, the Display Text field displays the selected text to which you want to insert the link. If you selected an image, this field remains blank.

You can select the type of link that you want to insert from the following options:

- **Project Files** Select this option to link to a topic within the project. Use the Search bar to search for a topic. You can also use the Recently Used panel or Contents panel to select a topic of your choice.
- **Local Files** Select this option to link to a file on your computer. Click 🗄️ to browse and select a .htm or .html file. You can then preview the selected file in the Link To dialog box.
- **Webpage** Select this option to link to a webpage. In the Enter or paste URL field, specify the URL of the webpage that you want to link to.
- **Email** Select this option to link to an email that the user can send. You can specify the email address to whom you want the user to send to, in the Address field. Optionally, you can enter the subject and body of the mail in Subject and Body, respectively. In the output, when a user clicks this link, the draft email opens in the default mail client. The user can further edit the mail before sending it.
To link to a project file, use the Search bar or the Recently Used panel to view a topic. You can also browse your topic in the Contents panel below the Recently Used panel.

4 Click **Link**.

You can preview the inserted link when you click **Preview** in the standard toolbar.

**Note:**

Alternatively, you can do the following to link to a project file (topic):

Select the text or an image in an open topic to which you want to insert the link. From the **Contents** panel of the authoring window, drag-and-drop a topic of your choice on the selected text or image. The destination topic is then inserted as a link. In the **Preview** mode or output, click the link to view the destination topic in a pop-up window.

**Fix broken links**

You can quickly generate a Broken Links report to view the links that need to be fixed in your project. To do this, follow these steps:

1 In an open project, click **Reports** in the Author toolbar.

2 In the **Reports** panel, double-click **Broken Links**. Alternatively, click **Options** next to **Broken Links** and select **Open**.

Fix broken links by referring to the information in the **Broken Links** report. This report displays a list of links that have been moved, renamed, or removed. You can also view the corresponding topics that contain the broken links and their link types.
Create and use variables for easy updates

A variable is a text phrase or word that serves as a reusable piece of information, simultaneously used across multiple topics in your project. This makes your content portable and easy to update. When you modify a variable or its value, every occurrence of that variable or value is updated across the project.

Create a variable

A variable is a text phrase to which you assign a value. Follow these steps to create a variable in your open project:

1. In the Author toolbar, click Variables. The Variables panel opens.
2. In the Variables panel, click +. The Define Variable dialog box opens.
3. In the Define Variable dialog box, specify the Name of the variable and its corresponding text value in Value.
4. Click Done.

Edit a variable

To edit a variable in RoboHelp, follow these steps:

1. In the Author toolbar, click Variables. The Variables panel opens.
2. In the Variables panel, click Options next to the desired variable.
3. Select Edit in the given Options list.
4. In the Edit Variable dialog box, you can edit the Name and Value of the selected variable.
5. Click Done.

Insert a variable

To insert or use a variable in an open topic or master page:

1. To open a topic:
   In the Author toolbar, select Contents and open a topic of your choice from the Contents panel.
   To open a master page:
   In the Author toolbar, select Master Pages and open a master page of your choice from the Master Pages panel.
2. Select Variables in the Author toolbar. The Variables panel opens.
3. Select a variable from the Variables panel. Now drag-and-drop the selected variable at the desired text location in the open topic or master page.
   Alternatively, press Ctrl+I. From the Variable dialog box, you can filter variables by typing the first few alphabets. Press the upward and downward arrow keys to navigate through the list of variables. Press Enter to insert a variable.
4. Click the Save All icon at the left side of the standard toolbar.
   Note:
   You can also use variables in an output title. To do so, open the required output preset in Edit mode. In the General tab > Title field, type { and select a variable from the drop-down list, and then press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output generation, the value of the selected variable is picked from the variable set.
Delete a variable
1 In the Author toolbar, click Variables. The Variables panel opens.
2 In the Variables panel, click Options next to the desired variable.
3 Select Delete in the Options list.
4 Click Yes in the Confirm dialog box to delete the selected variable.

Generate Variables report
You can generate a Variables report to view and manage variables in your project. Using this report you can find variables that are used in a topic and those that are not used in any topic. Before you delete a variable, you can locate the topics in which the variable is used and delete references to that variable.

You can then download or print the Variables report.
1 In the Author toolbar, select Reports. The Reports panel opens.
2 In the Reports panel, select Variables.
3 Use the Filters panel on the right side of the screen to customize the report. To know more, see Customize a report.
4 Step text
5 Once you've customized the Variables report based on your needs, click the Download icon in the standard toolbar to instantly download the report. The report is saved as a .csv file.
6 To print the report, click the Print icon in the standard toolbar.

Single-source with snippets
A snippet can be a para­graph of text, a piece of code, an object such as an image, or an entire topic itself. You can single-source a snippet and reuse it across multiple topics in a project or master pages. A snippet can also contain variables and conditional text tags. When you change the contents of a snippet, it is updated across all the topics and master pages that contain it.

Create a snippet
Open a project in RoboHelp and follow these steps to create a snippet:
1 In the Author toolbar, select Contents and open a desired topic from the Contents panel.
2 In the Author toolbar, select Snippets. The Snippets panel opens.
3 In the Snippets panel, click +.
4 In the New Snippet dialog box, specify the name and description of the snippet in Name and Description, respectively.
5 Click Create. The snippet is created and can be accessed from the Snippets panel.
Insert a snippet
To insert or use a snippet in an open topic or master page:

1. To open a topic:
   In the Author toolbar, select Contents and open a topic of your choice from the Contents panel.

2. To open a master page:
   In the Author toolbar, select Master Pages and open a master page of your choice from the Master Pages panel.

3. Now drag-and-drop the selected snippet at the preferred location in the open topic or master page.
   Alternatively, press Ctrl+2. In the Snippet dialog box, you can filter snippets by typing the first few alphabets. Press the upward and downward arrow keys to navigate through the list of snippets. Press Enter to insert a snippet.

4. Click the Save All icon at the left side of the standard toolbar.

Delete a snippet
To delete a snippet from a project, follow these steps:

1. In the Author toolbar, select Snippets. The Snippets panel opens.

2. Select the snippet that you want to delete and click Options next to the snippet.

3. In the Options list, select Delete.

4. In the Confirm dialog box, click Yes.

Generate Snippets report
You can generate a Snippets report to view the details of snippets in your project. You can also customize, download, or print your report.

1. In the Author toolbar, select Reports. The Reports panel opens.

2. In the Reports panel that appears, select Snippets.

3. You can customize a report using the Filters panel on the right side of the screen. To know more, see Customize a report.

4. Click the Download icon in the standard toolbar to instantly download the report.

5. Click the Print icon in the standard toolbar to print your report.

Use Find and Replace

Find a phrase or text
Follow these steps to quickly find a phrase or text in a topic:

1. In an open project, open a desired topic from the Contents panel.

2. In the upper-left corner of the standard toolbar, click the Find and Replace tool.
A bottom panel appears with the **Find** field. In this field, enter the phrase or text that you want to find in the open topic.

Click **Find**. The found phrase or text is highlighted in your topic.

**Note:**

*In the bottom panel, click to do the following:*

- **Ignore case** Select this option to ignore upper or lower cases in text.
- **Whole word only** Select this option to find the entire word.

### Quickly replace a phrase or text

Follow these steps to easily replace a specific phrase or text with an alternate phrase or text in a topic:

1. In an open project, open a desired topic in the **Contents** panel.
2. In the upper-left corner of the standard toolbar, click the **Find and Replace** tool..
3. A bottom panel appears with the **Find** field. In this field, enter the phrase or text that you want to find in the open topic.

   *In the bottom panel, click to do the following:*

   - **Ignore case** Select this option to ignore upper or lower cases in text.
   - **Whole word only** Select this option to find the entire word.

4. Click **Find**. The found phrase or text is highlighted in your topic.
5. In the **Replace with** field, enter the phrase or text that you want to replace the found text within the topic.
6. Click **Replace** to update the highlighted phrase or text. You can click **Replace All** to replace the specified phrase or text across the open topic.
7. Click **X** to close the bottom panel.
Chapter 4: TOCs, indexes, and glossaries

Create and manage a Table of Contents

A Table of Contents provides a hierarchy of the books (folders) and pages (topics) that you have in the output of your project. The Table of Contents gives the reader an ability to view the Help system as a whole and its individual topics. With a Table of Contents, the reader can quickly select and view a topic of their choice.

You can have multiple Tables of Contents in a single project, depending on the type of output that you want for your readers. For example, you can have a Table of Contents to cater to a specific audience (say, Developers) and another Table of Contents for a different audience (say, End users). You can simultaneously maintain the two Table of Contents files in the Table of Contents panel.

At the time of publishing your project, the entire project is not included in the output generated. Only the topics (and the referenced files inside these topics) in the Table of Contents file selected are included.

Create a Table of Contents

To create a Table of Contents:

1. In the Author toolbar, select Table of Contents. The Table of Contents panel opens.
2. In the Table of Contents panel, click + to create a Table of Contents.
3. In the New Table of Contents dialog box, in the Name field, specify the name of the Table of Contents file.
4. Click Done.

The Table of Contents is created in the Table of Contents panel. You can add multiple Table of Contents files in a project. You can expand a Table of Contents file by clicking against it.

Edit a Table of Contents

You can edit a Table of Contents file in two modes—quick edit mode and comprehensive edit mode.

Quick edit mode is accessible as a context menu in the Table of Contents panel after you expand a Table of Contents file. This mode does not launch the Table of Contents editor or display the Table of Contents toolbar.

Comprehensive edit mode launches the Table of Contents editor and displays the Table of Contents toolbar at the center of the standard toolbar. To edit a Table of Contents file in the comprehensive edit mode:

1. In the Author toolbar, select Table of Contents. The Table of Contents panel opens.
2. Launch the Table of Contents editor by doing one of the following in the Table of Contents panel:
   - Double-click a Table of Contents file.
   - Right-click a Table of Contents file and then click Edit.
   - Against a Table of Contents file, choose Options (*** > Edit).

   The Table of Contents editor opens as a tab and RoboHelp displays the Table of Contents toolbar at the center of the standard toolbar.
In edit mode, you can do the following:

- **Auto-create a Table of Contents**
- Insert a folder
- Merge projects
- Delete items in a Table of Contents
- Insert a topic
- Insert a Table of Contents placeholder
- Reorder items in a Table of Contents
- Work with a Table of Contents' properties

**Auto-create a Table of Contents**

Quickly create a Table of Contents using **Auto-create TOC**. This feature uses the hierarchy of the folders and topics in your project to create a Table of Contents file.

To auto-create a Table of Contents:

1. Do one of the following:
   - In the Table of Contents toolbar, click 📜.
   - Right-click in the Table of Contents editor and click **Auto-create TOC**.

2. In the **Confirm** dialog box, you can select one or both of the following:
   - **Delete current TOC before creating new** Deletes existing Table of Contents, if any, before auto-creating.
   - **Create TOC pages for bookmarks** If your topics include bookmarks, selecting this field creates an additional page for each bookmark.

Click **Ok**.

*Note:*

*If a Table of Contents already exists, and you do not select any option in the **Confirm** dialog box, the new Table of Contents is appended at the end of the existing Table of Contents.*

**Insert a topic**

Quickly insert a topic in the TOC by dragging it from the **Contents** panel and dropping it in the Table of Contents.

Or, follow these steps:

1. Do one of the following:
   - In the Table of Contents toolbar, click 📜.
   - Right-click in the Table of Contents editor and choose **New > Page**.

2. In the **Insert Page** dialog box, do the following:
   - **Project Files** Select this option to insert a topic from your project.
   - **Title** Use to modify the display title of the topic in the Table of Contents without changing the actual topic title.
   - **Search** Use to search for a topic. You can also use the **Recently Used** panel or the **Contents** panel to select a topic of your choice.
   - Click **Insert**.
If you insert a topic in an existing Table of Contents, it is inserted after the currently selected topic. If a folder is selected at the time of insertion, the topic is inserted at the end of the list of topics inside the selected folder.

**Insert a folder**

Quickly insert a folder in the TOC by dragging it from the Contents panel and dropping it in the Table of Contents. RoboHelp retains the original hierarchy of the folder in the Table of Contents panel.

Or, follow these steps:

1. Do one of the following:
   - In the Table of Contents toolbar, click 🔊.
   - Right-click in the Table of Contents editor and choose New > Book.

2. In the Insert Book dialog box, do the following:
   - **Project Files** Select this option to insert a folder from your project.
   - **Title** Use to modify the display title of the folder in the Table of Contents without changing the actual folder title.
   - **Search** Use to search for a folder. You can also use the Recently Used panel or the Contents panel to select a folder of your choice.
   - Click Insert.

If you insert a folder in an existing Table of Contents, it is inserted after the currently selected topic. If another folder is selected at the time of insertion, the new folder is inserted at the end of the list of topics in the selected folder.

**Insert a Table of Contents placeholder**

You can achieve collaborative authoring in RoboHelp where multiple writers can work on their individual books. Using Table of Contents placeholders, you can create a merged output from individual books. To do so, you can insert a Table of Contents placeholder in your current Table of Contents. RoboHelp retains the original hierarchy of topics and folders in a placeholder, which is expanded as a complete Table of Contents in the output generated.

Quickly insert a Table of Contents placeholder by dragging it from the Table of Contents panel and dropping it in the current Table of Contents.

Or, follow these steps:

1. Do one of the following:
   - In the Table of Contents toolbar, click 🔊.
   - Right-click in the Table of Contents editor and choose New > TOC Placeholder.

2. In the Insert TOC dialog box, from the list of Table of Contents, select one and click Insert.

The Table of Contents is inserted as a placeholder. If you insert a placeholder in an existing Table of Contents, it is inserted after the currently selected topic. If a folder is selected at the time of insertion, the placeholder is inserted at the end of the list of topics in the selected folder.

**Reorder items in a Table of Contents**

To quickly reorder the items (topics, folders, and Table of Contents placeholders) inside a Table of Contents file, do one of the following:

- Use drag-and-drop
• Click the following icons in the Table of Contents toolbar or from the **Move** context menu in the Table of Contents editor:
  - ** направлен налево** Changes the hierarchy of the topic/folder by moving it one level above the original level
  - ** направлен направо** Changes the hierarchy of the topic/folder by moving it one level below the original level
  - ** направлен вверх** Changes the order of the topic/folder by moving it above the previous topic/folder
  - ** направлен вниз** Changes the order of the topic/folder by moving it below the next topic/folder

**Delete items in a Table of Contents**
To delete an item (a topic, a folder, or a Table of Contents placeholder) inside a Table of Contents file, do one of the following:
• Select the item and press **Delete**.
• Right-click the item and click **Delete**.
• Against the item, choose **Options (***)** > **Delete**.

**Work with a Table of Contents’ properties**
The Table of Contents editor displays the **Properties** panel at the right side of the screen. The **Type** field displays the type of the currently selected item—**Book** (a folder), **Page** (a topic), or **TOC** (a Table of Contents placeholder). For each item, you can set the following:
• **Title** Use this field to specify the display title of a folder, topic, or a Table of Contents placeholder, which can be different from the original title.

  **Note:**
  *The display title is visible only in the Table of Contents file. The original title of the topic remains unchanged. If you do not specify a display title, the topic title in the Table of Contents file gets synced with the original topic title.*

• **Source** [Applicable only to topics] Displays the URL of the selected topic file along with its original title (not the display title if modified). You can replace the selected topic with a different topic from your project by clicking **-question mark**, choosing the topic, and clicking **Update**.

  **Note:**
  *If the linked topic does not exist, RoboHelp displays a red x mark against the topic in the TOC.*

• **Hide in output** Select to hide the topic from the Table of Contents in the output.

  **Note:**
  *This feature is useful if you want to publish supplementary files, for example, PDF and DOC, but do not want to show it in the Table of Contents in the output. To do so, add supplementary files to the TOC and against each file, select **Hide in output**.*

• **Apply Tags** Click to apply condition tags to the Table of Contents file. From the **Apply Condition Tags** dialog box, select the condition tags you want to apply. The selected tags appear at the right side of the dialog box. Click **Apply**. The applied tags are displayed in the **Properties** panel below the **Condition Tags** drop-down section. In the **Properties** panel or in the **Apply Condition Tags** dialog box, you can click **х** against a tag to remove it.
TOCs, indexes, and glossaries

Use a desired Table of Contents in your output
To use a Table of Contents in the output:
1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click Output Presets.
3. In the Output Presets panel, select your desired output preset from the given options. You can choose output presets from among Responsive HTML5, Mobile App, WebHelp, eBook, and more.
4. Select the Content tab.
5. The Table of Contents field displays all your created Table of Contents files in the project. Use the drop-down list to select your desired Table of Contents file.

The selected Table of Contents is then included in your output. See Generate output for details on how to generate the output.

Rename a Table of Contents
To rename a Table of Contents:
1. In an open project, select Table of Contents in the Author toolbar. The Table of Contents panel opens.
2. In the Table of Contents panel, against the Table of Contents that you want to rename, choose Options (*** > Rename).
3. In the Rename Table of Contents dialog box, modify the current name. Click Done.

Delete a Table of Contents
To delete a Table of Contents:
1. In an open project, select Table of Contents in the Author toolbar. The Table of Contents panel opens.
2. In the Table of Contents panel, against the Table of Contents that you want to delete, choose Options (*** > Delete).
3. In the Confirm dialog box, click Yes to confirm the deletion.

Create and manage an index

What is an index
An index is an alphabetically sorted list of keywords used in your project. Keywords can include multiple levels of subkeywords. You can associate keywords and subkeywords with topics that contain them and add cross-references to other keywords. You can also use project variables while adding keywords or subkeywords. You can add condition tags to index keywords to choose which keywords to publish in a specific output. You can also publish keywords so that your end users can use the keywords to search for and access specific topics in the output.

You can work with keywords and subkeywords through the Index panel of RoboHelp.
Add keywords to create an index

You can add index keywords/subkeywords in two ways—from Topic properties and from the Index panel.

From Topic properties

From Index panel

From Topic properties

1. In an open topic, navigate to index in topic properties by clicking Properties panel > Topic tab > Index drop-down section.

2. In the Index Keywords field, specify a keyword and press Enter. To specify a subkeyword, use a colon : between keywords. You can use variables while specifying keywords and subkeywords.

   The new keywords and subkeywords are placed below the Index Keywords field. To remove a keyword/subkeyword, click × against it.

   The new keywords/subkeywords are also placed in the Index panel according to alphabetical order of keywords. To access the Index panel, click Index in the Author toolbar.

From Index panel

1. In an open project, select Index in the Author toolbar.

2. In the Index panel, do one of the following:
   • Click + at the upper-right corner of the panel.
   • Against an existing keyword, choose Options (⁎⁎⁎) > New Keyword.
   • Right-click a keyword and select New Keyword.
   
   An empty field appears in the Index panel.

3. In the empty field, specify a keyword and press Enter. The keyword is added to the Index panel and placed according to alphabetical order of keywords.

   You can add multiple keywords to create an index.

   The keywords are also visible in Properties panel > Topic tab > Index drop-down section.

Add subkeywords to keywords

To add a subkeyword to a keyword, follow these steps:

1. In an open project, select Index in the Author toolbar.

2. In the Index panel, against a keyword, choose Options (⁎⁎⁎) > New Subkeyword. Alternatively, right-click a keyword and select New Subkeyword.

   An empty field appears below the keyword.

3. In the empty field, specify a subkeyword and press Enter. The subkeyword is added below the keyword.
You can add multiple subkeywords to a keyword.

**Link keywords and subkeywords to specific topics**

Once you’ve added keywords and subkeywords to an index, you can link them to specific topics. To do this, follow these steps:

1. In an open project, select Index in the Author toolbar.
2. In the Index panel, against a keyword/subkeyword, choose Options > Add Topic. Alternatively, right-click a keyword/subkeyword and select Add Topic.
3. In the Add Topic dialog box, use the Search bar, Recently Used panel, or Contents panel to select a topic in your project.
4. Click Link. The topic is added below the keyword/subkeyword.

*Note:*

To remove or edit a linked topic, click next to the topic or right-click the topic and select Remove or Edit, respectively.

If the linked topic is open, the Properties panel > Topic tab > Index drop-down section displays the associated keywords and subkeywords. For more information, see Index.

**Link keywords and subkeywords to other keywords**

Once you’ve added keywords and subkeywords to an index, you can link them to other keywords in the index. To do this, follow these steps:

1. In an open project, select Index in the Author toolbar.
2. In the Index panel, against a keyword/subkeyword, choose Options > Add Cross Reference. Alternatively, right-click a keyword/subkeyword and select Add Cross Reference.
3. In the Insert Cross Reference dialog box, you can filter keywords by typing the first few alphabets. Press the upward and downward arrow keys to navigate through the list of keywords. Press Enter to insert a keyword.

The keyword is added as a cross-reference below the main keyword.

*Note:*

To remove or edit a cross-reference, click next to the cross-reference or right-click the cross-reference and select Remove Cross Reference or Edit Cross Reference, respectively.
Apply condition tags to a keyword or subkeyword

You can use a single index file in all outputs and apply condition tags to specific keywords/subkeywords to publish those in specific outputs. You can apply multiple condition tags to keywords and subkeywords in an index. To do this, follow these steps:

1. In an open project, select **Index** in the Author toolbar.
2. In the **Index** panel, against a keyword/subkeyword, choose **Options > Apply Condition Tags**. Alternatively, right-click a keyword/subkeyword and select **Apply Condition Tags**.
3. In the **Apply Condition Tags** dialog box, click a condition tag in the left panel. The tag appears in the right panel. To remove the tag, click ✗ against it.
4. Click **Apply**.

   In the **Index** panel, against the keyword/subkeyword, a colored circle indicates that conditional tags are applied.

Rename a keyword or a subkeyword

To rename a keyword/subkeyword in the Index panel, follow these steps:

1. In an open project, select **Index** in the Author toolbar.
2. In the **Index** panel, against the keyword/subkeyword, choose **Rename**. Alternatively, right-click the keyword/subkeyword and select **Rename**.
3. Edit the keyword/subkeyword inside the editable box and press **Enter**.

   The edited keyword/subkeyword is reflected in the Index panel and the Index drop-down section in a topic’s properties. All the topics in which this keyword/subkeyword is used are updated as well.

Delete a keyword or a subkeyword

To delete a keyword/subkeyword in the **Index** panel, follow these steps:

1. In an open project, select **Index** in the Author toolbar.
2. In the **Index** panel, against the keyword/subkeyword, choose **Delete**. Alternatively, right-click the keyword/subkeyword and select **Delete**.
3. Click **Yes** in the **Confirm** dialog box to confirm deletion.

   The deleted keyword/subkeyword is removed from the Index panel and the Index drop-down section in a topic’s properties. It is also removed from all the topics in which it was used.

Publish an index

By default, an index is published in the output. You can change this setting in RoboHelp while configuring an output preset that you want to use to generate output. To do so, follow these steps:

1. Click the **Output** tab at the left side of the standard toolbar.
2. In the Output toolbar, click **Output Presets**.
3. From the **Output Presets** panel, double-click the output preset that you want to edit.
4. Click the **Content** tab.

   The **Include Index** field is selected by default, so index is published by default. You can select or deselect this field depending on whether you want to publish an index.
Note:

For WebHelp and Responsive HTML5 output types, you can also control whether to show or hide an index from the respective skins. To do so, in the Layout tab of the Skin Components panel, you can enable or disable the Show Index option.

Generate output.

Use an index in the output

An index, if published, appears as a panel in the output. The index panel in the output displays all keywords and serves as an additional navigational channel for your end users. In the index panel, one can filter through keywords and click a keyword to quickly navigate to the associated topic. Your end users can use index keywords to quickly search for and access topics of their choice. Index keywords have the same ranking as search keywords.

Create and manage a glossary

A glossary is a list of terms with their corresponding definitions, just like a dictionary. You can specify the definitions of terms in your project that you think are difficult to understand by your readers. A single glossary file can contain multiple terms and you can have multiple such glossary files in a project. You can decide which glossary file goes into your output, based on your audience.

You can access, add, remove, and edit glossaries from the Glossary panel.

Create a glossary

To create a glossary file for your project in RoboHelp:

1. In the Author toolbar, select Glossary. You can view the Glossary panel.
2. In the Glossary panel, click the icon.
3. In the Add Glossary dialog box, specify the name of the glossary file in the Name field and click Done.

You can now view the created glossary file as an expandable list in the Glossary panel. You can create multiple glossary files in a project. However, you can expand only one glossary file at a time by clicking against it.

Add terms to a glossary

To add definition terms to a glossary file, follow these steps:

1. In the Author toolbar, select Glossary. The Glossary panel opens.
2. In the Glossary panel, click to expand the glossary file in which you want to add a term.
3. In the expanded glossary file, click the icon to add a new term.
4. In the Define Glossary Term dialog box, specify the term and its definition in Term and Definition, respectively.
5. Click Done.

You can now find the term and its definition in the expanded view of the selected glossary file.
Add a glossary term's definition in a topic
You can easily add a glossary term and its definition in the content of a desired topic. The term is then highlighted as a hyperlink in your topic. When you generate the output, your reader can click the term to view its specified definition, which displays as expanding text. To add a glossary term definition in a topic, follow these steps:
1. In the Author toolbar, select Contents and open your desired topic.
2. In the Author toolbar, click Glossary. The Glossary panel opens with all glossary files.
3. Click to expand the glossary file from which you want to add a term's definition.
4. Drag-and-drop a glossary term to an appropriate location in your open topic.

   The term is highlighted as a hyperlink. In the project's output, a reader can click the highlighted term to view its definition. See Generate output for details on how to publish a project.

Edit a glossary term
You can change or edit the definition of a term in your glossary file. To do this:
1. In the Author toolbar, select Glossary. The Glossary panel opens.
2. In the Glossary panel, click to expand a glossary file and hover over the term definition that you want to edit.
3. Click.
4. In the Edit Glossary Term dialog box, you can edit both the Term and Definition.
5. Click Done.

   The edit is reflected in the glossary file.

Use a desired glossary file in your output
Out of the several glossary files that you've created in a project, you can use one in your output. To specify which glossary goes into your output, follow these steps:
1. Click the Output tab at the left side of the Standard toolbar.
   The Output view opens.
2. In the Output toolbar, click Output Presets.
3. In the Output Presets panel, select your desired output preset from the given options. You can choose from output presets options such as Responsive HTML5, Mobile App, WebHelp, eBook, and more.
4. Select the Content tab.
5. In the Glossary field, select your desired glossary file from the drop-down list.
   The selected glossary file is then included in your output. See Generate output for details on how to generate the output.

Remove a glossary term
To remove a glossary term from a glossary file, follow these steps:
1. In the Author toolbar, select Glossary. The Glossary panel opens.
2. In the Glossary panel, click to expand a glossary file and hover over the term definition that you want to remove.
3. Click.

Last updated 2/20/2019
4 In the Confirm dialog box, click Yes.
   The glossary term is removed from the glossary file.

**Rename a glossary**
You can rename a glossary file in the Glossary panel in RoboHelp. To do this:
1 In the Author toolbar, select Glossary. The Glossary panel opens.
2 In the Glossary panel, against the glossary that you want to rename, choose Options (*** > Rename).
3 In the Rename Glossary dialog box, specify the new name and click Done.

**Delete a glossary**
You can delete a glossary file from the Glossary panel in RoboHelp. To do this:
1 In the Author toolbar, select Glossary. The Glossary panel opens.
2 In the Glossary panel, against the glossary file that you want to delete, choose Options (*** > Delete).
3 In the Confirm dialog box, click Yes to confirm the deletion.

**Create and manage browse sequences**

**What is a browse sequence**
A browse sequence is a linear list of topics that helps your users to logically and easily move through a series of topics in the output. Use browse sequences to provide a path for your users to navigate to the previous or the next relevant topic.

When working with browse sequences, keep in mind the following:
- You cannot include topics from other projects in browse sequences.
- You can include a single topic in multiple browse sequences.

**Add a browse sequence**
To add a browse sequence:
1 Click the Author tab at the left side of the Standard toolbar.
   The Author view opens.
2 In the Author toolbar, click Browse Sequences. The Browse Sequence panel opens.
3 Click + in the upper-right corner of the panel. The New Browse Sequence dialog box opens.
4 In the New Browse Sequence dialog box, specify the name of the browse sequence and click Create.
   The new browse sequence is added to the Browse Sequence panel and placed in alphabetical order.
5 Click the Save All icon at the left side of the standard toolbar.
Edit a browse sequence

You can easily customize a browse sequence to suit your requirements. To edit a browse sequence:

1 Click the Author tab at the left side of the Standard toolbar.
   The Author view opens.

2 In the Author toolbar, click Browse Sequences. The Browse Sequence panel opens.

3 In the Browse Sequence panel, against the browse sequence you want to customize, choose Options (***) > Edit.
   The browse sequence editor opens. Use drag-and-drop to add topics or TOCs to the browse sequence editor. You can add a topic or a TOC before, in between, or after existing topics.

4 To add topics from the Contents panel:
   a In the Author toolbar, click Contents.
   b From the Contents panel, drag a topic and drop it in the browse sequence editor. To add a group of topics from a folder, drag-and-drop the folder. All the topics inside the folder, including subfolders, are inserted as a linear list.
   To add topics from a TOC:
   c In the Author toolbar, click Table of Contents.
   d From the Table of Contents panel, drag a TOC and drop it in the browse sequence editor. Topics from the TOC are inserted as a linear list. You can also expand a TOC from the Table of Contents panel, and drag-and-drop individual books or pages.

5 Manage topics in the browse sequence editor:
   • To change the sequence of topics, use drag-and-drop.
   • To delete a topic, click against it or right-click the topic, and click Delete.
   • To delete all topics in the browse sequence, right-click a topic and click Delete All.

6 Click the Save All icon at the left side of the standard toolbar.

Rename a browse sequence

To rename a browse sequence:

1 Click the Author tab at the left side of the Standard toolbar.
   The Author view opens.

2 In the Author toolbar, click Browse Sequences. The Browse Sequence panel opens.

3 In the Browse Sequence panel, against the browse sequence you want to customize, choose Options (***) > Rename.

4 In the Rename Browse Sequence dialog box, edit the name of the browse sequence and click Done.

5 Click the Save All icon at the left side of the standard toolbar.
Delete a browse sequence

To delete a browse sequence:

1. Click the Author tab at the left side of the Standard toolbar. The Author view opens.
2. In the Author toolbar, click Browse Sequences. The Browse Sequence panel opens.
3. In the Browse Sequence panel, against the browse sequence you want to delete, choose Options (***)> Delete.
4. In the Confirm dialog box, click Yes to confirm deletion.
5. Click the Save All icon at the left side of the standard toolbar.

Include browse sequences in output

While defining an output preset, you can select multiple browse sequences. If several browse sequences have a common topic, RoboHelp gives precedence to browse sequences according to the alphabetical order of their names. So the topics before and after the common topic are picked from the browse sequence name with the highest alphabetical order.

For example, the topic Random is included in browse sequences A, B, and C. In this case, RoboHelp gives precedence to the order of topics in browse sequence A. In the output, RoboHelp shows the topics before and after Random from browse sequence A.

Note:

- Browse sequences are supported in Responsive HTML5, WebHelp, and Microsoft HTML Help output types.
- You can include one or more browse sequences in Responsive HTML5 and WebHelp output presets.
- Microsoft HTML Help output presets automatically include all browse sequences available in a project. So in the output, from the list of browse sequences, you can select the one you want to use.

To include browse sequences in your output:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens. In the Output toolbar, Output Presets is the default selection.
2  In the Output Presets panel, double-click a preset to edit it, or choose Options (*** > Edit.

3  In the siderail of the output preset, click the Content tab.

4  From the Browse Sequence drop-down list, select the browse sequence you want to add.

   The selected browse sequence is placed below the Browse Sequence drop-down list. To remove a selected browse sequence, click X on it.

5  Generate output.

   The output contains navigation buttons according to the skin selected. Clicking these buttons navigate to the topics in the sequence defined in the selected browse sequences.
Chapter 5: Conditional content

What is conditional content

Conditional content helps organizations to single-source content efficiently to address various documentation purposes and audience needs. In Adobe RoboHelp, you implement conditional content by applying condition tags to your content. Condition tags enable you to generate output with content variations.

Additionally, Manage tag groups help you group multiple related condition tags to provide relevant content to a focus group. You can use tag groups such as audience, platform, product, properties, and other custom groups. For example, use the audience group to provide targeted content to developers, administrators, and so on. Use the platform group to target operating system-related information to appropriate users, such as system requirements for Windows and Mac.

Common use cases

In RoboHelp, you can use condition tags to generate subsets of content from your project as needed. This way, you need not create multiple projects for different output types.

Here are some common scenarios in which you can use condition tags effectively:

- Customize content for output formats

Online documentation often contains elements that are not useful in a printed manual. You can mark these elements using a condition tag, for example, online-only, and exclude them from the printed manual. Alternatively, if your manual is a subset of your online documentation, you can apply a different condition tag, for example, print-only, to the topics and topic content that you want to include in the printed manual. When you generate your project, you can use the print-only or online-only tag as required.
Conditional content

Output-based conditional content

• Target custom content for specific audiences
Sometimes, topics are specific to products, experience levels, or types of users. Using condition tags, you can target such topics for the right audience. This way, the content that an audience receives is relevant and clutter-free. For example, beginners get the content that’s relevant for them and their consumption experience is not suboptimized because of notes and tips that are relevant for advanced users.

Expertise-based conditional content

• Filter published content based on relevance
Sometimes, all published content may not be relevant to a set of your audience. Using dynamic content filters, you can provide your audience the ability to filter out irrelevant content from the output. For example, in a multi-locale travelogue, users can quickly filter content for specific locales, instead of having to read through or search the entire travelogue.

Locale-based conditional content
Conditional content

High-level workflows
The end-to-end implementation of conditional content involves performing steps in both authoring and publishing workflows. Also, you can optimize and manage your conditional content.

1 Authoring workflow
2 Publishing workflow
3 Optimize and manage conditional content

Authoring workflow
1 Add a condition tag.
2 Apply a condition tag to topics, topic content, TOCs, and indexes.
3 To check tagged content, preview a topic with associated condition tags.

Publishing workflow
1 Configure condition expressions and dynamic content filters.
2 Configure an output preset to generate conditional content.
3 Generate output using a configured output preset.

Optimize and manage conditional content
1 Manage condition tags.
2 Manage condition expressions and dynamic content filters.
3 Generate reports.

Create and apply condition tags
To implement What is conditional content in your project, you need to add condition tags and apply the tags to your content. After applying the tags, you can preview tagged content to check if the applied tags are working as expected.

Add a condition tag
Adobe RoboHelp provides two default condition tags—Online and Print. You can add new tags and group a bunch of related tags using the Group field in the Define Condition Tag dialog box. For example, you can group the Beginners, Intermediate, Experts, Developers, Administrators, and EndUsers tags under the Audience group. You can also choose background and text colors to differentiate the tags, and the content to which the tags are applied.

To add a new tag, do the following:
1 Click the Author tab at the left side of the Standard toolbar. The Author view opens.
2 In the Author toolbar, click the Condition Tags icon.
3 In the Condition Tags panel, click the New Tag icon in the upper-right corner.
4 In the Define Condition Tag dialog box, do the following:
   a Choose the group in which you want to create a tag, from the Group drop-down list. For example, to tag audience-specific content, choose the Audience group.
Note:

If you upgraded to Adobe RoboHelp 2019 from an earlier version, all your previous tags are grouped under the **Others** group in the Condition Tags panel. This is because the previous versions of Adobe RoboHelp did not contain the **Group** field. Adobe recommends that you organize your tags under appropriate groups. To do so, drag-and-drop tags from the **Others** group to the appropriate group in the **Condition Tags** panel.

In the **Condition Tags** panel, groups (such as, **Audience** and **Others**) and tags (such as Developer and Adventure) under each group appear as shown in the image:

![Condition Tags Panel](image)

**Note:**

You can also add a new tag group, and rename and delete existing tag groups. Check out the steps in **Manage tag groups**.

b Specify the tag name in the **Name** field.

c In the **Identify with** area, select the background and text colors. Background and text colors help differentiate multiple condition tags by highlighting the content chunks to which the tags are applied.

d Click **Done**.

The group and the condition tag appear in the **Condition Tags** panel.

**Manage tag groups**

You can add a tag group to the list of default tag groups. You can also rename and delete existing tag groups.

1 Choose **File > Project Settings** or press **Ctrl+Shift+/.**

   The **Project Settings** dialog box opens.

2 To manage tag groups, use the **Tag Groups** tab in the **Project Settings** dialog box. For more information, see **Tag Groups**.

3 Click **Done** to save the changes.

**Apply a condition tag**

You can apply a condition tag to topics, topic content, TOCs, and indexes. Learn more here:

- **Apply to a topic**
Conditional content

- Apply to a snippet
- Apply to an index
- Apply to topic content
- Apply to a master page
- Apply to an index

Apply to a topic
To learn how to work with topics to build your content in RoboHelp, see Work with topics and folders.

1 Click the Author tab at the left side of the Standard toolbar.
   The Author view opens.

2 In the Author toolbar, click the Contents icon.

3 In the Contents panel, double-click a topic to open it.

4 Apply a condition tag to the topic through the Apply Tags button, which is accessible in two ways:
   - Option 1:
     In the Properties panel, click the Topic tab. Under Condition Tags > Topic-Level, click Apply Tags.

   - Option 2:
     In the Contents panel, right-click the topic, and then click Properties. In the Topic Properties dialog box, under Condition Tags > Topic-Level, click Apply Tags.

The Apply Condition Tags dialog box appears.
5 In the Apply Condition Tags dialog box, do the following:
   a From the left side of the dialog box, click the tag you want to apply. The selected tag and its group appear in the
      right side of the dialog box. From here also, you can remove a tag by clicking \text{x}.
   b Click Apply Tags to apply the selected tag.

The applied tag and its group appear under Condition Tags > Topic-Level in the Properties panel or the Topic
Properties dialog box.

6 To save the changes, click the Save icon in the standard toolbar.

Apply to topic content
To learn how to add content to your topic, see Add content to or edit a topic.

1 Click the Author tab at the left side of the Standard toolbar.
   The Author view opens.

2 In the Author toolbar, click the Contents icon.

3 In the Contents panel, double-click a topic to open it.

4 In Author view, select the content element to which you want to apply a tag. For example, select a paragraph.
5 From the Author toolbar, click the **Condition Tags** icon.

6 From the **Condition Tags** panel, drag the condition tag that you want to apply and drop it anywhere on the selected content element in the topic.

The content element is highlighted in the background and text colors of the condition tag applied.

In the **Properties** panel > **Topics** tab, under **Condition Tags > Content-Level**, the applied tag and its group appear.

7 To save the changes, click the **Save** icon in the standard toolbar.

**Apply to a snippet**

To learn about how to use and work with snippets in RoboHelp, see Single-source with snippets.

1 Click the **Author** tab at the left side of the Standard toolbar.

   The Author view opens.

2 In the Author toolbar, click the **Snippets** icon.

3 In the **Snippets** panel, expand and double-click a snippet to open it.

4 In **Author** view, select the snippet content to which you want to apply a tag.

5 From the Author toolbar, click the **Condition Tags** icon.

6 From the **Condition Tags** panel, drag the condition tag that you want to apply and drop it anywhere on the selected content in the snippet.
To apply condition tags to a master page:

1. Click the Author tab at the left side of the Standard toolbar.
2. From the Author toolbar, click the Master Pages icon.
3. From the Master Pages panel, double-click a master page to open it.
4. Select the content to which you want to apply condition tags.
5. To apply condition tags, do one of the following:
   - Right-click the selected content, and click Apply Condition Tags. In the Apply Condition Tags dialog box, drag a condition tag from the left panel and drop it in the right panel. Click Apply.
   - From the Author toolbar, click the Condition Tags icon. From the Condition Tags panel, drag the condition tag that you want to apply and drop it on the selected content.

The selected content is highlighted in the background and text colors of the condition tag applied.

In the Properties panel > Topics tab, under Condition Tags > Content-Level, the applied tag and its group appear.

6. To save the changes, click the Save icon in the standard toolbar.

Apply to a Table of Contents

To apply condition tags to a Table of Contents (TOC):

1. Click the Author tab at the left side of the Standard toolbar.
2. In the Author toolbar, click the Table of Contents icon.
3. In the Table of Contents panel, double-click a TOC to open it.

Note:

If the TOC is blank, that is, elements inside the TOC are not visible, click the Auto-create ToC icon on the standard toolbar to create the TOC. Note that clicking the Auto-create ToC icon includes all the topics in your project.
If you want to apply condition tags to selective pages, books, or TOC, click the **Insert Page**, **Insert Book**, or **Insert TOC** icons on the standard toolbar. Alternatively, click the **Contents** icon in the Author toolbar and from the **Contents** panel, drag-and-drop selective topics.

4 Select a book or a page inside the ToC.

5 In the **Properties** panel, under **Condition Tags**, click **Apply Tags**.
   The **Apply Condition Tags** dialog box appears.

6 In the **Apply Condition Tags** dialog box, do the following:
   a From the left side of the dialog box, click the tag you want to apply. The selected tag and its group appear in the right side of the dialog box. From here also, you can remove a tag by clicking \(\times\).
   b Click **Apply Tags** to apply the selected tag.
   In the **Properties** panel > **Topics** tab, under **Condition Tags** > **Topic-Level**, the applied tag and its group appear.

7 To save the changes, click the **Save** icon in the standard toolbar.

**Apply to an index**

To learn how to work with an index in RoboHelp, see Create and manage an index.

1 Click the **Author** tab at the left side of the Standard toolbar.
   The Author view opens.

2 In the Author toolbar, click the **Index** icon.

3 In the **Index** panel, right-click an index entry and click **Apply Condition Tags**.
   The **Apply Condition Tags** dialog box appears.

4 In the **Apply Condition Tags** dialog box, do the following:
   a From the left side of the dialog box, click the tag you want to apply. The selected tag and its group appear in the right side of the dialog box. From here also, you can remove a tag by clicking \(\times\).
   b Click **Save** to apply the selected tag.

5 To save the changes, click the **Save** icon in the standard toolbar.

**Preview a topic with associated condition tags**

You can preview the tagged elements in a topic to verify if the tagging is correct.

1 Click the **Author** tab at the left side of the Standard toolbar.
   The Author view opens.

2 In the Author toolbar, click the **Contents** icon.

3 In the Contents panel, double-click to open the topic that you want to preview.

4 To switch to Preview mode, click the **Preview** icon on the right side of the standard toolbar.

The preview mode opens and displays all tagged and untagged content. For example, the following image displays content tagged using three tags and untagged content.
5 Select specific condition tags to check which content elements are tagged using the selected tags. For example, select the EndUser and Sales tags.

In the preview window, all content elements tagged with the selected tags (EndUser and Sales), and all untagged content remain. Content element tagged with the unselected tag (Marketing tag indicated by callout B in the Step 3 image) is filtered out.

6 Select the Highlight selected condition tags field to visually differentiate tagged (only the selected tags) and untagged content.

In the preview window, tagged content is highlighted in the respective background and text colors of the selected tags (EndUser and Sales). Untagged content is not highlighted.
Configure output presets for conditional content

After you have implemented What is conditional content in your project, you need to add or configure condition expressions and filters that you want to use during publishing. Both condition expressions and dynamic content filters use condition tags for granular control over content. Then, configure the output preset from which you want to publish, to include the appropriate condition expressions and dynamic content filters. Next, generate the output for the configured output preset.

Configure condition expressions and dynamic content filters

- Configure a condition expression
- Configure a dynamic content filter

Configure a condition expression

**Condition expression** A condition expression controls the inclusion of tagged source content or its exclusion from the output. Depending on the condition tags used in an expression, the corresponding source content is included in the output. You can define various tag combinations in the expression using OR, AND, and NOT operators to customize the inclusion or exclusion of content in the output. Condition expressions are not published along with the source content and do not appear in the output.

1. Click the Output tab at the left side of the Standard toolbar.
   The Output view opens.

2. In the Output toolbar, click the **Condition Expressions** icon.

3. In the **Condition Expressions** panel, click the **Add** icon ( +).

4. In the **New Condition Expression** dialog box, specify the name of the condition expression. Click **Done**.
   The new condition expression is added to the **Condition Expressions** panel.

5. From the **Condition Expressions** panel, double-click to open the expression.
   The **Condition Tags** panel and the expression editor panel open.

6. From the **Condition Tags** panel, drag a tag and drop it in the expression editor panel.
The tag is removed from the **Condition Tags** panel and appears in the expression editor panel as a condition.

You can drop multiple tags as required. You can drop a tag above, below, or in between multiple tags.

You can delete an expression by clicking the delete icon against it.

7 Against each condition in the expression editor panel, do one of the following:
   - Select **Include** to add the tag in the expression. This action includes all source content associated with the tag in the output.
   - Select **Exclude** to exclude the tag from the expression. This action excludes all source content associated with the tag from the output.

8 To combine multiple conditions, use the **AND** and **OR** operators.
   - To ensure that the expression runs only when all conditions are met, use the **AND** operator between the conditions.
   - Use the **OR** operator to let the expression run if one or more conditions are met.

The following expression displays Developer or EndUser content for Canadian locale.

9 To save the changes, click the **Save** icon in the standard toolbar.

**Configure a dynamic content filter**

A dynamic content filter controls the display of content in the output. Add a dynamic content filter and then customize it by adding condition tags. The filters are published along with the tagged source content. From the published filters displayed in the output, your end-users can select specific filters to view selective content and hide the rest of the content. Dynamic content filters facilitate quick retrieval and consumption of specific information, instead of having to go through the entire published content.

1 Click the **Output** tab at the left side of the Standard toolbar.
   - The Output view opens.

2 In the Output toolbar, click the **Dynamic Content Filters** icon.

3 In the **Filters** panel, click the **Add** icon (\+)

4 In the **New Filter** dialog box, specify the name of the dynamic content filter. Click **Done**.
   - The new dynamic content filter is added to the **Filters** panel. The **Condition Tags** panel and the filter editor panel open. The filter editor displays the new dynamic content filter.

5 From the **Condition Tags** panel, drag a tag and drop it in the filter editor panel.
   - The tag is removed from the **Condition Tags** panel and appears in the filter editor panel along with its original group. For example, the US tag and its original group, **Others**, appear in the filter editor panel.
If you do not want the original group to appear with the tag, create a new filter group by clicking + in the filter editor panel.

A new filter group with the editable title New Group appears. Rename the title as required, for example, rename the title as US-only.

From the Condition Tags panel, drag a tag and drop it under the new filter group in the filter editor panel. For example, drag-and-drop the US tag.

The US tag is removed from the Condition Tags panel and appears under the US-only filter group without its original group Others.

(Optional) If you added multiple condition tags and filter groups in the filter editor panel, you can use the drag-and-drop method to reorder tags within and across filter groups. Similarly, you can also reorder filter groups.

Click the Drag icon against a tag or a filter group to drag it.

To provide your users the ability to select multiple filters across filter groups in the published output, select the Allow Multiple Selection field. This field is deselected by default to provide the ability to select only one filter from each filter group.

To save the changes, click the Save icon in the standard toolbar.

**Configure an output preset to generate conditional content**

To be able to generate conditional content, you must configure the appropriate output preset to use a specific condition expression and/or dynamic content filter.

1. Click the Output tab at the left side of the Standard toolbar.

The Output view opens.
2 In the Output toolbar, click the Output Presets icon.  

*Note:*

Adobe RoboHelp provides several output presets that you can use to generate output as required. If you want to use an existing output preset, proceed to Step 3.

(Optional) If you want to create a new output preset for additional custom requirements, you can add a new output preset for one of the output preset types available in RoboHelp. For information about how to create a custom output preset, see Create an output preset.

After creating an output preset, it appears in the Output Presets panel. Now proceed to Step 3.

3 In the Output Presets panel, double-click an output preset to open it.

The output preset editor panel opens with General as the default selection.

4 In the output preset editor panel, click Content.

5 In the content editor panel, do the following:
  • From the Condition Expression drop-down list, select a condition expression. By default, None is selected.
  • From the Dynamic Content Filter drop-down list, select a dynamic content filter. By default, None is selected.

6 (Optional) You can edit the selected condition expression and dynamic content filter by clicking the respective Edit icon against it.

7 To save the changes, click the Save icon in the standard toolbar.

### Generate output using a configured output preset

1 Click the Output tab at the left side of the Standard toolbar.

   The Output view opens.

2 In the Output toolbar, click the Output Presets icon.

3 In the Output Presets panel, select the configured output preset you want to publish with and click the Generate Preset icon ( ).

   Or, against the configured output preset you want to publish with, choose Options ( ) > Generate.

   While the output is being generated, a progress bar appears against the output preset.

Adobe RoboHelp displays a message confirming successful output generation. It also intimates if publishing fails.

When you create a new project, by default, output files are saved in the outputs folder inside the user area:  
<user_area>/Documents/My RoboHelp Projects/outputs/<folder_name>/<output_preset_name>.

For example:


*Note:

To change the output folder path of an output preset, do the following:

1 Against the output preset, choose Options ( ) > Edit.

2 In the preset editor panel, select General.

3 In the general editor panel, in the Output Path field, choose or type an alternative path. Choose an output path outside your main project folder.
4 To save the change, click the Save icon in the standard toolbar.

The option to change the output folder path is available for all output presets, except for Mobile App.

5 To view the output, in the Output Presets panel, against the output preset you published with, choose Options (*** > View).

Depending on the output type, it opens in its default viewer. For example, responsive output opens in your default browser. Output generated for mobile app, however, opens in a dialog box:

![Mobile App output](image)

**Note:**

If you have generated the output in a previous session and if it exists in the system, you can view it anytime, irrespective of which session you are in.

6 (Optional) To view the output log, in the Output Presets panel, against the output preset you published with, choose Options (*** > View Log).

**Note:**

Displays the log only if the output is generated (irrespective of success or failure) in the current session.
Optimize and manage conditional content

Learn how to optimize What is conditional content by managing condition tags, condition expressions, and dynamic content filters. Check out the steps to generate the conditions report.

Manage condition tags

You can add, edit, delete, and change the group of a condition tag.

1 In the Author toolbar, click the Condition Tags icon.
2 To add a tag, see Add a condition tag.
3 To edit a tag:
   a From the Condition Tags panel, double-click the condition tag that you want to edit. Alternatively, right-click a condition tag and choose Edit.
   b In the Edit Condition Tag dialog box, modify the tag group, tag name, and background and text colors as required.
   c Click Done. Changes made to the condition tag are saved.
4 To delete a tag:
   a From the Condition Tags panel, right-click a condition tag and click Delete.
   b In the Confirm dialog box, click Yes to confirm the deletion. The condition tag is deleted.
5 To change the group of a tag:
   In the Condition Tags panel, tags (such as Developer and Adventure) and their respective groups (such as, Audience and Others) appear as shown in the image:

   ![Condition Tags](image)

   To change the group of a condition tag, drag it from its current group and drop it under the target group.

   In the target group, the newly added tag is listed in alphabetical order.
6 To save the changes, click the Save icon in the standard toolbar.

Manage condition expressions and dynamic content filters

- Manage condition expressions
Conditional content

- Manage dynamic content filters

Manage condition expressions
1. Click the Output tab at the left side of the Standard toolbar.
   The Output view opens.
2. In the Output toolbar, click the Condition Expressions icon.
3. To add/configure an expression, see Configure condition expressions and dynamic content filters.
4. To edit an expression:
   a. In the Condition Expressions panel, do one of the following:
      1. Double-click the expression.
      2. Select the expression and choose Options (*** > Edit.
   a. In the expression editor panel, do the following as required:
      1. Add or remove condition tags.
      2. Modify the operators - Include/Exclude and AND/OR.
3. To rename an expression, in the Condition Expressions panel, select the expression and choose Options (*** > Rename.
4. To delete an expression, in the Condition Expressions panel, select the expression and choose Options (*** > Delete.
5. To save the changes, click the Save icon in the standard toolbar.

Manage dynamic content filters
1. Click the Output tab at the left side of the Standard toolbar.
   The Output view opens.
2. In the Output toolbar, click the Filters icon.
3. To add/configure a dynamic content filter, see Configure condition expressions and dynamic content filters.
4. To edit a filter:
   a. In the Filters panel, do one of the following:
      1. Double-click the filter.
      2. Select the filter and choose Options (*** > Edit.
   a. In the filter editor panel, do the following as required:
      1. Modify filter groups.
      2. Add or remove condition tags.
3. To delete a filter, in the Filters panel, select the filter and choose Options (*** > Delete.
4. To save the changes, click the Save icon in the standard toolbar.

Generate the conditions report
For information about generating reports, including the condition tags report, see Generate reports.
Chapter 6: Skins and master pages

Work with skins

What is a skin
A skin in RoboHelp helps you alter and customize the look and feel of your Help system before publishing it. You can customize a skin by changing colors, buttons, fonts, icons, logos, and background of your output. Whether it is Responsive Html5 or WebHelp that you want to publish, RoboHelp provides several predefined skins in the Skins panel of the publishing window. You can apply one of these predefined skins as it is or edit it to achieve the preferred output layout.

Add a skin
You can add a skin in the Responsive HTML5 or WebHelp format. To add a skin, do the following:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the Skins icon .
3. In the Skins panel, click New Skin . From the drop-down menu, click one of the following options:
   - New WebHelp Skin To add a WebHelp skin. The New WebHelp Skin dialog box opens.
   - New HTML5 Skin To add a Responsive HTML5 skin. The New Responsive HTML5 Skin dialog box opens.
4. In the New WebHelp Skin or the New Responsive HTML5 Skin dialog box, select a predefined template in the Templates section. You can preview the selected template in the Preview area.
5. In the Name field, modify the default name of the predefined template, if required.
6. Click Done.
   The new skin is added to the Skins panel and placed in alphabetical order of skin names. RoboHelp also opens the skin editor as a tab.
Edit a skin
You can easily customize a skin to suit your liking. To edit a skin, follow these steps:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the Skins icon 📋.
3. In the Skins panel, against the skin you want to customize, choose Options (*** > Edit).
   RoboHelp opens the skin editor as a tab. The skin editor comprises a live skin preview on the left and the Skin Components panel on the right side.
   In a Responsive HTML5 skin, a toolbar above the skin editor allows you to do the following:
   • Desktop icon (Default layout) Displays your content in the desktop view.
   • Phone icon Displays your content in the phone view.
   • Tablet icon Displays your content in the tablet view.
   • Toggle highlight icon Toggles the highlighting of skin components in the skin editor.
   The skin components and its settings vary according to the type of Responsive HTML5 skin view (desktop, phone, or tablet) you select.
4. In the Skin Components panel, click a skin component on the left to set your preferences for the component.
   On clicking a skin component, RoboHelp displays its current settings and highlights the component in the output preview tab. For example, clicking Filter displays its current settings and highlights the Filter icon and area in the output preview tab.
5. Specify the preferred settings for each skin component as required, and click the Save icon in the standard toolbar of the publishing window.
   RoboHelp applies the new skin settings to your content and displays it in the output preview tab.

Upgrade a skin
In case of upgradation of RoboHelp Classic projects, RoboHelp automatically upgrades all Responsive HTML5 skins.
If you customized skins outside the RoboHelp Classic skin editor, use the Layout tab of the Skin Components panel in RoboHelp 2019 to add a custom JavaScript or CSS file.
To add a custom JavaScript/CSS file, do the following:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the Skins icon 📋.
3. In the Skins panel, against the skin you want to customize, choose Options (*** > Edit).
4. In the Skin Components panel at the right side of the skin editor, Click the Layout tab.
5. Under the User Assets drop-down section, click Add Asset.
6. In the Open dialog box, navigate to choose a JavaScript/CSS file and click Open.
   The file gets added to the User Assets drop-down section. You can add multiple such files.
7. Click 🗑 against a file and use drag-and-drop to change its order in a list of files.
   Click 🗑 to delete a file.
Import a skin

To import a skin, do the following:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the Skins icon.
3. In the Skins panel, choose New Skin (+) > Import.
4. In the Open dialog box, navigate to the skin (.skz or .slz file) you want to import, and then click Open.

The selected skin is added to the Skins panel and placed in alphabetical order of skin names.

Note:

If you import a .slz file, which is a RoboHelp Classic file, it is upgraded automatically. For more information, see Upgrade a skin.

Export a skin

To export a skin, do the following:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the Skins icon.
3. In the Skins panel, against the skin you want to export, choose Options (***) > Export.
4. In the download dialog box, the Downloads folder in your computer is the default location to export a skin. You can navigate to a location of your choice, and then click Save.

The skin is saved to the chosen location.

Delete a skin

To export a skin, do the following:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the Skins icon.
3. In the Skins panel, against the skin you want to delete, choose Options (***) > Delete.
4. In the Confirm dialog box, click Yes to confirm the deletion.

The skin is deleted.

Locate a skin file in your computer

To see the location of a skin file in your computer, do the following:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the Skins icon.
3. In the Skins panel, against the skin you want to locate, choose Options (***) > Show in Explorer.

Windows Explorer opens to display the skin file and its location.
Work with master pages

What is a master page

An HTML page comprises three elements: content, layout, and styling. For single sourcing, it is best to separate content from layout and styling. Although CSS files separate styling from content, layout remains embedded in the HTML code. By using master pages, you can separate layout and styling from content.

A master page contains layout information and is associated with a CSS file. A master page is a template for HTML topics. You can define the placeholders for header, footer, and topic. You can include breadcrumbs, Mini TOC, snippets, variables, fields, and symbols. You can also apply condition tags to a master page.

You can create a topic using a master page or associate an existing topic with a master page. When you create a topic using a master page, the topic placeholder content is placed in the resulting topic. If you apply a master page to an existing topic, the topic placeholder content is ignored. In this case, actual content of the topic replaces the topic placeholder in the master page at the time of preview and generation.

The layout information defined in master pages is not visible in Author view. You can see the layout when you generate output or preview an associated topic. The topic content is placed in the topic placeholder, and the layout is inherited from the master page. All placeholders defined in the master page are also populated with relevant information when you generate output.

You can also import and export master pages to use across projects.

Add a master page

You can add a master page in two ways:

- From the Master Pages panel: When you add a master page using the Master Pages panel or upgrade to RoboHelp 2019 from a previous version, by default, the master page files are stored in the assets/masterpages folder in the Contents panel.
- From the Contents panel: When you add a master page to a different project folder in the Contents panel, the master page files are stored in that project folder.

Irrespective of the location in which you add a master page, access and manage all master pages in your project from the Master Pages panel.

To add a master page:

1. Click the Author tab at the left side of the Standard toolbar.
   The Author view opens.

2. To add a master page through the Master Pages panel:
   a. In the Author toolbar, click Master Pages. The Master Pages panel opens.
   b. Click + in the upper-right corner of the panel. The New Master Page dialog box opens.

   To add a master page through the Contents panel:
   c. In the Author toolbar, click Contents. The Contents panel opens.
   d. In the Contents panel, right-click a folder, or click Options (***), and choose New > New Master Page.
      The New Master Page dialog box opens.
3 In the **New Master Page** dialog box, specify the name of the master page and click **Done**.

The new master page is added to the **Master Pages** panel and placed in alphabetical order.

4 Click the **Save All** icon at the left side of the standard toolbar.

### Edit a master page

You can easily customize a master page to suit your liking. To edit a master page:

1 Click the **Author** tab at the left side of the Standard toolbar.

   The Author view opens.

2 In the Author toolbar, click **Master Pages**. The **Master Pages** panel opens.

3 In the **Master Pages** panel, against the master page you want to customize, choose **Options (*** > Edit**.

   The master page opens as a tab, displaying the header, topic, and footer placeholders.

   When you create a topic from a master page, the topic includes content from the master page. Copyright information is an example. When you apply a master page to a topic, actual content of the topic replaces the topic placeholder in the master page at the time of preview and generation.

4 Customize the header, topic, and footer placeholders as required by inserting breadcrumbs, variables, snippets, Mini TOC, fields, and symbols. You can also apply condition tags to the master page.

   For more information, see the following resources:

   • Insert breadcrumbs
   • Insert variables
   • Insert and customize a Mini TOC
   • Insert a symbol
   • Insert snippets
   • Insert a field
   • Apply to a master page

5 To insert a paragraph between placeholders, hover the pointer above the appropriate placeholder and click the **Insert paragraph** indicator.

6 Click the **Save All** icon at the left side of the standard toolbar.
Insert breadcrumbs

You can insert breadcrumbs placeholder in an open master page. The placeholder shows the automatically generated breadcrumbs at the time of generation of Help topic. The breadcrumbs are generated based on the TOC.

1. In the standard toolbar, click the Insert Breadcrumbs Placeholder icon ➔. The breadcrumbs placeholder is inserted at the location of the pointer.

2. Click the breadcrumbs placeholder to set its properties.

   The Properties panel > General tab displays the Type as Breadcrumbs.

3. In the General tab, do the following:
   - Home Page Name Specify the name of the home page of your Help.
   - Separator Specify or select a separator to separate the elements in breadcrumbs. The default is >.
   - Prefix Label Specify a label that is prefixed to the breadcrumbs. For example, Navigate to:

4. Click the Save All icon at the left side of the standard toolbar.

Insert and customize a Mini TOC

You can insert a Mini TOC in a topic or a master page. The Mini TOC placeholder shows the automatically generated Mini TOC at the time of generation or preview of a topic. You can define the exact location and format of the Mini TOC while designing the layout of the master page. You can also customize the heading levels as required.

To insert a Mini TOC in an open topic or master page:

1. In the standard toolbar, click the Insert Mini TOC Placeholder icon ➔. The Mini TOC placeholder is inserted at the location of the cursor.

2. Click the Mini TOC placeholder to set its properties.

   The Properties panel > General tab displays the Type as Mini TOC Caption or Mini TOC List, depending on the location of the pointer.

   You can apply inline formatting using the General tab or a style from your style sheet using the Styles tab.

3. To apply inline formatting, in the General tab, do the following:

   - For Type: Mini TOC Caption
     - Select Make list collapsible to toggle the Mini TOC between expanded and collapsed states. You can then specify a different caption for each state in the Caption when Expanded and Caption when Collapsed fields. By default, the mini TOC is in the expanded state initially, you can choose to collapse it by deselecting the Show TOC in expanded form field.
- If you do not select **Make list collapsible**, you can specify a default caption in the **Caption** field.
- Use various **Font** options to change the font family, style, size, color, and more.
- Use the **Background** options to change the background shade, and add and customize the dimensions of the background image.

**For Type: Mini TOC List**

- In the **Use Headings** field, use the **from** and **to** drop-downs to customize the heading levels. The default range of heading levels is 2 – 4. You can include heading 1 also.
- Use various **Font** options to change the font family, style, size, color, and more.
- Use the **Background** options to change the background shade, and add and customize the dimensions of the background image.

4 To apply a style from your style sheet, in the **Styles** tab, do the following:

**For Type: Mini TOC Caption**

- Select **Paragraph Styles** or **Hyperlink Styles** from the styles drop-down list. If the Mini TOC list is not collapsible, the default caption style is paragraph. If the list is collapsible, the default caption style is hyperlink.
- From the list of styles, select a style to apply it.

**Note:**

*By default, the following styles are applied to different parts in a Mini TOC placeholder:*

- **minitoc-caption** to a caption
- **minitoc-list** to a list
- **minitoc-list-item** to each list item

*These styles are defined in your project’s default style sheet (default.css). In a new project, you can control all aspects of Mini TOC styling by copying new classes from default.css. You can also **Add or edit twisty images** to Mini TOC Caption when it is collapsible.*

**For Type: Mini TOC List**

- Select **List Styles** from the styles drop-down list.
- From the list of styles, select a style to apply it.

5 Click the **Save All** icon at the left side of the standard toolbar.

### Insert a field

You can insert system or project variables, such as date, time, project title and more, as fields in an open topic or master page. Fields are read-only, and not customizable.

To insert a field in an open topic or master page:

1 In the standard toolbar, click the **Insert Variables/Snippets/Fields** icon, and then click Field. The **Fields** dialog box opens.

2 In the **Fields** dialog box, use the drop-downs to select a field and its format. For example, if you select the **Field** as **Date**, select the **Format** as **default**, **DD-MM-YYYY**, or **MM-DD-YYYY**.

3 Click **Insert**. The selected field in the selected format is inserted at the location of the pointer.

4 Click the **Save All** icon at the left side of the standard toolbar.
Skins and master pages

Insert a symbol
You can insert a symbol in an open topic or master page. To do so, click the Insert Symbol icon in the standard toolbar, and select a symbol from symbols displayed. The selected symbol is inserted at the location of the pointer.

Create a topic with a master page
While creating a topic, you can associate it with a master page. For more information, see Create a topic.

Associate a topic with a master page
You can associate an existing topic with a master page by editing the topic’s properties. For more information, see Set topic properties.

Create a duplicate master page
You can create a duplicate copy of a master page with a different name and modify it to suit your requirements.

1 Click the Author tab at the left side of the Standard toolbar.
   The Author view opens.
2 In the Author toolbar, click Master Pages. The Master Pages panel opens.
3 In the Master Pages panel, against the master page you want to duplicate, choose Options (***) > Duplicate.
4 In the Duplicate Master Page dialog box, specify the name of the duplicate copy and click Done.
   The duplicate master page is added to the Master Pages panel and placed in alphabetical order.
5 Customize the duplicate master page if necessary. For more information, see Edit a master page.
6 Click the Save All icon at the left side of the standard toolbar.

Delete a master page
To delete a master page:

1 Click the Author tab at the left side of the Standard toolbar.
   The Author view opens.
2 In the Author toolbar, click Master Pages. The Master Pages panel opens.
3 In the Master Pages panel, against the master page you want to delete, choose Options (***) > Delete.
4 In the Confirm dialog box, click Yes to confirm the deletion.
   The master page is deleted.
5 Click the Save All icon at the left side of the standard toolbar.

Locate a master page file in your computer
To see the location of a master page file in your computer:

1 Click the Author tab at the left side of the Standard toolbar.
   The Author view opens.
2 In the Author toolbar, click Master Pages. The Master Pages panel opens.
In the Master Pages panel, against the master page you want to locate, choose Options (*** > Show in Explorer). Windows Explorer opens to display the master page file and its location.

**Work with labels**

**What are labels**
Labels are the display text of various elements of the Help system (output) generated for your end users. For example, the text in previous and next buttons in browse sequences, show/hide and other buttons, tabs, tool tips, and some messages. In PDF outputs, labels are the titles of TOC, index, and glossary pages.

Any text in the output that does not come from your project content is picked from label files. A label file is language-specific and contains labels grouped in various categories such as common, browse sequence, and master page. Each category lists the appropriate labels and its values.

RoboHelp adds a label file in the default language, which is the same as your project language. You can edit the default language file to customize labels in the default language. To customize labels in a language of your choice, you can add, import, or export a label file and then edit it. For example, you can change the default text “Search” on the Search tab to “Find” in a language of your choice.

**Add labels**
To add a label file in a language of your choice, do the following:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the Labels icon 📝.
3. In the Labels panel, click New Language +.
4. The New Language dialog box, choose the language in which you want to add labels from the Name drop-down list.
5. Click Done.

The new label file is named according to the chosen language. The file is added to the Labels panel and placed in alphabetical order of label names. RoboHelp also opens the labels editor as a tab.

6. Click the Save All icon 🗂️ at the left side of the standard toolbar.

**Edit a label file**
You can easily customize labels to suit your liking. To customize labels:

1. Click the Output tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the Labels icon 📝.
3. In the Labels panel, double-click to open the label file that you want to customize. Or, against a label file, choose Options (*** > Edit.

RoboHelp opens the labels editor as a tab.

4. In the labels editor, click to expand a drop-down section. To customize a label in the drop-down section, edit its value.
Click the **Save All** icon at the left side of the standard toolbar.

**Delete a label file**
To delete a label file:
1. Click the **Output** tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the **Labels** icon .
3. In the Labels panel, against the label you want to delete, choose **Options (*** > Delete.**
4. In the **Confirm** dialog box, click **Yes** to confirm deletion.
5. Click the **Save All** icon at the left side of the standard toolbar.

**Import a label file**
To import a label file:
1. Click the **Output** tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the **Labels** icon .
3. In the Labels panel, against a label, choose **Options (*** > Import.
4. In the **Open** dialog box, navigate to the label (.lng) file you want to import, and then click **Open**.
   - The selected label file is added to the Labels panel and placed in alphabetical order of label names.
5. Click the **Save All** icon at the left side of the standard toolbar.

**Export a label file**
To export a label file:
1. Click the **Output** tab at the left side of the Standard toolbar. The Output view opens.
2. In the Output toolbar, click the **Labels** icon .
3. In the Labels panel, against the label file you want to export, choose **Options (*** > Export.
4. In the **Export** dialog box, navigate to the location at which you want to export the label file, and then click **Save**.
   - Only the modified labels are exported to the chosen location.
5. Click the **Save All** icon at the left side of the standard toolbar.
Chapter 7: Generating output

Generate output

RoboHelp comes with powerful publishing capabilities so you can generate your output in many formats. Choose from a variety of output preset types, such as Responsive HTML5, PDF, and Mobile App, and cater to users from various platforms. Output presets are easy-to-configure; you can use the many settings to create multiple Help systems from the same project with different content, layouts, and experiences.

With RoboHelp (2019 release), you can experience a smooth output generation, even as you continue working on your project.

Types of output presets

You can generate your project output using a desired type of output preset. The following types of output presets are available in RoboHelp:

- Generate Responsive HTML5 output
- Generate PDF output
- Generate Microsoft HTML Help output
- Generate WebHelp output
- Generate Mobile App output
- Generate eBook output

Work with an output preset to generate output

Before you generate your project output in RoboHelp, you need to create and configure an output preset. Once the output preset is ready, you can use the preset to generate the output.

- Create an output preset
- Generate output
- Configure an output preset

Create an output preset

To create an output preset in RoboHelp, follow these steps:

1. In an open project, do one of the following:
   - Click Quick Generate in the upper-right corner of the Standard toolbar and click the Edit Settings icon.
   - Click the Output tab at the left side of the Standard toolbar.
   The Output view opens.

2. In the Output toolbar, click Output Presets. The Output Presets panel opens.
3 In the **Output Presets** panel, click +.

4 In the **New Preset** dialog box, specify the following:
   - **Name**: Specify a name for the output preset.
   - **Type**: Use the drop-down list to select a desired output preset type. You can choose from Responsive HTML5, PDF, Microsoft HTML Help, WebHelp, Mobile App, and EBook.

5 In the **Publish** toolbar, select **Output Presets**.

6 Click **Done**.

You can access the output preset from the **Output Presets** panel in the **Output** toolbar. Alternatively, you can access the output preset in the **Quick Generate** dialog box of the authoring window.

**Note:**

To identify the type of output preset from the **Output Presets** panel or in the **Quick Generate** dialog box, check the icon before the output preset name. The following icons correspond to the given types of output presets:

- Responsive HTML5
- Printed documentation
- Microsoft HTML Help
- WebHelp
- Mobile App
- EBook

**Configure an output preset**

To configure the settings of an output preset, follow these steps:

1 In an open project, do one of the following:
   - Click **Quick Generate** in the upper-right corner of the Standard toolbar and click the **Edit Settings** icon 🌍.
   - Click the **Output** tab at the left of the Standard toolbar.

2 In the Output toolbar, click **Output Presets**. In the **Output Presets** panel, do one of the following:
   - Double-click the desired output preset.
   - Click the ⚡️ icon next to the desired output preset and select **Edit**.

3 Based on the type of your output preset you had chosen, you can view tabs such as **General**, **Content**, and more to configure settings.

To know more about how to configure a type of output preset, see the following resources:

- Configure Responsive HTML5 output preset
- Configure PDF output preset
- Configure Microsoft HTML Help output preset
- Configure WebHelp output preset
- Configure Mobile App output preset
- Configure EBook output preset

**Note:**

Last updated 2/20/2019
The entire project is not included in the output generated. In the Contents tab > Table of Contents field, the selected Table of Contents determines what is included. That is, only the topics (and the referenced files inside these topics) in the selected Table of Contents file are included.

4 To save your settings, click Save All icon in the upper-left corner of the standard toolbar.

Generate output
Once you've configured your desired output preset, you're set to generate your output. To do this, follow these steps:

1 In the authoring window of an open project, click Quick Generate in the upper-right corner of the standard toolbar.

2 In the Quick Generate dialog box, select your desired output preset, and click Generate.

Note: Alternatively, you can do the following to generate output:

1 Click the Output tab at the left side of the Standard toolbar.

2 In Output view, in the Output toolbar, click Output Presets.

3 In the Output Presets panel, select an output preset and click Generate Preset. Or, against an output preset, choose Options > Generate.

A progress bar displays the progress of output generation. To cancel output generation, click . After output generation is complete, to view the output, click . If the output generation is not successful, click to view the error log.

Note: Before generating output, you can also edit multiple output presets through the Quick Generate dialog box. To do so:

1 Select the output presets you want to edit, and click Edit. The preset editor for each output preset opens in Output view.

2 Use tabs such as General, Content, and Layout to edit the properties of each output preset.

3 Generate output using the Output Presets panel in Output view. Or, go back to Author view, open the Quick Generate dialog box, select the edited output presets, and click Generate.

Manage output presets
You can easily duplicate an available output preset or delete it from the Output Presets panel and the Quick Generate dialog box.

- Rename an output preset
- Delete an output preset
- Duplicate an output preset
- Locate an output preset file in your computer

Rename an output preset
1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, against the output preset you want to rename, choose Options > Rename.
4 In the **Rename Preset** dialog box, specify the name of the output preset.
5 Click **Done**.

**Duplicate an output preset**

1 Do one of the following:
   • Click **Quick Generate** in the upper-right corner of the standard toolbar and click the **Edit Settings** icon.
   • Click the **Output** tab at the left side of the Standard toolbar.
   
   The Output view opens.

2 In the Output toolbar, click **Output Presets**. The **Output Presets** panel opens.
3 In the **Output Presets** panel, click **Options** next to your desired output preset.
4 In the **Options** drop-down list, select **Duplicate**.
5 Specify **Name** of the duplicate output preset and click **Done**.

**Delete an output preset**

1 Do one of the following:
   • Click **Quick Generate** in the upper-right corner of the standard toolbar and click the **Edit Settings** icon.
   • Click the **Output** tab at the left side of the Standard toolbar.
   
   The Output view opens.

2 In the Output toolbar, click **Output Presets**. The **Output Presets** panel opens.
3 In the **Output Presets** panel, select your desired output preset and click **Options**.
4 In the **Options** drop-down list, select **Delete**. In the **Confirm** dialog box, click **Yes**.

**Locate an output preset file in your computer**

1 Click the **Output** tab at the left side of the Standard toolbar.
   
   The Output view opens.

2 In the Output toolbar, click **Output Presets**. The **Output Presets** panel opens.
3 In the **Output Presets** panel, against the output preset you want to locate, choose **Options** > **Show in Explorer**.
   
   Windows Explorer opens to display the output preset file and its location in your computer.

**Tips for optimal output generation**

• Ensure that your system has sufficient memory. See RoboHelp system requirements for more details.

• To generate Mobile App output, you will require Internet connection.

**Generate Responsive HTML5 output**
What is Responsive HTML5 output

Generating Responsive HTML5 output makes your project output consumable on devices of various screen sizes. This means that you can publish content that is optimized to fit screens of popular devices, such as iPad, iPhone, and more.

Responsive HTML5 output can be viewed both online and offline. You can publish the output on HTTP and HTTPS servers. For information about supported browsers, see RoboHelp system requirements.

Configure a Responsive HTML5 output preset

The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various settings of the output preset. You can use the following settings to configure a Responsive HTML5 output preset:

General
Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more:

Title Specify the title for the generated output.

You can use variables in the title. To do so, type `{ and select a variable from the drop-down list, and then press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output generation, the value of the selected variable is picked from the variable set.

The title, along with the variables if used, appears on the browser tab of the output.

Favicon Specify an icon to associate with the output. This icon appears on the browser tab of the output. Click to browse and select a desired icon.

Output Path Specify a location for the output. To select a location, click .

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the contents of the folder before generating the output.

Start Page Specify the page name and extension (.htm or .html) that RoboHelp can use to generate the URL for the output. For example, specify index.html.

Language Use the drop-down list to specify a language for the output preset if the language of the UI of the generated output needs to be different from the language of the content specified in project settings.

Encoding Use the drop-down list to specify the type of character encoding format to be used for your content.

Use lowercase file names Select to generate all output files with lowercase filenames.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, glossary, and condition expression:

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected by default.

Browse Sequence Use the drop-down list to view the defined browse sequences in your project. You can select more than one browse sequence. The selected browse sequences are then merged for the output. If there is a conflict with the selected browse sequences, the first selection is given preference.

Default Topic Click to select the topic that displays in the Topic panel when you open the output. By default, the first topic in the Table of Contents selected for this output is the default topic.
Include Index Select this setting to include the index in the output.

Glossary Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to easily access relevant terms in your project, with the corresponding definitions.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows you to easily include or exclude content depending on the desired type of output or userbase. Click to edit the selected condition expression. You can also select None in the drop-down list to not specify a condition expression.

Dynamic Content Filter Use the drop-down list to select a dynamic content filter so your end users can filter content in the generated output. Click to edit the selected Dynamic Content Filter. Alternatively, select None in the drop-down list to not specify a dynamic content filter.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-specific use of variables. For example, you can have different variable sets for generating output for customers and internal users.

Layout
Use the following options to configure the appearance of your output:

Master Page Use the drop-down list to select the master page for the output you are generating.

Skin Use the drop-down list to select a skin to apply in your output.

Create thumbnail for images Select this setting to convert images to thumbnails in the output. These images can be enlarged when the user clicks them.

Search
Use the following options to specify search-related settings for your output:

Use topic description as search context Select this setting to display the topic description with the title in search topic results. In Set a Character limit, enter the maximum number of characters to be displayed in the topic description. To set a topic description, right-click a topic in the Contents panel and select Properties. In the Topic Properties dialog box, enter the description in Description and click Apply.

Enable auto complete in search box Select this option to display predictive options for the search query based on the initial characters typed by users.

Auto correct search query Select this option to correct misspelled terms that are typed during search. This setting corrects up to one character in each word typed during search. This ensures that you receive relevant search results, even if you enter a misspelled term.

Show definitions from glossary Select this option to display definitions of search terms from the glossary selected for this output. If the search term matches a glossary term, the definition of the term is displayed.

Generate XML sitemap Select this setting to generate a sitemap for your published output. The sitemap.xml file in the published output contains the sitemap. You can then submit this file to your search engine to improve search results for your site. To submit the sitemap.xml file, follow the procedure described in your search engine's documentation. In Base URL of the hosted content, enter the relative URL of the site. In Frequency of content change, specify a cadence for indexing the content.

Select file types to exclude from search You can exclude specific types of files, such as PDF, Word, and Excel, from search. The content from the selected files will not be included during search.

Note:
Generating output

After you’ve configured an output preset, you can access it in the Quick Generate dialog box of the authoring window or in the Output Presets panel of the publishing window.

**Generate Responsive HTML5 output**

1. In the authoring window of your project, click the Quick Generate icon in the upper-right corner of the standard toolbar. Alternatively, select Quick Generate in the Output menu.

2. Select a Responsive HTML5 output preset in the Quick Generate dialog box.

3. To configure the settings, do one of the following:
   - Click the Edit Settings icon in the Quick Generate dialog box.
   - Click the Output tab at the left side of the Standard toolbar.

   The Output view opens.

4. In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:
   - Double-click the desired Responsive HTML5 output preset.
   - Click the ** icon next to the desired output preset and select Edit.

5. See Configure a Responsive HTML5 output preset to configure the output settings.

6. To save your settings, click the Save icon in the upper-left corner of the standard toolbar in the Output view.

7. Click the Generate Preset icon in the Output Presets panel.

   You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output generation is complete, a Success dialog box is visible at the lower-right corner of the screen.

   After the output generation is complete, click in the Output Presets panel to view the output.

   **Note:**

   Alternatively, you can generate the output in the authoring window. Click Quick Generate in the toolbar, select the desired output preset, and click Generate.

   You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, click next to the output preset to view the output. In case the output generation failed, click next to the selected output preset to view the error log.

**Generate PDF output**

**What is PDF output**

Generating PDF output helps you distribute your project output to millions of users. Adobe PDF or Portable Document Format is a universal file format for viewing, sharing, and printing content. PDFs preserve fonts, images, and layout of content created with different applications and platforms. They are compact, easy to navigate with links, and effective in printing workflows.

**Note:**

You require Adobe Reader software to view PDF files.
Configure a PDF output preset

The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various settings of the output preset. You can use the following settings to configure a PDF output preset:

**General**
Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more.

**Title** Specify the title for the generated output. This is part of the metadata.

You can use variables in the title. To do so, type `{` and select a variable from the drop-down list, and then press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output generation, the value of the selected variable is picked from the variable set.

The title, along with the variables if used, appears on the browser tab of the output.

**Output Path** Specify a location for the output. To select a location, click . Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the contents of the folder before generating the output.

**PDF File** Specify the name and extension (.pdf) of the output file to be generated. For example, specify Printed_Documentation.pdf.

**Language** Use the drop-down list to specify a language for the titles of Index, Glossary, and Table of Contents in your output. Specify this setting if you want to change the language specified in project settings.

**Content**
Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, glossary, and condition expression.

**Table Of Contents** Use the drop-down list to select a desired Table of Contents in your project. Only the topics that are in the selected Table of Contents are displayed in the output. The sequence of files in your project form the hierarchical Table of Contents.

**Cover Page** Click to select the file that first appears when you view the output.

**Include Index** Select this setting to include the index in the output.

**Glossary** Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to easily access relevant terms in your project, with the corresponding definitions.

**Condition Expression** Use the drop-down list to specify the condition expression for your output. This setting allows you to easily include or exclude content depending on the desired type of output or userbase. Click to edit the selected condition expression. You can also select None in the drop-down list to not specify a condition expression.

**Variable Set** Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can select <Default Variable Set> to use the project’s default variable set. Variable sets allow you to implement output-specific use of variables. For example, you can have different variable sets for generating output for customers and internal users.

**Layout**
Use the following options to specify details of appearance in your output.

**Master Page** Use the drop-down list to select the master page for the output you are generating.
Multiple Header/Footer Select this option to specify master pages to assign header and footer settings for TOC, Chapter Layout (topics), Index, and Glossary pages in your output. Each of these types of pages have the following settings for header and footer:

- **First Page** Specify the master page for the first page in your output.
- **Use this header for all sections** Select this setting to use the given header in all sections in the output, such as paragraphs and headings.
- **Even Pages** Specify a master page for only the even pages in your output.
- **Odd Pages** Specify a master page for only the odd pages in your output.

Header/Footer If you don’t select the above option, you can select a master page to set common header and footer settings for all pages in your output.

PDF

Use the following options to specify the page size, TOC depth, and page margin settings.

**Page Size** Use the drop-down list to select a desired page size for your output. You can choose from options such as A4, A3, Letter, and more. You can also select Custom to specify your own page width (in mm) and page height (in mm).

**Limit TOC depth** Specify the number of sublevels of topics to display in the Table of Contents of your output.

**Page Margin** Specify the desired page margin in mm. You can specify the page margin for specific sides using the following icons:
- Specify the top page margin.
- Specify the bottom page margin.
- Specify the left page margin.
- Specify the right page margin.

To have equal page margins on all sides of the page, click ⬇️.

Generate PDF output

1 In the authoring window of your project, click the Quick Generate icon in the upper-right corner of the standard toolbar.
2 Select a PDF output preset in the Quick Generate dialog box.
3 To configure the settings, do one of the following:
   - Click the Edit Settings icon in the Quick Generate dialog box.
   - Click the Output tab at the left side of the Standard toolbar.
     The Output view opens.
4 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:
   - Double-click the desired PDF output preset.
   - Click the icon next to the desired output preset and select Edit.
5 See Configure a PDF output preset to configure the output settings.
6 To save your settings, click the Save icon in the upper-left corner of the standard toolbar in the Output view.
7 Click the Generate Preset icon in the Output Presets panel.
You can then view a progress bar next to the selected output preset in the **Output Presets** panel. Once the output generation is complete, a **Success** dialog box is visible at the lower-right corner of the screen.

After the output generation is complete, click ![Output Presets](image) in the **Output Presets** panel to view the output.

**Note:**

Alternatively, you can generate the output in the authoring window. Click **Quick Generate** on the toolbar, select the desired output preset, and click **Generate**.

You can then view a progress bar in the **Quick Generate** dialog box. After the output generation is complete, click ![Output Presets](image) next to the output preset to view the output. In case the output generation failed, click ![Output Presets](image) next to the selected output preset to view the error log.

---

**Generate Microsoft HTML Help output**

**What is Microsoft HTML Help output**

Generating Microsoft HTML output in RoboHelp helps you create in-app Help for Windows desktop apps.

The main components of HTML Help include the following:

- **Compressed HTML**: A collection of all files in the project in a single CHM file that occupies less disk space and is faster to load. You can ship this compiled file with an application or distribute it to users as a stand-alone online document.

- **HTML Help viewer**: Displays compiled HTML Help (CHM file). It uses components of the Internet Explorer browser while displaying content in its proprietary window interface.

- **Layout engine**: Microsoft Internet Explorer 6 and later supply the required components for HTML Help support.

- **HTML Help ActiveX control**: Supports navigation features, such as the Table of Contents, index, and link controls (related topics and keyword links). It also supports HTML Help controls: WinHelp topic links, startup screens, and close window controls.

**Configure a Microsoft HTML Help output preset**

The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various settings of the output preset. You can use the following settings to configure a Microsoft HTML output preset:

**General**

Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more.

**Title** Specify the title for the generated output.

You can use variables in the title. To do so, type `{` and select a variable from the drop-down list, and then press `Enter`. Note that if you have provided a variable set in the **Content** tab > **Variable Set** field, during output generation, the value of the selected variable is picked from the variable set.

The title, along with the variables if used, appears on the browser tab of the output.

**Output Path** Specify a location for the output. To select a location, click ![Output Path](image).
Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the contents of the folder before generating the output.

**CHM file** Specify the CHM filename with extension *.chm*.

**Language** Use the drop-down list to specify a language for the tab titles in the output. Specify this setting if you want to change the specified language in project settings.

**Content**

Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, glossary, and condition expression.

**Table Of Contents** Use the drop-down list to select a Table of Contents to be included in the output. This drop-down list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected by default.

**Default Topic** Click to select the topic that displays in the Topic panel when you open the output. By default, the first topic in the Table of Contents selected for this output is the default topic.

**Include Index** Select this setting to include the index in the output.

**Glossary** Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to easily access relevant terms in your project, with the corresponding definitions.

**Condition Expression** Use the drop-down list to specify the condition expression for your output. This setting allows you to easily include or exclude content depending on the desired type of output or userbase. Click to edit the selected condition expression. You can also select None in the drop-down list to not specify a condition expression.

**Variable Set** Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can select `<Default Variable Set>` to use the project's default variable set. Variable sets help you implement output-specific use of variables. For example, you can have different variable sets for generating output for customers and internal users.

**Layout**

Use the following options to configure the appearance of your output.

**Master Page** Use the drop-down list to select the master page for the output you are generating.

**Note:**

*After you’ve configured an output preset, you can access it in the Quick Generate dialog box of the authoring window or in the Output Presets panel of the publishing window.*

**Generate Microsoft HTML Help output**

1. In the authoring window of your project, do one of the following, click the Quick Generate icon in the upper-right corner of the standard toolbar.

2. Select a Microsoft HTML Help output preset in the Quick Generate dialog box.

3. To configure the settings, do one of the following:
   - Click the Edit Settings icon in the Quick Generate dialog box.
   - Click the Output tab at the left side of the Standard toolbar.

The Output view opens.
In the Output toolbar, click **Output Presets**. In the **Output Presets** panel, do one of the following:

- Double-click the desired Microsoft HTML Help output preset.
- Click the **Edit** icon next to the desired output preset and select **Edit**.

See [Configure a Microsoft HTML Help output preset](#) to configure the output settings.

To save your settings, click the **Save** icon in the upper-left corner of the standard toolbar in the Output view.

Click the **Generate Preset** icon in the **Output Presets** panel.

You can then view a progress bar next to the selected output preset in the **Output Presets** panel. Once the output generation is complete, a **Success** dialog box is visible in the lower-right corner of the screen.

After the output generation is complete, click **Output Presets** in the **Output Presets** panel to view the output.

**Note:**

Alternatively, you can generate the output in the authoring window. Click **Quick Generate** on the toolbar, select the desired output preset, and click **Generate**.

You can then view a progress bar in the **Quick Generate** dialog box. After the output generation is complete, click **Output Presets** next to the output preset to view the output. In case the output generation failed, click **Output Presets** next to the selected output preset to view the error log.

---

**Generate WebHelp output**

**What is WebHelp output**

WebHelp output can be viewed on the web or using a desktop application. This output type works with any browser and platform and provides several customization capabilities.

**Configure a WebHelp output preset**

The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various settings of the output preset. You can use the following settings to configure a WebHelp output preset:

**General**

Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more:

**Title** Specify the title for the generated output.

You can use variables in the title. To do so, type `/` and select a variable from the drop-down list, and then press `Enter`. Note that if you have provided a variable set in the Content tab > Variable Set field, during output generation, the value of the selected variable is picked from the variable set.

The title, along with the variables if used, appears on the browser tab of the output.

**Favicon** Specify an icon to associate with the output. This icon appears on the browser tab of the output. Click to browse and select a desired icon.

**Output Path** Specify a location for the output. To select a location, click .
Generating output

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the contents of the folder before generating the output.

**Start Page** Specify the page name and extension (.htm or .html) that RoboHelp can use to generate the URL for the output. For example, specify index.html.

**Language** Use the drop-down list to specify a language for the output preset if the language of the UI of the generated output needs to be different from the language of the content specified in project settings.

**Encoding** Use the drop-down list to specify the type of character encoding format to be used for your content.

**Use lowercase file names** Select to generate all output files with lowercase filenames.

**Content**

Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, glossary, and condition expression:

**Table Of Contents** Use the drop-down list to select a Table of Contents to be included in the output. This drop-down list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected by default.

**Browse Sequence** Use the drop-down list to view the defined browse sequences in your project. You can select more than one browse sequence. The selected browse sequences are then merged for the output. If there is a conflict with the selected browse sequences, the first selection is given preference.

**Default Topic** Click to select the topic that displays in the Topic panel when you open the output. By default, the first topic in the Table of Contents selected for this output is the default topic.

**Include Index** Select this setting to include the index in the output.

**Glossary** Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to easily access relevant terms in your project, with the corresponding definitions.

**Condition Expression** Use the drop-down list to specify the condition expression for your output. This setting allows you to easily include or exclude content depending on the desired type of output or userbase. Click to edit the selected condition expression. You can also select None in the drop-down list to not specify a condition expression.

**Dynamic Content Filter** Use the drop-down list to select a dynamic content filter so your end users can filter content in the generated output. Click to edit the selected Dynamic Content Filter. Alternatively, select None in the drop-down list to not specify a dynamic content filter.

**Variable Set** Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can select <Default Variable Set> to use the project’s default variable set. Variable sets allow you to implement output-specific use of variables. For example, you can have different variable sets for generating output for customers and internal users.

**Layout**

Use the following options to configure the appearance of your output:

**Master Page** Use the drop-down list to select the master page for the output you are generating.

**Skin** Use the drop-down list to select a skin to apply in your output.

**Create thumbnail for images** Select this setting to convert images to thumbnails in the output. These images can be enlarged when the user clicks them.

Last updated 2/20/2019
Generating output

Search
Use the following options to specify search-related settings for your output:

Use topic description as search context Select this setting to display the topic description with the title in search topic results. In Set a Character limit, enter the maximum number of characters to be displayed in the topic description. To set a topic description, right-click a topic in the Contents panel and select Properties. In the Topic Properties dialog box, enter the description in Description and click Apply.

Enable auto complete in search box Select this option to display predictive options for the search query based on the initial characters typed by users.

Auto correct search query Select this option to correct misspelled terms that are typed during search. This setting corrects up to one character in each word typed during search. This ensures that you receive relevant search results, even if you enter a misspelled term.

Show definitions from glossary Select this option to display definitions of search terms from the glossary selected for this output. If the search term matches a glossary term, the definition of the term is displayed.

Generate XML sitemap Select this setting to generate a sitemap for your published output. The sitemap.xml file in the published output contains the sitemap. You can then submit this file to your search engine to improve search results for your site. To submit the sitemap.xml file, follow the procedure described in your search engine's documentation. In Base URL of the hosted content, enter the relative URL of the site. In Frequency of content change, specify a cadence for indexing the content.

Select file types to exclude from search You can exclude specific types of files, such as PDF, Word, and Excel, from search. The content from the selected files will not be included during search.

Note:
After you've configured an output preset, you can access it in the Quick Generate dialog box of the authoring window or in the Output Presets panel of the publishing window.

Generate WebHelp output
1 In the authoring window of your project, click the Quick Generate icon in the upper-right corner of the standard toolbar. Alternatively, select Quick Generate from the Output menu.
2 Select a WebHelp output preset in the Quick Generate dialog box.
3 To configure the settings, do one of the following:
   • Click the Edit Settings icon in the Quick Generate dialog box.
   • Click the Output tab at the left side of the Standard toolbar.
   The Output view opens.
4 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:
   • Double-click the desired WebHelp output preset.
   • Click the icon next to the desired output preset and select Edit.
5 See Configure a WebHelp output preset to configure the output settings.
6 To save your settings, click the Save icon in the upper-left corner of the standard toolbar in the Output view.
7 Click the Generate Preset icon in the Output Presets panel.
   You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output generation is complete, a Success dialog box is visible at the bottom-right corner of the screen.
Generating output

After the output generation is complete, click in the Output Presets panel to view the output.

Note:
Alternatively, you can generate the output in the authoring window. Click Quick Generate on the toolbar, select the desired output preset, and click Generate.

You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, click next to the output preset to view the output. In case the output generation failed, click next to the selected output preset to view the error log.

Generate Mobile App output

What is Mobile App output
In RoboHelp, the Mobile App output preset allows you to generate an Android or iOS mobile application as your project output.

Note:
To generate a mobile app using RoboHelp, you require a PhoneGap account. If you don’t have a PhoneGap account, you can create one in the PhoneGap ID section of the output preset settings in RoboHelp.

Configure a Mobile App output preset
The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various settings of the output preset. You can use the following settings to configure a Mobile App output preset:

General
Language Use the drop-down list to specify a language for the output preset if the language of the UI of the generated output needs to be different from the language of the content.

Encoding Use the drop-down list to specify the type of character encoding format to be used for your content.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, glossary, and condition expression:

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected by default.

Browse Sequence Use the drop-down list to view the defined browse sequences in your project. You can select more than one browse sequence. The selected browse sequences are then merged for the output. If there is a conflict with the selected browse sequences, the first selection is given preference.

Default Topic Click to select the topic that displays in the Topic panel when you open the output. By default, the first topic in the Table of Contents selected for this output is the default topic.

Include Index Select this setting to include the index in the output.
Glossary  Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to easily access relevant terms in your project, with the corresponding definitions.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows you to easily include or exclude content depending on the desired type of output or userbase. Click to edit the selected condition expression. You can also select None in the drop-down list to not specify a condition expression.

Dynamic Content Filter Use the drop-down list to select a dynamic content filter so your end users can filter content in the generated output. Click to edit the selected Dynamic Content Filter. Alternatively, select None in the drop-down list to not specify a dynamic content filter.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-specific use of variables. For example, you can have different variable sets for generating output for customers and internal users.

Layout
Use the following options to configure the appearance of your output:

Master Page Use the drop-down list to select the master page for the output you are generating.

Skin Use the drop-down list to select a skin to apply in your output.

Create thumbnail for images Select this setting to convert images to thumbnails in the output. These images can be enlarged when the user clicks them.

Search
Use the following options to specify search-related settings for your output:

Use topic description as search context Select this setting to display the topic description with the title in search topic results. In Set a Character limit, enter the maximum number of characters to be displayed in the topic description. To set a topic description, right-click a topic in the Contents panel and select Properties. In the Topic Properties dialog box, enter the description in Description and click Apply.

Enable auto complete in search box Select this option to display predictive options for the search query based on the initial characters typed by users.

Auto correct search query Select this option to correct misspelled terms that are typed during search. This setting corrects up to one character in each word typed during search. This ensures that you receive relevant search results, even if you enter a misspelled term.

Show definitions from glossary Select this option to display definitions of search terms from the glossary selected for this output. If the search term matches a glossary term, the definition of the term is displayed.

Select file types to exclude from search You can exclude specific types of files, such as PDF, Word, and Excel, from search. The content from the selected files will not be included during search.

App Details
Package Specify a name for the mobile app. A common naming convention is to use your company domain name in reverse followed by the name of the app. For example, com.adobe.myapp. This is used by PhoneGap to uniquely identify the application.

To avoid issues with third-party tools used in PhoneGap, use English letters, the underscore character, and a period as the separator.
Generating output

**Version** The PhoneGap version number for the app.

**Version Code (Android only)** The Android version number for the app. This is a positive integer that increases by one value each time you update the app. When you upload your app to an Android store, such as Google Play, your user will be notified of updates to your app when you update the version number.

**Title** The name of the mobile app. This is displayed in Google Play Store or App Store and on the mobile device when a user installs the app.

**Description** Specify the PhoneGap description for the app.

**Icon** Specify the icon that is associated with the application. This is displayed in Google Play Store or App Store and on the mobile device when a user installs the app.

**Splash Screen** Specify the splash screen for the app.

**Phonegap ID**

**User ID** Enter the user ID of your PhoneGap account.

**Password** Enter the password of your PhoneGap account.

**Create PhoneGap Account** Click this if you don’t have a PhoneGap account. You will then be directed to the PhoneGap plans page.

**Validate User ID** Click this to test your PhoneGap credentials. If this fails, go to phonegap.com and log in with the same credentials. After you log in to phonegap.com, retest the credentials in RoboHelp.

**Signing Key**

**Generate iOS App** Select this option to generate an iOS app as your output and specify the following:

- **Digital Certificate** Upload the digital certificate of the app. Click \(\text{\text{ }}\) to do this.
- **Certificate Password** Enter the password of the digital certificate.
- **Provisioning Profile** Specify the digital certificate. Click \(\text{\text{ }}\) to do this. The digital certificate contains details of the registered testing device. If the APP is not posted on the App store, it can be installed only on registered testing devices.

**Generate Android App** Select this option to generate an iOS app as your output and specify the following:

- **Keystore File** Click \(\text{\text{ }}\) to upload the keystore file. This is to authenticate your app. When you sign an Android app, it means that you brand your app with your credentials. You can brand multiple applications using the same key.
- **Keystore Password** Specify the password of your keystore file.
- **Certificate Alias** Specify the alias name of your keystore.
- **Certificate Password** Specify the password for the alias name of your keystore.

**Note:**

*The settings marked with * are mandatory fields; you need to configure these settings to successfully generate an app.*

**Generate Mobile App output**

1 In the authoring window of your project, click the **Quick Generate** icon \(\text{\text{ }}\) in the upper-right corner of the standard toolbar.

2 Select a Mobile app output preset in the **Quick Generate** dialog box.
To configure the settings, do one of the following:

- Click the **Edit Settings** icon 🏷️ in the **Quick Generate** dialog box.
- Click the **Output** tab at the left side of the Standard toolbar.

The Output view opens.

4 In the Output toolbar, click **Output Presets**. In the **Output Presets** panel, do one of the following:

- Double-click the desired Mobile app output preset.
- Click the ⚙️ icon next to the desired output preset and select **Edit**.

5 See [Configure a mobile app output preset](#) to configure the output settings.

6 To save your settings, click the **Save** icon 📈 in the upper-left corner of the standard toolbar in the Output view.

7 Click the **Generate Preset** icon ✨ in the **Output Presets** panel.

You can then view a progress bar next to the selected output preset in the **Output Presets** panel. Once the output generation is complete, a **Success** dialog box is visible at the lower-right corner of the screen.

After the output generation is complete, click 🦁 in the **Output Presets** panel to view the **Mobile App output** dialog box. Click **Download** to download the app to your computer. You can download and allow other users to download the app onto mobile devices by scanning the given QR code or by navigating to the URL on the devices.

iOS apps can only be installed using this URL if your device UDID is added in the mobile provision file.

**Note:**

Alternatively, you can generate the output in the authoring window. Click **Quick Generate** 📃 on the toolbar, select the desired output preset, and click **Generate**.

You can then view a progress bar in the **Quick Generate** dialog box. After the output generation is complete, click 🦁 next to the output preset to view the **Mobile App output** dialog box. In case the output generation failed, click 🗑️ next to the selected output preset to view the error log.

**Upload your mobile app to the app store**

After you have configured your mobile app settings, you can then generate the app. This app is the uploaded to the PhoneGap server. You can then either download the app to your computer or you can use the QR code to download the app to your mobile device.

To upload the app to the Apple or Android app stores, follow the instructions in the following articles:

- (For iOS) [Submitting Your App to the Apple App Store](#)
- (For Android) [Android Developer Console](#)

**Generate eBook output**

**What is eBook output**

In RoboHelp, you can use the eBook output preset type to generate your project output in EPub format.

Output generated in EPub or Electronic Publication file format can be viewed on devices like smartphones, tablets, computers, or e-readers with the compliant software. These files have the file extension .epub.
Configure an eBook output preset

The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various settings of the output preset. You can use the following settings to configure an eBook output preset:

**General**

Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more:

**Title** Specify a title for the generated output. This is part of the metadata.

You can use variables in the title. To do so, type `{` and select a variable from the drop-down list, and then press `Enter`. Note that if you have provided a variable set in the Content tab > Variable Set field, during output generation, the value of the selected variable is picked from the variable set.

**Output Path** Specify a location for the output. To select a location, click .

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the contents of the folder before generating the output.

**EPub file** Specify the file name and extension (.epub) that RoboHelp can use to generate the output. For example, specify EmployeeCare.epub.

**Language** Use the drop-down list to specify a language for the titles of Index and Glossary in your output. Specify this setting if you want to change the language specified in project settings.

**Content**

Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, glossary, and condition expression:

**Table Of Contents** Use the drop-down list to select a desired Table of Contents to be included in the output. This drop-down list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected by default.

**Include Index** Select this setting to include the index in the output.

**Glossary** Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to easily access relevant terms in your project, with the corresponding definitions.

**Condition Expression** Use the drop-down list to specify the condition expression for your output. This setting allows you to easily include or exclude content depending on the desired type of output or userbase. Click to edit the selected condition expression. You can also select None in the drop-down list to not specify a condition expression.

**Variable Set** Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can select <Default Variable Set> to use the project’s default variable set. Variable sets help you implement output-specific use of variables. For example, you can have different variable sets for generating output for customers and internal users.

**Layout**

Use the following options to specify details of appearance in your output.

**Master Page** Use the drop-down list to select the master page for the output you are generating.

**Meta Information**

Use the following options to specify the eBook’s author, publisher, description, and more.
**Author** Specify the author of the eBook.

**Publisher** Specify the publisher of the eBook.

**Rights** Specify the publishing rights of the eBook.

**Description** Enter a brief summary of the eBook to help the user understand your content better.

**Publication Identifier** Specify the unique identifier of the eBook. This is a thirteen digit ISBN ID.

**Publish Date** Specify the date of publishing of the eBook in mm/dd/yy format. You can also click to do this.

**EPub Validation**

Use the following settings to validate your eBook output:

**Validate EPUB3 Output** Select this option to validate your output. This is necessary to successfully generate your desired eBook.

**EpubCheck Path** Specify the EpubCheck path of your output. Click to do this. You can also click Go to EpubCheck download page to view and download the .zip file. You can then provide the path of the unzipped file.

**Generate eBook output**

1. In the authoring window of your project, click the Quick Generate icon in the upper-right corner of the standard toolbar.

2. Select an eBook output preset in the Quick Generate dialog box.

3. To configure the settings, do one of the following:
   - Click the Edit Settings icon in the Quick Generate dialog box.
   - Click the Output tab at the left side of the Standard toolbar.

   The Output view opens.

4. In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:
   - Double-click the desired eBook output preset.
   - Click the icon next to the desired output preset and select Edit.

5. See Configure an eBook output preset to configure the output settings.

6. To save your settings, click the Save icon in the upper-left corner of the standard toolbar in the Output view.

7. Click the Generate Preset icon in the Output Presets panel.

   You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output generation is complete, a Success dialog box is visible at the lower-right corner of the screen.

   After the output generation is complete, click in the Output Presets panel to view the output.

   **Note:**
   - Alternatively, you can generate the output in the authoring window. Click Quick Generate on the toolbar, select the desired output preset, and click Generate. You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, click next to the output preset to view the output. In case the output generation failed, click next to the selected output preset to view the error log.
Generate iOS app using RoboHelp (2019 release)

Note:
For details on the mobile app output preset in RoboHelp, see Generate Mobile App output.

Generate an iOS mobile app

1 In the authoring window of your project, click the Quick Generate icon in the upper-right corner of the standard toolbar.

2 Select a Mobile app output preset in the Quick Generate dialog box. To configure the settings, do one of the following:
   • Click the Edit Settings icon in the Quick Generate dialog box.
   • Click the Output tab at the left side of the Standard toolbar.
   The Output view opens.

3 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:
   • Double-click the desired Mobile app output preset.
   • Click the icon next to the desired output preset and select Edit.

4 Configure the output preset. See Configure a Mobile app output preset for details.

5 In the Signing Key tab of the configuration settings, select Generate iOS App and specify the following:
   Digital certificate Specify the Digital certificate. For details on how to create a Digital certificate, see Create Digital certificate.
   For details, see Generate a certificate signing request.
   Provisioning profile This contains details of the registered testing device. Until the APP is not posted on the App store, it can be installed only on registered testing devices.
   For details, see Generate provisioning profile.

6 To save your settings, click the Save icon in the upper-left corner of the standard toolbar in the Output view.

7 Click the Generate Preset icon in the Output Presets panel.
   You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output generation is complete, a Success dialog box is visible at the lower-right corner of the screen.
   Once the app is generated scan the QR code on the registered device for testing. This will download and install the app on the device.

Create digital certificate and provisioning profile for iOS APP

• Create Digital certificate
• Register your testing device
• Generate provisioning profile
Create Digital certificate

To create digital certificate you need an Apple Developer ID. It has an annual cost. However, this cost is applicable only for creating an APP.

To create Apple Developer ID go to My Apple ID.

After setting up your Apple developer account and ID, perform the following steps to create a digital certificate.

1. **Generate a certificate signing request** (CSR): This can be created on Mac and Windows devices (with some installations). It is easier to create it on a Mac device.

2. **Associate CSR with Apple ID on Apple developer site.**

3. You can then **Download Apple .cer file and convert it into digital certificate**

Generate a certificate signing request

For Windows OS

1. Download and install OpenSSL on your Windows computer from the following location:
   
   http://www.openssl.org/related/binaries.html

2. Download and install Visual C++ 2008 Redistributables files that are listed on the OpenSSL download page.

3. After the installation is complete, restart the computer.

4. Open a Windows command session, and ensure that your current working directory is the OpenSSL bin directory.
   
   For example: c:\OpenSSL\bin\

5. Create the private key by entering the following in the command line:
   
   openssl genrsa -out <key file name> <encryption bit level>

   For example, to create a private key name mykey with 2048 encryption bit level:
   
   openssl genrsa -out mykey.key 2048

   **Note:**

   When using OpenSSL, do not ignore error messages. If OpenSSL generates an error message, it still generate a key file. However, this key file may not be usable. If you encounter any errors, check your syntax and run the command again.

6. Create the CSR file by entering the following in the command line:
   
   openssl req -new -key mykey.key -out CertificateSigningRequest.certSigningRequest -subj "/emailAddress=<your email address>, CN=<certificate name>, C=<country code>"

   For example, to create a CSR file with email myemail.@mydomain.com, certificate name My Certificate and country code US:
   
   openssl req -new -key mykey.key -out CertificateSigningRequest.certSigningRequest -subj "/emailAddress=myemail.@mydomain.com, CN=My Certificate, C=US"

7. You will be prompted for a password.

   Keep a note of this password. This is your **Certificate Password** that you will provide in the **Signing Key** tab in the mobile app output preset configuration settings.
For iOS
1 Open Keychain Access. The Keychain Access application is in the Utilities subdirectory of the Applications directory.
2 On the Keychain Access menu, select Preferences.
3 In the Preferences dialog box, click Certificates.
5 On the Keychain Access menu, select Certificate Assistant > Request a Certificate from a Certificate Authority.
6 Enter the e-mail address and name that matches your iPhone developer account ID.
7 Select Request is saved to Disk.
8 Click the Continue button.
9 Save the file (CertificateSigningRequest.certSigningRequest).

Associate CSR with Apple ID on Apple developer site
Upload the CSR file (created in previous step) on the Apple iPhone developer site. Click Certificates on the site.

Download Apple .cer file and convert it into digital certificate
In the following procedures (for Windows and iOS), you require the .cer file. You will receive this file from Apple in your e-mail provided in previous procedure as iPhone developer account ID.

For Windows OS
On Windows you need to convert .cer file to .pem file as described in the following procedure:
1 To convert the .cer file to a .pem file, run the following command-line statement from the OpenSSL bin directory:
   openssl x509 -in -inform DER -out -outform PEM
   For example:
   openssl x509 -in "C:\RHAPP\iOS_development.cer" -inform DER -out "C:\RHAPP\iOS_development.PEM" -outform PEM
2 You can now generate a valid P12 file, based on the key and the PEM version of the iPhone developer certificate:
   openssl pkcs12 -export -inkey "mykey.key" -in -out
   For example:
   openssl pkcs12 -export -inkey mykey.key -in "C:\RHAPP\iOS_development.PEM" -out "C:\RHAPP\iOS_development.P12"
   The mykey.key is created during the Generate a certificate signing request procedure described above.

For iOS
1 Open the Keychain Access application (in the Applications/Utilities folder).
2 Select File > Import and navigate to the certificate file (the .cer file).
3 Select the Keys category in Keychain Access.
4 Select the private key associated with your iPhone Development Certificate.
5 Command-click the iPhone Developer certificate and select, Export "iPhone Developer: Name...".

Last updated 2/20/2019
Generating output


7. You will be prompted to create a password. Keep the password safe. This is the Certificate Password that you will need to provide in Signing Key tab in the output preset configuration settings.

Register your testing device

1. Go to the Apple Developer portal.

2. Go to Device section. Under Manage tab, provide Device Name and Device ID (40 hex characters). To know your device id click this link.

Generate provisioning profile

1. Go to the Apple Developer portal.

2. Go to Provisioning section. Create a new profile under the Development tab.

3. Fill the form with Profile Name (File name), Certificates (the .cer file created above), App ID and your development device.

Download the provisioning profile and keep it safe. You need to specify this in Provisioning Profile in the Signing Key tab of the output preset configuration settings.

Generate Android app

Note:

For details on the mobile app output preset in RoboHelp, see Generate Mobile App output.

Generate an android mobile app

1. In the authoring window of your project, click the Quick Generate icon in the upper-right corner of the standard toolbar.

2. Select a Mobile app output preset in the Quick Generate dialog box. To configure the settings, do one of the following:
   - Click the Edit Settings icon in the Quick Generate dialog box.
   - Click the Output tab at the left side of the Standard toolbar.
   The Output view opens.

3. In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:
   - Double-click the desired Mobile app output preset.
   - Click the icon next to the desired output preset and select Edit.

4. Configure the output preset. See Configure a Mobile app output preset for details.

5. In the Signing Key tab of the configuration settings, select Generate Android App and specify the following:
   - Keystore file: This file is used to authenticate yourself. If you sign an Android app, it implies that you are branding your application with your credentials. You can brand multiple applications with the same key. See the section below on how to Generate keystore file.
   - Keystore password: The password for your keystore file. This password is required to Generate keystore file.
   - Certificate Alias: Alias name for your keystore.
**Certificate Password:** The password for the alias name for your keystore.

6. To save your settings, click the Save icon 🖌️ in the upper-left corner of the standard toolbar in the Output view.

7. Click the Generate Preset icon ➔ in the Output Presets panel.

   You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output generation is complete, a **Success** dialog box is visible at the lower-right corner of the screen.

---

**Generate keystore file**

**Keystore File:** This file is used to authenticate yourself. If you sign an Android app, it implies that you are branding your application with your credentials. You can brand multiple applications with the same key.

You can use the script contained in the attached zip archive to generate a keystore file:

You need to import the script into your RoboHelp project and run the script. To do this, follow these steps in RoboHelp Classic (2019 release):

1. Download the *AndroidKeyGenerator.zip* and extract the *AndroidKeyGenerator.jsx*.


4. Click Import Script Files and import the *AndroidKeyGenerator.jsx* file.

5. Right-click *AndroidKeyGenerator.jsx* and select Run.

   In the Android Key generator dialog, enter the following information:

   **Java bin folder path:** Path to Java bin folder on your computer.

   **Keystore name:** Name of your keystore file.

   **Keystore alias:** Alias name for your keystore.

   After you click the Generate Preset icon in the Output Presets panel, you will be prompted for the following information in the command prompt:

   **Keystore password:** The password for your keystore file.

   **Personal information:**

   - Your first and last name separated by a space
   - Name of your organizational unit
   - Name of your city
   - Name of your province
   - Two letter code for your country. For example: **US** for United states or **UK** for United Kingdom

   Enter Yes in the confirmation message.

   Finally, you will be prompted for a password. Enter a password. Or press Enter if you want use the keystore password. This password will be used as the **Certificate password** in the Generate an android mobile app.

   If all the details are correct, the keystore file will be created in the Documents folder of your user area.

   For example: For a user John Doe, the file is created in the following location:

   C:\Users\jdoe\Documents
Chapter 8: Publish output

Import FrameMaker documents into a project

Note:

FrameMaker 2019 Update 2 or later is required for this feature.

You can quickly import a FrameMaker document into RoboHelp as one or multiple topics. While importing, you can configure several settings that RoboHelp provides to import and customize topics based on your needs. Also, you can link FrameMaker documents into your RoboHelp project.

Import a FrameMaker document

You can import FrameMaker books (.book) and documents (.fm, .mif) into your RoboHelp project. On importing a FrameMaker document in the Contents panel, RoboHelp places the topics at the chosen location (at the root level or inside a folder). However, all assets referenced in the imported document are placed in the respective subfolder in the assets folder. For example, style sheets are placed in the css subfolder and images in the images subfolder.

To import a FrameMaker document:

1. In the Contents panel, do one of the following:
   • To import a FrameMaker document in a folder, do one of the following:
     • Select the folder and choose File > Import > FrameMaker Document.
     • Right-click the folder or click *** against it, and choose Import > FrameMaker Document.
   • To import a FrameMaker document at the root level, do one of the following:
     • Without selecting any folder, choose File > Import > FrameMaker Document.
     • Right-click outside folders and choose Import > FrameMaker Document.

The FrameMaker Import Settings dialog box opens.

2. In the FrameMaker Import Settings dialog box, select the FrameMaker document you want to import and edit the settings. For information about options in the dialog box, see FrameMaker import settings.

3. Click Import.

An HTML version of the selected FrameMaker document is generated with the specified settings. The topic is placed in the alphabetical order of topics at the chosen location in the Contents panel.

FrameMaker import settings

When you choose File > Import > FrameMaker Document, the FrameMaker Import Settings dialog box appears. Configure the settings in the following tabs in this dialog box:

• General
• Paragraph
General

The General tab is selected by default in the FrameMaker Import Settings dialog box. In this tab, specify the following settings:

- **FrameMaker Document** Click to select the FrameMaker document (.fm, .mif, or .book) you want to import. Note: When you select a FrameMaker document, an instance of FrameMaker is launched, if it is not running already. RoboHelp reads the selected document and populates the applicable tabs in the FrameMaker Import Settings dialog box.

- **CSS file for style mapping** Click to select an external style sheet (.css file), which is different from your project style sheet, to map FrameMaker styles with RoboHelp styles. By default, RoboHelp picks the default style sheet of the project.

- **Start new topic from style** Use the following settings to create topics from the content in the selected FrameMaker document:
  - **FrameMaker Style** Select a paragraph style from the FrameMaker document that RoboHelp can use to create topics. For example, to create a topic for every first-level heading, select Heading1. Note: This field displays all paragraph styles from the document selected in the FrameMaker Document field. If you did not select a document in the FrameMaker Document field, this field remains blank.
  - **Topic Name Pattern** Specify the naming pattern for the new topics. You can choose from the following options:
    - `<filename_no_ext>-<n>` Creates filenames without extension and includes a number in sequential order. For example, if ABC.fm is the imported FrameMaker document, the filenames of new topics become ABC1, ABC2.
    - `<filename_no_ext>-<sparatext>` Creates filenames without extension and includes the initial text of the first paragraph.
    - `<sparatext>` Creates filenames with the initial text of the element on which the selected style is applied. This option is set by default.
  - **Use only ASCII characters in the generated file names** Select this field to convert non-ASCII characters in new topic filenames to ASCII characters. The conversion follows the Punycode standard.
  - **Save Settings** Click to save the settings of the FrameMaker Import Settings dialog box as a preset (.fsf) file. If you modify and save the settings as a new preset file, you can select the file from the Load Settings field the next time you open the dialog box.
  - **Load Settings** Click to select a different preset (.fsf) file in which you want to save the settings of the FrameMaker Import Settings dialog box. This field shows the default preset file default.fsf. You can also click to select a recently saved preset file.

Note:
The **Character, Paragraph, Table, and Cross Reference** tabs are enabled only when these styles are applied in the selected FrameMaker document.
**Character**
Select the Character tab to specify character styles for your imported content. In this tab, you can view the following columns:

- **FrameMaker Style** The style in the FrameMaker document selected in the FrameMaker Document field in General tab.
- **In RoboHelp** Styles populated from the CSS file specified in the CSS file for style mapping field in General tab.

For each FrameMaker style, click ✓ in In RoboHelp to select a different style and map it to the corresponding FrameMaker style. If there is no style to match with the corresponding FrameMaker style, RoboHelp provides two style options:

- **Import style** (default) imports styles from the selected FrameMaker document to RoboHelp.
- **Discard content** Discards all content on which the selected style is applied.

You can preview the selected FrameMaker style and mapped style in FrameMaker Preview and RoboHelp Preview sections, respectively.

**Paragraph**
Select the Paragraph tab to specify paragraph styles for your imported content. In this tab, you can view the following columns:

- **FrameMaker Style** The style in the FrameMaker document selected in the FrameMaker Document field in General tab.
- **In RoboHelp** Styles populated from the CSS file specified in the CSS file for style mapping field in General tab.

For each FrameMaker style, click ✓ in In RoboHelp to select a different style and map it to the corresponding FrameMaker style. If there is no style to match with the corresponding FrameMaker style, RoboHelp provides two style options:

- **Import style** (default) imports styles from the selected FrameMaker document to RoboHelp.
- **Discard content** Discards all content on which the selected style is applied.

You can preview the selected FrameMaker style and mapped style in FrameMaker Preview and RoboHelp Preview sections, respectively.

**Table**
Select the Table tab to specify table styles for your imported content. In this tab, you can view the following columns:

- **FrameMaker Style** The style in the FrameMaker document selected in the FrameMaker Document field in General tab.
- **In RoboHelp** Styles populated from the CSS file specified in the CSS file for style mapping field in General tab.

For each FrameMaker style, click ✓ in In RoboHelp to select a different style and map it to the corresponding FrameMaker style. If there is no style to match with the corresponding FrameMaker style, RoboHelp provides two style options:

- **Import style** (default) imports styles from the selected FrameMaker document to RoboHelp.
- **Discard content** Discards all content on which the selected style is applied.

You can preview the selected FrameMaker style and mapped style in FrameMaker Preview and RoboHelp Preview sections, respectively.
Cross Reference
Select the Cross Reference tab to specify cross-reference styles for your imported content. In this tab, you can view the following columns:

- **FrameMaker Style** Displays names of the cross-reference styles applied in the FrameMaker document selected in the FrameMaker Document field in General tab.
- **In RoboHelp** Displays the current definitions of the styles. By default, this column is populated from the definitions in the imported FrameMaker document. You can modify the definitions by using combinations of constants and variables. To specify a variable, type `<` and select a variable from the drop-down list or type the variable name.

You can preview the selected FrameMaker style and its definition in FrameMaker Preview and RoboHelp Preview sections, respectively.

Images
Select the Images tab to specify image styles for your imported content. In this tab, use the following fields:

- **Do Not Regenerate Images** Select this field if you are reimporting FrameMaker documents and do not need to update the images in the imported content.
- **Import Reference Page Images** Select this field to import images from the Reference Page in the imported FrameMaker document.
- **Preserve 3D Images** Preserves 3D images in the selected FrameMaker document, that is, 3D images are not flattened to 2D images. When the output is published, 3D information in images is visible in the browser. This field is selected by default.
- **Preferred Dimensions**
  - **Width** and **Height** Specify the preferred width and height of the imported images. By default, the width and height fields are linked to accept same values. Toggle to set different width and height values.
  - **Scale** Specify a scaling factor to scale the imported images. **Note:** Specifying a scale may change the width or height values.
  - **Maintain Aspect Ratio** Select this field to maintain the aspect ratio according to the images in the imported FrameMaker document. **Note:** Specifying a scale may change the width or height values.
- **Maximum Dimensions** As the Preferred Dimensions can be overridden by Scale and Maintain Aspect Ratio settings, use this section to set a maximum limit for the image size in the imported document.
  - **Width** and **Height** Specify the width and height of the imported images. By default, the width and height fields are linked to accept same values. Toggle to set different width and height values.
  - **Margin** Specify a value for all four margins around images. Toggle if you want to specify a different value for each of the top, bottom, left, and right margins.
- **Borders** Control the properties of the standard HTML borders that are applied to the imported images using this section.
  - **Border Style** Select a border style from the drop-down list. Default is None.
  - **Color** Click to select a border color. Default is black. Or, click to pick a color from the screen.
  - **Width** Specify the border width.
  - Select the borders you want to apply from the following options:
    - All (default)
    - Top
Publish output

- Right
- Bottom
- Left

Advanced

- Default Format Select the default image format to which you want to convert all imported images.
- Color Bit Depth Values in this field change according to the selected default image format. You can choose a depth from the supported options.
- JPG Quality Specify a value to set the quality of all imported JPG images. This field controls the JPG compression in terms of size and quality, for example, the default value 100 means the best quality and minimum compression.
- Grayscale Select to convert all imported images to grayscale.

Advanced
Select the Advanced tab to specify advanced settings for your imported content. In this tab, use the following fields:

- Context sensitive help marker If you want to import context-sensitive help markers from the FrameMaker document, select this field and specify the type of context-sensitive help maker to be imported.
- Split into topics using marker If you want to create topics based on a specific marker type from the FrameMaker document, select this field and specify the marker type.
- Keep all topics in one folder If a FrameMaker book is being imported, select this field to keep all topics in the book in the same folder.
- Add all topics to Table of Contents Select this field to add all topics created from the selected FrameMaker document to the Table Of Contents file being created.
- Cleanup inline HTML styles If the imported FrameMaker document has inline styles, select this field to discard such styles.
- Import Glossary files Imports all glossary information from the selected FrameMaker document into a new glossary file. This option is selected by default.
- Import TOC files Imports all Table Of Contents files referred from the FrameMaker book being imported into a new Table Of Contents file. This option is selected by default.

Link a FrameMaker document
You can link a FrameMaker document from your RoboHelp project folder.

Apart from the basic functions available for topics and folders, you can Create HTML topics from the linked FrameMaker document.

Publish to a RoboHelp Server
What is RoboHelp Server
Adobe RoboHelp Server 10 is a server-based Help solution that provides real-time end-user feedback on your Help and knowledgebase. Generate the output of your project in RoboHelp and then publish the output to a RoboHelp Server. RoboHelp Server gathers and logs data about what questions users ask while searching content and how users navigate through topics. Results are displayed in an easy-to-view graphical format for quick interpretation.

How to publish to RoboHelp Server
To publish to RoboHelp Server, first setup a publishing profile providing information about the RoboHelp Server instance. RoboHelp supports WebHelp and Responsive HTML5 output types. You can publish content from the Output Presets panel. Edit a WebHelp or a Responsive HTML5 output preset and select the publish profiles you want to use. Then publish content to RoboHelp Server.

Configure a publish profile for RoboHelp Server
You must create and configure a profile before publishing your output to RoboHelp Server. To create and configure a profile:

2. Click + to create a new profile.
3. In the Server Type field, select the type of server as RoboHelp Server. Default is SharePoint Online. Other fields in the dialog box change based on the server type selected.
4. For the RoboHelp Server server type, do the following:
   - Name Shows the default profile name. Modify the name if required.
   - Address Specify the address of the Robohelp server to which you want to publish your projects. The address must be in the following format: http://<server-name>:<port-number>/<context-name>/server
     - server-name: The host name or IP address of the machine on which RoboHelp Server is setup. If its on the same machine, you can specify localhost as server name.
     - port-number: (Optional) The port on which RoboHelp Server is running. Default is 8080. If you are using port 8080, specify it here. However, if you are using the default ports for HTTP or HTTPS protocols, you need not provide the port number. For example, the default port for HTTP is 80. So if you are using HTTP and port 80, you need not provide the port number.
     - context-name: The context to which you want to publish. Default is robohelp.
     For example, http://localhost:8080/robohelp/server.
   Note:
   By default, RoboHelp Server uses the http protocol. For the https protocol, use the following format: https://<server-name>:<port-number>/<context-name>/server
   - User ID and Password Enter your credentials.
   - Areas Select an area on the server on which you want to publish content. To refresh areas, click 🔄.
5. Click Save.
RoboHelp saves the profile and displays the profile name under the Profiles column. To edit a profile, click the profile name and edit its fields. To delete a profile, click ✖️ against it.
Publish to a RoboHelp Server

You can configure a WebHelp or a Responsive HTML5 output preset to link it to the RoboHelp Server profile, and then publish your content to the RoboHelp Server. You can publish content to multiple RoboHelp Servers.

1. Click the Output tab in the standard toolbar. Output Presets is the default selection in the Output toolbar.
2. In the Output Presets panel, double-click an output preset to edit it.
3. In the output preset editor, click the Publish tab to view the servers created across projects.
   You can also edit server information in the Publish Profiles dialog box, which you can launch by clicking.
4. Select the profiles (servers) to which you want to publish content.
5. Select Republish All to republish entire content. If this field is not selected, RoboHelp publishes only updated content since the previous publish, not the entire content.
6. To publish to the selected profiles (servers), click the output preset and then click in the standard toolbar. Or right-click the output preset and click Publish.

If you selected multiple RoboHelp Servers, RoboHelp publishes to RoboHelp Servers in a sequence. Two prompts appear, one displays publishing information (such as the file being published, preset name, and server name) and the other displays publishing status.

Note:
RoboHelp creates log files at %/AppData%/Local/Temp/RHTMP. To view log files, right-click the output preset and click View Publish Log. If you published content to multiple servers, the log file shows publishing information (success or failure and errors) about all servers.

7. To view published content, click in the Results column against the published profile.
   If publishing fails, the Results column does not show the icon.

Publish to an FTP server, a Secure FTP server, or a File System

How to publish

You can generate the output of your project in RoboHelp and then publish the output to an external server using file transfer protocol (FTP), secure file transfer protocol (SFTP), or a file system. To do so, first setup a publishing profile providing information about the FTP, SFTP, or file system instance. Edit an output preset, select the publish profiles you want to use, and then publish content.

Configure a publish profile

To create and configure a profile:

1. Choose Edit > Publish Profiles.
   The Publish Settings dialog box opens.
2. Click + to create a new profile.
3. In the Server Type field, select the type of server as FTP, SFTP, or File System. Default is SharePoint Online.

Last updated 2/20/2019
Except for Name, other fields in the dialog box change based on the server type selected.

4 In the Name field, modify the default profile name if required.

5 For the FTP server type, do the following:
   • Address Specify the domain name of the server or its IP address.
     Note: Port is not required in the address.
   • Anonymous User Select this field to publish content as an anonymous user. Sign-in credentials are not required for anonymous users. If you do not want to publish as an anonymous user, enter your sign-in credentials in the UserID and Password fields.
   • Server Directory Specify the path on the server to which you want to publish content. For example, specify / for root folder, specify /folder1/folder2 for folders and subfolders. If the specified subfolder does not exist, RoboHelp creates it and copies files inside the new subfolder.
   • Port Specify a port. The default is 21.

6 For the SFTP server type, do the following:
   • Address Specify the domain name of the server or its IP address.
     Note: Port is not required in the address.
   • UserID and Password SFTP servers support only username and password sign-ins. Enter your sign-in credentials.
   • Server Directory Specify the path on the server to which you want to publish content. For example, specify / for root folder, specify /folder1/folder2 for folders and subfolders. If the specified subfolder does not exist, RoboHelp creates it and copies files inside the new subfolder.
   • Port Specify a port. The default is 22.

7 For the File System server type, in the Destination Path field, specify the path on your network to which you want to publish the content. Only absolute paths are supported. RoboHelp copies files at the path you provide without creating any sub-folder for the output.

8 Click Save.

RoboHelp saves the profile and displays the profile name under the Profiles column. To edit a profile, click the profile name and edit its fields. To delete a profile, click against it.

**Publish to an FTP or SFTP server or a file system**

You can configure an output preset to link it to the FTP, SFTP, or File Transfer publish profile, and then publish your content to multiple servers.

1 Click the Output tab in the standard toolbar. Output Presets is the default selection in the Output toolbar.

2 In the Output Presets panel, double-click an output preset to edit it.

3 In the output preset editor, click the Publish tab to view the servers created across projects.

   You can also edit server information here or in the Publish Profiles dialog box, which you can launch by clicking .

4 Select the profiles (servers) to which you want to publish content.

5 Select Republish All to republish entire content, including updates, if content was previously published to a specific server. If this field is not selected, RoboHelp publishes only content updates, not the entire content.

6 To publish to the selected profiles (servers), right-click the output preset and click Publish.
If you selected multiple servers, RoboHelp publishes in parallel. Two prompts appear, one displays publishing information (such as the file being published, preset name, and server name) and the other displays publishing status.

**Note:**

RoboHelp also creates log files at %/AppData/%/Local/Temp/RHTMP. To view log files, right-click the output preset and click View Publish Log. If you published content to multiple servers, the log file shows publishing information (success or failure and errors) about all servers.

7 To view published content, click 📌 in the Results column against the published profile.

If publishing fails, the Results column does not show the 📌 icon.
Chapter 9: Collaborate with authors

Collaborate using Git

Prerequisites for connecting to Git
1. Install Git in your system. For detailed instructions, see the Git installation page.
2. Add Git to system PATH.
3. Set up Git in your system. For detailed instructions, see Git help.

Create a Git connection profile
To connect RoboHelp with Git, create a Git connection profile.
1. Open RoboHelp.
2. Choose Collaborate > New Connection.
3. In the Connection Profiles dialog box, specify a name for your connection profile.
4. From the Version Control drop-down list, select Git.
5. In the Repository SSH URL field, specify the repository SSH URL in the following format:
   git@<servername>:<orgName/repoName>.git
7. In the Branch field, specify the branch name, for example, master.
8. In the Local Path field, specify the project path.
   The project path must be different for each of the following scenarios:
   • Adding a project to Git: Provide the path of the project you want to add to your Git repository for version control.
   • Opening a connection: Provide the path to an empty local folder in which the Git project is to be cloned locally.
9. Click Save.

Add a RoboHelp project to Git
1. Open the project that you want to add to Git. This is the same project for which you specified the path while creating a Git connection. For more information, see Step 8 in Create a Git connection.
2. Choose Collaborate > Add Project > <profile name>.
In the **Commit** dialog box, select the files that you want to add in the **Git Version Control** field.

In the **Commit Description** field, provide a description.

Click **Commit**.

To push the files to the Git repository, click **Push**.
Your RoboHelp project is added to your Git repository. You can start committing changes to and from the RoboHelp project to the Git repository.

To push your changes:

a. Make the required changes in your project.

b. Choose **Collaborate > Commit**.

c. Select the files to commit and provide a commit description.

d. Click **Commit**.

e. To push the changes to the Git repository, choose **Collaborate > Push**.

To sync changes from the Git repository to your local project, choose **Collaborate > Pull**.

After pushing files, if you receive the following message, it indicates a merge conflict in the files:

“The tip of your current branch is behind its remote counterpart. Try pulling before pushing.”

To merge conflicts if the changes are made in the same file:

**Prerequisites**:

a. Choose **Edit > Preferences > Version Control**.

b. Provide the path of the .exe file of any External Diff/Merge Application.

c. Choose **Collaborate > Pull**. The following message appears: “Your local changes conflicted with changes made on the remote branch. Resolve the conflicts and commit to continue.”

d. Choose **Collaborate > Commit**. This marks the conflicted files with Action as “In merge conflict” to indicate that there is a difference.

Then, to resolve conflicts, click ![icon].

e. Ensure that the merge application is already added. To add merge application, follow the steps in the **Prerequisites**.

f. Then, select the changes you want to commit and save the changes in the merge application. Close the merge application.

g. Select the file in the already open **Commit** dialog box and provide the commit description. Click **Commit**.

Then, click **Push**. Git repository changes and the local RoboHelp project is in sync now.

### Open a RoboHelp project added to Git

1. Ensure that you have provided the correct path to the Git repository where your RoboHelp project is present and the local path points to an empty folder where the Git project will be cloned locally.

2. Open RoboHelp.

3. Choose **Collaborate > Open Connection > <profile name>**. The repository starts getting cloned in the local system.

4. Double-click the .rhpj file to open the project.

The Git project is now open.
5 You can start committing the changes with Push/Pull. To resolve conflicts, see Step 9 in Add a RoboHelp project to Git.

Collaborate using SharePoint Online

Create a SharePoint Profile
1 In the menu bar, select Collaborate > New Connection.
2 In the Connections Profile dialog box, specify a profile name in Name. For example: Sharepoint_Profile
3 In the Version Control drop-down list, select SharePoint Online.
4 In SharePoint Site URL, specify the URL of SharePoint site.
5 Click Login.
   After you log in, you can view your user name and ID in the Connection Profiles dialog box.
6 Click Save to save the profile.
   You can now add projects to Sharepoint or download a project from it.

Download a project from SharePoint Online
1 In the menu bar, select Collaborate > Open Connection and select a desired profile.
2 Browse and select a desired RoboHelp project file and click Select.
3 In Repository Details dialog box, specify the Local Path where you want the project to be downloaded to and click Open. The project will then download and open in RoboHelp.
4 After you've edited your project, you can check out the files in your project. To do this, click Save All in the File menu. When prompted to check out, click OK. The project is then checked out and saved.
5 In the menu bar, select Collaborate > Check In to check in the checked out files.

Add a project to SharePoint Online
1 In SharePoint Online, from your browser, create a folder in which you want to add your RoboHelp project.
2 In RoboHelp, open the project that you want to add to SharePoint.
3 In the menu bar, select Collaborate > Add Project and select a desired profile.
4 Browse and select the folder on SharePoint where you want to add the project. Ensure that this folder is empty.
5 In the Check In dialog box, you can view the list of files that will be added to SharePoint.
6 Click Select All and check in. Ensure to specify the description in the Check In dialog box. Your project is then added to SharePoint.

Note:
In the Collaborate menu, you can find the following options:
- Get latest revision Provides the latest revision of files from SharePoint.
- Refresh status View the check in or check out status of files.
Collaborate using Team Foundation Server

Prerequisites for connecting to Team Foundation Server
Before creating a Team Foundation Server connection profile, do the following:

1. Create a team project to establish a repository for source content, where teams can plan, track progress, and collaborate.
2. Set up Team Foundation Version Control on a machine.

Create a Team Foundation Server connection profile

1. In RoboHelp, choose Collaborate > New Connection.
2. In the Connection Profiles dialog box, specify a name for your connection profile.
3. From the Version Control drop-down list, select Team Foundation Server.
4. In the Team Project Collection URL field, specify the team project collection URL in the following format: http://myserver:8080/tfs/DefaultCollection
5. In the Team Project field, specify the name of the Team Foundation Server project.
   Note:
The team project name must be the same as the new team project created/existing team project in Team Foundation Server.
6. In the Workspace field, specify a workspace name.
   Workspace is your local copy of the project, where you can create content locally and then check in your work. For information about workspace, see this page.
7. In the Local Path field, specify the project path.
   The project path must be different for each of the following scenarios:
   • Adding a project to Team Foundation Server: Provide the path of the project you want to add to Team Foundation Server for version control.
   • Opening a connection: Provide the path to an empty local folder in which the Team Foundation Server project is to be downloaded locally.
8. Click Save.
Download a project from Team Foundation Server

1 In RoboHelp, choose Collaborate > Open Connection and select a desired profile.
   The project is downloaded in the local path specified in the Connection Profiles dialog box (accessed through Collaborate > New Connection).

2 In the Open dialog box, select a desired RoboHelp project file (.rhpj) and click Open.
   You can now edit your files and save the changes.

3 Choose Collaborate > Check In.

4 In the Check-in dialog box, from the list of modified/newly added files, select the files you want to check in.

5 You can also specify a check-in description. Click Check-in.
   Your project is added to Team Foundation Server.

Add a project to Team Foundation Server

1 In RoboHelp, open the project that you want to add to Team Foundation Server.
   The project must be in the same path that was specified in the Connection Profiles dialog box (accessed through Collaborate > New Connection).

2 In the menu bar, select Collaborate > Add Project and select a desired profile.
   The project from the local path is added to the team project specified in the Connection Profiles dialog box.

3 In the Check-in dialog box, from the list of modified/newly added files, select the files you want to check in.

4 You can also specify a check-in description. Click Check-in.
   Your project is added to Team Foundation Server.

Note:

In the Collaborate menu, you can find the following options:

- Get latest revision Provides the latest revision of files from Team Foundation Server.
- Refresh status View the check in or check out status of files.