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Chapter 1: Introduction to RoboHelp

What 's New in Adobe RoboHelp?
Introducing Adobe RoboHelp on Mac - the widely used and the most advanced operating system yet. Adobe RoboHelp 
brings in more smart features and enhancements to scale up content creation and reach wider audiences. With built-in 
Microcontent  editor, fully integrated workflow to manage the translation process - both Manual and Machine, to 
export XLIFF files for your content, online review, PDF enhancements, and more.  Collaborate seamlessly with the 
subject matter experts using web-based review capabilities.  Establish a use-by-reference relationship allowing text 
from one topic to be linked in multiple places by cross-referencing. Easily import HTML or Markdown content as 
HTML topics. Navigate with new Frameless HTML5 layouts featuring a navigation bar positioned at the top.  In 
addition, this release includes out-of-the-box support to publish to Zendesk, Salesforce, and ServiceNow.

Here’s a brief rundown of the new features and enhancements included in this release.

Feature summary

Introducing RoboHelp on Mac

With the introduction to macOS, Adobe RoboHelp introduces the users to new levels of ease of use, performance, and 
reliability, giving people the power to work more productively. Adding up to the most beautiful, seamless experience 
yet - and another big step forward. See the system requirements to deploy RoboHelp on your Mac system.

http://helpx.adobe.com/en/robohelp/kb/download-installer-macos.html
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An illustration of RH landing page on Mac

Collaborate using out-of-the-box Online Review

Produce high-quality contextual reviews to streamline live collaboration with reviewers and subject matter experts via 
secure cloud-based review. Allow multiple reviewers to markup the topics at the same time. Add stakeholders and 
modify their access at any time. With the new RoboHelp, you have access to a unified platform for team discussion and 
real-time project collaboration and feedback. For more information, see Review and Collaboration.

An illustration of how the review feature works

Enhance experience with top navigation in Frameless HTML5 output
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The main navigation is designed to be positioned at the top with a single column layout. The top navigation outputs 
are responsive to give the user the optimum viewing and reading experience across all devices, mobile, tablet, and 
desktop. On smaller devices, the top navigation is replaced with a different layout for better reading experience. All 
toolbar icons are moved under one "View more" icon to handle touch gestures to all icons. Enjoy the new skin layout 
with a menu at the top, room for a logo and search, and the main content area. 

An illustration of Top Navigation in Frameless HTML5 output

Make a macro impact with Microcontent

Go beyond topic-based authoring to any piece of short, bite-sized snippets of content with built-in microcontent 
authoring that entices your viewers to check out a larger piece of your content. Create AI-ready microcontent or 
repurpose your existing content for use as microcontent. Make the content trivially easy for the user by atomizing any 
long-form content and customize for use in chatbots, and frequently asked questions (FAQ) database, among other 
applications. Check how to:

• Create information-rich content snippets within Adobe RoboHelp.

• Leverage Microcontent for featured snippets in search results and in-context help.

• Use Microcontent to power next-generation chatbots.

• Integrate the new Microhelp in your environment.
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An illustration of Snippet search & FAQ page

Expand your reach globally with Translation

Reach global audience by localizing your content with Machine or Manual translation functionality in 35+ languages. 
Extend the reach of your created content, optimize costs, and increase discoverability by the users. Export and import 
your content using the widely supported XLIFF (XML Localization Interchange File) format. Leverage the state-of-the-
art machine translation powered by Google Translate, Yandex Translate, and Microsoft Translator APIs. For more 
information, see Translating content to multiple languages.

Enhanced PDF output
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Learn how new PDF output capabilities are evolving to fine-tune and meet your needs. Publish chapter-based printed 
documentation like a book and have better control over the final output with CSS3. Password protection to keep away 
the prying eyes from your important files. Improve your PDF accessibility by generating tagged PDF documents. Add 
secure and dynamic watermarks as protection to your PDF files. Wondering how to:

• Set up the front matter with Cover page, Foreword, Preface, Table of Contents, and much more. 

• Set up the back matter with Appendix, Glossary, Back cover, Index, Bibliography, and much more.

• Use multiple columns for an entire publication.

• Embed different kind of fonts in your PDF document 

• Reduce the redundancy of images without sacrificing the image quality.

• Combine multiple PDFs into a single PDF.

• Adjust page magnification with Zoom In and Zoom Out settings.

• Save any topic as PDF.

• Export and Import settings as PDF template for reuse.

• Managing cross-references and bookmarks. 

For more information on PDF enhancements, see Generate PDF output.

Explore the world of cross-references

Establish a relationship between a new piece of information and the existing content with cross-references, which 
would help readers better understand the information. RoboHelp makes it easy to include, update, and maintain cross-
references in your publications. Cross-references have the advantage of dynamically changing based on your output 
types. Use cross-references to link information within the topic or across multiple topics, or to a section in a topic. To 
learn how to work with cross-references, see Create and manage cross-references.

Inserting cross-references

Powerful integration with Zendesk, Salesforce, and ServiceNow

Publish effortlessly to multiple channels to support the different needs of the end-users with robust built-in integrations 
with leading CRM solutions - Zendesk Help Center, Salesforce Knowledge Base, and ServiceNow Knowledge Base.
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See more details on how to 

• Publish to Zendesk Help Center

• Publish to Salesforce Knowledge Base

• Publish to ServiceNow Knowledge Base

Get Adobe RoboHelp
Visit the Adobe RoboHelp product page to subscribe to RoboHelp.

The latest release of RoboHelp is available only via subscription. However, you can install a 30-day free trial from the 
product page and even request a demo.

If you are an existing user of an earlier version of RoboHelp (2019 release), you can easily upgrade to the latest version 
of Adobe RoboHelp. Visit Adobe RoboHelp to know more.

See RoboHelp system requirements to check if your computer supports the latest version of Adobe RoboHelp.

Basic workflow

Basic workflow in RoboHelp: From a project to a type of output

Create a project
A project is a container for all your content and the various components, such as Table of Contents, snippets, skins, and 
more, for building the right output. To learn more, see Create a project.

Author the content
Using the powerful editor in RoboHelp, you can author your content with all the elements you need, to make your 
output engaging. Create topics for authoring and add text, images, and multimedia, format the content with text effects, 
tables, lists, and more.  You can preview the content in your desired layout while you are authoring. To know about how 
to work with a topic, see Work with topics and folders.

Import content
You can import content from other sources such as Microsoft Word files (.docx) into your project. For step-by-step 
Help, see Import Word documents into a project.

https://www.adobe.com/products/robohelp.html
https://www.adobe.com/products/robohelp.html
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Build the navigation
You can link text and images to other content and decide the content hierarchy or organization scheme in your Help 
system. Create links among different sets of content (topics) and to content that is external to your Help system (such 
as YouTube videos). For step-by-step Help, see Create and manage links and Create and manage a Table of Contents.

Configure the output
You can select a type of output preset (for example, Responsive HTML5 and PDF) in RoboHelp and configure the 
settings to customize the appearance and capabilities of your output. You can also implement conditional content to 
show or hide content depending on the user interest, skill level, and other factors. For more information, see Generate 
outputand What is conditional content.

Generate the output
Generate or publish the output for multiple platforms, such as web, mobile, and print. You can choose from a variety 
of output presets, such as Responsive HTML5, PDF, Microsoft HTML Help (CHM), Frameless, Mobile App, and more. 
For step-by-step Help, see Generate output.

https://helpx.adobe.com/in/robohelp/using/create-manage-links.html
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To download and start using RoboHelp, see Get started with RoboHelp.

• 2019 release

Adobe RoboHelp (2019 release) is a powerful and intuitive application for creating and publishing content. Easily 
and efficiently develop Help systems, e-learning content, policies, procedures, and knowledge bases with RoboHelp. 
You can deliver personalized experiences for different audiences and on a wide range of devices - with minimal 
effort by using out-of-the-box capabilities. Sophisticated content editing, layout creation, formatting, and search 
capabilities in RoboHelp help you create and deliver impactful, easy-to-manage content experiences.   RoboHelp 
provides modern, Responsive HTML5, and device-friendly output presets for creating fluid and personalized 
content; your output looks stunning and is easy to consume. Use condition tags and expressions to create interactive 
and filtered content in several formats and for different screens. You can cater to a wider or more targeted audience.  
Get started with RoboHelp (2019 release)  Need training? Join the Introduction to RoboHelp (2019 release) course.

Feature summary

Responsive HTML5 and CSS3 authoring support

Create highly immersive content experiences using text and multimedia with the out-of-the-box HTML5 and CSS3 
authoring support. Easily add videos from YouTube and Vimeo, audio, images, text effects, symbols, and other 
elements and make your content engaging. The powerful preview capability helps you experience the impact of the 
content while authoring. For step-by-step Help, see Format your contentand Work with images and multimedia.

Enrich your content with SVG support

Make your content look super-sharp across mobile, web, and print by using SVGs. You can import and use multiple 
visuals in SVG files to make your end users experience a smooth output.

Intelligent content reuse

Save time and effort by efficiently using variables and snippets for content reuse across topics in your project. Any 
update to a variable or snippet is reflected everywhere you have used that variable or snippet. You can even add a 
snippet within an existing snippet by drag-and-drop. For step-by-step Help, see Create and use variables for easy 
updatesand Single-source with snippets.

Conditional content definition and publishing

Easily create rules and apply them to a topic, paragraph, or word using condition tags. With condition tags, you can 
control the content for the different Help systems you want to generate from the same project. You can also specify 
the foreground and background colors of conditions and manage them easily. For step-by-step Help, see the 
following:

1 What is conditional content

2 Create and apply condition tags

3 Configure output presets for conditional content

4 Optimize and manage conditional content

http://helpx.adobe.com/en/robohelp/get-started.html
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Cleaner project structure

RoboHelp maintains all your project contents in a clean and organized structure. Whether it is in the RoboHelp 
workspace or in the Explorer view of your computer, you find the project assets such as style sheets, skins, and 
snippets, are all organized in separate folders. For more information, see Get to know the RoboHelp workspaceand 
Create a project.

Switch between multiple views

Switch between author, code, and preview views at ease when you use the icons in the upper-right corner of the 
screen. This way, you can quickly see a preview of your content output or its HTML. For more information, see Get 
to know the RoboHelp workspace.

Intuitive interface for configuring object properties

While authoring your content, adjust the properties of the various objects you add with optimal accuracy and 
unprecedented ease. You can watch them transform in real time with every change. When you select the object you 
have added, the Properties panel on the right displays all the properties of the selected object. Tweak a value and see 
the change instantly. For more information, see Get to know the RoboHelp workspaceand Format your content.

Powerful skin editor

Customize skins to give a unique appearance to your output. With the powerful skin editor of RoboHelp, you can 
create modern interfaces that are more engaging and user friendly. For step-by-step Help, see Work with skins.
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Optimized search engine

Deliver best-in-class search results to end users with a search engine powered by a smart algorithm and highlighting 
of the searched word. Each output preset comes with configurable search settings. For more information about the 
search settings of a type of output preset, navigate to the relevant article from Generate output.

Multiformat publishing

Use Quick Generate to instantly publish content to a wide range of output formats - Responsive HTML5, Microsoft 
HTML Help (CHM), Frameless, Mobile App, and more. 

Easily generate content-centric mobile apps for iOS and Android with one click, with a PhoneGap Build license.

For more information, start with Generate output.

Next-generation Responsive HTML5 layouts

Deliver personalized content experiences with new Responsive HTML5 layouts that provide intuitive navigation 
and best-in-class search. You can easily show or hide widgets such as glossary and TOC. For step-by-step, see 
Generate Generate Responsive HTML5 output.

Greater content accessibility

Deliver content to accommodate the special needs of your end users. Use 508-compliant HTML5 layouts to create 
content that is accessible to all users, on multiple platforms, such as web, mobile, and print.

Optimized HTML5 output

Experience as much as a 50% reduction in loading time compared to the previous RoboHelp version and a file size 
savings of about 20 KB per topic. You can also experience smoother transitions between pages with faster and more 
responsive HTML5 output. For step-by-step Help, see Generate Generate Responsive HTML5 output.

Dynamic content filters

Deliver more relevant and highly personalized content experiences with dynamic content filters. Use condition tags 
and expressions to enable end users to filter content easily. For step-by-step Help, see Configure output presets for 
conditional content.

Ability to add thumbnails

You can publish images as thumbnails that expand on clicking. This makes content viewing on mobile devices easier 
for end users.

Single-click mobile app generation

Easily generate content-centric mobile apps for iOS and Android with one click, with a PhoneGap Build license. For 
step-by-step Help, see Generate Mobile App output.

Favorites in Responsive HTML5 output
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In Responsive HTML5 output, provide end users the option to mark topics as favorites. This saves them time and 
effort to locate their frequently used content. For step-by-step Help, see Generate Responsive HTML5 output.

Git support

Empower your team members with the ability to collaborate on projects of any size with speed and efficiency using 
Git support.

SharePoint Online support

Ensure everyone stays on the same page by enabling sharing and collaboration across your organization with 
SharePoint Online.

• Get Adobe RoboHelp (2019 release)

Visit the Adobe RoboHelp product page to license RoboHelp.

To know the product better before you license it, you can install a 30-day free trial from the product page and even 
request a demo.

If you are an existing user of an earlier version of RoboHelp, you can easily upgrade to Adobe RoboHelp (2018 
release). Visit Adobe RoboHelp (2019 release) to know more.

See RoboHelp system requirements to check if your computer supports Adobe RoboHelp (2018 release). 

RoboHelp system requirements

RoboHelp

Windows
• Intel Core i5 or faster processor (recommended)

• Microsoft Windows® 10 

• 4 GB of RAM or more is recommended

• 3 GB of hard-disk space is required for installation; additional space is required during installation (cannot install 
on a volume that uses a case-sensitive file system or on removable flash storage devices) 

This software will not operate without activation. Broadband Internet connection and registration are required for 
software activation, validation of subscriptions, and access to Online Services. 

Phone activation is not available.

macOS
• Intel Core i5 or faster processor (recommended)

• macOS 10.14.6 or higher

• 4 GB of RAM or more is recommended

• 3 GB of hard-disk space is required for installation; additional space is required during installation

• Safari 10.0 or higher 

https://www.adobe.com/products/robohelp.html
https://www.adobe.com/products/robohelp.html
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Note: 

This product may integrate with or allow access to certain Adobe or third-party hosted online services (“Online Services”). 
Online Services are available only to users 13 and older and require agreement to additional terms of use and Adobe’s 
online privacy policy. Online Services are not available in all countries or languages, may require user registration, and 
may be discontinued or modified in whole or in part without notice. Additional fees or subscription charges may apply.

Optional requirements
• Java Runtime Environment (JRE) 8 ( PDF Generation)

• Microsoft Visual Studio/ Team Explorer 2015 or later ( Azure Dev Ops connections)

• Git for Windows/Mac ( Git connections)

• Adobe FrameMaker 2019 Update 2 or later

Language versions
RoboHelp User Interface is available in the following languages:

• English

• French

• German

• Japanese

Supported browsers for published output
• Google Chrome

• Mozilla Firefox 

• Microsoft Edge

• Microsoft Internet Explorer 11 (Basic Certification) 

• Safari

RoboHelp (2019 release)
• Core i3 or faster processor

• Microsoft®  Windows® 7, 8.1, or 10

• 4 GB of RAM or more is recommended

• 3 GB of hard-disk space is required for installation; additional space is required during installation (cannot install 
on a volume that uses a case-sensitive file system or on removable flash storage devices)

• 64-bit CPU and operating system 

This software will not operate without activation. Broadband Internet connection and registration are required for 
software activation, validation of subscriptions, and access to Online Services. Phone activation is not available.

Note: 

This product may integrate with or allow access to certain Adobe or third-party hosted online services (“Online Services”). 
Online Services are available only to users 13 and older and require agreement to additional terms of use and Adobe’s 
online privacy policy. Online Services are not available in all countries or languages, may require user registration, and 
may be discontinued or modified in whole or in part without notice. Additional fees or subscription charges may apply.

http://www.adobe.com/go/terms
http://www.adobe.com/go/terms
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Supported software
• Microsoft® Word 2016, 2013, 2010 

• Adobe Acrobat Pro DC (2015 release), Pro 2017

• Adobe Captivate 2019*

• Microsoft SharePoint Online*

*These versions are supported with RoboHelp (2019 release) application. However, with RoboHelp Classic 2019, only 
SharePoint 2010 and Adobe Captivate 2017 are supported.

Language versions
RoboHelp (2019 release) is available in the following languages:

• English

• French

• German

• Japanese

Supported browsers for published output
• Google Chrome 65.0 or above

• Mozilla Firefox 59.0 or above

• Microsoft Edge 40.0 or above

• Microsoft Internet Explorer 11

RoboHelp (2017 release)
• Intel®  Pentium®  4 or faster processor

• Microsoft®  Windows®  10, 8.1 or 7

• 1 GB of RAM (2 GB recommended)

• 3 GB of available hard-disk space for installation; additional free space required during installation (cannot install 
on a volume that uses a case-sensitive file system or on removable flash storage devices)

• DVD-ROM drive

• Maximum supported screen resolution – 4K (3480 x 2160, 8.3 megapixel, aspect ratio 16:9)

This software does not operate without activation. A broadband Internet connection and registration are required for 
software activation, validation of subscriptions, and access to Online Services. Phone activation is not available.

Note: 

This product may integrate with or allow access to certain Adobe or third-party hosted online services (“Online Services”). 
Online Services are available only to users age 13 years and older and require agreement to additional terms of use and 
Adobe’s online privacy policy (www.adobe.com/go/terms). Online Services are not available in all countries or languages, 
may require user registration, and may be discontinued or modified in whole or in part without notice. Additional fees or 
subscription charges may apply.

Supported software
• Microsoft® Office 365 (only documents downloaded from Office 365) or Microsoft®  Word 2016, 2013, 2010    

http://www.adobe.com/go/terms
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• Adobe Acrobat Pro DC (2015 release) or XI

• Microsoft®  SharePoint Server® 2013 or 2010 

• Adobe RoboHelp Server 10

Language versions  
This product is available in the following languages:

• English

• French

• German

• Japanese

RoboHelp (2015 release)
• Intel®  Pentium®  4 or faster processor

• Microsoft®  Windows®  10, 8.1 or 7

• 1 GB of RAM (2 GB recommended)

• 3 GB of available hard-disk space for installation; additional free space required during installation (cannot install 
on a volume that uses a case-sensitive file system or on removable flash storage devices)

• DVD-ROM drive

• 1024x768 screen resolution (1280x800 recommended) with 16-bit video card

This software will not operate without activation. Broadband Internet connection and registration required for 
software activation, validation of subscriptions, and access to Online Services. Phone activation is not available.

Note: 

This product may integrate with or allow access to certain Adobe or third-party hosted online services (“Online Services”). 
Online Services are available only to users age 13 and older and require agreement to additional terms of use and Adobe’s 
online privacy policy (www.adobe.com/go/terms). Online Services are not available in all countries or languages, may 
require user registration, and may be discontinued or modified in whole or in part without notice. Additional fees or 
subscription charges may apply.

Supported software
• Microsoft® Office 365 (only documents downloaded from Office 365) or Microsoft®  Word 2016, 2013, 2010    

• Adobe Acrobat Pro DC (2015 release) or XI

• Microsoft® SharePoint Server® 2013 or 2010 

• Adobe RoboHelp Server 10

Language versions  
This product is available in the following languages:

• English

• French

• German

• Japanese
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RoboHelp FAQs

Basic FAQs
• What is Adobe RoboHelp?

Create and deliver exceptional Help, policy and procedure, and knowledgebase content with Adobe RoboHelp, now 
also on Mac. Author microcontent to fuel chatbots, featured snippets in search results, and more. Create media-rich 
experiences using HTML5 and CSS3. Make collaboration seamless using web-based review capabilities. Personalize 
customer experiences using Dynamic Content Filters. Publish content as Frameless Responsive HTML5, PDF, 
mobile app, and much more to serve customers across all touchpoints.

• Who should use Adobe RoboHelp?

The latest release of Adobe RoboHelp is designed for:

• Help authors, knowledgebase experts, Help developers for mobile applications, user assistance designers, 
and content strategists who produce Help systems, professional knowledgebases, technical support 
information, user guides, maintenance manuals, and Help content for mobile apps. They want a scalable 
authoring and publishing solution that enables them to single-source content and publish it to multiple channels, 
platforms, and devices across mobile, web, desktop, and print.

• Policies and procedures specialists who produce documentation that helps government and corporate 
organizations achieve compliance with accounting, privacy, accessibility, and other regulatory statutes. They 
need a tool that enables them to write structured, searchable documents that can be easily accessed by anyone in 
an organization.

• Instructional designers and eLearning professionals who create document-based learning materials for real 
and virtual classrooms and self-study programs. They are looking for an authoring and publishing tool that is 
comprehensive but easy to use and integrates with specialist tools like Adobe Captivate. They need to develop 
and maintain instructionally sound eLearning courses that integrate with Learning Management Systems 
(LMSs). They work in a collaborative environment with multiple review cycles and follow-up. Productivity is a 
major concern - they need to deliver more in less time, with fewer people, at a lower cost.

• Technical subject matter experts and engineers who create comprehensive technical documentation, including 
test plans, designs, reports, and product specifications. They increasingly want to include 3D models and 
simulations in their documents and often seek solutions with these rich media capabilities.

• What is the difference between Adobe RoboHelp and Adobe Technical Communication Suite?

Create and deliver exceptional help, policy, and procedure, and knowledgebase content with Adobe RoboHelp, now 
also on Mac. Author microcontent to fuel chatbots, featured snippets in search results, and more. Create media-rich 
experiences using HTML5 and CSS3. Make seamless collaboration using web-based review capabilities. Personalize 
customer experiences using Dynamic Content Filters. Publish content as Frameless, Responsive HTML5, PDF, 
mobile app, and much more to serve customers across all touchpoints.

Adobe Technical Communication Suite provides five market-leading tools for your technical, eLearning and 
business content in one value-for-money suite. The suite empowers technical communicators to:

• Easily author long, complex XML and non-XML documents.

• Deliver highly personalized interactive Help experiences with best-in-class search.

• Create responsive eLearning content and transform presentations to enable on-demand learning.

• Publish content across channels, formats, and devices.
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• Collaborate in real time with shared PDF reviews.

Adobe Technical Communication Suite combines:

• Adobe FrameMaker 

• Adobe RoboHelp 

• Adobe Captivate (2019 release)

• Adobe Acrobat DC#

• Adobe Presenter 11.1

#Note: Adobe Document Cloud services is only available under subscription buying programs with Named User 
Licensing (NUL) deployment.

• What are the new features in RoboHelp?

Create exceptional help, policy, and procedure, and knowledgebase content using RoboHelp, now available on Mac. 
Efficiently reuse existing content (paragraph, table, images, and so on) from within a topic or across multiple topics 
using cross-references. Author modular, information-rich microcontent snippets that can be leveraged by search 
engines, social platforms, in-context help, feature snippets, FAQs, chatbots, and more. Easily import HTML or 
Markdown content as HTML topics. Seamlessly collaborate with reviewers and subject matter experts using a web-
based review process. Reach global audiences by leveraging the all-new translation support to export XLIFF files for 
your content. Save time and costs by taking advantage of advances in machine learning to auto-translate content 
within RoboHelp itself. Make navigating on devices with various form factors easy with new Frameless HTML5 
layouts featuring a navigation bar in the header. Leverage out-of-the-box support for the Zendesk and Salesforce 
Knowledge platform.

See all the new features in the latest release of Adobe RoboHelp.

• What is Responsive HTML5 publishing in RoboHelp?

Responsive HTML5 is an output type in Adobe RoboHelp. It is based on a single responsive layout that automatically 
scales to different screen sizes. Generating Responsive HTML5 output using RoboHelp is as easy as generating 
WebHelp because you don’t need to configure anything - just choose the responsive layout as you choose a WebHelp 
skin.

• Does RoboHelp have international language support?

Yes. RoboHelp supports Unicode, which enables you to author and edit Help topics in many different languages. You 
can publish Help systems in Brazilian Portuguese, Bulgarian, Canadian French, Catalan, Croatian, Czech, Danish, 
Dutch, English, Estonian, Finnish, French, German, Greek, Hungarian, Italian, Japanese, Korean, Latvian, 
Lithuanian, Norwegian, Polish, Portuguese, Romanian, Russian, Simplified Chinese, Slovenian, Spanish, Swedish, 
Swiss German, Thai, Traditional Chinese, Turkish, and Vietnamese. Adobe RoboHelp checks spelling, auto-corrects 
words, and creates a keyword index in any of these languages. The generated Help system, including navigation, 
appears in the selected language. Full text search is also operational in all the languages.

•  Does Adobe RoboHelp integrate with Adobe FrameMaker?

You can import FrameMaker MIF and FrameMaker files with style mapping, conditional tags, user-defined 
variables, and Adobe Captivate content intact into RoboHelp.

• Which browsers support the output generated by Adobe RoboHelp?

The following browsers support the output generated by RoboHelp:

• Google Chrome

• Mozilla Firefox

http://helpx.adobe.com/en/robohelp/using/overview.html#Featuresummary
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• Microsoft Edge

• Microsoft Internet Explorer 11 (Basic Certification)

• Which versions of Microsoft Office are compatible with RoboHelp?

Microsoft® Word 2019, 2016 are compatible with RoboHelp.

• Which versions of Acrobat are compatible with RoboHelp?

Adobe Acrobat Pro (2015 release), Pro 2017 and Adobe Document Cloud are compatible with RoboHelp.

• Which versions of Adobe Captivate are compatible with Adobe RoboHelp?

Adobe Captivate 2019 is compatible with Adobe RoboHelp.

• Can I import a project created in other Help authoring tools, for example, AuthorIT, Component One, or Flare?

You can import the final Help system output, but you cannot import proprietary file formats from third-party 
authoring tools.

• What is Frameless output in Adobe RoboHelp?

RoboHelp introduces Frameless output with sleek layout designs and an improved user experience. The Frameless 
output significantly improves Google search for online help as it does not use iframes or framesets for the layout. In 
the Frameless output, every topic has a unique URL, which improves access to context-sensitive information. The 
Frameless output includes a built-in Mini TOC, an improved dynamic content filter experience, the capability to 
present a PDF version of the online version, and enhanced security and accessibility features.

• Can I access RoboHelp Classic with the latest release of Adobe RoboHelp?

RoboHelp Classic is no longer shipped with the Adobe RoboHelp. You can migrate existing projects from RoboHelp 
Classic into the latest release of RoboHelp. However, once you have migrated and changes have been made, those 
projects cannot be imported back to RoboHelp Classic (2019 release and previous versions).

• Can I publish to RoboHelp Server from RoboHelp?

Yes, you can publish to Adobe RoboHelp Server from Adobe RoboHelp.

• What are the formats that can be published to RoboHelp Server from RoboHelp?

You can publish content as Frameless, Responsive HTML5 and WebHelp to RoboHelp Server from Adobe 
RoboHelp.

• How do I find an Adobe Technical Communication Partner in my country or region?

You can find an Adobe Technical Communication Partner to assist you in your country or region by visiting 
the Partner Portal.

• Are there any training or learning resources available for my Adobe Technical Communication software?

You can access free learning assets and training material for your Adobe Technical Communication software here.

Pricing and purchasing information
• Can I buy a full / Perpetual license (with serial key) of the latest release of Adobe RoboHelp?

Full license of Adobe RoboHelp is no longer available for purchase. For individual needs, you can opt for 
subscription plans via adobe.com.

For enterprises, SMBs, Education and Government segments, one can opt for volume licensing plans like Enterprise 
Term License Agreement (ETLA) and Value Incentive Program (VIP).

To explore all the buying options, visit the Buying guide page or write to us at techcomm@adobe.com.

https://partners.adobetechcomm.com/
https://www.adobe.com/products/technicalcommunicationsuite/resources.html
https://www.adobe.com/products/robohelp/buying-guide.html
https://www.adobetechcommcallback.com/
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• How much does it cost to purchase a RoboHelp or RoboHelp Server license?

The latest version of Adobe RoboHelp is available on subscription for US$29.99†/month per user (annual 
commitment). Visit the Buying guide page to explore all the buying options.

RoboHelp Server is available on VIP and ETLA plan. Visit the Buying guide page to explore all the buying options. 
Request a call back for more details on RoboHelp Server.

Please note: Full version perpetual license of the latest release of Adobe RoboHelp and RoboHelp Server is no longer 
available.

†Prices listed are the Adobe direct store prices. Actual price can vary depending on the country and currency of 
purchase, product language and applicable local taxes.

• I own an older version of RoboHelp or RoboHelp Server. What is your upgrade policy?

There is no upgrade path available for users holding a valid license (with serial key) of Adobe RoboHelp (2017 
release) or Adobe RoboHelp (2019 release).

To access the latest version of Adobe RoboHelp, you must move to subscription plans. To explore all the buying 
options, visit the Buying guide page. You can also request a callback or write to us at techcomm@adobe.com.

• Can I try RoboHelp before I buy it?

Yes. You can download a fully functional, free 30-day trial version.

• Is volume licensing available, and where can I learn more about it?

Special programs are available for volume licensing of RoboHelp. To learn more about volume licensing plans, 
request a callback.

• Does Adobe have a maintenance program for RoboHelp?

Yes. Adobe provides maintenance programs for users who participate in the volume licensing programs. Learn 
more.

• Where can I buy Adobe RoboHelp?

You can buy RoboHelp through the online Adobe Store or by calling: +1-866-647-1213 (Monday to Friday, 8 AM 
ET – 5 PM ET). Learn about other ways to buy RoboHelp, including buying directly from Adobe, through 
authorized resellers or purchasing with education or government discounts here.

• Does Adobe offer educational pricing for RoboHelp?

Adobe does offer educational pricing for RoboHelp, but only via licensing and not via retail. Learn more about 
special education pricing.

• How do I find an Adobe Technical Communication Partner in my country or region?

You can find an Adobe Technical Communication Partner to assist you in your country or region by visiting the 
Partner Portal.

• Are there any training or learning resources available for my Adobe Technical Communication software?

You can access free learning assets and training material for your Adobe Technical Communication software here.

Support information
• Where do I go if I have customer service questions?

For any customer service questions, write to us at techcomm@adobe.com.

• Where do I go if I have technical support questions?

https://www.adobe.com/products/robohelp/buying-guide.html
https://www.adobe.com/products/robohelp/buying-guide.html
https://www.adobetechcommcallback.com/
https://www.adobe.com/products/robohelp/buying-guide.html
https://www.adobetechcommcallback.com/
https://www.adobetechcommcallback.com/
https://www.adobe.com/products/robohelp/download-trial/try.htm
https://www.adobetechcommcallback.com/
https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp
https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp
https://www.adobe.com/products/catalog.html
https://www.adobe.com/products/robohelp/buying-guide.html
https://www.adobe.com/products/technicalcommunicationsuite/education.html
https://www.adobe.com/products/technicalcommunicationsuite/education.html
https://partners.adobetechcomm.com/
https://helpx.adobe.com/support/tech-comm-suite.html
http://helpx.adobe.com/robohelp/using/mailto:techcomm@adobe.com
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For any technical support questions, visit the Customer Support page.

• What is activation?

Activation is a mandatory process that requires the software to connect to Adobe servers via the Internet and 
associates the products you have bought from Adobe with the computers on which you use those products. 
Activation helps protect your computers and environment from malicious code by ensuring you are using genuine 
Adobe software.

• What information is passed to Adobe during activation?

Adobe does not gather, transmit, or use personally identifiable information during activation, other than the 
computer’s IP address.

• How many times or how often will I have to connect to the Internet?

The machine with RoboHelp installed must connect to the Internet at least once within 30 days of the first launch 
of your product.

• Do I need to do anything to activate the software?

Activation occurs silently in the background after installation when the system detects an Internet connection. You 
don't have to do anything proactively to activate.

• How long can I use the product before I need to activate?

The product must connect to the Internet at least one time within 30 days of the first launch of your product. If the 
product has not been activated after 30 days, the application does not launch until an Internet connection is detected 
and the software can be activated.

• What happens if I do not have an Internet connection or do not activate my product?

The software silently tries to connect to the Internet to activate for the first 7 days after the first launch of your 
product. If the software has not activated within the first 7 days, you receive a reminder for the next 23 days on every 
launch that the machine must connect to the Internet and activate the software. As soon as the software detects an 
Internet connection, it silently activates the product.

In case of Feature Restricted Licensing (FRL)*, the activation method is different. Please visit this page or contact 
support.

*Feature Restricted Licensing (FRL) is recommended for organizations that have very specific needs to control data 
flow in and out of locked down or restricted network environments.

• If I don’t have an Internet connection, can I call Support for phone activation?

No. Activation of the product via the Internet is required for RoboHelp. If your system is connected to the Internet 
and you receive an activation reminder, contact your local Customer Support for assistance. Customer Support, 
however, cannot activate your software over the phone if you don’t have an Internet connection.

• I have an Internet connection, but received a reminder that I still need to activate my product. What do I need 
to do?

http://helpx.adobe.com/en/tech-comm-suite/customer-support.html
https://helpx.adobe.com/enterprise/using/create-frl-packages.html
https://helpx.adobe.com/support/robohelp.html
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If your system is connected to the Internet and you have received a reminder asking you to activate your product, 
contact Customer Service.

• I work for a company that has a volume license agreement with Adobe. Do I still need to activate?

Yes. All users of RoboHelp need to activate their product. If your company has firewall restrictions that prevent the 
machines from connecting to the Internet, have your IT administrator contact Customer Service.

In case of Feature Restricted Licensing (FRL)*, the activation method is different. Please visit this page or contact 
support.

*Feature Restricted Licensing (FRL) is recommended for organizations that have very specific needs to control data 
flow in and out of locked down or restricted network environments.

• I work for a company that has a license with Adobe and I’ve already activated one of my computers. Do I need 
to activate the other?

Yes. Every computer that has RoboHelp installed must activate to continue using the software.

• I work for a company that has a license with Adobe, and our company systems do not connect to the Internet 
due to firewall restrictions. What do I need to do to make sure the software doesn’t stop working?

If your company has firewall restrictions that prevent the machines from connecting to the Internet, have your IT 
administrator contact Customer Service.

In case of Feature Restricted Licensing (FRL)*, the activation method is different. Please visit this page or contact 
support.

*Feature Restricted Licensing (FRL) is recommended for organizations that have very specific needs to control data 
flow in and out of locked down or restricted network environments.

• Can I choose not to activate Adobe RoboHelp?

Activation of the latest version of RoboHelp is required via the Internet to continue use of the product. Activating 
your product helps protect your computer and your environment by ensuring that you are using a genuine Adobe 
product. Activating your product has other benefits. Visit the activation page for more information. The machine 
with RoboHelp installed must connect to the Internet at least once within 30 days of the first launch of your 
serialized product or the product stops working. If you work in a company that has a firewall that prevents your 
system from connecting to the Internet, have your IT administrator contact Customer Service.

In case of Feature Restricted Licensing (FRL)*, the activation method is different. Please visit this page or contact 
support.

*Feature Restricted Licensing (FRL) is recommended for organizations that have very specific needs to control data 
flow in and out of locked down or restricted network environments.

• I didn’t know I needed to have an Internet connection when I subscribed to RoboHelp. Is there a way to activate 
without having an Internet connection?

No. Activation of RoboHelp is required via the Internet. Each machine with an application installed must connect 
to the Internet at least once within 30 days of the first launch of your serialized product to continue using the 
product. 

In case of Feature Restricted Licensing (FRL)*, the activation method is different. Please visit this page or contact 
support.

https://helpx.adobe.com/support/robohelp.html
https://helpx.adobe.com/support/robohelp.html
https://helpx.adobe.com/enterprise/using/create-frl-packages.html
https://helpx.adobe.com/support/robohelp.html
https://helpx.adobe.com/support/robohelp.html
https://helpx.adobe.com/enterprise/using/create-frl-packages.html
https://helpx.adobe.com/support/robohelp.html
https://helpx.adobe.com/support/robohelp.html
https://helpx.adobe.com/tech-comm-suite/kb/activate-technical-communication-suite.html
https://helpx.adobe.com/support/robohelp.html
https://helpx.adobe.com/enterprise/using/create-frl-packages.html
https://helpx.adobe.com/support/robohelp.html
https://helpx.adobe.com/enterprise/using/create-frl-packages.html
https://helpx.adobe.com/support/robohelp.html
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*Feature Restricted Licensing (FRL) is recommended for organizations that have very specific needs to control data 
flow in and out of locked down or restricted network environments.

• I didn’t know I needed to have an Internet connection when I purchased Adobe RoboHelp? What is the return 
policy?

For details on Adobe return policies in your region, see this Return or exchange a non-subscription product.

• Are activation and registration the same thing?

No. Activation is a mandatory process that requires the software to connect to Adobe servers via the Internet and 
associates the products you have bought from Adobe with the computers on which you use those products. 
Activation helps protect your computers and environments from malicious code by verifying that you have genuine 
Adobe software. Registration is an optional process that gives you access to a wide range of benefits and options, 
including access to support, notification of product updates, newsletters, special offers, and invitations to Adobe 
events.

• I have registered my product but am still being asked to activate. What do I need to do?

Registration and activation are completely different.

Activation is a mandatory process that requires the software to connect to Adobe servers via the Internet and 
associates the products you buy from Adobe with the computers on which you use those products. Activation helps 
protect your computers and environments from malicious code by verifying that you have genuine Adobe software.

Registration is an optional process that gives you access to a wide range of benefits and options, including access to 
support, notification of product updates, newsletters, special offers, and invitations to Adobe events.

• I misplaced my product key for RoboHelp. How can I get a new product key?

Contact Adobe Tech Comm Customer Support at tcssup@adobe.com or write to techcomm@adobe.com.

Subscription information and pricing
• What is an Adobe technical communication software subscription?

A subscription is a new, more flexible way to get technical communication software. It gives ongoing access to the 
software for a low monthly fee, as well as access to all upgrades at no additional charge as long as your subscription 
remains active.

Note: The subscription plan requires an annual commitment, billed monthly or prepaid. There is no month-on-
month subscription plan.

• Do I install the subscription software on my computer or is it a cloud-based application that I log in to via the 
Internet?

The software installs locally on your computer. It is unnecessary to be online to use your subscription. Access to the 
Internet is required during installation and licensing of your software and once every 30 days, thereafter. The 
software alerts you when a connection to the Internet is required for a license status check. You have access to the 
software as long as your subscription is current.

• Is subscribing to Adobe Technical Communication software the best choice for me?

Subscribing is a great option to consider if:

• You always want to benefit from the latest capabilities and updates of the latest version.

• You haven’t upgraded your software in years and want to move up to the current version at an affordable price.

• You have never used Adobe Technical Communication software and want to try it.

http://helpx.adobe.com/en/x-productkb/policy-pricing/return-cancel-or-change-order.html
http://helpx.adobe.com/robohelp/using/mailto:tcssup@adobe.com
http://helpx.adobe.com/robohelp/using/mailto:techcomm@adobe.com


22
Introduction to RoboHelp

Last updated 7/13/2020

• Which Adobe technical communication software is available on a subscription basis?

The following Adobe Technical Communication software are available by subscription:

• Adobe FrameMaker

• Adobe RoboHelp

• Adobe Technical Communication Suite

• What subscription plans are available for Adobe Technical Communication software?

Adobe Technical Communication software are available only via the one-year subscription plan. One-year plans 
have lower monthly payments and require that you remain a subscriber for at least a year. For more details, visit the 
buying guide.

• How much does it cost to subscribe to Adobe FrameMaker, Adobe RoboHelp, or Adobe Technical 
Communication Suite, Adobe FrameMaker Publishing Server or RoboHelp Server?

Subscription fees vary by product, plan, and your country of residence. Visit Adobe.com or the online Adobe Store 
in your respective country for pricing information.

FrameMaker Publishing Server and RoboHelp Server are not available for Subscription via Adobe.com or online 
Adobe store.

• How am I billed for my subscription?

Under an annual plan, paid monthly, you’ll be charged the rate stated at the time of purchase, plus applicable taxes 
(such as value added tax when the stated rate doesn’t include VAT), every month for the duration of your annual 
contract.

Under an annual plan that is prepaid, you’ll be charged the annual rate stated at the time of purchase as one lump 
sum, plus applicable taxes. Your contract will renew automatically, on your annual renewal date, until you cancel.

See terms and conditions for more details.

• Where can I purchase Adobe Technical Communication software subscription editions?

Adobe Technical Communication software subscription plans are available exclusively through Adobe.com or 
respective product websites (in select countries).

• Are there any differences in functionality between the Adobe Technical Communication software purchased as 
a subscription versus the traditional purchasing model?

No, there are no differences in the functionality or in the system requirements between the two. However, if you 
suspend or cancel your subscription, you cannot use the software.

• I’m currently using a 30-day trial version. Can I convert that to a subscription?

Yes, you can convert the 30-day trial version of Adobe RoboHelp into a subscription by purchasing a license from 
adobe.com. For any queries, you can reach us at techcomm@adobe.com.

• When I purchase my subscription, do I receive a box that contains the software?

No. When you purchase a subscription on adobe.com, you immediately receive an email that contains a link to the 
electronic download of the software.

• I checked my credit card statement, and my subscription fee sometimes varies from one month to the next. Why 
is that?

If you live in a region where you purchase from the Adobe Store with a price quoted in U.S. dollars or euros (but you 
receive credit card statements with charges stated in your local currency), you could see different amounts charged 
from month to month. Changes in the currency exchange rates from one billing date to the next affect the charges.

https://www.adobe.com/products/robohelp/buying-guide.html
https://www.adobe.com/legal/subscription-terms.html
http://helpx.adobe.com/robohelp/using/mailto:techcomm@adobe.com
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• I have bought a subscription from Adobe.com already. Will the cost of my subscription increase?

No, there is no increase in subscription pricing.

• What does my Adobe Technical Communication software subscription include?

Your subscription includes access to current and future versions of the Adobe technical communication application 
as long as your subscription remains active.

• Are volume licenses available on subscription for Adobe Technical Communication software?

No, only individual subscription editions are available, and only on adobe.com. For volume licensing needs, kindly 
request a call back.

• Is the pricing different for government or educational customers?

Education customers are eligible to discounted prices if they meet the eligibility requirements. For more details, 
write to techcomm@adobe.com.

• What language versions of Adobe Technical Communication software are available by subscription?

Adobe FrameMaker, Adobe RoboHelp, and Adobe Technical Communication Suite subscriptions are available in 
English, French, German, and Japanese.

• How do I purchase and get started with my Adobe Technical Communication subscription software?

Getting started with a subscription is fast and easy: Go to our buying guide and choose your product and plan, and 
then complete the purchase. Immediately after purchase, check your email for a message from Adobe with your 
serial number and a link to download your software. After you download the product, double-click the installer and 
follow the onscreen instructions to install your product and start your subscription.

• How to upgrade to or download the latest version of Adobe Technical Communication software if I have an 
active subscription?

Download and install the trial build from here. Once you have downloaded and installed the software, activate the 
software using your Adobe credentials.

• When does my subscription begin?

Your subscription begins as soon as your payment is processed.

• What if I have problems downloading my software?

Visit the Troubleshooting download problems page, where you can find information about typical software 
download issues. You can also reach out to us at techcomm@adobe.com for any queries.

• What is an Adobe ID and why do I need one to use my subscription?

During your purchase and installation, you are asked to create or enter an Adobe ID. An Adobe ID is simply your 
current email address with a password you create. Learn more about the benefits of an Adobe ID.

• If I subscribe to multiple products, do I need to create multiple Adobe IDs to use them?

No. You can use the same Adobe ID with all your Adobe products, including subscriptions.

• What are the terms and conditions for an Adobe Technical Communication software subscription?

See subscription terms and conditions. 

https://www.adobetechcommcallback.com/
http://helpx.adobe.com/robohelp/using/mailto:techcomm@adobe.com
https://www.adobe.com/products/robohelp/buying-guide.html
https://www.adobe.com/products/robohelp/download-trial/try.html
https://helpx.adobe.com/download-install/kb/troubleshoot-download-problems.html
http://helpx.adobe.com/robohelp/using/mailto:techcomm@adobe.com
https://helpx.adobe.com/manage-account.html
http://www.adobe.com/go/subscription_policy
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Download and install RoboHelp on macOS

System Requirements
Before you install, always make sure that your system meets the minimum system requirements.

Download and install from Adobe.com
Download the latest build of Adobe RoboHelp and follow the set-up instructions below:

1 Open the installer file that you downloaded from the Adobe website.

2 Navigate to Set-up.dmg inside the product folder.

3 Double-click Set-up.dmg file. The .dmg file mounts in two places: on your desktop and in the Finder sidebar under 
your hard drive. Clicking either one of these opens the .dmg file.

4 Navigate to the Adobe RoboHelp folder using the file browser and simply click on the Install.app file located inside 
the folder.

5 To install the Install.app file, drag it into your Applications folder and launch it.

6 Once the installer window opens, sign in with your Adobe ID and password if you are not already signed in.

7 Follow the installation prompts until the installation is complete.

Get to know the RoboHelp workspace
Packed with tons of powerful features, Adobe RoboHelp offers you a thoughtfully designed, clean, and easy-to-use 
workspace. Quickly create content with all the elements you need, build efficiency with single-sourcing and content 
reusability, and publish your project in a desired output type. You can also collaborate with multiple authors in a project.

http://helpx.adobe.com/en/robohelp/using/rh_system_requirements.html
http://prdl-download.adobe.com/RoboHelp/3585BF94D9A1428F92422C2BC40517D0/1593505312487/RoboHelp_15_LREFDJ.dmg
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The RoboHelp workspace
A Menu bar  B Author & Output views  C Left toolbar  D Contents panel  E Open topic  F Properties panel  G Standard toolbar  

• Menu bar

The menu bar provides access to the File, Edit, View, Collaborate, and Help menus.

File menu Create, open, save, and close a project. You can also find options to import Word document and Captivate 
video, upgrade RoboHelp Classic project, configure project settings, and exit project.

Edit menu Cut, copy, paste, undo, and redo content. You can also find options to select all, copy and clear 
formatting, and edit application preferences.

View menu Find options to view Properties panel, starter screen, condition tags, variables, and view topics by title. 
You can also view options to Toggle Full Screen and change the application theme.

Collaborate menu You can find options to add and open connections to share your project for collaboration in a 
multi-author system.

Help menu You can find options to access Help resources, manage your account, sign out from RoboHelp, update 
your application, and view the RoboHelp About dialog box.

• Menu bar controls

The RoboHelp menu bar provides various navigational controls in the authoring area. For example, zoom controls, 
rulers, etc.

Zoom in and out

• To zoom a topic Click the “View” menu in the menu bar and select Zoom. Then select the desired percentage 
between 25% to 500% from the Zoom sub-menu.
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• To set the document zoom to 100% Click the Zoom sub-menu and select “100%”. Alternatively, press CTRL+0. 
        Note: If you have zoomed in or out in your topic, you can press CTRL+0 on your keyboard to return the 
view to 100%.

• To increase or decrease the magnification Select Zoom In or Zoom Out from the View menu. Alternatively, 
press CTRL+= (that's a plus sign) to increase the zoom level and to zoom out again, press CTRL+- (that's a minus 
sign).        Note: You can also hold the CTRL key on your keyboard and scroll the mouse wheel to zoom in and 
out.

Rulers

Rulers provide a quick way to control and set margins for paragraphs, images, tables, text, and other elements in 
your topic and appear horizontally at the top of the editor. To turn the display of the ruler on and off, select View > 
Show > Rulers. 

• Measurement units By default, the Measurement unit for the ruler is set to Inch (in). To change the unit of 
measure, such as  Centimeter (cm), Pica (pc), Point (pt), and Pixel (px),  right-click the ruler and choose a new 
unit from the context menu that appears. Note: These settings control the units of measurement used throughout 
RoboHelp.

• Change margins Margins are indicated on the rulers by grey and white areas. The grey areas at either end of the 
ruler represent the parent area, while the white areas represent your authoring area. You can quickly adjust the 
margin inside the white area by sliding the little inverted triangle on the ruler.

• Author & Output views

Tha Author and Output views are two different workspaces and can be accessed through respective tabs in the 
standard toolbar. The Author view is used to write, modify, and format the content for topics that the users see in 
the output. In addition to writing content, you can also work with Index, Glossary, Table of Contents. etc. in topics 
and master pages.

Author view
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In Output View, there are various components to set up your Output formats e.g., Skins, Map Files, Variable Sets, 
Dynamic Content Filters, etc. To configure and use these components, create and use various Web-based and Print-
based Output Presets. Output presets are easy-to-configure; you can use the many settings to generate and publish 
multiple output formats.

Publish view

• Left toolbar

The left toolbar helps you to easily manage your project by accessing various components of your project, such as 
Contents, Table of Contents, Condition Tags, Variables, Snippets, Reports, and more.

In the left toolbar, click the desired project component to open its corresponding panel.
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• Contents panel

When you click a project component on the Author toolbar, the project component panel opens and allows you to 
manage that component. You can find the following project components in the Author toolbar:

• Contentspanel This panel lists the topics in a project and provides options to add, rename, and edit topic 
properties. You can also create folders and subfolders to organize the topics. To know more about how to work 
with topics, see Work with topics and folders.

• Table of Contentspanel This includes the hierarchy of the folders, subfolders, and topics in a project. You can 
reorder the folders and organize your content in a strategic manner for easy user navigation in your output. You 
can edit, rename, and delete a Table of Contents. To know more, see Create and manage a Table of Contents.

• Index panel This panel lists the index in your project. You can add, rename, edit, and delete an index. To know 
more, see Create and manage an index.

• Glossary panel Lists the glossary terms in your project. You can add, edit, rename, or delete a glossary item. To 
know more, see Create and manage a glossary.

• Condition Tagspanel This panel lists the assigned condition tags in your project. You can add, edit, and delete 
a conditional tag. To know more, see Create and apply condition tags.

• Variables panel This panel displays all the variables that are assigned values in your project. You can add, edit, 
or delete a variable. To know more, see Create and use variables for easy updates.

• Snippetspanel This panel displays the snippets in your project. You can create, edit, or delete snippets. To know 
more, see Single-source with snippets.

• Master Pages panel This panel displays the master pages in your project. You can create, edit, duplicate, delete, 
import, or export master pages. To know more, see Work with master pages.

• Browse Sequences panel This panel displays the browse sequences in your project. You can create, edit, rename, 
or delete browse sequences. To know more, see Create and manage browse sequences.

• Reportspanel Includes options to generate reports such as Topic List, Project Status, Variables, Condition Tags, 
Broken links, and more. You can edit, download, and print a desired report. To know more about reports, 
see Generate reports.

• Open topic

Double-click a topic in the Contents panel to open a topic. You can then edit and format content in your topic. To 
know more about topics, see Work with topics and folders.

• Properties panel

While authoring a topic in a project, the panel displayed on the right side of the screen is the Properties panel. This 
panel contains the following tabs:

• General You can find options to edit font, alignment, border, layout, and background. To know more, see Format 
your content.

• Styles You can find options to edit various types of styles such as paragraph style, character style, hyperlink style, 
and more.

• Topic You can find options to edit topic properties. To know more, see Topic properties.

As you adjust a property of a selected object, like an image, you can see the content changes in real time. You can 
hide or display the Properties panel by choosing View > Properties Panel or click Toggle Right Pane on the 
Standard toolbar.

http://helpx.adobe.com/en/robohelp/using/topic-properties.html
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Use the three tabs in the Properties panel to edit content properties.

• Standard toolbar

The Standard toolbar appears below the menu bar and includes three toolsets:

• The first toolset is a set of tabs and icons at the left side of the standard toolbar. This includes Author and Output 
tabs, and Save All, Undo, Redo, Find Files, and Find and Replace icons. 

• The second toolset is the set of icons at the center of the standard toolbar. This contains various options to 
quickly format content such as inserting bulleted and numbered lists, images, multimedia, and more. To know 
more, see Format your content.

• The last toolset is the set of icons at the right side of the standard toolbar. This contains various view options such 
as Author, Source, and Preview. It also includes Quick Generate and Toggle Right Pane. The Quick Generate 
dialog box allows you to select and configure an output preset of your choice and generate your output. To know 
more about generating output, see Generate output.

The three toolsets in the Standard toolbar.

• Dialog boxes

There are many dialog boxes that you will come across while working with RoboHelp. The most commonly used are:

• Special Character Dialog The Special Character dialog offers hundreds of characters that you can insert into 
your content. To know more, see Work with special characters.

• Hyperlink Dialog The Hyperlink dialog helps to create a navigation link. When an end user clicks the hyperlink 
in the output, the location specified in the hyperlink opens. To know more, see Open, Edit and Remove 
Hyperlinks. 

• Image Dialog  RoboHelp supports standard image formats such as GIF, JPEG, BMP, MRB, WMF, PNG, etc. To 
know more, see Work with images and multimedia.

Note: 

You can easily resize the dialog boxes by clicking the edge and dragging the mouse to the desired size. 

http://helpx.adobe.com/en/robohelp/using/create-manage-links.html#OpenEditandRemovehyperlinks
http://helpx.adobe.com/en/robohelp/using/create-manage-links.html#OpenEditandRemovehyperlinks
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Note: 

You can also drag-and-drop the dialog boxes around in topics. The next time you re-open the dialog box, its last position 
is retained to the place before you closed the dialog box.

• Context menus

The context menu gives people access to additional functionality related to the components in the Author and 
Output tabs. When you right-click or hover over the  icon on any of the components in the content panel, a 
context menu with a nested list opens and immediately displays the relevant commands. From the list, you can select 
from several options to take action on the content associated with that particular component.

An illustration of how the context menu looks
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Chapter 2: Projects

Plan your RoboHelp project
It’s always a good idea to first spend some time in planning your project and not jump straight into authoring. Think 
of the business goal you are trying to accomplish and the audience you need to serve. The resources you have for 
creating and delivering the content also impact the decisions you make while planning the project. If you would like 
multiple authors to collaborate on a project, planning the project is especially important to ensure quality and maximize 
resource usage.

Single-author or multi-author setup
The size of your authoring team is an important consideration for determining the type of processes and tools  to put 
in place. For example, if multiple authors need to collaborate on creating and delivering your content, integrating a 
version control system is always a good idea. Similarly, creating and maintaining glossaries, common assets, and 
authoring and publishing guidelines helps ensure content quality in a multi-author setup.

Multi-role setup
If your publishing requirements are voluminous and varied, you might need to have authoring and output generation 
handled by separate groups of team members. In such a case, plan the processes and protocols in such a way that the 
team can use the power and built-in capabilities of RoboHelp to implement an efficient, frictionless system of delivery. 
If there are designers in the team, make sure that authors, designers, and publishing experts collaborate on creating 
master pages and skins for optimal layout design.

Output types and delivery
Identify the different output types you need. Would there be a need for additional output types later? If yes, what can 
you do now to make adding an output type later easier? If you plan to host the output on a server, do you need to work 
with your IT admin? If you plan to generate a Mobile App output, do you need to outline the guidelines for writing bite-
sized topics? Do you need to maintain content for multiple versions of a product or deliver content for two co-existing 
experiences of a single feature? Plan whether you need to define condition tags and expressions so you can include 
conditional content in different types of output. Plan variable sets for different types of output.
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Look and feel of the output
To ensure that the content experience meets the expectation of your target audience, spend time visualizing the look 
and feel of the output. Check out the skins that come with RoboHelp and see whether you need to tweak or touch up 
available skins or create skins. Plan to invest in creating a great style sheet so your end users have a great content 
consumption experience.

Leveraging external content
Do you have content available in other formats? For example, you might have FAQs, solutions, case studies, and other 
types of high-quality content authored by Subject Matter Experts in Microsoft Word. If yes, you can import this content 
easily in RoboHelp. However, make sure that you review the various Word import settings and make decisions about 
the style, formatting, and various other aspects of the imported content. If there are Adobe Captivate videos for the 
content you are delivering, you can integrate them in your content and provide users a rich, immersive content 
experience.

Navigation design
Before you create tons of content, make sure that you design how end users can navigate the content in the output. How 
do you want to organize the topics and the content inside each topic? How many levels of folders do you want to allow? 
How many levels of headings should be used to organize the content in a topic? Do you want different TOCs for 
different output types or variants? For example, you might want to plan for different TOCs if you want to generate 
output variants for PDF output and Responsive HTML output or for different Help systems for internal and external 
users. Similarly, if you want to create separate Help systems for beginners and advanced users from the same project, 
you will need to plan for different TOCs.

Reusable content
One of the key strengths of RoboHelp is the support for implementing content reusability. Identify the types of 
information that need to be consistently used across the project. If they change often or change late in your project 
cycle, use variables and snippets to author and update them in one place and use them several times in your project.

Content formatting and styling
Plan to implement a consistent and professional look-and-feel for the various elements of your content using styles. 
What’s best, RoboHelp lets you disallow inline formatting at a project level. So before you start authoring, make the 
decision to allow or disallow inline formatting. If you want to allow inline formatting, make sure that you define and 
follow some conventions so the content is consistently formatted. For example, if you want that all UI terms mentioned 
in the content should be in bold, make sure that you define this convention in the planning stage of your project and 
follow it consistently while authoring.

Glossary of terms
It’s always a good idea to invest in a glossary. Identifying the terms and providing clear descriptions of the terms helps 
your end users absorb the concepts and instructions. What’s more, the glossary helps authors to establish a consistent 
verbiage across the project and provide a seamless and authentic user experience. RoboHelp lets you create and 
maintain more than one glossary in a project. So you can even have a glossary that is only for authors and not included 
in the project output. You can also have multiple glossaries for users and choose to include or exclude from the specific 
types of output.
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Content governance
Make use of RoboHelp’s built-in capabilities to define a governance framework for your content. Define the list of topic 
statuses and encourage the authors to use them consistently. Use the various RoboHelp reports effectively to identify 
errors and inconsistencies in different components and make global updates. Keep your projects clean and robust by 
removing unused assets and project components. You can even maintain your guidelines and author notes within the 
project in topics that you can exclude from project output.

Create a project
Note: 

If you are a RoboHelp Classic user, upgrade your projects in a few simple steps. For more information, see Upgrade a 
RoboHelp Classic project.

A project is the core entity that you work with in Adobe RoboHelp. The basic element of a project is a topic. To start 
authoring your content, add topics to a project. Then, add navigation, configure project properties, and generate the 
desired output. A typical output of RoboHelp is a Help system in one or more formats, such as Responsive HTML5 and 
PDF. A RoboHelp project file has the .rhpj extension.

Besides the project file, RoboHelp maintains various project components, such as topics, Table of Contents, variables, 
skins, and master pages, in separate files. As an author, you need not manipulate the project file or the component files 
directly. Whenever you edit a project from within RoboHelp, the project file and any other affected project component 
file are updated automatically.

Project components
The following table lists the various components of a RoboHelp project:

Project component Description

Topic The basic element of your content structure in RoboHelp. A topic can 
contain text, multimedia such as images and videos, navigation links, 
and more. When you plan a topic, make sure that it is easy to consume 
and reuse. Avoid creating topics that are very long or very short.

From the Author toolbar, click the Contents icon to work with topics. 
For more information, see Work with topics and folders.

Folder and subfolder The components that help you organize the contents of your project. 
You can create folders and subfolders to organize topics and assets, 
such as images, videos, and style sheets.

From the Author toolbar, click the Contents icon to create, rename, or 
delete folders and subfolders. For more information, see Work with 
topics and folders. 

Image and multimedia Graphics, audio, video, animation, and other audiovisual assets that 
you can add to a topic to enhance your content.

In an open topic, you can find the Insert Image and Insert Multimedia 
icons in the toolbar on top of the authoring area. For more 
information, see Work with images and multimedia.
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Table of Contents (TOC) A TOC helps present a hierarchical outline of the content in a Help 
system. During authoring, you can browse the TOC and select folders 
or topics to view and edit. In the published output, end users can use 
the TOC to quickly view the scope and coverage of content in the Help 
system. A TOC also allows the end user to quickly jump to a topic of 
choice.

From the Author toolbar, click the Table of Contents icon to work with 
TOC. For more information, see Create and manage a Table of 
Contents.

Index Allows the end user to navigate through a Help system using 
keywords or phrases that you've specified. These keywords or phrases 
require to be associated with specific topics. An index can include 
multiple levels of keywords and cross-references to other keywords.  

From the Author toolbar, click the Index icon to work with indexes. For 
more information, see Create and manage an index.

Glossary Displays the list of definitions for terms or phrases in a Help system. 
You can filter glossary terms with the help of conditions, link to a 
glossary file external to the project, and maintain multiple glossary 
files in a Help system. 

From the Author toolbar, click the Glossary icon to work with 
glossaries. For more information, see Create and manage a glossary.

Condition tags Allow you to define subsets of content and generate multiple Help 
systems from the same project. Condition tags help you manage your 
content for different needs, such as different target audiences and 
delivery formats.

From the Author toolbar, click the Condition Tags icon to work with 
condition tags. For more information, see What is conditional content.

Variables Allow you to store text or a phrase that you can update in one place 
but use in many places across the project. Variables help you make 
quick global updates and ensure consistency. A good use case of 
variables is to store information such as product names and release 
dates. 

From the Author toolbar, click the Variables icon to work with 
variables. For more information, see Create and use variables for easy 
updates.

Snippets Allow you to create and manage reusable content. Global snippets 
help you to identify content and replace it across several topics in a 
single step, which saves times and facilitates efficient content 
changes. 

From the Author toolbar, click the Snippets icon to work with 
snippets. For more information, see Single-source with snippets.

Master pages Provide templates for the layout of a topic and help control the styling 
of content. You can apply a master page to a topic during topic 
creation or to an existing topic, and see the master page applied to the 
topic in preview. 

From the Author toolbar, click the Master Pages icon to work with 
master pages. For more information, see Work with master pages.
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Browse sequences A browse sequence is a linear list of files that helps you logically 
navigate to the next relevant topic. You can add, edit, and delete 
browse sequences. In a browse sequence, you can drag-and-drop 
topics from the Contents panel and TOC, change the sequence of 
topics, and delete topics. 

From the Author toolbar, click the Browse Sequences icon to work 
with browse sequences. For more information, see Create and manage 
browse sequences.

Reports You can generate various reports using the Reports icon on the Author 
toolbar. You can then view and share reports of broken links, unused 
files, missing topics, and more.

From the Author toolbar, click the Reports icon to work with 
reports. For more information, see Generate reports.

Output presets Allow you to define your preferred output format and content layout. 
You can also assign search-related settings for your output, such as 
Enable autocorrect in search box, Show definitions from glossary, and 
more. 

From the Output toolbar, click the Output Presets icon to work with 
output presets. For more information, see Generate output.

Skins Allow you to define the appearance of your HTML output. Just as a 
website template comes with a unique appearance, a RoboHelp skin 
can add a unique appearance to your output. You can add a logo, 
choose the color of borders and headings, and do more to make your 
output look good. You can preview the output in a skin of your choice. 

From the Output toolbar, click the Skins icon to work with skins. For 
more information, see Work with skins.

Labels Allow you to edit and delete language-specific labels, and undo or 
redo the edits. You can also export languagewise labels as XML for 
localization, and import a translated copy for a specific language.

From the Output toolbar, click the Labels icon to work with labels.

Variable sets A variable set enables you to customize variables (added using the 
Variables icon in the Author toolbar) for a specific output by overriding 
the values of the variables. In a newly created variable set, all the 
variables from the project are listed. From this list, you can override the 
values of the variables that you want to customize for a specific 
output. You can create different variable sets to customize the 
variables for different outputs.

From the Output toolbar, click the Variable Sets icon to work with 
variable sets. 

Condition expressions A condition expression controls the inclusion of tagged source 
content or its exclusion from the output. Depending on the condition 
tags used in an expression, the corresponding source content is 
included in the output. You can define various tag combinations in the 
expression using OR, AND, and NOT operators to customize the 
inclusion or exclusion of content in the output. Condition expressions 
are not published along with the source content and do not appear in 
the output.

From the Output toolbar, click the Condition Expressions icon to work 
with condition expressions. For more information, see Configure 
condition expressions and dynamic content filters.

http://helpx.adobe.com/en/robohelp/using/configure-presets-conditional-content.html#Configureconditionexpressionsanddynamiccontentfilters
http://helpx.adobe.com/en/robohelp/using/configure-presets-conditional-content.html#Configureconditionexpressionsanddynamiccontentfilters
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Start a project
Do one of the following to start a project in RoboHelp:

• Create a project

• Upgrade a RoboHelp Classic project

Create a project
Once you've launched RoboHelp, follow these steps to create a project from scratch:

1 Choose File > New Project or press Alt+Ctrl+N. The New Project dialog box appears.

2 In the New Project dialog box, do the following:

• Title Enter the name of the project.

• Language From the drop-down list, select your preferred language for the project's content.

• Save Location Specify the location to save your project. Click  to browse your computer and select your 
preferred folder to save your project in that folder.

3 Click Create.

Dynamic content filters A dynamic content filter controls the display of content in the output. 
Add a dynamic content filter and then customize it by adding 
condition tags. The filters are published along with the tagged source 
content. From the published filters displayed in the output, your end-
users can select specific filters to view selective content and hide the 
rest of the content. Dynamic content filters facilitate quick retrieval 
and consumption of specific information, instead of having to go 
through the entire published content. 

From the Output toolbar, click the Dynamic Content Filters icon to 
work with dynamic content filters. For more information, 
see Configure condition expressions and dynamic content filters.

Stop words Stop words add common (minor) words, such as “a” or “the” in the stop 
list file. During search, RoboHelp ignores the words listed in the stop 
list file to display optimal and relevant search results. You can add, edit, 
and delete stop words for different languages. RoboHelp creates a 
stop list file for each language, for example English (US).stp.

From the Output toolbar, click the Stop Words icon to work with stop 
words. 

Synonyms You can define multiple synonyms for a word to allow for variations in 
search terminologies. For example, you can define "cursor," "pointer," 
and "mouse" as synonymous terms. If the search term is "mouse," 
RoboHelp returns all topics containing the word "cursor," with that 
term highlighted. You can add, edit, and delete synonyms for different 
languages. RoboHelp creates a synonyms file for each language, for 
example English (US).syn.

From the Output toolbar, click the Synonyms icon to work with 
synonyms. 

Style sheets Stores styles defined to control the appearance of your content. 
Instead of formatting content locally, create styles for different 
elements of your content (for example, the different heading levels) 
and apply a style sheet at a project- or topic-level.

To apply a style sheet provided by RoboHelp to an open topic, go to 
the Properties panel > Topic tab > Style Sheets. 

http://helpx.adobe.com/en/robohelp/using/configure-presets-conditional-content.html#Configureconditionexpressionsanddynamiccontentfilters
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To add topics and start authoring content in your project, see Work with topics and folders.

When a new project is created, or any classic or RoboHelp 2019 project is upgraded, a uniquely defined value is 
automatically generated referred as Project ID. It is defined in the .rhpj file.

To check how to track the translation files using the Project ID, see Translating content to multiple languages.

Upgrade a RoboHelp Classic project
To open a RoboHelp Classic project (.xpj file) in RoboHelp, follow these steps:

1 Choose File > Upgrade RoboHelp Classic Project.

2 In the Open dialog box that appears, browse your computer, select the desired .xpj project file, and click Open.

3 In the New Project dialog box, click Create. 

The RoboHelp project is now saved as a .rhpj file.

Note: 

The Project ID is automatically assigned to all the projects upgraded from Classic and RH2019.

Save a project
To save your project or file in RoboHelp, you can do the following:

• To save your project, choose File > Save All or press Ctrl+S.

• To save your topic, choose File > Save or press Alt+Ctrl+S.

Alternatively, you can click  in the upper-left corner of the standard toolbar to save your work.

Configure project settings
You can specify and edit the title and language of the project, along with settings such as topic status, colors, tag groups, 
and version control.

To access the Project Settings dialog box, follow these steps:

1 Once you've launched RoboHelp and opened your project, choose File > Project settings or press Ctrl+Shift+/.

2 In the Project Settings dialog box, you can specify settings in tabs such as General, Topic Status, Colors, and more.

See Project Settingsfor more details. 

3 Once you've entered your desired settings, click Done.

Project Settings
You can find the following tabs in the left panel of the Projects Settings dialog box.

• General

• Colors

• FONT LIST

• Topic Status

• Tag Groups

• PANELS

http://helpx.adobe.com/en/robohelp/using/translation.html#UsingProjectIDasparentchildassociation
http://helpx.adobe.com/en/robohelp/using/create-project.html#Tag_groups


38
Projects

Last updated 7/13/2020

General
In the Project Settings dialog box, the General tab is selected by default. To configure the General tab, do the 
following:

1 Specify or edit the name of the project in Project Title.

2 In Language, click  to select the desired language for your project.

3 In Default Stylesheet, click  to select a desired style sheet for your project. When you create a topic in your 
current project, this style sheet is automatically applied to the topic. 

4 In Default Word Import Settings, choose the file that contains the default settings for converting Word files to 
HTML files.

To edit this file, choose File > Import > Word Document and configure the settings in the General tab of the Word 
Import Settings dialog box. For information about the General tab, see General.

5 Select Do not allow inline formatting to avoid applying new inline formatting. Previously applied inline formatting 
remains unchanged.

Topic Status
You can select a topic status such as Draft, In Progress, and Ready for Review to indicate the current stage of 
authoring of your topic. You can also add a custom status, rename and delete an existing status, and reorder the 
statuses. 

Note: 

The topmost status in the list of statuses is considered as the default status for new topics. 

1 Select the Topic Status tab from the left panel of the Project Settings dialog box.

2 To create your own status, specify the name of the status in Add a new status and click  against it. 

The new status is added to the list of statuses.

3 To rename a status, click its name and modify it.

4 To reorder statuses, click  against a status and drag-and-drop it at the desired position.

5 To delete a status, click  against it.

Note: 

If you delete a status, all topics that are in the deleted status move to the default status. For example, the default 
(topmost) status in the Topic Status tab is Draft and some of your topics are in the Review status. If you delete the 
Review status, all topics that were previously in the Review status move to the Draft status.

Colors
You can add or edit a color and maintain a list of specified colors for your project. You can also rename or delete existing 
colors. 

1 Select the Colors tab from the left panel of the Project Settings dialog box.

2 To add a color, click  to choose a color, specify a name in Color Name, and click .

The new color is added to the list of colors. The list of colors are shown as swatches in Color Picker dialog.

3 To rename a color, click its name and modify it.

4 To reorder colors, click  against a color and drag-and-drop it at the desired position.

5 To delete a color, click  against it.
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Note: 

To know more about Color Picker, see Use the Color Picker dialog box.

Tag Groups
Tag groups help you group multiple related What is conditional contentto provide relevant content to a focus group. 
You can add a tag group to the list of default tag groups. You can also rename and delete existing tag groups. 

1 Select the Tag Groups tab from the left panel of the Project Settings dialog box.

2 To add a tag group, specify its name in Add a new tag group and click  against it.

The new group is added to the list of tag groups.

3 To rename a tag group, click its name and modify it.

4 To delete a tag group, click  against it.

Note: 

A tag group cannot be deleted if it contains tags. Before you delete a tag group, ensure that all the tags grouped under 
that tag group are deleted. To delete a tag, in the Condition Tags panel, right-click the tag and click Delete. 

FONT LIST
Fonts are essential for the look and feel of your publication, maintaining consistency through all your topics. For the 
fonts to work, they must be installed on the computer building the output.

1 Select the Font List tab from the left panel of the Project Settings dialog box.

2 To add fonts, specify the name in Add Fonts group and click  against it. You can also add multiple fonts to one 
line separated by a comma.

Link

The new fonts are added to the list of fonts. 

Note: 

If multiple fonts are added to one line, the browser will select the first one it finds installed in your system.

3 To rename a font, click its name and modify it.

4 To reprioritize the fonts, click  against a font and drag-and-drop it at the desired position.

5 To delete a tag group, click  against it.

6 Select the Do not include system fonts check box to limit the listed fonts. Selecting this option will exclude the list 
of system fonts from the font list.

Using file explorer, you will find the FontList.xml in Project > Settings.  You can use this file to copy the fonts to 
another project.

PANELS
With a large number of panels available in RoboHelp, your workspace can become cluttered very quickly. To optimize 
the display of the left toolbar in the Author and Publish view, show/hide button associated with the panels can be used, 
thus maximizing your working view, as needed. 

1 Select the Panels tab from the left panel of the Project Settings dialog box.

2 You can switch on or off  the toggle button associated with individual panels, as required.

3 Click Done.

http://helpx.adobe.com/robohelp/using/
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Work with topics and folders
A topic is the basic element that contains your content (text, images, multimedia, links, and more) in a project. You can 
add, edit, format, and delete content in a topic. You can have multiple topics organized in a folder and have multiple 
folders in a project. This way you can easily maintain structured content in your project.

Create a folder
Folders store your topics. You can have multiple folders in a project. 

You can create a folder at the root level in the Contents panel or a subfolder inside a folder. 

To create a root-level folder in an open project:

1 In the Author toolbar, click Contents. The Contents panel opens.

2 In the Contents panel, click  in the upper-right corner of the panel and then click New Folder.

3 In the Folder Details dialog box, specify the folder name in Name.

4 Click Create.

The folder is created at the root level in the Contents panel.

Note: 

To create a subfolder inside a folder, select the folder, click  in the upper-right corner of the Contents panel, and 
then click New Folder. Or, right-click the folder or click  against it, and choose New > New Folder. 

Create a topic
You can create a topic inside a folder or at the root level in the Contents panel.

To create a topic in a folder:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 In the Contents panel, do one of the following:

• Select the desired folder, then click  in the upper-right corner of the panel, and click New Topic.

• Right-click the folder or click  against it, and choose New > New Topic.

Note: 

If you don't select a folder, the topic is created at the root level in the Contents panel. 

3 In the New Topic dialog box, specify the properties for the topic in different sections as required.

The New Topic dialog box has the same sections as the Topic Properties dialog box, except for the File Info section, 
which is specific to topic properties. For more information, see Topic properties.

4 Click Create.

The topic is created inside the selected folder in the Contents panel. You can create multiple topics inside a folder 
or a subfolder.

Add content to or edit a topic
Once you've created a topic, to add or edit content:

1 In the Author toolbar, select Contents. The Contents panel opens.

http://helpx.adobe.com/en/robohelp/using/topic-properties.html#Topic_properties
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2 In the Contents panel, expand the folder that contains your topic, and double-click a topic to open it.

Note: 

To quickly search for the topic you want to edit, click  on the top left toolbar or press Ctrl+F. In the search dialog 
box, type the topic title and filename. Double-click to open the relevant topic from the search results.

You can open and work on several topics simultaneously. Each topic opens as a tab in the authoring workspace.

3 In an open topic, you can add or edit text, images, and multimedia content. You can also include expanding text, 
drop-down text, and create links within topics and to external content. You can also insert and customize a Mini 
TOC, variables, snippets, and fields.

See the following resources for more details:

• Work with images and multimedia

• Format your content

• Create and manage links

• Insert and customize a Mini TOC

Note: 

To toggle the display of paragraph markers in a topic, choose View > Show > Paragraph Markers.

4 To quickly run a spell check in an open topic, do the following:

a Choose Edit > Preferences or press Ctrl+Shift+T.

b In the Application Settings dialog box, select Enable Spell Checking.

c Click Done.

RoboHelp highlights the misspelled words in the topic. Right-click a misspelled word to:

• View suggested spellings. To correct the misspelled word, click the appropriate suggested spelling.

• Ignore the instance of misspelled word by clicking Ignore.

• Ignore all the instances of the misspelled word in the topic by clicking Ignore All.

• Add the word to the dictionary by clicking Add to Dictionary.

• Apply condition tags to the word by clicking Apply Conditon Tags. In the left pane of the Apply Conditon Tags 
dialog box, select the condition tags you want to apply. The selected tags are removed from the left pane and 
appear in the right pane. You can click  against a tag to remove it from the right pane. Click Apply.

• Create a snippet by clicking Create Snippet. For more information, see Create a snippet.

• Locate the topic file in the Contents panel by clicking Locate in Contents panel.

• Open the Topic tab in the Properties panel by clicking Topic Properties.

5 To close a topic tab, click .

Note: 

Save your work before closing a topic. When you click  to close a tab, the Save Changes dialog box appears.

In the Save Changes dialog box, do the following:

• If your project is connected to a version control system, click Check-in the file and specify a version label. Then, 
click Save & Check-In.

• If your project is local, click Save to save your work and close the tab.

http://helpx.adobe.com/en/robohelp/using/snippets.html#Createasnippet
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Import files and folders
You can import files and Word documents as topics in a project folder. You can also import folders and Adobe Captivate 
videos. 

To import:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 To import a file:

a Right-click a folder or click  against it, and choose Import > File.

b In the Open dialog box, select the file you want to import and click Open. 

Note: 

The file type drop-down list in the Open dialog box displays the supported file types, for example, all files, topics, style 
sheets, and more. Use this drop-down list to filter files according to its type during file selection.

The selected file is copied as a topic inside your project folder.

3 To import a folder:

a Right-click a folder or click  against it, and choose Import > Folder.

b In the Open dialog box, select the folder you want to import and click Select Folder. 

The selected folder and its files are copied inside your project folder.

4 To import the HTML version of a Word document, see Import Word documents into a project.

5 To import an Adobe Captivate video, see Import and insert an Adobe Captivate video.

Link files and folders
You can link files and folders from your system to your project folder. 

To link:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 To link a file:

a Right-click a folder or click  against it, and choose Link > Link File.

b In the Open dialog box, select the file you want to link and click Open. 

The file is copied inside the selected folder. RoboHelp notifies that the copied/project file is linked to the 
original/source file. A green arrow precedes the project file in the Contents panel, indicating in-sync status. 

Note: 

If modifications are made in the project or the source version, the green color of the preceding arrow changes to red, 
indicating out-of-sync status. To sync linked files:

• From source to project: Right-click the topic or click  against it, and click Sync > From Source to Project. 

• From project to source: Right-click the topic or click  against it, and click Sync > From Project to Source. 

A sync success or failure notification appears.

To remove the link between the project and source versions, right-click the topic or click  against it, and click 
Remove Link. This also removes the arrow preceding the project file in the Contents panel.
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3 To link a folder:

a Right-click a folder or click  against it, and choose Link > Link Folder.

b In the Open dialog box, select the folder you want to import and click Select Folder. 

The selected folder and its files are copied inside your project folder.

4 To import the HTML version of a Word document, see Import Word documents into a project.

5 To import the HTML version of a FrameMaker document, see Import FrameMaker documents into a project.

6 To import an Adobe Captivate video, see Import and insert an Adobe Captivate video.

Create HTML topics
Note: 

Applicable only for Word and FrameMaker files.

To create HTML topics:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 To create HTML topics from a Word or a FrameMaker file, right-click the file or click  against it, and 
click Update HTML. 

RoboHelp creates a folder with the same name as the Word or FrameMaker file and places all HTML topics and 
referenced assets inside the new folder.

Note: 

To create HTML topics, RoboHelp considers the settings specified in the following fields in the Project Settings dialog 
box (General tab):

• For Word documents: Default Word Import Settings

• For FrameMaker documents: Default FrameMaker Import Settings

If a folder has multiple files, use the following options to simultaneously create HTML topics from all files:

• For Word files, right-click the folder and choose Word Documents > Update All.

• For FrameMaker files, right-click the folder and choose FrameMaker Documents > Update All.

Rename a topic or a folder
You can rename a topic or a folder in your project without having to open it. 

To rename:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 To rename a folder, right-click it or click  against it, and click Rename. 

To rename a topic's filename, first expand the folder that contains the topic you want to rename. Then, right-click 
the topic or click  against it, and click Rename. 

3 In the Rename dialog box, specify the new name and click Done. 

Note: 

To view the new filename of the topic you renamed, choose View > Show and deselect Topics by Title. From the default 
title view, RoboHelp switches to the filename view and displays all topics by filename.
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Create a duplicate topic
To create a duplicate topic in the same folder:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 To create a duplicate topic, first expand the folder that contains the topic you want to duplicate. Then, right-click the 
topic or click  against it, and click Duplicate.

3 In the Duplicate dialog box, specify a title and filename for the duplicate topic, and click Done. The duplicate topic 
created in the same folder as the original topic.

Delete a topic or a folder
To delete a topic or a folder in your open project:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 To delete a folder, right-click it or click  against it, and click Delete.

To delete a topic, first expand the folder that contains the topic you want to delete. Then, right-click the topic or 
click  against it, and click Delete.

3 Click Yes in the Confirm dialog box. The topic or the folder is deleted.

Collapse all folders in the project
To collapse all expanded folders in your project:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 Right-click or click  against any expanded folder or any topic inside an expanded folder, and click Collapse All.

All expanded folders in your project collapse.

Locate a topic in a TOC
To locate a topic in a TOC:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 Right-click or click  against a topic and hover over Locate in TOC.

RoboHelp displays the TOCs to which the topic belongs. Click the TOC in which you want to locate the topic.

The Table of Contents panel displays the TOC in expanded view in which, the topic is highlighted.

Note: 

If a topic is not included in any TOC, the Locate in TOC option is not visible. 

Show topics or folders in Windows Explorer
To show the location of specific topics or folders in Windows Explorer:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 Right-click or click  against a folder or a topic inside an expanded folder, and click Show in Explorer (Mac: 
Reveal in Finder)

The location of the folder or the topic is displayed.
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Set topic properties
For information about setting topic properties, see Set topic properties.

Topic tab context menu options
You can open and work on several topics simultaneously. Each topic opens as a tab in the authoring workspace. You can 
right-click a topic tab to use the following options:

Close Closes the current file.

Close Others Closes all open files except for the current file.

Close All Closes all open files. 

While closing multiple open files, RoboHelp prompts you to save your changes. In the Save Changes dialog box, you 
can save a specific file or all files. By default, all open files are selected for saving. If you do not want to save a file, click 
to deselect it. Click Save.

Locate in Contents panel Opens the Contents panel if it's not open already, and highlights the topic.

Generate reports
In Adobe RoboHelp, you can generate a variety of reports to monitor, compare, and optimize the content of your 
project. You can customize your report and display the desired columns, reorder information, and filter project 
components. You can then quickly download a report as a .csv file.

Reports in RoboHelp
You can generate the following types of reports in RoboHelp:

• Topic List

Tip: You can also launch topic list by choosing View > Topic List.

The Topic List report displays the list of topics in a project. For each topic, you can view the filename, title, status, 
author, and the Table of Contents it belongs to. You can view the folder containing the topic, the condition tags 
applied to a topic and its content, the style sheets and master pages used in a topic, the See Also component if added 
to a topic, and the last modified date and time. You can also view if a topic has index keywords associated with it 
and if the topic is included in search. 

You can use the Filters panel at the right to filter the topic list by status, author, folder, and search.

For individual topics or multiple selected topics, you can use the context menu to edit (click Edit) and delete 
topics (click Delete), and configure topic properties (click Properties). The Properties panel shows the number of 
topics present in the topic list; you can use this information while filtering specific topics. You can also create a 
duplicate of an individual topic (click Duplicate) and locate a topic in a specific Table of Contents (click Locate in 
TOC).

You can also drag-and-drop topics from the topic list to a Table of Contents and an index. You can resize columns 
in the topic list report. If you make changes in a topic or add/delete a topic, RoboHelp automatically updates the 
topic list report to reflect the changes.

• Project Status

http://helpx.adobe.com/en/robohelp/using/topic-properties.html
http://helpx.adobe.com/en/robohelp/using/topic-properties.html
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The Project Status report allows you to view the status of each topic in your project. This way you can generate 
information on the total number of topics completed, in progress, and ready for review.

• Topic Properties

The Topic Properties report allows you to view the various topic properties associated to each topic in your project. 
You can view a topic's status, author, condition tags, style sheet, Table of Contents, index keywords, and search 
keywords associated with it.

• Topic References

In the Topic References report, you can view the incoming links in each topic. This way you can view the references 
that are leading to a topic.

• External references

In the External References report, you can view the links that are referred to resources outside your project. This 
way you can test the links in topics that lead to external content.

• Search Keywords

The Search Keywords report lists the keyword tags applied in each topic.

• Broken Links

The Broken Links report lists the topics that contain broken links, that is, links to objects (topics/images) that have 
been moved, renamed, or removed. You can view the topic, the folder in which the topic exists, broken link path, 
and type of object for each broken link in your project. You can also fix broken links.

Note: 

In a multi-author and version-controlled environment, ensure that you don’t link to topics that have been moved, 
renamed, or removed as these links are broken.

• Unused Files

The Unused Files report lists the various files that are not used in your project. For each unused file, you can view 
its file name and the folder.

If you want to remove any unused file(s) from your project, right-click the file from the list and press the Delete 
button. You can also use the individual or multiple checkboxes to select the files you would like to delete. 

• Unreferenced Topics

The Unreferenced Topics report lists the topics in your project that are not linked to in the Table of Contents, index, 
browse sequences, or in other topics. You can use this report to identify:

• Inaccessible topics that are not linked from other topics

• Topics excluded from the Table of Contents

• Topics without index

Note: 

Few topics do not use references such as context-sensitive Help topics. For example, if you create window-level context-
sensitive Help, topics are accessible only when you press F1 or click Help. In this case, you don't require references.

• Table of Contents

http://helpx.adobe.com/en/robohelp/using/create-manage-links.html#Fixbrokenlinks
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The Table of Contents report lists the details of the selected Table of Contents in your project. You can view the 
links in the topics, the title and file type such as book or page, and if it is hidden or not in the Table of Contents 
output.

• Index

The Index report lists all the index keyword tags applied across topics in your project. You can view the keywords 
and the topics that contain them.

• Glossary

The Glossary report lists the terms and their definitions in the selected glossary. You can also view the topics that 
the terms are added in and the file types.

• Condition Tags

The Condition Tags report lists the condition tags in your project with the tag name and color. For each tag, you 
can view the group of condition tag, the topic, and file type that the condition tag is applied in.

• Variables

The Variables report lists variables in your project with their values. For each variable and its value, you can view 
the topic and file type that the variable is used in. This way you can find variables that are used in a topic or those 
that are not used in any topic. Before you delete a variable, you can locate the topics in which the variable is used 
and delete references to that variable.

• Snippets

The Snippets report lists the snippets defined in your project. You can view the topic and the file type each snippet 
is used in.

• Images

The Images report lists the image file names that are used in your project. For each image file name, you can view 
the topic and the file type that it is in.

• Multimedia

The Multimedia report lists the multimedia file names in your project. For each multimedia file name, you can view 
the topic and the file type it is in.

• Stylesheets

Use the Stylesheets report to view the list of style sheets in your project. For each style sheet, you can view the topic 
and the file type it is in.

• See Also

Use the See Also report to view information such as the list of See Also keywords (terms) in your project, the main 
topics that use each term, title of the main topics, and the folder in which the main topic exists. You can also filter 
the report according to folders.

For information about See Also keywords, see Work with See Also and Related Topics.

• Map ID

Use the Map ID report to view the information related to the map IDs used in your project. You can view the map 
number, map ID, map filename, topics in the map file, topic title, and the folder in which the topic exists.
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Open a report
To open or generate a report in RoboHelp, follow these steps:

1 In an open project, click Reports  on the Author toolbar.

2 In the Reports panel, double-click the report that you want to generate. Alternatively, click Options  next to the 
desired report type and choose Open. To know more about the various reports in RoboHelp, see Reports in 
RoboHelp.

Note: 

To view the latest report after you've edited your project, click the Refresh icon  on the toolbar.

Customize a report
You can customize a report using the Filters panel on the right side of the screen. In this panel, you can view the type 
of report, select a criteria to order information, filter information, and select the columns to view in the report. To 
customize your report, use the following options in the Filters panel:

Type
Under Type, you can view the type of report that is open. To know more about the types of reports in RoboHelp, see 
Reports in RoboHelp.

Order By
You can select a criteria to order the information in your report using the options under Order By. Based on the type 
of report, you can find different options such as Status, Keyword, Topic, and more.

View
By default, a report is viewed as a table. Reports such as Topic References and Project Status can also be viewed as a 
graph and pie chart, respectively. Use the options under View to change the appearance of the report.

Filter
Under Filter, use the drop-down lists of various project components to specify information in the report. You can also 
select multiple options in each drop-down list.

For Index, Glossary, Condition Tags, Variables, Snippets, Images, Multimedia, and Stylesheets reports, you can 
also select Used in <project component> to view the files that the project component is applied in.

RoboHelp remembers all filtering and column selections for all reports across sessions.

Columns
You can add or remove columns in your report using the options in Columns. These columns are based on the type of 
report that you have selected. Select a column to view it and deselect it to remove it in the report. To sort the data in 
each column in all reports, click the column header. 

Download a report
To download a report with the applied settings in RoboHelp, follow these steps:

1 Click Reports  on the Author toolbar.
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2 In the Reports panel, double-click the type of report you want to generate and open it. Alternatively, click 
Options  next to the desired report type and choose Open.

3 To customize your report, use the Filters panel on the right side of the screen. For details, see Customize a report.

4 To download your report, click Download  on the toolbar. 

The report is then saved as a .csv file.

Work with context-sensitive help

What is context-sensitive help
A context-sensitive help topic provides information about the user interface of an application relative to the task your 
user performs. For example, context-sensitive help topics provide details about fields and controls in dialog boxes, 
descriptions of windows or screen objects, and explanations of messages. Your users access a context-sensitive help 
topic by pressing F1, clicking a Help button, selecting from a menu, or clicking a question-mark icon.

What is a map file
In RoboHelp, you work with context-sensitive help topics through map files in Output view. You can create, assign, 
unassign, edit, import, and export map files. A pairing of a map ID and map number for each topic is saved in map files. 

A map ID and map number pairing inside a map file

Map ID Assign a unique map ID to each topic to display it in the CSH. For example, ID_SetupScreen.

Map number A numeric value associated with a topic. Map numbers are used with applications to specify a topic for 
calling context-sensitive help. For example, 101.

Whether application developers use map numbers, map IDs, or both depends on the programming language they use. 

Topic You can assign or unassign a topic against a map ID and number. For example, SetupScreen.

Author and developer tasks
Map files are used by authors and developers to build a context-sensitive help for an application. 

• Author Writes the Help topics that describe how to use application components such as windows, dialog boxes, 
fields, and controls.

• Developer Builds the components (windows, dialogs, fields, controls) that make up the application.

An author can generate map files containing map IDs and give them to the developer. Or, an author can obtain map 
files from the developer.

To share map files, you can Export a map fileas a .h file in this format:
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#define ID_SetupScreen 101

Create a map file
To create a map file:

1 In the Output toolbar, click Map Files.

2 In the Map Files panel, click  at the top right corner and then click New Map File. 

3 In the New Map File dialog box, specify the name of the map file.

Note: 

When creating filenames, use underscores instead of spaces, and avoid using these illegal characters: \ / : * ? < > | # " $ 
& [ ]

4 Click Done. 

RoboHelp places the map file in alphabetical order of filenames in the Map Files panel and opens the map file editor.

Edit a map file
To edit a map file:

1 In the Output toolbar, click Map Files.

2 In the Map Files panel, double-click the map file you want to edit. Or choose Options  > Edit against the map 
file.

RoboHelp opens the map file editor with Contents panel at the left and the fields Map ID, Map No., and Topic at 
the right.

3 To map topics, you can follow two approaches.

Approach 1: To let RoboHelp automatically assign map IDs and map numbers, from the Contents panel, drag a 
topic and drop it below the field names in the map file editor.

RoboHelp automatically maps the topic name as map ID. For the first topic, the default map number is 1. You can 
edit the map ID and map numbers.

Note: 

Specify map file settings, if specified, are applicable to all topics that are dragged and dropped.

Approach 2: If you want to specify a custom map ID or map number and separately assign a topic, do the following:

a Type a map ID in the Map ID field and press Enter. 

b Type a map number in the Map No. field and press Enter.

c Assign a topic by clicking  at the right side of the row. 

d In the Insert Topic dialog box, search for a topic or select it from the Contents or Recently Used drop-down 
sections. 

e Click Insert.

The topic is assigned to the map ID and number, and the topic filename appears under the Topic field.

To unassign a topic, click  next to the topic name.

To delete an entire row of map ID, map number, and topic, click  in that row.
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Note: 

Specify map file settings, if specified, are not applicable to topics that are assigned separately or to mappings defined 
before the settings were specified.

4 You can modify both Map ID and Map No. fields.

Specify map file settings
Map file settings apply to topics that are dragged and dropped in the map file editor. To specify map file settings:

1 In the Output toolbar, click Map Files.

2 In the Map Files panel, right-click a map file and click Options. Or, against the map file, choose  > Options.

3 In the Mapping Options dialog box, do the following:

• Prefix Map ID With To automatically add a prefix to all new map IDs, specify the prefix in this field. 

• Start Map Number From To automatically start map numbers from a specific number, specify the number in 
this field.

• Create Map ID in uppercase Select this field to automatically create map IDs in uppercase. 

4 Click Done.

Rename a map file
To rename a map file:

1 In the Output toolbar, click Map Files.

2 In the Map Files panel, right-click a map file and click Rename. Or, against the map file, choose  > Rename.

3 In the Rename dialog box, specify a new name for the map file. 

4 Click Done.

The updated name of the map file is shown in the Map Files panel.

Import a map file
You can import a map file received from Author and developer tasks. To import a map file:

1 In the Output toolbar, click Map Files.

2 In the Map Files panel, click  at the top right corner and click Import. 

3 In the Import dialog box, select the map file you want to import.

4 Click Open.

RoboHelp places the imported map file in alphabetical order of filenames in the Map Files panel.

Note: 

Map numbers and topics IDs are stored in Map Files. After importing, users can make changes to these Map numbers and 
Map IDs in the Map Editor.
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Export a map file
You can export a map file to share it with Author and developer tasks. To export a map file:

1 In the Output toolbar, click Map Files.

2 In the Map Files panel, right-click a map file and click Export. Or, against the map file, choose  > Export.

3 In the Export dialog box, select a location at which you want to save the map file.

4 Click Save.

RoboHelp exports the map file at the selected location.

Delete a map file
To delete a map file, press Delete. Or do the following:

1 In the Output toolbar, click Map Files.

2 In the Map Files panel, right-click a map file and click Delete. Or, against the map file, choose  > Delete.

3 In the Confirm dialog box, click Yes to confirm the deletion.

The map file is deleted.

Locate a map file on your computer
To see the location of a map file on your computer, do the following:

1 In the Output toolbar, click Map Files.

2 In the Map Files panel, right-click a map file and click Show in Explorer. Or, against the map file, choose  > 
Show in Explorer.

Windows Explorer opens to display the map file and its location.

Manage References
The Topic References report provides a detailed summary of all references in your topic or project. References such as 
Topic, Title, Folder, Outgoing Links, and Incoming Links are included in the report . In addition, you can customize 
the fields and download it for future access.

Open a report
To open the References report, do the following:

1 In an open project, click Reports  on the Author toolbar.

2 In the Reports panel, double-click the Topic References tab to open the report. Alternatively, click Options  next 
to the Topic References tab and choose Open. 

Customize a report
You can customize the Topic References report using the Filters panel on the right side of the screen. In this panel, you 
can view the  report in different formats, filter information, use browse sequence, and various columns. To customize 
your report for Table or Graph view, use the following options in the Filters panel:
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Table view
When you view the report in Table, RoboHelp displays data in rows and columns, as in a spreadsheet. 

TYPE

Link

Under Type, you can view the type of report that is open. For example, Topic References.

Link

VIEW

Link

By default, the Topic References report is shown as Table. Use the options under View to change the appearance of the 
report.

Link

FILTER

Link

Under Filter, use the drop-down list of various project components to include information in your report. You can also 
select multiple options in the drop-down list.

Link

COLUMNS

Link

Following are the types of information that can be included in your report.

• Topic Displays the name of the topic with a link. You can navigate to the target topic by clicking on the link.

• Title Displays the title of the topic.

• Folder Displays the location of the topic.

• Outgoing Links Lists all the occurrences of outgoing links that are referenced from the topic. Outgoing links are 
meant to drive the users to additional sources of information on a specific topic. 

• Incoming Links Lists all the occurrences of  incoming links that are referenced to the topic. Incoming links are links 
from other topics that, when clicked, reach to the current topic. 

Select a column to view it and deselect to remove it from the report. To sort the data in each column, click the column 
header. 

Graph view
When you view records in Graph, RoboHelp displays the data in graphical format. 

TYPE

Link

Under Type, you can view the type of report that is open. For example, Topic References.

Link

VIEW

Link

http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
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By default, the Topic References report is shown as Table. Use the options under View to change the appearance of the 
report to Graph.

Link

FILTER

Link

Browse Sequence Use browse sequences to provide sequence of topics to the users to navigate to the previous or the 
next topic. You can select a particular browse sequence to see the references of the topics in the chosen sequence by 
using left and right arrows at the right side of the screen.

TOPIC

Link

Use the search using the search box to look out for any other topic.

View a report
You can view a report in Table view and Graph view formats. The display type you select determines how the report 
looks and the extent to which the report can be formatted. 

The following examples show the same report run in different view options.

Table view
Select View from the Filters panel, then select Table to display the report in Table view.

The report is displayed in a table format. 

An illustration of how the Reference report looks in Table view

The Topic is displayed at the left, Outgoing Links at the center, and Incoming links at the right side of your screen.

Graph view
Select View from the Filters panel, then select Graph to display the report in Graph view.

The report is displayed in a graphical format. 

An illustration of how the References report looks in Graph view

The Incoming links are displayed in green at the left, Topic in blue at the center, and Outgoing links in orange at the 
right side of your screen.

http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
http://helpx.adobe.com/robohelp/using/
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Fix broken links
A broken reference in the report is indicated with red color alerting you about the broken link. 

To fix, select the link that contains the broken link. The Fix Broken Links dialog box opens that displays the list of 
broken link and its location. You can point the broken link to the correct topic and update the link as appropriate.

Delete references
While deleting any topic you can delete all its references, too by following the below steps:

1 From the Reports panel, right-click a topic and click Delete.

2 The Confirm dialog box opens, showing the list of files where this topic is referred from. Click the checkbox to 
confirm deletion of all the references from the files.  

3 Click Yes to confirm the deletion. The topic, along with its references, is deleted.

Note: 

Choosing NOT to delete the references forces the links to display as Broken Links.
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Chapter 3: Collaborate with authors

Collaborate using Git

Prerequisites for connecting to Git
1 Download and install Git on your system. Click here to download Git for Windows. For more information, see Git 

Help. 

2 Adjust your PATH environment variable so that Git and optional UNIX tools can be used from the Windows 
command prompt. To do so, select this option in the Git installer:

Your PATH environment variable must contain this value:

C:\\Program Files\\Git\\usr\\bin

https://git-scm.com/download/win
https://git-scm.com/book/en/v2/Getting-Started-Installing-Git
https://git-scm.com/book/en/v2/Getting-Started-Installing-Git
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Note: 

Since Windows 10 version 1803, Microsoft has added native SSH support, which is known to cause conflict with Git 
connections. If your Windows version is higher than 1803, ensure that the path to SSH binaries in the Git installation 
(C:\\Program Files\\Git\\usr\\bin) takes precedence over the path to SSH binaries provided by Microsoft 
(%SystemRoot%\\system32). You can access the system PATH environment variable through the System Properties 
dialog box > Advanced tab > Environment Variables.

3 Register your external diff/merge application in RoboHelp. To do so:

a Choose Edit > Preferences. 

b In the Application Settings dialog box, click the Version Control tab. 

c In the External Diff/Merge Application field, click  to select your external diff/merge application such as 
p4merge.

Verify that Git supports your application by running the following command on the command prompt:

git mergetool --tool-help

d Click Done.

Create a Git connection profile
To connect RoboHelp with Git, create a Git connection profile.

1 On your Git server, a repository must exist to which you can connect from RoboHelp. To create a repository, follow 
the instructions on GitHub, Bitbucket, or from your Git hosting provider.

Note: 

If the connection profile is to be used to Add a project to your Git server, the new repository URL must be empty. While 
creating the repository, ensure that you do not initialize it with a readme file.  

2 In RoboHelp, choose Collaborate > New Connection.

3 In the Connection Profiles dialog box, specify a name for your connection profile.

4 From the Version Control drop-down list, select Git.

https://help.github.com/en/articles/creating-a-new-repository
https://confluence.atlassian.com/bitbucket/create-a-git-repository-759857290.html
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5 In the Repository URL field, specify the SSH or HTTPS URL of the remote repository. 

The SSH URL can be specified in one of the following formats:

• git@<servername>:<orgName/repoName>.git 

• ssh://git@<servername>/<orgName/repoName>.git

For example, git@github.com:adobe/brackets.git or ssh://git@github.com/adobe/brackets.git.

The HTTPS URL is specified as: 

https://<servername>/<orgName>/<repoName>.git

For example, https://git@github.com/adobe/brackets.git

6 In the User ID field, specify the name of the user account that has read/write access to the specified Git repository.

Note: 

If you specified an HTTPS server URL, RoboHelp prompts you to enter the password associated with the specified 
username on the first connection to the server and saves it in the Credential Manager for subsequent use. The record is 
stored in this format:

https://<servername>:<orgName/repoName>/<user>

If you changed the credentials recently, delete or update the corresponding record from the Credential Manager to avoid 
authentication error prompts. If RoboHelp does not find a matching record in the system Credential Manager, it 
prompts for the credentials again. For more information about system Credential Manager (Windows), see Microsoft 
Help.

7 In the Branch field, specify the branch name on the server. The default branch name is master.

8 In case you specified an SSH URL in step 5, the SSH private key field is visible. In the SSH Private Key field, specify 
or navigate to the path of the SSH Private Key that you use for connecting to the repository on your Git server. To 
set up a new SSH connection to your Git server, see Set up an SSH connection. 

Note: 

If the specified SSH key contains a passphrase, RoboHelp prompts you to enter this passphrase and saves it in the system 
Credential Manager for subsequent use. The record is stored in this format: 
git@<servername>:<orgName/repoName>/<user> If you are using a new SSH key for connection to the same 
repository but with a different passphrase, delete or update the corresponding record in the system Credential Manager. 
If RoboHelp does not find a matching record in the system Credential Manager, it prompts for the passphrase again. For 
more information about system Credential Manager (Windows), see Microsoft Help.

9 In the Local Path field, specify a path on your computer that maps to the repository on the server.

If the connection profile is to be used to Add a project to your Git server, specify the folder containing the project 
or any of its parent folders. The local Git repository is initialized in this folder and is published to your Git server. 

Otherwise, to use the connection profile to Clone a project from your Git server, provide the path to an empty local 
folder in which the repository is to be cloned. If the specified path does not exist, it is created before cloning.

10 Click Save.

Set up an SSH connection
1 Create an SSH key pair (public and private) using GitBash. For more information, see Git Help. 

2 Add the new SSH public key to your account on your Git server by following the instructions on GitHub, Bitbucket, 
or from your Git hosting provider.

https://support.microsoft.com/en-in/help/4026814/windows-accessing-credential-manager
https://support.microsoft.com/en-in/help/4026814/windows-accessing-credential-manager
https://support.microsoft.com/en-in/help/4026814/windows-accessing-credential-manager
https://www.atlassian.com/git/tutorials/setting-up-a-repository/git-init
https://help.github.com/articles/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent/
https://help.github.com/articles/testing-your-ssh-connection/
https://confluence.atlassian.com/bitbucket/access-keys-294486051.html
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3 Test the connection to your Git server using the SSH key pair by following the instructions on GitHub, Bitbucket, 
or from your Git hosting provider. Connect to the specified Git server via SSH using the following command on the 
terminal:$ ssh -T git@<servername>

Note: 

You may have to specify additional arguments if your Git server is using a port for SSH connections which is different 
from the default (22). For example, add the option -p <portnumber> to specify the alternate SSH port number.

Ensure that SSH connections are not blocked by your firewall. Git connection through RoboHelp is successful only 
if this step succeeds.

 

 

Clone a project from your Git server
1 In RoboHelp, choose Collaborate > Open Connection and select a Git connection profile. The repository is cloned 

at the local path specified in the connection profile.

Note: 

If the specified local path in the connection profile already contains a Git repository, cloning is skipped.

2 In the Open dialog box, select a RoboHelp project file (.rhpj) and click Open.

RoboHelp opens the project file.  

Note: 

When you open a RoboHelp project for the first time using these steps, connection information is stored inside the project 
for subsequent use. So directly open the project using one of the ways described in Open a project. 

Work with files under version control
Add content to or edit a topic. You can quickly begin editing files without any network connection. 

Also, you can do the following:

• Commit your changes

• Pull latest versions from the server

• Push your changes to the server

Commit your changes
1 To commit the changes to your local repository, choose Collaborate > Commit. 

The Commit dialog box opens.

2 In the Commit dialog box, from the list of modified, newly added, and deleted files, select the files you want to 
commit.

3 To be able to commit the changes, specify a commit description. 

4 Click Commit. 

After the commit is successful, RoboHelp displays a success message.

https://help.github.com/en/articles/testing-your-ssh-connection
https://confluence.atlassian.com/bitbucket/troubleshoot-ssh-issues-271943403.html
https://www.atlassian.com/git/tutorials/setting-up-a-repository/git-clone
http://helpx.adobe.com/en/robohelp/using/manage-projects.html#Openaproject
http://helpx.adobe.com/en/robohelp/using/work-with-topics-folders.html#Addcontenttooreditatopic
https://www.atlassian.com/git/tutorials/saving-changes/git-commit
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Push your changes to the server
To push pending commits to your Git server, choose Collaborate > Push. 

If another user updated the repository on your Git server, your push operation fails. In this case, Pull latest versions 
from the serverfrom the repository on the server and then retry the push operation.

Note: 

To perform the push operation, you must have write access to the repository on your Git server.

Pull latest versions from the server
1 To sync your local repository to match the repository on the server, choose Collaborate > Pull.

If some of your local files contain edits that are not yet committed to your local repository and these files are updated 
on the server, the pull operation fails. In this case, Commit your changesfirst. 

2 After successfully pulling changes, files that contain both local and remote commits are merged. If the merge is 
unsuccessful, a merge conflict occurs and it must be resolved. To resolve merge conflicts, choose Collaborate > 
Commit.

In the Commit dialog box, files containing merge conflicts are indicated as  in 
the Action column.

3 Click  against the file to merge conflicts using the external diff/merge application that you have registered in Step 
3 in Prerequisites for connecting to Git. 

The registered diff/merge application opens for the specific file. 

4 Resolve the conflicts and close the diff/merge application.

5 Commit the resolved files by clicking Commit in the Commit dialog box.

Add a project to your Git server
1 To add a project, choose Collaborate > Add Project and select a Git connection profile.

The local path in the profile must contain the current project. For more information, see Step 9 in Create a Git 
connection profile.  

Note: 

This operation fails if the repository specified in the connection profile contains any files. To add your RoboHelp project 
to an existing repository on the server, first Clone a project from your Git serveron your system and then copy or move 
your project into the folder in which the repository is cloned.

The Commit dialog box opens.

2 Commit the required files as described in Commit your changes. 

3 Push the commit as described in Push your changes to the server. 

Remove Git connection
1 To remove the Git connection from the current RoboHelp project, choose Collaborate > Remove Connection.

2 If you want to delete the local repository also, select the Delete any source control information from the local 
folder also field in the Confirm dialog box. 

Note: 

https://www.atlassian.com/git/tutorials/syncing/git-push
https://www.atlassian.com/git/tutorials/syncing/git-pull
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Commit and push all your changes before deleting the repository.

3 Click Ok.

When the connection is removed, RoboHelp reopens the project, and the Add Project option in Collaborate menu 
becomes available. To add the project again, see Add a project to your Git server.

Note: 

If you did not delete the local repository, when you add the project using the same connection profile as before, your local 
changes are preserved and you can commit/push them as required. 

If you deleted the local repository, you cannot push changes to the repository on the server mentioned in the same 
connection profile as it already contains files. So you must add the project using a connection profile that contains an 
empty repository.

Collaborate using SharePoint Online

Prerequisites for connecting to SharePoint Online
If you are working behind an enterprise firewall, whitelist the following URLs:

• https://graph.microsoft.com

• http://www.adobe.com

• https://login.microsoftonline.com/common/oauth2

Create a SharePoint Online connection profile
1 In RoboHelp, choose Collaborate > New Connection.

2 In the Connection Profiles dialog box, specify a name for your connection profile.

3 In the Version Control drop-down list, select SharePoint Online.

4 In SharePoint Site URL, specify the URL of the SharePoint site. For example:

• <tenant>.sharepoint.com

• <tenant-my>.sharepoint.com

• If your SharePoint site is the sub-site of a larger site, your URL could be <tenant>.sharepoint.com/sites/<subsite>

5 Click Login.

RoboHelp launches the Microsoft Sign in window. 

6 Enter your credentials in the Sign in window and accept the permissions requested by RoboHelp.

https://graph.microsoft.com/
http://www.adobe.com/
https://login.microsoftonline.com/common/oauth2
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After you log in, you can view your user name and ID in the Connection Profiles dialog box in RoboHelp. 
RoboHelp searches for the specified SharePoint site URL using the credentials entered in the Microsoft Sign In 
window. The Save button is enabled only if the search is successful and your user account has adequate permissions 
to access the site. If the specified SharePoint site URL is not found, an error message is shown.

7 Click Save to save the profile.

Download a project from SharePoint Online
1 In RoboHelp, choose Collaborate > Open Connection and select a SharePoint Online connection profile.

2 Browse and select a RoboHelp project file, and click Select.

3 In the Repository Details dialog box, specify the Local Path at which you want to download the project, and click 
Open. RoboHelp downloads and opens the project.

Note: 

When you open a RoboHelp project for the first time using these steps, the connection information is stored inside the 
project for subsequent use. Next time you can directly open the project using one of the ways described in Open a 
project. 

Work with files under version control
1 By default, files are downloaded as read-only. To make a file writable, right-click it in the Contents panel and 

click Checkout. RoboHelp indicates the status of a file as  when checked out. 

http://helpx.adobe.com/en/robohelp/using/manage-projects.html#Openaproject
http://helpx.adobe.com/en/robohelp/using/manage-projects.html#Openaproject
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Note: 

If you try to save changes in a read-only file, RoboHelp prompts you to check it out first. Accept the prompt to be able 
to save your changes. 

If you select the Automatically check out file on save field in the Application Settings dialog box > Version 
Control tab, files are automatically checked out when saved. In this case, RoboHelp does not display the check-out 
prompt. To launch the Application Settings dialog box, choose Edit > Preferences.

2 Add content to or edit a topic.

3 To check-in the changes to SharePoint Online, choose Collaborate > Check In. The Check-in dialog box opens.

Note: 

If you want to automatically launch the Check-in dialog box every time you close a project, select the Checkin files 
when project is closed field in the Application Settings dialog box > Version Control tab.  

4 In the Check-in dialog box, from the list of checked out, newly added, and deleted files, select the files you want to 
check in.

5 You can optionally specify a check-in description. 

6 Click Check-in. 

After the check-in is successful, RoboHelp displays a success message. Your version of the file becomes the latest 
version on SharePoint Online. 

7 During every check-in and check-out operation, the file status on SharePoint Online is refreshed automatically. To 
fetch the latest status manually, choose Collaborate > Refresh Status.

Note: 

The refresh operation can take a long time if the drive on your SharePoint site contains many files. To avoid delays, 
regularly remove unused files from your SharePoint site.

8 To sync your local files with the latest version from SharePoint Online, choose Collaborate > Get Latest Version. 

Add a project to SharePoint Online
1 Create a folder on SharePoint Online in which you want to add your current project.

2 In RoboHelp, choose Collaborate > Add Project and select a SharePoint Online connection profile.

3 In the file browser, select the folder created in Step 1. The Check-in dialog box opens.

4 Check in the required files as described in Work with files under version control. 

Refresh your SharePoint login
During any network communication between RoboHelp and SharePoint Online, if your login expires, the 
Microsoft Sign in window is launched. Sign in again and refresh your login session for the network communication to 
succeed. You may not need to enter your credentials every time; selecting your user ID also refreshes the session.

Remove SharePoint Online connection
1 To remove the SharePoint Online project connection from the current RoboHelp project, choose Collaborate > 

Remove Connection.

Note: 

http://helpx.adobe.com/en/robohelp/using/work-with-topics-folders.html#Addcontenttooreditatopic
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Check in all your changes before removing the connection.

2 In the Confirm dialog box, click Ok to remove the connection.

After the connection is removed, RoboHelp reopens the project, and the Add Project option in Collaborate menu 
becomes available. To add the project again, see Add a project to SharePoint Online.

Collaborate using Azure DevOps (Team Foundation 
Server)

Prerequisites for connecting to Azure DevOps
Before creating a Azure DevOps connection profile, do the following:

1 Set up  Azure DevOps Version Control on your machine. For more information, see Microsoft Help.

2 In RoboHelp, choose Edit > Preferences. In the Application Settings dialog box, click Version Control and specify 
the complete path of the tf.exe binary in the Team Foundation Client field. The tf.exe binary is available in the 
Visual Studio or Team Explorer install directory on your computer. An example path: C:/Program Files 
(x86)/Microsoft Visual Studio/2017/Enterprise/Common7/IDE/CommonExtensions/Microsoft/ 
TeamFoundation/Team Explorer/TF.exe

Note: 

RoboHelp supports the tf.exe file version 14.102 and above.

If your system language is other than English, a workaround is needed to support the connection to Azure DevOps. The 
folder that contains tf.exe also contains subfolders for different languages. Remove or rename the subfolder corresponding 
to your system language so that tf.exe defaults to the English version. For example, if your system language is French, 
remove or rename the 'fr' subfolder.

Create a Azure DevOps connection profile
1 Create a project on Azure DevOps Services (or, a Team Project on Azure DevOps Server) to establish a repository 

for source content, where teams can plan, track progress, and collaborate.

Note: 

Ensure that your user account has adequate permissions to access the created project. In case you are connecting to an 
Azure DevOps Server, this account is the same as your system account (through which RoboHelp is being run). For 
information about modifying user permissions, see Microsoft Help.

2 In RoboHelp, choose Collaborate > New Connection.

3 In the Connection Profiles dialog box, specify a name for your connection profile.

4 From the Version Control drop-down list, select Azure DevOps (Team Foundation Server).

5 In the Project Collection URL field, define and manage the service connections of your project:

• For Azure DevOps Server, specify the Project Collection URL as https://dev.azure.com/myorganization

• For Azure DevOps Services, specify your Organization URL as http://myserver:8080/tfs/DefaultCollection

https://docs.microsoft.com/en-us/azure/devops/organizations/projects/create-project
https://docs.microsoft.com/en-us/azure/devops/repos/tfvc/set-up-team-foundation-version-control-your-dev-machine?view=azure-devops
https://docs.microsoft.com/en-us/azure/devops/organizations/projects/create-project
https://docs.microsoft.com/en-us/azure/devops/organizations/security/add-users-team-project?view=azure-devops
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6 In the Project field, specify the name of the Azure DevOps project. Here, you can also specify the path of any folder 
in your project repository. The path is specified in the following format:

$/<project name>/< nested path>

'$/<project name>' is the default repository path.

Note: 

The Project name and casing must match the name and casing of the team project on Azure DevOps. 

7 In the Workspace field, specify a workspace name. This workspace is created at the path specified in the Local Path 
field.

Workspace is your local copy of the project. You can create content locally in RoboHelp and then check it in to Azure 
DevOps. For more information about workspace, see Microsoft Help. 

Note: 

Ensure that your user account has adequate permissions to create a workspace for the project.

RoboHelp works only with local workspaces. For information about using a local workspace and setting the default 
workspace type for your project collection, see Microsoft Help. 

8 In the Local Path field, specify a path on your computer that maps to the project.

If the connection profile is to be used to Add a RoboHelp project to Azure DevOps to Azure DevOps, specify the 
folder containing the project or any of its parent folders. This folder is mapped to the project contents on the server.

Otherwise, to use the connection profile to download project contents, provide the path to an empty local folder in 
which the project is to be downloaded.

9 Click Save.

Download a RoboHelp project from Azure DevOps
1 In RoboHelp, choose Collaborate > Open Connection and select a Azure DevOps connection profile.

Note: 

For first-time connections to the Project Collection URL, RoboHelp prompts for your credentials and saves these in the 
system Credential Manager for subsequent use.

For connections to Azure DevOps Server, the credential is the password for your user account. For connections to Azure 
DevOps Services, the credential is a Personal Access Token with appropriate permissions. For help on Personal Access 
Tokens, see Microsoft Help.

Note: 

If you changed the credentials recently, delete or update the corresponding record from the Credential Manager to avoid 
authentication error prompts. The record is stored in this format: team:<server>|<user> If RoboHelp does not find a 
matching record in the system Credential Manager, it prompts for the credentials again. For more information about 
system Credential Manager (Windows), see Microsoft Help.

The project is cloned at the local path specified in the connection profile.

2 In the Open dialog box, select a RoboHelp project file (.rhpj) and click Open.

RoboHelp opens the project file.  

Note: 

https://docs.microsoft.com/en-us/azure/devops/repos/tfvc/create-work-workspaces
https://docs.microsoft.com/en-us/azure/devops/repos/tfvc/decide-between-using-local-server-workspace?view=azure-devops
https://docs.microsoft.com/en-us/azure/devops/organizations/accounts/use-personal-access-tokens-to-authenticate?view=azure-devops&viewFallbackFrom=vsts&tabs=preview-page
https://support.microsoft.com/en-in/help/4026814/windows-accessing-credential-manager
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When you open a RoboHelp project for the first time using these steps, connection information is stored inside the project 
for subsequent use. So directly open the project using one of the ways described in Open a project. 

Work with files under version control
1 Add content to or edit a topic. You can quickly begin editing files when your network connection is unavailable or 

unreliable. As RoboHelp uses only local workspaces, you need not explicitly check out files before editing.

2 To check-in the changes to the server, choose Collaborate > Check In. 

3 In the Check-in dialog box, from the list of modified, newly added, and deleted files, select the files you want to 
check in.

4 You can optionally specify a check-in description. 

5 Click Check-in. 

After the check-in is successful, RoboHelp displays a success message.

Note: 

If the file you are trying to check in is changed by another user on the server, the check-in fails. You are prompted to 
resolve the conflict between the local and server versions. After all conflicts are resolved, check in the file again.

6 To sync your local files with the latest version from the Azure DevOps, choose Collaborate > Get Latest Version. 

Files in your workspace are updated, except for those containing edits. You can merge the local edited versions with 
the updated versions from the server during check-in.

Lock files
You can lock files in the Contents panel to temporarily prevent changes by other users on the server. This is helpful if 
you want to change a file in your workspace and then check it in without being forced to resolve merge conflicts. Only 
one user at a time can lock a file. 

1 To refresh the lock status of a file, right-click it and select Refresh Lock Status.

RoboHelp indicates the lock status of a file as  when locked by other users and as  when locked by you. 

2 To view the name of the user who locked the file, hover the pointer over . 

3 To lock a file, right-click it in the Contents panel and select Lock. The Lock option is displayed only if the file is not 
already locked by another user. Locking a file allows other users to edit it however, they cannot check in their 
changes to the server before the lock is removed. 

4 To unlock a locked file, right-click it and select Unlock. This allows other users to check-in their changes to the 
server. When you check in a file that is locked by you, it is automatically unlocked.

Add a RoboHelp project to Azure DevOps
1 To add a project, choose Collaborate > Add Project and select a Azure DevOps connection profile.

The local path in the profile must contain the current project. For more information, see Step 8 in Create a Azure 
DevOps connection profile. 

The Check-in dialog box opens. 

2 Check in the required files as described in Work with files under version control. 

http://helpx.adobe.com/en/robohelp/using/manage-projects.html#Openaproject
http://helpx.adobe.com/en/robohelp/using/work-with-topics-folders.html#Addcontenttooreditatopic
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Remove Azure DevOps connection
1 To remove the Azure DevOps connection from the current RoboHelp project, choose Collaborate > Remove 

Connection.

2 If you want to delete the local workspace also, select the Delete any source control information from the local 
folder also field in the Confirm dialog box. 

Note: 

Check-in all your changes before deleting the workspace and unlock locked files that are not being checked in.

Note: 

The delete workspace operation fails if the current user does not have delete permission.

3 Click Ok.

As soon as the connection is removed, RoboHelp reopens the project, and the Add Project option in Collaborate 
menu becomes available. To add the project again, see Add a RoboHelp project to Azure DevOps.
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Chapter 4: Editing and formatting

Format your content
Once you've created topics in Adobe RoboHelp, you are set to add text, images, tables, videos, links, and more. Format 
inline text, characters, paragraphs, and tables, and display them your way. You can also add symbols, HTML elements, 
expanding text, drop-down text, and more. You can format your content using the formatting options in the standard 
toolbar and the General tab in the Properties panel. To quickly preview your changes, click Preview  in the 
Standard toolbar (upper-right corner of the screen).

Apply formatting
To format your content, use the formatting options available in the:

• Standard toolbar

• General tab in Properties panel

Standard toolbar
The standard toolbar contains the following options:

Icon Formatting option Description

Bulleted List Styles Use this option to format content as an 
unordered list. For more information, see 
Work with lists.

Numbered List Styles Use this option to format steps, activities, and 
tasks as an ordered list. For more information, 
see Work with lists.

Multilevel List Styles Use this option to format content as an 
unordered or ordered list of multiple 
levels. For more information, see Work with 
lists.

Insert Table Add tables to organize data and showcase 
content in a simplified format. You can 
organize text and multimedia in a table, 
highlight them using different colors, and do 
more. For more information, see Work with 
tables.

Insert Image Add images in various formats, such as PNG, 
JPEG, WEBP, and SVG, and enrich your 
content. You can add images from your 
project and local files, and web links. For more 
information, see Work with images and 
multimedia.

Insert Multimedia Add videos, including Adobe Captivate 
videos, from your computer, YouTube, and 
Vimeo. For more information, see Add videos.

http://helpx.adobe.com/en/robohelp/using/format-content.html#Workwithlists
http://helpx.adobe.com/en/robohelp/using/format-content.html#Workwithlists
http://helpx.adobe.com/en/robohelp/using/format-content.html#Workwithlists
http://helpx.adobe.com/en/robohelp/using/format-content.html#Workwithlists
http://helpx.adobe.com/en/robohelp/using/format-content.html#Workwithtables
http://helpx.adobe.com/en/robohelp/using/format-content.html#Workwithtables
http://helpx.adobe.com/en/robohelp/using/add-image-multimedia.html#Addvideos
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General tab in Properties panel
Use the General tab in the Properties panel to format content. You can edit font type and style, character spacing, 
indent, color, and more. You can also add borders and customize backgrounds.

To format content:

1 In the Author toolbar, select Contents. The Contents panel opens.

Insert Link You can add hyperlinks to internal content 
(from other topics in your project) and to 
external content (from local files, emails, and 
web pages). For more information, see Create 
and manage links.

Insert Bookmark You can select content and insert it as a 
bookmark by clicking Insert Bookmarks. You 
can use these bookmarks to create intra-topic 
links.

Insert Variables/Snippet/Fields Add variables, snippets, and fields in your 
topic to single-source content and quickly 
update different types of outputs. For more 
information, see Create and use variables for 
easy updatesand Single-source with snippets.

Insert HTML Elements Add HTML elements, such as Horizontal Line, 
iframe, and Text Box to control the 
appearance and layout of content.

Insert Special Character Add various characters to your text. Choose 
from various fractional numbers, shapes, and 
icons. For more information, see Work with 
special characters. 

Create Expanding Text Use this option to add extra text adjacent to 
specific content portions. You can click the 
highlighted content portions in the output 
to show/hide the display of the additional 
text. For more information, see Work with 
expanding text.

Create Drop-down Text Use this option to add drop-down text to 
specific content portions. You can click the 
highlighted content portions in the output 
to show/hide the display of the drop-
down text. For more information, see Work 
with drop-down text.

Insert Mini TOC Placeholder Use this option to insert a Mini TOC 
placeholder in your topic or master page. For 
more information, see Insert and customize a 
Mini TOC.

Insert See Also Placeholder Use this option to insert a See Also 
placeholder in your master page or topic. For 
more information, see Insert the See Also 
placeholder in a master page or a topic.

Insert Related Topics Placeholder Use this option to insert a Related Topics 
placeholder in your master page or topic. For 
more information, see Insert the related 
topics placeholder.
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2 In the Contents panel, double-click a topic to open it. You can view the Properties panel on the right side of the 
screen.

Note: 

If you are unable to view the Properties panel, select View > Properties Panel.

In the Properties panel, the General tab is selected by default. 

3 In your topic, click or select an element to view its type in the Type field. For example, selecting a topic title 
displays h1 (Heading 1) as the type and a paragraph displays p as the type.

For a selected element displayed in the Type field:

• You can edit the formatting, and then apply the same formatting to all elements of the same nature across your 
project, and update the style sheet. To do so, click the Update Style icon next to the Type field.  For example, the 
default font (according to the style sheet) of a topic title is Arial 20 points. You changed the font to Adobe Clean 
24 points. To apply Adobe Clean 24 points font to all topic titles in your project, and update the style sheet, click 
Update Style.

• You can clear the current formatting by selecting the text and clicking  next to the Type field or choosing Edit 
> Clear Formatting. For example, the default font of a topic title (according to the style sheet), was Arial 20 
points. You changed the font to Adobe Clean 24 points but did not update the style sheet. To restore the default 
font to Arial 20 points (according to the style sheet), select the text and click .

4 To format text, click the Font drop-down section. This panel has the following options:

• Font Family Use the drop-down list to select your desired font type.

• Font Style Use the drop-down list to select your desired font style such as italic, oblique, and more.

• Font Size Enter your desired font size or use the increment and decrement buttons to automatically change the 
current size by .5 units. From the units drop-down list, you can choose the unit as pixel, percentage, and more. 

• Color Click  to choose your preferred font color. You can also enter the color code in this field. Black is the 
default text color.

• Text Transform Use the options in the drop-down list to easily capitalize, change upper or lowercases, and more.

• Inline formatting options Select the content and click the icons to apply inline formatting such as strikethrough, 
underline, bold, italics, superscript, and subscript.

• Character Spacing Enter your desired character spacing or use the increment and decrement buttons to 
automatically increment the current spacing by .5 units. From the units drop-down list, you can choose the unit 
as pixel, percentage, and more.

5 To change the alignment of content, click the Alignment drop-down section. This panel has the following options:

• Alignment options Align your content left, center, right, or justify.

• Line Height Use the drop-down list to choose a line height.

• Decrease/Increase Indent Use the respective buttons to change the distance between margin and content.

6 To add and edit borders to your content, click the Border drop-down section. This panel has the following options:

• Border Style Use the drop-down list to select your preferred border style. You can find options such as dotted, 
dashed, double, and more.

• Color Click  to select the preferred border color or specify RGB codes.

• Width Enter the numerical value for the width of your border and choose the unit from the Unit drop-down list.
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Use the following icons to apply the border to specific content edges:

 Applies border to all four edges.

 Applies border only to the top edge.

 Applies border only to the right edge.

 Applies border only to the bottom edge.

 Applies border only to the left edge.

7 To format the layout of your content, click the Layout drop-down section. This panel has the following options:

• Height Specify the height of the content. You can also use the Increment and Decrement buttons to increase and 
decrease the height. Select the unit from the Unit drop-down list.

• Width Specify the width of the content. You can also use the Increment and Decrement buttons to increase and 
decrease the width. Select the unit from the Unit drop-down list.

• Margin 

• Select the unit of the margin from the Unit drop-down list. 

• You can also specify values for the top, bottom, left, and right margins, and use 
the Increment and Decrement buttons to increase and decrease each of the four margin values. 

• To link all four margin values so that updating the value of one margin syncs all margin values, click . 

• To keep four different margin values so that updating the value of one margin does not sync all margin values, 
click .

• Padding 

• Select the unit of the padding from the Unit drop-down list. 

• You can also specify top, bottom, left, and right padding values, and use 
the Increment and Decrement buttons to increase and decrease each of the four padding values. 

• To link all four padding values so that updating the value of one padding syncs all padding values, click . 

• To keep four different padding values so that updating the value of one padding does not sync all padding 
values, click . 

• Float Used for positioning and layout on web pages. Select a float value from the drop-down list:

• inherit Indicates that the element inherits the float value of its parent

• none Indicates that the element does not float (is displayed where it occurs in the text)

• left and right Indicate the direction of the container to which the content floats

• Clear Specifies which elements can float beside the cleared element and on which side. Select a clear value from 
the drop-down list:

• inherit Indicates that the element inherits the clear value of its parent

• both Indicates that no floating elements are allowed on either left or right side

• none Indicates that floating elements are allowed on both the left and right sides

• left and right Indicate that no floating elements are allowed on the left or the right side

8 To format your content background, click the Background drop-down section. This panel has the following 
options:

• Shading Click  to choose your preferred background color. You can also enter the color code in this field. 
Black is the default background color.
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• Image Insert a background image by browsing through your computer.

• Width Specify the width of the background image.

• Maintain aspect ratio icon Click to maintain the aspect ratio of the background image. If you change one 
component (width/height) of the image, the other component (height/width) is automatically changed according 
to aspect ratio.

• Height Specify the height of the background image.

• Reset to default icon Click to reset to the original height and width of the background image.

9 To copy the formatting of selected content, choose Edit > Copy Formatting. Then, select the content to which you 
want to apply the copied formatting.

10 To remove the formatting of selected content, choose Edit > Clear Formatting. The selected content displays the 
default formatting.

11 To save the changes, click the Save All icon  in the standard toolbar.

Work with lists
You can create bulleted or numbered lists to present your content in a neat and easy-to-read manner. You can then 
adjust the indent, add color, add a paragraph within a list, and more. You can even match the bullet color to its text color.

To create a list:

1 Select the desired text and do one of the following:

• To create a bulleted list, click Bulleted List Styles  in the standard toolbar and choose a style from the drop-
down list. 

• To create a numbered list, click Numbered List Styles  in the standard toolbar and choose a style from the 
drop-down list.

• To create a numbered or bulleted list containing multiple levels, do the following:

1 Click Multilevel List Styles  in the standard toolbar and choose a style from the drop-down list.

2 To create a sublevel list, select the text and press Tab. Or, from the Properties panel > General tab 
> Alignment drop-down section, click the Increase Indent icon.

3 To remove list formatting, click , , or  in the standard toolbar, and select the None style.

Work with tables
In RoboHelp, you can insert tables to organize and present content in a structured manner. You can also edit colors, 
indent, customize borders, and more for tables.

To insert a table:

1 In an open topic, place the cursor at the desired location and click Insert Table  in the standard toolbar.

2 To select the required number of rows and columns, drag your cursor over the drop-down table grid. The selected 
rows and columns are highlighted in blue. Click to insert the selected rows and columns in your topic.

Right-click options for table
Right-clicking inside a table cell will display a pop-up menu with the actions you can perform:

Convert to header
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Each cell in a header row works as the heading of its column. Similarly, you can also use the header column to label the 
corresponding rows. To convert an existing row or column into the header, do the following:

• Select a row or column that you want to use as header row or column.

• Right-click and choose Convert to Header.

Remove header

• Select the header cells of a row or column.

• Right-click and choose Remove Header.

Add or delete rows and columns

You can easily insert and delete additional rows and columns into an existing table. Click where you want to add or 
remove a row or column in your table and then right-click.

• To add rows, click Row Before or Row After and to add columns, click Column Before or Column After.

• To add cells, click Cell Before or Cell After.

• Click Delete, and then click the option your need on the menu.

Merge cells

To create more complex tables, with merged cells, use the Merge command from the Table menu.

• To merge cells, place the cursor in a cell and select multiple cells by holding arrow key along with shift key. 
Alternatively, select the cells using mouse. It will highlight the cells to merge.

• Right-click and choose Merge > Cells.

Split cells

You can split one cell in a table into two or more smaller cells horizontally or vertically. To split cells in a table:

• Place the cursor in the cell you want to split.

• Right-click and choose Split > Cells Horizontally or Cells Vertically, depending on how you want to split the cell.

AutoFit to resize a table or column

To automatically adjust your table or columns to fit the size of the content, use the AutoFit command from the Table 
menu.

• Select AutoFit to Contents to resize the cells to fit their content.

• Click AutoFit Window to stretch the table across the page to fit the topic. 

• Click Fixed Column Width to set the width of the columns manually.

Select tables cells, rows, and columns

There are times you may want to select a single cell, an entire row or column, or an entire table.

Select row To select a row in a table, right-click and from the context menu, choose Select > Row.

Select column To select a column in a table, right-click and from the context menu, choose Select > Column.

Select cell To select an individual cell, right-click and from the context menu, choose Select > Cell.

Select table To select an entire table, right-click and from the context menu, choose Select > Table.
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General tab in the Properties panel
You can resize tables to specify, increase, or decrease the width and height of the table, or row height and change the 
width of the columns.

1 Right-click the table and choose Select > Table to open the formatting properties of the table. You can view the 
Properties panel on the right side of the screen.

In the Properties panel, the General tab is selected by default. 

2 The following options are available to format the table:

Table width The width attribute specifies the width of a table. To resize the width of the entire table, specify the 
Table Width in any unit of measurement of the entire table.

Column width To change the width to a specific measurement, select the Column number that you want to resize. 
On the table settings in the Properties panel, click in the Column Width box, and then specify the width in any unit 
of measurement you want.

Row height To set the row height to a specific measurement, select the Row number that you want to resize. On 
the table settings in the Properties panel, click the Row Height box, and then specify the height in any unit of 
measurement you want.

Table caption Table Caption can be used to provide a title to a table. It is optional to use the table caption, and it can 
be added above or bottom of the table. Use the following icons to select the positioning of the caption:

Displays the caption above the table.

Displays the caption below the table.

 Removes the caption from the table.

Work with special characters
You can insert special characters into your content by using the Insert Special Character Dialog. The Insert Special 
Character Dialog allows you to search for and insert special characters from a large set of characters, organized in 
various categories.

1 In an open topic, place the cursor at the desired location and click Insert Special Character  in the standard 
toolbar. Alternatively, you can use CTRL+4 to insert special characters.

2 Select a category from the following options in the dropdown list:

• Arrows

• Currency Symbols

• Extended ASCII

• Miscellaneous

• Number Forms

• Punctuation

• Special Characters

3 Hover your mouse on the character to see its full readable name. Choose the character you want to insert or search 
for a specific character by typing name in the Find Box, and double-click on it. The symbol will be added at the 
cursor's point. Alternatively, click Insert.

4 Click Close to close the Insert Special Character dialog.
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Work with expanding text
In a content-heavy topic, you can use expanding text to add extra text adjacent to specific content portions. You can 
click the highlighted content portions in the output to show/hide the display of the additional text.

1 In an open topic, select the text you want to expand, and then click Create Expanding Text  in the standard 
toolbar.

The selected text becomes the title of the expanding text. A placeholder for the content appears.

2 In the placeholder, specify the content of the expanding text.

3 Manage expanding texts in the following ways:

• Toggle the display of the boundary of all expanding text placeholders in your topic: Choose View > Show > 
Expanding/Drop-down Text Boundary.

• Toggle the display of a specific expanding text placeholder: Right-click the text header and click Show 
Expanding Text or Hide Expanding Text. 

• Remove an expanding text: Right-click the text header and click Remove Expanding Text. 

• Collapse or expand an expanding text: Double-click the text header.

• Collapse or expand all expanding texts in your topic: Right-click any expanding text header and click Collapse 
All Text or Expand All Text.

• Set separate text for the title of an expanding text in collapsed state: Click the expanding text. In the Properties 
panel > General tab > Text when collapsed field, type the new title. As expanding texts are collapsed by default, 
in your output, the new title is displayed in the collapsed state. On expanding the text, the original text on which 
the expanding text was created is displayed.

• Add or edit twisty images.

4 Click the Save All icon  at the left side of the standard toolbar.

Work with drop-down text
In a content-heavy topic, you can add drop-down text to specific content portions. You can click the highlighted 
content portions in the output to show/hide the display of the drop-down text.

1 In an open topic, select the text you want to drop down, and then click Create Drop-down Text  in the standard 
toolbar.

The selected text becomes the title of the drop-down text. A placeholder for the content appears below the selected 
text.

2 In the placeholder, specify the content of the drop-down text.

3 Manage drop-down texts in the following ways:

• Toggle the display of the boundary of all drop-down text placeholders in your topic: Choose View > Show > 
Expanding/Drop-down Text Boundary.

• Toggle the display of a specific drop-down text placeholder: Right-click the text header and click Show Drop-
down Text or Hide Drop-down Text. 

• Remove a drop-down text: Right-click the text header and click Remove Drop-down Text. 

• Collapse or expand an drop-down text: Double-click the text header.

• Collapse or expand all drop-down texts in your topic: Right-click any drop-down text header and click Collapse 
All Text or Expand All Text.
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• Set separate text for the title of a drop-down text in collapsed state: Click the drop-down text. In 
the Properties panel > General tab > Text when collapsed field, type the new title. As drop-down texts are 
collapsed by default, in your output, the new title is displayed in the collapsed state. On expanding the text, the 
original text on which the drop-down text was created is displayed.

• Add or edit twisty images.

4 Click the Save All icon  at the left side of the standard toolbar.

Add or edit twisty images
You can add twisty images–an image each for expanded and collapsed states–to expanding and drop-down texts, 
and topic TOCs. In preview and in your output, the respective images appear in expanded and collapsed states.

To add twisty images:

1 In an open topic, click an expanding or drop-down text, or the word Caption in a topic TOC.

2 In the Properties panel > Styles tab, select Hyperlink Styles from the drop-down list.

3 From the list of hyperlink styles displayed, click a style to apply it to the selected item. If the applied style has the 
twisty feature set, the twisty images are displayed in the preview and output.

4 Do one of the following:

• Click  against the applied style to edit it. In the Styles panel of the style sheet editor, in Hyperlink Styles, the 
applied style opens for editing.

• From the Contents panel, expand assets > css. From the list of style sheets displayed, double-click one or 
click  against it. Then, expand the Hyperlink Styles and click the applied style.

5 In the Properties panel of the style sheet editor, expand Twisties.

6 Against the Image when expanded and Image when collapsed fields, click  to select and insert the required 
images.

7 Click  to place images at the start of text (default) or  to place images at the end of text. 

8 Click the Save All icon  at the left side of the standard toolbar.

Note: 

After you set twisty images for a particular hyperlink style, you can apply the same twisty images to different items by 
just applying the same hyperlink style from the Styles panel. 

Use the Color Picker dialog box
The Color Picker dialog provides multiple ways of choosing a color as per the following: 

• The Color Picker displays a grid of predefined color swatches. You can see the names by hovering your mouse over 
any of the swatches. The list of these swatches can be modified in the Colors.

• You can either pick from a set of predefined colors (swatches) or create your own using an RGB value.

• The Color Picker displays the color along with the associated hexadecimal (HEX) color value. You can also type a 
hexadecimal number  (e.g., #0000FF) directly in the given blank space.

• You can set the opacity of color with an alpha channel. The alpha parameter is a number between 0 (fully 
transparent) and 100 (fully opaque).
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• You can also pick the color from anywhere on your screen. Click on the eye-dropper icon  and hover over pixels 
on your screen to choose a specific color. When you click, the selected color is automatically updated into the color 
picker dialog. You can click 'Mouse Right-click' or 'Escape' key to close the screen color dropper if you don't want to 
pick a color. The color dropper also works on a multi-monitor setup in case you want to choose color across multiple 
monitors.

• The first swatch visible in the list of predefined swatches represent None  (no fill). To remove any selected color, 
you can click on "None."

The color picker dialog box
A Screen Color Picker  B Hexadecimal (HEX) color value  C RGB values  D Alpha component  E Predefined swatches  F No fill  

Create and manage cross-references
Cross-references are references to information located in a topic or across multiple topics. They appear as links that 
take the reader to the referenced items. If you are writing a reference topic, you may want to include references from 
one topic to another that are automatically updated and display the correct references in the generated output.  You can 
specify whether cross-references are derived from a bookmark, description, figure, heading, paragraph, table, or from 
a title you’ve created. You can also determine the cross-references format, such as Page number, Chapter number, and 
more.

Cross-references can dynamically change based on the output types. For an online output, cross-references look like 
normal hyperlinks, while for print-based outputs, the cross-references can be used to convert online links to page 
number references. For example, "See on Page 15."

Insert a cross-reference
To insert a cross-reference, follow these steps:

1 Open any topic . Place the cursor at the appropriate location where you want to insert a reference.

2 In the standard toolbar, click the Insert Link icon   and select cross-reference  or alternatively, press 
CTRL+R. The Cross-reference dialog box opens.

3 You can select the settings that you want to insert from the following options:

• Select topic By default, the topic selection dialog opens. Navigate to the topic in your project that you want to 
link. To select a topic, click  .  

• Type From the Type drop-down field, select the type of reference you want to create. 

http://helpx.adobe.com/robohelp/using//content/dam/adobe-connect/None.png
http://helpx.adobe.com/robohelp/using//content/dam/adobe-connect/None.png
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• Format Based on the option you choose in the Type field, the Format section gives you a list of options.  The 
below table details each of the choice controls that are available for both Type & Format.

• Targets are filtered HTML snippets to which the content is referred to. It can be a heading, table, page number, 
or footnote according to the selected type.  

• Preview A visual preview of the content appears in the Preview tab.

Type and Format 
options

Type Format

Bookmark A 
bookmark is an 
incremental link 
within a topic. 
This helps to 
create links 
which, when 
clicked, take the 
reader to a 
bookmarked 
section of the 
topic.

• Bookmark 
text Creates a 
cross-
reference to 
the 
bookmarked 
text.     For 
example, stop
_words. 

• Page 
number Adds 
a cross-
reference to 
the page on 
which the 
bookmark 
appears.    For 
example, See 
on page 1.

• Chapter 
number Adds 
a cross-
reference to 
the chapter 
numbers.    For 
example, See 
on chapter 1.

• Bookmark 
text with 
page 
number Adds 
the name of 
the bookmark 
along with the 
page number.   
 For 
example, See 
"stop_words" 
on page 1

Description The 
Description 
shows the topic 
description as 
entered in the 
topic properties. 

• Description 
Text Adds a 
cross-
reference to 
the text of the 
description.
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Figure The HTM
L <figure> 
element contain
s an image, that is 
referenced in the 
topic and is 
specified using 
the <figcaption
> element.

• Caption 
Text Functions 
like a heading 
of an image. 
Creates a 
cross-
reference to 
image in your 
topic and 
shows the text 
of the caption 
for the image.   
     For 
example, 
Airflow. 

• Page 
Number Adds 
a cross-
reference to 
the page on 
which the 
figure appears. 
       For 
example,  See 
on page 1.

• Chapter 
Number Adds 
a cross-
reference to 
the chapter 
numbers.       
 For 
example, See 
on chapter 1.

• Caption text 
with page 
number Adds 
the figure 
caption along 
with the page 
number.       For 
example, See 
"Airflow" on 
page 1
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Heading The HT
ML <h1> to 
<h6> elements r
epresents six 
levels of 
headings. The 
heading 
elements are H1, 
H2, H3, H4, H5, 
and H6.

• Heading 
Text Creates a 
cross-
reference to 
the heading of 
the topic.       
For example, 
Project 
Reviews. 

• Page 
Number Adds 
a cross-
reference to 
the page on 
which the 
heading 
appears.       For 
example, See 
on page 1.

• Chapter 
Number  Adds 
a cross-
reference to 
the chapter on 
which the 
heading 
appears.       
 For 
example, See 
on chapter 1.

• Heading text 
with page 
number Adds 
the heading 
text along with 
the page 
number.       
 For 
example, See 
"Project 
Reviews" on 
page 1
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Paragraph The 
HTML <p> elem
ent represents a 
paragraph. 

• Paragraph 
Text Creates a 
cross-
reference to 
any paragraph 
in the topic 
you define.     
 For example, 
The output will 
be generated 
to the         path 
defined in the 
preset. 

• Page 
Number Adds 
a cross-
reference to 
the page 
numbers.            
                   For 
example, See 
on page 1.

• Chapter 
Number Adds 
a cross-
reference to 
the chapter 
numbers.     
  For 
example, See 
on chapter 1.

• Heading text 
with page 
number Adds 
the heading 
text along with 
the page 
number.        
For 
example, See 
"The output 
will be 
generated to 
the path 
defined in the 
preset." on 
page 1.
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Table Creates a 
cross-reference 
to the table and 
is represented by 
caption. You can 
define the 
caption in the 
Author view.

• Caption 
Text Functions 
like a heading 
for a table. 
Creates cross-
reference to 
tables in your 
topic and 
shows the text 
of the caption 
for the table.     
 For 
example, Conc
erts. 

• Page 
Number Adds 
a cross-
reference to 
the page on 
which the 
table appears. 

•       For 
example, See 
on page 1.

• Chapter 
Number Adds 
a cross-
reference to 
the chapter 
numbers.       
For 
example, See 
on chapter 1. 

• Caption text 
with page 
number Adds 
the table 
heading with 
the page 
number.       For 
example, See 
"Concerts" on 
page 1
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4 Click Insert.

The cross-reference is added to the topic.

Note: 

The Screen Tip and Display In options are also available for cross-references.

Updating Cross-References
Every cross-reference is dynamically linked to its target. This means that if anything is updated in the target, the cross-
references are automatically updated. 

For example, if a reference points to a heading on page 5 (i.e. See "Project Reviews" on page 5), and if the heading page 
number changes due to some text being added or deleted, the cross-reference number will update automatically (i.e., 
See "Project Reviews" on page 8).

This automatic and dynamic management of references enables you to add a reference once without worrying about 
having to update it whenever something changes in the topic.

Create and manage links
Links facilitate quick navigation from one content element to another with a simple click. While authoring in 
RoboHelp, you can add links to text or images and direct them to a project file, a file on your computer, webpage, or an 
email.

Title  The title of 
the selected 
topic comes from 
the topic 
properties. You 
can edit the topic 
title from the 
topic properties.

• Title 
Text Creates a 
cross-
reference to 
the title of the 
topic.       For 
example, 
Useful Links. 

• Page 
Number Adds 
a cross-
reference to 
the page on 
which the title 
appears.       For 
example, See 
on page 1.

• Title text with 
page 
number Adds 
the title with 
the page 
number.       For 
example, See 
"Useful Links" 
on page 1
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Types of links
The following types of links are available in RoboHelp to help build navigation in your output:

• Hypertext link Highlights the link in your text and opens the destination when you click it.

• Image map links A link on the section of an image that leads you to the destination or opens a pop-up when you 
click the image.

• Bookmarks A link that takes you to a specific location in a topic. For more information, see Create and Edit 
Bookmarks.

• Browse sequence The series of topics viewed in your output. For more information, see Create and manage browse 
sequences.

• Searches The topics that contain search keywords appear as links in the search results.

Insert a link
To insert a link, follow these steps:

1 Place the cursor at the appropriate location or select the required text.

2 In the standard toolbar, click the Insert Link icon  or alternatively, press CTRL+K. The Link To dialog box 
opens.

3 If you select text while inserting a link, the Display Text field displays the selected text. 

When you insert a link on an image or an image map, the Link To dialog box displays the Alternate Text field 
instead of the Display Text field. Alternate Text provides alternative information for an image if the image cannot 
be displayed, or the user, for some reason, cannot view it (because of an error in the SRC attribute).

You can select the type of link that you want to insert from the following options:

• Project Files (default selection) Links to a topic in the project. Use the Search field or browse through the 
Contents or the Recently Used drop-down section to select the topic of your choice. You can verify the topic 
selection through the preview pane. 

• Local Files Select this option to link to a file on your computer. Click  to browse and select any file from the 
local file system, and that file will be copied to a specific folder inside the project.

• Webpage Select this option to link to a webpage. In the Enter or paste URL field, specify the URL of the webpage 
that you want to link to.

• Email Select this option to link to an email that the user can send. You can specify the email address in “To” and 
“Cc” Address fields, indicating the intended recipients of the message.  Optionally, you can enter the subject and 
body of the mail in Subject and Body, respectively. In the output, when a user clicks this link, the draft email 
opens in the default mail client. The user can further edit the mail before sending it.

4 Select appropriate options to display the link in the Display In section. For more information, see Display settings 
for links.

5 Click Link.

You can preview the inserted link when you click Preview  in the standard toolbar.

Note: 

Alternatively, you can do the following to link to a project file:
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Select the text in an open topic to which you want to insert the link. From the Contents panel of the authoring window, 
drag-and-drop a topic of your choice on the selected text. The destination topic is then inserted as a link. In the Preview 
mode or output, click the link to view.

Add Screen Tips
To add a Screen Tip, select the relevant text, and press CTRL+K. Alternatively, click on the "Link to"   icon on top 
of the editor. In the dialog box that opens, enter the text in the "Screen Tip" edit box. Click Link.

When you hover your mouse over the link, the Screen Tip  appears in the browsers as a small rectangular box that 
contains the text, however also known as Tooltips.

Note: 

You can create Screen Tips only in hyperlinks.

Display settings for links
While selecting a project or a local file, use the Display In section to customize the display of the linked topic in a frame 
or a pop-up window and its dimensions. The section has the following options:

• Frame (default): Displays the linked topic in a frame. Select the type of frame from the drop-down list below 
the Frame field: 

• Page Default (none) (default) Opens the topic in the same frame as the Help file window. 

• New Window Opens the topic in a new browser window. 

• Same Frame Opens the topic in the same frame as the current topic. 

• Parent Frame Opens the topic in the link parent frame and hides the current topic. 

• Whole Page Opens the topic in the Help file window, replacing the original topic or frameset.

• Auto-sized popup: Select this option to display the linked topic in a pop-up window instead of a viewer or a 
browser. The window size adjusts to the content. If you have a long topic, use a custom-sized pop-up.

• Custom-sized popup: Select this option to display the linked topic in a pop-up window and specify the width and 
height of the window. The default width is 400 pixels (px) and height is 300 px. If the text goes beyond the pop-up's 
height or width, the pop-up window includes scroll bars. This option is available only for linking to topics.

Open, Edit and Remove hyperlinks
Once you have inserted a hyperlink, you can right-click the hyperlink to open, edit or remove it. You can also open a 
hyperlink by pressing the CTRL key and clicking the hyperlink. 
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Fix broken links
To fix a broken link, you can replace it, that is, point it to another file in the project. If the broken link points to a topic 
file, you can replace it or create a new topic. If you create a new topic, RoboHelp automatically points the broken link 
to the new topic. You can fix a broken link in two ways–through the Fix Broken Links dialog box or the Broken Links 
report.

To fix a broken link:

1 Do one of the following to launch the Fix Broken Links dialog box:

• Choose Edit > Fix Broken Links. 

• Generate the Broken Links report. In the Broken Links report, click  from the standard toolbar at the top. 

The Fix Broken Links dialog box opens.

2 In the Broken Links section, click the broken link that you want to fix.

The Used In section displays the corresponding topic in which the broken link exists. 

You can now do one of the following:

• Point the broken link to an existing file in the project (refer Step 3).

• For a broken link pointing to a topic, you can create a new topic and point the link to the new topic (refer Step 4).

3 To point the link to another file in the project:

a Click Replace. 

Note: 

In the Broken Links report, you can directly replace a specific broken link through the Replace Link dialog box. To 
launch the dialog box:

1 In the Filters panel > Order By section, select Broken Link. RoboHelp orders information in the report by 
broken links.

2 In the Broken Link column, right-click a link and click Replace Link. 

The Replace Link dialog box opens. 

In the Replace Link dialog box, RoboHelp automatically opens appropriate folders depending on the type of 
referenced item to which the broken link points. For example, if a broken link points to an image, RoboHelp 
automatically opens the assets/images folder. 

http://helpx.adobe.com/en/robohelp/using/generate-reports.html#Openareport
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a Locate an alternate topic/image to which you want to point the link. To do so, use the Search field or browse 
through the Contents or the Recently Used drop-down section. 

b Select the topic/image and click Link. RoboHelp fixes the broken link and removes it from the Fix Broken Links 
dialog box and the Broken Links report.

3 To fix a broken link that points to a topic by creating a new topic:

a Click Create New.

Note: 

The Create New button is enabled only for broken links pointing to topics.

The New Topic dialog box opens.

b In the New Topic dialog box, specify the properties for the topic in different sections as required.

The New Topic dialog box has the same sections as the Topic Properties dialog box, except for the File Info 
section, which is specific to topic properties. For more information, see Topic properties.

c Click Create.

The topic is created inside the selected folder or a subfolder in the Contents panel. RoboHelp automatically 
points the broken link to the new topic.

4 Click  to save the changes.

Single-source with snippets
A snippet can be a para­graph of text, a piece of code, an object such as an image, or an entire topic itself. You can single-
source a snippet and reuse it across multiple topics in a project or master pages. A snippet can also contain variables 
and conditional text tags. When you change the contents of a snippet, it is updated across all the topics and master pages 
that contain it.

Create a snippet
Open a project in RoboHelp and follow these steps to create a snippet:

1 In the Author toolbar, select Contents and open a desired topic from the Contents panel.

2 In the Author toolbar, select Snippets. The Snippets panel opens.

3 In the Snippets panel, click .

4 In the New Snippet dialog box, specify the name and description of the snippet in Name and Description, 
respectively.

5 Click Create. The snippet is created and can be accessed from the Snippets panel.

http://helpx.adobe.com/en/robohelp/using/topic-properties.html#Topic_properties
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Insert a snippet
To insert or use a snippet in an open topic or master page:

1 To open a topic:

In the Author toolbar, select Contents and open a topic of your choice from the Contents panel.

To open a master page:

In the Author toolbar, select Master Pages and open a master page of your choice from the Master Pages panel.

2 In the Author toolbar, select Snippets. In the Snippets panel, choose a snippet.

3 Now drag-and-drop the selected snippet at the preferred location in the open topic or master page.

Alternatively, press Ctrl+2. In the Snippet dialog box, you can filter snippets by typing the first few alphabets. Press 
the upward and downward arrow keys to navigate through the list of snippets. Press Enter to insert a snippet. 

4 Click the Save All icon  at the left side of the standard toolbar.

Delete a snippet
To delete a snippet from a project, follow these steps:

1 In the Author toolbar, select Snippets. The Snippets panel opens.

2 Select the snippet that you want to delete and click Options  next to the snippet.

3 In the Options list, select Delete.

4 In the Confirm dialog box, click Yes.

Generate Snippets report
You can generate a Snippets report to view the details of snippets in your project. You can also customize, download, 
or print your report.

1 In the Author toolbar, select Reports. The Reports panel opens.

2 In the Reports panel that appears, select Snippets.

3 You can customize a report using the Filters panel on the right side of the screen. To know more, see Customize a 
report.

4 Click the Download icon  in the standard toolbar to instantly download the report.

5 Click the Print icon  in the standard toolbar to print your report.

Work with images and multimedia
Use RoboHelp's powerful workspace to easily add images and multimedia to your topics. Insert images in various 
formats, videos from your computer, YouTube, and Vimeo, and audio clips. With the latest RoboHelp interface, you can 
insert and preview YouTube videos in a click. You can also add image thumbnails that can be zoomed when clicked in 
the output. Publish rich and creative content with images and multimedia while you experience the smoothest 
workflows of authoring, publishing, and viewing your project output.

Note: 

If an image or video is available in the Contents panel, you can drag-and-drop it to the desired location in your open topic.
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Add images
To add an image:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 Double-click a topic in the Contents panel to open it. Place the cursor at the location in which you want to insert 
an image.

3 In the standard toolbar at the top of the screen, click the Insert Image icon  to add an image.

4 In the Insert Image dialog box, select an image using one of the following options:

• Project Files Browse through the project files in the Contents or the Recently Used drop-down section.

• Local Files Browse through your computer or specify the path of the image file.

• Web Link Specify the URL of the image.

You can preview the selected image in the preview area of all three insert image options.

5 (Optional) You can also add Figure Caption to provide a title to your image.

6 Click Insert. The selected image is added in the topic.

Edit image properties
To edit the properties of an image:

1 In an open topic, click the desired image.

2 On the right side of the screen, in the Properties panel > General tab, the Type field shows Img. Other fields in the 
panel display the properties of the image.

3 Use the following fields to modify the properties of the image:

• Source Displays the path of the folder from which the image was uploaded.

• Alternate Text Specify an alternate text for the image. Terms used in this field improve the searchability of the 
image.

• Image Title Specify a title for the image, which is displayed when you hover over the image.

• Width Specify the width of the image.

• Maintain aspect ratio icon By default, RoboHelp maintains the aspect ratio of an image. If you change one 
component (width/height) of the image, the other component (height/width) is automatically changed according 
to aspect ratio. To disable maintain aspect ratio, click the icon. 

• Height Specify the height of the image. 

• Reset to default icon Click to reset to the original height and width of the image.

• Figure caption Specify the caption to provide a title to an image. Figure caption is optional to use and can be 
added at the top or bottom of the image. Use the following icons to select the positioning of the figure 
caption: Displays the caption above the image. Displays the caption below the image.  Removes the 
caption from the image.

• Text wrapping Click the Left or Right icons to choose the direction of alignment of the image with respect to 
text. The default is None.

• Use Thumbnail Select to use the image as a thumbnail in the output and specify its width and height.

For information about the drop-down sections in the General tab, see General tab in Properties panel.
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Create an image link
You can link an image to internal content, such as a topic in your project, and to external content such as websites and 
documents. For information about inserting a link, see Insert a link.

Work with image maps
An image with clickable areas that link to topics or web pages is called an image map. To create an image map, add a 
clickable area by drawing a shape (rectangle, circle, or polygon) over an image. To each area, add a link.

Image maps are not supported in PDF output.

To work with an image map, do the following:

1 In a topic, click the image on which you want to create an image map.

RoboHelp displays the Insert/Edit Image Map icon  in the standard toolbar. Click .

Alternatively, right-click the image and click Insert Image Map.

The Image Map dialog box appears displaying the selected image.

2 In the Image Map dialog box, click the icon corresponding to your preferred shape—  for rectangle,  for circle, 
or  for polygon. 

3 Add a clickable area by drawing the shape on the image. RoboHelp displays the number and points (small white 
squares) for each area.

4 To further define the area, resize the shape by dragging-and-dropping a point or move the shape as required.

5 To insert a link against the area, click . The Link To dialog box opens with the Project Files option selected by 
default.

6 In the Link To dialog box, select the topic or specify the web page address to which you want to link the area. For 
information about the dialog box, see Step 3 in Insert a link.

In the Image Map dialog box, you can draw multiple areas by inserting multiple shapes. To verify the linked topic 
or web page, hover the cursor over an area. The shape is highlighted, and a tooltip displays the path.

7 If areas overlap, click a shape and then click one of the following icons to arrange its layering:

• To bring to the front of all shapes, click .

• To bring forward by one shape, click .

• To send backward by one shape, click .

• To send to the back of all shapes, click .

8 To delete an area, select the shape and click .

9 Click Done.

10 To modify an image map, right-click the image and click Edit Image Map or click  in the standard toolbar.

11 To remove an image map, right-click the image and click Remove Image Map.

12 To view the list of areas in the image map, click the image. In the Properties panel > General tab > Image Map drop-
down section, the areas are listed. For each area, you can do the following:

• Modify the linked topic or webpage by clicking  against the area.

• Delete the area by clicking  against the area.

http://helpx.adobe.com/en/robohelp/using/create-manage-links.html#Insertalink
http://helpx.adobe.com/en/robohelp/using/create-manage-links.html#Insertalink
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Add videos
You can add videos in a topic in the following ways:

• From your computer, YouTube, or Vimeo

• Import and insert an Adobe Captivate video

From your computer, YouTube, or Vimeo
1 In the Author toolbar, select Contents. The Contents panel opens.

2 Double-click a topic in the Contents panel to open it. Place the cursor at the location in which you want to insert a 
video.

3 In the standard toolbar, select the Insert Multimedia icon  and one of the following options from the drop-
down list:

• Video File To select a video from your computer.

• YouTube To select a YouTube video.

• Vimeo To select a Vimeo video.

4 In the Insert Multimedia dialog box, select a video using one of the following options:

• Project Files Browse through the project files in the Contents or the Recently Used drop-down section. Or, 
quickly search for a video by filename. RoboHelp searches for the specified filename in the Contents panel.

• Local Files Browse through your computer or specify the path of the video.

• Web Link Specify the URL of the video.

You can preview the selected video in the preview area of all three insert video options.

5 Click Insert. The selected video is added in the topic.

Import and insert an Adobe Captivate video
Note: 

To be able to insert an Adobe Captivate video in your topic content, you must first import it in your project.

1 In the Author toolbar, select Contents. The Contents panel opens.

2 In the Contents panel, do one of the following to import a video in your project:

• Select the desired folder and choose File > Import > Adobe Captivate Demo.

• Right-click a folder or click  against it, and choose Import > Adobe Captivate Demo. 

3 In the Open dialog box, select the video you want to import. 

Adobe Captivate stores video output as a collection of files and folders. To automatically import all the associated 
files as a zipped file, select index.html or index.htm from the output folder. Or, you can select the .zip or .cpz file of 
the entire output folder. 

Click Open.

RoboHelp places the zipped video in .cpz format in alphabetical order of filenames in the folder.

Note: 

If you don't select a folder while importing, the video is placed at the root level in the Contents panel. 

4 To insert the imported video in your content, double-click a topic in the Contents panel. In the open topic, place 
the cursor at the location in which you want to insert the video.
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5 In the standard toolbar, select the Insert Multimedia icon  and then select Adobe Captivate Demo from the 
drop-down list. 

6 In the standard toolbar, select the Insert Multimedia icon  and then select Adobe Captivate Demo from the 
drop-down list. In the Adobe Captivate Demo dialog box, from the Contents drop-down section, select the 
imported video. 

Note: 

If you insert an imported video once, it is listed under the Recently Used drop-down section in the Adobe Captivate 
Demo dialog box. You can quickly select videos from here as well. 

7 Before inserting the selected video, you can preview it in the Adobe Captivate Demo dialog box. Click Insert.

The video is inserted at the location of the cursor in the topic.

Note: 

In the standard toolbar, click  at the right corner of the toolbar to quickly play the entire video in Preview and 
check it before you publish your project.

Delete an image or video
To delete an image or video from a topic:

1 In the Author toolbar, select Contents. The Contents panel opens.

2 In the Contents panel, open the topic that contains the image or video you want to delete.

3 Select the desired image or video, and then press Delete.

Supported image file formats
RoboHelp supports the following image file formats:

• BMP

• GIF

• ICO

• JPE

• JPEG

• JPG

• PNG

• SVG

• WEBP

Supported video file formats
RoboHelp supports the following audio and video file formats:

Audio file formats
• ASF

• ASX
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• AU

• MID

• MP3

• RA

• RAM

• RM

• RMI

• WAV

• WAX

• WMA

Video file formats
• AVI

• CPZ

• F4V 

• FLV

• MOV

• MP4 

• MPE

• MPEG

• MPG

• OGG

• OGV 

• QT 

• RPM

• SWF

• WEBM

• WMV 

• WVX

Create and use variables for easy updates
A variable is a text phrase or word that serves as a reusable piece of information, simultaneously used across multiple 
topics in your project. This makes your content portable and easy to update. When you modify a variable or its value, 
every occurrence of that variable or value is updated across the project.
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Create a variable
A variable is a text phrase to which you assign a value. Follow these steps to create a variable in your open project:

1 In the Author toolbar, click Variables. The Variables panel opens.

2 In the Variables panel, click  . The Define Variable dialog box opens.

3 In the Define Variable dialog box, specify the Name of the variable and its corresponding text value in Value.

4 Click Done.

Edit a variable
To edit a variable in RoboHelp, follow these steps:

1 In the Author toolbar, click Variables. The Variables panel opens.

2 In the Variables panel, click Options  next to the desired variable.

3 Select Edit in the given Options list.

4 In the Edit Variable dialog box, you can edit the Name and Value of the selected variable.

5 Click Done.

Note: 

If you rename any variable, RoboHelp simultaneously updates all the references wherever applicable. For example, Topic 
titles, Topic content, Table of Contents, Output Presets titles, Variable Sets, and so on.

Insert a variable
To insert or use a variable in an open topic or master page:

1 To open a topic:

In the Author toolbar, select Contents and open a topic of your choice from the Contents panel.

To open a master page:

In the Author toolbar, select Master Pages and open a master page of your choice from the Master Pages panel.

2 Select Variables in the Author toolbar. The Variables panel opens.

3 Select a variable from the Variables panel. Now drag-and-drop the selected variable at the desired text location in 
the open topic or master page.

Alternatively, press Ctrl+1. From the Variable dialog box, you can filter variables by typing the first few alphabets. 
Press the upward and downward arrow keys to navigate through the list of variables. Press Enter to insert a variable. 

4 Click the Save All icon  at the left side of the standard toolbar.

Note: 

You can also use variables in an output title. To do so, open the required output preset in Edit mode. In the General tab 
> Title field, type { and select a variable from the drop-down list, and then press Enter. Note that if you have provided 
a variable set in the Content tab > Variable Set field, during output generation, the value of the selected variable is 
picked from the variable set. 

Delete a variable
1 In the Author toolbar, click Variables. The Variables panel opens.
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2 In the Variables panel, click Options  next to the desired variable.

3 Select Delete in the Options list.

4 Click Yes in the Confirm dialog box to delete the selected variable.

5 If the variable is referenced in your project, you are prompted to choose among the listed three options:

• Delete the variable and its references - Deletes the variable and all its occurrences in the project.

• Delete only the variable - Deletes only the variable. This retains the references of the variable in the project.

• Delete variable and replace references with actual content - Deletes the variable and replaces all its occurrences 
with the variable value.

6 Select the relevant option and click Done.

Generate Variables report
You can generate a Variables report to view and manage variables in your project. Using this report you can find 
variables that are used in a topic and those that are not used in any topic. Before you delete a variable, you can locate 
the topics in which the variable is used and delete references to that variable.

You can then download or print the Variables report.

1 In the Author toolbar, select Reports. The Reports panel opens.

2 In the Reports panel, select Variables.

3 Use the Filters panel on the right side of the screen to customize the report. To know more, see Customize a report.

4 Step text

5 Once you've customized the Variables report based on your needs, click the Download icon  in the standard 
toolbar to instantly download the report. The report is saved as a .csv file.

6 To print the report, click the Print icon  in the standard toolbar.

Use Find and Replace 

Find a phrase or text
Follow these steps to quickly find a phrase or text in a topic:

1 In an open project, open a desired topic from the Contents panel.

2 In the upper-left corner of the standard toolbar, click the Find and Replace tool .

3 A bottom panel appears with the Find field. In this field, enter the phrase or text that you want to find in the open 
topic.

4 Click Find. The found phrase or text is highlighted in your topic.

Note: 

In the bottom panel, click  to do the following:

• Ignore case Select this option to ignore upper or lower cases in text.

• Whole word only Select this option to find the entire word.
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Quickly replace a phrase or text
Follow these steps to easily replace a specific phrase or text with an alternate phrase or text in a topic:

1 In an open project, open a desired topic in the Contents panel.

2 In the upper-left corner of the standard toolbar, click the Find and Replace tool .

3 A bottom panel appears with the Find field. In this field, enter the phrase or text that you want to find in the open 
topic.

In the bottom panel, click  to do the following:

• Ignore case Select this option to ignore upper or lower cases in text.

• Whole word only Select this option to find the entire word.

4 Click Find. The found phrase or text is highlighted in your topic.

5 In the Replace with field, enter the phrase or text that you want to replace the found text within the topic.

6 Click Replace to update the highlighted phrase or text. You can click Replace All to replace the specified phrase or 
text across the open topic.

7 Click  to close the bottom panel.

Auto save your content
Auto save is a new feature that automatically saves your work at certain intervals.  To create a seamless authoring 
experience, here’s how to set your topics to auto save every minute.  This feature is disabled by default, but can be turned 
on from the menu.

How to enable autosave
To enable, click Edit > Preferences > Enable auto save.

Here you'll find the "Specify time interval in seconds for auto save" option, which by default is set to 60 seconds, 
meaning that RoboHelp will save your unsaved content every 60 seconds. 
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How to disable auto save
Uncheck the box for "Enable auto save" if you wish to disable the auto save feature.

Side-by-side editing in Split View

Get started with Split View
The opened editor files (Topics, Output presets, TOCs, Master pages) are displayed as tabbed headers (Tabs) at the top 
of the screen.

If you want to multi-edit your editor files, there is a quick way to do so. Right-click on the top of the title bar of the first 
topic and select how you want to toggle your view among the four options - Split Up, Split Down, Split Left, or Split 
Right. As per your selection, split view of your editor files are created.

The Split View works both for Author and Output tabs; therefore, the users can also have multiple output presets open 
side-by-side.

Note: 

You can drag-and-drop the data from one topic to another while the topics are sharing the screen.

Exit Split View
To exit the Split View, follow the step below:

• To close the active topic, press the keyboard shortcut key Ctrl+F4 or click the close button (denoted by an "X") at 
the top right-hand corner. Alternatively, you can drag the tab from one of the screens to the other. Once the last tab 
is pulled, the topic will return to the full screen, which will turn off Split View.   

• Or, you can right-click on one of the editor files and select "Merge Split View." This will merge all the editor files 
back into a single window, which gets rid of the Split View.

Note: 

If any of the open topics have NOT been saved, you will be prompted to save the file. The pop-up window will appear and 
you can opt to Save or Don't Save for each unsaved topic.
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Work with Split View
In Split View, you can use multiple topics side-by-side or one-above-the-other:

• Choose any topic to work in by clicking anywhere on either of the topics.

• Any split view can be further divided if more than one file is opened in that split view.

Use the Spell Check feature
Working with the spell check option is a good practice to ensure high quality. By default, Adobe RoboHelp provides 
support for "Run spell checking on opening a topic," and highlights the misspelled words underlined in red, in the 
topic. 

Spell Check Options
You must access the Spell Check panel, located next to the Properties tab, on the right side of the screen to choose 
among the spell check options. On selecting one of these options, click the spin  on the right-side to run spell check 
in the specified files. The spell check scans all the words and suggests corrections for errors.

• Current File - Allows spell check on the file currently in focus.

• All Topics - Allows spell check in all the files of the currently opened project.

• All Project Files - Allows spell check in all the files of the currently opened projects which includes topics, TOC, 
Index, and Glossary.

The Settings icon  on the right side of the Spell Check tab offers two additional preferences on click - User 
Dictionary and Ignored Words.

Spell Check with Keyboard Shortcuts
Note: 

Use this key combo for a rapid Spell Check.

• Press F7. The Spell Check panel opens and automatically displays the first questionable spelling it finds in the 
currently active file in the editor.

• Press CTRL+F7. Checks the spelling in all topics located in the same folder as the current one.

• Press CTRL+SHIFT+F7. Irrespective of whether any file is open or not, the Spell Check panel opens and runs over 
all the files (Index, Glossary, HTML content files, TOC) to look out for any errors.

How it Works
Spell check stops at every instance of a misspelled word. Based on your selection, all misspelled words which are not 
available in the Dictionary appear under the Not in Dictionary field, which you can select to either Skip, Ignore or Add. 
For more details, see Not in Dictionary.

The Suggestions list below displays the correctly spelled options. You can opt to Replace or Replace All the misspelled 
words with any provided suggestions. For more details, see Correct your spellings using Suggestions.

After you have fixed a misspelled word using the above steps, the spell check moves onto the next misspelled word. 
Once the spelling mistakes are completed, a message appears "<None>" under Mispelt Word.
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Note: 

If the user manually rectifies a misspelled word, the spell check is required to re-run on the updated content of the current 
file.

Not in Dictionary
This selection indicates that a misspelled word is detected. The word is considered misspelled as it could not be located 
in the main dictionary. You can choose to select among these three options:

• Skip - Makes the reported word to be skipped over and move to the next misspelled word.

• Ignore - Causes the occurence of a misspelled word to be skipped. You might use this if the word reported as a 
misspelling is actually spelled the way you want. As a result, that word is automatically added to the Ignored Words 
list. For more details, see Ignored Words.

• Add - Makes the reported word added to the User Dictionary.  Use the Add button if a correctly spelled word (e.g., 
Name of a person, place, and so on) you use is reported as a misspelling, so it does not get flagged in any future spell 
checks. For more details, see User Dictionary.

Correct your spellings using Suggestions
The spell check feature offers suggestions for replacing the misspelled word by choosing among the below options:

• Replace - Use one of the suggested words to fix the error, and then click Replace.

• Replace All - You may want to choose Replace All to fix all the instances of the error in the topic in one go.

User Dictionary
Note: 

Adding a word to your dictionary makes the word available for spelling checks across the projects.

This allows the program to recognize new words as correctly spelled words. To edit or delete any words that have been 
added to your dictionary, follow these steps:-

• To add a word, type it in the box, and then click Add (+).

• To delete a word, select it in the Dictionary box, and then click Delete ( ). However, you can choose to select 
multiple words, and then click Delete ( ) to get rid of the unwanted words from your Dictionary.
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Ignored Words
Note: 

The Ignored Words list is specific to the project level and varies from project to project.

This selection lets you define the ignored words, which are then never presented as misspelled words, useful for 
excluding specific words such as names, abbreviations, etc. This list inherits the ignored word lists from Not in 
Dictionary tab. 

• To remove a word, select it in the list and click the Delete ( ) button. However, you can choose to select multiple 
words, and then click Delete ( ).
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Create and Edit Bookmarks
Bookmarks are named locations in a document. Use bookmarks to create incremental links within a topic. You can link 
to a bookmark from within the topic itself; from any other topic in your project; or from an index entry, TOC entry, or 
image map. The Bookmark icon appears at the bookmarked location. To view bookmarks in Contents Panel, click 
the sign next to a topic, and it will show all the bookmarks defined within that topic. They are also useful to mark a 
position that you want to return to later, especially with long topics. 

Insert a bookmark
To insert a bookmark, follow these steps:

1 Place the cursor at the appropriate location or select the required text in a topic.

2 In the standard toolbar, click the Insert Bookmark  icon. The Bookmark dialog box opens.

3 In the ID field, type a name for your bookmark, without spaces, using any combination of letters and numbers. You 
can see the existing bookmarks under Bookmarks in this topic.

4 Click Insert.

5 Click Save.

After you save the topic, bookmark icons appear nested under the individual topics listed in the Contents panel and 
at the appropriate location in the topic.

6 You can also show/hide the bookmark icons in topics with settings in the menu: View > Show > Bookmarks.

Note: 

You can also drag-and-drop an existing bookmark to a new location in the topic. 

Rename a bookmark
You can rename any of the bookmarks that you have inserted in the topic. To do this:

1 Select and double-click the bookmark that you want to rename. The Bookmark dialog opens, with the bookmarks 
in that topic listed.

2 In the ID (New bookmark)field, type a new name for the bookmark.

3 Click Update. This changes the bookmark name in the topic.

4 Click Save. 

Remove a bookmark
You can permanently remove a bookmark if you no longer need it. To do this:

? Right-click the selected bookmark to remove and select Remove Bookmark from the context menu.

Create links to bookmarks
After inserting a bookmark in a topic, you can link to that bookmark within the same topic or from other topics or 
TOC, etc. 

To create a link, put the cursor inside the desired topic, and Insert Hyperlink (link it to hyperlink help link). Then, 
select a bookmark in Insert Link dialog.
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Insert and update fields
Fields are the unique variables, which display information based on their type. For example, they can display the 
current date, time, or current file name, etc. You can insert fields in topics, snippets, and master pages. Various 
categories of fields allow you to display system, file, or project variables in your output.

Insert a field in the file
You can insert fields, such as date, time, title, and more, in topics or master pages.

1 Open the topic or master page. Place your cursor where you want to insert the field.

2 In the Author toolbar, click the Insert Variables/Snippets/Fields icon , and then click Field. The Fields dialog 
box opens. Alternatively, press CTRL+3 to open the Fields dialog box.

3 In the Fields dialog box, select field type in the left list and then select its format in the right list. For example, if you 
select the Field as Date, then select the format as DD-MM-YYYY, or MM/DD/YY, etc.

4 Navigate to the field that you want to insert and select it. 

5 Click Insert. The field is inserted into your topic.

6 Click  to save your work.

Remove a field from the file
You can delete fields that you have inserted into a topic. To do so, follow the below steps:

1 Open the topic or the master page containing the field.

2 Right-click the field that you want to delete.

3 From the context menu, select Remove Field. The field is removed from the topic.

4 Click  to save your work.

Work with Fields
There are various field options to work with, such as Date, Time, File, Title, Project Title, and more:

Date Allows users to enter a date, including day, month, year, or combinations of the day, month, and year.

Time Allows users to enter a time of day, including hours, minutes, and seconds using any custom time field. The time 
displays in a 24-hour notation with AM or PM. 

For example, you can select a time value in hh:mm:ss A, 14:40:10 PM, or M/D/YY H:mm, 3/30/20 14:40.

File Displays the file name of a topic.

Title Displays the title of a topic.

Project Title Displays the title of the project.

Fields in Master Pages
There are few Fields like Page Number and Total Pages which can only be inserted in Master Pages. To learn how to use 
Master Pages in RoboHelp, see Work with master pages.

Page Number When the master pages are applied to the topics, the page numbering is updated automatically.

Total Pages Indicates the total number of pages in the topic using the  “Page 1 of 10” format.
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Add a new format to a particular field
You can add a new format to a specific field following the below steps:

1 In the Author toolbar, click the Insert Variables/Snippets/Fields icon , and then click Field. The Fields dialog 
box opens. Alternatively, press CTRL+3 to open the Fields dialog box.

2 In the Fields dialog box, click  to create a Field. The new format dialog box opens.

3 In the field, you can specify a format for how the specified field is displayed. As you do this, the example is displayed 
below the field in that format. 

4 Click Ok. 

The new format for the specific selected field is created.

Delete a format from a particular field
1 In the Author toolbar, click the Insert Variables/Snippets/Fields icon , and then click Field. The Fields dialog 

box opens. Alternatively, press CTRL+3 to open the Fields dialog box.

2 Select a particular Field type and then hover on the format that you want to delete. Click to delete the selected 
format. 

3 The selected format is deleted.

Edit a format of a particular field
1 In the Author toolbar, click the Insert Variables/Snippets/Fields icon , and then click Field. The Fields dialog 

box opens. Alternatively, press CTRL+3 to open the Fields dialog box.

2 Select a particular Field type and then hover on the format that you want to edit. Click  to edit the selected 
format. 

3 The selected format is edited.

Reset to Default
You can use the Reset to Default option to restore the list of field formats back to RoboHelp's default set. 

Click the Reset to Default icon in the upper-right corner of the Fields dialog box.

Auto-update fields
With the "Auto-update this field" option selected, RoboHelp will keep the inserted field up-to-date based on its most 
recent value. For example, select this option while adding a File Title field to use the latest file title in the File Title field 
or Unselect it to use the file title value at the time of insertion.

1 Open the Fields dialog box and choose the field format you want to auto-update.

2 Check "Auto-update this field" at the bottom of the Fields dialog box. The respective field format would be 
automatically updated on a given topic.

Switch between multiple views
To help you work more efficiently, RoboHelp enables you to view and work with your authored content in different 
views. These views help in authoring and viewing content e.g. Topics, Stylesheets, Snippets, Table of Contents etc. 
enabling different ways to interact with the content. You can switch between the three views - Author view, Source View 
and Preview easily by clicking the relevant icon from the upper-right corner of the screen.
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Icons of the three views in the Standard Toolbar
A Author View  B Source View  C Preview  

Author View

The Author view uses the built-in “What-You-See-Is-What-You-Get” (WYSIWYG) editor and provides an easy-to-use 
interface for authoring your content. For example use author view to insert elements, such as hyperlinks, images, 
multimedia in topics, or add pages in Table of Contents etc. You can author several types of content in author view e.g. 
topics, master pages, snippets, Table of Contents, stylesheets, etc.

Source View

The Source view allows you to author topics, stylesheets, JavaScript, Table of Contents etc. by writing their HTML, CSS, 
or XML source.

 To activate the source view:

1 Open a topic, master page, or any source file.

Select Source View from the top right corner of the standard toolbar.

2 It will show the source content of the file.

Preview

The built-in preview window enables the authors to invoke a quick preview of what a topic, snippet or master page will 
look like when the output is generated. You don’t have to generate the entire output just to see how the topic will appear.

To activate the preview:

1 Open a topic, snippet, or master page, or any source file.

2 Click Preview  from the top right corner of the standard toolbar.

3 It opens the preview for the current topic.

4 To view the preview in any of the web browser installed on your system, you can click on View with at the center 
of the standard toolbar.

5 It will show the list of available browsers. Choose any of them to see the preview.
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Chapter 5: Import and linking

Import Markdown files into a project

Import a Markdown file
To import the Markdown file in your current project, follow these steps:

1 In the Contents panel, do one of the following:

• Select the desired folder in which you want to import the Markdown (.md) file. Then, select File > Import > 
Markdown File.

• Right-click the desired folder or click  against it and select Import > Markdown File.

2 In the Open dialog box, select the Markdown file you want to import and click Open. The selected file is imported 
as a topic (.htm) inside your project folder.

3 The HTML version of the selected Markdown file is generated and added as a topic in the selected folder. If you don't 
choose a folder while importing, the Markdown file is imported as a root-level topic in the Contents panel.

Note: 

The Markdown file should have a .md  or .markdown extension.

Note: 

You can select and import multiple files at the same time. While importing multiple Markdown files, the links and cross-
references do not break in the imported HTML files.

Import Word documents into a project
You can quickly import a Microsoft Word document into RoboHelp as one or multiple topics and work with it. While 
importing you can also configure several settings that RoboHelp provides to import and customize the topics based on 
your needs.

Import a Word document
To import the HTML version of a Word document in your open project, follow these steps:

1 In the Contents panel, do one of the following:

• Select the desired folder in which you want to import the Word document. Then, select File > Import > Word 
Document.

• Right-click the desired folder or click  against it and select Import > Word Document.
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2 In the Word Import Settings dialog box, select the desired Word document and edit the settings. See Word import 
settingsto know more.

3 Once you've specified your desired settings, click Save Settings. RoboHelp saves these settings and applies them 
automatically when you import a Word document the next time.

4 Click Import. The HTML version of the selected Word document is generated with the specified settings and 
included as a topic in the selected folder. The topic is placed in the alphabetical order of topics in the folder, based 
on its file name. If you don't select a folder while importing, the Word document is imported as a root-level topic in 
the Contents panel.

Word import settings
When you choose File > Import > Word Document, you can view the Word Import Settings dialog box. Use the 
following tabs in this dialog box to configure the various settings:

Note: 

The Paragraph, Character, Hyperlink, and Table tabs are enabled only when these styles are applied in the selected Word 
document.

• General

• Paragraph

• Character

• Hyperlink

• Table

• Advanced

General
The General tab is selected by default In the Word Import Settings dialog box. In this tab you can specify the following 
settings:

• Word Document Specify the Word document you want to import. To do this, click the  icon, select your Word 
document, and click Open.

• Load Settings Select a file with predefined settings for the content you are importing. Click   to do this.

• CSS file for style mapping Select the style sheet that RoboHelp can use to map styles in the Word document to 
RoboHelp styles. Click   to do this. By default, RoboHelp uses the style sheet specified in project settings.

• Start new topic from style Use the following settings to create multiple topics from the content imported from the 
Word document:

• Word Style Use the drop-down list to specify the style in the Word document that RoboHelp can use to create 
new topics. For example, to create a topic for every first level heading, select Heading1.

• Topic Name Pattern Specify the naming pattern for the new topics. You can choose from the following options:

• <$filename_no_ext><n> Creates the file names without extension (.docx) and includes a number in 
sequential order. For example: if the file is ABC.docx, the file names of the new topics will be ABC1, ABC2, 
and so on.

• <$filename_no_ext>-<$paratext> Creates the file names without the extension (.docx) and includes the 
initial text of the first paragraph

• <$paratext> (Default) Creates the file names with the initial text of the first paragraph

http://helpx.adobe.com/en/robohelp/using/import-word-documents.html#Hyperlink
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• Use only ASCII characters in the generated file names Select this field to use ASCII characters for the file 
names.

Paragraph
Select the Paragraph tab to specify paragraph styles for your imported content. In this tab you can view the following 
columns:

• Word Style The style in the selected Word document.

• In RoboHelp The style in the imported content. This style is automatically mapped to match its corresponding 
Word Style. This mapping is based on the css file that you have specified.

For each mapped style, you can click  next to it and select a style from the Map to Style section. If there is no style 
to match with the corresponding Word Style, RoboHelp provides the following default style options:

• Import Word style imports the content with the applied styles. 

• Discard style imports the content without the applied styles. In this case, the default style of RoboHelp is applied.

• Discard content removes the content with the applied styles.

• Map to HTML tag Specify the pre tag from this section for the content with the applied style.

You can preview the selected Word style and mapped style in Word Preview and RoboHelp Preview, respectively.

Character
Select the Character tab to specify character styles for your imported content. In this tab you can view the following 
columns:

• Word Style The style in the selected Word document.

• In RoboHelp The style in the imported content. This style is automatically mapped to match its corresponding 
Word Style. This mapping is based on the css file that you have specified.

For each mapped style, you can click  next to it and select a style from the Map to Style section. If there is no style 
to match with the corresponding Word Style, RoboHelp provides the following default style options:

• Import Word style imports the content with the applied styles. 

• Discard style imports the content without the applied styles. In this case, the default style of RoboHelp is applied.

• Discard content removes the content with the applied styles.

You can preview the selected Word style and mapped style in Word Preview and RoboHelp Preview, respectively.

Hyperlink
Select the Hyperlink tab to specify hyperlink styles for your imported content. In this tab you can view the following 
columns:

• Word Style The style in the selected Word document.

• In RoboHelp The style in the imported content. This style is automatically mapped to match its corresponding 
Word Style. This mapping is based on the css file that you have specified.

For each mapped style, you can click  next to it and select a style from the Map to Style section. If there is no style 
to match with the corresponding Word Style, RoboHelp provides the following default style options:

• Import style imports the content with the applied styles. 

• Discard style imports the content without the applied styles. In this case, the default style of RoboHelp is applied.
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• Discard content removes the content with the applied styles.

You can preview the selected Word style and mapped style in Word Preview and RoboHelp Preview, respectively.

Table
Select the Table tab to specify table styles for your imported content. In this tab you can view the following columns:

• Word Style The style in the selected Word document.

• In RoboHelp The style in the imported content. This style is automatically mapped to match its corresponding 
Word Style. This mapping is based on the css file that you have specified.

For each mapped style, you can click  next to it and select a style from the Map to Style section. If there is no style 
to match with the corresponding Word Style, RoboHelp provides the following default style options:

• Import Word style imports the content with the applied styles. 

• Discard style imports the content without the applied styles. In this case, the default style of RoboHelp is applied.

• Discard content removes the content with the applied styles.

You can preview the selected Word style and mapped style in Word Preview and RoboHelp Preview, respectively.

Advanced
Select the Advanced tab in the Word Import Settings dialog box. In this tab you can specify the following:

• Convert Word Lists to HTML Lists Select this field to import numbered or bulleted lists in the Word document as 
HTML lists in your topic. If you don't select this setting, the look and feel of the Word lists are maintained in the 
imported content but they don't remain as lists.

• Import inline styles Select this field to import the inline styles applied to the content in the Word document.

• Add Topics to Table of Contents Select this field to add topics generated from Word documents to a Table of 
Contents. From the drop-down list, select <New TOC> to create a Table of Contents or choose an existing Table of 
Contents from your project.

• Post Import Script From the drop-down list, you can select a script to be run on document import. 

Import FrameMaker documents into a project
Note: 

FrameMaker 2019 Update 2 or later is required for this feature.

You can quickly import a FrameMaker document into RoboHelp as one or multiple topics. While importing, you can 
configure several settings that RoboHelp provides to import and customize topics based on your needs. Also, you can 
link FrameMaker documents into your RoboHelp project. 

Import a FrameMaker document
You can import FrameMaker books (.book) and documents (.fm, .mif) into your Robohelp project. On importing a 
FrameMaker document in the Contents panel, RoboHelp places the topics at the chosen location (at the root level or 
inside a folder). However, all assets referenced in the imported document are placed in the respective subfolder in 
the assets folder. For example, style sheets are placed in the css subfolder and images in the images subfolder.
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To import a FrameMaker document:

1 In the Contents panel, do one of the following:

• To import a FrameMaker document in a folder, do one of the following:

• Select the folder and choose File > Import > FrameMaker Document.

• Right-click the folder or click  against it, and choose Import > FrameMaker Document.

• To import a FrameMaker document at the root level, do one of the following:

• Without selecting any folder, choose File > Import > FrameMaker Document.

• Right-click outside folders and choose Import > FrameMaker Document.

The FrameMaker Import Settings dialog box opens.

2 In the FrameMaker Import Settings dialog box, select the FrameMaker document you want to import and edit the 
settings. For information about options in the dialog box, see FrameMaker import settings.

3 Click Import.

An HTML version of the selected FrameMaker document is generated with the specified settings. The topic is 
placed in the alphabetical order of topics at the chosen location in the Contents panel.

FrameMaker import settings
When you choose File > Import > FrameMaker Document, the FrameMaker Import Settings dialog box appears. 
Configure the settings in the following tabs in this dialog box:

• General

• Paragraph

• Cross Reference

• Advanced

• Character

• Table

• Images

Note: 

The Character, Paragraph, Table, and Cross Reference tabs are enabled only when these styles are applied in the selected 
FrameMaker document.

General
The General tab is selected by default in the FrameMaker Import Settings dialog box. In this tab, specify the following 
settings:

• FrameMaker Document Click  to select the FrameMaker document (.fm, .mif, or .book) you want to 
import.Note: When you select a FrameMaker document, an instance of FrameMaker is launched, if it is not running 
already. RoboHelp reads the selected document and populates the applicable tabs in the FrameMaker Import 
Settings dialog box.

• CSS file for style mapping Click  to select an external style sheet (.css file), which is different from your project 
style sheet, to map FrameMaker styles with RoboHelp styles. By default, RoboHelp picks the default style sheet of 
the project.
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• Start new topic from style Use the following settings to create topics from the content in the selected FrameMaker 
document:

• FrameMaker Style Select a paragraph style from the FrameMaker document that RoboHelp can use to create 
topics. For example, to create a topic for every first-level heading, select Heading1. Note: This field displays all 
paragraph styles from the document selected in the FrameMaker Document field. If you did not select a 
document in the FrameMaker Document field, this field remains blank. 

• Topic Name Pattern Specify the naming pattern for the new topics. You can choose from the following options:

• <$filename_no_ext>-<n> Creates filenames without extension and includes a number in sequential order. 
For example, if ABC.fm is the imported FrameMaker document, the filenames of new topics become ABC1, 
ABC2.

• <$filename_no_ext>-<$paratext> Creates filenames without extension and includes the initial text of the 
first paragraph.

• <$paratext> Creates filenames with the initial text of the element on which the selected style is applied. This 
option is set by default.

• Use only ASCII characters in the generated file names Select this field to convert non-ASCII characters in new 
topic filenames to ASCII characters. The conversion follows the Punycode standard.

• Save Settings Click to save the settings of the FrameMaker Import Settings dialog box as a preset (.fsf) file. If you 
modify and save the settings as a new preset file, you can select the file from the Load Settings field the next time 
you open the dialog box.

• Load Settings Click  to select a different preset (.fsf) file in which you want to save the settings of 
the FrameMaker Import Settings dialog box. This field shows the default preset file default.fsf. You can also 
click  to select a recently saved preset file.

Character
Select the Character tab to specify character styles for your imported content. In this tab, you can view the following 
columns:

• FrameMaker Style The style in the FrameMaker document selected in the FrameMaker Document field in 
General tab.

• In RoboHelp Styles populated from the CSS file specified in the CSS file for style mapping field in General tab. 

For each FrameMaker style, click  in In RoboHelp to select a different style and map it to the corresponding 
FrameMaker style. If there is no style to match with the corresponding FrameMaker style, RoboHelp provides two style 
options:

• Import style (default) imports styles from the selected FrameMaker document to RoboHelp. 

• Discard content Discards all content on which the selected style is applied.  

You can preview the selected FrameMaker style and mapped style in FrameMaker Preview and RoboHelp Preview 
sections, respectively.

Paragraph
Select the Paragraph tab to specify paragraph styles for your imported content. In this tab, you can view the following 
columns:

• FrameMaker Style The style in the FrameMaker document selected in the FrameMaker Document field in 
General tab.

• In RoboHelp Styles populated from the CSS file specified in the CSS file for style mapping field in General tab. 

https://tools.ietf.org/html/rfc3492
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For each FrameMaker style, click  in In RoboHelp to select a different style and map it to the corresponding 
FrameMaker style. If there is no style to match with the corresponding FrameMaker style, RoboHelp provides two style 
options:

• Import style (default) imports styles from the selected FrameMaker document to RoboHelp. 

• Discard content Discards all content on which the selected style is applied. 

You can preview the selected FrameMaker style and mapped style in FrameMaker Preview and RoboHelp Preview 
sections, respectively.

Table
Select the Table tab to specify table styles for your imported content. In this tab, you can view the following columns:

• FrameMaker Style The style in the FrameMaker document selected in the FrameMaker Document field in 
General tab.

• In RoboHelp Styles populated from the CSS file specified in the CSS file for style mapping field in General tab. 

For each FrameMaker style, click  in In RoboHelp to select a different style and map it to the corresponding 
FrameMaker style. If there is no style to match with the corresponding FrameMaker style, RoboHelp provides two style 
options:

• Import style (default) imports styles from the selected FrameMaker document to RoboHelp. 

• Discard content Discards all content on which the selected style is applied.

You can preview the selected FrameMaker style and mapped style in FrameMaker Preview and RoboHelp Preview 
sections, respectively.

Cross Reference
Select the Cross Reference tab to specify cross-reference styles for your imported content. In this tab, you can view the 
following columns:

• FrameMaker Style Displays names of the cross-reference styles applied in the FrameMaker document selected in 
the FrameMaker Document field in General tab.

• In RoboHelp Displays the current definitions of the styles. By default, this column is populated from the definitions 
in the imported FrameMaker document. You can modify the definitions by using combinations of constants and 
variables. To specify a variable, type < and select a variable from the drop-down list or type the variable name. 

You can preview the selected FrameMaker style and its definition in FrameMaker 
Preview and RoboHelp  Preview sections, respectively.

Images
Select the Images tab to specify image styles for your imported content. In this tab, use the following fields:

• Do Not Regenerate Images Select this field if you are reimporting FrameMaker documents and do not need to 
update the images in the imported content.

• Import Reference Page Images Select this field to import images from the Reference Page in the imported 
FrameMaker document.

• Preserve 3D Images Preserves 3D images in the selected FrameMaker document, that is, 3D images are not 
flattened to 2D images. When the output is published, 3D information in images is visible in the browser. This field 
is selected by default.
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• Preferred Dimensions

• Width and Height Specify the preferred width and height of the imported images. By default, the width and 
height fields are linked to accept same values. Toggle  to set different width and height values.

• Scale Specify a scaling factor to scale the imported images.Note: Specifying a scale may change the width or 
height values.

• Maintain Aspect Ratio Select this field to maintain the aspect ratio according to the images in the imported 
FrameMaker document. Note: Specifying a scale may change the width or height values.

• Maximum Dimensions  As the Preferred Dimensions can be overridden by Scale and Maintain Aspect Ratio 
settings, use this section to set a maximum limit for the image size in the imported document.

• Width and Height Specify the width and height of the imported images. By default, the width and height fields 
are linked to accept same values. Toggle  to set different width and height values.

• Margin Specify a value for all four margins around images. Toggle  if you want to specify a different value for 
each of the top, bottom, left, and right margins.

• Borders Control the properties of the standard HTML borders that are applied to the imported images using this 
section.

• Border Style Select a border style from the drop-down list. Default is None.

• Color Click  to select a border color. Default is black. Or, click  to pick a color from the screen.   

• Width Specify the border width.

• Select the borders you want to apply from the following options:

•  All (default)

•  Top

•  Right

•  Bottom

•  Left

• Advanced

• Default Format Select the default image format to which you want to convert all imported images. 

• Color Bit Depth Values in this field change according to the selected default image format. You can choose a 
depth from the supported options.

• JPG Quality Specify a value to set the quality of all imported JPG images. This field controls the JPG 
compression in terms of size and quality, for example, the default value 100 means the best quality and minimum 
compression. 

• Grayscale Select to convert all imported images to grayscale.

Advanced
Select the Advanced tab to specify advanced settings for your imported content. In this tab, use the following fields:

• Context sensitive help marker If you want to import context-sensitive help markers from the FrameMaker 
document, select this field and specify the type of context-sensitive help maker to be imported.  

• Split into topics using marker If you want to create topics based on a specific marker type from the FrameMaker 
document, select this field and specify the marker type. 

• Keep all topics in one folder If a FrameMaker book is being imported, select this field to keep all topics in the book 
in the same folder.
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• Add all topics to Table of Contents Select this field to add all topics created from the selected FrameMaker 
document to the Table Of Contents file being created. 

• Cleanup inline HTML styles If the imported FrameMaker document has inline styles, select this field to discard 
such styles.

• Import Glossary files Imports all glossary information from the selected FrameMaker document into a new 
glossary file. This option is selected by default. 

• Import TOC files Imports all Table Of Contents files referred from the FrameMaker book being imported into a 
new Table Of Contents file. This option is selected by default.

Link a FrameMaker document
You can link a FrameMaker document from your Robohelp project folder.

Apart from the basic functions available for topics and folders, you can Create HTML topicsfrom the linked 
FrameMaker document.

http://helpx.adobe.com/en/robohelp/using/work-with-topics-folders.html#Linkfilesandfolders
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Chapter 6: TOCs, indexes, and glossaries

Create and manage a Table of Contents
A Table of Contents provides a hierarchy of the sections (earlier called books) and pages (topics) that you have in the 
output of your project. The Table of Contents gives the reader an ability to view the publication as a whole and its topics. 
With a Table of Contents, the reader can quickly select and view a topic of their choice.

You can have multiple Tables of Contents in a single project, depending on the type of output that you want for your 
readers. For example, you can have a Table of Contents to cater to a specific audience (say, Developers) and another 
Table of Contents for a different audience (say, End users). You can simultaneously maintain the two Table of Contents 
files in the Table of Contents panel.

At the time of publishing your project, the entire project is not included in the output generated. Only the topics (and 
the referenced files inside these topics) in the selected Table of Contents file are included.

With RoboHelp, you can create two types of TOCs: "Online TOC" and "Book TOC". The Online TOC  has 
sections and topics and is applicable for Frameless, Responsive HTML5, and other online outputs whereas, the Book 
TOC   has front matter and back matter useful for PDF and Word outputs.

Create a Table of Contents
To create a Table of Contents:

1 In the Author toolbar, select Table of Contents. The Table of Contents panel opens.

2 In the Table of Contents panel, click  to create a Table of Contents.

3 In the New Table of Contents dialog box, specify the following:

Name Specify the name of the Table of Contents file.

Type Select the desired TOC type.

• Online TOC Select this option to make a table of contents based on sections and topics.

• Book TOC Select this option to enable book-related features, like front matter and back matter. See Customize 
Table of Contents for Book TOC.

4 Click Done.

The Table of Contents is created in the Table of Contents panel. You can add multiple Table of Contents files in a 
project. You can expand a Table of Contents file by clicking  against it. 

Edit a Table of Contents
You can edit a Table of Contents file in two modes–quick edit mode and comprehensive edit mode.

Quick edit mode is accessible as a context menu in the Table of Contents panel after you expand a Table of Contents 
file. This mode does not launch the Table of Contents editor or display the Table of Contents toolbar.
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Comprehensive edit mode launches the Table of Contents editor and displays the Table of Contents toolbar at the center 
of the standard toolbar. To edit a Table of Contents file in the comprehensive edit mode:

1 In the Author toolbar, select Table of Contents. The Table of Contents panel opens.

2 Launch the Table of Contents editor by doing one of the following in the Table of Contents panel:

• Double-click a Table of Contents file.

• Right-click a Table of Contents file and then click Edit.

• Against a Table of Contents file, choose Options ( ) > Edit.

The Table of Contents editor opens as a tab and RoboHelp displays the Table of Contents toolbar at the center of the 
standard toolbar.

In edit mode, you can do the following:

For Online TOC

• Insert topic

• Insert section

• Link Another TOC

• Insert Child Project

• Insert Child HTML Help (.chm) File

• Auto-create TOC

• Reorder items in a Table of Contents

• Convert Topics to Sections

• Delete items in a Table of Contents

• Work with a Table of Contents' properties

For Book TOC

• Insert topic

• Insert section

• Insert Front Matter

• Insert Back Matter

• Link Another TOC

• Auto-create TOC

• Reorder items in a Table of Contents

• Convert Topics to Sections

• Delete items in a Table of Contents

• Work with a Table of Contents' properties

Customize Table of Contents for Online TOC
The Online TOC is an organized listing of the sections and topics of your publication. You can also link another TOC, 
insert Child Project, insert Child HTML Help file, auto-create TOC as follows:

http://helpx.adobe.com/en/robohelp/using/manage-projects.html#InsertChildProject
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Insert topic
Quickly insert a topic in the TOC by dragging it from the Contents panel and dropping it in the Table of Contents.

Or, follow these steps:

1 Do one of the following:

• In the Table of Contents toolbar, click .

• Right-click in the Table of Contents editor and choose Insert Topic. 

2 In the Insert Topic dialog box, do the following:

• Project Files Select this option to insert a topic from your project. 

• Title By default, the title displays the text specified in the topic title. You can set a different title if you want to 
override the topic title. Note: Any further change in the topic title will not impact the overridden title.

• Search Use this field to quickly search for a topic. You can also use the Recently Used panel or the Contents panel 
to select a topic of your choice.

• Click Done.

If you insert a topic in an existing Table of Contents, it is inserted after the currently selected topic. If a section is 
selected at the time of insertion, the topic is inserted at the end of the list of topics inside the selected section.

Insert section
Quickly insert a section in the TOC by dragging the folder from the Contents panel and dropping it in the Table of 
Contents. RoboHelp retains the original hierarchy of the section in the Table of Contents.

Or, follow these steps:

1 Do one of the following:

• In the Table of Contents toolbar, click   .

• Right-click in the Table of Contents editor and choose Insert Section.

2 In the Insert Section dialog box, in the Name field, specify the name of the section. You can associate a topic to the 
section from the Properties panel using the Source field. 

If you insert a section in an existing Table of Contents, it is inserted after the currently selected topic. If another 
section is selected at the time of insertion, the new section is inserted at the end of the list of topics in the selected 
section.

Note: 

If a topic is associated with the section, the user can either use the topic title or specify a different title.

Link Another TOC
You can achieve collaborative authoring in RoboHelp where multiple writers can work on their individual 
sections. Using another TOC, you can create a merged output from individual TOCs. To do so, you can insert another 
TOC in your current Table of Contents. RoboHelp retains the original hierarchy of topics and sections in a placeholder, 
which is expanded as a complete Table of Contents in the output generated.

Quickly insert a Table of Contents by dragging it from the Table of Contents panel and dropping it in the current Table 
of Contents. 



117
TOCs, indexes, and glossaries

Last updated 7/13/2020

Or, follow these steps:

1 Do one of the following:

• In the Table of Contents toolbar, click .

• Right-click in the Table of Contents editor and choose Insert TOC.

2 In the Insert TOC dialog box, from the list of Table of Contents, select one and click Insert. 

The Table of Contents is inserted as a placeholder. If you insert a TOC in an existing Table of Contents, it is inserted 
after the currently selected topic. If a section is selected at the time of insertion, it is inserted at the end of the list of 
topics in the selected section.

Insert Child HTML Help (.chm) File
To merge a CHM file into your project, follow these steps: 

1 Do one of the following:

• In the Table of Contents toolbar, click  .

• Right-click in the Table of Contents editor and choose Insert Child HTML Help File. 

2 In the Insert HTML Help File dialog box, specify a location for the .chm file. To select a location, click .

3 Click Insert.

Note: 

Insert Child HTML Help (.chm) option is not available for Mac users.

Note: 

Insert Child Project and Insert Child HTML Help File are not available in Book TOC mode.

Auto-create TOC
Quickly create a Table of Contents using Auto-create TOC. This feature uses the hierarchy of the folders and topics in 
your project to create a Table of Contents file.

To auto-create Table of Contents:

1 Do one of the following:

• In the Table of Contents toolbar, click .

• Right-click in the Table of Contents editor and click Auto-create TOC. 

2 In the Confirm dialog box, you can select one or both of the following:

• Delete current TOC before creating new Deletes existing Table of Contents, if any, before auto-creating.

• Create TOC pages for bookmarks If your topics include bookmarks, selecting this field creates an additional 
page for each bookmark.

Click Ok. 

Note: 

If a Table of Contents exists, and you do not select any option in the Confirm dialog box, the new Table of Contents is 
appended at the end of the existing Table of Contents.
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Reorder items in a Table of Contents
To quickly reorder the items inside a Table of Contents file, do one of the following:

• Use drag-and-drop

• Click the following icons in the Table of Contents toolbar or from the Move context menu in the Table of Contents 
editor:

•  Changes the hierarchy of the topic/section by moving it one level above the original level

•  Changes the hierarchy of the topic/section by moving it one level below the original level

•  Changes the order of the topic/section by moving it above the previous topic/section

•  Changes the order of the topic/section by moving it below the next topic/section

Convert Topics to Sections
To convert each topic to a section inside a Table of Contents file, do one of the following:

• Select the topic you want to convert and click the right arrow  in the Table of Content toolbar.

• Right-click the topic  and choose Convert to Section .

Note: The right arrow  changes the hierarchy of the topic by moving it one level below the original level. So, if you 
click the right arrow on a topic, which is at the same level as the section, it gets merged in that particular section. If there 
is no section parallel to the topic, the topic remains at the same level and gets converted to section.

Delete items in a Table of Contents
To delete an item inside a Table of Contents file, do one of the following:

• Select the item and press Delete. 

• Right-click the item and click Delete. 

• Against the item, choose Options ( ) > Delete.

Work with a Table of Contents' properties
The Table of Contents editor displays the Properties panel at the right side of the screen. 

The Type field displays the type of the currently selected item. For each item, you can set the following:

• Title Use this field to overwrite the existing title of a section or a topic.

Note: 

If a topic is associated with the section, the user can either use the topic title or specify a different title.

• Source Displays the path of the selected item. You can replace the selected topic with a different topic from your 
project by clicking , choosing the topic, and clicking Update Topic. 

Note: 

If the linked topic does not exist, RoboHelp displays a red x mark against the topic in the TOC.

• Hide in output Select to hide the topic from the Table of Contents in the output.

Note: 
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This feature is useful if you want to publish supplementary files, such as PDF, but do not want to show it in the Table of 
Contents in the output. To do so, add supplementary files to the TOC, and select Hide in output against each file.

• Apply Tags Click to apply condition tags to the selected item. From the Apply Condition Tags dialog box, select 
the condition tags you want to apply. The selected tags appear at the right side of the dialog box. Click Apply. The 
applied tags are displayed in the Properties panel below the Condition Tags drop-down section. In the Properties 
panel or in the Apply Condition Tags dialog box, you can click  against a tag to remove it.

• Tile Image Specify the image to use on homepage TOC tiles in the Frameless output. Click  to browse and select 
a desired image. 

Customize Table of Contents for Book TOC
You can customize the TOC layout, as well as your content in the book. You can create special placeholders for 
displaying front matter and back matter sections as follows:

• Front Matter: Consists of very first pages before the actual content, the front matter can contain a Cover page, 
foreword, preface, table of contents.

• Back Matter: What you find at the end of the book, the back matter can include an appendix, a glossary, and an 
index, all of which are optional.

Insert Front Matter
1 In the Table of Contents toolbar, click .

2 From the options Cover Page, TOC Page, and Other Page, you can include either one of them or all of these front 
matter elements.

3 In the Insert Cover Page dialog box, do the following:

• Title Include a title of your cover page.

• Search Use this field to quickly search for a topic. You can also use the Recently Used panel or 
the Contents panel to select a topic of your choice.

• Click Done.

You can reorganize your Front Matter section by dragging the cover page to its appropriate location.

4 Click TOC Page to insert a Table of Contents placeholder. 

You can reorganize your Front Matter section by dragging the TOC  to its appropriate location.

5 Click Other Page to insert a new topic in your book. Remember, the new page inside the Front Matter section is for 
any content user would like to include.

Insert Back Matter
1 In the Table of Contents toolbar, click .

2 From the options Index Page, Glossary Page, and Other Page, you can include either one of them or all of 
these back matter elements.

3 Click Index Page to locate keywords in your content without having to search. The index is an alphabetically sorted 
list of words with page numbers (or hyperlink to pages) where they are mentioned.

You can reorganize your Back Matter section by dragging the index to its appropriate location.

4 Click Glossary Page for new and specialized terms. When selecting the glossary page option, a dialog box opens 
which allows you to select the glossary file to be included.
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You can reorganize your Back Matter section by dragging the Glossary page to its appropriate location.

5 Click Other Page to insert a new topic in your book. Remember, the new page inside the Back Matter section is for 
any content user would like to include.

Note: 

• Any section or topic at the first level becomes a chapter in PDF and Word outputs.

• Any topic associated with a section becomes the first topic within this chapter.

• All child sections and topics get flattened on generating the output. This means that all the child sections are 
removed, and their respective content comes at the second level along with other topics.

Use a desired Table of Contents in your output
To use a Table of Contents in the output:

1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click Output Presets. 

3 In the Output Presets panel, select your desired output preset from the given options. You can choose output presets 
from among Responsive HTML5, Mobile App, Frameless, eBook, Word, PDF, and more.

4 Select the Content tab.

5 The Table of Contents field displays all your created Table of Contents files in the project. Use the drop-down list 
to select your desired Table of Contents file. 

The selected Table of Contents is then included in your output. See Generate outputfor details on how to generate 
the output.

Cut, Copy, and Paste in a Table of Contents
To cut, copy, and paste the content in the active Table of Contents, select your content, and right-click the mouse button 
for a Quick Menu. Click either Cut or Copy, then place your cursor where you want to put the content and click the 
Paste command.

Alternatively, if you open two Table of Contents positioned side-by-side, you can also drag items from one Table of 
Content to another Table of Content, which is a copy-and-paste operation.

Rename a Table of Contents
To rename a Table of Contents:

1 In an open project, select Table of Contents in the Author toolbar. The Table of Contents panel opens.

2 In the Table of Contents panel, against the Table of Contents that you want to rename, choose Options ( ) > 
Rename.

3 In the Rename Table of Contents dialog box, modify the current name. Click Done.

Delete a Table of Contents
To delete a Table of Contents:

1 In an open project, select Table of Contents in the Author toolbar. The Table of Contents panel opens.
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2 In the Table of Contents panel, against the Table of Contents that you want to delete, choose Options ( ) > 
Delete.

3 In the Confirm dialog box, click Yes to confirm the deletion.

Create and manage an index

What is an index
An index is an alphabetically sorted list of keywords used in your project. Keywords can include multiple levels of 
subkeywords. You can associate keywords and subkeywords with topics that contain them and add cross-references to 
other keywords. You can also use project variables while adding keywords or subkeywords. You can add condition tags 
to index keywords to choose which keywords to publish in a specific output. You can also publish keywords so that your 
end users can use the keywords to search for and access specific topics in the output.

You can work with keywords and subkeywords through the Index panel of RoboHelp.

Add keywords to create an index
You can add index keywords/subkeywords in two ways–from Topic properties and from the Index panel. 

From Topic properties

From Index panel

From Topic properties
1 In an open topic, navigate to index in topic properties by clicking Properties panel > Topic tab > Index drop-down 

section.

2 In the Index Keywords field, specify a keyword and press Enter. To specify a subkeyword, use a colon : between 
keywords. You can use variables while specifying keywords and subkeywords. 

As you type in the index keyword field, you get all the keywords and subkeywords already used in the project as the 
dropdown. The list gets further filtered as you type. You can now select the relevant keyword from the list.

From Index panel
1 In an open project, select Index in the Author toolbar.

2 In the Index panel, do one of the following:

• Click  at the upper-right corner of the panel. 

• Against an existing keyword, choose Options ( ) > New Keyword. 

• Right-click a keyword and select New Keyword.

An empty field appears in the Index panel.

3 In the empty field, specify a keyword and press Enter. The keyword is added to the Index panel and placed according 
to alphabetical order of keywords.
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You can add multiple keywords to create an index.

The keywords are also visible in Properties panel > Topic tab > Index drop-down section.

Add subkeywords to keywords
To add a subkeyword to a keyword, follow these steps:

1 In an open project, select Index in the Author toolbar.

2 In the Index panel, against a keyword, choose Options ( ) > New Subkeyword. Alternatively, right-click a 
keyword and select New Subkeyword.

An empty field appears below the keyword.

3 In the empty field, specify a subkeyword and press Enter. The subkeyword is added below the keyword.

You can add multiple subkeywords to a keyword.

Link keywords and subkeywords to specific topics
Once you've added keywords and subkeywords to an index, you can link them to specific topics. To do this, follow these 
steps:

1 In an open project, select Index in the Author toolbar. 

2 In the Index panel, against a keyword/subkeyword, choose Options  > Add Topic. Alternatively, right-click a 
keyword/subkeyword and select Add Topic.

3 In the Add Topic dialog box, use the Search bar, Recently Used panel, or Contents panel to select a topic in your 
project.

4 Click Link. The topic is added below the keyword/subkeyword.

Note: 

To remove or edit a linked topic, click  next to the topic or right-click the topic and select Remove or Edit, 
respectively.

If the linked topic is open, the Properties panel > Topic tab > Index drop-down section displays the associated 
keywords and subkeywords. For more information, see Index.

Link keywords and subkeywords to other keywords
Once you've added keywords and subkeywords to an index, you can link them to other keywords in the index. To do 
this, follow these steps:

1 In an open project, select Index in the Author toolbar. 

2 In the Index panel, against a keyword/subkeyword, choose Options  > Add Cross Reference. Alternatively, 
right-click a keyword/subkeyword and select Add Cross Reference.

http://helpx.adobe.com/en/robohelp/using/topic-properties.html#Index
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3 In the Insert Cross Reference dialog box, you can filter keywords by typing the first few alphabets. Press the upward 
and downward arrow keys to navigate through the list of keywords. Press Enter to insert a keyword. 

The keyword is added as a cross-reference below the main keyword.

Note: 

To remove or edit a cross-reference, click  next to the cross-reference or right-click the cross-reference and select 
Remove Cross Reference or Edit Cross Reference, respectively.

Apply condition tags to a keyword or subkeyword
You can use a single index file in all outputs and apply condition tags to specific keywords/subkeywords to publish those 
in specific outputs. You can apply multiple condition tags to keywords and subkeywords in an index. To do this, follow 
these steps:

1 In an open project, select Index in the Author toolbar. 

2 In the Index panel, against a keyword/subkeyword, choose Options  > Apply Condition Tags. Alternatively, 
right-click a keyword/subkeyword and select Apply Condition Tags.

3 In the Apply Condition Tags dialog box, click a condition tag in the left panel.

The tag appears in the right panel. To remove the tag, click  against it.

4 Click Apply. 

In the Index panel, against the keyword/subkeyword, a colored circle indicates that conditional tags are applied.

Rename a keyword or a subkeyword
To rename a keyword/subkeyword in the Index panel, follow these steps:

1 In an open project, select Index in the Author toolbar. 

2 In the Index panel, against the keyword/subkeyword, choose  > Rename. Alternatively, right-click the 
keyword/subkeyword and select Rename.

3 Edit the keyword/subkeyword inside the editable box and press Enter.

The edited keyword/subkeyword is reflected in the Index panel and the Index drop-down section in a topic's 
properties. All the topics in which this keyword/subkeyword is used are updated as well. 

Delete a keyword or a subkeyword
To delete a keyword/subkeyword in the Index panel, follow these steps:

1 In an open project, select Index in the Author toolbar. 

2 In the Index panel, against the keyword/subkeyword, choose  > Delete. Alternatively, right-click the 
keyword/subkeyword and select Delete.

3 Click Yes in the Confirm dialog box to confirm deletion.

The deleted keyword/subkeyword is removed from the Index panel and the Index drop-down section in a topic's 
properties. It is also removed from all the topics in which it was used.
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Publish an index
By default, an index is published in the output. You can change this setting in RoboHelp while configuring an output 
preset that you want to use to generate output. To do so, follow these steps:

1 Click the Output tab at the left side of the standard toolbar.

2 In the Output toolbar, click Output Presets.

3 From the Output Presets panel, double-click the output preset that you want to edit.

4 Click the Content tab.

The Include Index field is selected by default, so index is published by default. You can select or deselect this field 
depending on whether you want to publish an index.

Note: 

For Frameless and Responsive HTML5 output types, you can also control whether to show or hide an index from the 
respective skins. To do so, in the Layout tab of the Skin Components panel, you can enable or disable the Show 
Index option.

5 Generate output.

Use an index in the output
An index, if published, appears as a panel in the output. The index panel in the output displays all keywords and serves 
as an additional navigational channel for your end users. In the index panel, one can filter through keywords and click 
a keyword to quickly navigate to the associated topic. Your end users can use index keywords to quickly search for and 
access topics of their choice. Index keywords have the same ranking as search keywords.

Create and manage a glossary
A glossary is a list of terms with their corresponding definitions, just like a dictionary. You can specify the definitions 
of terms in your project that you think are difficult to understand by your readers. A single glossary file can contain 
multiple terms and you can have multiple such glossary files in a project. You can decide which glossary file goes into 
your output, based on your audience.

You can access, add, remove, and edit glossaries from the Glossary panel.

Create a glossary
To create a glossary file for your project in RoboHelp:

1 In the Author toolbar, select Glossary. You can view the Glossary panel.

2 In the Glossary panel, click the  icon.

3 In the Add Glossary dialog box, specify the name of the glossary file in the Name field and click Done.

You can now view the created glossary file as an expandable list in the Glossary panel. You can create multiple 
glossary files in a project. However, you can expand only one glossary file at a time by clicking  against it. 
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Add terms to a glossary
To add definition terms to a glossary file, follow these steps:

1 In the Author toolbar, select Glossary. The Glossary panel opens.

2 In the Glossary panel, click  to expand the glossary file in which you want to add a term.

3 In the expanded glossary file, click the  icon to add a new term. 

4 In the Define Glossary Term dialog box, specify the term and its definition in Term and Definiton, respectively.

5 Click Done.

You can now find the term and its definition in the expanded view of the selected glossary file.

Edit a glossary term
You can change or edit the definition of a term in your glossary file. To do this:

1 In the Author toolbar, select Glossary. The Glossary panel opens.

2 In the Glossary panel, click  to expand a glossary file and hover over the term definition that you want to edit.

3 Click Edit ( ).

4 In the Edit Glossary Term dialog box, you can edit both the Term and Definition.

5 Click Done.

The edit is reflected in the glossary file.

Remove a glossary term
To remove a glossary term from a glossary file, follow these steps:

1 In the Author toolbar, select Glossary. The Glossary panel opens.

2 In the Glossary panel, click  to expand a glossary file and hover over the term definition that you want to remove.

3 Click Delete ( ).

4 In the Confirm dialog box, click Yes.

The glossary term is removed from the glossary file.

Rename a glossary
You can rename a glossary file in the Glossary panel in RoboHelp. To do this:

1 In the Author toolbar, select Glossary. The Glossary panel opens.

2 In the Glossary panel, against the glossary that you want to rename, choose Options ( ) > Rename.

3 In the Rename Glossary dialog box, specify the new name and click Done.

Note: 

If you rename any glossary term, RoboHelp simultaneously updates all references in the Topic content.

Delete a glossary
You can delete a glossary file from the Glossary panel in RoboHelp. To do this:

1 In the Author toolbar, select Glossary. The Glossary panel opens.
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2 In the Glossary panel, against the glossary file that you want to delete, choose Options ( ) > Delete.

3 In the Confirm dialog box, click Yes to confirm the deletion.

Import a Glossary
You can import a glossary to your project from the Glossary panel in RoboHelp.

1 In the Author toolbar, select Glossary. The Glossary panel opens.

2 In the Glossary panel, click the  icon to add a new glossary file or, select an existing glossary.

3 Choose Options ( ) > Import against the glossary file (.GLO) in which you want to import the glossary.

4 The Import Glossary dialog box opens. Click  to browse and select the .GLO file you want to import.

An illustration of how to import Glossary (.GLO) file

5 For definitions in the external glossary to overwrite matching terms, select Replace existing glossary 
definitions. Unselect the check box to leave existing definitions in an existing glossary.

6 Select one or more terms in the Terms in Imported Glossary list, and then click Done.

Note: 

A .GLO file stores glossary terms created in the Adobe RoboHelp.

You can import glossary to your project from any glossary file (*.GLO) in RoboHelp Reimagined and RoboHelp 
Classic projects.

Export a Glossary
You can export a glossary to your project from the Glossary panel in RoboHelp.

1 Select the Glossary panel and choose the glossary file (.GLO) you would like to export.

2 With File Explorer open, select the location to browse to the folder where you want to export the glossary file. 
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3 Your glossary file is exported and saved as a .GLO file at the specified location.

Add a glossary term's definition in a topic
You can easily add a glossary term and its definition in the content of a desired topic. The term is then highlighted as a 
hyperlink in your topic. When you generate the output, your reader can click the term to view its specified definition, 
which displays as expanding text. To add a glossary term definiton in a topic, follow these steps:

1 In the Author toolbar, select Contents and open your desired topic.

2 In the Author toolbar, click Glossary. The Glossary panel opens with all glossary files.

3 Click  to expand the glossary file from which you want to add a term's definition.

4 Drag-and-drop a glossary term to an appropriate location in your open topic.

The term is highlighted as a hyperlink. In the project's output, a reader can click the highlighted term to view its 
definition. See Generate outputfor details on how to publish a project.

Use a desired glossary file in your output
Out of the several glossary files that you've created in a project, you can use one in your output. To specify which 
glossary goes into your output, follow these steps:

1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click Output Presets. 

3 In the Output Presets panel, select your desired output preset from the given options. You can choose from output 
presets options such as Responsive HTML5, Mobile App, Frameless, eBook, and more.

4 Select the Content tab.

5 In the Glossary field, select your desired glossary file from the drop-down list.

The selected glossary file is then included in your output. See Generate output for details on how to generate the 
output.

Create and manage browse sequences

What is a browse sequence
A browse sequence is a linear list of topics that helps your users to logically and easily move through a series of topics 
in the output. Use browse sequences to provide a path for your users to navigate to the previous or the next relevant 
topic.

When working with browse sequences, keep in mind the following:

• You cannot include topics from other projects in browse sequences.

• You can include a single topic in multiple browse sequences. 
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Add a browse sequence
To add a browse sequence:

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click Browse Sequences. The Browse Sequence panel opens.

3 Click  in the upper-right corner of the panel. The New Browse Sequence dialog box opens.

4 In the New Browse Sequence dialog box, specify the name of the browse sequence and click Create.

The new browse sequence is added to the Browse Sequence panel and placed in alphabetical order. 

5 Click the Save All icon  at the left side of the standard toolbar.

Edit a browse sequence
You can easily customize a browse sequence to suit your requirements. To edit a browse sequence:

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click Browse Sequences. The Browse Sequence panel opens.

3 In the Browse Sequence panel, against the browse sequence you want to customize, choose Options ( ) > Edit. 

The browse sequence editor opens. Use drag-and-drop to add topics or TOCs to the browse sequence editor. You 
can add a topic or a TOC before, in between, or after existing topics.

4 To add topics from the Contents panel:

a In the Author toolbar, click Contents.

b From the Contents panel, drag a topic and drop it in the browse sequence editor. To add a group of topics from 
a folder, drag-and-drop the folder. All the topics inside the folder, including subfolders, are inserted as a linear 
list.

To add topics from a TOC:

c In the Author toolbar, click Table of Contents. 

d From the Table of Contents panel, drag a TOC and drop it in the browse sequence editor. Topics from the TOC 
are inserted as a linear list. You can also expand a TOC from the Table of Contents panel, and drag-and-drop 
individual books or pages.

5 Manage topics in the browse sequence editor:

• To change the sequence of topics, use drag-and-drop.

• To delete a topic, click  against it or right-click the topic, and click Delete.

• To delete all topics in the browse sequence, right-click a topic and click Delete All.

6 Click the Save All icon  at the left side of the standard toolbar.

Rename a browse sequence
To rename a browse sequence:

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.
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2 In the Author toolbar, click Browse Sequences. The Browse Sequence panel opens.

3 In the Browse Sequence panel, against the browse sequence you want to customize, choose Options ( ) 
> Rename. 

4 In the Rename Browse Sequence dialog box, edit the name of the browse sequence and click Done.

5 Click the Save All icon  at the left side of the standard toolbar.

Delete a browse sequence
To delete a browse sequence:

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click Browse Sequences. The Browse Sequence panel opens.

3 In the Browse Sequence panel, against the browse sequence you want to delete, choose Options ( ) > Delete. 

4 In the Confirm dialog box, click Yes to confirm deletion.

5 Click the Save All icon  at the left side of the standard toolbar.

Include browse sequences in output
While defining an output preset, you can select multiple browse sequences. If several browse sequences have a common 
topic, RoboHelp gives precedence to browse sequences according to the alphabetical order of their names. So the topics 
before and after the common topic are picked from the browse sequence name with the highest alphabetical order.

For example, the topic Random is included in browse sequences A, B, and C. In this case, RoboHelp gives precedence 
to the order of topics in browse sequence A. In the output, RoboHelp shows the topics before and 
after Random from browse sequence A. 

Note: 

• Browse sequences are supported in Responsive HTML5, Frameless, and Microsoft HTML Help output types.

• You can include one or more browse sequences in Responsive HTML5 and Frameless output presets. 

• Microsoft HTML Help output presets automatically include all browse sequences available in a project. So in the 
output, from the list of browse sequences, you can select the one you want to use.

Microsoft HTML Help output: From multiple browse sequences, select one to use it.
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To include browse sequences in your output:

1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens. In the Output toolbar, Output Presets is the default selection.

2 In the Output Presets panel, double-click a preset to edit it, or choose Options ( ) > Edit.

3 In the siderail of the output preset, click the Content tab.

4 From the Browse Sequence drop-down list, select the browse sequence you want to add. 

The selected browse sequence is placed below the Browse Sequence drop-down list. To remove a selected browse 
sequence, click  on it.

5 Generate output.

The output contains navigation buttons according to the skin selected. Clicking these buttons navigate to the topics 
in the sequence defined in the selected browse sequences.

Work with See Also and Related Topics

About See Also and Related Topics
The See Also feature links a topic with related/associated topics through keywords. A keyword contains a group of 
associated topics. Linking a keyword to a topic also links the associated topics in the keyword to the topic. RoboHelp 
displays associated topics in preview mode and output through a control inserted in the topic or a master page applied 
to the topic.

You can link a keyword to multiple topics so that each topic displays the same set of associated topics from the linked 
keyword. You can also link multiple keywords to a topic so that the topic displays a combination of different sets of 
associated topics from each linked keyword.

If you modify the grouping of associated topics in a keyword, RoboHelp automatically updates all the topics linked to 
the keyword. If you modify the title of a topic in the project, RoboHelp automatically updates the title in all linked 
keywords.

Use the See Also feature to simultaneously manage related topics at a project level, that is, in multiple topics. If you want 
to manage related topics explicitly for an individual topic, use the Related Topics feature instead of the See Also feature.

Use the See Also feature
To use the feature, do the following:

1 Create and manage See Also keywords 

2 Associate topics to a See Also keyword

3 Link a topic to a See Also keyword

4 Insert the See Also placeholder in a master page or a topic

5 View associated topics

6 Apply styles to the See Also placeholder

7 Generate a See Also report

http://helpx.adobe.com/en/robohelp/using/generate-output.html#Generate%20_an_output
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Create and manage See Also keywords
To use the See Also feature, first create a See Also keyword. To do so:

1 In the Author mode, click See Also. The See Also panel appears.

2 In the See Also panel, click  to create a keyword.

3 In the New See Also Keyword dialog box, specify the name of the keyword.

4 Click Done.

The new keyword is placed in the See Also panel in alphabetical order of keyword names.

5 To manage See Also keywords, click  against a keyword or right-click a keyword and do the following:

• To rename a keyword, click Rename. In the Rename Keyword dialog box, specify the new name and click Done.

• To delete a keyword, click Delete. In the Confirm dialog box, click Yes.

6 Click  to save the changes.

Associate topics to a See Also keyword
While defining a keyword, add associated topics in the Associated Topics section. To do so:

1 In the Author toolbar, click See Also. 

2 In the See Also panel, click  against a keyword to expand it. 

3 To add an associated topic, click   against Associated Topics.

4 In the Add Associated Topic dialog box, locate the associated topic. Use the Search field or browse through 
the Contents or the Recently Used drop-down section. 

5 Select the associated topic. You can verify topic selection through the preview pane at the right side of the dialog box.

6 Click Link.

The associated topic is placed below Associated Topics in alphabetical order of the topic name. You can add 
multiple associated topics in a keyword.

7 To manage associated topics, do the following:

• To reorder a topic in the list of associated topics, click  and use drag-and-drop. 

• To remove a topic, click  against it.

8 Click  to save the changes.

Link a topic to a See Also keyword
You can link topics to keywords in two ways—through a topic’s properties or a keyword.

To link topics to keywords, do the following:

1 To link through a topic’s properties:

a From the Contents panel, right-click the appropriate topic and then click Properties.

b In the TopicProperties dialog box, expand the See Also drop-down section.

The Select Keyword drop-down list displays all keywords in a project.

c From the Select Keyword drop-down list, select the appropriate keyword. You can select multiple keywords.

The keywords appear below the Select Keyword field. To remove a keyword, click  against it.

Note: 
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After you link the topic to keywords, RoboHelp automatically displays the topic in each keyword in the See 
Also panel > expanded view of each keyword > Used In Topics section. 

2 To link through a keyword:

a In the Author toolbar, click See Also. 

b In the See Also panel, click  against a keyword to expand it.

c Click  against Used In Topics.

d In the Add Used In Topic dialog box, locate the topic to which you want to associate the keyword. Use 
the Search field or browse through the Contents or the Recently Used drop-down section.

e Select the topic. You can verify the topic selection through the preview pane at the right side of the dialog box.

f Click Link.

The topic is placed below Used In Topics in alphabetical order of the topic name. You can associate multiple 
topics with the keyword.

Note: 

After you link topics to the keyword, RoboHelp automatically displays the keyword in each topic in the Topic 
Properties dialog box > See Also drop-down section.

If a topic is linked to multiple keywords and each keyword contains a different group of associated topics, 
RoboHelp displays all associated topics from all keywords in the topic. For example, the topic Brochure is linked 
to two keywords–Sales and Marketing. The Sales keyword has associated topics A, B, and C and the Marketing 
keyword has associated topics X, Y, and Z. RoboHelp displays the associated topics A, B, C, X, Y, and Z in 
Brochure.

g To remove a topic, click  against it.

3 Click  to save the changes.

Note: 

If you want to explicitly insert specific related topics in an individual topic, Use the related topics feature. 

Insert the See Also placeholder in a master page or a topic
To view the associated topics linked to a topic, you must insert a See Also placeholder in the master page linked to a 
topic or the topic itself.

Note: 

To avoid having to insert the See Also placeholder in each topic in your project, you can insert it in the master page.

To insert the placeholder, do the following:

1 Open the master page from the Master Pages panel or the topic from the Contents panel.

2 Place the pointer at the appropriate location.

3 In the standard toolbar, click .

RoboHelp adds the See Also placeholder at the specific location.

4 To delete the placeholder, right-click anywhere in the placeholder and click Delete See Also. 
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5 Click  to save the changes.

View associated topics
To view the list of associated topics, you can preview the topic or Generate output. To preview the topic, click 
Preview  on the standard toolbar. In Preview mode and in the output, RoboHelp populates the See Also placeholder 
with associated topics from linked keywords. 

Apply styles to the See Also placeholder
You can apply various styles to the caption and topic list components in the See Also placeholder.

1 In the See Also placeholder, click the caption. 

In the Properties panel > General tab, the Type field shows See Also Caption.

2 Modify the caption, if required, in the Caption field. 

3 To the caption, apply styles from options in the General and Styles tabs:

• For information about the General tab, see General tab in Properties panel. Note that for See Also Caption, you 
can apply only Font, Alignment, and Background options.

• In the Styles tab, select Paragraph Styles from the styles drop-down list and and click a paragraph style to apply 
it.

4 In the See Also placeholder, click the topic list.

In the Properties panel > General tab, the Type field shows See Also List.

5 To the topic list, apply styles from options in the General and Styles tabs:

• For information about the General tab, see General tab in Properties panel. Note that for See Also List, you can 
apply only Font and Background options.

• In the Styles tab, select List Styles from the styles drop-down list and click a list style to apply it. 

Note: 

By default, the following styles are applied to different parts in a See Also placeholder:

• seealso-caption to a caption

• seealso-list to a list

• seealso-list-item to each list item

These styles are defined in your project's default style sheet (default.css). In a new project, you can control all aspects 
of See Also styling by copying new classes from default.css. 

6 Click  to save the changes.

Generate a See Also report
Use the See Also report to view information such as the list of See Also keywords in your project, the topics associated 
with each keyword, topic titles, and the folder in which the topic exists. You can also filter the report according to 
folders.

To generate a report, see Open a report. To customize a report, see Customize a report.

http://helpx.adobe.com/en/robohelp/using/generate-reports.html#Openareport
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Use the related topics feature
To use the feature, do the following:

1 Insert the related topics placeholder

2 Add topics to the Related Topics placeholder

3 View related topics

4 Apply styles to the Related Topics placeholder

Insert the related topics placeholder
To insert and manage related topics in each topic explicitly, insert the Related Topics placeholder in the topic. To do so:

1 From the Contents panel, open the topic in which you want to add related topics.

2 Place the pointer at the location in which you want to insert the placeholder.

3 In the standard toolbar, click .

RoboHelp adds the Related Topics placeholder at the specific location in the topic.

4 To delete the placeholder, right-click anywhere in the placeholder and click Delete Related Topics.

5 Click  to save the changes.

Add topics to the Related Topics placeholder
After you insert the Related Topics placeholder in the topic, the Type field in the Properties panel > General tab 
shows Related Topic List. You can now add related topics to the placeholder. To do so:

1 In the General tab, against Related Topics, click . 

2 In the Add Related Topic dialog box, locate the related topic you want to link to the topic. To do so, use the Search 
field or browse through the Contents or the Recently Used drop-down section.

3 Select the related topic. You can verify the topic selection through the preview pane at the right side of the dialog box.

4 Click Link.

The related topic is placed below Related Topics in alphabetical order of the topic name. You can add multiple 
related topics.

5 To manage related topics, do the following:

• To reorder a topic in the list of related topics, click  and use drag-and-drop. 

• To remove a topic, click  against it.

6 Click  to save the changes.

View related topics
To view the list of related topics, you can preview the topic or Generate output. To preview the topic, 
click Preview  on the standard toolbar. In Preview mode and in the output, RoboHelp populates the Related Topics 
placeholder with related topics added to the placeholder.
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Apply styles to the Related Topics placeholder
You can apply various styles to the caption and topic list components in the Related Topics placeholder.

1 In the Related Topics placeholder, click the caption.

In the Properties panel > General tab, the Type field shows Related Topics Caption.

2 Modify the caption, if required, in the Caption field. 

3 To the caption, apply styles from options in the General and Styles tabs:

• For information about the General tab, see General tab in Properties panel. Note that for See Also Caption, you 
can apply only Font, Alignment, and Background options.

• In the Styles tab, select Paragraph Styles from the styles drop-down list and click a paragraph style to apply it.

4 In the Related Topics placeholder, click the topic list.

In the Properties panel > General tab, the Type field shows Related Topics List.

5 To the topic list, apply styles from options in the General and Styles tabs:

• For information about the General tab, see General tab in Properties panel. Note that for Related Topics List, 
you can apply only Font and Background options.

• In the Styles tab, select List Styles from the styles drop-down list and click a list style to apply it. 

Note: 

By default, the following styles are applied to different parts in a Related Topics placeholder:

• reltopics-caption to a caption

• reltopics-list to a list

• reltopics-list-item to each list item

These styles are defined in your project's default style sheet (default.css). In a new project, you can control all aspects 
of Related Topics styling by copying new classes from default.css. 

6 Click  to save the changes.
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Chapter 7: Conditional content

What is conditional content
Conditional content helps organizations to single-source content efficiently to address various documentation 
purposes and audience needs. In Adobe RoboHelp, you implement conditional content by applying condition tags to 
your content. Condition tags enable you to generate output with content variations.

Role-based conditional content

Additionally, Manage tag groupshelp you group multiple related condition tags to provide relevant content to a focus 
group. You can use tag groups such as audience, platform, product, properties, and other custom groups. For example, 
use the audience group to provide targetted content to developers, administrators, and so on. Use the platform group 
to target operating system-related information to appropriate users, such as system requirements for Windows and 
Mac.

Common use cases
In RoboHelp, you can use condition tags to generate subsets of content from your project as needed. This way, you need 
not create multiple projects for different output types.

Here are some common scenarios in which you can use condition tags effectively:

• Customize content for output formats

Online documentation often contains elements that are not useful in a printed manual. You can mark these elements 
using a condition tag, for example, online-only, and exclude them from the printed manual. Alternatively, if your 
manual is a subset of your online documentation, you can apply a different condition tag, for example, print-only, to 
the topics and topic content that you want to include in the printed manual. When you generate your project, you can 
use the print-only or online-only tag as required.
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Output-based conditional content

• Target custom content for specific audiences

Sometimes, topics are specific to products, experience levels, or types of users. Using condition tags, you can target such 
topics for the right audience. This way, the content that an audience receives is relevant and clutter-free. For example, 
beginners get the content that’s relevant for them and their consumption experience is not suboptimized because of 
notes and tips that are relevant for advanced users.

Expertise-based conditional content

• Filter published content based on relevance

Sometimes, all published content may not be relevant to a set of your audience. Using dynamic content filters, you 
can provide your audience the ability to filter out irrelevant content from the output. For example, in a multi-locale 
travelogue, users can quickly filter content for specific locales, instead of having to read through or search the entire 
travelogue.

Locale-based conditional content
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High-level workflows
The end-to-end implementation of conditional content involves performing steps in both authoring and publishing 
workflows. Also, you can optimize and manage your conditional content.

1 Authoring workflow

2 Publishing workflow

3 Optimize and manage conditional content

Authoring workflow
1 Add a condition tag.

2 Apply a condition tag to topics, topic content, TOCs, and indexes.

3 To check tagged content, preview a topic with associated condition tags. 

Publishing workflow
1 Configure condition expressions and dynamic content filters.

2 Configure an output preset to generate conditional content.

3 Generate output using a configured output preset.

Optimize and manage conditional content
1 Manage condition tags.

2 Manage condition expressions and dynamic content filters.

3 Generate reports.

Create and apply condition tags
To implement What is conditional contentin your project, you need to add condition tags and apply the tags to your 
content. After applying the tags, you can preview tagged content to check if the applied tags are working as expected.

Add a condition tag
Adobe RoboHelp provides two default condition tags—Online and Print. You can add new tags and group a bunch of 
related tags using the Group field in the Define Condition Tag dialog box. For example, you can group the Beginners, 
Intermediate, Experts, Developers, Administrators, and EndUsers tags under the Audience group. You can also choose 
background and text colors to differentiate the tags, and the content to which the tags are applied. 

To add a new tag, do the following:

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click the Condition Tags icon. 

3 In the Condition Tags panel, click the New Tag icon ( ) in the upper-right corner.

4 In the Define Condition Tag dialog box, do the following:

a Choose the group in which you want to create a tag, from the Group drop-down list. For example, to tag 
audience-specific content, choose the Audience group.

http://helpx.adobe.com/en/robohelp/using/create-apply-condition-tags.html#Addaconditiontag
http://helpx.adobe.com/en/robohelp/using/create-apply-condition-tags.html#Applyaconditiontag
http://helpx.adobe.com/en/robohelp/using/create-apply-condition-tags.html#Previewatopicwithassociatedconditiontags
http://helpx.adobe.com/en/robohelp/using/configure-presets-conditional-content.html#Configureconditionexpressionsanddynamiccontentfilters
http://helpx.adobe.com/en/robohelp/using/configure-presets-conditional-content.html#Configureanoutputpresettogenerateconditionalcontent
http://helpx.adobe.com/en/robohelp/using/configure-presets-conditional-content.html?cq_ck=1533211022200#Generateoutputusingaconfiguredoutputpreset
http://helpx.adobe.com/en/robohelp/using/optimize-manage-conditional-content.html#Manageconditiontags
http://helpx.adobe.com/en/robohelp/using/optimize-manage-conditional-content.html#Manageconditionexpressionsanddynamiccontentfilters
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Note: 

If you upgraded to Adobe RoboHelp 2019 from an earlier version, all your previous tags are grouped under the 
Others group in the Condition Tags panel. This is because the previous versions of Adobe RoboHelp did not contain 
the Group field. Adobe recommends that you organize your tags under appropriate groups. To do so, drag-and-drop 
tags from the Others group to the appropriate group in the Condition Tags panel.

In the Condition Tags panel, groups (such as, Audience and Others) and tags (such as Developer and 
Adventure) under each group appear as shown in the image:

An illustration of how the condition tags appear

Note: 

You can also add a new tag group, and rename and delete existing tag groups. Check out the steps in Manage tag 
groups.

b Specify the tag name in the Name field. 

c In the Identify with area, select the background and text colors.

Background and text colors help differentiate multiple condition tags by highlighting the content chunks to 
which the tags are applied.

d Click Done.

The group and the condition tag appear in the Condition Tags panel.

Edit a condition tag
1 In the Condition Tags panel, expand the Group drop-down list. 

2 Double-click the condition tag set you want to modify. Alternatively, right-click a condition tag and choose Edit 
(  ).

3 In the Edit Condition Tag dialog box, modify the tag group, tag name, background, and text colors, as required.

4 Click Done. 

Note: 

All the references associated with the condition tag are updated to reflect the change, wherever applicable like Topic content, 
Condition Expressions, Dynamic Content Filters, and so on.
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Delete a condition tag
1 From the Condition Tags panel, right-click a condition tag and click Delete ( ).

2 In the Confirm dialog box, click Yes to confirm the deletion. The condition tag is deleted.

Select multiple condition tags
1 From the Condition Tags panel, right-click a condition tag and click Select Multiple.

2 Click on all the condition tags you want to select.

3 Right-click the condition tags and click Delete ( ).

Note: 

If the tags are renamed or deleted, their references are immediately reflected in the document content, wherever applicable 
like Topic content, Condition Expressions, Dynamic Content Filters, and so on.

Manage tag groups
You can add a tag group to the list of default tag groups. You can also rename and delete existing tag groups.

1 Choose File > Project Settings or press Ctrl+Shift+/.

The Project Settings dialog box opens. 

2 To manage tag groups, use the Tag Groups tab in the Project Settings dialog box. For more information, see Tag 
Groups.

3 Click Done to save the changes.

Note: 

All renamed or deleted condition tag occurrences are applied automatically to the topics.

Apply a condition tag
You can apply a condition tag to topics, topic content, TOCs, and indexes. Learn more here:

• Apply to a topic 

• Apply to a snippet 

• Apply to an index

• Apply to topic content

• Apply to a master page

• Apply to an index  

Apply to a topic
To learn how to work with topics to build your content in RoboHelp, see Work with topics and folders.

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click the Contents icon. 

3 In the Contents panel, double-click a topic to open it. 
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4 Apply a condition tag to the topic through the Apply Tags button, which is accessible in two ways:

• Option 1: 

In the Properties panel, click the Topic tab. Under Condition Tags > Topic-Level, click Apply Tags.

The Apply Condition Tags dialog box appears.

• Option 2:

In the Contents panel, right-click the topic, and then click Properties. In the Topic Properties dialog box, under 
Condition Tags > Topic-Level, click Apply Tags.
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The Apply Condition Tags dialog box appears.

5 In the Apply Condition Tags dialog box, do the following:

a From the left side of the dialog box, click the tag you want to apply. The selected tag and its group appear in the 
right side of the dialog box. From here also, you can remove a tag by clicking .

b Click Apply Tags to apply the selected tag.

The applied tag and its group appear under Condition Tags > Topic-Level in the Properties panel or the Topic 
Properties dialog box. 

6 To save the changes, click the Save icon in the standard toolbar.

Apply to topic content
To learn how to add content to your topic, see Add content to or edit a topic. 

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click the Contents icon. 

3 In the Contents panel, double-click a topic to open it. 

4 In Author view, select the content element to which you want to apply a tag. For example, select a paragraph.

http://helpx.adobe.com/en/robohelp/using/work-with-topics-folders.html#Addcontenttooreditatopic
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5 From the Author toolbar, click the Condition Tags icon.

6 From the Condition Tags panel, drag the condition tag that you want to apply and drop it anywhere on the selected 
content element in the topic. 

The content element is highlighted in the background and text colors of the condition tag applied.

In the Properties panel > Topics tab, under Condition Tags > Content-Level, the applied tag and its group appear.

7 To save the changes, click the Save icon in the standard toolbar.

Apply to a snippet
To learn about how to use and work with snippets in RoboHelp, see Single-source with snippets.

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click the Snippets icon. 

3 In the Snippets panel, expand and double-click a snippet to open it.

4 In Author view, select the snippet content to which you want to apply a tag.

5 From the Author toolbar, click the Condition Tags icon.

6 From the Condition Tags panel, drag the condition tag that you want to apply and drop it anywhere on the selected 
content in the snippet. 
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The snippet content is highlighted in the background and text colors of the condition tag applied.

In the Properties panel > Topics tab, under Condition Tags > Content-Level, the applied tag and its group appear.

7 To save the changes, click the Save icon in the standard toolbar.

Apply to a master page
To learn how to work with master pages in RoboHelp, see Work with master pages. You can apply condition tags to the 
header, topic, footer, breadcrumbs, and Mini TOC placeholders in a master page.

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 From the Author toolbar, click the Master Pages icon.

3 From the Master Pages panel, double-click a master page to open it. 

4 Select the content to which you want to apply condition tags.

5 To apply condition tags, do one of the following:

• Right-click the selected content, and click Apply Condition Tags. In the Apply Condition Tags dialog box, drag 
a condition tag from the left panel and drop it in the right panel. Click Apply.

• From the Author toolbar, click the Condition Tags icon. From the Condition Tags panel, drag the condition tag 
that you want to apply and drop it on the selected content. 

The selected content is highlighted in the background and text colors of the condition tag applied.

In the Properties panel > Topic tab, under Condition Tags > Content-Level, the applied tag and its group appear.

6 To save the changes, click the Save icon in the standard toolbar.

Apply to a Table of Contents
To learn how to work with Table of Contents (TOC) in RoboHelp, see Create and manage a Table of Contents.

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click the Table of Contents icon. 

3 In the Table of Contents panel, double-click a TOC to open it.

Note: 

If the TOC is blank, that is, elements inside the TOC are not visible, click the Auto-create ToC icon on the standard 
toolbar to create the TOC. Note that clicking the Auto-create ToC icon includes all the topics in your project.
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If you want to apply condition tags to selective pages, books, or TOC, click the Insert Page, Insert Book, or Insert TOC 
icons on the standard toolbar. Alternatively, click the Contents icon in the Author toolbar and from the Contents panel, 
drag-and-drop selective topics. 

4 Select a book or a page inside the ToC.

5 In the Properties panel, under Condition Tags, click Apply Tags.

The Apply Condition Tags dialog box appears.

6 In the Apply Condition Tags dialog box, do the following:

a From the left side of the dialog box, click the tag you want to apply. The selected tag and its group appear in the 
right side of the dialog box. From here also, you can remove a tag by clicking .

b Click Apply Tags to apply the selected tag.

In the Properties panel > Topics tab, under Condition Tags > Topic-Level, the applied tag and its group appear.

7 To save the changes, click the Save icon in the standard toolbar.

Apply to an index
To learn how to work with an index in RoboHelp, see Create and manage an index.

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click the Index icon. 

3 In the Index panel, right-click an index entry and click Apply Condition Tags.

The Apply Condition Tags dialog box appears.

4 In the Apply Condition Tags dialog box, do the following:

a From the left side of the dialog box, click the tag you want to apply. The selected tag and its group appear in the 
right side of the dialog box. From here also, you can remove a tag by clicking .

b Click Save to apply the selected tag.

5 To save the changes, click the Save icon in the standard toolbar.

Preview a topic with associated condition tags
You can preview the tagged elements in a topic to verify if the tagging is correct.

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click the Contents icon. 

3 In the Contents panel, double-click to open the topic that you want to preview.

4 To switch to Preview mode, click the Preview icon on the right side of the standard toolbar.

The preview mode opens and displays all tagged and untagged content. For example, the following image displays 
content tagged using three tags and untagged content.
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A Content tagged with the EndUser tag  B Content tagged with the Marketing tag  C Content tagged with the Sales tag  D Untagged content  

5 Select specific condition tags to check which content elements are tagged using the selected tags. For example, select 
the EndUser and Sales tags.

In the preview window, all content elements tagged with the selected tags (EndUser and Sales), and all untagged 
content remain. Content element tagged with the unselected tag (Marketing tag indicated by callout B in the Step 3 
image) is filtered out.

A Content tagged with the EndUser tag  B Content tagged with the Marketing tag is filtered out and not visible in the current image  C Content 
tagged with the Sales tag  D Untagged content  

6 Select the Highlight selected condition tags field to visually differentiate tagged (only the selected tags) and 
untagged content.

In the preview window, tagged content is highlighted in the respective background and text colors of the selected 
tags (EndUser and Sales). Untagged content is not highlighted.
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Configure output presets for conditional content
After you have implemented What is conditional content in your project, you need to add or configure condition 
expressions and filters that you want to use during publishing. Both condition expressions and dynamic content filters 
use condition tags for granular control over content. Then, configure the output preset from which you want to publish, 
to include the appropriate condition expressions and dynamic content filters. Next, generate the output for the 
configured output preset.

Configure condition expressions and dynamic content filters
• Configure a condition expression

• Configure a dynamic content filter

Configure a condition expression
Condition expression A condition expression controls the inclusion of tagged source content or its exclusion from the 
output. Depending on the condition tags used in an expression, the corresponding source content is included in the 
output. You can define various tag combinations in the expression using OR, AND, and NOT operators to customize 
the inclusion or exclusion of content in the output. Condition expressions are not published along with the source 
content and do not appear in the output.

1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click the Condition Expressions icon.

3 In the Condition Expressions panel, click the Add icon ( ).

4 In the New Condition Expressiondialog box, specify the name of the condition expression. Click Done.

The new condition expression is added to the Condition Expressions panel.

5 From the Condition Expressions panel, double-click to open the expression. 

The Condition Tags panel and the expression editor panel open.

6 From the Condition Tags panel, drag a tag and drop it in the expression editor panel.
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The tag is removed from the Condition Tags panel and appears in the expression editor panel as a condition.

You can drop multiple tags as required. You can drop a tag above, below, or in between multiple tags.

You can delete an expression by clicking the delete icon against it.

7 Against each condition in the expression editor panel, do one of the following:

• Select Include to add the tag in the expression. This action includes all source content associated with the tag in 
the output. 

• Select Exclude to exclude the tag from the expression. This action excludes all source content associated with the 
tag from the output.

8 To combine multiple conditions, use the AND and OR operators.

To ensure that the expression runs only when all conditions are met, use the AND operator between the conditions. 
Use the OR operator to let the expression run if one or more conditions are met. 

The following expression displays Developer or EndUser content for Canadian locale.

9 To save the changes, click the Save icon in the standard toolbar.

Configure a dynamic content filter
 A dynamic content filter controls the display of content in the output. Add a dynamic content filter and then customize 
it by adding condition tags. The filters are published along with the tagged source content. You can use dynamic filters 
to control the content that appears in the output. The resulting output will include only the topics and content that is 
either untagged or has the selected tags applied. The rest of the content which has some other tag applied will be 
hidden. Dynamic content filters facilitate quick retrieval and consumption of specific information, instead of having to 
go through the entire published content.

1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click the Dynamic Content Filters icon.

3 In the Filters panel, click the Add icon ( ).

4 In the New Filterdialog box, specify the name of the dynamic content filter. Click Done.

The new dynamic content filter is added to the Filters panel. The Condition Tags panel and the filter editor panel 
open. The filter editor displays the new dynamic content filter.

5 From the Condition Tags panel, drag a tag and drop it in the filter editor panel.

The tag is removed from the Condition Tags panel and appears in the filter editor panel along with its original 
group. 
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Filter editor panel

If you do not want the original group to appear with the tag, create a new filter group by clicking  in the filter 
editor panel.

A new filter group with the editable title New Group appears. Rename the title as required, for example, rename the 
title as Product.

From the Condition Tags panel, drag a tag and drop it under the new filter group in the filter editor panel. For 
example, drag-and-drop the Printer tag.

The Printer tag is removed from the Condition Tags panel and appears under the Product filter group without its 
original group Platform.

New filter groups

6 (Optional) If you added multiple condition tags and filter groups in the filter editor panel, you can use the drag-and-
drop method to reorder tags within and across filter groups. Similarly, you can also reorder filter groups.

Click the Drag icon against a tag or a filter group to drag it.

Drag icon

7 To provide your users the ability to select multiple filters across filter groups in the published output, select the 
Allow Multiple Selection field. This field is deselected by default to provide the ability to select only one filter from 
each filter group.

8 To provide your users the option to define dynamic filters without tag groups, deselect the User filters in groups. 
This field is selected by default. You can now change the previously defined filters to remove tag groups or add to 
tag groups.
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9 To save the changes, click the Save icon in the standard toolbar.

Configure an output preset to generate conditional content
To be able to generate conditional content, you must configure the appropriate output preset to use a specific condition 
expression and/or dynamic content filter.

1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click the Output Presets icon.

Note: 

Adobe RoboHelp provides several output presets that you can use to generate output as required. If you want to use an 
existing output preset, proceed to Step 3.

(Optional) If you want to create a new output preset for additional custom requirements, you can add a new output 
preset for one of the output preset types available in RoboHelp. For information about how to create a custom output 
preset, see Create an output preset.

After creating an output preset, it appears in the Output Presets panel. Now proceed to Step 3.

3 In the Output Presets panel, double-click an output preset to open it.

The output preset editor panel opens with General as the default selection. 

4 In the output preset editor panel, click Content. 

5 In the content editor panel, do the following:

• From the Condition Expression drop-down list, select a condition expression. By default, None is selected. 

• From the Dynamic Content Filter drop-down list, select a dynamic content filter. By default, None is selected. 

6 (Optional) You can edit the selected condition expression and dynamic content filter by clicking the respective Edit 
icon against it.

7 To save the changes, click the Save icon in the standard toolbar.

Generate output using a configured output preset
1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click the Output Presets icon.

3 In the Output Presets panel, select the configured output preset you want to publish with and click the Generate 
Preset icon ( ). 

Or, against the configured output preset you want to publish with, choose Options ( ) > Generate.

While the output is being generated, a progress bar appears against the output preset.

Adobe RoboHelp displays a message confirming successful output generation. It also intimates if publishing fails.

When you create a new project, by default, output files are saved in the outputs folder inside the user area:

<user_area>/Documents/My RoboHelp Projects/outputs/<folder_name>/<output_preset_name>. 

For example:
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C:/Users/jdoe/Documents/My RoboHelp Projects/outputs/Travel the Whirls/Responsive HTML 5.

Note: 

To change the output folder path of an output preset, do the following:

1 Against the output preset, choose Options ( ) > Edit. 

2 In the preset editor panel, select General. 

3 In the general editor panel, in the Output Path field, choose or type an alternative path. Choose an output path 
outside your main project folder.

4 To save the change, click the Save icon in the standard toolbar. 

The option to change the output folder path is available for all output presets, except for Mobile App.

5 To view the output, in the Output Presets panel, against the output preset you published with, choose Options 
( ) > View.

Depending on the output type, it opens in its default viewer. For example, responsive output opens in your default 
browser. Output generated for mobile app, however, opens in a dialog box:

Note: 

If you have generated the output in a previous session and if it exists in the system, you can view it anytime, irrespective 
of which session you are in.
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6 (Optional) To view the output log, in the Output Presets panel, against the output preset you published with, choose 
Options ( ) > View Log.

Note: 

Displays the log only if the output is generated (irrespective of success or failure) in the current session.

Note: 

The Output view in Output Preset Editor gives you quick actions on the standard toolbar to use Generate Preset ( ), 
View output ( ) and Publish ( ) icons.

Optimize and manage conditional content
Learn how to optimize What is conditional contentby managing condition tags, condition expressions, and dynamic 
content filters. Check out the steps to generate the conditions report.

Manage condition tags
You can add, edit, delete, and change the group of a condition tag.

1 In the Author toolbar, click the Condition Tags icon.

2 To add a tag, see Add a condition tag.

3 To edit a tag:

a From the Condition Tags panel, double-click the condition tag that you want to edit. Alternatively, right-click a 
condition tag and choose Edit.

b In the Edit Condition Tag dialog box, modify the tag group, tag name, and background and text colors as 
required.

c Click Done. Changes made to the condition tag are saved.

4 To delete a tag:

a From the Condition Tags panel, right-click a condition tag and click Delete. 

b In the Confirm dialog box, click Yes to confirm the deletion. The condition tag is deleted.

5 To change the group of a tag:

In the Condition Tags panel, tags (such as Developer and Adventure) and their respective groups (such as, 
Audience and Others) appear as shown in the image:

http://helpx.adobe.com/en/robohelp/using/create-apply-condition-tags.html#Addaconditiontag
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To change the group of a condition tag, drag it from its current group and drop it under the target group.

In the target group, the newly added tag is listed in alphabetical order.

6 To save the changes, click the Save icon in the standard toolbar.

Manage condition expressions and dynamic content filters
• Manage condition expressions

• Manage dynamic content filters

Manage condition expressions
1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click the Condition Expressions icon.

3 To add/configure an expression, see Configure condition expressions and dynamic content filters.

4 To edit an expression:

a In the Condition Expressions panel, do one of the following:

1 Double-click the expression.

2 Select the expression and choose Options ( ) > Edit.

a In the expression editor panel, do the following as required:

1 Add or remove condition tags.

2 Modify the operators - Include/Exclude and AND/OR. 

3 To rename an expression, in the Condition Expressions panel, select the expression and choose Options ( ) > 
Rename.

4 To delete an expression, in the Condition Expressions panel, select the expression and choose Options ( ) > 
Delete.

5 To save the changes, click the Save icon in the standard toolbar.

http://helpx.adobe.com/en/robohelp/using/configure-presets-conditional-content.html?cq_ck=1533211022200#Configureconditionexpressionsanddynamiccontentfilters
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Manage dynamic content filters
1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click the Filters icon.

3 To add/configure a dynamic content filter, see Configure condition expressions and dynamic content filters.

4 To edit a filter:

a In the Filters panel, do one of the following:

1 Double-click the filter.

2 Select the filter and choose Options ( ) > Edit.

a In the filter editor panel, do the following as required:

1 Modify filter groups.

2 Add or remove condition tags.

3 To delete a filter, in the Filters panel, select the filter and choose Options ( ) > Delete.

4 To save the changes, click the Save icon in the standard toolbar.

Generate the conditions report
For information about generating reports, including the condition tags report, see Generate reports.

http://helpx.adobe.com/en/robohelp/using/configure-presets-conditional-content.html?cq_ck=1533211022200#Configureconditionexpressionsanddynamiccontentfilters
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Chapter 8: Microcontent

Microcontent

Introduction to Microcontent
Microcontent is a small, bite-sized snippet of self-contained information delivered through Chatbots, Microhelp, and 
FAQs.

In addition to topic-based authoring, RoboHelp gives you the ability to create a new microcontent or repurpose your 
existing content, such as a specific portion of a topic, for use as microcontent, that can be easily digested by Artificial 
Intelligence (AI) applications.

In RoboHelp, it begins with the creation of Microcontent group, collection of intent, and corresponding response, such 
as question and answer. In short, Microcontent means small content authored for a specific entity, "Intent." User will 
define an intent; for example, What is Browse Sequence?, and define its response as a rich text content. The response 
text can be either authored or can be created using an existing topic content. The intent/response combination can help 
to spark the curiosity of the user. 

Uses of Microcontent
You can consider several types of content to be used as Microcontent, which is engaging, eye-catching and quick to take 
in. Having created Microcontent in RoboHelp, you can deploy it in a number of different ways for use within 
Chatbot,Search Snippet, FAQ, or Microhelp, and each one of them can be used in their own way to direct traffic to 
engage the audience. 

Chatbot Create response that can be integrated with any chatbot engine. For more details, see Configure output preset 
for Chatbot. 

Search Snippet Retrieve a concise response to the search query in Frameless output on the homepage and topic page. 
For more details, see Add FAQ page to Frameless output.

FAQ Create FAQ topic for Frameless output. For more details, see Configure a Frameless output preset and Add FAQ 
page to Frameless output.

Microhelp Create small file (HTML, JSON, XML, Text) that developers can access in an app, with or without links to 
the main help. This is very small in size and sit standalone on a server. This output does not require any phrase or 
keyword. For more details, see Configure output preset for Microhelp.

https://helpx.adobe.com/robohelp/using/generate-frameless-output.html#ConfigureaFramelessoutputpreset
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Understanding Intents
The term "Intent" is a piece of information intended to assist the user. It is all about what a reader uses when performing 
a search or interacting with, say a chatbot or something included in a FAQ page. It could be a possible question about 
the project which the user can query while performing a search or while interacting with the chatbot.

Let us understand this with an example:

Suppose the owner of a coffee shop has authored a project which imparts training to the new employees on how to brew 
coffee, and other drinks. The trainee will have the project's output with him in the form of a help website. If he wants 
to look up "how to make cappuccino," he will simply type it in the search box, and get the response about the query. 
So "how to make cappuccino" forms an intent. There is a concept of "Phrases," too. A Phrase is associated with an 
intent. Here, the phrases for "how to make cappuccino" can be 

1. how to prepare cappuccino.2. how to brew cappuccino. .. and so on;

basically, all the possible ways in which the question "how to make cappuccino" can be asked by the user.

Now, the intent described above can be used in the chatbot, can be enlisted as a FAQ, or as a search snippet in Frameless 
output.
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Create Microcontent Group
You can create multiple Microcontent groups to help organize your intents into different groups. To create a 
Microcontent Group, follow these steps:

1 Do one of the following:

• In the Author toolbar, select Microcontent. The Microcontent Group panel opens. 

• In the Author toolbar, select Contents. The Contents panel opens.

2 Do one of the following:

• In the Microcontent panel, click . The New Microcontent Group dialog box opens.

• In the Contents panel, right-click the folder or click  against it, and choose New > Microcontent 
Group. The New Microcontent Group dialog box opens.

3 In the New Microcontent Group dialog box, specify the Name of the Microcontent Group. The corresponding File 
Name is automatically added with .mc extension.

4 Click Done. 

The Microcontent Group is added to the Microcontent panel.

Create intent and response in the Microcontent panel
The Microcontent file opens in the authoring area, as a single row table, where you can add intent and response. Each 
intent that you create should become associated with a response.

How to add intents and responses

The left column "Intent" lets you create a new intent in a text form.      For example: "What are the Employee benefits?" 

Whereas, the right column "Response" lets you create rich content, and offers familiar options as topic creation, such 
as adding cross-reference, hyperlink, image, variable, snippet, and drop-down content.

Intent properties
An Intent can have multiple phrases defined to map to the same response. For example, What is Navigation 
Sequence w.r.t. What is Browse Sequence? An intent can have metadata like keywords for example, navigation, 
sequence, order, etc. for Browse Sequence intent. 

The Intent properties are shown on the right in the properties panel and represent the defining characteristics of an 
intent.

Name Displays the name of the intent added in the left column.

Phrases Add new alternative phrases for each intent that would have the same answer. Alternative phrases are very 
useful as it is impossible to predict the phrasing a user will use. Adding an alternate phrase improves the chance that 
the matching response is displayed for the end user, even though the main intent is not used.For example: "What are 
the Employee benefits" or "What are the advantages for employees" or "Employee welfare."
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Keywords Add tags and keywords associated with your content so that the user can use them in his search. Adding 
keywords is again very useful as the user might enter a word or two where the same information would be relevant.

ID You can enter IDs for use with the Microhelp output.

Condition Tags You can apply condition tags so that a particular intent within a group is not included when the output 
has the selected tag(s) applied.

Create response using existing topic content
You can create response to your intent by using an existing topic or snippet. To do so, follow the steps below:

1 In the Author toolbar, select Contents and open a topic of your choice from the Contents panel.

2 Select the required content in a topic and right-click. A context menu appears. 

3 Select Add to Microcontent from the context menu.

4 In the Add as Response dialog box, specify the Group and Intent. 

5 Click Apply.

The response gets added to the selected intent.

Generate Microcontent output
Before you generate your Microcontent output in RoboHelp, you need to create and configure an output preset. Once 
the output preset is ready, you can use the preset to generate the output in various forms such as, Chatbot, Microhelp, 
and FAQ.

Create a Microcontent output preset
To create an output preset in RoboHelp, follow these steps:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, click .

4 In the New Preset dialog box, specify the following:

Type Use the drop-down list to either select Chatbot, Frameless, or Microhelp preset type, as required.

Name Specify a name for the output preset.

5 Click Done.

You can access the output preset from the Output Presets panel in the Output toolbar. Alternatively, you can access 
the output preset in the Quick Generate dialog box of the authoring window.
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Configure output preset for Chatbot
You can use the following settings to configure the various settings of the Microcontent output preset for Chatbot:

General
Use the following options to specify basic output settings, such as title, Chatbot engine, output path, language,  and post 
generation script.

Link

Title Specify the title for the generated output.

You can use variables in the title. To do so, type Ctrl+1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, the value of the selected 
variable is picked from the variable set during output generation.

Chatbot Engine From the drop-down, select a Chatbot Engine. Currently, Chatbot output has connectors to allow 
Google Dialogflow integration.  

Output Path Specify a location for the output. To select a location, click  .  Ensure that the output path is NOT 
located inside the project folder. 

Language You can create chatbots in a number of languages to reach to a much broader audience. Specify this setting 
to create chatbot in one of the languages listed in the drop-down.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list. The .js files displayed in the list are from the Scripting folder of your RoboHelp app data.

Content
Use the following options to specify content-related output settings, such as Microcontent groups, condition 
expression, and variable set.

Microcontent Groups Use the drop-down list to select as many Microcontent Groups as you need, storing multiple 
intents/responses from the selected groups, hence resulting in various responses to the user's query.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or user base. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-
specific use of variables. For example, you can have different variable sets for generating output for customers and 
internal users.

Dialogflow
Use the following options to specify output settings, such as Client-info JSON and Embed Code.

Client Info JSON Specify the JSON file containing the credentials for Google Dialogflow agent. For Dialogflow 
Authentication setup, click on the note at the end for step-by-step guide to procure the Client Info JSON file .

Embed Code Copy-paste this code in the HTML Head section in which you want to render the chatbot.

Configure output preset for Microhelp
You can use the following settings to configure the various settings of the Microcontent output preset for Microhelp:

http://helpx.adobe.com/robohelp/using/
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General
Use the following options to specify basic output settings, such as output path, format, language, and post generation 
script.

Link

Output Path Specify a location for the output. To select a location, click  .  Ensure that the output path is NOT 
located inside the project folder. 

Format Specify the desired format for your Microcontent.

• HTML5 + CSS3 - Use to generate output in markup language with styling (for example, controlling the size of text, 
font type, background color, etc.).

• HTML5 - Use to generate output in markup language without styling.

• JSON - Use to generate output in JSON format.

• XML - Use to generate output in XML format.

• Text - Use to generate output in text format.

Language Specify this setting for adding language attribute in the content.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list. The .js files displayed in the list are from the Scripting folder of your RoboHelp app data.

Content
Use the following options to specify content-related output settings, such as Microcontent groups, condition 
expression, and variable set.

Microcontent Groups Use the drop-down list to select as many Microcontent Groups as you need, storing multiple 
intents/responses from the selected groups, hence resulting in various responses to the user's query.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or user base. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-
specific use of variables. For example, you can have different variable sets for generating output for customers and 
internal users.

Publish
Click Quick Generate  on the toolbar, select the desired output preset, and click Generate.

You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, 
click  next to the output preset to view the output. 

To publish all files, select Republish All and click . To view the publish log, in the Output Presets panel, against the 
appropriate output preset, choose  > View Publish Log.

Add FAQ page to Frameless output
You can author a group of Microcontents and then combine them to create FAQs. To add FAQ page in Frameless 
output, follow these steps:

http://helpx.adobe.com/robohelp/using/
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Quickly insert a Microcontent in the TOC by dragging it from the Contents panel and dropping it in the Table of 
Contents.

Or, follow these steps:

1 In the Author toolbar, select Table of Contents in which you want to add a Microcontent file.

2 Do one of the following:

• In the Table of Contents toolbar, click .

• Right-click in the Table of Contents editor and choose Insert Topic. 

3 In the Insert Topic dialog box, search for a Microcontent file of your choice. Click Done.

4 The Microcontent file is added as FAQs in your output.

An illustration of how the FAQ page looks

5 You can also retrieve a concise response to the search query in Frameless output on the homepage and topic 
page. Note: A response will be displayed as a snippet in search results if the searched words are present in the intent, 
phrases, or keywords of your intent.

Search snippets on Frameless homepage and topic page 
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Chapter 9: Review and Collaboration

Review and Collaboration
This article discusses how to build a collaborative content-centric workflow for live collaboration with reviewers and 
subject matter experts via secure cloud-based review. Create multiple stages in your review process, implement a 
workflow with various steps, each of them tailored to fit your needs. 

Using the online review platform, you can transform the best practices into a robust, scalable, and distributed process.

• Assign multiple reviewers to collaborate with a secure web-based environment.

• Easy controls for creating, sharing, participating in, and managing reviews.

• Experience browser-based collaboration in real-time from all the reviewers and subject matter experts.

Pre-requisites
To create or take part in an online review, you must set up your Adobe account to get started. The content that you share 
for review is stored in the cloud storage linked to your Adobe account. To successfully share content, you must install 
the Creative Cloud Desktop App on your system.

Note: 

For optimal performance, we recommend you to verify that the cloud storage is enabled in your account. 

The review workflow
Adobe RoboHelp facilitates synchronous collaboration and helps automate the process of getting feedback from 
the reviewers and subject matter experts on a shared topic.

The author can start a review cycle by selecting a set of topics from the project and creating a private or public web link 
for the same. The reviewers are invited to access the link to add annotations in the shared topic with their feedback. The 
author can then view the shared feedback, make requested changes, and then continue the cycle.

The workflow is divided into two stages:

• The author workflow, where new reviews are created while being assigned to the reviewers and SMEs.

• The reviewer workflow, where the peer review happens, as well as any revisions required by the author.

The author workflow
To develop the review process as friendly and efficient as possible, here are the steps which include the following stages:

Create a Review
To create a review in RoboHelp, follow these steps:

1 Click the Review tab in the standard toolbar. The Review tab opens.

https://account.adobe.com/
https://helpx.adobe.com/in/download-install/kb/creative-cloud-desktop-app-download.html
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2 The left toolbar in the Review tab displays the Active and Completed Review groups. These groups give you an 
overview of the entire shared topics in each queue.

Click the desired group to open its corresponding panel. The Active Reviews (selected by default) displays a list of 
ongoing reviews while the Completed Reviews displays a list of reviews that are completed.

A Review tab  B Active and Completed Reviews  

3 In the Active Reviews panel, click  to create a review.

4 In the Create Review dialog box, in the Review Title field, give the review a descriptive name. 

5 Click Done.

The review is created in the Active Reviews panel. 

You can use the right panel to help filter out the list of topics that you would like to add to the review. For details, see 
How review filters work. 

Select content for review
1 You can either select all the topics by selecting the top check box or just those you want. Once you have selected the 

topics to be reviewed, click the Share icon in the upper-right corner of the authoring screen.
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Select your topics for review

2 Click Create to upload your selected content to cloud storage and create a weblink for sharing.

Create a review link

3 Once a weblink is created for review, a chevron starts appearing in the left panel. You can now configure access for 
the same.

Share for review using private invites
1 To share the review with specified reviewers and SMEs, select the default access setting Invite Only. Once Invite 

Only access is configured for your weblink, anyone invited will be able to view the content.
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Invite only

2 In the Members tab, click on the Add People button to invite a new member to review. You can also specify multiple 
email addresses to send out invitations and include any message, if desired.

Click Invite. 

Share invites

3 All reviewers receive an email with the details of the review, message, and the URL link where they can click and 
post their responses.

4 To remove a reviewer, hover your cursor over the member's name and click Remove.
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Remove reviewers

Share for review using public link
1 To share the review with a wider audience, click the drop-down under Access Settings, and select Public. Once 

Public access is configured for your weblink, anyone having the link will be able to view your content. 

Public

2 You can enable the Require Password to add a layer of security to the shared public link, which will require that the 
participant enter the correct password to gain access to the shared topic.

The reviewer workflow
After you receive an invitation for review, open the link in a browser, and use the commenting tools to add comments, 
highlight text, insert text, and draw a shape. Multiple reviewers can contribute to the same version of a shared topic in 
real-time. Real-time comments mean you will know the instant your review is done. 

If the shared topic is protected by a password, you need to enter the password to view it. 

1 Click the review link to open the Review on your browser. You may be prompted to sign in to your account.

2 Click the chevron next to the shared topic in the left panel. Double-click to open the selected topic.
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Reviewer's screen

3 Under the Review tab, use the following annotation tools to provide feedback:

• Place a pin Allows you to insert comments on the topic. Every pinned comment is assigned a number. The 
comments in the comment panel reflect these numbers to identify the context of the comment.

• Highlight text Adds an annotation element to the shared topic. 

• Strikethrough text Indicates the deletion of the text with a horizontal line through the text.

• Insert text Adds some text.

• Draw a shape Draws a free format shape, such as traingle, rectangle, etc.

Click on the desired tool and annotate the chosen content in the center.

4 Click Submit.

How review filters work
When you create a review, you will see the entire list of the topics in your project, along with various filters and options 
for the columns displayed. To customize your selection, use the following options in the Filter panel on the right side 
of the screen.

• Author Filter the topics based on their Author name, provided in topics metadata.

• TOC Filters the topics based on the selected Table of Contents.

• Folder Filter files based on the folders present in the project.

• Modified After Filter files based on their last modified date time.

• Columns Choose among various columns that you want to see in the files list.

View feedback
To see the reviewer's comments, double-click on the desired topic to open it in the center. The comments are displayed 
in the right panel, along with the corresponding annotations in the center. You can choose to reply to any comments or 
make your comment. 
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View the reviewer's comments

Complete a review
The author can view the comments and mark the review as completed when done. To mark the review as completed, 
do the following:

1 In the Active Review panel, select the topic which is to be marked complete.

2 To mark the review as completed, right-click the review or click   against it, and click Complete.

3 The Active Review is then moved to Completed Reviews.
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Chapter 10: Translation

Translating content to multiple languages
RoboHelp enables you to localize your authored content with a fully integrated manual and machine translation 
workflow in more than 35+ languages. Read this article to learn how RoboHelp enables you to extend the reach of your 
content to the wider audience. 

Manual Translation RoboHelp content is exported to the industry-standard XLIFF format, which can be provided to 
Translation vendors. After the XLIFF content is translated, it can be imported into RoboHelp, creating a translated 
version of the original RoboHelp project.

Machine Translation To automate translation workflows, the translation service providers are integrated with 
RoboHelp for translating content into multiple languages. The translation provider translates a large amount of content 
using an automated translation system in real-time, and the translated content is automatically imported back once 
APIs translate the content.

To get started with translations, a Translation project should be set up. It requires specifying the target language, 
translation method (manual/machine translation), translation provider and the content to be translated.

RoboHelp automatically assigns a unique identifier to each project, and creates an association between the master 
(source) project and the child (translation) project. All actions of the translation management happen from the master 
project, even for the child projects. For more details on Project ID, see Create a project.

Create a Translation project
To create a Translation project in RoboHelp, follow these steps:

1 Open the RoboHelp project you want to translate.

2 Click the Translations  tab at the bottom side of the left toolbar.

3 The Translation panel opens.

4 Click  to add a new Translation.

5 In the new Translation dialog box, specify the following:

• Translation Language Select the target language into which the project content would be translated.

• Link an existing translated project Select this option if you already have the translated version of this project, 
then no new translation project is created in this case.

• Translation Project Location To select a location, click . You would need to select the RoboHelp project 
(.rhpj) or an empty folder location, depending on if you want to link to an existing project or not.

6 Click Done.

Manage Translation
Do one of the following to manage the Translation project:

• On the Translation panel, double-click the language. The translation editor opens on a separate editor tab.
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• Alternatively, right-click the language and choose Manage from the context menu. 

Quick start: Filter by specific tabs
With so much of content, it can be difficult to find what all files are required to be sent for Translation. RoboHelp 
manages to extract all the translatable content from all the files in order to reduce the user's workload. To manage the 
translation files in a better way, the following three tabs are available at the top right corner of the authoring screen. 

Depending on the selected tab, RoboHelp displays the filter options in the Filters panel. Let's take a closer look by 
clicking on the corresponding tab.

Configure translation-related properties
Configure translation-related properties in the properties panel to specify how to translate your content. The 
configuration includes the following information: 

Choosing the right translation type
Manual or Machine: Choosing the right translation type for your content.

• Translation type Use the drop-down list to choose among the two options :

• Manual Translation The content is sent to the translation vendor by the user in XLIFF file format for 
translation.    

• Machine Translation The translation provider performs the translation using machine translation in real-time.

Tab Description

Topics The Topics tab displays all the topics in your project, which include

• text from elements, titles, etc.

• captures all image alternate text (alt attributes)

Author The Author tab displays

• Master pages, which include text and graphic elements that will 
appear on all pages of your publication (for example, headers, 
footers, etc.)

• Glossary includes all the terminology from the content.

• Snippets include text from elements, titles, etc. and captures all 
image alternate text (alt attributes)

Output The Output tab displays

• Labels, which include description of each entry from 
the label file.

• Preset, includes the preset content, title, settings, and 
formatting from the preset file.

• Skin includes custom skin (skin.js) and title (title.js) 
from your skin files.

• Stop words, include the stop words list.

• Synonyms include alternative words in your project.

• Variables include values from your variable files.
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Translation Project Path
Click  to open the target path which the user chose while creating the translation project.

Applying Filters
RoboHelp includes a large set of filter configurations for the user to determine which files are to be translated. You can 
choose the authored content using provided filters to control the content to be translated in your project. To customize 
your selection, use the following options in the Filters panel:

• Translation status Filter files based on their translation status. The Master project maintains the status of 
translation and keeps a record of each translated file. The translation status of a file shows its translation state in the 
end-to-end workflow. Following is the list of status:

• Not Translated Indicates with a grey dot that the translation has not been initiated. This happens when you add 
new topics which are not part of the translated project yet.

• Out of Sync Indicates with a yellow dot that the source and the translated topics are not identical.

• For example, in the case of Machine Translation, if you update the source, the source content may no longer 
match the translation provided by the Machine Translation provider. If this happens, the Translation Status 
displays "Out of Sync."

• Missing Indicates with a red dot the files which are deleted at the destination translated project.

• In Sync Indicates with a green dot the files which are in sync with the ones in the translated project.

• Topic Status Filter the topics based on their topic status and select the filtered topics to send for translation.

• Author Filter the topics based on their Author name, provided in topics metadata.

• Folder Filter files based on the folders present in the project.

• Modified After Filter files based on their last modified date time.

• Columns Choose among various columns that you want to see in the files list.

Translating projects using Machine Translation
In the Translation Profile field, select the previously created Translation Profile.

1 Click the Translations  tab at the bottom side of the left toolbar. The Translation panel opens.

2 Choose Translation Type as Machine Translation in the Properties panel. Select an existing Translation Service API 
Profile or create a new one.

3 Select files among various categories e.g. Topics, Author, Output. You can also filter the files before selecting and 
sending for translation.

4 Click Machine Translate  from the standard toolbar. The Machine Translate dialog box opens.

5 The dialog box displays the topics to be sent for translation.

6 Click Ok.

Create profile for Machine Translation
1 Click Edit .

2 The Translation Profiles dialog box opens.

3 Click + to create a new profile.

• Name Shows the default profile name. Modify the name if required.



172
Translation

Last updated 7/13/2020

• Translation Provider API From the dropdown, select a Machine Translation API from the following. You can 
only select one provider when applying Machine Translation to the entire project.

• Google Translation API

• Yandex Translate API

• Microsoft Translator Text API

• Custom Provider API You would need to provide a custom script with API configuration. For more details, 
see Configure a translation framework for a service provider.

• API Key Enter the API key for the selected Translation Service API. The API key would be stored in the 
Credential Manager service of the OS the user uses.

• End Point Specify the endpoint for selected Translation Service API.

For information about API key and End Point, visit the provider's website.

4 Click Validate to verify that the credentials entered are correct and complete.

5 Click Save.

Translating projects with Manual Translation
Select Manual Translation in the Properties panel to indicate that the translation is to be performed manually.

1 Click the Translations  tab at the bottom side of the left toolbar. The Translation panel opens.

2 Choose Translation Type as Manual Translation in the Properties panel. 

3 Select files among various categories e.g. Topics, Author, Output. You can also filter the files before selecting and 
sending for translation.

Export to XLIFF
RoboHelp will export the selected files to XLIFF format, which can be sent to a translation vendor.

1 Click Export to XLIFF  from the standard toolbar. The Export to XLIFF dialog box opens.

2 The dialog box displays the files to be exported.

Click OK.

3 Select a location where you want to export the files as XLIFF. Note the export location for later use.

The exported files are exported at the selected location under <selected-location>/translations/<language-
code> as a <context-name>.xlf file. 

4 RoboHelp converts the selected files to XLIFF format. A separate .xlf file is created for each file.

5 After the export is completed, a success message "Export successful" is displayed at the right bottom of the screen.

Once you have successfully exported the files, you can share them with the Translation provider,  who will translate 
them as per the target language.

Import XLIFF
Once the translation vendor processes the exported XLIFF files, you can import them into the RoboHelp project.

1 Click Import XLIFF  from the standard toolbar. 

2 Navigate to the location where you have translated XLIFF files from the vendor. Select the folder which contains the 
translated XLIFF files.
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Note: 

The current project will not be changed during import, the imported files will be updated in the translation project.

3 The Import dialog box opens which displays the list of files to be imported in the translation project.

Click OK.

4 After importing, files are shown with In Sync status in the current project.

5 Only the XLIFF files exported in the current project would be imported, stray XLIFF files of other projects would 
be discarded during import, in case, the folder is a heterogeneous mix of multiple projects' XLIFF files. 

Note: 

Ensure all translation activities, including Export/Import XLIFF files, are managed from the Master project only.

Reviewing the translated content
After the translation job is completed, you can open the translated project to review the files translated by right-clicking 
on the translation file in the Translation panel.

Using Translate attribute
The translate attribute indicates whether the content of the element should be translated when the topic is localized, or 
whether to leave them unchanged. You may want to identify the content that should not be translated. 

Filter an element or text for translation based on translate attribute
1 In an open topic, select the text, or a block element like a paragraph, etc. and then click the Attributes tab in the 

Properties panel.

2 The Attributes options display three values:

• "default" If there is no attribute assigned to the parent, the default behavior would be "yes", and the content 
would be sent for translation.

• "yes" This attribute indicates that the element or selected text will be translated when the page is localized.

• "no" This attribute indicates that the element or selected text will not be translated.

3 Select the content for which you want to set up a translate attribute, and then choose among the available Attribute 
values.

4 Click Save.
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Configure a translation framework for a service provider
In addition to the pre-defined translation providers available out-of-the-box, you can also integrate your translation 
connector to serve your requirements.  

Using custom script for translation
To configure a custom provider, create a JavaScript file on the system. The file contains a function with return value an 
object. This returned object has a field “caller” and has a function of return type JavaScript Promise as its value.

(src_lng, tar_lng, text2translate, API_KEY, endpoint) => { 
//src_lang: source language 
//tar_lang: target language 
//text2translate: text to send for translation 
//API_KEY: API key from your service provider 
//endpoint: endpoint/API URL of your service provider 
//build your query  
var query:Function = //REST API goes here, which returns a Promise 
return { 

caller: query  
} 
}

caller (Function)
The function defined in the caller field of the returned object sends the REST API request over to the server using 
javascript "request" method, which returns a javascript Promise. Resolve/reject the Promise accordingly and finally 
return the translated text or in case of an error, throw an error.

Bing sample script file

(src_lng, tar_lng, text2translate, API_KEY, endpoint) => { 
   const uuidv4 = require('uuid/v4'); 
 const request = require('request'); 
var api_request_fn = () => { 

// return a promise because sending and receiving translated text is asynchronous 
procedure 
           return new Promise((resolve, reject) => {  

var request_data = { 
           method: 'POST', 
           baseUrl: endpoint, 
           url: 'translate', 
           qs: { 
             'api-version': '3.0', 
             'to': [tar_lng] 
           }, 
           headers: { 
             'Ocp-Apim-Subscription-Key': API_KEY, //your API key goes here 
             'Content-type': 'application/json', 
             'X-ClientTraceId': uuidv4().toString() //give an ID to your request 
           }, 
           body: [{ 
                 'text': text2translate //send the text to translate as a part of the body 
           }], 
           json: true, 
       }  
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// the structure of request_data is different for every service provider 
// look up the documentation provided by your translation service provider  
// to build the request data. 

               request(request_data, function(err, res, body) {  
// read about request method here https://www.npmjs.com/package/request 

                   if(err) {// in case of an error reject the promise, it will exit the 
translation process 
                       reject({body, err, res}) 
                   } else {// in case of a valid response from the server, resolve the promise 
                       resolve({body, err, res}) 
                   } 
               }) 
           }).then(data => { 
               if(data.body.error) { 

// in case error from the server is send as part of the body  
// and skipping the previous if block in request, handle it here  

                   throw new Error(data.body.error.message); 
// throw the error with the message you want to show,  
// preferably the error message sent by the server 

               } else { 
                   return data.body[0].translations[0].text  

// return the translated text here, in this case it is in the data at  
// the specified location. The location in the data object varies with the 

provider 
               } 
           }) 
       } 
}

We discussed Bing translate API builder in the above example, notice that google and yandex have different handlers 
than the Bing. Build this function according to the specifications provided by your service provider.

We strongly recommend to check out samples in your RoboHelp installation directory:  
 "resources/data/template/translation/bing/profile_builder.js""resources/data/template/translation/google/profi
le_builder.js""resources/data/template/translation/yandex/profile_builder.js"

Note: 

1 When customers use these translation features, the data is submitted to the vendor for the purpose of processing. 

2 The use and processing of that data is governed by the customer’s contract with the vendor and the vendor’s privacy 
policy, and Adobe is not responsible for the vendor.

Create a custom integration profile
1 Navigate to Translation Profiles. For details, see Create profile for Machine Translation.

2 Click + to create a new profile.

3 In the Translation profile dialog box, provide the details for API key, Endpoint & Custom Script Path. 

4 Click Validate to verify that the credentials entered are correct and complete.

5 Click Save.

http://helpx.adobe.com/en/robohelp/using/translation.html#TranslatingprojectsusingMachineTranslation
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Chapter 11: Skins and master pages

Work with skins

What is a skin
A skin in RoboHelp helps you alter and customize the look and feel of your Help system before publishing it. You can 
customize a skin by changing colors, buttons, fonts, icons, logos, and background of your output. Whether it is 
Responsive Html5 or Frameless that you want to publish, RoboHelp provides several predefined skins in the Skins 
panel of the publishing window. You can apply one of these predefined skins as it is or edit it to achieve the preferred 
output layout.

Add a skin
You can add a skin in the Responsive HTML5 or Frameless format. To add a skin, do the following:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Skins icon .

3 In the Skins panel, click New Skin . From the drop-down menu, click one of the following options:

• New Frameless Skin To add a Frameless skin. The New Frameless Skin dialog box opens.

• New HTML5 Skin To add a Responsive HTML5 skin. The New Responsive HTML5 Skin dialog box opens.

4 In the New Frameless Skin or the New Responsive HTML5 Skin dialog box, select a predefined template in the 
Templates section. You can preview the selected template in the Preview area.

5 In the Name field, modify the default name of the predefined template, if required.

6 Click Done.

The new skin is added to the Skins panel and placed in alphabetical order of skin names. RoboHelp also opens the 
skin editor as a tab.
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Edit a skin
You can easily customize a skin to suit your liking. To edit a skin, follow these steps:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Skins icon .

3 In the Skins panel, against the skin you want to customize, choose Options ( ) > Edit. 

RoboHelp opens the skin editor as a tab. The skin editor comprises a live skin preview on the right 
and the Layout panel on the left side.

In a Responsive HTML5 or Frameless skin, a toolbar above the skin editor allows you to do the following:

• Desktop icon (Default layout) Displays your content in the desktop view. 

• Phone icon Displays your content in the phone view. 

• Tablet icon (Not available in Frameless) Displays your content in the tablet view.

• Toggle highlight icon Toggles the highlighting of skin components in the skin editor.

The skin components and its settings vary according to the type of skin view (desktop, phone, or tablet) you select.

4 In the Layout panel, click a skin component on the left to set your preferences for the component.

On clicking a skin component, RoboHelp displays its current settings and highlights the component in the output 
preview tab. For example, in Responsive HTML5, clicking Filter displays its current settings and highlights the 
Filter icon and area in the output preview tab.

5 In Frameless skin, in the Home Page or the Topic Page panel, click a drop-down section and select a component to 
set its styling properties (font, alignment, border, layout, and background) on the right panel. 

6 Specify the preferred settings for each skin component as required, and click the Save icon in the standard toolbar 
of the publishing window.

RoboHelp applies the new skin settings to your content and displays it in the output preview tab.

Rename a skin
You can rename any skins in your project.

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Skins icon . The skins in your project are displayed.

3 In the Skins panel, against the skin you want to rename, choose Options ( ) > Rename, or alternatively, press F2.

4 In the Rename Skin dialog box, type a new name for the skin and click Done. The skin is renamed.

The renamed skin is placed in the alphabetical order in the Skins panel.

Note: 

The new name of the skin is automatically reflected in all the Output Presets, that use the skin.

Upgrade a skin
When you upgrade RoboHelp Classic projects, RoboHelp automatically upgrades all Responsive HTML5 skins. If you 
customized skins outside the RoboHelp Classic skin editor, use the Layout component in the Layout panel 
in RoboHelp 2019 to add a custom JavaScript or CSS file.
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To add a custom JavaScript/CSS file, do the following:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Skins icon .

3 In the Skins panel, against the skin you want to customize, choose Options ( ) > Edit. 

4 In the Layout panel at the left side of the skin editor, click the Layout component.

5 Under the User Assets drop-down section, click Add Asset. 

6 In the Open dialog box, navigate to choose a JavaScript/CSS file and click Open.

The file gets added to the User Assets drop-down section. You can add multiple such files.

7 Click  against a file and use drag-and-drop to change its order in a list of files. 

Click  to delete a file.

Import a skin
To import a skin, do the following:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Skins icon .

3 In the Skins panel, choose New Skin ( ) > Import. 

4 In the Import Skin dialog box, click  to navigate to the skin (.skz or .slz file) you want to import, and then click 
Open. The selected skin appears in the Skin File field. Click Done to import the skin.

The selected skin is added to the Skins panel and placed in alphabetical order of skin names.

Note: 

• If you import a .slz file, which is a RoboHelp Classic file, it is upgraded automatically. For more information, 
see Upgrade a skin.

• If you are importing an Indigo skin and want to use the RoboHelp Classic layout format, select the Keep using 
older layout for the skin field in the Import Skin dialog box. 

Export a skin
To export a skin, do the following:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Skins icon .

3 In the Skins panel, against the skin you want to export, choose Options ( ) > Export. 

4 In the download dialog box, the Downloads folder in your computer is the default location to export a skin. You 
can navigate to a location of your choice, and then click Save.

The skin is saved to the chosen location.

Delete a skin
To export a skin, do the following:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Skins icon .
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3 In the Skins panel, against the skin you want to delete, choose Options ( ) > Delete. 

4 In the Confirm dialog box, click Yes to confirm the deletion.

The skin is deleted.

Locate a skin file in your computer
To see the location of a skin file in your computer, do the following:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Skins icon .

3 In the Skins panel, against the skin you want to locate, choose Options ( ) > Show in Explorer. 

Windows Explorer opens to display the skin file and its location.

Work with master pages

What is a master page
An HTML page comprises three elements: content, layout, and styling. For single sourcing, it is best to separate content 
from layout and styling. Although CSS files separate styling from content, layout remains embedded in the HTML 
code. By using master pages, you can separate layout and styling from content.

A master page contains layout information and is associated with a CSS file. A master page is a template for HTML 
topics. You can define the placeholders for header, footer, and topic. You can include breadcrumbs, Mini TOC, snippets, 
variables, fields, and symbols. You can also apply condition tags to a master page.

You can create a topic using a master page or associate an existing topic with a master page. When you create a topic 
using a master page, the topic placeholder content is placed in the resulting topic. If you apply a master page to an 
existing topic, the topic placeholder content is ignored. In this case, actual content of the topic replaces the topic 
placeholder in the master page at the time of preview and generation.

The layout information defined in master pages is not visible in Author view. You can see the layout when you generate 
output or preview an associated topic. The topic content is placed in the topic placeholder, and the layout is inherited 
from the master page. All placeholders defined in the master page are also populated with relevant information when 
you generate output. 

You can also import and export master pages to use across projects.

Add a master page
You can add a master page in two ways:

• From the Master Pages panel: When you add a master page using the Master Pages panel or upgrade to RoboHelp 
2019 from a previous version, by default, the master page files are stored in the assets/masterpages folder in 
the Contents panel.

• From the Contents panel: When you add a master page to a different project folder in the Contents panel, the 
master page files are stored in that project folder. 
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Irrespective of the location in which you add a master page, access and manage all master pages in your project from 
the Master Pages panel. 

To add a master page:

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 To add a master page through the Master Pages panel:

a In the Author toolbar, click Master Pages. The Master Pages panel opens.

b Click  in the upper-right corner of the panel.  The New Master Page dialog box opens.

To add a master page through the Contents panel:

c In the Author toolbar, click Contents. The Contents panel opens.

d In the Contents panel, right-click a folder, or click Options ( ), and choose New > New Master Page. 
The New Master Page dialog box opens.

3 In the New Master Page dialog box, specify the name of the master page and click Done.

The new master page is added to the Master Pages panel and placed in alphabetical order. 

4 Click the Save All icon  at the left side of the standard toolbar.

Edit a master page
You can easily customize a master page to suit your liking. To edit a master page:

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click Master Pages. The Master Pages panel opens.

3 In the Master Pages panel, against the master page you want to customize, choose Options ( ) > Edit. 

The master page opens as a tab, displaying the header, topic, and footer placeholders.

When you create a topic from a master page, the topic includes content from the master page. Copyright 
information is an example. When you apply a master page to a topic, actual content of the topic replaces the topic 
placeholder in the master page at the time of preview and generation.

4 Customize the header, topic, and footer placeholders as required by inserting breadcrumbs, variables, snippets, Mini 
TOC, fields, and symbols. You can also apply condition tags to the master page.

For more information, see the following resources:

• Insert breadcrumbs

• Insert variables

• Insert and customize a Mini TOC

• Insert a symbol

• Insert snippets

• Insert fields

• Apply to a master page

5 To insert a paragraph between placeholders, hover the pointer above the appropriate placeholder and click 
the Insert paragraph indicator.

http://helpx.adobe.com/en/robohelp/using/variables-fields.html#Insertavariable
http://helpx.adobe.com/en/robohelp/using/snippets.html#Insertasnippet
http://helpx.adobe.com/en/robohelp/using/fields.html#Insertafield
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Insert paragraph indicator

6 Click the Save All icon  at the left side of the standard toolbar.

Insert breadcrumbs
You can insert breadcrumbs placeholder in an open master page. The placeholder shows the automatically generated 
breadcrumbs at the time of generation of Help topic. The breadcrumbs are generated based on the TOC. 

1 In the standard toolbar, click the Insert Breadcrumbs Placeholder icon . The breadcrumbs placeholder is 
inserted at the location of the pointer.

Breadcrumbs placeholder

2 Click the breadcrumbs placeholder to set its properties.

The Properties panel > General tab displays the Type as Breadcrumbs. 

3 In the General tab, do the following:

Home Page Name Specify the name of the home page of your Help. 

Separator Specify or select a separator to separate the elements in breadcrumbs. The default is >.

Prefix Label Specify a label that is prefixed to the breadcrumbs. For example, Navigate to:.

4 Click the Save All icon  at the left side of the standard toolbar.

Insert and customize a Mini TOC
You can insert a Mini TOC in a topic or a master page. The Mini TOC placeholder shows the automatically 
generated Mini TOC at the time of generation or preview of a topic. You can define the exact location and format of 
the Mini TOC while designing the layout of the master page. You can also customize the heading levels as required. 

To insert a Mini TOC in an open topic or master page:

1 In the standard toolbar, click the Insert Mini TOC Placeholder icon . The Mini TOC placeholder is inserted at 
the location of the cursor.
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Mini TOC placeholder

2 Click the Mini TOC placeholder to set its properties.

The Properties panel > General tab displays the Type as Mini TOC Caption or Mini TOC List, depending on the 
location of the pointer. 

You can apply inline formatting using the General tab or a style from your style sheet using the Styles tab.

3 To apply inline formatting, in the General tab, do the following:

For Type: Mini TOC Caption

• Select Make list collapsible to toggle the Mini TOC between expanded and collapsed states. You can then 
specify a different caption for each state in the Caption when Expanded and Caption when Collapsed fields. 
By default, the mini TOC is in the expanded state initially, you can choose to collapse it by deselecting the Show 
TOC in expanded form field.

• If you do not select Make list collapsible, you can specify a default caption in the Caption field. 

• Use various Font options to change the font family, style, size, color, and more. 

• Use the Background options to change the background shade, and add and customize the dimensions of the 
background image. 

For Type: Mini TOC List

• In the Use Headings field, use the from and to drop-downs to customize the heading levels. The default range 
of heading levels is 2 – 4. You can include heading 1 also.

• Use various Font options to change the font family, style, size, color, and more. 

• Use the Background options to change the background shade, and add and customize the dimensions of the 
background image. 

4 To apply a style from your style sheet, in the Styles tab, do the following:

For Type: Mini TOC Caption

• Select Paragraph Styles or Hyperlink Styles from the styles drop-down list. If the Mini TOC list is not 
collapsible, the default caption style is paragraph. If the list is collapsible, the default caption style is hyperlink.

• From the list of styles, select a style to apply it.

Note: 

By default, the following styles are applied to different parts in a Mini TOC placeholder:

• minitoc-caption to a caption

• minitoc-list to a list

• minitoc-list-item to each list item
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These styles are defined in your project's default style sheet (default.css). In a new project, you can control all aspects of 
Mini TOC styling by copying new classes from default.css. You can also Add or edit twisty images to Mini TOC Caption 
when it is collapsible.

For Type: Mini TOC List

• Select List Styles from the styles drop-down list. 

• From the list of styles, select a style to apply it.

5 Click the Save All icon  at the left side of the standard toolbar.

Insert a symbol
You can insert a symbol in an open topic or master page. To do so, click the Insert Symbol icon  in the standard 
toolbar, and select a symbol from symbols displayed. The selected symbol is inserted at the location of the pointer.

Create a topic with a master page
While creating a topic, you can associate it with a master page. For more information, see Create a topic.

Associate a topic with a master page
You can associate an existing topic with a master page by editing the topic's properties. For more information, see Set 
topic properties.

Create a duplicate master page
You can create a duplicate copy of a master page with a different name and modify it to suit your requirements.

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click Master Pages. The Master Pages panel opens.

3 In the Master Pages panel, against the master page you want to duplicate, choose Options ( ) > Duplicate. 

4 In the Duplicate Master Page dialog box, specify the name of the duplicate copy and click Done.

The duplicate master page is added to the Master Pages panel and placed in alphabetical order. 

5 Customize the duplicate master page if necessary. For more information, see Edit a master page.

6 Click the Save All icon  at the left side of the standard toolbar.

Delete a master page
To delete a master page:

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click Master Pages. The Master Pages panel opens.

3 In the Master Pages panel, against the master page you want to delete, choose Options ( ) > Delete. 

4 In the Confirm dialog box, click Yes to confirm the deletion.

The master page is deleted. 

http://helpx.adobe.com/en/robohelp/using/work-with-topics-folders.html#Createatopic
http://helpx.adobe.com/en/robohelp/using/topic-properties.html
http://helpx.adobe.com/en/robohelp/using/topic-properties.html
http://helpx.adobe.com/en/robohelp/using/master-pages.html#Editamasterpage
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5 Click the Save All icon  at the left side of the standard toolbar.

Locate a master page file in your computer
To see the location of a master page file in your computer:

1 Click the Author tab at the left side of the Standard toolbar.

The Author view opens.

2 In the Author toolbar, click Master Pages. The Master Pages panel opens.

3 In the Master Pages panel, against the master page you want to locate, choose Options ( ) > Show in Explorer. 

Windows Explorer opens to display the master page file and its location.

Work with labels

What are labels
Labels are the display text of various elements of the Help system (output) generated for your end users. For example, 
the text in previous and next buttons in browse sequences, show/hide and other buttons, tabs, tool tips, and some 
messages. In PDF outputs, labels are the titles of TOC, index, and glossary pages. 

Any text in the output that does not come from your project content is picked from label files. A label file is language-
specific and contains labels grouped in various categories such as common, browse sequence, and master page. Each 
category lists the appropriate labels and its values. 

RoboHelp adds a label file in the default language, which is the same as your project language. You can edit the default 
language file to customize labels in the default language. To customize labels in a language of your choice, you can add, 
import, or export a label file and then edit it. For example, you can change the default text “Search” on the Search tab 
to “Find” in a language of your choice. 

Add labels
To add a label file in a language of your choice, do the following:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Labels icon .

3 In the Labels panel, click New Language . 

4 The New Language dialog box, choose the language in which you want to add labels from the Name drop-down list.

5 Click Done.

The new label file is named according to the chosen language. The file is added to the Labels panel and placed in 
alphabetical order of label names. RoboHelp also opens the labels editor as a tab. 

6 Click the Save All icon  at the left side of the standard toolbar.
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Edit a label file
You can easily customize labels to suit your liking. To customize labels:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Labels icon .

3 In the Labels panel, double-click to open the label file that you want to customize. Or, against a label file, 
choose Options ( ) > Edit. 

RoboHelp opens the labels editor as a tab. 

4 In the labels editor, click to expand a drop-down section. To customize a label in the drop-down section, edit its 
value.

5 Click the Save All icon  at the left side of the standard toolbar.

Delete a label file
To delete a label file:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Labels icon .

3 In the Labels panel, against the label you want to delete, choose Options ( ) > Delete. 

4 In the Confirm dialog box, click Yes to confirm deletion.

5 Click the Save All icon  at the left side of the standard toolbar.

Import a label file
To import a label file:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Labels icon .

3 In the Labels panel, against a label, choose Options ( ) > Import. 

4 In the Open dialog box, navigate to the label (.lng) file you want to import, and then click Open.

The selected label file is added to the Labels panel and placed in alphabetical order of label names.

5 Click the Save All icon  at the left side of the standard toolbar.

Export a label file
To export a label file:

1 Click the Output tab at the left side of the Standard toolbar. The Output view opens.

2 In the Output toolbar, click the Labels icon .

3 In the Labels panel, against the label file you want to export, choose Options ( ) > Export. 

4 In the Export dialog box, navigate to the location at which you want to export the label file, and then click Save.

Only the modified labels are exported to the chosen location. 

5 Click the Save All icon  at the left side of the standard toolbar.
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Chapter 12: Generating output

Generate output
RoboHelp comes with powerful publishing capabilities so you can generate your output in many formats. Choose from 
a variety of output preset types, such as Responsive HTML5, PDF, and Mobile App, and cater to users from various 
platforms. Output presets are easy-to-configure; you can use the many settings to create multiple Help systems from 
the same project with different content, layouts, and experiences.

With RoboHelp (2019 release), you can experience a smooth output generation, even as you continue working on your 
project.

Types of output presets
You can generate your project output using a desired type of output preset. The following types of output presets are 
available in RoboHelp:

• Generate Responsive HTML5 output

• Generate PDF output

• Generate Microsoft HTML Help output

• Generate Frameless output

• Generate Mobile App output

• Generate eBook output

• Generate Word Document output

• Generate Content Only output

Note: 

Microsoft HTML Help (.chm) is not supported on macOS.

Work with an output preset to generate output
Before you generate your project output in RoboHelp, you need to create and configure an output preset. Once the 
output preset is ready, you can use the preset to generate the output.

• Create an output preset

• Generate output

• Configure an output preset

• Generate output using a command-line utility
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Create an output preset
To create an output preset in RoboHelp, follow these steps:

1 In an open project, do one of the following:

• Click Quick Generate  in the upper-right corner of the Standard toolbar and click the Edit Settings icon .

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, click .

4 In the New Preset dialog box, specify the following:

Name Specify a name for the output preset.

Type Use the drop-down list to select a desired output preset type. You can choose from Responsive HTML5, PDF, 
Microsoft HTML Help, Frameless, Mobile App, and EBook.

5 In the Publish toolbar, select Output Presets.

6 Click Done.

You can access the output preset from the Output Presets panel in the Output toolbar. Alternatively, you can access 
the output preset in the Quick Generate dialog box of the authoring window.

Note: 

To identify the type of output preset from the Output Presets panel or in the Quick Generate dialog box, check the icon 
before the output preset name. The following icons correspond to the given types of output presets:

 Responsive HTML5

 Printed documentation

 Microsoft HTML Help 

 Frameless

 Mobile App

 EBook

Note: 

Creating an output preset for Microsoft HTML Help (.chm) does not show for Mac users.

Configure an output preset
To configure the settings of an output preset, follow these steps:

1 In an open project, do one of the following:

• Click Quick Generate  in the upper-right corner of the Standard toolbar and click the Edit Settings icon .

• Click the Output tab at the left of the Standard toolbar. 

2 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:

• Double-click the desired output preset.

• Click the  icon next to the desired output preset and select Edit.
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3 Based on the type of your output preset you had chosen, you can view tabs such as General, Content, and more to 
configure settings.

To know more about how to configure a type of output preset, see the following resources:

• Configure Responsive HTML5 output preset

• Configure PDF output preset

• Configure Microsoft HTML Help output preset

• Generate Frameless output

• Configure Mobile App output preset

• Configure EBook output preset

Note: 

The entire project is not included in the output generated. In the Contents tab > Table of Contents field, the 
selected Table of Contents determines what is included. That is, only the topics (and the referenced files inside these 
topics) in the selected Table of Contents file are included.

4 To save your settings, click Save All  icon in the upper-left corner of the standard toolbar.

Generate output
After configuring the required output preset, you can generate output.

To generate output, follow these steps:

1 In the authoring window of an open project, click Quick Generate  in the upper-right corner of the standard 
toolbar.

2 In the Quick Generate dialog box, select your desired output preset, and click Generate.

Note: 

Alternatively, you can do the following to generate output:

1 Click the Output tab at the left side of the Standard toolbar. 

2 In Output view, in the Output toolbar, click Output Presets.

3 In the Output Presets panel, select an output preset and click Generate Preset .  Or, against an output preset, 
choose Options  > Generate.

A progress bar displays the progress of output generation. To cancel output generation, click . After 
output generation is complete, to view the output, click . If the output generation is not successful, click  to 
view the error log. 

Note: 

Before generating output, you can also edit multiple output presets through the Quick Generate dialog box. To do so:

1 Select the output presets you want to edit, and click Edit. The preset editor for each output preset opens in Output 
view. 

2 Use tabs such as General, Content, and Layout to edit the properties of each output preset. 

3 Generate output using the Output Presets panel in Output view. Or, go back to Author view, open the Quick 
Generate dialog box, select the edited output presets, and click Generate. 

Note: 

http://helpx.adobe.com/en/robohelp/using/generate-responsive-html5-output.html#ConfigureaResponsiveHTML5outputpreset
http://helpx.adobe.com/en/robohelp/using/generate-pdf-output.html#ConfigureaPDFoutputpreset
http://helpx.adobe.com/en/robohelp/using/generate-microsoft-html-help-output.html#ConfigureaMicrosoftHTMLHelpoutputpreset
http://helpx.adobe.com/en/robohelp/using/generate-mobile-app-output.html#ConfigureaMobileAppoutputpreset
http://helpx.adobe.com/en/robohelp/using/generate-ebook-output.html#ConfigureanEbookoutputpreset
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Output generation takes place in the background, and simultaneously multiple outputs can be generated while you 
continue to use RoboHelp.

Generate output using a command-line utility
To generate output without launching the RoboHelp GUI, specify the following command in a command-line utility:

<path_of_Robohelp.exe> --cl "<project_path>" -o "<output_preset>" -l "<logfile_path>" -p "<output_path>"

Command description:

• path_of_Robohelp.exe Path of the RoboHelp executable file.

• --cl Launches RoboHelp in command-line mode.

• project_path Path of the project you want to generate.

• -o Includes output preset.

• output_preset Name of the output preset you want to use to generate output.

• -l or --log (Optional) Includes the log file argument.

• logfile_path If you include the log file argument, specify the path of the log file in which logs are generated. The log 
file must be in HTML format as logs are in HTML format.

• -p or --path (Optional) Includes the output path argument.

• output_path If you include the output path argument, specify the path at which you want to save the output 
generated. If you exclude this argument, RoboHelp generates output at the output path specified in the selected 
output preset's properties.

For example:

Robohelp.exe --cl "C:\\Latte.rhpj" -o "My Responsive Output" -l "C:\\logfile.html" -p "C:\\outputfolder"

Note: 

Enclose argument values containing spaces, for example, paths and output preset name, in double quotes.

Manage output presets
You can easily duplicate an available output preset or delete it from the Output Presets panel and the Quick Generate 
dialog box.

• Rename an output preset

• Delete an output preset

• Duplicate an output preset

• Locate an output preset file in your computer

Rename an output preset
1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, against the output preset you want to rename, choose Options  > Rename.

4 In the Rename Preset dialog box, specify the name of the output preset.

5 Click Done.
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Duplicate an output preset
1 Do one of the following:

• Click Quick Generate  in the upper-right corner of the standard toolbar and click the Edit Settings icon .

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, click Options  next to your desired output preset.

4 In the Options drop-down list, select Duplicate.

5 Specify Name of the duplicate output preset and click Done.

Delete an output preset
1 Do one of the following:

• Click Quick Generate  in the upper-right corner of the standard toolbar and click the Edit Settings icon .

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, select your desired output preset and click Options . 

4 In the Options drop-down list, select Delete. In the Confirm dialog box, click Yes.

Locate an output preset file in your computer
1 Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, against the output preset you want to locate, choose Options  > Show in 
Explorer  (Mac: Reveal in Finder).

The output preset file and its location is displayed in your computer.

Tips for optimal output generation
• Ensure that your system has sufficient memory. See RoboHelp system requirementsfor more details.

• To generate Mobile App output, you will require Internet connection.

Generate Frameless output

What is Frameless output
Frameless output can be viewed on the web or using a desktop application. This output type works with any browser 
and platform and provides several customization capabilities.
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Configure a Frameless output preset
The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various 
settings of the output preset. You can use the following settings to configure a Frameless output preset:

General
Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more:

Title Specify the title for the generated output.

You can use variables in the title. To do so, type Ctrl + 1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

The title, along with the variables if used, appears on the browser tab of the output.

Favicon Specify an icon to associate with the output. This icon appears on the browser tab of the output. Click  to 
browse and select a desired icon.

Output Path Specify a location for the output. To select a location, click  . 

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

Start Page Specify the page name and extension (.htm or .html) that RoboHelp can use to generate the URL for the 
output. For example, specify index.html.

Language Use the drop-down list to specify a language for the output preset if the language of the UI of the generated 
output needs to be different from the language of the content specified in project settings. 

Encoding Use the drop-down list to specify the type of character encoding format to be used for your content.

Use lowercase file names Select to generate all output files with lowercase filenames.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, 
glossary, and condition expression:

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output.

Browse Sequence Use the drop-down list to view the defined browse sequences in your project. You can select more 
than one browse sequence. The selected browse sequences are then merged for the output. If there is a conflict with the 
selected browse sequences, the first selection is given preference.

Default Topic Click  to select the topic that displays in the Topic panel when you open the output. By default, the 
first topic in the Table of Contents selected for this output is the default topic.

You can also select the default topic from the merged child projects. The list shown under the merged child projects is 
read from the selected TOC.
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Include Index Select this setting to include the index page in the output.

Glossary  Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to 
quickly retrieve the  relevant terms in your project, with the corresponding definitions.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or userbase. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Dynamic Content Filter Use the drop-down list to select a dynamic content filter so your end users can filter content 
in the generated output. Click  to edit the selected Dynamic Content Filter. Alternatively, select None in the drop-
down list to not specify a dynamic content filter.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can select 
<Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-specific 
use of variables. For example, you can have different variable sets for generating output for customers and internal 
users.

Map Files Use the drop-down to select a map file to use context-sensitive help. For more help, see Work with context-
sensitive help.

Layout
Use the following options to configure the appearance of your output:

Master Page Use the drop-down list to select the master page for the output you are generating.  

Skin Use the drop-down list to select a skin to apply in your output.

Show Thumbnail for Images Select this field to show thumbnail for images in output.

• Create Thumbnail for images Select this field to generate image thumbnails from existing images in the output. 
These images can be enlarged when the user clicks them.

• Style Existing Images as Thumbnails Select this field to style existing images as thumbnails in the output. These 
images can be enlarged when the user clicks them.

You can create a custom home page or topic page footer and apply it to the topics of your choice. The footer may 
contain any dynamic elements (snippets, variables, conditional tags, etc.) a topic may contain.

Home Page Footer Content  Click  to browse and select a topic (.htm) that you want to show as a footer on the 
home page. For example, specify README.htm.

Topic Page Footer Content  Click  to browse and select a topic (.htm) that you want to show as a footer on the topic 
page. For example, specify README.htm.

PDF to Download Click  to browse and select the PDF that you want the users to download when they click on the 
Download PDF button in the output.

Use skin home page Select this field to show the home page in your output.

Skin Home Page Content Click  to browse the topic that you want to show on the home page along with the Table 
of Contents tiles.

Search
Use the following options to specify search-related settings for your output:

https://helpx.adobe.com/in/robohelp/using/context-sensitive-help.htm
https://helpx.adobe.com/in/robohelp/using/context-sensitive-help.htm
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Use topic description as search context Select this setting to display the topic description with the title in search topic 
results. In Set a Character limit, enter the maximum number of characters to be displayed in the topic description. To 
set a topic description, right-click a topic in the Contents panel and select Properties. In the Topic Properties dialog 
box, enter the description in Description and click Apply.

Enable auto complete in search box Select this option to display predictive options for the search query based on the 
initial characters typed by users.  

Auto correct search query Select this option to correct misspelled terms that are typed during search. This setting 
corrects up to one character in each word typed during search. This ensures that you receive relevant search results, 
even if you enter a misspelled term.

Show definitions from glossary Select this option to display definitions of search terms from the  glossary selected for 
this output. If the search term matches a glossary term, the definition of the term is  displayed.

Generate XML sitemap Select this setting to generate a sitemap for your published output. The sitemap.xml file in the 
published output contains the sitemap. You can then submit this file to your search engine to improve search results for 
your site. To submit the sitmap.xml file, follow the procedure described in your search engine’s documentation. In Base 
URL of the hosted content, enter the relative URL of the site. In Frequency of content change, specify a cadence for 
indexing the content.

Select file types to exclude from search You can exclude specific types of files, such as PDF, Word, and Excel, from 
search. The content from the selected files will not be included during search.

Publish
You can publish your output to SharePoint Online and FTP, SFTP, or File System. To be able to publish your output, 
first configure a publish profile for the appropriate server type. For more information, see the following sections:

• Configure a publish profile for SharePoint Online 

• Configure a publish profile for FTP, SFTP, or File System

After you save the publish profile, RoboHelp displays the profile in the Publish tab. To publish your output, select the 
appropriate publish profiles and click .

By default, only modified files are published using the chosen publish profiles since the last publish.

To publish all files, select Republish All and click . To view the publish log, in the Output Presets panel, against the 
appropriate output preset, choose  > View Publish Log.

Generate Frameless output
1 In the authoring window of your project, click the Quick Generate icon  in the upper-right corner of the 

standard toolbar. Alternatively, select Quick Generate from the Output menu.

2 Select a Frameless output preset in the Quick Generate dialog box.

3 To configure the settings, do one of the following:

• Click the Edit Settings icon  in the Quick Generate dialog box.

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

4 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:

• Double-click the desired Frameless output preset.

http://helpx.adobe.com/en/robohelp/using/publish-sharepoint.html#ConfigureapublishprofileforSharePointOnline
https://helpx.adobe.com/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
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• Click the  icon next to the desired output preset and select Edit.

5 See Configure a Frameless output preset to configure the output settings.

6 To save your settings, click the Save icon  in the upper-left corner of the standard toolbar in the Output view.

7 Click the Generate Preset icon  in the Output Presets panel.

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the bottom-right corner of the screen.

After the output generation is complete, click  in the Output Presets panel to view the output.

Note: 

Alternatively, you can generate the output in the authoring window. Click Quick Generate  on the toolbar, select 
the desired output preset, and click Generate. 

You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, 
click  next to the output preset to view the output. In case the output generation failed, click  next to the selected 
output preset to view the error log.

8 To view the output in a selected browser, select View With and choose one of the browsers installed on your 
computer. The currently available browsers are listed in alphabetical order, for example, Google Chrome, Internet 
Explorer, and Mozilla Firefox. You can preview your output with any of the browsers installed on your 
computer. This View With option is also available in topic Preview mode in authoring.

Users would also be able to download and install any new browser. Whenever any new browser is installed, it starts 
appearing in the browser listing.

Generate PDF output

What is PDF output
Generating PDF output helps you distribute your project output to the users. Adobe PDF or Portable Document 
Format is a universal file format for viewing, sharing, and printing content. PDFs preserve fonts, images, and layout of 
content created with different applications and platforms. They are compact, easy to navigate with links, and effective 
in printing workflows.

Note: 

You need to download a PDF reader on your computer to view PDF files.

Configure a PDF output preset
The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various 
settings of the output preset. You can use the following settings to configure a PDF output preset:

General
Use the following options to specify basic output settings, such as output path, langauge, and more.

Output Path Specify a location for the output. To select a location, click  .  Ensure that the output path is NOT 
located inside the project folder. 

http://helpx.adobe.com/en/robohelp/using/generate-frameless-output.html#ConfigureaFramelessoutputpreset
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PDF File Specify the name and extension (.pdf) of the output file to be generated. For example, specify 
Printed_Documentation.pdf.

Language Use the drop-down list to specify a language. The selected language is then used for labels of Index, Glossary 
and hyphenation rules in your output.  Hyphens break words so that they wrap around to the next line. Specify this 
setting if you want to change the language specified in project settings. 

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list. The .js files displayed in the list are from the Scripting folder of your RoboHelp app data.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, 
referenced topics, condition expression, variable set, and including expanding and drop-down text.

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output. For book 
related features like front matter, back matter, etc., see Create and manage a Table of Contents.

Include All Referenced Topics Includes topics that are not part of the Table of Contents but are referenced from topics 
in the Table of Contents. Deselect this option to exclude the referenced topics in your Word Document output. All the 
referenced topics are grouped together and added to the end.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or user base. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-
specific use of variables. For example, you can have different variable sets for generating output for customers and 
internal users.

Include Expanding Text Select this option to include Expanding Text in your PDF output; otherwise, only the 
Expanding Text title goes into the output. With this option selected, the Expanding Text will be shown in the expanded 
form in the generated PDF.

Include Drop-down Text Select this option to include Drop-down Text in your PDF output; otherwise, only the Drop-
down Text title goes into the output. With this option selected, the Drop-down text will be displayed in the generated 
PDF.

Metadata
The metadata options such as title, author, subject, and keywords get included in the final PDF output.

Title Specify the title for the publication. 

You can use variables in the title. To do so, type Ctrl + 1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

Author Specify the name of the author for the publication.

Subject Specify the description of the publication.

Keywords Specify a list of keywords relevant to the publication. 

https://helpx.adobe.com/in/robohelp/using/table-of-contents.html
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Master Pages
Use the following options to apply certain content such as header, footer, styling, etc.

Common Master Page Select this option if you want the same master page to be applied to all topics in the output. For 
example, header content, footer content, styling, etc.

Specify separate master pages Select this option to associate multiple master pages to assign different headers and 
footers for Chapters & Topics, TOC, Index, Glossary, Front Matter Topics, and Back Matter Topics in your output.

First Page Specify a master page for the first page.

Apply to all pages Select this option to apply the master page chosen for the first page to even and odd pages. Deselect 
this option if you want to apply a different master page for even and odd pages.

Even Pages Specify a master page for the even pages.

Odd Pages Specify a master page for the odd pages.

Apply to all parts below  Click this option to apply same master pages across other parts below.

Note: 

 Front Matter and back matter master pages don't get applied to Index, Glossary or Coverpage inside them. They are only 
for the topics in the respective sections.

Note: 

If you do not select the Specify separate master pages field, common header and footer settings from the master page 
selected in the Common Master Page field get applied to all pages except the cover page.

Layout
Use the following options to specify the page specifications (size, orientation, margin settings etc.).

Page Size Use the drop-down list to select a desired page size for your output. You can choose from options such as A4, 
A3, Letter, and more. You can also select Custom to specify your own page width and page height (in mm (millimeters), 
px (pixels), in (inches), cm (centimeters), pt (points). By default, RoboHelp uses millimeters.

Orientation Select the orientation of the page (Portrait or Landscape).

Page Margin Specify the desired page margin (in mm (millimeters), px (pixels), in (inches), cm (centimeters), pt 
(points). Click to set different margins for all four sides and  to apply the same margin to all four sides.

 Specify the top page margin.

 Specify the left page margin.

 Specify the bottom page margin.

 Specify the right page margin.

View options Select any of the options to set a specific initial view of a PDF document that determines how the 
document displays when it is opened. It depends on the PDF viewer to honor these settings.

• Single Page View  (by default) - Displays one page at a time, with no portion of the next page displayed.

• Single Page Scrolling - Displays a single-page in a continuous vertical column.

• Two Page View - Displays two-page spread side-by-side at a time.

• Two Page Scrolling - Displays facing pages side-by-side with continuous scrolling.
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Zoom Select any of the options to resize the page view that determines how the document displays when it is opened.

• 100% - Makes the page appear in its actual size.

• Fit Page - Makes the page width and height to fit within the document pane.

• Fit Page Width - Makes the width of the page fill the width of the document pane.

• Fit Page Height - Makes the height of the page fill the height of the document pane.

Start each topic from a new page Select this option for each of your topics to start from a new page in the output.

Always start chapter from  You can opt to start your chapter always from New Page, Odd Page, or Even Page.

• New Page Starts the new chapter from an even-numbered or odd-numbered page.

• Odd Page Starts the new chapter on the next odd-numbered page.

• Even Page Starts the new chapter on the next even-numbered page.

TOC Structure

• Chapter names and topic titles  With this option selected, the structure of the generated TOC is based on the 
chapters and topics in the TOC.

• Use topic heading styles  With this option selected, the structure of the generated TOC is based on the heading 
styles, which by default is applied to heading 1. You can limit the number of levels shown in the generated TOC by 
adding the heading levels from heading 1 through heading 6.

Advanced
Use the following options to specify advanced print options:

Create accessible (tagged) PDF  Select this option to generate tagged PDF.  This makes it easier for screen readers to 
read and navigate a document, hyperlinks, bookmarks, and so on. For example, if a table is tagged, the screen reader 
will know that it is reading the table and not just lines and text.

Merge PDFs included in the TOC Select this option to merge existing PDFs into your output by adding them to your 
Table of Contents. The PDFs will be inserted at the location represented in the TOC and the pages will be incremented 
accordingly.

Create secure PDF Select this option to create a password protected PDF. The end users would then be prompted to 
provide the password in the text box when enabled.

Embed used fonts Select this option when using fonts that may not be installed on end user's machines. For fonts to 
work in PDF output, they must be installed on your machine building the output. With this option selected, the used 
fonts get embedded in the PDF, ensuring the user can see the PDF as intended even if the fonts are not installed on their 
machine.

Embed multimedia files Select this option to embed videos and other multimedia files to your output.

Note: 

A security warning appears when there is potentially unsafe active content (such as playing embedded multimedia, URL 
access, and so on) in the PDF you want to open. If you know and trust the sender, click Allow to download the external 
content.

Use image compression to optimize PDF size Select this option if you want to compress/reduce the size of an image, 
which can significantly reduce the size of the PDF if the project has lot of heavy images. Remember, the quality of the 
image reduces when you use compression.
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Use custom resolution (pixels per inch)  In HTML pages, the height and width of elements are calculated in pixels, 
and for PDF, the same is measured in inch. By default, 96 pixels are converted to an inch. Use this setting if you want 
to change that, setting a higher value will fit more content in an inch and will look smaller in PDF, and vice versa, if you 
set a lower value.

Use watermark Select this option to superimpose a watermark in your output. You can enter a new text string in the 
text box with the character casing the way you want.

Publish
You can publish your output to FTP, SFTP, or File System. To be able to publish your output, first configure a publish 
profile for the appropriate server type. For more information, see Configure a publish profile for FTP, SFTP, or File 
System.

After you save the publish profile, RoboHelp displays the profile in the Publish tab. To publish your output, select the 
appropriate publish profiles and click .

By default, only modified files are published using the chosen publish profiles since the last publish.

To publish all files, select Republish All and click . To view the publish log, in the Output Presets panel, against the 
appropriate output preset, choose  > View Publish Log.

Generate PDF output
1 In the authoring window of your project, click the Quick Generate icon  in the upper-right corner of the 

standard toolbar.

2 Select a PDF output preset in the Quick Generate dialog box.

3 To configure the settings, do one of the following:

• Click the Edit Settings icon  in the Quick Generate dialog box.

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

4 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:

• Double-click the desired PDF output preset.

• Click the  icon next to the desired output preset and select Edit.

5 See Configure a PDF output preset to configure the output settings.

6 To save your settings, click the Save icon  in the upper-left corner of the standard toolbar in the Output view.

7 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to view the output.

Note: 

Alternatively, you can generate the output in the authoring window. Click Quick Generate  on the toolbar, select 
the desired output preset, and click Generate.

You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, 
click  next to the output preset to view the output. In case the output generation failed, click  next to the selected 
output preset to view the error log.

http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
http://helpx.adobe.com/en/robohelp/using/generate-pdf-output.html#ConfigureaPDFoutputpreset
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Generate Responsive HTML5 output

What is Responsive HTML5 output
Generating Responsive HTML5 output makes your project output consumable on devices of various screen sizes. This 
means that you can publish content that is optimized to fit screens of popular devices, such as iPad, iPhone, and more.

Responsive HTML5 output can be viewed both online and offline. You can publish the output on HTTP and HTTPS 
servers. For information about supported browsers, see RoboHelp system requirements.

Configure a Responsive HTML5 output preset
The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various 
settings of the output preset. You can use the following settings to configure a Responsive HTML5 output preset:

General
Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more:

Title Specify the title for the generated output.

You can use variables in the title. To do so, type Ctrl + 1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

The title, along with the variables if used, appears on the browser tab of the output.

Favicon Specify an icon to associate with the output. This icon appears on the browser tab of the output. Click  to 
browse and select a desired icon.

Output Path Specify a location for the output. To select a location, click  . 

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

Start Page Specify the page name and extension (.htm or .html) that RoboHelp can use to generate the URL for the 
output. For example, specify index.html.

Language Use the drop-down list to specify a language for the output preset if the language of the UI of the generated 
output needs to be different from the language of the content specified in project settings. 

Encoding Use the drop-down list to specify the type of character encoding format to be used for your content.

Use lowercase file names Select to generate all output files with lowercase filenames.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, 
glossary, and condition expression:
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Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output.

Browse Sequence Use the drop-down list to view the defined browse sequences in your project. You can select more 
than one browse sequence. The selected browse sequences are then merged for the output. If there is a conflict with the 
selected browse sequences, the first selection is given preference.

Default Topic Click  to select the topic that displays in the Topic panel when you open the output. By default, the 
first topic in the Table of Contents selected for this output is the default topic.

You can also select the default topic from the merged child projects. The list shown under the merged child projects is 
read from the selected TOC.

Include Index Select this setting to include the index page in the output.

Glossary  Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to 
quickly retrieve the  relevant terms in your project, with the corresponding definitions.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or userbase. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Dynamic Content Filter Use the drop-down list to select a dynamic content filter so your end users can filter content 
in the generated output. Click  to edit the selected Dynamic Content Filter. Alternatively, select None in the drop-
down list to not specify a dynamic content filter.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can select 
<Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-specific 
use of variables. For example, you can have different variable sets for generating output for customers and internal 
users.

Map Files Use the drop-down to select a map file to use context-sensitive help. For more help, see Work with context-
sensitive help.

Layout
Use the following options to configure the appearance of your output:

Master Page Use the drop-down list to select the master page for the output you are generating.  

Skin Use the drop-down list to select a skin to apply in your output.

Show Thumbnail for Images Select this field to show thumbnail for images in output.

• Create Thumbnail for images Select this field to generate image thumbnails from existing images in the output. 
These images can be enlarged when the user clicks them.

• Style Existing Images as Thumbnails Select this field to style existing images as thumbnails in the output. These 
images can be enlarged when the user clicks them.

Search
Use the following options to specify search-related settings for your output:

https://helpx.adobe.com/in/robohelp/using/context-sensitive-help.htm
https://helpx.adobe.com/in/robohelp/using/context-sensitive-help.htm
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Use topic description as search context Select this setting to display the topic description with the title in search topic 
results. In Set a Character limit, enter the maximum number of characters to be displayed in the topic description. To 
set a topic description, right-click a topic in the Contents panel and select Properties. In the Topic Properties dialog 
box, enter the description in Description and click Apply.

Enable auto complete in search box Select this option to display predictive options for the search query based on the 
initial characters typed by users.  

Auto correct search query Select this option to correct misspelled terms that are typed during search. This setting 
corrects up to one character in each word typed during search. This ensures that you receive relevant search results, 
even if you enter a misspelled term.

Show definitions from glossary Select this option to display definitions of search terms from the  glossary selected for 
this output. If the search term matches a glossary term, the definition of the term is  displayed.

Generate XML sitemap Select this setting to generate a sitemap for your published output. The sitemap.xml file in the 
published output contains the sitemap. You can then submit this file to your search engine to improve search results for 
your site. To submit the sitmap.xml file, follow the procedure described in your search engine’s documentation. In Base 
URL of the hosted content, enter the relative URL of the site. In Frequency of content change, specify a cadence for 
indexing the content.

Select file types to exclude from search You can exclude specific types of files, such as PDF, Word, and Excel, from 
search. The content from the selected files will not be included during search.

Note: 

After you've configured an output preset, you can access it in the Quick Generate dialog box of the authoring window or 
in the Output Presets panel of the publishing window.

Publish
You can publish your output to RoboHelp Server, SharePoint Online, FTP, SFTP, or File System. To be able to publish 
your output, first configure a publish profile for the appropriate server type. For more information, see the following 
sections:

• Configure a publish profile for RoboHelp Server 

• Publish to SharePoint Online 

• Configure a publish profile for FTP, SFTP, or File System

After you save the publish profile, RoboHelp displays the profile in the Publish tab. To publish your output, select the 
appropriate publish profiles and click .

By default, only modified files are published using the chosen publish profiles since the last publish.

To publish all files, select Republish All and click . To view the publish log, in the Output Presets panel, against the 
appropriate output preset, choose  > View Publish Log.

Generate Responsive HTML5 output
1 In the authoring window of your project, click the Quick Generate icon  in the upper-right corner of the 

standard toolbar. Alternatively, select Quick Generate in the Output menu.

2 Select a Responsive HTML5 output preset in the Quick Generate dialog box.

3 To configure the settings, do one of the following:

• Click the Edit Settings icon  in the Quick Generate dialog box.

http://helpx.adobe.com/en/robohelp/using/robohelp-server.html#ConfigureapublishprofileforRoboHelpServer
https://helpx.adobe.com/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
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• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

4 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:

• Double-click the desired Responsive HTML5 output preset.

• Click the  icon next to the desired output preset and select Edit.

5 See Configure a Responsive HTML5 output preset to configure the output settings.

6 To save your settings, click the Save icon  in the upper-left corner of the standard toolbar in the Output view.

7 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to view the output. Alternatively, 
click the  icon next to the desired output preset and select View Output option. 

Note: 

Alternatively, you can generate the output in the authoring window. Click Quick Generate  in the toolbar, select the 
desired output preset, and click Generate. 

You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, 
click  next to the output preset to view the output. In case the output generation failed, click  next to the selected 
output preset to view the error log.

8 To view the output in a selected browser, select View With and choose one of the browsers installed on your 
computer. The currently available browsers are listed in alphabetical order, for example, Google Chrome, Internet 
Explorer, and Mozilla Firefox. You can preview your output with any of the browsers installed on your computer. 
This View With option is also available in topic Preview mode in authoring.

Users would also be able to download and install any new browser. Whenever any new browser is installed, it starts 
appearing in the browser listing.

Generate Word Document output

What is Word Document output
The Word Document output describes specifics of exporting a generated RoboHelp project to the DOCX format.

Note: 

Adobe RoboHelp does not require Microsoft Word installed on your machine to generate Word Document output.

Configure a Word Document preset
The first step in generating the Word Document output of a RoboHelp project is to create an output preset and then 
configure the various settings of the output preset. You can use the following parameters to configure a Word 
Document preset:

http://helpx.adobe.com/en/robohelp/using/generate-responsive-html5-output.html#ConfigureaResponsiveHTML5outputpreset
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General
Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more.

Output Path Specify a location for the output. To select a location, click  . 

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also, the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

Word File Specify the name of the output file to be generated. 

Language Use the drop-down list to specify a language for the titles of Index, Glossary, and Table of Contents in your 
output. Specify this setting if you want to change the language specified in project settings.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list. The .js files displayed in the list are from the Scripting folder of your RoboHelp app data.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, 
referenced topics, condition expression, variable set, and including expanding and drop-down text.

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output.

Include All Referenced Topics Includes topics that are not part of the Table of Contents but are referenced from topics 
in the Table of Contents. Deselect this option to exclude the referenced topics in your Word Document output.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or user base. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-
specific use of variables. For example, you can have different variable sets for generating output for customers and 
internal users.

Include Expanding Text Select this option to include Expanding Text in your Word Document output; otherwise, only 
the Expanding Title goes into the output. However, the Expanding Text will be shown in the expanded form in the 
generated PDF.

Include Drop-down Text Select this option to include Drop-down Text in your Word Document output; otherwise, 
only the Drop-down Title goes into the output. However, the Drop-down text will be displayed in the generated PDF.

Metadata
The metadata options such as title, author, subject, and keywords selected during the TOC creation get embedded in 
the final Word output.

Title Specify the title for the generated output.

You can use variables in the title. To do so, press Ctrl + 1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

Author Specify the name of the author of the topic.



204
Generating output

Last updated 7/13/2020

Subject Specify the description of the topic.

Keywords Specify a list of keywords relevant to your topic. This is useful for narrowing searches.

Layout
Use the following options to configure the appearance of your output.

Master Page Use the drop-down list to select the master page for the output. If the master page is selected, the style 
definitions are determined by the CSS (Cascading Style Sheets) of the master page and are reflected in the style-
mapping. If set to None, then the CSS styles are taken from CSS files used in the TOC topics.

Start each topic on a new page Select this option to start each topic on a new page in a Word Document. If this option 
is not selected, then page break occurs after the chapters specified in the TOC.

Word
With the style-mapping feature included in the Word Document output, users can map the format available in the 
selected Word Document or template.

Word template Specify the particular Word Document or template to map any RoboHelp style to Word style. To do 
this, click the  icon, select your Word Document or template.

Style Mapping By default, RoboHelp uses the styles specified in the selected word template. This section lists the in-
built Character Styles, Paragraph Styles, and Table styles from the CSS files (used in the TOC Topics or in selected 
Master Page) on the left, and the map-to styles from the word template on the right. You have the option to either

1 Use RoboHelp styles in the output Word Document.

2 Discard RoboHelp styles and use default Word styles, or

3 Map to any Word style from the template selected for mapping.

If you do not select any word template, only two options are displayed under Word Output - Use RoboHelp style and 
Discard style.

Note: 

If you select a Word Document or template, the header and footer settings from the chosen template are applied in your 
output. 

Preview The preview section shows the preview of both the styles, allowing the content to be viewed in advance.

Publish
You can publish your output to FTP, SFTP, or File System. To be able to publish your output, first configure a publish 
profile for the appropriate server type. For more information, see Configure a publish profile for FTP, SFTP, or File 
System.

After you save the publish profile, RoboHelp displays the profile in the Publish tab. To publish your output, select the 
appropriate publish profiles and click .

By default, only modified files are published using the chosen publish profiles since the last publish.

To publish all files, select Republish All and click . To view the publish log, in the Output Presets panel, against the 
appropriate output preset, choose  > View Publish Log.

http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
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Generate Word output
1 In the authoring window of your project, click the Quick Generate icon  in the upper-right corner of the 

standard toolbar.

2 Select a Word output preset in the Quick Generate dialog box.

3 To configure the settings, do one of the following:

• Click the Edit Settings icon  in the Quick Generate dialog box.

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

4 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:

• Double-click the desired Word output preset.

• Click the  icon next to the desired output preset and select Edit.

5 See Configure a Word output preset to configure the output settings.

6 To save your settings, click the Save icon  in the upper-left corner of the standard toolbar in the Output view.

7 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to view the output.

Note: 

Alternatively, you can generate the output in the authoring window. Click Quick Generate  on the toolbar, select 
the desired output preset, and click Generate.

You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, 
click  next to the output preset to view the output. In case the output generation failed, click  next to the selected 
output preset to view the error log.

Generate Content Only output

What is Content Only output
Content Only output generates all the data in raw form in Extensible Markup Language (XML) format. It helps in re-
purposing the content as per your needs. Topics are generated in XHTML format, TOC, browse sequence, Glossary, 
Index, and map files are generated in simple XML format, which is easy to parse and transform in any other form as 
needed.

Configure Content Only output preset
The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various 
settings of the output preset. You can use the following settings to configure a Content Only output preset:

http://helpx.adobe.com/en/robohelp/using/generate-word-output.html#Configureawordoutputpreset
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General
Use the following options to specify basic output settings, such as Title, Target, Output Path, Encoding, and more:

Title Specify the title for the generated output.

You can use variables in the title. To do so, type Ctrl+1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

Target Use the drop-down to specify the target to generate the selected output in Content Only.

Output Path Specify a location for the output. To select a location, click  . 

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

Encoding Use the drop-down list to specify the type of character encoding format to be used for your content.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, 
condition expression, variable set, and including expanding and drop-down text.

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or user base. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-
specific use of variables. For example, you can have different variable sets for generating output for customers and 
internal users.

Include Expanding Text Select this option to include Expanding Text in your Content Only output; otherwise, only 
the Expanding Title goes into the output. However, the Expanding Text will be shown in the expanded form in the 
output.

Include Drop-down Text Select this option to include Drop-down Text in your Content Only output; otherwise, only 
the Drop-down Title goes into the output. However, the Drop-down text will be displayed in the output.

Layout
Use the following options to configure the appearance of your output.

Master Page Use the drop-down list to select the master page for the output. If the master page is selected, the style 
definitions are determined by the CSS (Cascading Style Sheets) of the master page. If set to None, then the CSS styles 
are taken from CSS files used in the topics.

Note: 
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After you've configured an output preset, you can access it in the Quick Generate dialog box of the authoring window or 
in the Output Presets panel of the publishing window.

XHTML
Start Page  Specify the page name and extension (.xml ) that RoboHelp can use to generate the URL for the output. For 
example, specify default.xml.

Glossary Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to 
quickly retrieve the relevant terms in your project, with the corresponding definitions.

Include Browse Sequence Select this setting to create an alphabetical list of all the topics for online output. The browse 
sequence can help the users to "browse" through topics in a particular order.

Include Index Select this setting to include the index page in the output.

Include Map Files Select this option to include Map Files in your XML output. The .map files are used for defining the 
topics of a publication, specifying the topic sequence, and controlling linking between topics.

Publish
You can publish your output to FTP, SFTP, or File System. To be able to publish your output, first configure a publish 
profile for the appropriate server type. For more information, see Configure a publish profile for FTP, SFTP, or File 
System.

After you save the publish profile, RoboHelp displays the profile in the Publish tab. To publish your output, select the 
appropriate publish profiles and click .

By default, only modified files are published using the chosen publish profiles since the last publish.

To publish all files, select Republish All and click . To view the publish log, in the Output Presets panel, against the 
appropriate output preset, choose  > View Publish Log.

Generate Content Only output
1 In the authoring window of your project, do one of the following, click the Quick Generate icon  in the upper-

right corner of the standard toolbar.

2 Select Content Only output preset in the Quick Generate dialog box.

3 To configure the settings, do one of the following:

• Click the Edit Settings icon  in the Quick Generate dialog box.

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

4 In the Output toolbar, click Output Presets.  In the Output Presets panel, do one of the following:

• Double-click the desired Content Only output preset.

• Click the  icon next to the desired output preset and select Edit.

5 See Configure Content Only output preset to configure the output settings.

6 To save your settings, click the Save icon  in the upper-left corner of the standard toolbar in the Output view.

7 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible in the lower-right corner of the screen. 

http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
http://helpx.adobe.com/en/robohelp/using/generate-xml-output.html#ConfigureaXMLoutputpreset
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After the output generation is complete, click  in the Output Presets panel to view the output.

Note: 

Alternatively, you can generate the output in the authoring window. Click Quick Generate  on the toolbar, select 
the desired output preset, and click Generate. 

You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, 
click  next to the output preset to view the output. In case the output generation failed, click  next to the selected 
output preset to view the error log.

Generate eBook output

What is eBook output
In RoboHelp, you can use the eBook output preset type to generate your project output in EPub format.

Output generated in ePub or Electronic Publication file format can be viewed on devices like smartphones, tablets, 
computers, or e-readers with the compliant software. These files have the file extension .epub.

Configure an eBook output preset
The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various 
settings of the output preset. You can use the following settings to configure an eBook output preset:

General
Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more:

Output Path Specify a location for the output. To select a location, click  . 

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

EPUB file Specify the file name and extension (.epub) that RoboHelp can use to generate the output. For example, 
specify EmployeeCare.epub.

Language Use the drop-down list to specify a language for the titles of Index and Glossary in your output. Specify this 
setting if you want to change the language specified in project settings.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, 
glossary, condition expression, variable set, and including expanding and drop-down text.

Table Of Contents Use the drop-down list to select a desired Table of Contents to be included in the output. This drop-
down list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is 
selected by default.
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The set of files and their references present in the selected Table of Contents appear in the generated output.

Include Index Select this setting to include the index page in the output.

Glossary Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to 
quickly retrieve the relevant terms in your project, with the corresponding definitions.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or userbase. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets help you implement output-specific 
use of variables. For example, you can have different variable sets for generating output for customers and internal 
users.

Include Expanding Text Select this option to include Expanding Text in your Word Document output; otherwise, only 
the Expanding Title goes into the output. However, the Expanding Text will be shown in the expanded form in the 
generated PDF.

Include Drop-down Text Select this option to include Drop-down Text in your Word Document output; otherwise, 
only the Drop-down Title goes into the output. However, the Drop-down text will be displayed in the generated PDF.

Metadata
The metadata options such as title, author, publisher, rights, description, publication identifier, and publish date get 
embedded in the final output.

Title Specify the title for the generated output. 

You can use variables in the title. To do so, type Ctrl + 1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

Author Specify the name of the author of the eBook.

Publisher Specify the publisher of the eBook.

Rights Specify the publishing rights of the eBook.

Description Enter a brief summary of the eBook to help the user understand your content better.

Publication Identifier Specify the unique identifier of the eBook. This is a thirteen digit ISBN ID.

Publish Date Specify the date of publishing of the eBook in mm/dd/yy format. You can also click  to do this.

Layout
Use the following options to specify details of appearance in your output.

Common Master Page Select this option if you want the same master page to be applied to all topics in the output. For 
example, header content, footer content, breadcrumbs, etc.

EPub Validation
Use the following settings to validate your eBook output:

Validate EPUB3 Output Select this option to validate your output. This is necessary to successfully generate your 
desired eBook.
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EpubCheck Path Specify the EpubCheck path of your output. Click  to do this. You can also click Go to EpubCheck 
download page to view and download the .zip file. You can then provide the path of the unzipped file.

Publish
You can publish your output to FTP, SFTP, or File System. To be able to publish your output, first configure a publish 
profile for the appropriate server type. For more information, see Configure a publish profile for FTP, SFTP, or File 
System.

After you save the publish profile, RoboHelp displays the profile in the Publish tab. To publish your output, select the 
appropriate publish profiles and click .

By default, only modified files are published using the chosen publish profiles since the last publish.

To publish all files, select Republish All and click . To view the publish log, in the Output Presets panel, against the 
appropriate output preset, choose  > View Publish Log.

Generate eBook output
1 In the authoring window of your project, click the Quick Generate icon  in the upper-right corner of the 

standard toolbar.

2 Select an eBook output preset in the Quick Generate dialog box.

3 To configure the settings, do one of the following:

• Click the Edit Settings icon  in the Quick Generate dialog box.

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

4 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:

• Double-click the desired eBook output preset.

• Click the  icon next to the desired output preset and select Edit.

5 See Configure an eBook output preset to configure the output settings.

6 To save your settings, click the Save icon  in the upper-left corner of the standard toolbar in the Output view.

7 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to view the output.

Note: 

• To view the output, you require Adobe Digital Edition installed on your computer. To download Adobe Digital 
Edition, see Download Adobe Digital Edition.

• Alternatively, you can generate the output in the authoring window. Click Quick Generate  on the toolbar, 
select the desired output preset, and click Generate. You can then view a progress bar in the Quick 
Generate dialog box. After the output generation is complete, click  next to the output preset to view the 
output. In case the output generation failed, click  next to the selected output preset to view the error log.

https://code.google.com/archive/p/epubcheck/downloads
https://code.google.com/archive/p/epubcheck/downloads
http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
http://helpx.adobe.com/en/robohelp/using/generate-ebook-output.html#ConfigureaneBookoutputpreset
https://www.adobe.com/solutions/ebook/digital-editions/download.html
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Generate Microsoft HTML Help output

What is Microsoft HTML Help output
Generating Microsoft HTML output in RoboHelp helps you create in-app Help for Windows desktop apps.   

The main components of HTML Help include the following:

• Compressed HTML: A collection of all files in the project in a single CHM file that occupies less disk space and is 
faster to load. You can ship this compiled file with an application or distribute it to users as a stand-alone online 
document.

• HTML Help viewer: Displays compiled HTML Help (CHM file). It uses components of the Internet Explorer 
browser while displaying content in its proprietary window interface.

• Layout engine: Microsoft Internet Explorer 6 and later supply the required components for HTML Help support.

• HTML Help ActiveX control: Supports navigation features, such as the Table of Contents, index, and link controls 
(related topics and keyword links). It also supports HTML Help controls: WinHelp topic links, startup screens, and 
close window controls.

Note: 

Please note Microsoft HTML Help output is not supported on macOS.

Configure a Microsoft HTML Help output preset
The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various 
settings of the output preset. You can use the following settings to configure a Microsoft HTML output preset:

General
Use the following options to specify basic output settings, such as title, output path, language of UI strings, and more.

Title Specify the title for the generated output. 

You can use variables in the title. To do so, type Ctrl + 1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

Output Path Specify a location for the output. To select a location, click  . 

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

CHM file Specify the CHM filename with extension .chm.

Language Use the drop-down list to specify a language for the tab titles in the output. Specify this setting if you want 
to change the specified language in project settings.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list.
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Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, 
glossary, and condition expression.

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output.

Default Topic Click  to select the topic that displays in the Topic panel when you open the output. By default, the 
first topic in the Table of Contents selected for this output is the default topic.

Include Index Select this setting to include the index page in the output.

Glossary Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to 
quickly retrieve the relevant terms in your project, with the corresponding definitions.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or userbase. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets help you implement output-specific 
use of variables. For example, you can have different variable sets for generating output for customers and internal 
users.

Layout
Use the following options to configure the appearance of your output.

Master Page Use the drop-down list to select the master page for the output you are generating.

Note: 

After you've configured an output preset, you can access it in the Quick Generate dialog box of the authoring window or 
in the Output Presets panel of the publishing window.

Publish
You can publish your output to FTP, SFTP, or File System. To be able to publish your output, first configure a publish 
profile for the appropriate server type. For more information, see Configure a publish profile for FTP, SFTP, or File 
System.

After you save the publish profile, RoboHelp displays the profile in the Publish tab. To publish your output, select the 
appropriate publish profiles and click .

By default, only modified files are published using the chosen publish profiles since the last publish.

To publish all files, select Republish All and click . To view the publish log, in the Output Presets panel, against the 
appropriate output preset, choose  > View Publish Log.

Generate Microsoft HTML Help output
1 In the authoring window of your project, do one of the following, click the Quick Generate icon  in the upper-

right corner of the standard toolbar.

2 Select a Microsoft HTML Help output preset in the Quick Generate dialog box.

http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
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3 To configure the settings, do one of the following:

• Click the Edit Settings icon  in the Quick Generate dialog box.

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

4 In the Output toolbar, click Output Presets.  In the Output Presets panel, do one of the following:

• Double-click the desired Microsoft HTML Help output preset.

• Click the  icon next to the desired output preset and select Edit.

5 See Configure a Microsoft HTML Help output preset to configure the output settings.

6 To save your settings, click the Save icon  in the upper-left corner of the standard toolbar in the Output view.

7 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible in the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to view the output.

Note: 

Alternatively, you can generate the output in the authoring window. Click Quick Generate  on the toolbar, select 
the desired output preset, and click Generate. 

You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, 
click  next to the output preset to view the output. In case the output generation failed, click  next to the selected 
output preset to view the error log.

Generate Mobile App output

What is Mobile App output
In RoboHelp, the Mobile App output preset allows you to generate an Android or iOS mobile application as your project 
output.

Configure a Mobile App output preset
The first step in generating the output of a RoboHelp project is to create an output preset and then configure the various 
settings of the output preset. You can use the following settings to configure a Mobile App output preset:

General
Title Specify the title for the generated output.

You can use variables in the title. To do so, type Ctrl + 1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

The title, along with the variables if used, appears on the browser tab of the output.

Output Path Specify a location for the output. To select a location, click  . 

http://helpx.adobe.com/en/robohelp/using/generate-microsoft-html-help-output.html#ConfigureaMicrosoftHTMLHelpoutputpreset


214
Generating output

Last updated 7/13/2020

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

Language Use the drop-down list to specify a language for the output preset if the language of the UI of the generated 
output needs to be different from the language of the content. 

Encoding Use the drop-down list to specify the type of character encoding format to be used for your content.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, index, 
glossary, and condition expression:

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output.

Browse Sequence Use the drop-down list to view the defined browse sequences in your project. You can select more 
than one browse sequence. The selected browse sequences are then merged for the output. If there is a conflict with the 
selected browse sequences, the first selection is given preference.

Default Topic Click  to select the topic that displays in the Topic panel when you open the output. By default, the 
first topic in the Table of Contents selected for this output is the default topic.

You can also select the default topic from the merged child projects. The list shown under the merged child projects is 
read from the selected TOC.

Include Index Select this setting to include the index page in the output.

Glossary  Use the drop-down list to select the glossary to be included in the output. The glossary helps your users to 
quickly retrieve the  relevant terms in your project, with the corresponding definitions.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or userbase. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Dynamic Content Filter Use the drop-down list to select a dynamic content filter so your end users can filter content 
in the generated output. Click  to edit the selected Dynamic Content Filter. Alternatively, select None in the drop-
down list to not specify a dynamic content filter.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can select 
<Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-specific 
use of variables. For example, you can have different variable sets for generating output for customers and internal 
users.

Map Files Use the drop-down to select a map file to use context-sensitive help. For more help, see Work with context-
sensitive help.

Layout
Use the following options to configure the appearance of your output:

Master Page Use the drop-down list to select the master page for the output you are generating.  

https://helpx.adobe.com/in/robohelp/using/context-sensitive-help.htm
https://helpx.adobe.com/in/robohelp/using/context-sensitive-help.htm
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Skin Use the drop-down list to select a skin to apply in your output.

Show Thumbnail for Images Select this field to show thumbnail for images in output.

• Create Thumbnail for images Select this field to generate image thumbnails from existing images in the output. 
These images can be enlarged when the user clicks them.

• Style Existing Images as Thumbnails Select this field to style existing images as thumbnails in the output. These 
images can be enlarged when the user clicks them.

Search
Use the following options to specify search-related settings for your output:

Use topic description as search context Select this setting to display the topic description with the title in search topic 
results. In Set a Character limit, enter the maximum number of characters to be displayed in the topic description. To 
set a topic description, right-click a topic in the Contents panel and select Properties. In the Topic Properties dialog 
box, enter the description in Description and click Apply.

Enable auto complete in search box Select this option to display predictive options for the search query based on the 
initial characters typed by users.  

Auto correct search query Select this option to correct misspelled terms that are typed during search. This setting 
corrects up to one character in each word typed during search. This ensures that you receive relevant search results, 
even if you enter a misspelled term.

Show definitions from glossary Select this option to display definitions of search terms from the  glossary selected for 
this output. If the search term matches a glossary term, the definition of the term is  displayed.

Select file types to exclude from search You can exclude specific types of files, such as PDF, Word, and Excel, from 
search. The content from the selected files will not be included during search.

App Details
Package Specify a name for the mobile app. A common naming convention is to use your company domain name in 
reverse followed by the name of the app. For example, com.adobe.myapp. 

To avoid issues with third-party tools, use English letters, the underscore character, and a period as the separator.

Version The version number for the mobile app.

Version Code (Android only) The Android version number for the app. This is a positive integer that increases by one 
value each time you update the app. When you upload your app to an Android store, such as Google Play, your user 
will be notified of updates to your app when you update the version number.

Title The name of the mobile app. This is displayed in Google Play Store or App Store and on the mobile device when 
a user installs the app.

Description Specify the description for the mobile app.

Icon Specify the icon that is associated with the application. This is displayed in Google Play Store or App Store and on 
the mobile device when a user installs the app.

Splash Screen Specify the splash screen for the app.

Note: 

The settings marked with * are mandatory fields; you need to configure these settings to successfully generate an app.
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Publish
You can publish your output to FTP, SFTP, or File System. To be able to publish your output, first configure a publish 
profile for the appropriate server type. For more information, see Configure a publish profile for FTP, SFTP, or File 
System.

After you save the publish profile, RoboHelp displays the profile in the Publish tab. To publish your output, select the 
appropriate publish profiles and click .

By default, only modified files are published using the chosen publish profiles since the last publish.

To publish all files, select Republish All and click . To view the publish log, in the Output Presets panel, against the 
appropriate output preset, choose  > View Publish Log.

Note: 

Learn how to convert your Responsive HTML5/Frameless output generated from RoboHelp into a mobile app by using 
Apache Cordova. For details about how to generate a mobile app, visit this page.

Generate Mobile App output
1 In the authoring window of your project, click the Quick Generate icon  in the upper-right corner of the 

standard toolbar.

2 Select a Mobile app output preset in the Quick Generate dialog box.

3 To configure the settings, do one of the following:

• Click the Edit Settings icon  in the Quick Generate dialog box.

• Click the Output tab at the left side of the Standard toolbar.

The Output view opens.

4 In the Output toolbar, click Output Presets. In the Output Presets panel, do one of the following:

• Double-click the desired Mobile app output preset.

• Click the  icon next to the desired output preset and select Edit.

5 To save your settings, click the Save icon  in the upper-left corner of the standard toolbar in the Output view.

6 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to open the output folder.

Note: 

Alternatively, you can generate the output in the authoring window. Click Quick Generate  on the toolbar, select 
the desired output preset, and click Generate. 

You can then view a progress bar in the Quick Generate dialog box. After the output generation is complete, 
click  next to the output preset to view the Mobile App output dialog box. In case the output generation failed, 
click  next to the selected output preset to view the error log.

http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
http://helpx.adobe.com/en/robohelp/using/ftp-sftp-file-system.html#Configureapublishprofile
https://helpx.adobe.com/tech-comm-suite/kb/generate-mobile-app-output-from-framemaker-and-robohelp-cordova.html
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Chapter 13: Publish output

Publish to a RoboHelp Server

What is RoboHelp Server
Adobe RoboHelp Server 10 is a server-based Help solution that provides real-time end-user feedback on your Help and 
knowledgebase. Generate the output of your project in RoboHelp and then publish the output to a RoboHelp Server. 
RoboHelp Server gathers and logs data about what questions users ask while searching content and how users navigate 
through topics. Results are displayed in an easy-to-view graphical format for quick interpretation.

How to publish to RoboHelp Server
To publish to RoboHelp Server, first setup a publishing profile providing information about the RoboHelp Server 
instance. RoboHelp supports Responsive HTML5 output types. You can publish content from the Output Presets panel. 
Edit a Responsive HTML5 output preset and select the publish profiles you want to use. Then publish content to 
RoboHelp Server.

Configure a publish profile for RoboHelp Server
You must create and configure a profile before publishing your output to RoboHelp Server. To create and configure a 
profile:

1 Choose Edit > Publish Profiles.

The Publish Settings dialog box opens. 

2 Click  to create a new profile.

3 In the Server Type field, select the type of server as RoboHelp Server. Default is SharePoint Online.

Other fields in the dialog box change based on the server type selected.

4 For the SharePoint Online server type, do the following:

• Name Shows the default profile name. Modify the name if required.

• Connection Profile Displays the connection profiles created using the Connection Profiles dialog box 
(accessed by choosing Collaborate > Connection Profiles). Choose a connection profile from the drop-down 
list. If no connection profile is listed, create one using the Connection Profiles dialog box.

• Remote Path Specify the server path at which you want to publish content. The default value / publishes to the 
default directory on the server.

5 For the RoboHelp Server server type, do the following:

• Name Shows the default profile name. Modify the name if required.
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• Address Specify the address of the Robohelp server to which you want to publish your projects. The address must 
be in the following format:http://<server-name>:<port-number>/<context-name>/server

• server-name: The host name or IP address of the machine on which RoboHelp Server is setup. If its on the 
same machine, you can specify localhost as server name.

• port-number: (Optional) The port on which RoboHelp Server is running. Default is 8080. If you are 
using port 8080, specify it here. However, if you are using the default ports for HTTP or HTTPS protocols, 
you need not provide the port number. For example, the default port for HTTP is 80. So if you are using 
HTTP and port 80, you need not provide the port number. 

• context-name: The context to which you want to publish. Default is robohelp. 

For example, http://localhost:8080/robohelp/server.

Note: 

By default, RoboHelp Server uses the http protocol. For the https protocol, use the following format:https://<server-
name>:<port-number>/<context-name>/server

• User ID and Password Enter your credentials.

• Areas Select an area on the server on which you want to publish content. To refresh areas, click .

6 Click Save. 

RoboHelp saves the profile and displays the profile name under the Profiles column. To edit a profile, click the 
profile name and edit its fields. To delete a profile, click  against it.

Publish to a RoboHelp Server
You can configure a Responsive HTML5 output preset to link it to the RoboHelp Server profile, and then publish your 
content to the RoboHelp Server. You can publish content to multiple RoboHelp Servers.

1 Click the Output tab in the standard toolbar. Output Presets is the default selection in the Output toolbar. 

2 In the Output Presets panel, double-click an output preset to edit it. 

3 In the output preset editor, click the Publish tab to view the servers created across projects.

You can also edit server information in the Publish Profiles dialog box, which you can launch by clicking . 

4 Select the profiles (servers) to which you want to publish content.

5 Select Republish All to republish entire content. If this field is not selected, RoboHelp publishes only updated 
content since the previous publish, not the entire content.

6 To publish to the selected profiles (servers), click the output preset and then click  in the standard toolbar. Or 
right-click the output preset and click Publish.

If you selected multiple RoboHelp Servers, RoboHelp publishes to RoboHelp Servers in a sequence. Two prompts 
appear, one displays publishing information (such as the file being published, preset name, and server name) and 
the other displays publishing status.

Note: 

RoboHelp creates log files at %/AppData/%/Local/Temp/RHTMP. To view log files, right-click the output preset and 
click View Publish Log. If you published content to multiple servers, the log file shows publishing information (success 
or failure and errors) about all servers.

7 To view published content, click  in the Results column against the published profile.

If publishing fails, the Results column does not show the  icon. 
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Publish to an FTP server, a Secure FTP server, or a File 
System

How to publish
You can generate the output of your project in RoboHelp and then publish the output to an external server using file 
transfer protocol (FTP), secure file transfer protocol (SFTP), or a file system. To do so, first setup a publishing profile 
providing information about the FTP, SFTP, or file system instance. Edit an output preset, select the publish profiles you 
want to use, and then publish content.

Configure a publish profile
To create and configure a profile:

1 Choose Edit > Publish Profiles.

The Publish Settings dialog box opens. 

2 Click  to create a new profile.

3 In the Server Type field, select the type of server as FTP, SFTP, or File System. Default is SharePoint Online.

Except for Name, other fields in the dialog box change based on the server type selected.

4 In the Name field, modify the default profile name if required.

5 For the FTP server type, do the following:

• Address Specify the domain name of the server or its IP address.

Note: Port is not required in the address. 

• Anonymous User Select this field to publish content as an anonymous user. Sign-in credentials are not required 
for anonymous users. If you do not want to publish as an anonymous user, enter your sign-in credentials in the 
UserID and Password fields.

• Server Directory Specify the path on the server to which you want to publish content. For example, specify / for 
root folder, specify /folder1/folder2 for folders and subfolders. If the specified subfolder does not exist, RoboHelp 
creates it and copies files inside the new subfolder.

• Port Specify a port. The default is 21.

6 For the SFTP server type, do the following:

• Address Specify the domain name of the server or its IP address.

Note: Port is not required in the address. 

• UserID and Password SFTP servers support only username and password sign-ins. Enter your sign-in 
credentials.

• Server Directory Specify the path on the server to which you want to publish content. For example, specify / for 
root folder, specify /folder1/folder2 for folders and subfolders. If the specified subfolder does not exist, RoboHelp 
creates it and copies files inside the new subfolder.

• Port Specify a port. The default is 22.
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7 For the File System server type, in the Destination Path field, specify the path on your network to which you want 
to publish the content. Only absolute paths are supported. RoboHelp copies files at the path you provide without 
creating any sub-folder for the output.

8 Click Save. 

RoboHelp saves the profile and displays the profile name under the Profiles column. To edit a profile, click the 
profile name and edit its fields. To delete a profile, click  against it.

Publish to an FTP or SFTP server or a file system
You can configure an output preset to link it to the FTP, SFTP, or File Transfer publish profile, and then publish your 
content to multiple servers.

1 Click the Output tab in the standard toolbar. Output Presets is the default selection in the Output toolbar. 

2 In the Output Presets panel, double-click an output preset to edit it. 

3 In the output preset editor, click the Publish tab to view the servers created across projects.

You can also edit server information here or in the Publish Profiles dialog box, which you can launch by 
clicking . 

4 Select the profiles (servers) to which you want to publish content.

5 Select Republish All to republish entire content, including updates, if content was previously published to a specific 
server. If this field is not selected, RoboHelp publishes only content updates, not the entire content.

6 To publish to the selected profiles (servers), right-click the output preset and click Publish.

If you selected multiple servers, RoboHelp publishes in parallel. Two prompts appear, one displays publishing 
information (such as the file being published, preset name, and server name) and the other displays publishing 
status.

Note: 

RoboHelp also creates log files at %/AppData/%/Local/Temp/RHTMP. To view log files, right-click the output preset 
and click View Publish Log. If you published content to multiple servers, the log file shows publishing information 
(success or failure and errors) about all servers.

7 To view published content, click  in the Results column against the published profile.

If publishing fails, the Results column does not show the  icon. 

Publish to SharePoint Online
Before you publish to SharePoint, make sure you have a Document Library in SharePoint where you have read and write 
rights. Connecting to the SharePoint server is the only mandatory step. See "Connecting to SharePoint Server."

Configure a publish profile for SharePoint Online
You must create and configure a publish profile before publishing your output to SharePoint online. To create and 
configure a profile:

1 Choose Edit > Publish Profiles.

The Publish Settings dialog box opens. 

https://helpx.adobe.com/in/robohelp/using/sharepoint.html
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2 Click  to create a new profile.

3 In the Server Type field, select the type of server as SharePoint Online, which is already selected, by default.

4 For the SharePoint Online server type, do the following:

• Name Shows the default profile name. Modify the name if required.

• Connection Profile Displays the connection profiles created using the Connection Profiles dialog box 
(accessed by choosing Collaborate > Connection Profiles). Choose a connection profile from the drop-down 
list. If no connection profile is listed, create one using the Connection Profiles dialog box.

• Remote Path Specify the server path at which you want to publish content. The default value / publishes to the 
default directory on the server.

5 Click Save. 

RoboHelp saves the profile and displays the profile name under the Profiles column. To edit a profile, click the 
profile name and edit its fields. To delete a profile, click  against it.

Publish to SharePoint Online
You can configure a Frameless or a Responsive HTML5 output preset to link to the SharePoint profile, and then publish 
your content to the SharePoint instance. 

1 Click the Output tab in the standard toolbar. Output Presets is the default selection in the Output toolbar. 

2 In the Output Presets panel, double-click an output preset to edit it. 

3 In the Output Preset editor, click the General tab to configure the settings.

Click the Generate SharePoint output button and Save the settings.

4 Click the Publish tab to view the publish profiles created across projects.

You can also edit server information in the Publish Profiles dialog box, which you can launch by clicking . 

5 Select the profiles (servers) to which you want to publish content.

6 Select Republish All to republish the entire content. If this field is not selected, RoboHelp publishes only the 
updated content since the previous publish, and not the complete content.

7 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to view the output.

8 To publish to the selected profiles (servers), click the output preset, and then click  in the standard toolbar. Or, 
right-click the output preset and click Publish.

9 To view published content, click  in the Results column against the SharePoint Server URL.

If publishing fails, the Results column does not show the  icon. 

Publish to Zendesk Help Center
Adobe RoboHelp extends the capabilities of its publishing feature, giving you the option to publish the Content Only 
output (earlier XML), directly to Zendesk Help Center.

Note: 
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The Content Only output enables content to be published to Publish to Salesforce Knowledge Base, Publish to ServiceNow 
Knowledge Base, and Zendesk, in addition to XHTML.

Pre-requisites
To create a connection with Zendesk Help Center, you must set up your account to get started. For more details, see 
Getting Started with Zendesk.

Set up the workflow
Following are the steps to configure Zendesk Help Center prior to publishing your output.

• Create an output preset and Configure a Zendesk output presetan output preset.

• Configure a publish profile

• Configure the TOC structure for Zendesk Help Center to use categories and sections.

Create an output preset
To create an output preset in RoboHelp, follow these steps:

1 In an open project, do one of the following:

• Click the Output tab at the left side of the Standard toolbar.

• Click Quick Generate  in the upper-right corner of the Standard toolbar and click the Edit 
Settings icon .

The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, click .

4 In the New Preset dialog box, specify the following:

Type Use the drop-down list to select Content Only preset type. 

Name Specify a name for the output preset.

Target From the target drop-down, choose Zendesk Help Center.

5 Click Done.

You can access the output preset from the Output Presets panel in the Output toolbar. Alternatively, you can access 
the output preset in the Quick Generate dialog box of the authoring window.

Configure a Zendesk output preset
You can use the following settings to configure the Content Only output preset:

General
Use the following options to specify basic output settings, such as title, target, output path, encoding, and more:

Title Specify the title for the generated output.

You can use variables in the title. To do so, type Ctrl+1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

https://support.zendesk.com/hc/en-us/articles/203664346-Getting-started-with-Guide-Setting-up
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Target Use the drop-down to specify the target to generate the selected output in Content Only.

Output Path Specify a location for the output. To select a location, click  . 

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

Encoding Use the drop-down list to specify the type of character encoding format to be used for your content.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, 
condition expression, variable set, and including expanding and drop-down text.

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output.

Note: 

It is important to understand how to map your publication to the categories and sections in Zendesk. To learn more about 
mapping, see Configure the TOC structure for Zendesk Help Center.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or user base. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-
specific use of variables. For example, you can have different variable sets for generating output for customers and 
internal users.

Include Expanding Text Select this option to include Expanding Text in your Content Only output; otherwise, only 
the Expanding Title goes into the output. However, the Expanding Text will be shown in the expanded form in the 
output.

Include Drop-down Text Select this option to include Drop-down Text in your Content Only output; otherwise, only 
the Drop-down Title goes into the output. However, the Drop-down text will be displayed in the output.

Layout
Use the following option to configure the appearance of your output.

Master Page Use the drop-down list to select the master page for the output. If the master page is selected, the style 
definitions are determined by the CSS (Cascading Style Sheets) of the master page. If set to None, then the CSS styles 
are taken from CSS files used in the topics.

Zendesk
Use the following options to specify Zendesk publish settings, such as Publish Profile, Visible to, Managed by, and more:

Publish Profile Use the drop-down to select among your Zendesk connection profile. To learn how to create publish 
profile, see Configure a publish profile.
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Visible to Click the drop-down to select a group of users to control the visibility settings of your published content. The 
view permissions are set on the Zendesk server depending on your Zendesk account.

Managed by Click the drop-down arrow and then select management permissions to determine who can have editing 
and publishing rights. These management permissions are pre-generated on the Zendesk server depending on your 
Zendesk account. 

Publish all articles in the same category Select this option to publish all the topics of the TOC to a single category and 
section on Zendesk site. For more details about categories and sections, visit Organizing knowledge base content in 
categories and sections.

Convert all styles to inline styles Select this option to ensure that your styling used in RoboHelp is maintained when 
you publish your output to Zendesk.

Upload images Select this option if you want any images in topics to be included in the published output.

Upload linked documents Select this option if you want documents like PPT, PPTX, DOC, DOCX, and PDF linked 
in topics to be included in the published output. 

Include Javascript Select this option to include JavaScript in your output to show expanding text, drop-down text, pop-
ups, and thumbnails. If unselected, the content will appear as a plain text if published to the site.

Configure a publish profile
You must create and configure a publish profile before publishing your output to Zendesk. To create and configure a 
profile:

1 Choose Edit > Publish Profiles.

The Publish Settings dialog box opens. 

2 Click  to create a profile.

3 In the Server Type field, select Zendesk Help Center.

4 For the Zendesk Help Center server type, do the following:

• Name Shows the default profile name. Modify the name if required.

• Site URL Add a site name to complete the site URL. The beginning of the URL includes your organization’s 
domain.              For example: https://companyname.zendesk.com/

•  User ID Specify the user ID. 

• Password Specify the password for this user.

5 Click Save. 

RoboHelp saves the profile and displays the profile name under the Profiles column. To edit a profile, click the 
profile name and edit its fields. To delete a profile, click  against it.

Configure the TOC structure for Zendesk Help Center
The last step prior to publishing is to check that your TOC is organized to publish your content into categories and 
sections, keeping the following guidelines in mind:

• The top-level of the TOC is converted to categories and second-level to sections; therefore, it is recommended to 
create a two-level TOC.

• Published articles that do not fall in this structure are rearranged into categories and sections.

https://support.zendesk.com/hc/en-us/articles/218222877-Organizing-knowledge-base-content-in-categories-and-sections
https://support.zendesk.com/hc/en-us/articles/218222877-Organizing-knowledge-base-content-in-categories-and-sections
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An illustration of how the two-level TOC looks

Publish to Zendesk Help Center
You can configure Content Only output preset to link to Zendesk, and then publish your content to Zendesk Help 
Center.

1 Click the Output tab in the standard toolbar. Output Presets is the default selection in the Output toolbar. 

2 In the Output Presets panel, double-click an output preset to edit it. 

3 In the output preset editor, click the Publish tab to view the profile selected in Zendesk tab configuration.

You can also edit server information in the Publish Profiles dialog box, which you can launch by clicking . 

4 Select the profiles (servers) to which you want to publish content.

5 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to view the output.

6 To publish to the selected profiles (servers), click the output preset, and then click  in the standard toolbar. Or, 
right-click the output preset and click Publish.

7 RoboHelp pushes the content to Zendesk. After the publishing is completed, Robohelp displays a report of the 
published content.

8 To view the published output, click the  icon to take you to the landing page of the Zendesk Help Center, where 
you can browse to your article.

Publish to Salesforce Knowledge Base
With Salesforce integration, Adobe RoboHelp has extended its publishing capabilities to publish the Content Only 
output (earlier XML), directly to Salesforce Knowledge Base as articles.

Note: 

The Content Only output enables content to be published to Salesforce, Publish to ServiceNow Knowledge Base, and 
Publish to Zendesk Help Center, in addition to XHTML.

Pre-requisites
To create a connection with Salesforce Knowledge Base, you need to set up your account with Lightning Knowledge 
enabled. For more details, see Set Up Accounts with Salesforce.

https://help.salesforce.com/articleView?id=accounts_settings.htm&type=5
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Set up the workflow
Following are the steps to configure Salesforce Knowledge Base prior to publishing your output.

• Create an output preset and Configure a Zendesk output presetan output preset.

• Configure a publish profile

Create an output preset
To create an output preset in RoboHelp, do the following:

1 In an open project, do one of the following:

• Click the Output tab at the left side of the Standard toolbar.

• Click Quick Generate  in the upper-right corner of the Standard toolbar and click the Edit 
Settings icon .

The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, click .

4 In the New Preset dialog box, specify the following:

Type Use the drop-down list to select Content Only preset type. 

Name Specify a name for the output preset.

Target From the target drop-down, choose Salesforce Knowledge Base.

5 Click Done.

You can access the output preset from the Output Presets panel in the Output toolbar. Alternatively, you can access 
the output preset in the Quick Generate dialog box of the authoring window.

Configure a Salesforce Knowledge Base output preset
You can use the following settings to configure the Content Only output preset:

General
Use the following options to specify basic output settings, such as title, target, output path, encoding, and more:

Title Specify the title for the generated output.

You can use variables in the title. To do so, type Ctrl+1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

Target Use the drop-down to select Salesforce Knowledge Base to generate the chosen output in Content Only.

Output Path Specify a location for the output. To select a location, click  . 

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

Encoding Use the drop-down list to specify the type of character encoding format to be used for your content.
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Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, 
condition expression, and variable set.

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or user base. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-
specific use of variables. For example, you can have different variable sets for generating output for customers and 
internal users.

Include Expanding Text  This option is not valid for publishing to Salesforce Knowledge Base. 

Include Drop-down Text This option is not valid for publishing to Salesforce Knowledge Base. 

Note: 

It is important to note that Salesforce does not permit adding JavaScript or Cascading Style Sheets (CSS) within the 
articles, so your publication must not use Drop-down text, Expanding text, or Thumbnail images. However if used, the text 
that is enclosed is preserved as plain text.

Layout
Use the following option to configure the appearance of your output.

Master Page Use the drop-down list to select the master page for the output. If the master page is selected, the style 
definitions are determined by the CSS (Cascading Style Sheets) of the master page. If set to None, then the CSS styles 
are taken from CSS files used in the topics.

Salesforce
Use the following options to specify Salesforce publish settings, such as Publish Profile, RecordType, Categories, and 
more:

Publish Profile Use the drop-down to select among your Salesforce connection profile. To learn how to create a publish 
profile, see Configure a publish profile.

RecordType Use the drop-down to select among the page layouts that have been set up in Salesforce as per the visibility 
settings, based on the user profile. RecordTypes define how your publication is organized and which fields, e.g., title, 
answer, equation, etc. should be displayed. The topics configured for this preset will be published to the selected Record 
Type.

Categories  Use the drop-down to select among what has been set up in Salesforce. Categories are like hierarchical 
trees, used to find and classify Salesforce Knowledge articles. These categories are also based on the visibility settings, 
based on the user profile.
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Convert all styles to inline styles Select this option to ensure that your styling used in RoboHelp is maintained when 
you publish your output to Salesforce Knowledge Base.

Upload images Select this option if you want any images in topics to be included in the published output.

Upload linked documents  Select this option if you want documents like PPT, PPTX, DOC, DOCX, and PDF linked 
in topics to be included in the published output. 

Configure a publish profile
You must create and configure a publish profile before publishing your output to Salesforce Knowledge Base. To create 
and configure a profile:

1 Choose Edit > Publish Profiles.

The Publish Settings dialog box opens. 

2 Click  to create a profile.

3 In the Server Type field, select Salesforce Knowledge Base.

4 For the Salesforce Knowledge Base server type, do the following:

• Name Shows the default profile name. Modify the name if required.

• Site URL Add a site name to complete the site URL. The beginning of the URL includes your organization’s 
domain.              For example: https://yourco.salesforce.com

5 Click Save. 

RoboHelp saves the profile and displays the profile name under the Profiles column. To edit a profile, click the 
profile name and edit its fields. To delete a profile, click  against it.

Publish to Salesforce Knowledge Base
You can configure Content Only output preset to link to Salesforce, and then publish your content to Salesforce 
Knowledge Base. 

1 Click the Output tab in the standard toolbar. Output Presets is the default selection in the Output toolbar. 

2 In the Output Presets panel, double-click an output preset to edit it. 

3 In the Output Preset editor, click the Publish tab to view the profile selected in the Salesforce tab configuration.

You can also edit server information in the Publish Profiles dialog box, which you can launch by clicking . 

4 Select the profiles (servers) to which you want to publish content.

5 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to view the output.

6 To publish to the selected profiles (servers), click the output preset, and then click  in the standard toolbar. Or, 
right-click the output preset and click Publish.

7 RoboHelp pushes the content to Salesforce. After the publishing is completed, Robohelp displays a report of the 
published content.

8 To view the published output, click the  icon to take you to the landing page of the Salesforce Knowledge Base, 
where you can browse to your article.
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Publish to ServiceNow Knowledge Base
With ServiceNow integration, Adobe RoboHelp has extended its publishing capabilities to publish the Content Only 
output (earlier XML), directly to ServiceNow Knowledge Base as KBs.

Note: 

The Content Only output enables content to be published to Publish to Salesforce Knowledge Base, ServiceNow, and 
Publish to Zendesk Help Center, in addition to XHTML.

Pre-requisites
Before you begin to start creating knowledge bases and knowledge articles, you must set up ServiceNow Knowledge 
Management. For more guided set-up, follow the below steps:

• Step-by-step instructions to configure ServiceNow Knowledge Management in your instance. For more details, 
see Using guided setup.

• Create, Publish rights for ServiceNow articles (kb_knowledge table CRUD Operation rights). For more details, see 
Create a knowledge article.

• To use keywords as tags, additional permissions to create and write label_entry.table and lable_entry.table_key. For 
more details, see Administering tags.

Set up the workflow
Following are the steps to configure ServiceNow Knowledge Base prior to publishing your output.

• Create an output preset and Configure a Zendesk output presetan output preset.

• Configure a publish profile.

• Configure the TOC structure for Zendesk Help Center to use categories and sections.

Create an output preset
To create an output preset in RoboHelp, do the following:

1 In an open project, do one of the following:

• Click the Output tab at the left side of the Standard toolbar.

• Click Quick Generate  in the upper-right corner of the Standard toolbar and click the Edit 
Settings icon .

The Output view opens.

2 In the Output toolbar, click Output Presets. The Output Presets panel opens.

3 In the Output Presets panel, click .

4 In the New Preset dialog box, specify the following:

Type Use the drop-down list to select Content Only preset type. 

Name Specify a name for the output preset.

Target From the target drop-down, choose ServiceNow Knowledge Base.

5 Click Done.

https://docs.servicenow.com/bundle/orlando-platform-administration/page/administer/core-configuration/concept/guided-setup.html
https://docs.servicenow.com/bundle/orlando-servicenow-platform/page/product/knowledge-management/task/create-knowledge-article.html
https://docs.servicenow.com/bundle/orlando-platform-user-interface/page/use/common-ui-elements/concept/administering-tags.html
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You can access the output preset from the Output Presets panel in the Output toolbar. Alternatively, you can access 
the output preset in the Quick Generate dialog box of the authoring window.

Configure a ServiceNow Knowledge Base output preset
You can use the following settings to configure the Content Only output preset:

General
Use the following options to specify basic output settings, such as title, target, output path, encoding, and more:

Title Specify the title for the generated output.

You can use variables in the title. To do so, type Ctrl+1 and select a variable from the drop-down list, and then 
press Enter. Note that if you have provided a variable set in the Content tab > Variable Set field, during output 
generation, the value of the selected variable is picked from the variable set.

Target Use the drop-down to select ServiceNow Knowledge Base to generate the chosen output in Content Only.

Output Path Specify a location for the output. To select a location, click  . 

Ensure that the output path is NOT located inside the project folder. If the output path is inside the project folder, the 
output generation fails. Also the folder you select should NOT have any content that you need. RoboHelp deletes the 
contents of the folder before generating the output.

Encoding Use the drop-down list to specify the type of character encoding format to be used for your content.

Post Generation Script To run your custom script after output generation, select the script .js file from the drop-down 
list.

Content
Use the following options to specify content-related output settings, such as the settings for Table of Contents, 
condition expression, and variable set.

Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down 
list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected 
by default.

The set of files and their references present in the selected Table of Contents appear in the generated output.

Condition Expression Use the drop-down list to specify the condition expression for your output. This setting allows 
you to easily include or exclude content depending on the desired type of output or user base. Click  to edit the 
selected condition expression. You can also select None in the drop-down list to not specify any condition expression.

Variable Set Use the drop-down list to specify the variable set to use in this output. In the drop-down list, you can 
select <Default Variable Set> to use the project's default variable set. Variable sets allow you to implement output-
specific use of variables. For example, you can have different variable sets for generating output for customers and 
internal users.

Include Expanding Text  This option is not valid for publishing to ServiceNow Knowledge Base. 

Include Drop-down Text This option is not valid for publishing to ServiceNow Knowledge Base. 

Note: 

It is important to note that ServiceNow does not permit adding JavaScript or Cascading Style Sheets (CSS) within the 
articles, so your publication must not use Drop-down text, Expanding text, or Thumbnail images. However if used, the text 
that is enclosed is preserved as plain text.
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Layout
Use the following option to configure the appearance of your output.

Master Page Use the drop-down list to select the master page for the output. If the master page is selected, the style 
definitions are determined by the CSS (Cascading Style Sheets) of the master page. If set to None, then the CSS styles 
are taken from CSS files used in the topics.

ServiceNow
Use the following options to specify ServiceNow publish settings, such as Publish Profile, RecordType, Categories, and 
more:

Publish Profile Use the drop-down to select among your ServiceNow connection profile. To learn how to create a 
publish profile, see Configure a publish profile.

Knowledge Base Use this field to select the required ServiceNow Knowledge Base.

The user can configure Knowledge Bases in the ServiceNow site to store the content based on the permissions. All the 
articles published from this project can be published to these Knowledge Bases. 

Publish all articles in the same category Select this option to publish all the topics of the TOC to a single category and 
section on ServiceNow site. 

Convert all styles to inline styles Select this option to ensure that your styling used in RoboHelp is maintained when 
you publish your output to ServiceNow Knowledge Base.

Use search keywords from topic as article tags Use tags to filter and view tagged articles. Select this option to tag your 
articles with search keywords. 

ServiceNow uses article tags using your keywords. Tags can be visible to any user (global), visible only to specific groups 
or users (shared), or visible to a single user (private).

For example, an article about setting up the translation in multiple languages might get the following system tags 
applied: translation, multiple, languages, etc. When searching or browsing for an article, users may click a tag to finesse 
their search results.

Upload as draft Select this option to upload the topic to share it as a draft before making it available to the users.

Upload images Select this option if you want any images in topics to be included in the published output.

Upload linked documents  Select this option if you want documents like PPT, PPTX, DOC, DOCX, and PDF linked 
in topics to be included in the published output. 

Configure a publish profile
You must create and configure a publish profile before publishing your output to ServiceNow Knowledge Base. To 
create and configure a profile:

1 Choose Edit > Publish Profiles.

The Publish Settings dialog box opens. 

2 Click  to create a profile.

3 In the Server Type field, select ServiceNow Knowledge Base.

4 For the ServiceNow Knowledge Base server type, do the following:

• Name Shows the default profile name. Modify the name if required.

• Site URL Add a site name to complete the site URL.               For example: https://devInstance.service-now.com
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5 Click Save. 

RoboHelp saves the profile and displays the profile name under the Profiles column. To edit a profile, click the 
profile name and edit its fields. To delete a profile, click  against it.

Configure the TOC structure for ServiceNow Knowledge Base
The last step prior to publishing is to check that your TOC is organized to publish your content into categories and 
sections, keeping the following guidelines in mind:

• The top-level of the TOC is converted to categories and second-level to sections; therefore, it is recommended to 
create a two-level TOC.

• Published articles that do not fall in this structure are rearranged into categories and sections.

An illustration of how the two-level TOC looks

Publish to ServiceNow Knowledge Base
You can configure Content Only output preset to link to ServiceNow, and then publish your content to ServiceNow 
Knowledge Base. 

1 Click the Output tab in the standard toolbar. Output Presets is the default selection in the Output toolbar. 

2 In the Output Presets panel, double-click an output preset to edit it. 

3 In the Output Preset editor, click the Publish tab to view the profile selected in ServiceNow tab configuration.

You can also edit server information in the Publish Profiles dialog box, which you can launch by clicking . 

4 Select the profiles (servers) to which you want to publish content.

5 Click the Generate Preset icon  in the Output Presets panel. 

You can then view a progress bar next to the selected output preset in the Output Presets panel. Once the output 
generation is complete, a Success dialog box is visible at the lower-right corner of the screen. 

After the output generation is complete, click  in the Output Presets panel to view the output.

6 To publish to the selected profiles (servers), click the output preset, and then click  in the standard toolbar. Or, 
right-click the output preset and click Publish.

7 RoboHelp pushes the content to ServiceNow. To view the published output, click the  icon to take you to the 
landing page of the ServiceNow Knowledge Base, where you can browse to your article.

8 To view the published output, click the  icon to take you to the landing page of the ServiceNow Knowledge Base, 
where you can browse to your article.
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Chapter 14: Appendix

Adobe RoboHelp Scripting Reference
Browse through the reference manual for JavaScript APIs to extend and automate RoboHelp workflows.

Adobe RoboHelp Scripting Reference

RoboHelp keyboard shortcuts
Adobe RoboHelp provides shortcuts to help you quickly navigate and work on documents. Know the keyboard 
shortcuts that appear next to command names in menus and the ones not included in menus.

Keys for project and file operations
The following Ctrl key combinations provide shortcuts to many of the frequently used commands.

Keys for editing
You can use shortcut keys to perform certain functions within the editing environment of RoboHelp.  The following 
section lists the shortcut keys available to increase your productivity.

Use these keys To do this

Alt + Ctrl + N New project

Ctrl + O Open project

Alt + Ctrl + S Save

Ctrl + S Save all

Ctrl + F4 Close active editor

Alt + Ctrl + C Close project

Ctrl + Shift + / Project settings

Ctrl + Q Exit application

Ctrl + W Open topic preview

Ctrl + R Open Source view

Ctrl + E Open Author view

Ctrl + F Find files

Ctrl + H Find and replace text in topics and Table of Contents (Author and 
Source views, and Table of Contents panel)

Ctrl + Alt + C Close project

https://helpx.adobe.com/content/dam/help/en/pdf/RoboHelp-Scripting-Reference-2019.pdf
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Keys for applying Heading styles
The following shortcut keys can be used to quickly apply heading styles for clear and consistent formatting:

Use these keys To do this

Ctrl + Z Undo

Ctrl + Y, Ctrl + Shift + Z Redo

Ctrl + X, Shift + Del Cut 

Ctrl + C Copy 

Ctrl + V, Shift + Insert Paste 

Ctrl + A Select all

Ctrl + Shift + T Application preferences

Shift + Arrow Select text by letters

Ctrl + Shift + Arrow Select text by words

Shift + Home Select text from the cursor to the beginning of the line

Shift + End Select text from the cursor to the end of the line

Ctrl + Shift + Home Select text from the cursor to the beginning of the document

Ctrl + Shift + End Select text from the cursor to the end of the document

Shift + Page Down Select text downwards from the cursor to the length of the editing 
area 

Shift + Page Up Select text upwards from the cursor to the length of the editing area

Ctrl + Shift + C Copy inline formatting from a text fragment and enable sticky mode

Ctrl + Shift + V Apply the copied inline formatting to a text fragment

Esc Disable sticky mode

Shift + Ctrl + V Paste as plain text

Tab Indent a list

Shift + Tab Outdent a list

Ctrl + B Make text bold

Delete Delete contextually

Ctrl + Alt + L Auto indent Source view

Ctrl + Space Show options in Source view

Ctrl + Up Arrow Move selected Table of Contents items up

Ctrl + Down Arrow Move selected Table of Contents items down

Ctrl + Left Arrow Move selected Table of Contents items left

Ctrl + Right Arrow Move selected Table of Contents items right
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Keys for insertion of items
The following shortcuts make it easier for you to perform insert actions:

Keys for navigation
The following keys help provide an easier and quicker method of navigating and executing commands. 

Keys for other functions
Some shortcut keys serve as function keys and are used as single key commands:

Ctrl + Alt + 1 Apply Heading 1 style

Ctrl + Alt + 2 Apply Heading 2 style

Ctrl + Alt + 3 Apply Heading 3 style

Ctrl + Alt + 4 Apply Heading 4 style

Ctrl + Alt + 5 Apply Heading 5 style

Ctrl + Alt + 6 Apply Heading 6 style

Ctrl + Alt + N Converts the text to normal paragraph text

Use these keys To do this

Ctrl + 1 Insert a variable

Ctrl + 2 Insert a snippet

Ctrl + 3 Insert a field

Ctrl + G Insert an image

Ctrl + K Insert a hyperlink

Use these keys To do this

Home Jump to the beginning of the line

Ctrl + Home Jump to the beginning of the document

End Jump to the end of the line

Ctrl + End Jump to the end of the document

Page Down Scroll down the length of the editing area in a document

Page Up Scroll up the length of the editing area in a document

Ctrl + Page Up Switch to the next open tab in RoboHelp workspace

Ctrl + Page Down Switch to the previous open tab in RoboHelp workspace

Use these keys To do this

F11 Toggle full screen

F1 Online Help
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