Adobe Photoshop CC

Align objects with guides

Guides help you precisely align and arrange objects in your projects. Follow along with project files to learn how to create multiple guides at once. (Try it, 10 min)

What do I need?

Get files Sample files to practice with

Get PDF Photoshop keyboard shortcuts

Step 1 of 7:

Create guides from a shape or object

Open the downloaded file in Photoshop. In the Layers panel, select the "Step 1" layer. If you don't see the Layers panel, go to Window > Layers.

Select View > New Guides From Shape, which creates guides in your document based on the dimensions of the object in the selected layer.

Step 2 of 7:

Explore the New Guide Layout options

Select View > New Guide Layout, which opens the New Guide Layout dialog box. Select the Clear Existing Guides option to remove the guides you made in Step 1. Select the Preview option so that you can view changes to your guides as you specify new guide settings.


Step 3 of 7:

Create column guides quickly 

With the New Guide Layout dialog box open, change the Preset from "Default" to "12 Column." Notice that Photoshop creates the gutters (or the spacing) between columns automatically based on the number of columns you have selected.

Step 4 of 7:

Create row guides quickly

Within the New Layout Guide dialog box, select the Rows option and change Number to "6." For the Gutter value, enter the same value that is used for Columns, "0.278 in" (or 20px). See the changes reflected as you preview your document.

Step 5 of 7:

Create margin guides

In the New Guide Layout dialog box, select the Margin option. Enter "0.278 in" (or 20px) for the Top, Left, Bottom, and Right margins (the same value you specified for Column and Row Gutters). The columns and rows shrink to accommodate the margins.

Click OK to finish creating your grid of guides.

Step 6 of 7:

Use guides to arrange an asset

To bring an image into your document, go to File > Place Embedded and select “step-6.jpg” from the practice files you downloaded. Click Place.

Drag the image to arrange it as shown in the illustration (right). Press Return or Enter to commit to the placement.


Step 7 of 7:

Experiment with guides

In the Layers panel, click the small box next to the “Step 7” folder, which causes all layers for Step 7 to display in your document. Click the arrow to the left of the folder icon to expand and show all of the layers and objects for this folder.  Move the objects on each layer around to create a unique composition, using the grid to align and arrange the elements.

Tip: You can quickly reveal or hide guides by pressing Command and ";" on Mac, or Control and ";" on PC keyboards , or select View > Show > Guides.

Let us know what you think.