Kendall Plant creates subtle motion through color. See how Plant transforms a gradient and animates it in Adobe Photoshop.

Kendall Plant is a designer, content creator, and art director whose unique creations incorporate nature, street photography, and even skulls. She works at Adobe as an associate creative director.

Create a composition

Before Plant defined gradients and animations, she created an elegant design using decorative typography against a solid background.  

The words “Light & Lut” typed in white letters against a black background

Set the stage

Plant used a Solid Color adjustment layer as the background for the composition. She set the initial color to blue (#2727D5).

The Adobe Photoshop layers panel shows solid color adjustment layer and Color Picker display over a blue background

Colorize your palette

She then added a new layer and selected a Soft Round Brush (B), set it to pink (#ff25de), and brushed a large swatch of color in the corner. Plant added a third color, cyan (#4befff), to create a custom gradient.

Brush properties panel shows a soft round brush set to 2700 next to Layers panel with the new pink and cyan gradient layer

Brighten the spectrum

To enhance the colors in the gradient, Plant applied a Hue/Saturation adjustment layer and increased the Saturation.

The Layers panel has a Hue Saturation adjust layer above the gradient layer, the HSL properties show Saturation set to +100

Connect color and composition

When Plant finished creating the gradient, she used Shift+click to select the two adjustment layers and the gradient layer, then right-clicked and chose Create Smart Object. She right-clicked on Smart Object and selected Create Clipping Mask to bound the gradient to the text.

Two states of the Layers panel, first combines layers, second applies clipping mask to clip gradient to smart object

Set it in motion

To animate the effect, Plant selected Window > Timeline, and clicked Create Video Timeline. Photoshop added each of the unlocked layers to the Timeline.

Photoshop Timeline panel with Create Video Timeline selected appears over “Light & Lut” with gradient applied

Initiate movement

The animation Plant created included a series of transformations of the text and color gradient. To start, she held Control+T (Windows) or Command+T (macOS), scaled up the gradient, repositioned it, and pressed Enter/Return to commit the changes. She then clicked the drop down arrow next to the Hue/Saturation layer in the Timeline and the Stopwatch next to the Transform property to set the first keyframe in the animation.

Timeline shows Hue/Saturation layer expanded with Transform property selected, the preview shows bounding box around artwork

Shift the scene

Plant then advanced the playhead on the Timeline, pressed Control+T / Command+T, moved and rotated the gradient layer, and pressed Enter/Return to create the next keyframe. She repeated this process to add two more keyframes to the animation.

Keyframe at 25 millisecond mark for Transform property on the Hue/Saturation layer, bounding box around artwork is tilted right

End from the beginning

To finish the animation, Plant moved the playhead to where she wanted the animation to end. She right-clicked on the first keyframe, chose Copy, then right-clicked on the last keyframe and chose Paste.

Photoshop timeline shows 4 keyframes on the Hue/Saturation layer. The first and last keyframes are circled in orange

Close the loop

Plant defined the extent of the animation by right-clicking on the playhead in its final position and chose Set End Work Area. She clicked the gear icon and checked Loop Playback to create a looping effect. She then clicked Play to test the animation.

Photoshop timeline shows Loop Playback option is checked and Set End of Work Area selected at the end of the timeline

Tip: Adjust the position

If the edge of the gradient is visible at any point during the animation, you can fix this easily. Just scrub the playhead on the Timeline until the white edge is visible. Use Control+T / Command+T to transform and move the gradient to fit within the bounds of the design. Repeat these steps as necessary. Photoshop adds a keyframe each time you transform the gradient.    

Animation preview shows 2 states of artwork, 1 with the gradient shifted and white shows through, the 2nd corrects the issue

Create infinite inspiration

Enhance your design with engaging color movement. When it’s ready for primetime, you can share your work in one of two ways.

Choose File > Export > Save for Web (Legacy) to save your animation as an animated GIF. Or render it as a video using File > Export > Render Video and choose a Preset, or customize the output by selecting Size and Frame Rate. Then stack in Adobe Premiere or After Effects to create a looping video.

Note: Project files included with this tutorial are for practice purposes only.

04/08/2020

Artist: Kendall Plant

Adobe Stock contributor: peshkov

Was this page helpful?