Learn advanced techniques to cut out hair from complicated backgrounds.

What you'll need

This sample file contains Adobe Stock assets you can use to practice what you learn in this tutorial. If you want to use the sample file beyond this tutorial, you can purchase licenses on Adobe Stock. Check out the ReadMe file in the folder for the terms that apply to your use of this sample file.

What you learned: Mask hair, and paint in hair strands using hair from another image

Select the person

  • Open an image of a person, and select the layer that contains the person—the portrait layer.
  • In the Properties panel, go to Quick Actions and click Remove Background. This automatically creates a layer mask that hides the background around the person.
  • Alternatively, you could use Select > Subject or the Quick Selection tool to select the person, and then click the Add Layer Mask button at the bottom of the Layers panel to make a mask from your selection.

Fine-tune the layer mask

  1. With the layer mask thumbnail on the portrait layer selected, choose Select > Select and Mask.
  2. In the Select and Mask workspace, use the sliders to refine the edge of the layer mask. Choose View Mode > On Black. Then drag the Smooth slider to the right to minimize jaggedness on the mask edge.
  3. Soften the mask edges by dragging the feather slider to the right.
  4. Choose Output To > Layer Mask, and click OK.
  5. Go back into the Select and Mask workspace to focus on masking the hair. Click the Select and Mask button again.
  6. Select the Refine Edge Brush tool, and drag over the edge of the hair.
  7. Drag the Shift Edge slider to the right to move the mask edge inward and hide imperfections.  
  8. Click OK to close Select and Mask. Don’t worry if the mask is not perfect. Painting in digital hair will make the result look more realistic.

Create a custom hair brush

Sometimes you’ll get better results if you use hair from another image to create and paint in strands of hair. Find a photo with a solid background that has a lot of contrast with the hair. Then create a custom brush out of the hair.

  1. With the Crop tool, crop the hair photo so that the only area visible is the hair that you want to turn into a brush.
  2. Remove the color by choosing Image > Adjustments > Desaturate.
  3. Choose Image > Adjustments > Levels, and drag the Input Levels sliders to turn the background white and the hair black.
  4. Select the Dodge tool, set the Range to Highlights, and paint on any gray areas in the background to make them white.
  5. Select the Burn tool, set the Range to Shadows, and paint over the hair to make it darker.
  6. Choose Edit > Define Brush Preset to make the black and white hair image into a brush.

Paint in digital hair using your new custom brush

  1. Back in the original portrait photo, click the Create New Layer button to create a new layer.
  2. Drag the new layer below the portrait layer.
  3. With the Brush tool active, hold down Alt (Windows) or Option (MacOS) to temporarily switch over to the Eyedropper tool. Click on the hair to sample a hair color.
  4. Use the left and right bracket keys ([ ]) on the keyboard to resize your hair brush tip and match it to the portrait image.
  5. Click once to paint hair on the new layer.
  6. Press Control+T (Windows) or Command+T (MacOS) to transform and distort the hair to better match the image.
  7. Repeat this process a few more times until you are happy with the results.

Tip: Don’t use just a single color for the hair that you paint in. Use as many colors as possible that are similar to the subject’s hair to create more realistic hair strands.

11/04/2019

Adobe Stock contributors: alonesdj, blackday

Presenter: Jesus Ramirez

Was this page helpful?