2014 releases of Photoshop CC

Note:

The 2017 release of Photoshop CC is now available! See the New features summary.

The 2014 releases of Photoshop CC rolled out several features and enhancements to enrich your digital imaging experience. Read on for a quick introduction and find links to resources that offer more information about these releases.

Note: For a summary of features introduced in earlier releases of Photoshop CC, see Feature summary | Photoshop CC | 2013 releases.

 


Photoshop CC 2014.2.2 (December 2014 release)

Collaborate on libraries

Enhanced in this release of Photoshop CC

You can now share libraries with collaborators from within Photoshop. Collaborators must have an Adobe ID. If they don't already have an Adobe ID, they can create one when they accept the invitation to collaborate.

Follow these steps to share a library:

  1. In the Libraries panel, select a library from the pop-up menu.
  2. Open the flyout menu and choose Collaborate.
  3. In the browser page that opens up, provide email addresses and an optional message for one or more collaborators with whom you want to share the library.
  4. Click Invite to send out the collaboration invites.

Collaborators receive an email invitation. Existing Creative Cloud members also receive a notification via the Creative Cloud desktop app and website.

Photoshop collaborate on libraries
Collaborate on libraries

For more information, see Collaborate on libraries.

Improved Extract Assets dialog

Enhanced in this release of Photoshop CC

  • Assets are now clipped to document bounds by default. Photoshop Generator has also been updated to use this behavior by default.
  • When you group layers in the Layer panel, the group is now listed correctly in the Extract Assets dialog. This improvement comes handy when you want to create assets from composite layers.
  • Smart objects are now rendered with higher fidelity when an SVG asset is extracted for 2x or 3x versions.
  • Transformed shapes and text retain their transformations when they're exported as SVG assets.
  • You no longer require a workaround to use Extract Assets if you're using proxies to redirect localhost queries.
  • Previews of assets no longer fail because of invalid, incorrect, or duplicate layer syntax.

For more information, see Extract assets and Generate image assets from layers.

Photoshop CC 2014.2 (October 2014 release)

Creative Cloud Libraries

New in this release of Photoshop CC

Creative Cloud Libraries is a powerful new feature that lets you create, categorize, and store your favorite colors, brushes, text styles, graphics, and vector images in one easily accessible place. Then you can access them anywhere: Assets you create under the same Adobe ID will be visible across different computers—in a variety of applications like Photoshop CC—wherever you sign in.  

Select Window > Library to open the Library panel.

For more information, watch CC Libraries in Photoshop.

Extract Assets

New in this release of Photoshop CC

The 2014.2 release of Photoshop CC introduces Extract Assets, a brand new user interface that lets you easily extract optimized image assets from layers and save them to various formats and resolutions, including SVG, JPG, PNG, or GIF. Using the simple visual Extract Assets interface built on top of Adobe Generator, you may extract content either on-demand or in real-time with auto-updated extractions tailored to your workflow.

This feature is particularly useful for web and screen designers who frequently create assets in multiple resolutions for use in websites and mobile apps.

Select File > Extract Assets.

For details, see Extract assets and Extract PSD assets workflow (video). For information about Adobe Generator, see Generate image assets from layers.

Improved Guides

Enhanced in this release of Photoshop CC

Quickly create multiple guides at one time. Accurately set the width and margins of multiple columns or rows, and even save guides as presets. 

Select View > New Guide Layout.

You can also create guides that align with the edges of the selected layers or selected shapes within a shape layer.

Select View > New Guides From Shape.  

3D imaging

New in this release of Photoshop CC

Support for rigged COLLADA files

Photoshop now supports animation on rigged COLLADA files. You can import and scrub the timeline for these files. Do the following:

  1. Open the rigged COLLADA file in Photoshop.
  2. Select Window > Timeline.
  3. Scrub to a desired position on the timeline.

Import and export 3D PDF files

Photoshop now lets you export and import 3D PDF files in the U3D format.

Export: In Photoshop, open a 3D file and then select 3D > Export 3D Layer. Now, follow the onscreen instructions.

Note:

You can use the 3D PDF export functionality in conjunction with rigged COLLADA file support. Scrub to the frame you'd like to export in the animated file and then export it as PDF or in another format.

Import: Photoshop lets you open 3D PDF files created in Acrobat or Photoshop.

  1. Open the 3D PDF file in Photoshop.
  2. Select the 3D option in the Import PDF dialog.
Photoshop 3D imaging Select the 3D option
Select the 3D option in the Import PDF dialog

  1. Click OK. Follow any further onscreen instructions.

New Welcome experience

New in this release of Photoshop CC

A new Welcome screen in Photoshop CC helps you discover, learn, and use the many features in Photoshop. The Welcome screen greets you each time you launch Photoshop and displays content that is personalized and relevant to you.

A tab-based interface helps you discover new features, how to get started, and tips and techniques.

Select Help > Welcome.

The new Welcome experience is only available in the English version of Photoshop at this time.

UI improvements to the Fill dialog

Enhanced in this release of Photoshop CC

A number of UI improvements make the Fill dialog more intuitive and easier to use. The enhancements are focused on the logical grouping of options in the dialog.

Support for Windows touch devices

New in this release of Photoshop CC

Photoshop CC now supports Windows 8.1 touch devices like the Microsoft Surface Pro, so you can use pinch, zoom, pan, and rotate.  

In Photoshop, two-finger touch gestures are used to control the location, rotation, and scaling of the Image > Canvas view. Users may alternate between touch view control and other interactions using the mouse or stylus, but touch may not be used simultaneously with other input. Touch control is convenient when painting on large touchscreen monitors, which are difficult to rotate physically, and on tablets to avoid constantly shifting the device.

For more information, see Touch gestures.

Additional updates

  •  Performance improvements to Mercury Graphics Engine to speed up Content-Aware technologies and the Focus Area selection feature
  •  Select > Modify command improvements; Also, a new edge padding option is now available for these commands
  •  Improved default values for Layer Styles
  •  Improved object selections on the canvas
  •  Improved layer locking behavior
  •  New menu item to collapse all layer groups
  •  Improved Gradient and Pattern presets
  •  Improved new document presets and default document size
  •  Document save operations are now recorded in the History panel
  •  New preference to enable overscrolling when a document does not fit the window
  •  When you create a new layer group while some layers are selected, the layers are automatically added to the layer group
  •  New Flame scripted pattern
  • Transparency support for Copy/Paste from Photoshop to other applications in OS X
  •  UI improvements for Adaptation parameters in Content-Aware Patch and Move operations
  •  Improved display of Properties panel for Live Shapes
  •  Improved enterprise compliance for cloud-based features
  •  The Adobe Color Themes panel (Window > Extensions > Adobe Color Themes) is now shipped with Photoshop
  •  3D printing support for rigging for figurine posing and animations
  •  3D PDF support and new 3D printer profiles
  •  Several dialogs are now optimized for wide-screen displays
  • Adobe Camera Raw interface now supports High DPI displays
  • New keyboard shortcuts for locking layers (Cmd/Ctrl+"/") and hiding layers (Cmd/Ctrl+",")

Note:

The menu font size in this release of Photoshop is determined by the operating system settings. For example, on Windows 8.1, you can adjust the menu font size by following the steps in the “Make text and other items on the desktop larger” section of this Microsoft Help topic.

Photoshop CC 2014.1 (August 2014 release)

The August 2014 update to Photoshop CC is focused on 3D printing and 3D imaging enhancements.

3D printing

Enhanced in this release of Photoshop CC

3D printing enhancements in this release include several workflow improvements, including higher fidelity mesh repair functionality and the ability to load assemblies. Also, previews in this release are more accurate than ever before.

Pack objects on the ground plane

Using the Pack Objects On the Ground Plane feature, you can easily arrange multiple objects for printing on the same build plate.

In earlier versions of Photoshop CC, for printing multiple objects, you'd need to manually position each object for printing. In this update to the Photoshop CC 2014 release, you can simply select the models in the 3D Panel and then choose 3D > Pack Objects On Ground Plane.

Switch between preview modes

You can now disable ray trace preview in the 3D Print Settings dialog. The preview defaults to the OpenGL preview mode if you disable ray trace preview.

Ray trace previews now more accurately represent the output of Fused Deposition Modeling (FDM) printers.

MakerBot 5 profile

This update includes a new profile for the MakerBot fifth generation printer. Direct USB printing with this printer profile is not supported yet. You can export the files you want to print to a USB stick and then print them locally.

DMM.com support

Photoshop now supports DMM.com 3D printing service for users in Japan.

Note:

For more information about using 3D printing functionality in Photoshop, see Print 3D objects.

3D imaging

Enhanced in this release of Photoshop CC

Bump map and normal map filters

You can now create bump maps and normal maps from any image that you open in Photoshop. With the image open, select Filter > 3D > Generate Bump Map or Filter > 3D > Generate Normal Map.

Line/point ray tracing

In earlier versions of Photoshop CC, lines or points added to an object looked flat when rendered. In this update to the Photoshop CC 2014 release, the rendered points or lines have volume. Points look like little spheres on the object and lines look like cylinders.

Photoshop Line/point ray tracing in Properties panel
Line/point ray tracing

Streamlined 3D painting

Improvements in this update make painting 3D models faster and easier.

Support for new formats

Photoshop can now open files in the VRML, IGES, U3D, and PLY formats. Also, you can now export objects as U3D and VRML files.

Photoshop CC 2014 (June 2014 release)

Smart Guides

Enhanced in this release of Photoshop CC

The 2014 release of Photoshop CC introduces many useful enhancements to Smart Guides:

Option (Mac)/Alt (Win) + Drag a Layer: When you drag a layer while keeping the Option (Mac) or Alt (Windows) key pressed, Photoshop displays reference measurement guides showing the distance between the original layer and the duplicate layer. This feature works with both the Move and Path Selection tools.

Photoshop Distance between the layers - original and duplicate
Distance between the layers: original and duplicate

Path measurements: Photoshop displays measurement guides while you're working with paths. Measurement guides are also displayed when you select the Path Selection tool and then drag a path within the same layer.

Photoshop Path measurements
Path measurements

Matched Spacing: When you duplicate or move an object, Photoshop displays measurement guides to visually indicate spacing between other objects that match the spacing between the selected object and its immediate neighbors.

Cmd (Mac)/Ctrl (Win) + Hover Over a Layer: You can view measurement guides while working with layers. With one layer selected, hover over another layer with the Cmd (Mac) or Ctrl (Windows) key pressed. You can use arrow keys in conjunction with this feature to nudge the selected layer.

Photoshop Measurement guides while working with layers
Measurement guides while working with layers

Distances from the canvas: When you hold down the Cmd (Mac) or Ctrl (Windows) key while hovering outside a shape, Photoshop displays distances from the canvas.

Photoshop Distances from the canvas
Distances from the canvas


Photoshop Spacing between matched objects
Spacing between matched objects

For details, see Grid and guides.

Linked Smart Object improvements

Enhanced in this release of Photoshop CC

  • You can package the Linked Smart Objects in a Photoshop document, such that their source files are saved to a folder on your computer. A copy of the Photoshop document is saved along with the source files in the folder. Select File > Package.
  • You can convert an embedded Smart Object to a Linked Smart Object. Transforms, filters, and other effects applied to the embedded Smart Object are preserved when it is converted. Select Layer > Smart Objects > Convert To Linked.
  • Workflow improvement: When you try to perform an operation on a Linked Smart Object whose source file is missing, you are prompted that the Smart Objects must be rasterized or resolved.
For details, see Create Smart Objects.

Layer comps in Smart Objects

Enhanced in this release of Photoshop CC

Consider a document with layer comps placed as a Smart Object within another document. When you select the Smart Object in the containing document, the Properties panel gives you access to the layer comps that were defined in the source file.

This feature lets you change the state of the Smart Object at a layer level without editing the Smart Object.

For details, see Layer comps.

Photoshop Layer comps in Smart Objects
Layer comps in Smart Objects

Work with fonts from Typekit

New in this release of Photoshop CC

Through integration with Typekit, Photoshop brings a world of typographic possibilities to your creative projects. You can use fonts from Typekit that are synchronized with your computer. These fonts appear alongside locally installed fonts. You can also choose to view only fonts from Typekit in the Text tool options bar and the Character panel font lists.

If you open a document that has some missing fonts, Photoshop also lets you replace those fonts with equivalent fonts from Typekit.

For details, see Work with fonts from Typekit.

Photoshop Replace missing fonts with Typekit fonts
Replace missing fonts with fonts from Typekit

New in this release of Photoshop CC

You can now quickly search for fonts in the Text tool options bar and Character panel font lists. As you type the name of your desired font family, Photoshop filters the list on the fly. You can search for fonts by font family or by style. Font search doesn't support wildcards.

Photoshop Search for fonts
Search for fonts by font family or font style

New in this release of Photoshop CC

Path blur

Using the Path Blur effects (Filter > Blur Gallery > Path Blur), you can create motion blurs along paths. You can also control the shape and amount of blurring. Photoshop automatically composites the effects of multiple path blurs applied to an image.

For details, see Path blur.

Photoshop Path blur example
A path blur example

Photoshop Simplistic path for the blur
A simplistic path for the blur

Spin blur

Using the Spin Blur effect (Filter > Blur Gallery > Spin Blur), you can rotate and blur the image around one or more points. The spin blur is a radial blur measured in degrees. Photoshop lets you work with center points, blur size and shape, and other settings, all while viewing a live preview of the changes.

For details, see Spin blur.

Photoshop Spin Blur in action
Spin Blur in action

A. Original image B. Spin Blur (Blur Angle: 15°; Strobe Strength: 50%; Strobe Flashes: 2; Strobe Flash Duration: 10°) C. Spin Blur (Blur Angle: 60°; Strobe Strength: 100%; Strobe Flashes: 4; Strobe Flash Duration: 10°) 

Select the image areas in focus

New in this release of Photoshop CC

The 2014 release of Photoshop CC lets you select the areas/pixels in an image that are in focus (Select > Focus Area). You can broaden or narrow down the default selection.

Once you've adjusted the selection to your satisfaction, determine whether the refined selection should become a selection or mask on the current layer, or produce a new layer or document. You can choose one of the following output options:

  • Selection (default)
  • Layer Mask
  • New Layer
  • New Layer With Layer Mask
  • New Document
  • New Document With Layer Mask

For details, see Select the image areas in focus.

Photoshop Focus Area selection
In action: A Focus Area selection

Content-aware features with color blending

Enhanced in this release of Photoshop CC

With the 2014 release of Photoshop CC, touching up images and removing unwanted elements from images is easier than ever before. The following content-aware features now incorporate algorithmic color blending:

  • Content-Aware Fill
  • Content-Aware Patch
  • Content-Aware Move
  • Content-Aware Extend
Photoshop Content Aware Extend operation
Example Content-Aware Extend operation

A. Without color blending B. With color blending 
Photoshop Content Aware Fill with Color Adaptation
Content-Aware Fill with Color Adaptation

While using the Content-Aware Patch, Content-Aware Move, and Content-Aware Extend tools, you can fine tune the degree to which algorithmic color-blending is applied to the image.

Photoshop Change the Color adaptation value
Adjust the Color adaptation value to control color blending

Structure

Enter a value between 1 and 5 to specify how closely the patch should reflect existing image patterns. If you enter 5, the patch adheres very strongly to existing image patterns. On the other hand, the patch adheres very loosely to the existing image patterns if you specify 1 as the value of Structure.

Color

Enter a value between 0 and 10 to specify the extent to which you want Photoshop to apply algorithmic color-blending to the patch. If you enter 0, color blending is disabled. A Color value of 10 applies maximum color blending.

For more information, see the following Help articles:

Enhancements to Photoshop Generator

Enhanced in this release of Photoshop CC

The 2014 release of Photoshop CC rolls out the following enhancements to Generator functionality:

  • You can choose to save image assets generated from particular layers/layer groups in a subfolder directly under the document's asset folder. Include the subfolder name in the layer/layer group name; for example:

    [subfolder]/Ellipse_4.jpg
  • You can specify document-wide default settings for the generated assets. Create an empty layer, begin its name with the keyword default, and then specify the default settings.

    For details, see Specify default settings for assets.

3D printing

Enhanced in this release of Photoshop CC

The 2014 release of Photoshop CC features exciting enhancements to 3D printing capability:

  • The Print Preview dialog now indicates what surfaces have been repaired. In the Print Preview dialog, select Show Repair. Photoshop displays the Original Mesh, Wall Thickness, and Closed Hole repairs using appropriate color coding:
Photoshop Print preview shows repaired surfaces
Print preview indicating what surfaces have been repaired

  • New rendering engine for the Print Preview dialog, resulting in more accurate previews with realistic lighting. The new rendering engine ray traces the 3D object better.
Photoshop 3D print previews
More accurate 3D print previews

  • New remeshing algorithm that greatly reduces the triangle count in your 3D object files
  • Better support for high­‐resolution textures when printing to Mcor and Zcorp printers

For details, see Print 3D objects.

Enable experimental features

New in this release of Photoshop CC

Photoshop now ships with the following experimental features that you can enable and try out:

  • Scale the UI 200% for high-density displays
  • Enable multitone 3D printing
  • Touch gestures

These features are not production-ready yet, so exercise discretion while using them. Do the following to enable an experimental feature:

  1. Select Preferences > Experimental Features.
  2. Select the experimental feature that you want to enable. For example, select Enable Multitone Printing.
  3. Click OK.
  4. Restart Photoshop.

For details, see Photoshop experimental features.

Sync settings improvements

Enhanced in this release of Photoshop CC

The 2014 release of Photoshop CC provides an improved Sync Settings experience featuring a simplified workflow and other useful enhancements:

  • You can now specify the direction of sync.
Photoshop Sync Settings
  • You can upload or download settings directly from the Preferences > Sync Settings tab.
  • You can now synchronize workspaces, keyboard shortcuts, and menu customizations
  • The Sync Settings log on the Preferences > Sync Settings tab displays the files being uploaded/downloaded, their sizes, and the timestamps for the upload/download operation. 
Photoshop Sync Settings log
Sync Settings log

See Sync Settings using Adobe Creative Cloud.

3D imaging

Enhanced in this release of Photoshop CC

OBJ group mesh import/export

In earlier versions of Photoshop, when you opened an OBJ file containing multiple meshes and multiple groups, all meshes were imported as a single group in the 3D panel. Beginning the 2014 release of Photoshop CC, the structure of the meshes and groups is preserved during import and export operations.

Photoshop OBJ imported
A. OBJ imported in earlier versions B. OBJ imported in Photoshop CC Version 2014 

Texture Properties dialog box enhancements

The 2014 release of Photoshop CC features useful enhancements to the Texture Properties dialog:

  • You can modify the name of the texture from directly within the dialog
  • The dialog features a new Apply To Matching Textures option. Using this option, you can apply the current UV settings to similar textures.

    For example, you might want a Diffuse map and a Bump map to scale together. Follow these steps:
    1. Select the same texture for both the maps.
    2. Edit the texture for one of the maps as per your requirements.
    3. To update the texture for the other map automatically, select Apply To Matching Textures in the Texture Properties dialog.
    4. Click OK.
Photoshop Select Apply to Matching Textures
Enhanced Texture Properties dialog

Improved convergence for emissive surfaces

Scenes with surfaces emitting light—for example, self-illuminating textures or colors—converge faster in the 2014 release of Photoshop CC. 

Export color lookup tables

New in this release of Photoshop CC

You can now export color lookup tables from Photoshop in multiple formats. The exported files can then be applied in Photoshop, After Effects, SpeedGrade, and other image/video editing applications.

You can export color lookup tables only from images that have a background layer as well as additional layers to modify colors.

For details, see Export color lookup tables.

Adobe Camera Raw enhancements

Enhanced in this release of Photoshop CC

For a list of enhancements in recent Adobe Camera Raw releases, see What's New in Adobe Camera Raw 8.x.

Other enhancements

  • Layer Copy CSS now supports Inner Shadow Layer effects
  • Smart Guides are now enabled by default
  • Brush highlights now show the currently-selected brush and brush changes
  • You can now access the most recently-used brush presets in the Brush context menu and the Brush Presets panel
  • New Hue and Brightness color picker cubes in the Color panel
  • Ability to specify transparency dithering in gradients
  • Ability to create gradients with a single stop. Saved single-stop gradients don't work with previous versions of Photoshop.
  • The new narrow Options bar lets you work more efficiently on devices having small screens. Select Preferences > Interface > Enable Narrow Options Bar.
  • Ability to create new gradient stops sampled from the current gradient preview
  • Import-only native support for MPEG-2 and Dolby audio
  • Support for new video formats, including Sony RAW and Canon RAW
  • Pin Edges To Liquify for warping in from the image edges
  • Reset All Tools now resets the tools displayed in the Tools panel slots to the default choices
  • Support for very large PNG files (up to Photoshop maximum and 2 GB limit)
  • Improved UI content for the New Document preset dialog
  • The Spectrum color picker in the Color Panel is now resizeable

Features no longer available

Deprecated in this release of Photoshop CC

Due to architectural changes, the following features are no longer available in the 2014 release of Photoshop CC:

  • Extension Panels using Flash, including Mini Bridge, Kuler and third Party Panels (such as Configurator panels)
  • Oil Paint filter
  • Mac OS X 10.6.x support

See this blog post for details.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy