W ramach rozpowszechniania formularza program Acrobat automatycznie tworzy portfolio PDF w celu zbierania danych przesyłanych przez użytkowników. Domyślnie ten plik jest zapisywany w tym samym folderze co oryginalny formularz i nosi nazwę nazwa_pliku_responses. Plik ten może posłużyć do zebrania odesłanych formularzy.

Adobe recommends

Adobe recommends
<a href="https://tv.adobe.com/watch/acrobat-x/managing-form-data/">Samuczek wideo: Zarządzanie formularzem danych</a>
Timothy Plumer, Jr.

Zbieranie danych przesłanych przez użytkowników

  1. Otwórz odesłany formularz.
  2. W oknie dialogowym Dodaj wypełniony formularz do pliku odpowiedzi wybierz jedną z następujących opcji:

    Dodaj do istniejącego pliku odpowiedzi

    Powoduje dołączenie danych do pliku odpowiedzi utworzonego w momencie użycia kreatora Rozpowszechnij formularz do rozesłania formularza. (W razie potrzeby kliknij przycisk Przeglądaj i zlokalizuj plik odpowiedzi).

    Utwórz nowy plik odpowiedzi

    Powoduje utworzenie nowego pliku odpowiedzi z wykorzystaniem nazwy i lokalizacji, które określił użytkownik.

Plik odpowiedzi zostaje otwarty po kliknięciu przycisku OK. Każdy odesłany formularz dodany do pliku odpowiedzi jest widoczny jako plik składowy portfolio PDF.

Kompilacja danych formularza

  1. W programie Acrobat wybierz polecenie Narzędzia > Formularze > Więcej opcji formularza > Kompiluj zwrócone formularze.
  2. W oknie dialogowym Kompiluj dane wykonaj dowolną z poniższych czynności w celu wybrania pliku odpowiedzi PDF:
    • Kliknij przycisk Przeglądaj, a następnie zlokalizuj i wybierz plik odpowiedzi.

    • Wpisz ścieżkę do pliku odpowiedzi.

  3. Kliknij przycisk Dodaj plik i przejdź do odesłanego formularza.
  4. Powtarzaj poprzedni etap niezbędną liczbę razy, dodając kolejne odesłane formularze.

Po kliknięciu przycisku OK dane z wybranych formularzy zostaną dodane do pliku odpowiedzi. Każdy odesłany formularz jest widoczny jako plik składowy portfolio PDF.

Dodawanie danych użytkowników do istniejącego pliku odpowiedzi

  1. W programie Acrobat otwórz plik odpowiedzi.
  2. W lewym panelu nawigacyjnym kliknij przycisk Dodaj.
  3. W oknie dialogowym Dodaj zwrócone formularze kliknij przycisk Dodaj plik. Następnie odszukaj i zaznacz odesłane formularze, po czym kliknij przycisk Otwórz.
  4. Powtarzaj poprzedni etap, dodając kolejne odesłane formularze umieszczone w innych folderach. Po zakończeniu kliknij przycisk OK.

Po zakończeniu każdy dodany formularz PDF jest widoczny jako plik składowy portfolio PDF.

Eksportowanie danych użytkowników z pliku odpowiedzi

Ten proces umożliwia zapisanie wszystkich pozycji pliku odpowiedzi w formacie portfolio PDF do arkusza kalkulacyjnego lub pliku XML.

  1. W programie Acrobat otwórz plik odpowiedzi i zaznacz dane do eksportowania.
  2. W lewym panelu nawigacyjnym kliknij przycisk Eksportuj.
  3. W oknie dialogowym Wybierz folder, aby zapisać plik określ nazwę, lokalizację i format (CSV lub XML) danych formularza, a następnie kliknij przycisk Zapisz.

Zarządzanie plikami danych formularzy

Odpowiedzi udzielone w formularzu PDF można przenosić do plików (i na odwrót) o formatach pozwalających przechowywać wszystkie te dane w pliku o dużo mniejszej wielkości niż dokument PDF.

Importowanie danych formularza

W niektórych scenariuszach obiegu pracy poszczególne osoby odsyłają wypełnione formularze w postaci jedynie plików danych, nie zaś pełnych plików PDF. Takie pliki danych nie są dokumentami PDF, ale wykorzystują inny format, taki jak FDF czy XML. Można wyświetlić dane przesłane przez poszczególnych respondentów w kontekście pliku PDF, otwierając oryginalny plik i importując informacje z pliku danych.

  1. W programie Acrobat otwórz formularz PDF, do którego mają zostać zaimportowane dane.
  2. Wybierz polecenie Narzędzia > Formularze > Wyczyść formularz.

    Uwaga:

    W przypadku importowania danych z innego pliku do formularza PDF importowane dane zastępują wszelkie informacje znajdujące się wcześniej w poszczególnych polach formularza. Jeśli jednak importowany plik danych zawiera jeden lub kilka pustych pól formularza, import nie spowoduje wyczyszczenia oryginalnych danych.

  3. Wybierz polecenie Narzędzia > Formularze > Więcej opcji formularza > Zarządzaj danymi formularza > Importuj dane.
  4. W oknie dialogowym Wybierz plik zawierający dane formularza wybierz z listy Plik typu format odpowiadający plikowi danych, który ma zostać zaimportowany. Następnie odszukaj i zaznacz ten plik, po czym kliknij przycisk Otwórz.

    Uwaga:

    Niektóre formaty są dostępne wyłącznie dla określonych formularzy PDF w zależności od aplikacji, w której utworzono formularz (np. Acrobat lub Designer ES2. Dane importowane z pliku tekstowego (txt) muszą być sformatowane w wierszach, w których kolumny są oddzielone znakami tabulacji.

Eksportowanie danych z pliku

Dane zawarte w ukończonym formularzu PDF można zapisać w pliku danych o innym formacie. W późniejszym terminie można ponownie wykorzystać te dane do ponownego wypełnienia tego samego formularza lub innego formularza zawierającego takie same pola o identycznych nazwach.

  1. W programie Acrobat otwórz ukończony plik formularza.
  2. Wybierz polecenie Narzędzia > Formularze > Więcej opcji formularza > Zarządzaj danymi formularza > Eksportuj dane.
  3. W oknie dialogowym Eksportuj dane formularza jako wybierz format, w którym mają zostać zapisane dane formularza (FDF, XFDF, XML lub TXT). Następnie określ położenie i nazwę pliku oraz kliknij przycisk Zapisz.

    Uwaga:

    Niektóre formaty plików są dostępne jedynie dla określonych typów formularzy PDF, zależnie od sposobu utworzenia formularza.

Scalanie eksportowanych danych w arkuszu kalkulacyjnym

Jeśli chcesz zebrać dane z formularzy, które nie wchodzą jeszcze w skład zestawu danych, użyj poniższej procedury.

  1. Wybierz polecenie Narzędzia > Formularze > Więcej opcji formularza > Zarządzaj danymi formularza > Połącz pliki danych w skoroszyt.
  2. W oknie dialogowym Eksportuj dane z kilku formularzy kliknij przycisk Dodaj plik.
  3. W oknie dialogowym Wybierz plik zawierający dane formularza wybierz z listy Plik typu opcję formatu pliku (Pliki danych formularza programu Acrobat lub Wszystkie pliki). Następnie znajdź pliki formularzy, które mają zostać połączone w arkusz kalkulacyjny, zaznacz je i kliknij przycisk Otwórz.
  4. W miarę potrzeby powtarzaj poprzedni etap, dodając kolejne pliki danych formularza z innych lokalizacji.
  5. Kliknij przycisk Eksportuj. Następnie określ folder i nazwę pliku arkusza kalkulacyjnego i kliknij przycisk Zapisz.
  6. W oknie dialogowym Postęp eksportu kliknij opcję Wyświetl plik teraz, aby otworzyć arkusz kalkulacyjny, albo opcję Zamknij okno dialogowe, aby wrócić do programu Acrobat.

Uwaga:

Gdy odesłane formularze znajdują się w pliku odpowiedzi, najwydajniejszym sposobem wyeksportowania danych do arkusza kalkulacyjnego jest użycie przycisku Eksportuj dane, znajdującego się w lewym panelu nawigacyjnym pliku odpowiedzi w formacie portfolio PDF.

Moduł śledzący formularze — informacje

Moduł śledzący umożliwia zarządzanie rozpowszechnionymi i odesłanymi formularzami. Za pośrednictwem modułu śledzącego można wyświetlać i edytować lokalizację pliku odpowiedzi, śledzić udzielanie odpowiedzi przez respondentów, dodawać kolejnych respondentów, wysyłać do respondentów wiadomości e-mail i przeglądać odpowiedzi udzielone dla formularza.

Śledzenie formularzy

  1. W programie Acrobat wybierz polecenie Edycja > Opcje formularza > Śledź lub Widok > Moduł śledzący.

  2. W panelu nawigacji z lewej strony rozwiń pozycję Formularze.

  3. Zaznacz formularz i wykonaj jedną z następujących czynności:

    • Aby wyświetlić wszystkie odpowiedzi dla danego formularza, kliknij pozycję Wyświetl odpowiedzi.

    • Aby zmienić położenie pliku odpowiedzi, w polu Położenie pliku odpowiedzi kliknij pozycję Edytuj położenie pliku.

    • Aby wyświetlić oryginalny formularz, kliknij pozycję Otwórz oryginalny formularz.

    • Aby wysłać formularz do innych odbiorców, kliknij pozycję Dodaj odbiorców.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online