Tworzenie formularza z istniejącego dokumentu

Możesz skonwertować istniejący dokument elektroniczny (w formacie Word, Excel lub PDF) lub zeskanować papierowy dokument do formularza PDF. Program Acrobat automatycznie wstawia interaktywne pola do formularza. Możesz edytować utworzony formularz, wprowadzając wyspecjalizowane pola, takie jak lista rozwijana, pole listy lub przyciski.

Rodzaje pól formularzy obsługiwanych w plikach PDF
Rodzaje pól formularzy obsługiwanych w plikach PDF

A. Pole podpisu opartego na certyfikacie B. Pole rozwijanej listy C. Pola tekstowe D. Pasek automatycznej wiadomości E. Pola wyboru F. Przyciski opcji G. Pole listy H. Przyciski 
  1. Kliknij menu Utwórz na pasku zadań i pozycję Utwórz formularz.

  2. Wybierz pozycję Z istniejącego dokumentu i kliknij Dalej.

  3. Zaznacz jedną z poniższych opcji:

    Użyj bieżącego dokumentu

    Przekształcanie otwartego dokumentu PDF w formularz interaktywny.

    Wybierz inny plik

    Przekształcanie istniejącego dokumentu elektronicznego (formatu Word, Excel lub PDF lub innych) w interaktywny formularz PDF. Kliknij Przeglądaj, a następnie wskaż plik.

    Skanuj formularz papierowy

    Skanowanie formularza papierowego i przekształcanie go w interaktywny formularz PDF.

  4. Kliknij Kontynuuj i wykonaj instrukcje ekranowe.

    Program Acrobat tworzy formularz i otwiera go w trybie edycji. Panel zadań Formularze zawiera opcje edycji formularza. Pasek narzędziowy zawiera obsługi pól formularza służące do wstawiania dodatkowych pól.

  5. Przejrzyj pola formularza utworzone przez program Acrobat. Dodaj pola do formularza za pomocą narzędzi pól formularza dostępnych w pasku zadań. Usuń pola, a także zmień ich rozmiar i położenie. Możesz dodawać następujące rodzaje pól formularzy:

    Pola z kodem kreskowym

    Zawierają kod kreskowy odpowiadający danym wprowadzanym przez użytkownika w wybranych polach. Kod ten jest odczytywany za pomocą odpowiedniego sprzętu i oprogramowania (sprzedawanego oddzielnie).

    Przyciski

    Naciśnięcie przycisku może wywoływać pewną akcję, na przykład otwarcie pliku, odtworzenie dźwięku czy przesłanie danych na serwer. Takie przyciski można dostosować do swoich potrzeb, kojarząc z nimi odpowiednie obrazy, teksty i zmiany wyglądu w reakcji na określone czynności użytkownika.

    Pola wyboru

    Reprezentują odpowiedzi lub wybory typu tak/nie. Jeśli formularz zawiera wiele pól wyboru, użytkownik może zaznaczyć dowolną ich liczbę.

    Pole podpisu elektronicznego

    Pole przeznaczone na podpis elektroniczny użytkownika.

    Rozwijana lista

    Pozwalają użytkownikowi wybrać element z menu podręcznego lub wpisać wartość. Możesz określić właściwość pola formularza, tak aby umożliwić użytkownikowi wprowadzenie wartości niestandardowej.

    Pola list

    Zawierają listy opcji do wyboru. Można tak ustawić właściwość pola formularza, aby klikanie z wciśniętym klawiszem Shift umożliwiało zaznaczanie wielu elementów listy.

    Przyciski opcji

    Reprezentują grupę opcji, spośród których użytkownik może wybrać jedną. Wszystkie przyciski opcji o tej samej nazwie funkcjonują razem, tworząc grupę.

    Pola tekstowe

    Pozwalają wprowadzać dane tekstowe, takie jak nazwisko, adres czy numer telefonu.

    Więcej informacji można znaleźć w sekcji Podstawy pól formularzy.

  6. Po zakończeniu projektowania formularza kliknij polecenie Zakończ edytowanie formularza.

Samouczek wideo „How to create PDF forms from existing documents” poświęcony tworzeniu formularzy: http://tv.adobe.com/watch/acrobat-xi-tips-tricks/how-to-create-new-pdf-forms-from-existing-documents/

Tworzenie formularzy dla usługi Adobe Sign

Możesz przekształcić istniejący formularz w formularz Adobe Sign lub przeciągnąć pola Adobe Sign i upuścić je w dokumencie PDF. Możesz wysyłać formularz do wypełnienia i podpisania za pomocą usługi Adobe Sign. Nie wszystkie pola można konwertować na pola Adobe Sign (np. pola listy, menu rozwijanego i przycisków). Możesz dodawać więcej pól Adobe Sign za pomocą paska narzędziowego.

  1. Otwórz plik PDF, który chcesz przekształcić w formularz Adobe Sign.

  2. Wybierz polecenia Narzędzia > Formularze > Edycja

  3. Jeśli zostanie wyświetlony monit z zapytaniem, czy program Acrobat ma automatycznie wykryć pola formularzy, kliknij przycisk Tak.

  4. Po wyświetleniu informacji o uruchomieniu trybu edytowania formularzy kliknij przycisk OK.

  5. Zostanie otwarty panel Formularze, w którym należy wybrać polecenie Zadania > Konwertuj na formularz Adobe Sign.

  6. Po wyświetleniu ostrzeżenia, że program Acrobat usunie pola formularzy nieobsługiwane przez usługę Adobe Sign, kliknij przycisk Dalej, a w następnym oknie ostrzeżenia kliknij przycisk OK.

  7. Aby dodać pole do formularza, wybierz jego ikonę na pasku narzędziowym. Umieść kursor w miejscu, w którym chcesz umieścić element i kliknij przyciskiem myszy, aby go wstawić.

  8. Wprowadź nazwę pola i określ osobę wypełniającą lub podpisującą. Aby ustawić właściwości pola, takie jak kolor krawędzi, wypełnienia, czcionki i rozmiar znaku, kliknij dwukrotnie pole.

    Właściwości pola formularza
    W momencie umieszczenia pola Adobe Sign można nadać mu nazwę i określić osobę, która powinna je wypełnić lub umieścić w nim podpis.

  9. Po wypełnieniu formularza kliknij polecenie Zakończ edytowanie formularza w pasku zadań.

  10. Aby wysłać formularz do usługi Adobe Sign, wybierz polecenie Podpisz > Poproś innych o podpisanie > Wyślij do podpisania.

  11. Gdy na ekranie zostanie wyświetlony komunikat „Dokument został wysłany do usługi Adobe Sign”, kliknij przycisk Aby kontynuować, przejdź do usługi Adobe Sign. Po otwarciu witryny Adobe Sign wykonuj polecenia wyświetlane na ekranie.

Dodawanie wyspecjalizowanych pól Adobe Sign

Możesz tworzyć wyspecjalizowane pola Adobe Sign, takie jak listy rozwijane, pola kontrolujące wprowadzone dane lub umożliwiające wprowadzenie jedynie konkretnych wartości. Możesz dodać nazwę pola za pomocą specjalnego znacznika tekstowego. Składnia znacznika zawiera wszystkie informacje niezbędne do utworzenia pola. Cechy pola są niewidoczne w programie Acrobat. Po przesłaniu formularza do witryny Adobe Sign system Adobe Sign tworzy pole na podstawie znacznika tekstowego.

Znacznik tekstowy można wprowadzić w polu Nazwa podczas wprowadzania pola. W razie potrzeby możesz zmienić tę nazwę w zakładce Ogólne okna dialogowego Właściwości (kliknij dwukrotnie pole, aby otworzyć jego właściwości). Listę znaczników tekstowych Adobe Sign można znaleźć w sekcji Tworzenie formularzy Adobe Sign przy użyciu znaczników tekstowych. Przy wstawianiu znacznika tekstowego do programu Acrobat należy pominąć nawiasy otaczające znaczniki: {{znacznik}}.

Zezwalanie użytkownikom programu Reader na zapisywanie danych formularzy

Według ustawień domyślnych, użytkownicy oprogramowania Reader X i wcześniejszych wersji nie mogą zapisywać wypełnionych plików formularzy. Autor pliku może rozszerzyć uprawnienia tych użytkowników, zezwalając im na zapisywanie danych formularza. Jeśli posiadasz program Acrobat Pro, możesz zezwolić użytkownikom programu Reader na wykonywanie dodatkowych czynności, takich jak dodawanie tekstu do formularzy nieinteraktywnych.

Uwaga:

W przeciwieństwie do wcześniejszych wersji programu Reader, wersja IX zawiera narzędzia Dodaj tekst i funkcję zapisywania danych formularza. Użytkownicy programu Acrobat mogą pisać w formularzach nieprzeznaczonych do wypełnienia, dodawać komentarze i cyfrowo podpisywać pliki PDF bez konieczności posiadania specjalnych uprawnień.

  1. Otwórz pojedynczy plik PDF lub wyświetl podgląd składowego pliku PDF w portfolio PDF.

  2. Jeśli edytujesz formularz, w panelu zadań Formularze kliknij opcję Zamknij edytowanie formularza.

  3. Wybierz polecenie Plik > Zapisz jako inny > Reader Extended PDF i wybierz jedną z następujących opcji:

    Włącz dodawanie tekstu w plikach PDF (niebędących formularzami PDF)

    (Acrobat Pro) Umożliwia użytkownikom wprowadzanie tekstu do dokumentów PDF lub płaskich formularzy, które nie zostały przygotowane z myślą o wypełnianiu elektronicznym (dla wcześniejszych wersji programu Reader).

    Komentowanie i mierzenie

    (Acrobat Pro) Umożliwia użytkownikom dodawanie komentarzy lub korzystanie z narzędzi Dane obiektu, Pomiar i Dane geograficzne.

    Włącz więcej narzędzi (w tym wypełnianie i zapisywanie formularza)

    Umożliwia użytkownikom zapisywanie danych wprowadzonych do formularzy interaktywnych lub formularzy możliwych do wypełnienia.

Ograniczenia lokalnego zapisywania wypełnionych formularzy

Zarówno program Acrobat Standard, jak i Acrobat Pro umożliwia użytkownikom programu Adobe Reader 8 lub nowszych wersji wypełnianie oraz lokalne zapisywanie formularzy PDF. Korzystanie z funkcji rozszerzeń programu Reader w zakresie lokalnego zapisywania formularzy PDF (zwanych dokumentami rozszerzonymi) jest ograniczone na dwa sposoby:

Liczba dokumentów rozszerzonych będących w użyciu

Użytkownik programu Acrobat Standard lub Acrobat Pro może wysłać rozszerzony dokument do nieograniczonej liczby użytkowników w celu jego wypełnienia. Przykład: Użytkownik programu Acrobat może opublikować pusty szablon formularza na stronie internetowej, która zezwala użytkownikom na wypełnianie i lokalne zapisywanie formularzy PDF. Dostęp do szablonu może uzyskać nieograniczona liczba użytkowników. Jednak użytkownik programu Acrobat może zebrać z wypełnionego formularza tylko 500 odpowiedzi. Ograniczenie to dotyczy zarówno kopii drukowanych (przesłanych w formie papierowej), jak również wersji elektronicznych wypełnionego formularza.

Liczba odbiorców dokumentu rozszerzonego

Użytkownik programu Acrobat Standard lub Acrobat Pro może wysłać rozszerzony dokument do maksymalnie 500 różnych odbiorców. Przykład: Użytkownik programu Acrobat jest pracownikiem firmy zatrudniającej nie więcej niż 500 osób. Użytkownik programu Acrobat może wysłać do wspomnianych 500 odbiorców nieograniczoną liczbę kopii dokumentu rozszerzonego i zebrać z wypełnionego formularza nieograniczoną liczbę odpowiedzi.

Oba ograniczenia odnoszą się do jednostki/formy, przy czym wielu użytkowników w ramach tej samej jednostki nie może nadużywać tej funkcji. Uzyskanie dodatkowej licencji na użytkowanie programu Acrobat nie powoduje zwiększenia wspomnianego limitu. Przykład: Pięcioro użytkowników programu Acrobat Standard 9 w tej samej firmie może wysłać ten sam dokument rozszerzony w celu otrzymania odpowiedzi i przetworzenia danych łącznie 500 razy.

Programy Acrobat Standard i Acrobat Pro są wyposażone w technologię pozwalającą na włączenie w dokumentach PDF pewnych funkcji poprzez użycie poświadczeń elektronicznych. Poświadczenie takie (zwane „kluczem”) jest zakodowane w oprogramowaniu. Użytkownik zobowiązuje się nie podejmować prób uzyskania dostępu do klucza ani kontrolowania, wyłączania, usuwania lub dystrybuowania go w jakimkolwiek celu.

Dodawanie do formularzy skryptów JavaScript

Język JavaScript umożliwia tworzenie interaktywnych stron internetowych. Firma Adobe rozszerzyła ten język, po to by ułatwić współpracę skryptów z formularzami PDF. Najbardziej typowe zastosowania skryptów JavaScript w programie Acrobat to: formatowanie danych, wykonywanie działań na danych, zatwierdzanie danych i przypisywanie zadań do pól. W systemie Windows formularze Adobe PDF można też skonfigurować w taki sposób, aby zapewnić ich bezpośrednią łączność z bazami danych ODBC (Open Database Connection).

Uwaga:

Projektanci formularzy dynamicznych muszą mieć świadomość, że program Reader nie obsługuje niektórych niestandardowych skryptów JavaScript, w związku z czym formularze dynamiczne mogą być wyświetlane nieprawidłowo w tym programie (chyba że skojarzono z nimi dodatkowe prawa użytkowania).

Dodatkowe zasoby

Więcej informacji na temat skryptów Acrobat JavaScript można znaleźć w następujących zasobach:

Rozpowszechnianie (wysyłanie) formularzy wśród odbiorców

Rozpowszechnianie plików PDF lub formularzy internetowych

Po utworzeniu formularza należy wybrać metodę wysyłki do odbiorców.

  1. Wybierz polecenie Narzędzia > Formularze > Rozpowszechnij.

  2. Zależnie od elementów wykrytych przez program Acrobat może pojawić się seria komunikatów. Postępuj zgodnie z instrukcjami wyświetlanymi na ekranie, po czym zapisz formularz.
  3. Wybierz metodę rozpowszechniania i zbierania:

    E-mail

    Zbieranie odpowiedzi w skrzynce odbiorczej e-mail.

    Serwer wewnętrzny

    Proces rozprowadzania i zbierania odpowiedzi odbywa się przez wewnętrzny serwer, na przykład przez SharePoint lub folder sieciowy . Więcej informacji można znaleźć w sekcji Określanie serwera.

    Więcej informacji można znaleźć w sekcji Wybór opcji rozpowszechniania dla recenzji i formularzy.

  4. Kliknij przycisk Kontynuuj i postępuj zgodnie z instrukcjami wyświetlanymi na ekranie, aby rozpowszechnić formularz.

  5. Jeśli wybrano zbieranie odpowiedzi w skrzynce odbiorczej poczty e-mail, wykonaj jedną z następujących czynności:

Uwaga:

Jeśli nie znasz adresów e-mail odbiorców, wprowadź swój adres e-mail. System wyśle na ten adres łącze do formularza, które można wysłać pocztą e-mail do odbiorców.

Rozpowszechnianie formularzy Adobe Sign

Po utworzeniu formularza Adobe Sign możesz rozesłać go do wypełnienia lub podpisania przy użyciu usługi Adobe Sign.

  1. Jeśli formularz jest przestawiony w tryb edycji, kliknij pozycję Zakończ edytowanie formularza na pasku zadań.

  2. Jeśli formularz nie został jeszcze zapisany, zapisz go teraz.

  3. Aby wysłać formularz do usługi Adobe Sign, wybierz polecenie Podpisz > Poproś innych o podpisanie > Wyślij do podpisania.

  4. Gdy na ekranie zostanie wyświetlony komunikat „Dokument został wysłany do usługi Adobe Sign”, kliknij przycisk Aby kontynuować, przejdź do usługi Adobe Sign.

  5. Po otwarciu witryny Adobe Sign wykonuj polecenia wyświetlane na ekranie.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online