Tworzenie indeksu w pliku PDF i zarządzanie nim

Osadzenie w dokumencie indeksu z wyrazami z tego dokumentu może znacznie skrócić czas potrzebny do przeszukiwania długich plików PDF. Program Acrobat przeszukuje indeks znacznie szybciej, niż dokument. Osadzony indeks jest dołączony w rozpowszechnianych lub udostępnianych kopiach pliku PDF. Przeszukiwanie plików PDF z osadzonymi indeksami nie różni się od przeszukiwania dokumentów bez takich indeksów; operacja nie wymaga wykonania dodatkowych czynności.

Dodawanie indeksu do pliku PDF

  1. Po otwarciu dokumentu w programie Acrobat wybierz polecenie Narzędzia > Przetwarzanie dokumentu > Zarządzaj osadzonym indeksem.
  2. W oknie dialogowym Zarządzaj osadzonym indeksem kliknij przycisk Osadzony indeks.
  3. Zapoznaj się z wyświetlonymi komunikatami i kliknij OK.

    Uwaga:

    W programach Outlook i Lotus Notes, opcje osadzania indeksu pojawiają się przy konwersji wiadomości lun folderów poczty elektronicznej na PDF. Operacja jest szczególnie zalecana w przypadku folderów z wieloma wiadomościami poczty elektronicznej.

Uaktualnianie lub usuwanie indeksu osadzonego w pliku PDF

  1. Wybierz polecenie Narzędzia > Przetwarzanie dokumentu > Zarządzaj osadzonym indeksem.
  2. Kliknij opcję Uaktualnij indeks lub Usuń indeks.

Informacje o funkcji Katalog (Acrobat Pro)

Wybrana grupa plików PDF może być zdefiniowana jako katalog i posiadać ujednolicony indeks dla całej kolekcji dokumentów. Indeks znacznie przyspiesza przeszukiwanie skatalogowanych plików PDF pod kątem określonych informacji.

Dystrybucja kolekcji na CD może obejmować indeks z plikami PDF.

Funkcja katalogowania jest dostępna dla dokumentów zawierających znaki romańskie, a ponadto chińskie, japońskie i koreańskie. Katalogować można następujące elementy: tekst dokumentu, komentarze, zakładki, pola formularzy, znaczniki, metadane obiektów i dokumentów, załączniki, informacje o dokumencie, podpisy elektroniczne, metadane obrazków XIF oraz specjalne właściwości dokumentów.

Przygotowanie dokumentów PDF do utworzenia indeksu (Acrobat Pro)

Procedurę tworzenia skorowidza należy rozpocząć od utworzenia folderu zawierającego wybrane pliki Adobe PDF. Wszystkie pliki PDF powinny być kompletne zarówno pod względem zawartości, jak i funkcji elektronicznych (łączy, zakładek i pól formularzy). Jeśli pliki, które mają być uwzględnione w indeksie, zawierają dokumenty zeskanowane, należy sprawdzić, czy ich tekst daje się przeszukiwać. Dzielenie długich dokumentów na mniejsze, wielkości rozdziału, znacznie skraca czas ich przeszukiwania. Przeszukiwanie staje się łatwiejsze także dzięki dodawaniu dodatkowych informacji do właściwości dokumentu.

Przed utworzeniem indeksu kolekcji dokumentów należy koniecznie skonfigurować strukturę dokumentów na dysku lub woluminie serwera sieciowego, a następnie zweryfikować nazwy plików pod kątem zgodności z różnymi platformami. W trakcie wyszukiwania obejmującego różne platformy nazwy plików mogą ulegać skracaniu i być trudne do pobrania. Aby uniknąć takich ograniczeń, warto zapoznać się z podanymi niżej wskazówkami:

  • Zmień nazwy plików, folderów i indeksów, korzystając z konwencji MS-DOS (osiem znaków lub mniej poprzedzających trzyznakowe rozszerzenie nazwy pliku), zwłaszcza w sytuacjach, gdy kolekcja dokumentów i indeks mają być dostarczane na dysku CD-ROM sformatowanym zgodnie ze standardem ISO 9660.

  • Usuń z nazw plików i folderów znaki rozszerzone, takie jak znaki akcentowane i znaki spoza alfabetu języka angielskiego. (Czcionka używana przez funkcję Katalog nie obsługuje kodów znaków od 133 do 159).

  • Nie używaj głęboko zagnieżdżonych nazw ścieżek lub folderów przekraczających 256 znaków w przypadku indeksów, które będą przeszukiwane przez użytkowników systemu Mac OS.

  • W przypadku używania systemu Mac OS w połączeniu z serwerem OS/2 LAN skonfiguruj serwer IBM® LAN Server Macintosh (LSM) tak, aby wymuszał stosowanie konwencji nazw plików MS-DOS lub indeksuj tylko woluminy FAT. (System plików woluminów HPFS może zawierać długie nazwy, których nie będzie można prawidłowo pobrać).

    Jeśli struktura dokumentu zawiera podfoldery, które nie będą indeksowane, to można je wyłączyć z tej operacji.

Dodawanie metadanych do właściwości dokumentu (Acrobat Pro)

Aby ułatwić przeszukiwanie plików PDF, można uzupełnić ich właściwości o pewne dodatkowe informacje zwane metadanymi. (Właściwości otwartego w danej chwili dokumentu PDF można przeglądać po wybraniu kolejno opcji Plik > Właściwości dokumentu i kliknięciu zakładki Opis).

Uwaga:

(Windows) Właściwości danych można wprowadzać i przeglądać na poziomie pulpitu. W tym celu należy uruchomić Eksploratora Windows, kliknąć na dokumencie z wciśniętym prawym przyciskiem myszy, wybrać polecenie Właściwości i kliknąć na zakładce PDF. Wszelkie informacje, które zostaną wprowadzone lub zmienione w tym miejscu, będą również widoczne podczas otwierania pliku, w oknie dialogowym Opis właściwości dokumentu.

Dodając dane do właściwości dokumentu, warto przestrzegać następujących zaleceń.

  • W polu Tytuł należy umieścić dobrą, opisową nazwę. Nazwa pliku dokumentu powinna być wyświetlana w oknie dialogowym Wyniki wyszukiwania.

  • Podobne informacje powinny być zawsze umieszczane w tym samym polu. Na przykład, złą praktyką jest dodawanie tego samego ważnego terminu do pola Temat pewnych dokumentów i pola Słowa kluczowe innych dokumentów.

  • Informacje tego samego rodzaju powinny być zawsze określane tym samym terminem. Złą praktyką jest na przykład używanie terminu biologia w pewnych dokumentach, a terminu przyroda w innych.

  • W polu Autor należy podać informacje o osobie lub jednostce organizacyjnej odpowiedzialnej za treść dokumentu. Na przykład, autorem dokumentu poświęconego sprawom zatrudnienia może być Wydział spraw osobowych.

  • Nazwy wyróżnionych części dokumentu powinny być wprowadzane jako słowa kluczowe. Na przykład aby oznaczyć jeden spośród setek dokumentów na pewien temat, można wpisać w polu Słowa kluczowe określenie w rodzaju doc#=m234.

  • W celu określenia kategorii dokumentów należy używać pól Temat i Słowa kluczowe (osobno lub łącznie). Kategorię pewnego dokumentu można na przykład określić, wpisując w polu Temat wyraz raport, a w polu Słowa kluczowe — wyraz tygodniowy lub miesięczny.

    Użytkownicy o dużym doświadczeniu w pracy z formatem Adobe PDF mogą podczas tworzenia indeksu zdefiniować własne pola niestandardowe, na przykład Typ dokumentu, Numer dokumentu, Identyfikator dokumentu itp. Dotyczy to tylko użytkowników zaawansowanych i wykracza poza zakres tematyczny Pomocy programu Acrobat.

Tworzenie indeksu dla kolekcji (Acrobat Pro)

Wynikiem zbudowania nowego indeksu jest nowy plik .pdx i nowy folder zawierający co najmniej jeden plik .idx. Pliki IDX zawierają hasła indeksu. Wszystkie one muszą być dostępne dla użytkowników, którzy będą przeszukiwali indeks.

Okna dialogowe w programie <span class="uicontrol">Acrobat Pro</span> przeznaczone dla procesu tworzenia indeksu
Okna dialogowe w programie <span class="uicontrol">Acrobat Pro</span> przeznaczone dla procesu tworzenia indeksu

  1. Wybierz polecenie Narzędzia > Przetwarzanie dokumentu > Indeks pełnotekstowy z katalogiem, a następnie kliknij przycisk Nowy indeks.

    Uwaga:

    Jeśli nie widzisz panelu Przetwarzanie dokumentu, zapoznaj się z instrukcjami na temat dodawania paneli w części Panele zadań.

  2. W polu Tytuł indeksu wpisz nazwę pliku.
  3. W polu Opis indeksu, wpisz kilka słów na temat rodzaju tego indeksu i jego przeznaczenia.
  4. Kliknij Opcje i zaznacz wybrane opcje zaawansowane. Kliknij OK.
  5. W polu Dołącz katalogi, kliknij Dodaj, zaznacz folder z niektórymi lub wszystkimi plikami PDF objętymi indeksem i kliknij OK. Powtórz operację, aby dodać więcej folderów.

    Uwaga:

    Każdy folder zagnieżdżony w dołączonym folderze zostanie także objęty indeksowaniem. Jeśli nie planuje się przenoszenia skorowidza ani żadnych elementów z kolekcji dokumentów, można dodawać foldery z wielu różnych serwerów i dysków.

  6. W polu Wyklucz podkatalogi, kliknij opcję Dodaj i zaznacz zagnieżdżony folder z plikami PDF, które nie będą indeksowane. Kliknij OK i powtórz opisane czynności w razie potrzeby.
  7. Przejrzyj zaznaczenia. Aby edytować listę folderów dołączanych lub wykluczanych, zaznacz wybrany folder i kliknij Usuń.
  8. Kliknij przycisk Buduj i określ położenie pliku indeksu. Kliknij Zapisz, a potem:
    • Kliknij Zamknij po zakończeniu indeksowania.

    • Kliknij Stop, aby anulować indeksowanie.

    Uwaga:

    Po zatrzymaniu procedury tworzenia indeksu nie można jej wznowić, ale nie trzeba cofać wykonanego działania. Wybrane opcje i foldery pozostają bez zmian. Na tym etapie można kliknąć na opcji Otwórz indeks, która spowoduje otwarcie częściowego indeksu i przejrzeć go.

    Uwaga:

    Jeśli w polach Dołącz te katalogi i Wyłącz te podkatalogi są obcinane długie nazwy ścieżek, to aby wyświetlić pełną ścieżkę dostępu do danego folderu, należy ustawić kursor myszy nad wielokropkiem (...) i poczekać, aż pojawi się etykietka z pełną nazwą.

Opcje indeksowania, okno dialogowe

Nie dołączaj liczb

Zaznaczenie tej opcji powoduje, że z indeksu wyłączane są wszystkie występujące w dokumentach liczby. Wyłączenie liczb sprzyja mniejszym rozmiarom indeksu i przyspiesza wyszukiwanie.

Dodaj identyfikator do plików Adobe PDF v1.0

Opcję tę należy zaznaczyć, jeśli dana kolekcja zawiera pliki PDF starsze niż pliki w wersji Adobe v2.0, a więc pliki utworzone w aplikacji, która nie dodawała automatycznie numerów identyfikacyjnych. Identyfikatory plików są potrzebne w sytuacjach, gdy długie nazwy systemu Mac OS są skracane podczas tłumaczenia na nazwy systemu MS-DOS. Program Acrobat 2.0 i jego nowsze wersje automatycznie dodają identyfikatory.

Nie ostrzegaj o zmienionych dokumentach w czasie wyszukiwania

Jeśli opcja ta nie jest zaznaczona, to podczas przeszukiwania plików, które uległy zmianie od czasu ostatniej przebudowy indeksu, jest wyświetlany komunikat ostrzegawczy.

Ustawienia własne

Opcja jest przeznaczona do umieszczania w indeksie specjalnych właściwości dokumentu; indeksowanie obejmuje tylko te właściwości specjalne, które istnieją już w dokumentach PDF. W menu Typ określ typ właściwości i kliknij przycisk Dodaj. Właściwości te są wyświetlane podczas przeszukiwania otrzymanego indeksu jako opcja wyszukiwania w menu dodatkowych kryteriów, w oknie PDF Szukaj. Na przykład, wpisanie właściwości specjalnej Nazwa dokumentu i zaznaczenie właściwości ciągu z menu Typ, spowoduje, że osoba przeszukujące indeks może sprawdzić tę właściwość specjalną zaznaczając opcję Nazwa dokumentu, umieszczoną w menu Użyj tych dodatkowych kryteriów.

Uwaga:

Jeśli pola specjalne zostały utworzone w aplikacji pakietu Microsoft Office przy zaznaczonej opcji Konwertuj informacje o dokumencie (w module PDFMaker), pola te będą przekazywane do wszystkich tworzonych plików Adobe PDF.  

Pola XMP

Opcja jest przeznaczona do dołączania pól XMP. Specjalne pola XMP są indeksowane i pojawiają się w menu dodatkowych kryteriów, umożliwiając ich wyszukiwanie w zaznaczonych indeksach.

Wyrazy pomijane

Opcja ta pozwala wyłączyć z wyników przeszukiwania skorowidza wybrane wyrazy (nie więcej niż 500). Wpisz wyraz, kliknij Dodaj i powtórz opisane czynności w razie potrzeby. Wykluczanie wyrazów może zmniejszyć indeks o 10-15%. Wyrazy pomijane mogą mieć długość do 128 znaków, a w ich pisowni są rozróżniane małe i wielkie litery.

Uwaga:

Aby uniemożliwić użytkownikom wyszukiwanie wyrażeń zawierających te wyrazy, umieść wyrazy, które nie są indeksowane, w pliku Catalog Read Me.

Znaczniki struktury

Opcja ta ma zastosowanie w przypadku oznakowanych dokumentów o logicznej strukturze, a umożliwia przeszukiwanie końcowych węzłów znaczników.

Uwaga:

Opcje Właściwości specjalne, Wyrazy pomijane i Znaczniki stosują się tylko do bieżącego indeksu. Aby ich ustawienia były stosowane globalnie, do wszystkich tworzonych indeksów, należy zmienić domyślne ustawienia preferencji dla pól dostosowanych, wyrazów pomijanych i znaczników w Preferencjach katalogu.  

Pliki ReadMe katalogu (Acrobat Pro)

Często warto również przygotować oddzielny plik ReadMe (Czytaj mnie) i umieścić go w folderze z plikami indeksu. Plik ten może zawierać szczegółowe informacje dotyczące indeksu:

  • Rodzaj dokumentów uwzględnionych w indeksie.

  • Obsługiwane opcje wyszukiwania.

  • Osoba odpowiedzialna za kontakt lub telefon kontaktowy.

  • Lista numerów i wyrazów wyłączonych z indeksu.

  • Lista folderów zawierających dokumenty o indeksie opartym na sieci LAN lub lista dokumentów o indeksie wykorzystującym dysk. Do elementów listy można dołączyć krótkie opisy ich zawartości.

  • Lista wartości skojarzonych z poszczególnymi dokumentami (jeśli użyto wartości w polu Informacje o dokumencie).

    Jeśli katalog zawiera wyjątkowo dużo dokumentów, ich indeks warto uzupełnić tabelą wartości dla poszczególnych dokumentów. Tabela taka może stanowić część pliku Readme lub osobny dokument. Będzie ona użyteczna, gdy rozbudowując indeks, trzeba będzie zachować jego spójność.

Rewizja indeksu (Acrobat Pro)

Istniejący indeks można uaktualnić, przebudować lub wyczyścić.

  1. Wybierz polecenie Narzędzia > Przetwarzanie dokumentu > Indeks pełnotekstowy z katalogiem, a następnie kliknij przycisk Otwórz indeks.
  2. Odszukaj i zaznacz plik definicji indeksu (PDX) i kliknij przycisk Otwórz.
  3. Jeśli indeks został utworzony przy pomocy aplikacji Acrobat 5.0 lub wcześniejszej, zaznacz opcję Utwórz kopię, umożliwiającą utworzenie nowego indeksu (bez nadpisywania wersji wcześniejszej) lub zaznacz opcję Nadpisz stary indeks, nadpisującą wcześniejszy indeks.
  4. W oknie dialogowym Definicja indeksu wprowadź wybrane zmiany i kliknij funkcję, którą ma wykonać program Acrobat:

    Buduj

    Tworzy nowy plik IDX na podstawie istniejących informacji i uaktualnia go, dodając nowe hasła oraz oznaczając zmienione lub nieaktualne hasła jako nieważne. Wprowadzanie dużej liczby zmian lub częste stosowanie tej opcji zamiast tworzenia nowego indeksu znacznie wydłuża czas przeszukiwania indeksu.

    Odbuduj

    Tworzy nowy indeks z jednoczesnym nadpisaniem dotychczasowego indeksu i związanych z nim plików IDX.

    Wyczyść

    Usuwa zawartość indeksu (pliki IDX) bez usuwania samego indeksu (PDX).

Preferencje katalogu (Acrobat Pro)

Istnieje możliwość określenia preferencji katalogowania, które będą stosowane globalnie, do wszystkich, kolejno budowanych indeksów. Niektóre z tych preferencji można dostosować do potrzeb konkretnego indeksu, to znaczy wybrać odpowiednie ustawienia w trakcie definiowania indeksu.

W oknie dialogowym Preferencje w obszarze Kategorie wybierz pozycję Katalog. Wiele opcji jest identycznych z opcjami opisanymi dla procesu tworzenia indeksu.

Uwaga:

Wymuszanie zgodności ze standardem ISO 9660 jest użyteczne, jeśli podczas przygotowywania dokumentów do utworzenia indeksu długie nazwy dokumentów Adobe PDF nie mają być zamieniane na nazwy systemu MS-DOS. Należy jednak pamiętać, że nawet jeśli nazwy plików nie muszą być zgodne z konwencją MS-DOS, nazwy folderów muszą (mogą liczyć nie więcej niż 8 znaków).

Planowanie uaktualnień indeksu (Acrobat Pro)

Użyj funkcji Katalog oraz pliku wsadowego katalogu PDX (bpdx), aby zaplanować czas i częstotliwość automatycznego budowania, przebudowywania, uaktualniania i czyszczenia indeksu. Plik BPDX jest plikiem tekstowym zawierającym listę zależnych od platformy ścieżek plików indeksów katalogu i ich flag. Aplikacje do zarządzania harmonogramami, takie jak Harmonogram zadań systemu Windows, umożliwiają wyświetlenie pliku BPDX w programie Acrobat. Następnie program Acrobat ponownie tworzy indeks zgodnie z flagami określonymi w pliku BPDX.

Aby uzyskać więcej informacji na temat opracowywania uaktualnień indeksów, wyszukaj wyrażenie BPDX na stronie www.adobe.com/pl/support.

 

Uwaga:

Aby korzystać z plików BPDX, w oknie dialogowym Preferencje w obszarze Katalog zaznacz dla pozycji Zezwalaj na uruchamianie plików wsadowych katalogu (bpdx).

Przenoszenie kolekcji oraz ich indeksów (Acrobat Pro)

Przenoszenie kolekcji stanowi często drugi etap opracowywania indeksu: w etapie pierwszym kolekcja indeksowanych dokumentów jest tworzona i testowana na lokalnym dysku twardym, a w etapie drugim jest przenoszona na serwer lub dysk sieciowy. Definicja indeksu zawiera ścieżki względne między plikiem definicji indeksu (PDX) a folderami zawierającymi dokumenty kolekcji. Jeśli ścieżki te nie uległy zmianie, przeniesienie kolekcji nie wymaga uprzedniej przebudowy indeksu. Jeśli plik PDX i foldery zawierające indeksowane dokumenty znajdują się w tym samym folderze nadrzędnym, przeniesienie kolekcji z zachowaniem ścieżek względnych może polegać na zwykłym przeniesieniu tego folderu nadrzędnego.

Jeśli ścieżki względne uległy zmianie, to po przeniesieniu kolekcji indeksowanych dokumentów trzeba utworzyć nowy indeks. Niemniej, można nadal korzystać z oryginalnego pliku PDX. Aby móc z niego skorzystać, należy w pierwszej kolejności przenieść zindeksowane dokumenty. Następnie należy skopiować plik PDX do folderu, w którym ma zostać utworzony nowy indeks, i jeśli to konieczne, dokonać edycji list dołączanych i wykluczanych katalogów i podkatalogów.

Jeśli indeks znajduje się na dysku lub woluminie serwera, który nie zawiera żadnej części odpowiedniej kolekcji, przeniesienie jednego z tych elementów — kolekcji lub jej indeksu — spowoduje uszkodzenie indeksu. Jeśli planowane jest przeniesienie kolekcji w inne miejsce sieci lub na dysk CD, należy utworzyć i zbudować indeks w tym samym miejscu, gdzie znajduje się kolekcja.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online