Czy ten formularz jest przeznaczony do wypełnienia?

Nie wszystkie formularze są przeznaczone do wypełnienia. Czasami twórcy formularzy nie przekształcają swoich dokumentów PDF w interaktywne formularze przeznaczone do wypełnienia. Mogą też celowo zaprojektować formularz, który można wypełnić tylko ręcznie lub przy pomocy narzędzia Dodaj tekst. Są to formularze nieinteraktywne, nazywane formularzami płaskimi.

Formularze do wypełnienia w programie Reader XI
Formularze do wypełnienia w programie Reader XI

A. Interaktywne formularze podświetlają miejsce wpisywania B. W formularzach z narzędziami Dodaj komentarz tekstowy można dodawać tekst w dowolnym miejscu 

Wypełnianie formularzy interaktywnych

Formularz interaktywny zawiera pola, które można zaznaczyć i wypełnić.

Interaktywny formularz przeznaczony do wypełnienia
Interaktywny formularz przeznaczony do wypełnienia

A. Na obecność pól przeznaczonych do wypełnienia wskazuje purpurowy pasek komunikatów. B. Po kliknięciu wskazuje miejsce, w którym znajdują się pola przeznaczone do wypełnienia. 
  1. Jeśli to konieczne, kliknij dokument prawym przyciskiem myszy i wybierz albo narzędzie Rączka, albo narzędzie Zaznaczanie z wyskakującego menu.

    Kształt wskaźnika zmieni się po przesunięciu go nad pole. Na przykład, jeśli możesz wpisywać tekst w pole formularza, to narzędzie Rączka zmienia się w I-beam . Niektóre pola formularza są dynamiczne, to znaczy ich wymiary są zmieniane dynamicznie w zależności od objętości wprowadzanych danych; pola takie mogą wychodzić poza jedną stronę.

  2. (Opcjonalnie) Aby ułatwić identyfikowanie pól formularza, kliknij przycisk Podświetl pola na pasku komunikatów dokumentu. Wszystkie pola formularza są wyróżniane kolorem (domyślnie jest to kolor jasnoniebieski), a pola. które trzeba wypełnić, są otaczane konturem w innym kolorze (domyślnie jest to kolor czerwony).

  3. Kliknij, aby wybrać opcje, na przykład przyciski opcji. Aby pisać, kliknij wewnątrz pola tekstowego.
  4. Naciśnij klawisz Tab, aby przejść do przodu lub Shift+Tab, aby się cofnąć.
  5. Po zakończeniu kliknij przycisk Wyślij, aby albo wysłać dane na serwer, albo utworzyć wiadomość e-mail do wysłania danych. Przycisk Wyślij może pojawić się na purpurowym pasku komunikatów na górze formularza lub w zawartości formularza.

Aby uzyskać wskazówki dotyczące rozwiązywania problemów z wypełnianiem formularzy, zobacz Rozwiązywanie problemów z formularzami.

Wypełnienie płaskich formularzy przy pomocy narzędzia Dodaj tekst

Płaski formularz nie zawiera pól interaktywnych. Możesz jednak wprowadzić dane w polach formularza płaskiego za pomocą narzędzia Dodaj tekst. Programy Acrobat i Reader XI są wyposażone w narzędzie Dodaj tekst. W programie Reader X lub w jego wcześniejszej wersji tekst można dodać tylko wtedy, gdy kreator formularza umożliwia korzystanie z opcji Dodaj tekst (lub narzędzia Maszyna do pisania).

Uwaga:

Tekst, który zostanie dodany przy pomocy narzędzia Dodaj tekst jest typem komentarza. Pojawia się na liście komentarzy (Komentarz > Lista komentarzy).

Płaskie formularze przeznaczone do wypełnienia (trzy rodzaje) przy użyciu narzędzia Dodaj tekst
Płaskie formularze przeznaczone do wypełnienia (trzy rodzaje). Do wypełniania płaskich formularzy służy narzędzie Dodaj tekst.

A. Narzędzie Dodaj tekst w ruchomym pasku narzędziowym przeglądarki. B. Narzędzie Dodaj tekst na purpurowym pasku komunikatów. C. Narzędzie Dodaj tekst wybrane w panelu Podpisz wyświetla ruchomy pasek narzędziowy. 
  1. Wykonaj jedną z następujących czynności w zależności od tego, jak formularz wygląda w oknie:

    • Na purpurowym pasku komunikatu lub ruchomym pasku narzędziowym kliknij przycisk Maszyna do pisania.

    • W aplikacji Acrobat (nie w przeglądarce), wybierz polecenie Podpisz > Dodaj tekst.

    Wybierz polecenie Dodaj tekst i wypełnij formularz
    Wybierz polecenie Dodaj tekst i wypełnij formularz.

    Jeśli formularz pojawi się w oknie przeglądarki, przesuń kursor blisko dolnej części formularza i kliknij ikonę Zapisz na półprzezroczystym, ruchomym pasku narzędziowym. Otwórz formularz PDF w programie Acrobat i wybierz polecenie Podpisz > Dodaj tekst.

    Otwórz w programie Acrobat i wybierz pozycje Podpisz > Dodaj tekst.
    Pasek narzędziowy Dodaj tekst nie jest widoczny. Zapisz formularz, a następnie otwórz go w programie Acrobat i wybierz pozycje Podpisz > Dodaj tekst.

  2. Kliknij puste pole formularza i pisz.

  3. (Opcjonalnie) Aby zmienić rozmiar tekstu, położenie lub czcionkę, dostosuj opcje na purpurowym pasku komunikatów lub ruchomym pasku narzędziowym. Więcej informacji na temat narzędzia i paska narzędziowego Dodaj tekst można znaleźć w artykule Dodawanie tekstu za pomocą narzędzia Dodaj tekst.

  4. Po zakończeniu wydrukuj kopię wypełnionego formularza.

    Uwaga:

    Nie można wysłać elektronicznie formularza wypełnionego przy użyciu narzędzia Dodaj tekst. Wypełniony formularz należy wydrukować. Upewnij się, że wybrano opcję Dokument i znaczniki w oknie dialogowym Drukuj.

Wypełnienie płaskich formularzy w przeglądarce

Formularz PDF często wyświetlany jest w przeglądarce, na przykład gdy klikniesz łącze na stronie internetowej. Jeśli taki formularz nie zawiera pól interaktywnych, to do jego wypełnienia można użyć narzędzia Dodaj tekst. W przypadku niektórych formularzy PDF, pasek narzędziowy Dodaj tekst jest wyświetlany natychmiast po ich otwarciu. W innych należy najpierw zapisać dany formularz, następnie otworzyć go bezpośrednio w programie Acrobat. Program Reader XI zawiera narzędzie Dodaj tekst. We wcześniejszych wersjach programu Reader narzędzie to jest dostępne tylko wtedy, jeśli twórca formularza zezwolił na korzystanie z tej funkcji.

Jeśli pasek narzędziowy Dodaj tekst jest widoczny, kliknij pozycję Dodaj tekst. Następnie kliknij stronę i rozpocznij wpisywanie. Aby uzyskać więcej informacji, zapoznaj się z sekcją Wypełnienie płaskich formularzy przy pomocy narzędzia Dodaj tekst.

Narzędzie dodaj tekst dostępne w ruchomym pasku narzędziowym
Narzędzie dodaj tekst dostępne w ruchomym pasku narzędziowym

Jeśli pasek narzędziowy Dodaj tekst nie jest widoczny i nie możesz zaznaczyć lub pisać w polach, zapisz plik PDF na komputerze. (Przesuń kursor na dół formularza i kliknij ikonę Zapisz na półprzezroczystym, ruchomym pasku narzędziowym). Otwórz formularz PDF w programie Acrobat i wybierz polecenie Podpisz > Dodaj tekst. Następnie kliknij stronę i rozpocznij wpisywanie

Zapisz formularz, a następnie otwórz go w programie Acrobat i wybierz pozycje Podpisz > Dodaj tekst.
Pasek narzędziowy Dodaj tekst nie jest widoczny. Zapisz formularz, a następnie otwórz go w programie Acrobat i wybierz pozycje Podpisz > Dodaj tekst.

Uwaga:

Jeśli zamkniesz pasek narzędziowy Dodaj tekst, przesuń kursor w pobliże dolnej części formularza i kliknij ikonę  programu Acrobat na półprzezroczystym, ruchomym pasku narzędziowym. Pasek narzędziowy Dodaj tekst zostanie przywrócony. Jeśli ponownie zamkniesz pasek narzędziowy Dodaj tekst, przewiń w dół do paska narzędziowego i kliknij przycisk Tryb czytania . Następnie ponownie kliknij ikonę programu Acrobat.

Opcje pracy w formularzach

Klucz

Wynik

Tab lub Shift+Tab

Zatwierdza wpis i przechodzi do następnego pola

Strzałka w górę / Strzałka w lewo

Wybiera poprzedni przycisk opcji w danej grupie

Strzałka w dół / Strzałka w prawo

Wybiera następny przycisk opcji

Esc

Odrzuca i usuwa zaznaczenie pola formularza.

Esc (naciśnij dwukrotnie)

Wychodzi z trybu pełnoekranowego

Enter lub Return (pole tekstowe z jednym wierszem)

Zatwierdza wpis i usuwa zaznaczenie pola

Enter lub Return (pole tekstowe z wieloma wierszami)

Tworzy znak końca akapitu w tym samym polu formularza

Enter lub Return (pole wyboru)

Włącza lub wyłącza pole wyboru

Enter (klawiatura)

Zatwierdza wpis i usuwa zaznaczenie bieżącego pola formularza

(Windows) Ctrl + Tab Wstawia tabulator do pola tekstowego
(Mac) Alt + Tab Wstawia tabulator do pola tekstowego

Automatyczne wypełnianie formularzy (tylko formularze interaktywne)

Funkcja Auto-wypełnianie przechowuje wszystkie wpisy, które zostały wpisane w polu interaktywnego formularza. Auto-wypełnianie sugeruje następnie lub nawet automatycznie wprowadza odpowiedzi, które pasują do wpisów w innych polach formularza. Sugestie są wyświetlane w wyskakującym okienku, w którym można dokonać odpowiedniego wyboru. Funkcja Auto-wypełnianie jest domyślnie wyłączona; aby ją uaktywnić, należy odpowiednio ustawić preferencje formularza.

Aby usunąć dany wpis z pamięci Auto-wypełnianie, na przykład wpis z błędem ortograficznym, można otworzyć okno preferencji i dokonać odpowiednich zmian na liście preferencji.

Jak włączyć opcję automatycznego wypełniania w programie Acrobat | lynda.com (wideo 2:43)

Uwaga:

Preferencje formularzy odpowiadają za obsługę otwartych formularzy przez aplikację. Preferencje formularza PDF nie są zapisywane razem z nim.

Włączanie opcji auto-wypełniania

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Acrobat/Adobe Reader > Preferencje (Mac OS).

  2. Zaznacz opcję Formularze po lewej stronie.

  3. W obszarze Auto-wypełnianie wybierz z menu opcję Podstawowe lub Zaawansowane.

  4. Aby podczas wpisywania w formularzu danych liczbowych były one zapamiętywane, zaznacz opcję Pamiętaj dane liczbowe. W ten sposób będą one zachowywane w pamięci funkcji Auto-uzupełnianie.

Uwaga:

Zaznaczenie opcji z menu Auto-wypełnianie spowoduje, że w obszarze pod menu pojawi się opis wynikającej z takiego wyboru zmiany sposobu działania funkcji Auto-wypełnianie.

Usuwanie wpisu z pamięci auto-wypełniania

  1. Otwórz okno dialogowe Preferencje.

  2. Zaznacz opcję Formularze po lewej stronie.

  3. Kliknij przycisk Edytuj listę wpisów.

  4. W oknie dialogowym Lista wpisów auto-wypełniania wykonaj jedną z następujących czynności, a następnie kliknij przycisk Tak.

    • Aby usunąć wszystkie wpisy, kliknij przycisk Usuń wszystkie.
    • Aby usunąć tylko niektóre wpisy, zaznacz je i kliknij przycisk Usuń. (W celu zaznaczenia wielu wpisów sąsiadujących ze sobą klikaj je przy wciśniętym klawiszu Shift; w celu zaznaczenia wielu wpisów niesąsiadujących ze sobą klikaj je przy wciśniętym klawiszu Ctrl).

Zmiana płaskich formularzy na formularze przeznaczone do wypełnienia (Acrobat Pro)

Formularz płaski można zmienić na przeznaczony do wypełnienia przy pomocy kreatora formularzy lub poprzez włączenie narzędzia Dodaj tekst. Użytkownicy programów Acrobat i Reader XI mogą wypełnić formularze płaskie za pomocą narzędzia Dodaj tekst.  Należy jednak pamiętać, że wcześniejsze wersje programu Reader nie zawierają narzędzia Dodaj tekst (lub narzędzia Maszyna do pisania), chyba że autor włączył ich dostępność w danym pliku PDF.

Formularz interaktywny

Aby utworzyć formularz interaktywny, użyj kreatora formularzy. Zobacz Tworzenie formularzy przy pomocy programu Acrobat.

Formularz płaski

Aby włączyć narzędzie Dodaj tekst, wybierz polecenie Plik > Zapisz jako > Reader Extended PDF > Włącz dodawanie tekstu W dokumentach (które nie są formularzami przeznaczonymi do wypełnienia). Gdy formularz zostanie otwarty w programie Acrobat lub Reader, opcja ta spowoduje wyświetlenie narzędzia Dodaj tekst na purpurowym pasku komunikatów. Jeśli formularz zostanie otworzony w przeglądarce, pojawi się pasek narzędziowy Dodaj tekst.

Narzędzie Dodaj tekst jest włączone tylko dla bieżącego formularza. Wykonaj ponownie to zadanie podczas tworzenia innego formularza, aby pozwolić użytkownikom programu Reader korzystać z narzędzia Maszyna do pisania.

Zapisywanie formularzy

  • Aby zapisać wypełniony formularz, wybierz polecenie Plik > Zapisz jako i zmień nazwę pliku.

  • Aby usunąć rozszerzone funkcje programu Reader, wybierz polecenie Plik > Zapisz kopię.

  • Aby umożliwić zapisywanie wprowadzonych danych użytkownikom programu Reader, wybierz pozycje Plik > Zapisz jako inny > Reader Extended PDF > Włącz więcej narzędzi (w tym wypełnianie i zapisywanie formularza).

  1. Kliknij przycisk Drukuj  lub wybierz polecenie Plik > Drukuj.

  2. Wybierz drukarkę z menu w górnej części okna dialogowego Drukuj.

  3. W menu Komentarze i formularze w prawym górnym obszarze okna dialogowego Drukuj wybierz jedną z następujących opcji, a następnie kliknij przycisk OK:

    • (Formularz interaktywny lub płaski) Aby wydrukować formularz i wprowadzone wpisy, wybierz pozycję Dokument. Ta opcja drukuje wprowadzony tekst przy użyciu narzędzie Dodaj tekst.

    • (Formularz interaktywny lub płaski) Aby wydrukować formularz, wprowadzone wpisy oraz wszelkie komentarze na nim, wybierz Dokument i znaczniki. Ta opcja drukuje wprowadzony tekst przy użyciu narzędzie Dodaj tekst.

    • (Formularz interaktywny lub płaski) Aby wydrukować tylko wprowadzone wpisy, ale nie sam formularz, wybierz Tylko pola formularza.

Czyszczenie formularzy

Czyszczenie formularza w oknie przeglądarki

  1. Wykonaj jedną z poniższych czynności:
    • Kliknij przycisk Wyzeruj formularz (jeśli przycisk taki istnieje). Czynności tej nie można cofnąć.
    • Zamknij przeglądarkę i uruchom ją ponownie.

    Uwaga:

    Kliknięcie w przeglądarce na przycisk ponownego wczytywania, odświeżania, przechodzenia wstecz lub przechodzenia do przodu, a także użycie łącza do innej strony, może nie spowodować całkowitego wyczyszczenia formularza.

Czyszczenie niezapisanych wpisów formularza

  1. Wybierz pozycję Narzędzia > Formularze > Więcej opcji formularza > Wyczyść formularz.

Przykładowe formularze

Patti Sokol z firmy Sokol Consulting stworzyła dwa przykładowe formularze, aby pokazać różnice pomiędzy formularzem pasywnym a interaktywnym. Kliknij tutaj, aby wyświetlić formularz pasywny. Uwaga: Wpisywanie znaków w pola formularza pasywnego nie jest możliwe. Kliknij tutaj, aby wyświetlić formularz interaktywny. Pola w tym formularzu można podświetlać i wypełniać.

Przeczytaj dokładnie informacje w górnej ramce tekstowej umieszczonej na każdym z przykładowych formularzy. Następnie przesuń kursor na kolejne pola, aby zobaczyć, jakie czynności można w nich wykonać. Możesz także zapisać formularze na komputerze i wydrukować je.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online