Tworzenie pól formularza

W programie Acrobat można utworzyć pole formularza, wybierając jedno z narzędzi formularza. Dla każdego typu pola użytkownik może ustawić różne opcje, które są dostępne w oknie dialogowym Właściwości.

Otwieranie trybu edycji formularza

W trybie edycji formularza wyświetlany jest panel Formularz. Za pomocą opcji dostępnych w panelu Formularz można dodawać nowe pola, edytować już istniejące oraz wykonywać inne podobne zadania.

  • Po utworzeniu nowego formularza zostaje on domyślnie otwarty w trybie edycji.
  • W przypadku istniejących formularzy wybierz polecenie Narzędzia > Formularze > Edycja

Formularz będzie wyświetlany w trybie edycji oraz otwarty zostanie panel zadań Formularze.

Tworzenie pola formularza

  1. Po przekonwertowaniu dokumentu na formularz PDF otwórz panel zadań Formularze, jeśli nie jest jeszcze otwarty.(Narzędzia > Formularze > Edycja).
  2. Wykonaj jedną z następujących czynności:
    • Kliknij pozycję Dodaj nowe pole i wybierz typ pola formularza, który ma zostać dodany.

    • Wybierz pole formularza na pasku narzędziowym szybkiego dostępu.

    • Kliknij stronę prawym przyciskiem myszy i wybierz narzędzie.

    Kursor zamieni się w celownik i będzie wyświetlać podgląd danego pola.

  3. Na stronie kliknij miejsce, w którym chcesz dodać pole, aby utworzyć pole o domyślnym rozmiarze. Aby utworzyć pole o niestandardowym rozmiarze, rozciągnij prostokąt, określając rozmiar pola.
  4. W polu Nazwa pola wpisz nazwę pola i określ, czy ma ono być polem wymaganym. Wybierz nazwę, która będzie adekwatna i opisowa, aby ułatwić organizację i zbieranie danych.
  5. Aby wyświetlić okno dialogowe Właściwości i zmodyfikować inne właściwości pola, kliknij przycisk Wszystkie właściwości.

    Uwaga:

    Jeśli na pasku narzędziowym formularzy (widocznym w trybie edycji formularza) zaznaczono opcję „Utrzymaj narzędzie zaznaczone”, po dodaniu pola nie jest wyświetlana ramka Nazwa pola. Każdorazowo po kliknięciu strony do formularza jest dodawane nowe pole. Aby opuścić ten tryb, naciśnij klawisz Esc lub kliknij przycisk narzędzia Zaznaczanie obiektów. Aby zmodyfikować właściwości pola, kliknij je dwukrotnie.

  6. Aby przetestować formularz, kliknij przycisk Podgląd na pasku narzędziowym. Podgląd formularza umożliwia wyświetlenie go w takiej postaci, w jakiej będą go widzieć odbiorcy, i umożliwia sprawdzenie wyglądu formularza. Jeśli korzystasz z podglądu formularza, możesz kliknąć przycisk Edytuj , aby powrócić do trybu edycji.
  7. Po zakończeniu przygotowania formularza kliknij przycisk Zamknij edytowanie formularza.

Rozmieszczanie pól formularza na siatce

Siatki są niezwykle pomocne, gdy pola formularza trzeba umieścić na stronie bardzo dokładnie. Projektant formularza określa położenie siatki, jej kolor i odstępy między jej liniami. Może też zdecydować, czy podczas edycji pól formularza, ich obramowania mają być wyrównywane do linii siatki. Linie siatki nie są drukowane.

  1. Wybierz polecenie Widok > Pokaż/Ukryj > Miary i siatki > Siatka.
  2. Aby sprawić, żeby pola formularza były podczas ich tworzenia lub przesuwania przyciągane do najbliższych linii siatki, wybierz polecenie Widok > Pokaż/Ukryj > Miary i siatki > Przyciągaj do siatki.

Kopiowanie pola formularza

Można utworzyć kopie pola formularza na jednej stronie formularza PDF. Można także skopiować pole formularza i wkleić je na innych stronach. W przypadku tworzenia duplikatów pól formularza repliki oryginalnego pola są dodawane do jednej lub kilku innych stron. Zduplikowane pola znajdują się zawsze w tym samym miejscu na każdej stronie, tak jak w oryginale. Zarówno kopie, jak i duplikaty pól, można przeciągać w różne miejsca tej samej strony, ale nie na inne strony. Za pomocą narzędzia

Ponadto są one tworzone z tą samą podstawową nazwą, co oryginalne pole formularza. Do nazw kopii i duplikatów wklejanych przy użyciu polecenia Powiel na stronach jest dodatkowo dołączany numer. Wszystkie pola o tej samej nazwie bazowej (pole oryginalne oraz jego kopie/duplikaty) zawierają te same dane o użytkowniku oraz mają te same właściwości. Co za tym idzie, gdy użytkownik dodaje lub edytuje odpowiedź w kopii lub duplikacie pola, odpowiedź ta pojawia się we wszystkich polach o takiej samej nazwie podstawowej.

Jeśli zostaną zmienione właściwości dowolnej z wielu wersji pola formularza noszących tę samą nazwę podstawową, wprowadzone zmiany dotyczą tylko tej konkretnej kopii pola formularza. Zasada ta nie obowiązuje w przypadku zmiany listy Operacje, gdy wyzwalaczem nie jest operacja myszy.

Uwaga:

Aby zapobiec reagowaniu duplikatu lub kopii pola formularza wraz z polem oryginalnym na odpowiedzi, należy zmienić nazwę nowego pola formularza.

Tworzenie kopii pola formularza

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. Zaznacz pole formularza i wykonaj jedną z następujących czynności:
    • Aby skopiować pole formularza dokładnie na środku bieżącego widoku, wybierz polecenie Edycja > Kopiuj, a następnie polecenie Edycja > Wklej.

    • Aby skopiować pole formularza i przenieść je w inne miejsce strony, przeciągnij je przy naciśniętym klawiszu Ctrl.

      Wskazówka: Aby wymusić poziomy lub pionowy kierunek przeciągania, przytrzymaj naciśnięty klawisz Shift.

  3. Jeśli chcesz, aby pole było automatycznie zapełniane danymi wprowadzonymi przez użytkownika w oryginalnym polu, nie zmieniaj jego nazwy. Jeśli pole jest przeznaczone dla unikalnych danych użytkowników, zmień tę nazwę.

Tworzenie na stronie wielu kopii pola formularza

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. Wykonaj jedną z następujących czynności:
    • Kliknij prawym przyciskiem pole formularza i wybierz pozycję Utwórz wiele kopii.

    • Wybierz pole formularza polecenie Zadania > Edycja pól > Utwórz wiele kopii.

  3. W oknie dialogowym Utwórz wiele kopii pól, zaznacz opcję Podgląd, a następnie przesuń okno dialogowe, tak aby na stronie formularza było widoczne oryginalne pole i jego kopie.
  4. Dokonaj odpowiednich zaznaczeń:
    • Aby zmienić liczbę tworzonych kopii, wprowadź różne wartości opcji Kopiuj wybrane pola pionowo i Kopiuj wybrane pola poziomo.

    • Aby zmienić wymiary oryginalnego pola i wszystkich jego kopii, wprowadź różne wartości opcji Zmień szerokość i Zmień wysokość.

    • Aby zmienić położenie oryginalnego pola i wszystkich jego kopii, skorzystaj z przycisków W górę, W dół, W lewo i W prawo.

  5. Jeśli chcesz, aby pola były automatycznie zapełniane danymi wprowadzonymi przez użytkownika w oryginalnym polu, nie zmieniaj ich nazw. Jeśli skopiowane pola mają służyć do wprowadzania unikalnych danych użytkownika, zmień ich nazwę.

Powielanie pola formularza na wielu stronach

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. Wykonaj jedną z następujących czynności:
    • Kliknij pole formularza prawym przyciskiem myszy i wybierz opcję Powiel na stronach.

    • Wybierz pole formularza i wybierz Formularze > Zadania> Edytuj pola > Powiel na stronach.

      Uwaga: polecenie Powiel nie jest dostępne w przypadku formularzy jednostronicowych.

  3. Wykonaj jedną z następujących czynności:
    • Aby powielić pole formularza na wszystkich stronach, zaznacz opcję Wszystkie i kliknij OK.

    • Aby powielić pole formularza w pewnym zakresie stron, kliknij przycisk Od, po czym wprowadź numery strony początkowej i końcowej zakresu. Następnie kliknij przycisk OK.

      Uwaga: uwzględnienie lub nieuwzględnienie strony, na której pierwotnie znajdowało się pole formularza, nie wpływa na proces powielania. Uwzględnienie tej strony nie spowoduje utworzenia drugiej kopii oryginału na tej stronie, a nie uwzględnienie tej strony nie spowoduje usunięcia oryginalnego pola.

  4. Jeśli chcesz, aby pola były automatycznie zapełniane danymi wprowadzonymi przez użytkownika w oryginalnym polu, nie zmieniaj ich nazw. Jeśli zdublowane pola mają służyć do wprowadzania unikalnych danych użytkownika, zmień ich nazwę.

Zaznaczanie wielu pól formularza

Zaznaczanie wielu pól formularza stanowi pierwszy etap wielu czynności, takich jak tworzenie kopii pól, wyrównywanie pól i dopasowywanie odstępów między polami.

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. Wykonaj jedną z następujących czynności:
    • Aby zaznaczyć wszystkie pola formularza niezależnie od typu, wybierz polecenie Edycja > Zaznacz wszystkie.

    • Aby zaznaczyć określony zakres pól formularza, kliknij pierwsze z pól, po czym wciśnij klawisz Shift i kliknij ostatnie z pól. Zostaną zaznaczone wszystkie pola pomiędzy.

    • Aby zaznaczyć jedno pole formularza w różnych częściach strony PDF, klikaj kolejne pola przy naciśniętym klawiszu Ctrl.

    • Aby zaznaczyć wszystkie pola formularza w określonym obszarze strony, uaktywnij narzędzie Zaznaczanie obiektów  i narysuj odpowiednią ramkę zaznaczenia.

    • Aby usunąć zaznaczenie jednego pola, kliknij je przy naciśniętym klawiszu Ctrl.

    Pole, które zostanie podświetlone na granatowo i ma uchwyty obrzeża, jest zakotwiczeniem. Jeśli pola były zaznaczane metodą klikania, zakotwiczeniem jest ostatnie kliknięte pole. Jeśli pola były zaznaczane za pomocą ramki, zakotwiczeniem jest pierwsze utworzone ple. Usunięcie zaznaczenia zakotwiczenia (przez kliknięcie go przy wciśniętym klawiszu Ctrl) powoduje, że nowym zakotwiczeniem staje się pole położone najbliżej na lewo i w górę od starego zakotwiczenia.

Zmienianie rozmiaru i położenia pól formularza

Po utworzeniu pól formularza użytkownik może — chcąc uzyskać bardziej profesjonalny lub ładniejszy wygląd formularza — zmienić kolejność, rozmiary lub układ pól.

Aby dostosować układ pól formularza, użyj trybu edycji formularza (Narzędzia > Formularze > Edycja).

Zmiana rozmiaru pola formularza

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. Zaznacz wybrane pola formularza.
  3. Wykonaj jedną z następujących czynności:
    • Aby ręcznie zmienić rozmiar pola, przeciągnij uchwyt krawędzi. Chcąc zachować bieżące proporcje pola formularza, przytrzymaj wciśnięty klawisz Shift i przeciągnij uchwyt narożny.

    • Aby zmienić wielkość pola o jeden piksel, naciśnij klawisze Ctrl+strzałka. Aby zmienić wielkość pola o dziesięć pikseli, naciśnij klawisze Ctrl+Shift+strzałka.

    • Aby zmienić rozmiar do określonych wymiarów, kliknij pole prawym przyciskiem myszy i wybierz opcję Właściwości. Następnie kliknij zakładkę Pozycja i dostosuj wartości Szerokość i Wysokość.

Dopasowywanie rozmiaru wielu pól formularza do rozmiaru zaznaczonego pola

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. Zaznacz wszystkie pola formularza, których wielkość chcesz zmienić.
  3. Kliknij prawym przyciskiem myszy pole formularza, do którego mają zostać dopasowane pozostałe zaznaczone pola formularza. Wybierz opcję Ustaw jednakowy rozmiar pól, a następnie wybierz jedną z poniższych opcji:

    Wysokość

    Pozwala dopasować wysokość bez zmiany szerokości.

    Szerokość

    Pozwala dopasować szerokość bez zmiany wysokości.

    Obie

    Pozwala dopasować szerokość i wysokość pól.

Przesuwanie pojedynczych pól formularza

Pola mogą być przesuwane zwykłą metodą przeciągania. Aby uzyskać większą precyzję tej operacji, można skorzystać ze specjalnych funkcji programu, takich jak wyrównywanie pól, dopasowywanie odstępów między polami i środkowanie pól na stronie.

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. Zaznacz jedno lub więcej pól formularzy, które chcesz przenieść.
  3. Wykonaj jedną z następujących czynności:
    • Przeciągnij zaznaczone pola formularza w nowe miejsce.

      Wskazówka: Aby wymusić dokładnie poziomy lub pionowy ruch kursora, rozpocznij przeciąganie, naciśnij klawisz Shift i przytrzymując go, kontynuuj przeciąganie.

    • Aby przenieść w określone miejsce, kliknij pole prawym przyciskiem myszy i wybierz opcję Właściwości. Następnie kliknij zakładkę Pozycja i ustaw wartości Pozycja.

    • Aby przesuwać pola w poziomie lub w pionie o małe odcinki, używaj klawiszy strzałek.

    • Aby przenieść pole dokładnie na środek strony, wybierz polecenie Edycja > Wytnij, przejdź na wybraną stronę i wybierz polecenie Edycja > Wklej.

      Uwaga: pola są umieszczane pośrodku strony tylko podczas pierwszej operacji wklejania. Kolejne pola są umieszczane w niewielkich odległościach od pól poprzednio wklejonych.

Wyrównywanie i środkowanie pól formularza

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. Zaznacz pole lub pola do wyrównania.
  3. Kliknij prawym przyciskiem myszy pole formularza, do którego mają zostać wyrównane pozostałe pola. Wybierz opcję Wyrównaj, rozmieść lub wyśrodkuj, a następnie wybierz polecenie zgodnie z poniższym opisem:
    • Aby wyrównać kolumnę pól, wybierz opcję Wyrównaj do lewej, Wyrównaj do prawej lub Wyrównaj w pionie. Pola zostaną wyrównane odpowiednio do lewej krawędzi, prawej krawędzi lub osi pionowej (środkowej) pola zakotwiczenia.

    • Aby wyrównać wiersz pól, wybierz opcję Wyrównaj w górę, Wyrównaj w dół lub Wyrównaj w poziomie. Pola zostaną wyrównane odpowiednio do górnej krawędzi, dolnej krawędzi lub osi poziomej (środkowej) pola zakotwiczenia.

    • Aby wyśrodkować pola, wybierz opcję Wyśrodkuj pionowo, Wyśrodkuj poziomo lub Wyśrodkuj poziomo i pionowo.

    Uwaga:

    Po kliknięciu prawym przyciskiem myszy jednego z wybranych pól zostaną wyświetlone uchwyty krawędzi, wskazujące że to pole formularza jest polem zakotwiczenia. Polecenia z menu Wyrównaj pozwalają wyrównać zaznaczone pola formularza do krawędzi pola będącego zakotwiczeniem.

Dopasowywanie odstępów między polami formularza

W kontekście operacji na polach formularza termin rozmieszczanie oznacza rozstawianie pól w równych odstępach (liczonych względem ich środków). Polecenia dotyczące rozmieszczania są nadrzędne względem polecenia Przyciągaj do siatki.

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. Zaznacz pola formularza, które mają zostać dopasowane.
  3. Kliknij prawym przyciskiem myszy dowolne z zaznaczonych pól formularza, a następnie wykonaj jedną z następujących czynności:
    • Aby rozmieścić równomiernie pola znajdujące się między pierwszym od góry i pierwszym od dołu polem zaznaczenia, wybierz polecenie Wyrównaj, rozmieść lub wyśrodkuj > Rozmieść pionowo.

    • Aby rozmieścić równomiernie pola znajdujące się między pierwszym z lewej i pierwszym z prawej polem zaznaczenia, wybierz polecenie Wyrównaj, rozmieść lub wyśrodkuj > Rozmieść poziomo.

      Uwaga: polecenie Rozpowszechnij dostępne w panelu Narzędzia > Formularze ma inną funkcję. Służy ono do wysyłania formularza do innych użytkowników, którzy uzupełnią wymagane dane i zwrócą formularz nadawcy.

Usuwanie pola formularza

  1. Jeśli nie pracujesz w trybie edycji formularza, wybierz polecenie Narzędzia > Formularze > Edycja.
  2. W panelu Pola lub w widoku strony zaznacz pola formularza, które chcesz usunąć.
  3. Wciśnij klawisz Delete lub wybierz polecenie Edycja > Usuń.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online