Preferencje weryfikacji należy wybrać z wyprzedzeniem. Pomaga to upewnić się, że podpisy cyfrowe są ważne po otwarciu dokumentu PDF i wyświetleniu szczegółów weryfikacji wraz z podpisem. Szczegóły można znaleźć w sekcji Określanie preferencji weryfikacji podpisów.

Po zatwierdzeniu podpisów cyfrowych na pasku komunikatów dokumentu zostanie wyświetlona ikona informująca o stanie podpisu. Dodatkowe szczegóły dotyczące stanu są wyświetlane w panelu Podpisy oraz w oknie dialogowym Właściwości podpisu.

Konfigurowanie weryfikacji podpisów cyfrowych

Po otrzymaniu podpisanego dokumentu można zweryfikować podpis(-y) celem sprawdzenia autora podpisu oraz podpisanej zawartości. W zależności od konfiguracji aplikacji weryfikacja może nastąpić automatycznie. Ważność podpisu można zweryfikować na podstawie autentyczności certyfikatu cyfrowego identyfikatora podpisu oraz spójności dokumentu:

  • Weryfikacja autentyczności pozwala stwierdzić, czy certyfikat osoby podpisującej lub jego certyfikaty nadrzędne są uwzględnione na liście zaufanych tożsamości sprawdzającego. Pozwala ona także stwierdzić, czy certyfikat podpisywania jest ważny na podstawie konfiguracji programu Acrobat lub Reader użytkownika.

  • Weryfikacja spójności dokumentu pozwala stwierdzić, czy podpisana zawartość uległa zmianie po podpisaniu. Jeśli wprowadzono zmiany w zawartości, moduł sprawdzania spójności dokumentu zweryfikuje, czy wprowadzono je zgodnie z zasadami określonymi przez autora podpisu.

Określanie preferencji zatwierdzania podpisu

  1. Otwórz okno dialogowe Preferencje.
  2. W obszarze Kategorie wybierz pozycję Podpisy.
  3. Aby uzyskać więcej informacji na temat obszaru Weryfikacja, kliknij pozycję Więcej.

  4. Aby automatycznie zatwierdzać wszystkie podpisy otwieranego dokumentu PDF, zaznacz opcję Zatwierdzaj podpisy otwieranego dokumentu. Ta opcja jest domyślnie włączona.

  5. Dostosuj opcje weryfikacji do potrzeb, a następnie kliknij przycisk OK.

    Sposób działania weryfikacji

    Przy weryfikacji

    Opcje określają metody wyboru wtyczki do weryfikacji podpisu. Odpowiednia wtyczka jest często zaznaczana automatycznie. Informacje dotyczące wymagań wtyczek do zatwierdzania podpisów są dostępne u administratora systemu.

    Wymaga przeprowadzenia sprawdzania unieważnienia certyfikatu, kiedy tylko to możliwe...

    W trakcie procesu sprawdzania poprawności można użyć tych opcji w celu sprawdzenia, czy certyfikaty znajdują się na liście wykluczonych certyfikatów. Ta opcja jest domyślnie włączona. Jeśli zaznaczenie tej opcji zostanie usunięte, stan unieważnienia podpisów nieautoryzowanych będzie ignorowany. Stan odrzucenia jest zawsze sprawdzany przy zatwierdzaniu podpisów.

    Czas weryfikacji

    Sprawdź podpisy przy pomocy

    Wybierz opcję określającą sposób sprawdzania poprawności podpisów cyfrowych. Domyślnie, istnieje możliwość sprawdzenia godziny w oparciu o czas utworzenia podpisu. Można też dokonać sprawdzenia na podstawie aktualnej godziny lub godziny ustawionej przez serwer znaczników czasowych w momencie podpisania dokumentu.

    Użyj znaczników czasowych, które utraciły ważność

    Wykorzystuje czas przesłany z serwera znaczników lub osadzony w podpisie, nawet jeśli wygasła ważność certyfikatu podpisu. Ta opcja jest domyślnie włączona. Usunięcie zaznaczenia tej opcji spowoduje odrzucanie znaczników czasowych, które utraciły ważność.

    Dane weryfikacji

    Określa, czy podpisywane dokumenty PDF będą uzupełniane danymi weryfikacji. Według ustawień domyślnych, program ostrzega użytkownika, gdy dane weryfikacji są zbyt duże.

    Integracja z Windows

    należy określić, czy status zaufanych mają uzyskiwać wszystkie certyfikaty główne w magazynie certyfikatów Windows podczas weryfikowania podpisów i certyfikowanych dokumentów. Zaznaczenie tych opcji może naruszyć bezpieczeństwo.

    Uwaga:

    Nie jest zalecane ufanie wszystkim głównym certyfikatom systemu Windows. Wiele certyfikatów rozprowadzanych z systemem Windows zostało utworzonych w celach innych niż ustalanie zaufanych tożsamości.

Ustawianie poziomu zaufania certyfikatu

W programie Acrobat lub Reader podpis w certyfikowanym lub podpisanym dokumencie jest ważny, jeśli między użytkownikiem a autorem podpisu istnieje relacja zaufania. Poziom zaufania certyfikatu informuje o operacjach, w zakresie których ufa się osobie składającej podpis.

Aby zezwolić na konkretne operacje, można zmienić ustawienia zaufania certyfikatów. Można na przykład zmienić ustawienia w celu włączenia zawartości dynamicznej i osadzonych skryptów JavaScript w dokumencie certyfikowanym.

  1. Otwórz okno dialogowe Preferencje.
  2. W obszarze Kategorie wybierz pozycję Podpisy.
  3. Aby uzyskać więcej informacji na temat Tożsamości i zaufanych certyfikatów, kliknij Więcej.
  4. Wybierz pozycję Zaufane certyfikaty po lewej stronie.
  5. Wybierz certyfikat z listy i kliknij pozycję Edycja ustawień zaufania.
  6. Na zakładce Zaufanie zaznacz jedną z następujących opcji określających elementy godne zaufania:

    Użyj tego certyfikatu jako zaufanego certyfikatu głównego

    Certyfikat główny przypisany jest do jednostki źródłowej w łańcuchu jednostek, które wydały certyfikat. Nadając status zaufanego certyfikatowi głównemu, nadaje się go wszystkim certyfikatom wydanym przez wspomniany urząd.

    Podpisane dokumenty lub dane

    Ta opcja potwierdza tożsamość autora podpisu.

    Zatwierdzone dokumenty

    Zaznaczenie tej opcji powoduje udzielenie zaufania dokumentom, które zostały zatwierdzone za pomocą podpisu przez autora. Oznacza to, że użytkownik ufa autorowi podpisu w kwestii zatwierdzania dokumentów i akceptuje operacje związane z tymi dokumentami.

    Po zaznaczeniu tej opcji dostępne stają się następujące funkcje:

    Zawartość dynamiczna

    Umożliwia odtwarzanie w dokumencie certyfikowanym filmów, dźwięków i innych elementów dynamicznych.

    Osadzone skrypty JavaScript

    Umożliwia uruchamianie uprzywilejowanych skryptów JavaScript osadzonych w plikach PDF. Pliki JavaScript mogą być wykorzystywane do szkodliwych działań. Zaznaczenie tej opcji jest zalecane tylko w razie konieczności i tylko dla zaufanych certyfikatów.

    Uprzywilejowane operacje systemowe

    Umożliwia obsługę w dokumentach certyfikowanych połączeń z Internetem, skryptów krzyżowych, drukowania bez udziału użytkownika, odniesień do obiektów zewnętrznych oraz operacji związanych z metodologią importu/eksportu.

    Uwaga:

    Opcje Osadzone skrypty JavaScript i Uprzywilejowane operacje systemowe powinny być dozwolone wyłącznie dla zaufanych źródeł, z którymi użytkownik współpracuje w sposób ścisły. Przykład: Opcje te należy stosować w przypadku pracodawcy lub dostawcy usług.

  7. Kliknij przycisk OK, zamknij okno dialogowe Ustawienia identyfikatora cyfrowego i zaufanego certyfikatu, a następnie kliknij przycisk OK w oknie dialogowym Preferencje.

Więcej informacji można znaleźć w Przewodniku po podpisach cyfrowych pod adresem www.adobe.com/go/acrodigsig_pl.

Panel podpisów cyfrowych

Na panelu Podpisy są wyświetlane informacje o każdym podpisie w bieżącym dokumencie wraz z historią zmian dokumentu od pierwszego podpisu. Każdemu podpisowi cyfrowemu towarzyszy ikona oznaczająca jego bieżący stan. Szczegóły dotyczące weryfikacji są wyświetlane pod każdym podpisem i można je wyświetlić, rozwijając podpis. Panel Podpisy udostępnia także informacje na temat czasu podpisania dokumentu oraz szczegóły dotyczące zaufania i autora podpisu.

Weryfikuj podpisy w panelu Podpisy
Weryfikuj podpisy w panelu Podpisy

  1. Wybierz polecenie Widok > Pokaż/Ukryj > Panele nawigacji > Podpisy lub kliknij przycisk panelu Podpis na pasku komunikatów dokumentu.

Uwaga:

Większość zadań dotyczących podpisów, w tym ich dodawanie i czyszczenie oraz sprawdzanie ich poprawności, można wykonać, klikając prawym przyciskiem myszy pole podpisu w panelu Podpisy. Czasami jednak umieszczenie podpisu w polu powoduje zablokowanie tego pola.

Podpisywanie w trybie Podglądu dokumentu

Jeśli spójność dokumentu ma znaczenie krytyczne dla obiegu pracy związanego z podpisywaniem, w celu podpisania dokumentu należy skorzystać z opcji Podgląd dokumentu. Ta funkcja analizuje dokument pod kątem zawartości, która może zmieniać wygląd dokumentu. Następnie zatrzymuje działanie takiej zawartości, umożliwiając wyświetlenie i podpisanie dokumentu w bezpiecznym stanie statycznym.

Funkcja podglądu dokumentów pozwala sprawdzić, czy dokument zawiera treści dynamiczne lub odnośniki do źródeł zewnętrznych. Pozwala także sprawdzić, czy dokument zawiera takie elementy, jak pola formularza, multimedia lub skrypty JavaScript, które mogą wpływać na jego wygląd. Po przejrzeniu raportu można skontaktować się z autorem dokumentu w sprawie problemów wymienionych w raporcie.

Tryb podglądu dokumentu może być też używany poza obiegiem pracy związanym z podpisywaniem do sprawdzania spójności dokumentu.

  1. Otwórz okno dialogowe Preferencje.

  2. W sekcji Kategorie wybierz pozycję Podpisy.

  3. W sekcji Tworzenie i wygląd kliknij pozycję Więcej.

  4. W sekcji Podczas podpisywania zaznacz pole Wyświetl dokument w trybie podglądu i kliknij przycisk OK.

  5. W pliku PDF kliknij pole podpisu i wybierz opcję Podpisz dokument.

    Na ekranie zostanie wyświetlony pasek komunikatów z informacjami dotyczącymi zgodności i opcjami.

  6. (Opcja dodatkowa) Kliknij opcję Pokaż raport w pasku wiadomości dokumentu (jeśli jest) i zaznacz każdy element na liście, aby wyświetlić jego szczegóły. Po zakończeniu zamknij okno dialogowe Raport podpisu PDF.

  7. Jeśli stan zgodności dokumentu odpowiada oczekiwaniom, kliknij opcję Podpisz dokument na pasku komunikatów dokumentu i dodaj swój podpis cyfrowy.

  8. Zapisz plik PDF pod nazwą inną niż oryginalna i zamknij dokument bez wprowadzania dalszych zmian.

Zatwierdzanie pliku PDF

Zatwierdzanie dokumentu PDF polega na przyjęciu jego zawartości. Na tym etapie określa się także rodzaj zmian, jakie mogą być wprowadzane do dokumentu bez utraty jego certyfikatu. Na przykład, przypuśćmy, że agencja rządowa tworzy formularz zawierający pola podpisów. Po zakończeniu formularza, agencja zatwierdza dokument, pozwalając użytkownikom na wprowadzanie zmian tylko w polach formularza i podpisywanie dokumentu. Użytkownicy mogą wypełnić formularz i podpisać dokument. Jednak w przypadku usunięcia stron lub dodania komentarzy, dokument traci status certyfikowanego.

Podpis zatwierdzający może być dodawany tylko do plików PDF, które nie zawierają innych podpisów. Podpisy zatwierdzające mogą być widoczne lub niewidoczne. Ważny podpis zatwierdzający jest oznaczony ikoną niebieskiej wstążki  na panelu Podpisy. Identyfikator cyfrowy jest wymagany w celu dodania zatwierdzającego podpisu cyfrowego.

  1. Usuń zawartość, która może naruszyć bezpieczeństwo dokumentu, np. skrypty JavaScript, operacje lub osadzone pliki multimedialne.

  2. Wybierz pozycję Podpisz > Praca z certyfikatami, aby otworzyć panel.

  3. Kliknij jedną z następujących opcji:

    Zatwierdź (widoczny)

    Umieszcza certyfikowany podpis w istniejącym polu podpisu elektronicznego (jeśli dostępne) lub w wyznaczonej lokalizacji.

    Zatwierdź (niewidoczny)

    Zatwierdza dokument; podpis użytkownika będzie widoczny tylko w panelu Podpisy.

  4. Wykonaj instrukcje ekranowe, aby umieścić podpis w dokumencie (jeśli dotyczy), określić identyfikator cyfrowy (jeśli dostępny) oraz ustawić opcję Operacje dozwolone po zatwierdzeniu.

    Uwaga:

    Jeśli opcja Podczas podpisywania: Wyświetl dokument w trybie podglądu w sekcji preferencji podpisu została włączona, kliknij Podpisz dokument na pasku komunikatów dokumentu.

  5. Zapisz plik PDF pod nazwą inną niż oryginalna i zamknij dokument bez wprowadzania dalszych zmian. Warto zapisać go jako odrębny plik, aby zachować oryginalną, niepodpisaną wersję dokumentu.

Dodawanie znacznika czasowego do dokumentu

Program Acrobat oferuje użytkownikom możliwość opatrzenia dokumentów PDF znacznikami czasu i nie wymaga w tym celu potwierdzenia tożsamości podpisem. Aby wstawienie znacznika czasowego do dokumentu PDF było możliwe, należy skonfigurować serwer znacznika czasowego. (Zobacz Konfigurowanie serwera czasu). Znacznik czasowy gwarantuje autentyczność dokumentu i potwierdza, że dokument istniał w danym momencie. Znaczniki czasowe są zgodne z funkcjami znaczników czasowych i odwołań opisanych w części 4. standardu ETSI 102 778 PDF Advanced Electronic Signatures (PAdES). Użytkownicy programu Reader X także mogą dodawać znaczniki czasowe do dokumentu, jeśli w dokumencie tym włączono odpowiednie funkcje obsługi dla programu Reader.

Więcej informacji na temat standardu PAdES można znaleźć pod adresem blogs.adobe.com/security/2009/09/eliminating_the_penone_step_at.html

  1. Otwórz dokument, do którego chcesz dodać znacznik czasowy.

  2. Wybierz pozycję Podpisz > Praca z certyfikatami > Dokument ze znacznikiem czasowym.

  3. W oknie Wybierz domyślny serwer znacznika czasowego wybierz serwer z listy lub dodaj nowy serwer domyślny.

  4. Kliknij Dalej, a następnie zapisz dokument ze znacznikiem czasowym.

Weryfikacja podpisów cyfrowych

Jeśli stan podpisu nie jest znany lub podpis nie został sprawdzony, sprawdź ręcznie poprawność podpisu, aby ustalić problem i możliwe rozwiązanie. Jeśli stan podpisu jest nieprawidłowy, skontaktuj się z autorem podpisu, aby rozwiązać ten problem.

Więcej informacji na temat ostrzeżeń dotyczących podpisów oraz ważnych lub nieważnych podpisów można znaleźć w Przewodniku po podpisach cyfrowych pod adresem www.adobe.com/go/acrodigsig_pl.

Ważność podpisu cyfrowego i znacznika czasowego można sprawdzić we właściwościach podpisu.

  1. Określ preferencje zatwierdzania podpisu. Więcej informacji można znaleźć w temacie Określanie preferencji weryfikacji podpisów.

  2. Otwórz dokument PDF z podpisem i kliknij ten podpis. W oknie dialogowym Stan zatwierdzania podpisu zostanie wyświetlony opis ważności podpisu.

  3. Aby uzyskać więcej informacji na temat podpisu i znacznika czasowego, kliknij Właściwości podpisu.

  4. Przejrzyj Podsumowanie ważności widoczne w oknie dialogowym Właściwości podpisu. W podsumowaniu mogą zostać wyświetlone następujące komunikaty:

    Data/czas podpisu pochodzi z zegara w komputerze autora podpisu.

    Czas określono na podstawie lokalnego czasu komputera autora podpisu.

    Podpis jest oznaczony znacznikiem czasowym.

    Autor podpisu użył serwera znacznika czasowego, a ustawienia wskazują, że istnieje relacja zaufania między użytkownikiem a tym serwerem znacznika czasowego.

    Podpis jest oznaczony znacznikiem czasowym, którego nie można zweryfikować

    Operacja sprawdzania znaczników czasowych wymaga uzyskania certyfikatu serwera znaczników czasowych i dodania go do listy zaufanych tożsamości. Skontaktuj się z administratorem systemu.

    Podpis jest oznaczony znacznikiem czasowym, którego ważność wygasła

    Programy Acrobat i Reader weryfikują znaczniki czasowe na podstawie bieżącej godziny. Ten komunikat jest wyświetlany, gdy certyfikat znacznika czasowego autora podpisu wygaśnie przed bieżącą godziną. Jeśli chcesz, aby program Acrobat lub Reader zaakceptował nieaktualny znacznik czasowy, wybierz opcję Użyj znaczników czasowych, które utraciły ważność w oknie dialogowym Preferencje weryfikacji podpisów (Preferencje > Podpisy > Weryfikacja: Więcej). Programy Acrobat i Reader wyświetlają ostrzeżenie podczas weryfikowania podpisów zawierających znaczniki czasu, które utraciły ważność.

  5. Szczegółowe informacje na temat certyfikatu podpisującego, takie jak ustawienia zaufania lub ograniczenia prawne podpisu, można uzyskać, klikając Pokaż certyfikat podpisującego w oknie dialogowym Właściwości podpisu.

    Jeśli dokument został zmieniony po podpisaniu, sprawdź podpisaną wersję dokumentu i porównaj ją z wersją bieżącą.

Usuwanie podpisów cyfrowych

Nie możesz usunąć podpisu cyfrowego, chyba że jesteś osobą, która go dodała, i masz zainstalowany identyfikator cyfrowy umożliwiający podpisywanie.

  1. Wykonaj jedną z następujących czynności:

    • Aby usunąć podpis cyfrowy, kliknij prawym przyciskiem myszy pole podpisu i wybierz polecenie Usuń podpis.
    • Aby usunąć wszystkie podpisy z dokumentu PDF, wybierz opcję Wyczyść wszystkie pola podpisów w menu opcji panelu Podpisy. (Aby otworzyć panel Załączniki, wybierz polecenie Widok > Pokaż/Ukryj > Panele nawigacji > Podpisy).

Przeglądanie poprzednich wersji podpisanego cyfrowo dokumentu

Za każdym razem, gdy podpisywany jest dokument przy użyciu certyfikatu, wraz z plikiem PDF zapisywana jest jego podpisana wersja. Wszystkie wersje są zapisywane w trybie dołączania. Nie można modyfikować oryginału. Wszystkie podpisy cyfrowe oraz odpowiadające im wersje dokumentu są pokazywane na panelu Podpisy.

  1. Zaznacz podpis w panelu Podpisy i rozwiń podpis, a następnie wybierz polecenie Pokaż podpisaną wersję z menu Opcje .

    Poprzednia wersja zostanie otwarta w nowym pliku PDF, a na pasku tytułowym będą widoczne informacje o wersji i nazwa podmiotu podpisującego.

  2. Aby powrócić do oryginalnego dokumentu, wybierz nazwę dokumentu w menu Okno.

Porównywanie wersji podpisanego dokumentu PDF

Po podpisaniu dokumentu istnieje możliwość wyświetlenia listy zmian wprowadzonych od czasu utworzenia ostatniej wersji.

  1. Wybierz podpis w panelu Podpisy.

  2. Wybierz polecenie Porównaj podpisaną wersję z wersją bieżącą w menu Opcje .

  3. Po zakończeniu zamknij tymczasowy dokument.

Przypisywanie statusu zaufanego certyfikatowi osoby podpisującej

Nadanie certyfikatowi statusu zaufanego wiąże się z dodaniem go do listy zaufanych tożsamości w Menedżerze tożsamości oraz ręcznym ustawieniem poziomu zaufania. Podczas korzystania z zabezpieczeń certyfikatów użytkownicy końcowi często wymieniają się nimi zgodnie z potrzebami. Mogą też dodawać certyfikaty bezpośrednio z podpisów w podpisanych dokumentach, a następnie ustawiać poziomy zaufania. Jednak w korporacjach od użytkowników wymaga się weryfikacji podpisów innych osób bez wykonywania żadnych czynności ręcznych. Program Acrobat ufa wszystkim certyfikatom (dotyczącym podpisywania i certyfikowania), które są połączone z głównym modułem zaufania. W związku z tym administratorzy powinni dokonywać wstępnej konfiguracji oprogramowania klienckiego lub zezwolić użytkownikom końcowym na dodawanie głównych modułów zaufania. Więcej informacji na temat zaufania względem certyfikatów można znaleźć w artykule Podpisy oparte na certyfikacie.

Portfolio PDF i podpisy cyfrowe

Możesz podpisać składowy dokument PDF w portfolio PDF lub podpisać portfolio PDF jako całość. Podpisanie składowego dokumentu PDF powoduje zablokowanie go do edycji i zabezpieczenie jego zawartości. Po podpisaniu wszystkich składowych dokumentów PDF można podpisać całe portfolio PDF, aby je zakończyć. Można także podpisać portfolio PDF jako całość, aby zablokować zawartość wszystkich składowych dokumentów PDF jednocześnie.

  • Aby podpisać składowy dokument PDF, zobacz Podpisywanie dokumentów PDF. Podpisany dokument PDF jest automatycznie zapisywany w portfolio PDF.

  • Aby podpisać portfolio PDF jako całość, podpisz arkusz okładki (Widok > Portfolio > Arkusz okładki). Po podpisaniu całego portfolio PDF nie jest możliwe dodanie podpisów do dokumentów składowych. Można jednak dodać podpisy do arkusza okładki.

Podpisy cyfrowe na załącznikach składowych dokumentów PDF

Przed podpisaniem arkusza okładki można dodać podpisy do załączników. Aby nadać podpisy załączonym dokumentom PDF, otwórz dokument PDF w oddzielnym oknie. Kliknij załącznik prawym przyciskiem myszy i wybierz polecenie Otwórz plik z menu kontekstowego. Aby wyświetlić podpisy w portfolio PDF, przejdź do arkusza okładki i wyświetl pasek komunikatów dokumentu oraz panel podpisów.

Podpisane i certyfikowane portfolio PDF

Poprawnie podpisane i certyfikowane portfolio PDF posiada jeden lub więcej podpisów, zatwierdzających lub certyfikujących dane portfolio PDF. Najważniejszy podpis jest widoczny w Oznace podpisu na pasku narzędziowym. Szczegóły wszystkich podpisów widoczne są w arkuszu okładki.

Oznaka podpisu
Oznaka podpisu umożliwia szybkie sprawdzenie zatwierdzenia lub certyfikatu danego portfolio PDF.

  • Aby wyświetlić nazwę organizacji lub nazwisko osoby, która podpisała portfolio PDF, najedź kursorem na Oznakę podpisu.

  • Aby zobaczyć szczegółowe informacje na temat podpisu, który pojawia się w Oznace podpisu, kliknij . Arkusz okładki i znajdujący się po lewej stronie panel Podpisy otwierają się, ukazując szczegółowe informacje.

Jeśli zatwierdzenie lub certyfikacja portfolio PDF jest nieprawidłowa lub występują w niej jakieś problemy, to Oznaka podpisu wyświetla ikonę ostrzeżenia. Aby zobaczyć wyjaśnienie tego problemu, najedź wskaźnikiem na Oznakę podpisu z ikoną ostrzeżenia. W różnych sytuacjach pojawiają się różne ikony ostrzeżeń.

Lista i opis wszystkich ostrzeżeń znajdują się w Przewodniku administratora DigSig Admin Guide pod adresem www.adobe.com/go/acrodigsig_pl.

Podpisy danych XML

Programy Acrobat i Reader obsługują podpisy danych XML używane w celu podpisywania danych w formularzach XFA. Autor formularza zapewnia instrukcje dotyczące podpisywania, weryfikacji i usuwania XML dotyczące zdarzeń formularza, takich jak kliknięcia przycisków, zapisywanie pliku lub przesyłanie.

Podpisy danych XML są zgodne ze standardem W3C XML-Signature. Podobnie jak podpisy cyfrowe PDF, podpisy cyfrowe XML zapewniają spójność dokumentów oraz funkcje sprawdzania autentyczności.

Jednak podpisy PDF posiadają wiele stanów weryfikacji danych. Niektóre z tych stanów są wywoływane wówczas, gdy użytkownik próbuje zmienić podpisaną zawartość. Natomiast podpisy XML posiadają tylko dwa stany: ważny lub nieważny. Stan „nieważny” jest wywoływany wtedy, gdy użytkownik zmieni zawartość podpisanego dokumentu.

Ustalanie długoterminowego sprawdzania poprawności podpisu

Funkcja długoterminowego sprawdzania poprawności podpisu umożliwia sprawdzanie ważności podpisu długo po podpisaniu dokumentu. W celu umożliwienia długoterminowego sprawdzania poprawności podpisu należy osadzić wszystkie wymagane elementy tego mechanizmu w podpisanym dokumencie PDF. Osadzenie elementów może nastąpić podczas podpisywania dokumentu lub po utworzeniu podpisu.

Jeśli określone informacje nie zostaną dodane do dokumentu PDF, poprawność podpisu będzie można sprawdzić tylko przez ograniczony czas. To ograniczenie wynika z faktu, że z czasem certyfikaty powiązane z podpisem tracą ważność lub są unieważniane. Gdy certyfikat straci ważność, odpowiedni ośrodek certyfikacji przestanie być odpowiedzialny za udostępnianie stanu unieważnienia dla tego certyfikatu. Jeśli nie można potwierdzić stanu unieważnienia, sprawdzenie poprawności podpisu kończy się niepowodzeniem.

Elementy wymagane do sprawdzenia poprawności podpisu obejmują łańcuch certyfikatu podpisywania i stan unieważnienia certyfikatu, a w niektórych przypadkach także znacznik czasowy. Jeśli wymagane elementy są dostępne i zostają osadzone podczas składania podpisu, podpis może zostać zweryfikowany z wykorzystaniem zewnętrznych źródeł. Programy Acrobat i Reader mogą osadzić wymagane elementy, jeśli są one dostępne. Autor pliku PDF musi włączyć prawa użytkowania dla użytkowników programu Reader (Plik > Zapisz jako inny > Reader extended PDF).

Uwaga:

Do osadzenia informacji znacznika czasowego wymagany jest prawidłowo skonfigurowany serwer znaczników czasowych. Ponadto czas zatwierdzania podpisu należy ustawić na wartość Czas bezpieczny (Preferencje > Zabezpieczenia > Preferencje zaawansowane > zakładka Weryfikacja). Certyfikaty CDS wprowadzają w dokumencie dodatkowe informacje z zakresu weryfikacji, takie jak unieważnienie lub znacznik czasowy, bez konieczności wprowadzania zmian w konfiguracji przez osobę podpisującą. Autor podpisu musi być dostępny w Internecie, aby możliwe było pobranie niezbędnych informacji.

Dodawanie informacji sprawdzania poprawności podczas podpisywania

  1. Upewnij się, że komputer może nawiązać połączenie z odpowiednimi zasobami sieciowymi.

  2. Należy sprawdzić, czy wciąż wybrano opcję Dołącz stan unieważnienia podpisu (Preferencje > Podpisy > Tworzenie i wygląd: Więcej). Domyślnie ta opcja jest zaznaczona.

  3. Podpisz plik PDF.

Jeśli wszystkie elementy łańcucha certyfikatu są dostępne, informacje zostaną automatycznie dodane do pliku PDF. Skonfigurowanie serwera znacznika czasowego powoduje dodanie również znacznika czasowego.

Dodawanie informacji sprawdzania poprawności po podpisaniu

W niektórych obiegach pracy informacje dotyczące sprawdzania poprawności podpisu są niedostępne podczas podpisywania, ale można je uzyskać później. Przykład: Przedstawiciel firmy może podpisać kontrakt przy pomocy laptopa, odbywając lot służbowy. Komputer nie może nawiązać połączenia z Internetem w celu uzyskania informacji dotyczących znacznika czasowego i unieważniania oraz dodania ich do podpisu. Kiedy połączenie z Internetem stanie się dostępne, dowolna osoba, która zweryfikuje podpis, będzie mogła dodać te informacje do dokumentu PDF. Podczas każdego kolejnego sprawdzania poprawności podpisu można również użyć tych informacji.

  1. Należy upewnić się, że komputer jest w stanie połączyć się z właściwymi zasobami sieciowymi, a następnie kliknąć podpis w dokumencie prawym przyciskiem myszy.

  2. Wybierz polecenie Dodaj informacje weryfikacji.

Informacje i metody użyte w celu dołączenia informacji LTV do pliku PDF są zgodne z częścią 4. standardu 102 778 PDF Advanced Electronic Signatures (PAdES) ETSI. Więcej informacji można znaleźć pod adresem: blogs.adobe.com/security/2009/09/eliminating_the_penone_step_at.html. Polecenie jest niedostępne, jeśli podpis jest nieprawidłowy lub jest podpisany certyfikatem podpisanym przez użytkownika. Polecenie jest także niedostępne w przypadku, gdy czas weryfikacji jest taki sam, jak czas bieżący.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online