Szybkie rozpoznawanie zmian podczas porównywania dwóch wersji pliku PDF. Program Acrobat analizuje pliki i przedstawia raport dotyczący różnic między dokumentami.

Uwaga:

Jeśli masz subskrypcję programu Acrobat DC lub program Acrobat 2017, zobacz część Porównaj pliki poniżej. Jeśli masz starszą wersję programu Acrobat DC Classic tylko w wersji komputerowej, zobacz część Porównaj pliki w programie Acrobat DC Classic poniżej.

Narzędzie Porównaj pliki

Dostępne w programie Acrobat DC Continuous (subskrypcja), Acrobat 2017

Za pomocą nowego narzędzia Porównaj pliki można teraz szybko i dokładnie wykrywać różnice między dwiema wersjami pliku PDF.

  1. Wybierz polecenie Narzędzia > Porównaj pliki.

    Wybierz pliki do porównania
  2. Kliknij polecenie Wybierz plik po lewej stronie, aby wybrać starszą wersję pliku, który chcesz porównać. Kliknij polecenie Wybierz plik po prawej stronie, aby wybrać nowszą wersję pliku, który chcesz porównać.

  3. Kliknij przycisk Zmień plik, a następnie wybierz otwarty już plik lub odszukaj i wybierz żądany plik. Kliknij znajdującą się pomiędzy miniaturkami ikonę Zamień (przeciwstawne strzałki), aby zamienić położenie starego i nowego pliku.

    Wybierz pliki do porównania
  4. Aby zignorować różnice między elementami graficznymi, zaznacz pole tekstowe Porównaj tylko tekst.

  5. Możesz zmienić ustawienia. Wystarczy kliknąć ikonę zębatki (Ustawienia), co spowoduje otwarcie poniższego okna dialogowego.

    Ustawienia porównywania plików
    1. Porównanie można ograniczyć do fragmentów dokumentów, wprowadzając numery stron w polach Stary plik i Nowy plik.
    2. W polu Opis dokumentu wybierz rodzaj dokumentów do porównania.
      • Wybierz Autowykrywanie, jeśli chcesz, aby decydował program Acrobat.
      • Raporty, arkusze kalkulacyjne lub układy czasopism: porównuje zawartość w formie jednego bloku tekstu od początku do końca.
      • Prezentacje: postrzega każdy slajd lub stronę jako minidokument i dopasowuje te, które są do siebie podobne. Następnie porównywana jest zawartość dopasowanych dokumentów. Identyfikuje dokumenty, które zostały przeniesione (np. slajdy w prezentacji).
      • Zeskanowane dokumenty, rysunki lub ilustracje: tworzy obrazki dla każdej zeskanowanej strony, a następnie porównuje piksele. Porównuje zeskanowane strony i dopasowuje te, które są do siebie podobne. Identyfikuje także strony ułożone w innej kolejności. Opcja ta jest przydatna w przypadku porównywania obrazów lub rysunków technicznych budynków.

        Wskazówka
        : jeżeli treść dokumentu może ponownie wlać się między stronami, wybierz Raporty, arkusze kalkulacyjne lub układy czasopism; w przeciwnym razie wybierz Prezentacje. W przypadku porównywania zeskanowanych plików, wybierz Zeskanowane dokumenty, rysunki lub ilustracje.
        • W przypadku wybrania opcji raportu lub prezentacji, funkcja Porównaj tylko tekst identyfikuje wyłącznie różnice tekstowe pomiędzy oboma dokumentami.
        • W przypadku wybrania opcji skanowanych dokumentów, tekst jest porównywany niezależnie od grafik, a na koniec wyniki są łączone. W dokumentach zawierających reklamy, w których tekst został umieszczony na tle obrazu, dany akapit jest porównywany wyłącznie w trybie tekstowym. Grafika jest porównywana niezależnie w tle. Różnice zostają połączone w jeden dokument zawierający wyniki.
    3. Pokaż w raporcie: wybierz elementy dokumentów, których różnice chcesz zobaczyć w raporcie porównawczym.

      Uwaga: opcja tekstu może zostać użyta w każdym typie dokumentów. Opcję tę stworzono z myślą o porównywaniu tekstu w obszernych dokumentach (powyżej 250 stron). Opcja ta porównuje także tekst pomiędzy dokumentami posiadającymi obraz tła na każdej stronie, co spowalnia proces przetwarzania.
    4. Kliknij OK.
  6. Kliknij Porównaj.

    Program Acrobat wyświetli wyniki w nowym dokumencie. Pierwsza strona zawiera łatwe do przejrzenia podsumowanie wszystkich różnic między plikami.

    Wyniki porównania
    a – Znacznik czasowy porównania, b – Informacje o porównywanych plikach, c – Wszystkie zmiany, d – Rozpowszechnianie zmian, e – Zmiany formatowania, f – Łącze do pierwszej zmiany

  7. Kliknij przycisk Przejdź do pierwszej zmiany, aby rozpocząć szczegółowe sprawdzanie wszystkich różnic.

  8. Wybierz sposób przeglądania różnic.

    • Widok stron ułożonych obok siebie: użyj widoku Obok siebie (Ctrl+\), aby wyświetlić równoległy widok wyników, w którym różnice są oznaczone podświetleniem w paskach. Stary plik jest wyświetlany po lewej, a nowy plik po prawej stronie. Zmiany są oznaczane podświetleniem w paskach, które łączą pliki i ułatwiają sprawdzanie. Kliknij pasek, aby wyświetlić wyskakującą notatkę ze wszystkimi zmianami w ramach paska. Można też kliknąć wyróżnioną zawartość, aby otworzyć wyskakujące okienko.
    Widok Obok siebie

    Kliknij prawym przyciskiem myszy zmianę lub jej wyskakującą notatkę i ustaw odpowiedni stan zmiany.

    Ustaw stan zmiany
    • Widok Pojedyncza strona: użyj przycisku Stary plik lub Nowy plik (Ctrl+/) na pasku narzędzi, aby wyświetlić poszczególne pliki z podświetlonymi zmianami.
    Widok Pojedyncza strona
  9. Aby przejrzeć wszystkie zmiany:

    • Użyj opcji Filtruj i Pokaż.

    Różnice w adnotacjach, formatowaniu i tle są domyślnie wyłączone. Aby uwzględnić te zmiany w raporcie, wybierz te opcje w menu Filtruj na pasku narzędzi. Można również filtrować wyniki porównania przez wybór określonych typów zmian w menu Filtr. W menu Pokaż można wybrać opcję pokazywania/ukrywania legend, podświetlania wierszy lub wyników.

    Opcje funkcji Filtruj
    Opcje funkcji Pokaż
    • Użyj przycisku Poprzednia zmiana (Ctrl+.) lub Następny zmiana (Ctrl+,), aby przemieszczać się pomiędzy kolejnymi zmianami.
    Przyciski nawigacyjne

    Przyciski Poprzednia zmiana i Następna zmiana są również dostępne w wyskakujących notatkach ze szczegółami zmian.

    Przyciski nawigacyjne w wyskakującym okienku
    • Użyj panelu po prawej stronie. Kliknij trójkąt na środku prawego okna programu Acrobat, aby otworzyć panel po prawej stronie. Panel zawiera wszystkie zmiany widoczne w raporcie Wyniki porównania. Użyj pola tekstowego wyszukiwania, aby znaleźć określoną zmianę.
    Lista zmian podświetlona w panelu po prawej stronie
  10. Zapisz plik Wyniki porównania (Plik > Zapisz). Kliknij przycisk z krzyżykiem znajdujący się w prawym górnym rogu paska narzędzi, aby zamknąć narzędzia Porównaj pliki.

Można wydrukować raport porównawczy razem z podsumowaniem zmian.

  • Kliknij ikonę Drukuj na pasku narzędziowym, a następnie kliknij Drukuj w oknie dialogowym Drukuj.

Porównywanie plików w programie Acrobat DC Classic

Dostępne w programie Acrobat DC Classic (tylko wersja komputerowa)

Uwaga:

Jeśli masz program Acrobat DC Classic tylko w wersji komputerowej, postępuj zgodnie z poniższymi krokami: jeśli masz subskrypcję programu Acrobat DC Continuous albo program Acrobat 2017, zobacz Porównaj pliki w Acrobat DC Continuous i Acrobat 2017 powyżej.

Możesz korzystać z narzędzia Porównaj dokumenty w celu wyszukiwania różnic między dwoma wersjami pliku PDF. Po porównaniu dwóch plików program Acrobat tworzy szczegółowy raport o każdej zmianie, wliczając w to zmiany tekstu, czcionek, zdjęć, a nawet kolejności stron.

  1. Wybierz polecenie Narzędzia > Porównaj dokumenty.

  2. Wybierz dokumenty do porównania. Możesz ograniczyć porównanie do części dokumentów poprzez wprowadzenie numerów stron w polach Pierwsza strona i Ostatnia strona dla każdej nazwy pliku.

  3. W polu Opis dokumentu wybierz rodzaj dokumentów do porównania. Aby zignorować
    różnice między elementami graficznymi, wybierz opcję Porównaj tylko tekst. Kliknij przycisk OK.

    Program Acrobat wyświetli wyniki w nowym dokumencie. Pierwsza strona zawiera podsumowanie wyników porównania plików.

    Podsumowanie porównania dokumentów
    a – Różnice między plikami, b – Porównywane pliki, c – Łącze służące do rozpoczęcia pracy powoduje przejście do pierwszej różnicy, d – Przeniesione lub usunięte strony, e – Legenda symboli używanych w raporcie

  4. Wybierz sposób przeglądania różnic.

    1. Użyj panelu Porównaj, który znajduje się po lewej stronie (domyślnie).
      • Przejrzyj miniatury w panelu Porównaj. Ikona wyświetlana pod miniaturą wskazuje na różnicę. Zielona strzałka oznacza przeniesione lub usunięte strony. Fioletowa strzałka oznacza zmianę na stronie.
      • Powróć do pierwszej strony i kliknij przycisk Rozpoczynanie pracy, aby przejść do pierwszej różnicy.
      • Zmiany zostają podświetlone na ekranie głównym. Ustaw wskaźnik myszy na zaznaczeniu, aby wyświetlić szczegóły. Legenda w prawym górnym rogu zawiera objaśnienia kolorów.
    2. Skorzystaj z widoku stron ułożonych obok siebie.
      • W panelu Porównaj znajdującym się po lewej stronie kliknij ikonę opcji i wybierz polecenie Pokaż dokumenty
        obok siebie
        .
      • Zmiany zostają podświetlone na ekranie głównym. Ustaw wskaźnik myszy na zaznaczeniu, aby wyświetlić
        szczegóły. Legenda w prawym górnym rogu zawiera objaśnienia kolorów.
    Opcje porównania w programie Acrobat
    Opcje porównania dostarczają narzędzia do personalizacji porównania dokumentów.