Informacje o plikach programu Flash

Program Flash Professional obsługuje wiele typów plików, z których każdy ma inne przeznaczenie:

  • Pliki FLA są to najważniejsze spośród plików tworzonych w programie Flash Professional; zawierają podstawowe informacje o obiektach multimedialnych, osi czasu i skryptach używanych w dokumencie programu Flash Professional. Obiekty multimedialne są to różne obiekty graficzne, tekstowe, dźwiękowe i filmowe, które współtworzą dokument programu Flash Professional. Oś czasu jest to specjalna oś programu Flash Professional służąca do określania czasu wyświetlania poszczególnych obiektów multimedialnych na stole montażowym. Kod ActionScript® pozwala lepiej kontrolować działanie dokumentów programu Flash Professional i określać ich reakcje na działania użytkownika.

  • Nieskompresowane pliki XFL są podobne do plików FLA. Plik XLF i pozostałe skojarzone z nim pliki zawarte w tym samym folderze stanowią nieskompresowany odpowiednik pliku FLA. Dzięki temu formatowi grupy użytkowników mogą łatwiej równocześnie pracować nad różnymi elementami projektu Flash. Więcej informacji można znaleźć w rozdziale Praca z nieskompresowanymi plikami XFL.

  • Pliki SWF są to skompilowane wersje plików FLA wyświetlane na stronach internetowych. Podczas publikowania pliku FLA program Flash Professional tworzy plik SWF.

    Format SWF programu Flash Professional stanowi otwarty standard obsługiwany przez wiele aplikacji. Więcej informacji o formatach zapisu danych w programie Flash Professional można uzyskać pod adresem http://www.adobe.com/go/flashplayer_pl.

  • Pliki AS to pliki języka ActionScript. Dzięki nim niektóre lub nawet wszystkie fragmenty kodu ActionScript można zapisać poza plikiem FLA, co może usprawnić obsługę takiego kodu i jest wygodne w przypadku dużych projektów, kiedy nad różnymi fragmentami dokumentu programu Flash Professional pracują różne osoby.

  • Pliki SWC zawierają składniki programu Flash Professional przeznaczone do wielokrotnego użytku. Każdy plik SWC obejmuje skompilowany klip filmowy, kod ActionScript oraz wszelkie inne zasoby wymagane przez dany składnik.

    Uwaga: (Tylko Flash Professional CC) Plików SWC nie można importować do programu Flash Pro.

  • Pliki ASC zawierają kod ActionScript, który będzie wykonywany na komputerze wyposażonym w oprogramowanie Flash Media Server. Pliki takie powodują, że serwer poprawnie interpretuje kod ActionScript zawarty w pliku SWF.

    Uwaga: Program Flash Professional CC nie obsługuje plików ASC.

  • Pliki JSFL są to pliki skryptów JavaScript implementujących nowe funkcje programu Flash Professional.

Firma Adobe poleca

Firma Adobe poleca
<a href=”http://goo.gl/1iL8L”>Wprowadzenie do programu Flash Professional</a>
Todd Perkins

W następujących dodatkowych materiałach i samouczkach przedstawiono metody pracy w programie Flash Professional: W niektórych materiałach wideo może być prezentowany program Flash Professional CS3 lub CS4, jednak mają one zastosowanie również do programu Flash Professional CS5.

Współpraca z innymi aplikacjami firmy Adobe

Użytkownicy programu Flash mogą w szerokim zakresie stosować funkcje innych aplikacji firmy Adobe®. Pliki tworzone w programach Illustrator® i Photoshop® można importować bezpośrednio do programu Flash. Filmy utworzone w programie Flash można edytować za pomocą aplikacji Adobe ® Premiere® Pro lub After Effects® i na odwrót: pliki wideo utworzone w tych aplikacjach można importować do programu Flash. Do publikowania plików SWF można używać programu Dreamweaver® w celu osadzenia treści na stronie internetowej, a do jej edycji można użyć programu Flash bezpośrednio w programie Dreamweaver.

Otwieranie plików XFL

Począwszy od wersji programu Flash Professional CS5 XFL stanowi format wewnętrzny tworzonych plików FLA. W przypadku zapisywania pliku w formacie programu Flash FLA stanowi format domyślny, zaś formatem wewnętrznym pliku jest format XFL.

Inne aplikacje firmy Adobe®, takie jak After Effects®, umożliwiają eksportowanie plików w formacie XFL. Pliki te mają rozszerzenie XFL zamiast rozszerzenia FLA. Program InDesign® umożliwia eksportowanie plików bezpośrednio w formacie FLA, przy czym formatem wewnętrznym pozostaje XFL. Dzięki temu możliwa jest praca nad projektem początkowo w programach After Effects lub InDesign, a następnie w programie Flash.

W programie Flash można otwierać pliki XFL i pracować z nimi tak samo, jak z plikami FLA. Po otwarciu pliku XFL w programie Flash Professional możliwe jest zapisanie go w formacie FLA lub jako nieskompresowany plik XFL.

W poniższych samouczkach wideo zademonstrowano eksportowanie danych z programów InDesign i AfterEffects do programu Flash za pośrednictwem formatu XFL i FLA:

Aby otworzyć plik XFL w programie Flash:

  1. W innej aplikacji firmy Adobe®, na przykład InDesign lub After Effects, wyeksportuj efekty swojej pracy w pliku XFL.

    Aplikacja zachowa w tym pliku wszystkie informacje o warstwach i obiektach z oryginalnego pliku.

  2. W programie Flash Professional wybierz polecenie Plik > Otwórz i przejdź do pliku XFL. Kliknij przycisk Otwórz.

    Plik XFL zostanie otwarty w programie Flash w taki sam sposób, jak każdy plik FLA. Wszystkie warstwy oryginalnego pliku pojawią się na osi czasu, a oryginalne obiekty pojawią się w panelu Biblioteka.

    Teraz można pracować z plikiem w zwykły sposób.

  3. Aby zapisać plik, wybierz polecenie Plik > Zapisz.

    Program Flash Professional wyświetli monit z informacją o konieczności nazwania nowego pliku FLA w oknie dialogowym zapisywania jako.

  4. Wpisz nazwę i zapisz plik FLA.

Praca z nieskompresowanymi plikami XFL

Począwszy od wersji Flash Professional CS5 możliwa jest praca z plikami programu Flash w nieskompresowanym formacie XFL. Format ten zapewnia widoczność poszczególnych części (podplików) składających się na plik Flash. Są to następujące części:

  • Plik XML, który opisuje cały plik programu Flash.

  • Odrębne pliki XML opisujące poszczególne symbole biblioteczne.

  • Dodatkowe pliki XML zawierające ustawienia publikowania, ustawienia wdrożenia na urządzeniach mobilnych i inne ustawienia.

  • Foldery zawierające zasoby zewnętrzne, takie jak pliki bitmapowe, używane w pliku programu Flash.

Nieskompresowany format XFL umożliwia równoległą pracę kilku osób nad odrębnymi częściami pliku Flash. Do zarządzania zmianami dokonywanymi w poszczególnych podplikach nieskompresowanego pliku XFL można używać systemu kontroli wersji. Wszystkie te możliwości znacząco usprawniają zespołową pracę nad dużymi projektami, w których uczestniczy wielu projektantów i programistów.

Aktualizowanie otwartych plików XFL

Istnieje możliwość aktualizacji zasobów edytowalnych, w szczególności dowolnych zasobów bibliotecznych, w nieskompresowanym dokumencie XFL, który jest otwarty w programie Flash. Zmiany wprowadzone w zasobie zostaną odzwierciedlone w programie Flash po zakończeniu edycji zasobu w innej aplikacji.

Aby edytować zasób z nieskompresowanego dokumentu XFL w innej aplikacji:

  1. Zapisz dokument Flash w nieskompresowanym formacie XFL.

  2. W odpowiednim edytorze, takim jak Photoshop, otwórz zasób, który chcesz edytować, z folderu LIBRARY w nieskompresowanym dokumencie XFL.

  3. Dokonaj edycji zasobu i zapisz zmiany.

  4. Wróć do programu Flash Pro.

    Aktualizacja zasobu zostanie natychmiast odzwierciedlona w programie Flash.

Edytowanie pliku SWF programu Dreamweaver w programie Flash

Jeśli masz zainstalowane programy Flash i Dreamweaver, możesz zaznaczyć plik SWF w dokumencie Dreamweaver i użyć programu Flash, aby go edytować. Program Flash nie edytuje wprost pliku SWF; edytuje dokument źródłowy (plik FLA) i ponownie eksportuje plik SWF.

  1. W programie Dreamweaver, otwórz inspektor Właściwości (Okno > Właściwości).
  2. W dokumencie Dreamweaver, wykonaj jedną z poniższych czynności:
    • Kliknij element zastępczy pliku SWF, aby go zaznaczyć; następnie w inspektorze Właściwości kliknij Edytuj.

    • Kliknij prawym przyciskiem myszy (Windows) lub kliknij z wciśniętym klawiszem Control (Mac OS) element zastępczy pliku SWF, po czym wybierz z menu kontekstowego polecenie Edytuj w programie Flash.

      Program Dreamweaver przełącza się do programu Flash, a Flash próbuje zlokalizować plik (FLA) dla zaznaczonego pliku SWF. Jeśli program Flash nie może znaleźć pliku FLA, poprosi o wskazanie go.

      Uwaga: Jeśli plik FLA lub SWF jest zablokowany, wyewidencjonuj plik w programie Dreamweaver.

  3. W programie Flash, edytuj plik FLA. Okno dokumentu Flash pokazuje, że modyfikujesz plik z programu Dreamweaver.
  4. Gdy zakończysz edycję, kliknij Gotowe.

    Program Flash uaktualni plik FLA, ponownie wyeksportuje go jako plik SWF, zamknie, i następnie powróci do dokumentu Dreamweaver.

    Uwaga:

    Aby zaktualizować plik SWF i zachować otwarty program Flash, w programie Flash wybierz polecenie Plik > Zaktualizuj dla programu Dreamweaver.

  5. Aby wyświetlić zaktualizowany plik w dokumencie, kliknij opcję Odtwórz w Inspektorze właściwości programu Dreamweaver. Można też nacisnąć klawisz F12, aby wyświetlić podgląd strony w oknie przeglądarki.
  1. Uruchom program Flash.
  2. Na ekranie głównym programu Flash wybierz polecenie Utwórz nowy > Plik Flash (przenośne).
  3. W programie Device Central wybierz wersje odtwarzacza i języka ActionScript.
  4. Wybierz typ treści.
  5. Na liście dostępnych urządzeń zaznacz jedno urządzenie docelowe lub wiele urządzeń docelowych (lub wybierz co najmniej jedno urządzenie na liście zestawów urządzeń).
  6. Kliknij przycisk Utwórz.
  7. Dodaj treść do nowego dokumentu w programie Flash.
  8. Aby przetestować dokument, wybierz polecenie Sterowanie > Testuj.

Tworzenie nowego dokumentu

W programie Flash Professional można otwierać nowe lub uprzednio zapisane dokumenty, a także otwierać na bieżąco (w trakcie wykonywania innych zadań) nowe okna. Można też określać właściwości nowych i już utworzonych dokumentów.

Tworzenie nowego dokumentu

  1. Wybierz polecenie Plik > Nowy.
  2. Na karcie Ogólne wybierz typ dokumentu Flash, który chcesz utworzyć.
  3. Wykonaj jedną z następujących czynności:

Tworzenie nowego dokumentu z szablonu

  1. Wybierz polecenie Plik > Nowy.
  2. Kliknij zakładkę Szablony.
  3. Zaznacz kategorię na liście Kategoria, zaznacz dokument na liście Elementy kategorii i kliknij przycisk OK. Można wybrać jeden ze standardowych szablonów programu Flash Professional lub uprzednio zapisany szablon.

Otwieranie istniejącego dokumentu

  1. Wybierz polecenie Plik > Otwórz.
  2. W oknie dialogowym Otwórz przejdź do wybranego pliku lub wprowadź ścieżkę do pliku w polu Przejdź do.
  3. Kliknij przycisk Otwórz.

Wyświetlanie dokumentu, gdy jest otwartych wiele dokumentów

Kiedy jest otwartych wiele dokumentów, u góry okna Dokument są wyświetlane zakładki, które ułatwiają wywoływanie poszczególnych dokumentów. Zakładki są widoczne pod warunkiem, że dokumenty zostały zmaksymalizowane.

  1. Kliknij zakładkę dokumentu, który chcesz wyświetlić.

    Zgodnie z zasadą domyślną zakładki są wyświetlane w kolejności odpowiadającej kolejności tworzenia dokumentów. Obowiązującą kolejność można zmienić, przeciągając wybrane zakładki.

Otwieranie nowego okna dla bieżącego dokumentu

  1. Wybierz polecenie Powiel > Powiel okno.

Określanie właściwości nowego lub istniejącego dokumentu

  1. Mając dokument otwarty, wybierz polecenie Modyfikuj > Dokument.

    Zostanie wyświetlone okno dialogowe Ustawienia dokumentu.

  2. Aby ustawić wymiary stołu montażowego, wykonaj jedną z następujących czynności:
    • Aby określić rozmiar stołu montażowego w pikselach, wprowadź wartości w polach Szerokość i Wysokość. Rozmiar minimalny wynosi 1 x 1 piksel, a rozmiar maksymalny — 2880 x 2880 pikseli.

    • Aby dopasować rozmiar stołu montażowego dokładnie do miejsca używanego przez zawartość stołu montażowego, wybierz opcję Tak jak zawartość.

    • Aby rozmiar stołu montażowego odpowiadał maksymalnemu dostępnemu obszarowi druku, wybierz opcję Dopasuj do drukarki. Wielkość tego obszaru jest określana przez pomniejszenie rozmiaru papieru o bieżący rozmiar marginesów — rozmiar wybrany w obszarze Marginesy okna dialogowego Ustawienia strony (Windows) lub Marginesy wydruku (Macintosh).

    • Aby ustawić domyślny rozmiar stołu montażowego — 550 x 400 pikseli — wybierz opcję Dopasuj do domyślnego.

  3. Aby dopasować położenie i orientację obiektów 3D na stole montażowym w celu zachowania ich wyglądu względem krawędzi stołu, wybierz opcję Dopasuj kąt perspektywy 3D w celu zachowania bieżącego rzutowania stołu montażowego.

    Ta opcja jest dostępna tylko po zmianie rozmiaru stołu montażowego.

  4. (Tylko CS5.5) Aby automatycznie skalować zawartość stołu montażowego wraz ze zmianami jego rozmiaru, wybierz opcję Skaluj zawartość ze stołem montażowym.

    Ta opcja jest dostępna tylko po zmianie rozmiaru stołu montażowego. Preferencje pozwalają określić, czy skalowanie ma dotyczyć zawartości w zablokowanych i ukrytych warstwach. Więcej informacji zawiera sekcja Ustawianie preferencji ogólnych.

  5. Aby określić jednostkę dla miarek wyświetlanych w obszarze roboczym, wybierz opcję w menu Jednostki miarki. (Ustawienie to określa również jednostki używane w panelu Informacje).
  6. Aby ustawić kolor tła dokumentu, kliknij próbkę Kolor tła i wybierz kolor z palety.
  7. W polu Szybkość odtwarzania wprowadź liczbę klatek, które będą odtwarzane w ciągu sekundy.

    Większość animacji odtwarzanych na komputerze, w szczególności animacji odtwarzanych z witryn internetowych, działa wystarczająco dobrze przy szybkościach od 8 do 15 klatek na sekundę. Zmieniona szybkość odtwarzania będzie obowiązywać domyślnie dla nowych dokumentów.

  8. (Tylko CS5.5) Aby automatycznie zapisywać dokument w określonych odstępach czasu, wybierz opcję Autozapis i wprowadź liczbę minut między kolejnymi operacjami zapisywania.
  9. Wykonaj jedną z następujących czynności:
    • Aby zastosować nowe ustawienia tylko do bieżącego dokumentu, kliknij przycisk OK.

    • Aby uczynić nowe ustawienia domyślnymi właściwościami wszystkich nowych dokumentów, kliknij przycisk Ustaw jako domyślne.

Zmienianie właściwości dokumentu za pomocą Inspektora właściwości

  1. Kliknij w obszarze roboczym poza stołem montażowym, aby usunąć zaznaczenie wszystkich obiektów na stole montażowym. W Inspektorze właściwości zostaną wyświetlone właściwości dokumentu. Aby otworzyć Inspektora właściwości, wybierz opcję Okno > Właściwości.
  2. (Tylko CS5.5) W sekcji Publikowanie wybierz wersję programu Flash Player i języka ActionScript dla dokumentu. Aby uzyskać dostęp do dodatkowych ustawień publikowania, kliknij przycisk Ustawienia publikowania. Więcej informacji można znaleźć w sekcji Ustawienia publikowania.

  3. W sekcji Właściwości w polu szybkości odtwarzania (klatek na sekundę) wprowadź liczbę klatek animacji, które mają być odtwarzane w każdej sekundzie.
  4. Aby zmienić rozmiar stołu montażowego, wprowadź wartości szerokości i wysokości stołu montażowego.
  5. Aby ustawić kolor tła stołu montażowego, kliknij próbkę koloru obok właściwości stołu montażowego i wybierz kolor z palety.
  6. Aby edytować dodatkowe właściwości dokumentu, kliknij przycisk Edytuj obok właściwości rozmiaru. Więcej informacji na temat wszystkich właściwości dokumentu można znaleźć w sekcji Określanie właściwości nowego lub istniejącego dokumentu.

Dodawanie metadanych XMP do dokumentów

Do plików Flash można dodawać dane Extensible Metadata Platform (XMP), takie jak tytuł, nazwa autora, opis czy informacje o prawach autorskich. XMP to format metadanych rozpoznawany przez niektóre inne aplikacje firmy Adobe®. Metadane można wyświetlać w programie Flash Professional oraz w aplikacji Adobe® Bridge. Więcej informacji o metadanych XMP zawiera sekcja Metadane i słowa kluczowe w pomocy do programu Bridge.

Uwaga: Program Adobe Flash Professional CC nie obsługuje 32-bitowego programu Bridge.

Osadzenie metadanych usprawnia przeszukiwanie elementów utworzonych za pomocą programu Flash Professional przez różne wyszukiwarki internetowe. Metadane ułatwiające wyszukiwanie są oparte na specyfikacjach XMP (Extensible Metadata Platform); te metadane są zapisywane w pliku FLA w formacie zgodnym ze standardem W3C.

Metadane pliku zawierają informacje dotyczące treści, stanu praw autorskich, źródła i historii pliku. W oknie dialogowym Informacje o pliku można wyświetlać i edytować metadane dla bieżącego pliku.

W zależności od wybranego pliku mogą być dostępne następujące typy metadanych:

Opis

Zawiera między innymi informacje o autorze, tytule czy prawach autorskich.

IPTC

Wyświetla metadane podlegające edycji. Umożliwia dodawanie podpisów do plików oraz informacje o prawach autorskich. Rdzeń IPTC jest specyfikacją przyjętą przez IPTC (International Press Telecommunications Council) w październiku 2004 roku. Różni się od starszej specyfikacji IPTC (IIM, starszych) tym, że dodane zostały nowe właściwości, dla części właściwości zostały zmienione nazwy, a także niektóre właściwości zostały usunięte.

Dane aparatu fotograficznego (Exif)

Wyświetla informacje przypisywane przez aparaty cyfrowe, łącznie z ustawieniami aparatu, jakie były używane podczas wykonywania zdjęcia.

Dane wideo

Wyświetla metadane dla plików wideo łącznie z proporcjami pikseli, danymi dotyczącymi sceny i ujęcia.

Dane dźwiękowe

Wyświetla metadane dla plików audio łącznie z danymi dotyczącymi artysty, numerem ścieżki i gatunkiem.

SWF dla urządzeń przenośnych

Wyświetla informacje dotyczące plików SWF, między innymi: tytuł, autor, opis i prawa autorskie.

Historia

Rejestruje zmiany wprowadzone w obrazach przy użyciu programu Photoshop.

Uwaga: W programie Photoshop należy włączyć preferencję Dziennik historii. Wówczas w dzienniku będą zapisywane metadane pliku.

Version Cue

Wyświetla informacje Version Cue o wersji pliku.

DICOM

Wyświetla informacje o obrazach zapisanych w formacie DICOM (Digital Imaging and Communications in Medicine).

W celu dodania metadanych:

  1. Wybierz polecenie Plik > Informacje o pliku.
  2. Pojawi się okno dialogowe Informacje o pliku, do którego można wprowadzić metadane, jakie mają być uwzględniane. Metadane można w dowolnym czasie dodawać i usuwać z pliku FLA.

Zapisywanie dokumentów programu Flash

Dokument programu Flash Professional w formacie FLA można zapisać pod bieżącą nazwą i w bieżącej lokalizacji; można też wybrać inną nazwę lub lokalizację.

Jeśli pewien dokument zawiera niezapisane zmiany, po jego nazwie - widocznej na pasku tytułowym dokumentu, pasku tytułowym aplikacji lub zakładce dokumentu - jest widoczna gwiazdka (*). Po zapisaniu dokumentu gwiazdka znika.

Zapisywanie dokumentu programu Flash w domyślnym formacie FLA

  1. Wykonaj jedną z następujących czynności:
    • Aby zastąpić bieżącą wersję pliku na dysku, wybierz polecenie Plik > Zapisz.

    • Aby zapisać dokument w innym miejscu i/lub pod inną nazwą, wybierz polecenie Plik > Zapisz jako.

  2. Jeśli wybrano polecenie Zapisz jako lub jeśli dokument jest zapisywany po raz pierwszy, określ nazwę i miejsce zapisania pliku.
  3. Kliknij przycisk Zapisz.

Zapisywanie dokumentu w nieskompresowanym formacie XFL

  1. Wybierz polecenie Plik > Zapisz jako.
  2. W menu Zapisz jako typ wybierz opcję Nieskompresowany dokument Flash CS5 lub CS5.5 (*.xfl).
  3. Wybierz nazwę i położenie pliku, po czym kliknij przycisk Zapisz.

Przywracanie ostatnio zapisanej wersji dokumentu

  1. Wybierz polecenie Plik > Przywróć.

Zapisywanie dokumentu jak szablonu

  1. Wybierz polecenie Plik > Zapisz jako szablon.
  2. W oknie dialogowym Zapisz jako szablon wprowadź nazwę szablonu w polu Nazwa.
  3. Wybierz kategorię z menu Kategoria lub wprowadź nazwę, aby utworzyć nową kategorię.
  4. Wprowadź opis szablonu w polu Opis (maksymalnie 255 znaków) i kliknij przycisk OK.

    Opis będzie wyświetlany po zaznaczeniu szablonu w oknie dialogowym Nowy dokument.

    Aby usunąć zapisany szablon, przejdź do jednego z poniższych folderów i usuń plik szablonu FLA z odpowiedniego folderu kategorii.

    • Windows XP: C:\Documents and Settings\<nazwa użytkownika>\Ustawienia lokalne\Dane aplikacji\Adobe\Flash CS5\pl_PL\Configuration\Templates\

    • Windows 7 i Windows Vista: C:\Użytkownicy\<nazwa użytkownika>\AppData\Local\Adobe\Flash CS5\<język>\Configuration\Templates\

    • Mac OS: <dysk_twardy>/Użytkownicy/<nazwa_użytkownika>/Biblioteki/Application Support/Adobe/Flash CS5/<język>/Configuration/Templates/

Zapisywanie dokumentu jako dokumentu programu Flash CS4

  1. Wybierz polecenie Plik > Zapisz jako.
  2. Podaj nazwę i miejsce zapisania z pliku.
  3. Z wyskakującego menu Format wybierz opcję Dokument Flash CS4, po czym kliknij przycisk Zapisz.

    Uwaga:

    Jeśli pojawi się komunikat z ostrzeżeniem, że po zapisaniu pliku w formacie programu Flash CS4 treść zostanie usunięta, kliknij przycisk Zapisz jako Flash CS4, aby kontynuować.Taka sytuacja może wystąpić, jeśli dokument zawiera elementy obsługiwane tylko w wersji Flash CS5. Program Flash Professional nie zachowa tych elementów, jeśli plik zostanie zapisany w formacie Flash CS4.

Zapisywanie dokumentów przy zamykaniu programu Flash

  1. Wybierz polecenie Plik > Wyjdź (Windows) lub Flash > Zakończ Flash (Macintosh).
  2. Jeśli otwarte są dokumenty, których zmian jeszcze nie zapisano, program Flash Professional monituje o zapisanie lub pominięcie zmian w poszczególnych dokumentach.
    • Kliknij przycisk Tak, aby zapisać zmiany i zamknąć dokument.

    • Kliknij przycisk Nie, aby zamknąć dokument bez zapisywania zmian.

Drukowanie dokumentów programu Flash

Aby wyświetlać i edytować dokumenty, można albo drukować klatki z dokumentów programu Drukuj Flash Professional, albo w przeglądarce określić, które z nich nadają się do druku z programu Flash Player.

Drukując klatki z dokumentu programu Flash Professional należy w oknie dialogowym drukowania określić zakres scen lub klatek do drukowania oraz liczbę kopii wydruku. W systemie Windows rozmiar papieru, orientację oraz różne inne opcje drukowania, w tym ustawienia marginesów i to, czy wszystkie klatki będą drukowane na każdej stronie, można ustawić w oknie dialogowym Ustawienia strony. W systemie Macintosh, opcje te są dzielone pomiędzy okna dialogowe Ustawienia strony i Drukuj marginesy.

Okna dialogowe Ustawienia strony i Konfiguracja drukowania są standardowymi dla każdego systemu operacyjnego i ich wygląd zależy od wybranego sterownika drukarki.

  1. Wybierz polecenie Plik > Ustawienia strony (Windows) lub Plik > Drukuj marginesy (Macintosh).
  2. Ustaw marginesy strony. Aby drukowana klatka znajdowała się na środku strony, zaznacz obydwie opcje środkowania.
  3. W menu Klatki określ, czy program ma drukować wszystkie klatki w dokumencie, czy tylko pierwszą klatkę każdej sceny.
  4. W menu Układ zaznacz jedną z następujących opcji:

    Rzeczywista wielkość

    Klatka jest drukowana w pełnym rozmiarze. Aby zmniejszyć lub powiększyć drukowaną klatkę wprowadź wartość w polu Skala.

    Dopasuj do jednej strony

    Pozwala zmniejszyć lub powiększyć rozmiar każdej klatki, tak aby wypełniła obszar zadruku na stronie.

    Scenopis obrazkowy

    Drukowanie kilku miniaturek na jednej stronie. Wybierz jedną z opcji: Pola, Siatka lub Pusty. W polu Klatki wprowadź liczbę miniaturek na stronie. W polu Margines klatki określ ilość wolnego miejsca między miniaturkami, a następnie zaznacz pole Klatki z etykietami, aby wydrukować etykietę klatki w postaci miniaturki.

  5. Aby wydrukować klatki, wybierz polecenie Plik > Drukuj.

Wyłączanie drukowania za pomocą etykiet klatek

Aby zablokować wyświetlanie klatek na głównej osi czasu, należy nadać klatce etykietę !#p, co spowoduje, że cały plik SWF będzie zablokowany do drukowania. Nadanie klatce etykiety !#p wygasza polecenie Drukuj w menu kontekstowym programu Flash Player. Można również usunąć menu kontekstowe programu Flash Player.

Po wyłączeniu drukowania z programu Flash Player nadal można drukować klatki, korzystając z polecenia Drukuj, znajdującego się w przeglądarce. Polecenie to jest funkcją przeglądarki, dlatego program Flash Professional nie może nim sterować ani go wyłączyć.

Wyłączanie drukowania w menu kontekstowym programu Flash Player

  1. Aby rozpocząć publikowanie, otwórz lub uaktywnij dokument programu Flash Professional (plik FLA).
  2. Na głównej osi czasu zaznacz pierwszą klatkę kluczową.
  3. Wybierz polecenie Okno > Właściwości, aby wyświetlić okno Inspektora właściwości.
  4. W inspektorze Właściwości wpisz ! #p w polu Etykieta klatki, aby określić klatkę jako niedrukowalną.

    Określ tylko jedną etykietę !#p w celu wygaszenia polecenia Drukuj w menu kontekstowym.

    Uwaga:

    Można również zaznaczyć pustą klatkę (a nie klatkę kluczową) i nadać jej etykietę #p.

Wyłączanie drukowania przez usunięcie menu kontekstowego programu Flash Player

  1. Aby rozpocząć publikowanie, otwórz lub uaktywnij dokument programu Flash Professional (plik FLA).
  2. Wybierz polecenie Plik > Ustawienia publikowania.
  3. Zaznacz zakładkę HTML i usuń zaznaczenie opcji Wyświetl menu, a następnie kliknij przycisk OK.

Określanie obszaru zadruku w trakcie drukowania klatek

  1. Otwórz dokument programu Flash Professional (plik FLA) zawierający klatki przeznaczone do druku.
  2. Wybierz klatkę, która nie została przeznaczona do drukowania za pomocą etykiety #p i znajduje się na tej samej warstwie, co klatka z etykietą #p.

    Zaznacz klatkę, która ma następować po klatce o etykiecie #p.

  3. Utwórz na stole montażowym kształt obszaru zadruku w pożądanym rozmiarze. Zaznacz klatkę z jakimkolwiek obiektem znajdującym się w wyznaczonym rozmiarze obszaru zadruku, aby wykorzystać obwiednię klatki.
  4. Zaznacz na osi czasu klatkę zawierającą kształt dla obwiedni.
  5. W inspektorze Właściwości (Okno > Właściwości), w polu Etykieta klatki wpisz etykietę #b. Dzięki temu obwiednia obszaru drukowania będzie miała wybrany kształt.

    Na jednej osi czasu dozwolona jest tylko jedna etykieta #b. Identyczna opcja jest dostępna w zakładce Operacja druku dla pola Opcja obwiedni filmu.

Zmiana drukowanego koloru tła

Kolor tła wydruku ustawia się w oknie dialogowym Właściwości dokumentu. Dla drukowanych klatek kolor tła zmienia się przed drukowaniem przez umieszczenie kolorowego obiektu na najniższej warstwie osi czasu.

  1. Umieść wypełniony kształt przykrywający stół montażowy na najniższej warstwie osi czasu, aby go później wydrukować.
  2. Zaznacz kształt, następnie wybierz polecenie Modyfikuj > Dokument Zaznacz kolor tła wydruku.

    Operacja ta zmienia kolor tła dokumentu, włączając w to klipy filmowe i wczytane pliki SWF.

  3. Wykonaj jedną z następujących czynności:
    • Wyznacz do drukowania klatkę z umieszczonym w niej kształtem, aby wydrukować kolor będący tłem dokumentu.

    • Powtórz kroki 2 i 3, aby zachować inny kolor tła dla klatek niedrukowalnych. Potem, we wszystkich klatkach nie przeznaczonych do druku umieść kształt na najniższej warstwie osi czasu.

Do drukowania klatek z plików SWF programu Flash Player służy polecenie Drukuj w menu kontekstowym programu Flash Player.

Za pomocą polecenia Drukuj menu kontekstowego nie można drukować przezroczystości lub efektów kolorów oraz klatek z innych klipów filmowych; więcej zaawansowanych możliwości drukowania dostarcza obiekt PrintJob lub funkcja print().

  1. Otwórz dokument.

    Polecenie drukuje klatki z etykietą #p, wykorzystując stół montażowy dla obszaru drukowania lub określoną obwiednię.

    Jeśli nie ma wyznaczonych określonych klatek do druku, drukowane są wszystkie klatki w dokumencie leżącym na głównej osi czasu.

  2. Wybierz polecenie Plik > Podgląd publikowania > Domyślny lub naciśnij przycisk F12, aby zobaczyć zawartość programu Flash Professional w przeglądarce.
  3. Ustaw wskaźnik myszy w oknie przeglądarki i kliknij prawym przyciskiem myszy (Windows) lub kliknij z wciśniętym klawiszem Control (Macintosh) zawartość programu Flash Professional, aby wyświetlić menu kontekstowe programu Flash Player.
  4. Wybierz polecenie Drukuj z menu kontekstowego programu Flash Player, aby wyświetlić okno dialogowe Drukuj.
  5. Aby wyznaczyć klatki do druku w systemie Windows, zaznacz zakres druku.
  6. Na komputerze Macintosh zaznacz strony do druku w oknie dialogowym Drukuj.
  7. Zaznacz inne opcje druku, zgodne z właściwościami drukarki.
  8. Kliknij przycisk OK (Windows) lub Drukuj (Macintosh).

Uwaga:

Drukowanie z menu kontekstowego nie wpływa na wywołania obiektu PrintJob.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online