Problem: Błąd „Licencja dla tego produktu przestała działać”

Uwaga:

Ten artykuł dotyczy pakietu Creative Suite 5.5 i wcześniejszych wersji.

Podczas próby uruchomienia aplikacji firmy Adobe wyświetla się komunikat o błędzie „Licencja dla tego produktu przestała działać”? Jeśli tak, spróbuj wykonać czynności opisane na tej stronie, aby rozwiązać problem.

Rozwiązania

Ważne: Użyj poniższych rozwiązań w podanej kolejności. Jeśli jedno z rozwiązań rozwiąże problem, nie wykonuj już następnego rozwiązania. Po wykonaniu niektórych z tych rozwiązań może być konieczne ponowne wprowadzenie danych licencji lub ponowna aktywacja produktu. Ponadto uruchomienie wersji próbnych oprogramowania firmy Adobe może nie być możliwe.

Rozwiązanie 1: Zastosuj narzędzie License Service Update.

  1. Zamknij wszystkie aplikacje firmy Adobe.
  2. Uruchom narzędzie License Service Update:

    1. Rozpakuj plik LicenseRecovery109.zip.

      Ważne: W celu rozpakowania zawartości skompresowanego pliku użyj narzędzia takiego jak WinZip.
    2. Dwukrotnie kliknij plik LicenseRecover.exe.
  3. Postępuj zgodnie z instrukcjami wyświetlanymi na ekranie.
  4. Uruchom aplikację firmy Adobe.

    Ważne: Poprawka dotyczy produktów Creative Suite 3 lub 4, Acrobat 8 lub 9, Photoshop Elements 6, 7 lub 8, Director oraz Adobe Technical Communication Suite. Jeśli nie udało się rozwiązać problemu przy pierwszej próbie, uruchom poprawkę ponownie i wpisz opcję 0 w razie wyświetlenia monitu. Jeśli po drugim uruchomieniu poprawki problem nadal występuje, przejdź do Rozwiązania 2.

Rozwiązanie 2: Ustaw opcję Ręczny dla usługi FLEXnet Licensing Service, a następnie uruchom usługę.

  1. Wybierz polecenia Start > Panel sterowania.
  2. Dwukrotnie kliknij Narzędzia administracyjne.
  3. Dwukrotnie kliknij Usługi.
  4. Dwukrotnie kliknij usługę FLEXnet Licensing Service, aby wyświetlić okno dialogowe Właściwości.
  5. Kliknij menu Typ uruchomienia i wybierz opcję Ręczny.
  6. Kliknij Zastosuj.
  7. W sekcji Status usług kliknij polecenie Start, aby uruchomić usługę.
  8. Kliknij polecenie Zastosuj, a następnie kliknij OK.
  9. Zamknij wszystkie otwarte okna dialogowe.
  10. Uruchom aplikację firmy Adobe.
 

Uwaga: W przypadku otrzymania błędu „Błąd 5, odmowa dostępu” podczas próby uruchomienia usługi FLEXnet Licensing Service, wykonaj następujące czynności:

  1. Wybierz polecenie Start > Uruchom i wpisz services.msc.
  2. Dwukrotnie kliknij pozycję FLEXnet Licensing Service.
  3. Kliknij kartę Logowanie i wybierz opcję Logowanie jako: To konto, a następnie podaj nazwę swojego konta.
  4. Kliknij przycisk OK i zamknij okno Usługi.
  5. Zrestartuj system, a następnie powtórz Rozwiązanie 2.

Rozwiązanie 3: Zmień nazwę folderu FLEXnet.

Przejdź do podanej lokalizacji i zmień nazwę folderu FLEXnet na FLEXnetold:

  • W systemie Windows XP:
    C:\Documents and Settings\All Users\Application Data\FLEXnet
  • W systemie Windows Vista lub Windows 7:
    C:\ProgramData\FLEXnet folder

Ważne: Usunięcie tego pliku spowoduje automatyczne zakończenie okresu testowania wszystkich aktywnych wersji próbnych oprogramowania firmy Adobe. 

 

Rozwiązanie 4: Wyzeruj uprawnienia do folderu FLEXnet.

Zamknij wszystkie aplikacje firmy Adobe. Folder FLEXnet zawiera dane licencyjne dla zainstalowanych aplikacji Adobe. Dostosowanie uprawnień do plików w folderze FLEXnet może umożliwić prawidłowe zapisanie informacji licencyjnych.Aby zmodyfikować uprawnienia dla folderu FLEXnet (zawierającego dane o usłudze licencjonowania), wykonaj poniższe instrukcje stosownie do posiadanego systemu operacyjnego.

Uwaga: To rozwiązanie wymaga posiadania uprawnień administratora. W systemie Windows XP zaloguj się na konto administratora. W systemie Windows 7 i Vista podaj dane logowania administratora.

W systemie Windows XP Professional

  1. Wybierz polecenia Start > Panel sterowania.
  2. Dwukrotnie kliknij pozycję Opcje folderów, a następnie kliknij kartę Widok.
  3. Przesuń widok do sekcji Ustawienia zaawansowane i usuń zaznaczenie opcji Użyj prostego udostępniania plików (zalecane).
  4. Kliknij przycisk OK.
  5. W oknie eksploratora Panelu sterowania kliknij pasek adresu, wpisz %ALLUSERSPROFILE%\Application Data, a następnie naciśnij klawisz Enter.
  6. Kliknij prawym przyciskiem myszy folder FLEXnet i wybierz opcję Właściwości.
  7. W sekcji Atrybuty usuń zaznaczenie opcji Tylko do odczytu.
  8. Kliknij przycisk Zastosuj, a następnie kliknij OK, aby zamknąć okno dialogowe Potwierdzanie zmiany atrybutów.
  9. Kliknij kartę Zabezpieczenia.
  10. Upewnij się, czy na liście znajdują się pozycje Administratorzy i System i czy w sekcji Uprawnienia jest zaznaczona opcja Pełna kontrola.
  11. Kliknij łącze Zaawansowane.
  12. Zaznacz opcję Zamień wpisy uprawnienia na wszystkich obiektach podrzędnych na wpisy tutaj pokazane, stosowane do obiektów podrzędnych.
  13. Kliknij kartę Właściciel.
  14. Wybierz opcję Administratorzy.
  15. Zaznacz opcję Zamień właściciela dla podkontenerów i obiektów.
  16. Kliknij przycisk OK, a następnie kliknij przycisk Tak w oknie dialogowym Zabezpieczenia.
  17. Kliknij przycisk OK, aby zamknąć okno dialogowe Właściwości folderu FLEXnet.
  18. Uruchom aplikację firmy Adobe.
 

W systemie Windows XP Home

  1. Uruchom system ponownie w trybie awaryjnym.
    1. Uruchom system Windows ponownie.
    2. Przed uruchomieniem systemu Windows naciśnij klawisz F8 (gdy wyświetli się komunikat, taki jak Zaawansowane opcje uruchamiania systemu).
    3. Z listy opcji uruchamiania wybierz Tryb awaryjny.

      • Jeśli Tryb awaryjny nie wyświetla się w każdym z rogów pulpitu, powtórz kroki od 1.1 do 1.3.
      • Jeśli Tryb awaryjny wyświetla się w każdym z rogów pulpitu, zaloguj się jako administrator komputera lokalnego.
    4. Jeśli wyświetli się okno dialogowe z komunikatem informującym, że system Windows działa w trybie awaryjnym, kliknij przycisk OK.
  2. Wybierz polecenia Start > Panel sterowania.
  3. Dwukrotnie kliknij pozycję Opcje folderów, a następnie kliknij kartę Widok.
  4. Przesuń widok do sekcji Ustawienia zaawansowane i usuń zaznaczenie opcji Użyj prostego udostępniania plików (zalecane).
  5. Kliknij przycisk OK.
  6. W oknie eksploratora Panelu sterowania kliknij pasek adresu, wpisz %ALLUSERSPROFILE%\Application Data, a następnie naciśnij klawisz Enter.
  7. Kliknij prawym przyciskiem myszy folder FLEXnet i wybierz opcję Właściwości.
  8. W sekcji Atrybuty usuń zaznaczenie opcji Tylko do odczytu.
  9. Kliknij przycisk Zastosuj, a następnie kliknij OK, aby zamknąć okno dialogowe Potwierdzanie zmiany atrybutów.
  10. Kliknij kartę Zabezpieczenia.
  11. Upewnij się, czy na liście znajdują się pozycje Administratorzy i System i czy w sekcji Uprawnienia jest zaznaczona opcja Pełna kontrola.
  12. Kliknij łącze Zaawansowane.
  13. Kliknij kartę Właściciel.
  14. Wybierz opcję Administratorzy.
  15. Zaznacz opcję Zamień właściciela dla podkontenerów i obiektów.
  16. Kliknij przycisk Zastosuj, a następnie wybierz kartę Uprawnienia.
  17. Zaznacz opcję Zamień wpisy uprawnienia na wszystkich obiektach podrzędnych na wpisy tutaj pokazane, stosowane do obiektów podrzędnych.
  18. Kliknij przycisk OK, a następnie kliknij przycisk Tak w oknie dialogowym Zabezpieczenia.
  19. Kliknij przycisk OK, aby zamknąć okno dialogowe Właściwości folderu FLEXnet.
  20. Uruchom aplikację firmy Adobe.
 

W systemie Windows 7 lub Windows Vista

  1. Wybierz polecenie Start > Komputer.
  2. Wybierz polecenie Organizuj > Opcje folderów i wyszukiwania, a następnie kliknij kartę Widok.
  3. Przesuń widok do sekcji Ustawienia zaawansowane i usuń zaznaczenie opcji Użyj Kreatora udostępniania (zalecane).
  4. Kliknij przycisk OK.
  5. W oknie eksploratora Komputera kliknij pasek adresu, wpisz%ALLUSERSPROFILE%, a następnie naciśnij klawisz Enter.
  6. Kliknij prawym przyciskiem myszy folder FLEXnet i wybierz opcję Właściwości.
  7. W sekcji Atrybuty usuń zaznaczenie opcji Tylko do odczytu.
  8. Kliknij przycisk Zastosuj, a następnie kliknij OK, aby zamknąć okno dialogowe Potwierdzanie zmiany atrybutów.
  9. Kliknij kartę Zabezpieczenia.
  10. Upewnij się, czy na liście znajdują się pozycje Administratorzy i System i czy w sekcji Uprawnienia jest zaznaczona opcja Pełna kontrola. Jeśli nie, wykonaj następujące czynności:
    1. Kliknij przycisk Edytuj.
    2. Jeśli wyświetli się monit o podniesienie uprawnień Kontrola konta użytkownika, wykonaj podane instrukcje, aby go zaakceptować.
    3. Wprowadź wymagane zmiany.
  11. Kliknij łącze Zaawansowane.
  12. Kliknij kartę Właściciel.
  13. Kliknij przycisk Edytuj. Jeśli wyświetli się monit o podniesienie uprawnień Kontrola konta użytkownika, zaakceptuj go.
  14. W sekcji Zmień właściciela kliknij opcję Administratorzy.
  15. Zaznacz opcję Zamień właściciela dla podkontenerów i obiektów.
  16. Kliknij przycisk Zastosuj, a następnie kliknij kartę Uprawnienia.
  17. Kliknij przycisk Edytuj. Jeśli wyświetli się monit o podniesienie uprawnień Kontrola konta użytkownika, zaakceptuj go.
  18. Zaznacz opcję Zamień wpisy uprawnienia na wszystkich obiektach podrzędnych na wpisy tutaj pokazane, stosowane do obiektów podrzędnych.
  19. Kliknij przycisk OK, a następnie kliknij przycisk Tak.
  20. Kliknij przycisk OK, a następnie kliknij przycisk OK w oknie dialogowym Zabezpieczenia systemu Windows.
  21. Kliknij przycisk OK, aby zamknąć okno dialogowe Zaawansowane ustawienia zabezpieczeń dla folderu FLEXnet.
  22. Kliknij przycisk OK, aby zamknąć okno dialogowe Właściwości folderu FLEXnet.
  23. Uruchom aplikację firmy Adobe.
 

Rozwiązanie 5: Wyzeruj uprawnienia dla folderu Adobe PCD. 

Wykonaj instrukcje opisane w rozwiązaniu 4, jednak zastosuj je dla następującego folderu:

C:/Program Files/Common FIles/Adobe PCD

Rozwiązanie 6: Usuń plik rejestrowania w dzienniku SQLite.

Plik rejestrowania w dzienniku istnieje tylko w specjalnych okolicznościach, gdy klient próbuje uzyskać dostęp do pliku bazy danych przy włączonych określonych opcjach. Jeśli plik nie istnieje, przejdź do następnego rozwiązania.

  1. W programie Eksplorator przejdź do lokalizacji \Program Files\Common Files\Adobe\Adobe PCD\cache.
  2. Jeśli plik cache.db-journal jest obecny, usuń go.
  3. Uruchom aplikację firmy Adobe.

Rozwiązanie 7: (wyłącznie dla systemu Vista) Zsynchronizuj zwirtualizowane i niezwirtualizowane pliki PCD i caps.

W przypadku, gdy zainstalowane są zarówno aplikacje rozpoznające system Vista, jak i aplikacje nie rozpoznające go, pliki w lokalizacji C:\Program Files mogą nie być zsynchronizowane z plikami w lokalizacji magazynu wirtualnego. Aby zsynchronizować foldery, wykonaj następujące czynności:

  1. Zamknij wszystkie aplikacje firmy Adobe.
  2. Z lokalizacji C:\Program Files (x86)\Common Files\Adobe skopiuj folder „Adobe PCD”.
  3. Wklej ten folder do lokalizacji C:\Użytkownicy\[nazwa użytkownika]\AppData\Local\VirtualStore\Program Files (x86)\Common Files\Adobe.
  4. W przypadku wyświetlenia monitu z pytaniem, czy chcesz zamienić/scalić istniejące pliki, wybierz opcję Tak. W kolejnym oknie dialogowym wybierz opcję Kopiuj i zamień dla wszystkich plików.
  5. Ponownie uruchom aplikację.
  6. Jeśli problem będzie nadal występował, wykonaj te same czynności dla folderu „caps”, znajdującego się w tej samej lokalizacji

Uwaga: W wyniku zastosowania tego rozwiązania w aplikacji, w której występuje problem, jak również w innych aplikacjach firmy Adobe może wyświetlić się monit o ponowne podanie numeru seryjnego.

Alternatywnie można usunąć foldery z magazynu wirtualnego lub zmienić ich nazwy i ponownie uruchomić aplikację:

  1. Zamknij wszystkie aplikacje firmy Adobe.
  2. Przejdź do lokalizacji C:\Użytkownicy\[nazwa użytkownika]\AppData\Local\VirtualStore\Program Files (x86)\Common Files\Adobe.
  3. Zmień nazwę folderu Adobe PCD na inną, na przykład AdobeoldPCD, lub usuń ten folder.
  4. Uruchom aplikację.
  5. Jeśli problem będzie nadal występował, wykonaj tę samą czynność dla folderu caps.

Jeśli powyższe rozwiązanie nie przyniesie efektu, usuń klucz rejestru magazynu wirtualnego/Adobe:

  1. Zamknij wszystkie aplikacje firmy Adobe.
  2. Zaloguj się w systemie Windows jako administrator.
  3. Wybierz polecenie Start > Wszystkie programy > Akcesoria > Uruchom i wpisz polecenie regedit.
  4. Kliknij przycisk Kontynuuj w oknie dialogowym Kontrola konta użytkownika.
  5. Wykonaj kopię rejestru, wybierając polecenie Plik > Eksportuj. Nadaj nazwę dla kopii zapasowej i zapisz ją w lokalizacji, którą łatwo zapamiętasz.
  6. Kliknij prawym przyciskiem myszy klucz HKEY_LOCAL_MACHINE > SOFTWARE > Classes > VirtualStore > MACHINE > SOFTWARE > Adobe
  7. Wybierz opcję Usuń. Zamknij rejestr.
  8. Uruchom aplikację.

Uwaga: W wyniku zastosowania tego rozwiązania w aplikacji, w której występuje problem, jak również w innych aplikacjach firmy Adobe może wyświetlić się monit o ponowne podanie numeru seryjnego.

Rozwiązanie 8: Zainstaluj ponownie.

OSTRZEŻENIE! Ten proces wymaga całkowitego odinstalowania i ponownego zainstalowania wszystkich programów marki Adobe CS3 i CS4, jak również programu Acrobat 8 i 9. W celu zainstalowania oprogramowania firmy Adobe należy mieć uprawnienia administratora. Zaloguj się na konto administratora, aby wykonać poniższe kroki. Dodatkowe informacje znajdują się w dokumentacji systemu operacyjnego.

  1. Wybierz polecenia Start > Panel sterowania.
  2. Dwukrotnie kliknij opcję Funkcje i programy (Windows 7/Vista) lub Dodaj lub usuń programy (XP).
  3. Wybierz z listy produkt firmy Adobe i kliknij polecenie Zmień/Usuń.
  4. Postępuj zgodnie z instrukcjami wyświetlanymi na ekranie, aby usunąć oprogramowanie.
  5. Powtórz kroki 3. i 4. dla pozostałych produktów Adobe CS3/CS4, Acrobat 8/9.
  6. Usuń następujące foldery:
    C:\Program Files\Common Files\Adobe\Adobe PCD
    C:\Program Files\Common Files\Adobe\caps
    C:\Program Files\Common Files\Adobe\backup

  7. Wybierz polecenie Start > Zamknij, wybierz polecenie Uruchom ponownie i kliknij przycisk OK.
  8. Zainstaluj produkty firmy Adobe z oryginalnych nośników.
  9. Uruchom zainstalowane produkty firmy Adobe.

Rozwiązanie 9: Skontaktuj z działem pomocy technicznej firmy Adobe.

Dział pomocy technicznej firmy Adobe może wykorzystać dzienniki z Twojego komputera, aby uzyskać dodatkowe informacje na temat awarii. Jeśli dostarczone informacje nie pomogły w rozwiązaniu problemu, skontaktuj się z działem pomocy technicznej firmy Adobe.

Dodatkowe informacje

Wiele problemów może wywoływać ten błąd, między innymi:

  • Jeśli błąd występuje bezpośrednio po instalacji, może to oznaczać, że komponent wymaga aktualizacji, aby był zgodny z systemem operacyjnym. Komponent może również wymagać nieco innej konfiguracji dla danego systemu operacyjnego.
  • Jeśli aplikacja co najmniej raz uruchomiła się bez problemu lub była intensywnie używana, problem może być związany z zasobami systemu. Przyczyną może być zbyt mała ilość pamięci, mała ilość miejsca na dysku lub jednoczesne uruchomienie kilku programów. W rezultacie może nastąpić tymczasowa awaria systemu licencji lub uszkodzenie stałych danych licencji.
  • Jeśli proces instalacji został zakłócony, system licencji może nie działać prawidłowo.
  • W przypadku wcześniejszego korzystania z przedpremierowej wersji programu istnieje możliwość, że w aplikacji jest zapisany tymczasowy numer seryjny, który już wygasł. W takim przypadku odwiedź stronę Błąd „Licencja dla tego produktu już wygasła” | CS4, CS5.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online