Issue

When we attempt to upgrade from CQ5.2.1 to CQ5.3 we get the following error:

12.02.2010 14:08:54 *ERROR* Importer: Error while committing /libs/collab: 
javax.jcr.nodetype.ConstraintViolationException: Unable to perform operation. 
Node is protected. (Importer.java, line 715)
12.02.2010 14:08:54 *ERROR* Importer: Error while committing /libs: 
javax.jcr.nodetype.ConstraintViolationException: Unable to perform operation. 
Node is protected. (Importer.java, line 715)
12.02.2010 14:08:54 *ERROR* Importer: Error while committing : 
javax.jcr.nodetype.ConstraintViolationException: Unable to perform operation. 
Node is protected. (Importer.java, line 715)

Resolution

Prior to starting the upgrade, remove the ACLs on nt:folder nodes. This can be done via CRX Explorer.

  1. Log into the /crx web application as admin
  2. Click CRX Explorer
  3. Open the CRX Query tool (click on the magnifying glass button at the top of the "CRX Explorer" window)
  4. Select xpath as the query type and replace the auto generated query in the bottom text box of the dialog with this query:
    //*[jcr:primaryType="nt:folder"]/rep:accessControl
  5. Execute the query
  6. Click on the each of the nodes in the query result and do the following:
    1. Go to Security >> -> ACL Editor...
    2. Remove any defined ACLs and save

Note: Any ACLs that you need for your application to work properly should be documented so they can be reapplied once the system is upgraded to 5.3. See this article [1] for more info on how ACLs work in CQ5.3/CRX2.0.

Applies to

CQ5.2.1 to CQ5.3 Upgrade

References

[1] CQ53ACLsMappingToCRX2

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online