Użytkownicy Ubuntu 10.x i 11.x Linux OS czasem widzą pusty i czarny ekran w aplikacji Flash Player 11 przy odtwarzaniu zabezpieczonych treści wideo. (Na przykład, problem ten występuje w serwisach takich jak Amazon Instant Video.) Takie zachowanie powoduje brakujący moduł Ubuntu HAL (warstwy abstrakcji sprzętowej), który nie jest instalowany domyślnie. Jeśli sprzedawca eksponuje komunikat o błędzie, użytkownicy widzą błąd DRM 3323 lub 3322.

Warunki wstępne do odtwarzania zabezpieczonych treści

W przypadku wersji Ubuntu 10.04 lub nowszej, należy sprawdzić, czy moduł HAL jest najpierw instalowany za pomocą apt-get.
(Należy zwracać szczególną uwagę na błędy instalacji modułu „hal”, ponieważ uszkodzony pakiet instalacyjny może mieć dalszy wpływ na odtwarzanie wideo.)

sudo apt-get instalacja hal

Po ukończeniu instalacji biblioteki „libhal” (HAL), zamknij przeglądarkę i wyczyść katalogi Adobe Access przez wykonanie następujących poleceń interpretera:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Uwaga:

Jeśli brakuje modułu warstwy abstrakcji sprzętowe (HAL), Flash Player dalej działa. Nie może jednak odtwarzać zabezpieczonych treści, które wymagają modułu Adobe Flash Access DRM (zarządzania praw cyfrowych).

Obsługa specjalnych wersji 64-bitowej Linux

Adobe publikuje obsługę platformy dla 32-bitowej i 64-bitowej wersji systemu Linux w sekcji wymagań systemowych witryny internetowej aplikacji Flash Player 11. Aktualnie obsługiwane pakiety dystrybucyjne (32-bitowa i 64-bitowa) to wersje Redhat Enterprise Linux 5,6 lub nowsza i Ubuntu 10.04 lub nowsze.

openSuse jest również obsługiwane.

Zainstaluj właściwą wtyczkę 32-bitową lub 64-bitową Flash Player

Przejdź na stronę http://www.adobe.com/go/pl/flashplayer, aby zainstalować najnowszą wtyczkę Flash Player dla danej platformy i architektury.

W przypadku braku pewności, który pakiet Linux zainstalować, kliknij Czy masz inny system operacyjny lub przeglądarkę? w celu uzyskania większej liczby możliwości wyboru.

openSuse i inne wersje Linux

Niektóre pakiety dystrybucyjne systemu Linux mają swój własny sposób zarządzania pakietami, między innymi openSUSE. openSUSE wykorzystuje RPM jako format pakietu natywnego. Ma on jednak swoje własne narzędzie wysokiego poziomu do zarządzania instalacją oprogramowania systemowego.
instalacje .rpm na systemie openSuse (wersje 32-bitowa i 64-bitowa) bywają kapryśne. Czasami generują one błąd ogólny „Brak odpowiedzi na komunikat (przekroczony czas oczekiwania magistrali komunikatów)".

W takich przypadkach, pobierz archiwum .tar.gz i umieść Flash Player (libflashplayer.so) w poniższej lokalizacji:

/usr/lib/adobe-flashplugin/libflashplayer.so

Wykonaj test odtwarzania treści wideo za pomocą odtwarzacza demo

  1. Uruchom zasobnik demo odtwarzacza wideo demonstracyjnego: http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html
     
    Zanotuj wersję Adobe Flash Player w dolnej lewej części powłoki wideo demonstaryjnego. Upewnij się, że wskazuje ona wersję 11.2 lub wyższą
  2. Odrwórz próbną treść zabezpieczoną.
     
      Wprowadź poniższy adres URL w polu „Wprowadź adres URL wideo: (rozpoznaje duże i małe litery)
      http://drmtest2.adobe.com:8080/Content/anonymous.f4v
       
  3. Kliknij przycisk [Odtwórz] wyświetlony u dołu zasobnika wideo.

Odtwarzana jest zabezpieczona treść anonymous.f4v. (To wideo nosi nazwę „pociąg” Getty.)

 

Dotyczy produktów

Adobe Flash Player 11, Flash Access (FAXS), Ubuntu 10.x & 11.x Linux

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online