W tym dokumencie opisano, jak zainstalować dodatkową wtyczkę OpenEXR Alpha oraz jak jej używać.

Dodatkowa wtyczka OpenEXR Alpha pozwala na alternatywną metodę obsługi danych kanału „A” podczas otwierania pliku OpenEXR. Zamiast bezpośrednio konwertować dane kanału „A” na przezroczystość (na co pozwala stara wtyczka OpenEXR), wtyczka OpenEXR Alpha otwiera dane kanału „A” jako kanał alfa.

Tło

Program Photoshop CS2 zasadniczo nie obsługiwał przezroczystości w trybie 32-bitowym. W tej wersji wprowadzono sposób obejścia problemu, który pozwalał na wczytywanie danych przezroczystości do kanału alfa. W programie Photoshop CS3 obsługa przezroczystości została wprowadzona dla trybu 32-bitowego, zapewniając zgodność ze specyfikacją OpenEXR. Przezroczystość nie była zatem już wczytywana do kanału alfa podczas składania prostych kanałów.

Zanim zaczniesz

Instalacja wtyczki OpenEXR Alpha wymaga praw administratora lokalnego. Jeśli używasz systemów Mac OS, Windows Vista lub Windows 7, system operacyjny wyświetla monit o wprowadzenie nazwy i hasła konta użytkownika administratora. Jeśli używasz systemu Windows XP, przed rozpoczęciem zaloguj się na komputerze przy użyciu konta administratora lokalnego.

Użytkownicy systemu Windows: W niektórych krokach tej uwagi TechNote wymieniono pliki, używając pełnych nazw plików, które obejmują rozszerzenia nazw plików (np. OpenEXR Alpha.8bi). W systemie Windows rozszerzenia nazw plików dla znanych typów plików nie są domyślnie widoczne. Aby rozszerzenia nazw plików były widoczne, wykonaj następujące czynności:

  1. W Eksploratorze Windows wybierz kolejno opcje Narzędzia > Opcje folderów (Windows XP) lub Organizuj > Opcje folderów i wyszukiwania (Windows 7 i Vista).
  2. Wybierz kartę Widok w górnej części okna Opcje folderów.
  3. W obszarze Ustawienia zaawansowane na karcie Widok usuń zaznaczenie opcji Ukryj rozszerzenia znanych typów plików.
  4. Kliknij przycisk OK.

Użytkownicy systemu Windows: Niektóre kroki opisane w tym dokumencie wymagają ustalenia, czy używana jest 32-bitowa czy 64-bitowa wersja systemu Windows. Aby ustalić, który typ systemu posiadasz, zobacz temat Określanie, czy na komputerze zainstalowano 32- czy 64-bitową wersję systemu Windows.

Zgodność

W systemie Windows wtyczka OpenEXR Alpha nie jest zgodna z wersjami programu Photoshop wcześniejszymi niż Photoshop CS5. Nie można jej załadować w wersji Photoshop CS3 ani CS4.

W systemie Mac OS wtyczki OpenEXR Alpha nie można załadować na urządzeniach PPC.

Zainstaluj wtyczkę OpenEXR Alpha dla programu Photoshop CS5 w systemie Mac lub Windows (pobierz aktualizację z witryny firmy Adobe)

Aby zainstalować wtyczkę OpenEXR Alpha przez pobranie aktualizacji z witryny firmy Adobe:

  1. Pobierz spakowaną wtyczkę:

  2. Zakończ program Photoshop CS5.
  3. Rozpakuj pobrany plik.
  4. Przeciągnij wtyczkę do folderu Wtyczki w programie Photoshop.
    • Windows w wersji 32-bitowej: Przeciągnij wtyczkę OpenEXR Alpha.8bi z folderu Win32 do folderu /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows w wersji 64-bitowej/Photoshop w wersji 64-bitowej: Przeciągnij wtyczkę OpenEXR Alpha.8bi z folderu Win64 do folderu /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows w wersji 64-bitowej/Photoshop w wersji 32-bitowej: Przeciągnij wtyczkę OpenEXR Alpha.8bi z folderu Win32 do folderu /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Mac OS: Przeciągnij wtyczkę OpenEXR.plugin do folderu /Applications/Adobe Photoshop CS5/Plug-ins/File Formats.
  5. Uruchom program Photoshop CS5.

Użyj wtyczki OpenEXR Alpha

Aby otworzyć plik EXR:

  1. Uruchom program Photoshop CS5.
  2. Wybierz kolejno opcje Plik > Otwórz.
  3. Przeglądaj do pliku EXR, który chcesz otworzyć. Na liście formatów plików wybierz pozycję OpenEXR Alpha. Program Photoshop traktuje dane kanału „A” jako kanał alfa, a nie przezroczystość.

Aby eksportować plik EXR:

  1. Wybierz polecenie Plik > Zapisz jako.
  2. Na liście formatów plików wybierz pozycję OpenEXR Alpha.

  3. Wybierz opcję Zapisz: Alpha Channels. To ustawienie zachowuje dane kanału alfa.

Uwaga: Przezroczystość dodana po otwarciu pliku jest spłaszczona.

Uwaga: Nawet po zainstalowaniu wtyczki OpenEXR Alpha masz nadal możliwość wybrania starej wtyczki OpenEXR z listy formatów plików. Ta wtyczka nadal obsługuje dane w kanale „A” jako przezroczystość. Takie zachowanie jest domyślne w programie Photoshop od wersji Photoshop CS3 (10.0).

Dodatkowe uwagi

Inne godne uwagi zachowania w przypadku korzystania z dodatkowej wtyczki:

  • Składanie wstępnie pomnożone nie jest obsługiwane.
  • Po dwukrotnym kliknięciu pliku, aby go otworzyć, program Photoshop CS5 zawsze używa wtyczki OpenEXR Alpha, a nie OpenEXR.
  • Jeśli otworzysz plik z co najmniej dwoma kanałami alfa, wtyczka OpenEXR Alpha nie zachowa żadnych kanałów alfa. Zostaną one całkowicie usunięte.
  • (Mac OS): W oknie dialogowym Zapisz pozycja OpenEXR Alpha znajduje się na samej górze. Nie jest wyświetlana zgodnie z porządkiem alfabetycznym obok pozycji Open EXR.
  • (Windows): Aby korzystać ze starego zachowania wtyczki OpenEXR, wybierz kolejno opcje Plik > Otwórz jako, a następnie wybierz pozycję OpenEXR.
     

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online