Learn how to export Projects from Final Cut Pro, and bring your edit into Adobe Premiere Pro CC.

Export Events from FCPX

What you learned: How to Export XML (Extensible Markup Language) Files to migrate FCPX events, projects, and clips to Adobe Premiere Pro.

  • Select Event for Export.
  • Go to the File Menu and choose Export XML.
  • Create an FCP XML Export Folder.
  • Name and Save the .fcpxml file to FCP Exports folder.
  • Premiere does not read .fcpxml files from FCPX, but it does read .xml files from FCP7.
  • Use a third-party application, such as Intelligent Assistance XtoC (Project X27), to translate the exported .fcpxml into a .xml file, for import into Premiere Pro.

Import XML into Adobe Premiere Pro

What you learned: How to import XML files into Adobe Premiere Pro.

  • Create a new project in Adobe Premiere Pro.
  • Go to File > Import and select the exported XML file.
  • The Project (Sequence), Bins, and all associated clips appear in a single Bin in the Project Panel.
  • Move the Sequence into its own Bin, and move the Bins to the main project level.
  • Sequence Clips will link to clips inside the Bin created on Import.
  • Bins contain Master Clips and media as originally organized in FCPX.

Migration Results

  • Bin Hierarchy is preserved when migrating collected clips and events from FCPX to Premiere Pro.
  • Many effects migrate from FCPX to Premiere Pro, including dissolves and wipes, motion effects, titles, speed variations, audio keyframes and levels.
  • Alpha Channels from FCP footage migrate.
  • Multicam footage, if not flattened in FCPX, becomes a Multicam Sequence in Premiere Pro if it contains 4 or fewer camera angles.
  • If a FCPX Multiclip was flattened in the FCPX Timeline, camera angles will appear as individual clips on separate tracks, synched in the newly created Premiere Pro Sequence.
     

Export XML from FCP7

What you learned: How to Export XML (Extensible Markup Language) files to migrate FCP7 Sequences, Bins and Clips to Adobe Premiere Pro.

  • To Export the entire Project, Click in the Project Tab and go to Edit Menu > Deselect All. If individual items are selected in the Project tab, those will be the only files that migrate.
  • Go to the File Menu and choose Export > XML.
  • Create an FCP XML Export Folder, then Name and Save the .fcpxml file to this folder.
  • Premiere can import .xml files directly from FCP7.

Import XML into Adobe Premiere Pro

What you learned: How to import XML files into Adobe Premiere Pro.

  • Create a new project in Adobe Premiere Pro.
  • Go to File > Import and select the exported XML file.
  • A Bin appears inside the Project Panel. It contains the Sequence, Bins, and all associated clips.
  • Sequence clips are connected to the master clips inside the Bin created on Import.

Migration Results

  • Bin Hierarchy is preserved when migrating projects from FCP7 to Premiere Pro.
  • Many effects migrate from FCP7 to Premiere Pro, including motion effects, titles, some keyframes, dissolves, wipes, composite blend modes, speed variations, audio keyframes, and levels.
     

See Importing XML project files from Final Cut Pro and Final Cut Pro X for more information on how to import projects, selected clips, or selected sequences, into Premiere Pro.

04/04/2018

Contributor: Christine Steele

Was this page helpful?