creativecloud

Update to Premiere Pro CC available

For more information, see the New features summary.


Premiere Pro CC 2014.2 release | December 2014

GoPro CineForm codec support enhancements

(Windows) Support for QuickTime preview  

Premiere Pro provides full smart rendering support for GoPro CineForm files on Windows. You can now preview CineForm files in QuickTime format.

  1. In the New Sequence or Sequence Settings dialog, select Editing Mode as Custom.
  2. Select Preview File Format as QuickTime
  3. Select Codec as GoPro CineForm.
  4. (Optional) Save a preset for each combination of height-and-width and frame rate that you commonly use.

GoPro CineForm export enhancements

Earlier, there was a mismatch between the preset labels in the Export Settings dialog and the applied encoding. This issue is now corrected.

You can choose between 10-bpc YUV and 12-bpc RGBA presets, and the GoPro CineForm encoder resamples the frames to 10-bit YUV or 12-bit RGBA as appropriate. In addition, 10-bit YUV import support is also added.

For more information, see GoPro CineForm codec support.

Removal of Speech Analysis

Starting with the December 2014 release of Premiere Pro CC, the Speech-to-Text feature or Speech Analysis functionality is removed from Premiere Pro CC.

You can, however, continue to view the speech-to-text metadata for any clips that were previously analyzed using earlier versions of Premiere Pro CC.

For detailed information, see Speech analysis.

Other enhancements

Support for ARRI Open Gate media

Premiere Pro now supports importing ARRI Open Gate clips like any other clips.

Updates to Preferences

When you add still images, or audio, video transitions, you can assign a default duration to it. Premiere Pro now lets you specify the default duration either as number of frames or time in seconds.

Select the General category in the Preferences dialog to set these preferences.

For more information, see Preferences.

Improved scrubbing and shuttling in long GOP MXF files

When you scrub long GOP footage manually at speeds faster than 1x, or use J-K-L scrubbing at 8x, 16x, or 32x speeds, the sequence of frames are displayed at a smoother rate.

For a list of notable bugs fixed in the December 2014 release of Premiere Pro CC, see this blog post.

Premiere Pro CC 2014.1 release | October 2014

Updated user interface with HiDPI support

The October 2014 release of Premiere Pro CC welcomes you with a noticeably cleaner and modernized user interface. The user interface provides HiDPI support for Apple's Retina displays and Windows 8.1 displays.

 

Refreshed user interface
Refreshed user interface with cleaner, flatter design and HiDPI support

Modernized user interface

The modernized user interface provides cleaner visuals that let you focus more on the content. Apart from the visual enhancements, there are subtle but effective enhancements to the overall user experience.

When you select a user interface element, the selected element appears with a blue outline indicating its active state. When deselected, it appears in gray. This high contrast helps you easily distinguish between selected and deselected elements.

For a comfortable viewing experience, you can vary the brightness of the user interface from a darker to a lighter tone by using the Appearance preference option.

HiDPI support

With HiDPI support, Premiere Pro provides a higher resolution user interface that displays text, icons, and other user interface elements in greater clarity.

You can notice an optimal display clarity under various scaling factors. At a 100% scaling, the application displays more real estate for viewing, which means many more panels can be viewed at once. When you change the scaling, the user interface elements scale optimally and continue to appear sharp and clear.

Usability enhancements

The usability enhancements in Premiere Pro let you achieve editorial tasks with fewer clicks.

Menu items for a monitor or panel that were available from the pop-up menu are now grouped together and available under Settings. Or some of the menu items are available from the panel menu.

  • To access Settings, click the wrench icon in the Timeline header, Source Monitor, or Program Monitor panels to display all the available menu items.
  • To open a panel menu, right-click (Win) or Ctrl-click (Mac) a panel.

To make it easier to work with multiple open panels, a panel's Close button X is removed. To close a panel, you now right-click (Win) or Ctrl-click a panel header, and select Close Panel.  

Accessibility on touch devices

The 2014.1 release of Premiere Pro CC marks an important step in making Premiere Pro accessible on touch devices, including support for HiDPI Windows 8.1 displays.


Powerful search enhancements

New Search Bins

Premiere Pro introduces Search Bins that let you find, organize, and sort media based on metadata.

When you search for items in a Project Panel, you can now save the results as a Search Bin. Once you create Search Bins, they update automatically as relevant content gets added to the project. Search Bins display aliases of the original project items and not copied media, so no media duplication occurs.

For more information, see Find assets using Search Bins.

Advanced Timeline search

You can now manage complex Timelines more easily in Premiere Pro.

With the Timeline panel active, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Win)/ Cmd+F (Mac) to open the Find dialog.

Using the Find dialog, you can find and select clips within a sequence. You can find clips based on a single property, like clip name or label color, or use a combination of properties. Timeline Search also lets you find sequence markers in a Timeline.

For more information, see Find assets using Timeline Search.

Enhanced media management

Consolidate and transcode projects using the redesigned Project Manager

Premiere Pro's redesigned Project Manager lets you manage your media more efficiently. You can move, consolidate, and archive your projects in just a few clicks.

Using the new Project Manager, you can move files and sequences to a new destination based on user-defined options.

You can also render and transcode files in mixed formats into a single codec that you can archive, or share with other teams and systems. At any point, you can re-edit the transcoded projects in Premiere Pro.

For more information, see Copy, transcode, or archive your project.

Multi-project workflows

Editors often access multiple projects at the same time to import and edit media simultaneously. Premiere Pro introduces a new multi-project workflow that lets you browse media and sequences from other projects and import them directly in your current project.

You can edit or reuse clips, cuts, and transitions from previous projects and edit directly in your current project. For example, you can open and edit a Premiere Pro project and an After Effects project simultaneously in the same workspace.

Select New Media Browser Panel from the Media Browser's pop-up menu to browse other projects in as many Media Browser panels as needed. Like any other panel in Premiere Pro, the multiple Media Browser panels can be left open or docked.

For more information, see this video tutorial.

Render and replace

Premiere Pro lets you speed up playback of VFX-heavy sequences by rendering embedded video clips, including After Effects compositions, into flattened video clips.  

At any point, if you want to change the original media, you can restore the unrendered clip using the Restore Unrendered option.

For more information, see Render and Replace media.

Note:

The new Render and Replace feature replaces the earlier available Render And Replace for audio option (Clip > Audio Options > Render And Replace).

Source Monitor Timeline view

Premiere Pro lets you open and view sequences from an unopened project without importing the sequence into your current project.

Using the Media Browser, navigate to the project containing the sequence, and double-click the sequence to open.

The new Source Monitor Timeline view opens a second Timeline that displays the contents of the sequence in read-only mode. This second Timeline makes it easy to edit or reuse existing clips, cuts, and transitions from different projects.  

GoPro CineForm codec support

Premiere Pro lets you decode and encode QuickTime files using the GoPro CineForm codec on both Mac OS X and Windows systems.

Note:

Mac OS X users need to install QuickTime 7 or later to play back CineForm files outside Adobe's digital video applications. You can download QuickTime from Apple's Support website.

The GoPro CineForm codec is a cross-platform intermediate codec well-suited to edit high-resolution footage, and is optimized for better image quality and smoother playback.

In the Export Settings dialog box, select QuickTime as the Export Settings format, and GoPro CineForm as the video codec. Movie files encoded with the GoPro CineForm codec let you include an alpha channel. Select a 32-bit or 64-bit depth to support alpha channels.

For more information, see GoPro CineForm codec support.

GoPro CineForm is an ideal choice as a digital intermediate to convert various formats into a GoPro CineForm file for easy archival. Premiere Pro lets you do that easily by using the Consolidate and Transcode feature.

For more information, see Copy, transcode, or archive projects.

 

Masking and Tracking refinements

The new refinements in Masking and Tracking provide you a new free-draw polygon Pen tool that lets you create complex mask shapes.

You can convert any mask control point into a Bezier control point in a single click, and the Bezier handles let you create smoother, precise curves.

In addition, there are new masking controls that let you adjust feathering and expansion directly on the Program Monitor.

For more information, see Masking and Tracking.

Improved Master Clip effects

A new indicator in the Timeline lets you tell at a glance which sequence clips have master clip effects applied. A clip that has a Master Clip effect applied displays a red line under the FX badge.

In addition, the Effect Controls panel now has two tabs to toggle between a master clip and its child sequence clips.

Red underlined FX badge
Red underlined FX badge indicates Master Clip effect applied to the clip

For more information, see Master Clip Effects.

Editing experience enhancements

Automatically update label color and clip name changes

Premiere Pro now provides an option in the Project Settings dialog that lets you keep all instances of your project items in sync automatically.

Select File > Project Settings General to open the Project Settings dialog. In the Project Settings dialog, select Display The Project Items Name And Label Color For All Instances.

When you select this option, any changes made to a clip in the Project panel ripple to all instances used in sequences. For example, when you change the name of a sequence clip, it ripples up to the master clip and then down to all other sequence clips.  

Improved media management for Edit in Audition workflow

When you send a clip for audio editing in Audition by selecting Edit > Edit in Adobe Audition > Clip, the rendered copy of the clip is automatically saved alongside the original media file on disk. Storing the rendered media files along with the original files makes media management easier.

Option to suppress End Of Sequence indicator

The End Of Sequence Indicator, a purple colored band that appears along the right edge of the last frame of a clip or sequence, is now turned off by default.

Overlay Settings control the End Of Sequence indicator. Because Overlay Settings are turned off by default, the End Of Sequence indicator is also turned off.  

To view overlays but suppress the End of Sequence indicator, deselect End Of Media/Sequence Indicators in the Overlay Settings dialog.

For more information, see Monitor Overlays.

Audio-only clips displayed in SMPTE in monitor overlays

Previously, audio-only clips without embedded timecode were displayed as samples in monitor overlays. Now, when you set your monitor to display in Source Timecode setting, audio-only clips are also displayed in SMPTE.

Sequence Timecode overlay

The overlays in the Source and Program Monitors now have a new option to display sequence timecode.

For more information, see Monitor Overlays.

Assignable marker colors

Marker options
Marker options

Premiere Pro offers markers in eight different colors with green as the default.

Use the Marker dialog box to assign or change the color of a marker. Double-click the marker icon in the Program Monitor, or press M on the keyboard, to open the Marker dialog box.

You can also create markers with specific colors by assigning default keyboard shortcuts. For more information, see Changes to keyboard shortcuts.

Alignment options for Clip Name effect

The Clip Name effect provides alignment options to position text. You can apply Left, Center, or Right alignment.  

Easy identification of clips within In/Out range in Timeline

Clips appearing within an In/Out range on targeted tracks appear brighter than clips outside the In/Out range or within empty, untargeted tracks.

Disable writing clip markers to XMP

A new preference option Write Clip Markers To XMP lets you enable or disable the writing of clip markers to the XMP metadata file. This preference is enabled by default. Select Edit > Preferences> Media to deselect the preference.

Tip: Deselect this preference when you transfer projects from one computer to another. Then, clip markers are written to the project file instead of the media file's XMP. Doing so helps you retain clip markers in the transferred project without transferring the associated media.

Field information in Project panel metadata column

Premiere Pro lets you display a new column of metadata, Field Order, in the Project panel.

The Field Order column does not appear by default. To display this column, open the Metadata Display dialog by selecting Metadata Display from the Project panel menu. Then, select the check box next to Field Order.

Change the font size of the Project panel

To change the font size of the Project panel, right-click (Win) or Ctrl-click the panel. Then, select Font Size from the panel's pop-up menu, and choose an appropriate font size.

Move or delete multiple sequence markers at once

Premiere Pro lets you select multiple sequence markers at once by pressing shift and clicking the marker icons. You can then move or delete the selected markers as required.

Handling unsupported XMP metadata

Certain file formats do not support writing XMP metadata directly into media files.

When a media type does not support writing XMP, Premiere Pro generates a generic sidecar file and saves it alongside the original media file.

5.1 audio channel layout changes

The 5.1 audio channel layout in Premiere Pro is changed to L, R, C, LFE, Ls, Rs channels format to comply with multi-channel sound recordings standard.

New multichannel option for QuickTime exports  

When exporting media in QuickTime format, in the Audio section of the Export Settings dialog, there is a new Discrete option under Channel Layout.

You now have the option of specifying individual channels as Discrete or Mono.

Increased maximum limit for Motion Scale parameter

In the Effects Control Panel, under Motion video effects, the limit for the Scale parameter is increased to 10,000%. The maximum limit earlier was 600%.

New video codec column in Project panel

A new Video Codec column in the project panel displays the video codec for each asset.

The Video Codec column is not displayed in the Project panel by default. To display this column, select Metadata Display in the Project panel's pop-up menu. Then, select Video Codec under Premiere Pro Project Metadata.

Clip Name and Timecode effect track options

For Clip Name effect and Timecode effect, you can display information for clips on specified source tracks. This feature is especially useful for an adjustment layer.

In the Effects Control panel, use the Source Track pop-up menu to select the source track.


Other enhancements

GPU-based debayering for several raw file formats

Premiere Pro now offers GPU-based debayering for AJA RAW, Canon RAW, and Phantom Cine, as well as RED and Cinema DNG footage.

These raw clips can use the GPU (OpenCL and CUDA) for an improved and faster playback performance. For Phantom Cine files, Premiere Pro also applies white balance, color matrix, gamma, and gain using the camera values stored in the video file.

Improved AAF export to DAWs

Premiere Pro now provides an improved AAF exporter that facilitates smoother workflows between Premiere Pro and DAW (Digital Audio Workstation) systems.

Premiere Pro supports reading and modifying audio files with iXML metadata.

iXML metadata is typically captured by audio recording devices or on-location audio recording software such as Metacorder for Mac. An important feature of iXML metadata is the ability to select and mark the best takes, and record on-set notes.

Support for iXML audio workflows

Note:

iXML is an open standard for location sound metadata. iXML supports data such as Project name, Scene, Take, Tape, and Timecode data, as well as custom comments.

Changes to keyboard shortcuts

The Keyboard Shortcuts dialog in Premiere Pro offers a new Copy To Clipboard feature.

Using this feature, you can copy to clipboard the complete list of available commands, along with the assigned shortcuts.

  1. In Premiere Pro, open the Keyboard Shortcuts dialog.
  2. Click Copy To Clipboard.
  3. Paste into a text editor.

New shortcut commands

You can set default shortcuts for the following commands in the Keyboard Shortcuts dialog.

  • Set Marker Color 1
  • Set Marker Color 2
  • Set Marker Color 3
  • Set Marker Color 4
  • Set Marker Color 5
  • Set Marker Color 6
  • Set Marker Color 7 
  • Set Marker Color 8
  • Join All Through Edits  

 

Premiere Pro CC 2014.0.1 update | July 2014

Editing experience enhancements

The July 2014 update of Premiere Pro CC provides important fixes and enhancements to the editing experience.

  • Premiere Pro now displays a new Codec column in the Project panel.
  • Sequence Timecode is added as a display option in the Monitor Overlays dialog.
  • You can set Clip name and Timecode filters to reference and display information for clips on specified source tracks.

For complete information on the bug fixes and enhancements in this update, see the Adobe Premiere Pro weblog.

Premiere Pro CC 2014 release | June 2014

Masking and Tracking

Masks let you target specific areas in a clip to which you want to apply effects or color corrections. You can define a specific area in an image that you want to blur, cover, or highlight.  

One of the common uses of masking is to blur a person's face to protect their identity. For example, you can mask a person's face by applying a Blur effect or a Mosaic effect.

You can also use masking in more creative ways like applying a mask to correct a specific color. Or you can use an inverse mask selection to exclude the masked area from color corrections applied to the rest of the clip.

In addition, you can add multiple shape masks with different effects to different areas of a clip.

Premiere Pro lets you animate and track the mask shapes. That is, the mask can automatically track the movement of the masked object as the object moves. For example, after you blur a person's face, the mask can automatically track the movement of the face from frame to frame as the person moves.

For more information, see Masking and Tracking in Premiere Pro.

Live Text templates

Live Text templates let you edit textual content in animated titles and lower-third graphics quickly and easily.

You can edit text layers in an After Effects composition directly in Premiere Pro without having to return to After Effects.  Any changes you make to the text layers in the composition does not alter the imagery or graphics surrounding the text.

In addition, any changes you make to the Live Text template file are propagated to all the projects and sequences in Premiere Pro that use that project.

For more information, see Live Text templates in Premiere Pro.

Master Clip Effects

When you apply effects to a master clip in Premiere Pro, the effects automatically ripple down to all portions of the master clips used in sequences.

When you apply an effect or a LUT to a master clip, the effect or color change is automatically applied to each instance of the master clip edited into a sequence. In addition, any subsequent adjustments you make to the effect also automatically ripple through to all sequence clips.  

You can apply effects to a master clip by dragging an effect from the Effects panel to the master clip. To view or adjust the master clip effect from a sequence clip, use the Match Frame feature to load the master clip for that sequence into the Source monitor. Then, adjust any applied effects from the Effects Control panel.

For more information, see Master Clip Effects.

Support for fonts from Typekit

You can choose from thousands of fonts from Typekit available within Premiere Pro.

When you sync fonts from Typekit to your desktop through the Creative Cloud application, the fonts from Typekit appear alongside locally installed fonts.

  1. In Premiere pro, select Title > Add Fonts From Typekit.
  2. Browse through the fonts and download the required fonts.
  3. Quit and relaunch Premiere Pro. 

When you open the Titler, the fonts from Typekit appear alongside other locally installed fonts.

For more information on using fonts from Typekit with Creative Cloud, see Typekit Help Center.

Sync settings and file management

Auto-save projects to Creative Cloud

Your Adobe Creative Cloud account comes with online storage that makes your files available to you anywhere and on any device or computer.

Premiere Pro lets you auto-save your projects directly to your Creative Cloud-based storage, letting you save backups of your projects to a secure and accessible storage environment.

Choose Auto Save in the Preferences dialog, and select Save Backup Project To Creative Cloud.

When Premiere Pro auto-saves a project, a directory named "auto-save" is created in your Creative Cloud online storage. All the backed-up projects are stored in the "auto-save" directory.

You can access your backed-up projects from the Files tab of your Creative Cloud desktop application. Or you can access the files from your Creative Cloud account on the Web.

Migration of Sync Settings with version upgrade

Each major version of Premiere Pro CC has its own copy of settings files. For example, Premiere Pro CC 7.x uses a "7.0" directory to store the settings file while the 2014 version of Premiere Pro CC uses a "8.0" directory.

When you upgrade to the 2014 version from a 7.x version of Premiere Pro CC, your sync settings are migrated automatically to the new version.

Select Sync Settings or Use Settings From A Different Account from the Welcome screen or the File > Sync Settings menu. All the settings files from the "7.0" directory are automatically copied to the "8.0" directory.

Important notes:

  • The "8.0" directory is created on the Creative Cloud server only after you sync settings for the first time.  When you sync settings for the first time, you may notice a delay in syncing because all the settings from the “7.0’ directory are copied to the “8.0” directory. 
  • Before you customize any local settings like adding new keyboard shortcuts or workspaces, sync your settings at least once on one of your computers. Doing so ensures that you don’t lose any changes to your settings during auto-migration of settings from the previous version.

For more information on using Sync Settings in Creative Cloud, see Sync Settings.

Editing experience enhancements

Reverse match frame

You can find a frame loaded in the Source monitor and match it in the Timeline using the Reverse Match Frame command.

To use Reverse Match Frame, follow these steps:

  1. Ensure that you have a clip loaded in the Source monitor.
  2. In the Source Monitor, place the playhead on the frame that you want to find in the Timeline.
  3. Select Sequence > Reverse Time Frame, or use the keyboard shortcut Shift+R. Premiere Pro moves the playhead on the Timeline to that exact frame.

Double-click sequence clip to load Source monitor with matching frame

Double-click a sequence clip in the Timeline to load that clip in the Source monitor with the matching frame to where the playhead is placed over the Timeline.

Note:

If the playhead is not placed on any frame of that clip, the playhead in the Source monitor moves to the first frame of that sequence clip.

Manually sync offsets

You can fix out-of-sync clips by manually moving tracks in the Timeline. When you drag the synced clip back into the Project panel, a new project item is created. The new project item retains the applied offset, so that the sync is already applied the next time you use the new clip.

A new Sync Offset column in the project panel displays the applied offset.

Note:

The Sync Offset column is not displayed in the Project panel by default. To display this column, select Metadata Display in the Project panel's pop-up menu. Then, select Sync Offset under Premiere Pro Project Metadata.

This feature is useful for a clip that requires an offset and needs to be used multiple times. You don't have to sync tracks every time you place the clip on the Timeline. You can fix the offset once and create a new clip project item that retains the offset. You can then use the new clip multiple times without syncing tracks each time.

Assign multiple keyboard shortcuts to a command

You can assign multiple keyboard shortcuts for a single command.

The Keyboard Shortcuts dialog displays the keyboard shortcut as an editable button, which lets you easily change, add, or delete shortcuts.

To add shortcuts to a command, click to the right of an existing shortcut. If there is no existing shortcut, click anywhere in the Shortcut column. A new shortcut button is created in which you can type the shortcut.

Assign keyboard shortcuts
Assign keyboard shortcuts


For detailed information about adding and editing multiple keyboard shortcuts, see Keyboard shortcuts in Premiere Pro CC.

Set To Frame Size command

Use the Set To Frame Size command to scale an image to the sequence frame size without rasterizing the image. When you use this command, the native pixel resolution is preserved, letting you see the sharpest resolution when you zoom in on an image.

  1. Right-click (Windows), or Control-click (Mac OS) an asset in a Timeline.
  2. Select Set To Frame Size.

When you select the Set To Frame Size command, the Scale To Frame Size setting is toggled off for improved playback performance.

Transparent background grid

The Source and Program Monitors can display a checkerboard grid that identifies transparency in a layer.

The checkerboard pattern appears behind the video’s alpha channel, or if a clip is scaled smaller than the frame size.

To show or hide the transparency grid, click the Wrench icon to open the monitor's Settings menu, and select Transparency Grid.

Export command added to Project panel's context menu

In the Project panel, you can export a clip by using the context menu command. Right-click (Win) or Ctrl-click (Mac) the clip to export and select  Export Media from the context menu. This command is in addition to the File > Export > Media command.

Turn off FX badges

FX Badges now appear to the left of a clip in the Timeline, and can be turned off if necessary.

Click the Wrench icon in the Timeline header to open Timeline Display Settings. Deselect Show FX Badges to turn off FX Badges.

Preference to specify number of frames to move playhead

In previous versions of Premiere Pro, using the keyboard shortcut Shift+Left or Right arrow, moved the playhead by a fixed number of five frames.

Premiere Pro now provides a preference that lets you control the number of frames to move. In the Preferences dialog, select the Playback pane, and enter the number of frames for Step Forward/Back Many. The default is set to ten frames.

Track Selection Backward tool

Premiere Pro provides a Track Selection Backward Tool, available from the Tools panel. Use this tool to select all the clips to the left of the cursor in a sequence.

The Track Selection Tool from earlier versions is now renamed to Track Selection Forward Tool. While the name has changed, the function of this tool remains the same of selecting all clips to the right of the cursor in a sequence.

Track Selection Forward and Backward tools
Track Selection Forward and Backward tools

A. Track Selection Forward Tool B. Track Selection Backward Tool 

Adding Marker names

You can specify a name for a marker directly in the Markers panel or in the Marker dialog.

Editing markers
Editing markers


Enhanced media management

Flexibility in importing projects

Premiere Pro CC provides you greater flexibility around how media is referenced when importing a project. You can choose to place the imported project in a new directory or allow importing duplicate media.

When you import media into a project, Premiere Pro imports and places the media directly at the root level by default. The imported media clips intermingle with any existing clips.

To let Premiere Pro place the imported media into a separate folder, select Create Folder For Imported Items in the Import dialog. The folder is created at the project root level.

When importing media into a project, Premiere Pro checks to see if the master clip in the project references any of the imported media files. If so, Premiere Pro consolidates the imported media into the existing master clip by default. Any unique metadata in the imported media is lost. To prevent this occurrence, select Allow Importing Duplicate Media. Premiere Pro then allows importing duplicate instances of media, preserving the project metadata.

Import Project dialog
Import Project dialog

Bin structure preserved on folder import

When you import folders containing subfolders into your project, Premiere Pro creates bins and organizes the files in the same hierarchy as on your hard disk.

If you import a folder containing a single file, the file in moved into a folder in the next higher level of hierarchy. You cannot import a folder with no files.

Make sequences offline  

You can now quickly make sequences go offline by using the Make Offline context menu command. In the Timeline or Project Panel, right-click (Win) or Ctrl-click (Mac) the sequence that you want to make offline, and select Make Offline from the context menu.

Support for browsing After Effects projects in the Media Browser

You can now use the Media Browser to browse After Effects projects. You can also preview effects compositions in an After Effects project using the Media Browser.

Media Browser favorites

You can quickly add your favorite or most often used folder to your favorites list in the Media Browser. In the Media Browser, right-click the folder that you want to add, and select Add to Favorites.

Audio-related enhancements

Maintain audio pitch during scrubbing and playback

Premiere Pro provides a new preference that lets you maintain the audio pitch during scrubbing and playback while using the J,K,L keys.

In the Preferences dialog, select the Audio pane, and select Maintain Pitch While Shuttling.

Selecting this preference helps improve the clarity of speech when playback is at a higher or slower than normal speed.

Preferences dialog
Preferences dialog

Voice-over recording enhancements

You can now access voice-over record settings directly from the Timeline by selecting Voice-Over Record Settings from the context menu.

Choosing voice-over recording settings
Access voice-over settings from Timeline

You can specify the duration of the pre-roll and post-roll countdown. Select the Countdown Sound Cues check box to play a beep to indicate the status of recording. These beeps are not recorded in the voice-over.

Cross-platform support for video effects and transitions

To provide consistent support for effects and transitions across platforms, Premiere Pro supports the same effects and transitions on both Windows and Mac platforms.

Given this focus, some effects have been deprecated, and others have been ported to make them available across platforms.

Deprecated effects do not appear in the Effects panel, and cannot be applied in this version of Premiere Pro. However, if you open a project created in an older version of Premiere Pro with deprecated effects, you can still see the deprecated effects. When you select a clip with the deprecated effect in the Timeline, the Effects Control panel shows the effect with fully functional controls to adjust the effects.

Deprecated video effects  

Blur & Sharpen

Antialias

Ghosting

Distort

Bend


Keying

Blue Screen Key

Chroma Key

RGB Difference Key

Transform

Camera View

Horizontal Hold

Vertical Hold



Deprecated video transitions  

Page Peel

Center Peel

Peel Back

Roll Away

Zoom

Zoom

Zoom Boxes

Zoom Trails

Iris

Iris Points

Iris Shapes

Iris Star

Slide

Center Merge

Multi-Spin

Slash Slide

Sliding Bands

Sliding Boxes

Swap

Swirl

Map

Channel Map

Luminance Map


3D Motion

Curtain

Doors

Fold Up

Spin

Spin Away

Swing In

Swing Out

Tumble Away

Special Effect

Displace

Texturize

Three-D

Stretch

Cross Stretch

Stretch

Stretch In

Stretch Over

Dissolve

Dither Dissolve

Random Invert



Ported video effects  

Distort

Lens Distortion

Image Control

Color Pass

Color Replace

Ported transitions

Dissolve

Non-Additive Dissolve

Zoom

Cross Zoom


For the complete list of video effects and transitions supported in Premiere Pro, see Video effects and transitions.

Enhanced graphic performance and native format support

RED GPU debayering

RED format clips now use the GPU (OpenCL and CUDA) for debayering for an improved and faster playback performance.

Support for Intel Iris

Premiere Pro supports Intel Iris architectures for Mercury OpenCL processing.

Powerful new workflow for ARRI AMIRA camera

Premiere Pro provides built-in support for the ARRI AMIRA camera, with appropriate color LUTs applied as master clips on import.

Enhanced support for CinemaDNG

Premiere Pro provides enhanced support for CinemaDNG including Blackmagic Pocket Cinema Camera, and Convergent Design Odyssey7Q.

When working with CinemaDNG media, you can access the Source Settings and edit the metadata parameters like you would with RED and ARRIRAW media.


New delivery formats

Premiere Pro now supports export to industry-standard AS11 for broadcast, and certain types of Quvis Wraptor Digital Cinema Package (DCP). When exporting to both these formats, the associated metadata is included.

In addition, Premiere Pro can also export stereo audio to Dolby Digital and Dolby Digital Plus formats.

Other enhancements

New progress bar display

To view progress when rendering files, a new progress bar is displayed over the Premiere Pro icon on the Mac OS X dock or Windows taskbar. When you are in other applications, you can now easily view the progress of items in Premiere Pro without having Premiere Pro in the foreground.

Presets to remove GoPro camera lens distortion

To remove the distortion created from GoPro camera's wide angle lenses, Premiere Pro provides presets that use the Lens Distortion video effect.

Preserve effects when flattening multi-camera sequences

Premiere Pro lets you flatten a multi-camera sequence while preserving any intrinsic or non-intrinsic effects applied to the multiple source clips.

To flatten a multi-camera sequence, select the sequence and choose Clip > Multi-Camera > Flatten. The resulting flattened clip preserves the effects from the different single clips within the multi-camera sequence.

Enhancements to transitions  

  • Cross Dissolve transition can be saved as a preset
  • Ability to select multiple transitions at once and change durations simultaneously

Optimized metadata

Premiere Pro has optimized metadata for improved performance during indexing, searching, and sorting.

Closed captioning changes

In previous versions, when exporting captions, you encoded the accompanying video or audio. You can now directly export .scc, .mcc, .xml, or .stl sidecar files without having to encode the media.

Select File > Export > Captions for the selected clip or sequence in the Project panel. In the  Caption Sidecar Settings dialog, select the closed caption file format and frame rate. 

Faster searching and sorting in Project Panel

You can now search and sort assets in the Project panel noticeably faster than before.

Improved workflows and performance

  • Improved Red Giant Pluraleyes workflows
  • Issues with AAF export resolved
  • Ability to use Sound Roll and Sound Timecode in EDL export
  • Improved scratch-disk workflows when moving assets between platforms, and when an earlier scratch disk location is offline
  • Improved AVCi growing files performance
  • Mosaic effect is now GPU optimized

New and changed keyboard shortcuts

New default shortcuts

Results Windows Mac OS
Keyboard Shortcuts Ctrl+Alt+K Cmd+Opt+K
Reverse Match Frame Shift+R Shift+R

New shortcut commands

You can set default shortcuts for the following commands in the Keyboard Shortcuts dialog.

  • Add Fonts From Typekit
  • Browse Add-ons
  • Captions
  • Lock/Unlock All Audio Tracks
  • Lock/Unlock All Video Tracks
  • Nudge Volume +1dB
  • Nudge Volume +3dB
  • Nudge Volume -1dB
  • Nudge Volume -3dB
  • Toggle Maintain Pitch During Shuttling
  • Toggle Transparency Grid
  • Track Select Backward Tool

For the complete list of keyboard shortcuts, see Keyboard shortcuts in Premiere Pro CC.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy