The June 2015 release of Premiere Pro CC brings you fast new color workflows, a powerful Morph Cut transition, expanded collaboration capabilities, easier asset sharing, and several new features that help you edit with finesse, and deliver amazing content.

 

  COLOR

Premiere Pro CC introduces brand new color tools that combine the best of Adobe SpeedGrade and Adobe Lightroom technologies. Editing and color grading now work hand in hand, more closely than ever before.

Color tools
Color tools

The new Lumetri Color workspace in Premiere Pro provides editors the complete toolbox for professional color grading. You can grade your footage using professional color tools directly on your editing timeline.

Apply simple color corrections or complex Lumetri Looks using intuitive sliders and controls. Easily adjust cuts or fine-tune grades using advanced color correction tools. And if you want to do more, bring your project into SpeedGrade via Direct Link to make more refinements.

To learn more, see Color workflows.

  MORPH CUT

Morph Cut is a powerful new transition in Premiere Pro that lets you create more polished interviews by smoothing out distracting jump cuts without having to cross-dissolve or cut away.

Morph cut
Morph cut

Morph Cut uses an advanced combination of face tracking and optical flow interpolation to create a seamless transition between clips.

To learn more, see Morph Cut.

   COLLABORATION

Creative Cloud Libraries

Creative Cloud Libraries are now available in Premiere Pro. All your favorite assets can be accessed from a single Library panel in Premiere Pro.

Create a graphic in Photoshop, or save an Adobe Stock image and access them directly in Premiere Pro. You can save, access, and reuse assets stored in Libraries across Adobe's desktop and mobile apps.

You can share Libraries with anyone with a Creative Cloud account. Library sharing makes it easy to collaborate with teams and maintain consistency across projects with common assets like graphics, colors, Looks, or type styles.

Select Window > Library to open the Library panel in Premiere Pro.

To learn more, see Creative Cloud Libraries.

Tighter integration with Premiere Clip

Adobe Premiere Clip makes the creation of amazing videos with your iPhone and iPad easy and fast. Premiere Clip's tighter integration with Premiere Pro steps up your creative power to the next level by leveraging the power of Creative Cloud to seamlessly transfer assets from your mobile to desktop and take them through some professional-grade editing.

You can now open your Premiere Clip projects directly from the Welcome screen in Premiere Pro.

Edits, music cues, and Looks applied in Premiere Clip translate directly into a Premiere Pro timeline. This integration allows you to seamlessly  transition from quick mobile editing to the more professional desktop non-linear editing with just a couple of easy steps. 

To learn more, see Edit Premiere Clip videos in Premiere Pro.

Seamless Integration with Adobe Stock

Adobe Stock is a new service that sells millions of high-quality, royalty-free photos, illustrations, and graphics.

You can search for Adobe Stock content directly from within Premiere Pro through the Libraries panel (Window > Libraries) by clicking the Search Adobe Stock button in the panel. You can then purchase a license for an asset you want to use and include it in your Premiere Pro Library. Or, you can add an unlicensed preview (watermarked) copy to your Library and purchase a license for it later.

To learn more, see Using Adobe Stock and Creative Cloud Libraries.

   AUDIO

Audio workflow improvements

This release of Premiere Pro comes integrated with the powerful audio engine from Adobe Audition, ensuring a more seamless and robust audio editing experience.

Other new features include a faster voice-over recording configuration, improved multi-channel audio export, and a more intuitive user interface for audio routing. The new audio routing interface gives you more control over visually assigning the output channels for standard, mono, 5.1, and adaptive tracks. The audio channels in the Modify Clip workflow come with a matrix to match the available channels in the source file to the channels and track items in the clip.

In addition, Premiere Pro now allows plug-and-play with a wide range of audio hardware, including ASIO and MME (Windows) and CoreAudio (Mac) with pre-loaded setup for these device types.

Dynamic Link video streaming

When you send Premiere Pro projects to Audition using the Dynamic Link video streaming video option, you can view video in its native resolution within Audition.

  1. In a Project panel, select a sequence containing audio.
  2. Select Edit > Edit In Adobe Audition and then select Sequence from the submenu.
  3. In the Edit In Adobe Audition dialog, under Video, choose Send Through Dynamic Link.
  4. Select Open In Adobe Audition to open the selected clip in its native format in Audition.

   USER INTERFACE

Task-oriented workspaces

Premiere Pro now offers a more dynamic user interface with task-oriented workspaces that display the required toolsets for a task at hand.

Each workspace focuses on a specific task of the post-production workflow and includes panels that contain options and controls for working on that task.

The workspaces are designed such that they not only reduce clutter but also guide you through the tasks in a logical workflow. If you are using a touch-based device, you can switch workspaces with a tap of the finger.  

To learn more, see Workspaces.

New Welcome experience

The 2015 release of Premiere Pro CC has a new Welcome experience to help you discover, learn, and use features in Premiere Pro.

Each time you start Premiere Pro or when you click Help > Welcome, a tab-based Welcome screen helps you easily discover new features, getting started tutorials, and tips and techniques.

The content that is displayed is personalized and relevant to your subscription and use of Premiere Pro.

Welcome screen
The new Welcome screen

Note:

The new Welcome screen is currently available only in the English version of Premiere Pro.

   EDITING

Time Tuner

Time Tuner is a new feature in Adobe Media Encoder that enables you to deliver content that is the right duration without time-consuming micro-editing. Time Tuner adjusts the length of video by automatically adding or removing frames at scene changes or sections of low visual activity.

This feature is especially useful for editors working in broadcast to meet specific delivery requirements.

To learn more, watch this video tutorial.

Caption burn-in

Premiere Pro lets you burn in permanent captions into your video for both closed captions and open caption file formats. 

When you import open caption files, Premiere Pro automatically converts the open captions to closed captions. You can then edit and burn the captions into the export using Premiere Pro or Adobe Media Encoder.

To learn more, see Working with captions.

Editing experience refinements

Source Settings available in the Effect Controls panel

For RED, ARRI, CinemaDNG, DPX, and Sony F65 media files, you can adjust Source Settings by using the Master tab in the Effect Controls panel. Previously, Source Settings were available from a modal dialog.

To learn more, see Adjust Source Settings using the Effect Controls panel.

Clip markers displayed on minimized Timeline tracks

Earlier, clip markers were not displayed when tracks were collapsed to their minimum height. Now, you can always display clip markers. To turn them off, click in the Timeline panel, and deselect Show Clip Markers.

Improved four-point editing

When the In and Out points on the source are shorter than the In and Out points on the sequence, the Ignore Source In Point and Ignore Source Out Point options are no longer disabled. Earlier, these options were disabled even if the source has available frames to move the In and Out points and accommodate the edit.

Note:

Select Always Use this Choice to ensure that the Fit Clip dialog does not appear every time there is a mismatch. However, if there isn't enough media beyond the In or Out pints in the source to make the edit, an Insufficient Content for Edit warning dialog appears.

Adjust anchor points directly in the Program Monitor

For the Motion effect, you can now move the anchor point directly in the Program Monitor.

When you drag the anchor point in the Program Monitor, the anchor point gets relocated in the Program Monitor while the frame remains still. This is achieved by simultaneously updating both the Anchor Point and Position parameters.

To learn more, see Adjust anchor points in the Program Monitor.

Logarithmic waveform scaling in the Timeline

Premiere Pro now offers a new Logarithmic Waveform Scaling feature that scales up the peaks and valleys of a waveform to make them easier to read, especially at low noise levels. This feature is turned on by default, and applies to both rectified and non-rectified waveform settings.

To turn this feature off, select the pop-up menu from the Timeline, and deselect Logarithmic Waveform Setting.

Hide items in the Project panel

Premiere Pro lets you selectively hide items in the Project panel, letting you easily focus on only the visible items.

To hide a project item, select the item in the Project panel, and select Hide from the context menu. You can hide not only single project items but also a group of project items including bin folders, sequences, and nested sequences.

At any point, you can view the hidden items by selecting View Hidden from the context menu. The View Hidden option works on all project items and media types, including bins, sequences, and titles.

Important notes

  • You can use the Hide and View Hidden options while using the Search Bins feature in Premiere Pro. For example, you can create a single location where you can search for clips that have been hidden among all the other bins.
  • When you use the Reveal In Project feature on a sequence item whose master clip is hidden, the "View Hidden" settings are toggled off. Premiere Pro then displays all hidden items including the master clip that was hidden.  

Sort on XMP metadata in the Project panel

Sorting on XMP metadata columns in the project panel is re-enabled.

Click an XMP column header to sort metadata by this column. After the XMP loading is complete, the progress dialog disappears and the project panel is sorted.

At any point, you can cancel sort operations that are running long due to XMP loading.

Composite preview during trim

The new Composite Preview During Trim feature lets you trim clips more accurately.

When you drag trim an edit point in a Timeline panel, you can see a preview of what the final composited frames look like in the Program Monitor. You can preview what the composited frames look like on either side of the edit point, and not just the frames on the track that you are trimming.

To access this feature, click the Wrench icon in a Timeline panel, and select Composite Preview During Trim.

Create a subsequence from a sequence segment

You can now mark a portion of a sequence in the Source monitor with an In/Out range and create a new sequence that contains just that In/Out range with the original clip content and track layout. For example, you can divide a long sequence into segments that can be used as sources for other sequences.

With a sequence open in the Timeline panel or in the Source monitor, mark an In and Out range, then choose Make Subsequence from the Sequence menu. A new sequence is created in the Project panel, using the name of the original sequence, and appended with _Sub_01 and auto-incremented for the next subsequence.

Disable Master Clip Effects for project items

You can quickly disable Master Clip Effects by selecting one or more project items and choosing Disable Master Clip Effect from the context menu.

In the Effect Controls panel, use the FX button to toggle Master Clip Effects off and on.

AAF Export and reference video track

You can export AAF files directly from Premiere Pro. Select File> Export > AAF to export the selected project.

In the AAF Export Settings dialog, select Mixdown Video to include a reference video clip when exporting. A reference video clip can help with efficient editing and syncing. 

When you open the AAF file, the reference video clip is automatically linked.

Sequential Field playback in Source and Program Monitors

The Display Both Fields option in the Source Monitor and Program Monitor now plays clips sequentially, instead of one after the other. Playing clips one after the other is sometimes found to have combing effects.

The Display Both Fields option applies only to playback, and not to scrubbing or pausing.

Improved event notifications

In previous versions of Premiere Pro, a warning icon was displayed in the lower right corner of the Status Bar when an event occurred that would be displayed in the Events panel. Since the warning icon is small, it often went unnoticed.

Now, in addition to the warning icon, a notification pop-up dialog appears in the lower right corner of the application. Click the pop-up notification to open the Events Panel that contains more details.

To turn off this pop-up notification, deselect Show Event Notifications in the Preferences dialog under the General category.

Improvements to Consolidate and Transcode

  •  Increased handle frame limit
    When consolidating and transcoding a project, or rendering and replacing, you can specify up to 999 additional frames before the In point and after the Out point of each transcoded clip.
  • Preserved alpha channel graphics
    Premiere Pro preserves alpha channels in clips during transcoding. When this option is selected (default setting), Premiere Pro detects clips with an alpha channel. If the selected preset does not contain an alpha channel, Premiere Pro copies the alpha channel without transcoding. If the selected preset contains an alpha channel, then the clip is transcoded. Clips without alpha channels are transcoded following the normal rules of transcoding.

Export movies at a specific timecode

Previously, you could only set the start time code of a movie to zero in the Export Settings dialog. Now, you can have an exported movie start at a specified timecode, other than zero. For example, you can specify that an exported movie should start at a timecode of 00:09:32:27.

To specify a timecode, select Set Start Timecode in the Export Settings dialog box, and enter the timecode value.

New frame hold option

You can now freeze a video frame based on a clip's source timecode.  

In the Frame Hold options dialog box, a Source Timecode option is added. When you select Source Timecode, the Frame field changes to the clip's timecode. Modify the clip timecode value as required.

In addition, the Time option is now renamed to Sequence Timecode.

To learn more about the Frame Hold options, see Freeze and hold frames.

New Appearance preferences

The Appearance pane of the Preferences dialog box provides new preferences that let you control the brightness and saturation of the blue highlight color, interactive controls, and focus indicators.

   OTHER FEATURES

Expanded format support

Premiere Pro continues to expand its native format support by supporting the following formats:

  • DNxHD with compressed alpha
  • Canon XF-AVC
  • ProRes 4444XQ
  • Panasonic 4K_HS

Premiere Pro also supports DNxHD growing files.

Soft subclip support through XML

Premiere Pro now supports subclips with soft edits in Final Cut Pro project XML files.

New and changed keyboard shortcuts

Contextual keyboard shortcuts for Trim and Nudge

You can now use the same shortcuts for Trim and Nudge commands without having to use a different key combination for each shortcut. The correct shortcut combination works depending on the action you perform in the Timeline - for example, editing a clip versus moving a clip.

In the Keyboard Shortcuts dialog, when you specify a shortcut that has already been used, Premiere Pro displays a warning that the shortcut has already been assigned. However, you can go ahead and assign the shortcut to another command. For example, you can assign the same shortcut to the Trim Forward and  Nudge Forward commands.

New keyboard shortcuts to play In to Out

You can assign keyboard shortcuts for the following commands using the Keyboard Shortcuts dialog:

  • Play Video In to Out
  • Play Audio In to Out
  • Play from Playhead to Audio Out Point
  • Play from Playhead to Video Out Point

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy