Criação e gerenciamento de um índice em um PDF

É possível reduzir o tempo necessário para pesquisar um PDF grande incorporando um índice de palavras no documento. O Acrobat pode pesquisar o índice com mais rapidez do que ele pesquisa o documento. O índice incorporado está incluído em cópias distribuídas ou compartilhadas do PDF. Os usuários pesquisam PDFs com índices incorporados exatamente da mesma forma que pesquisam os sem índices; não são necessárias etapas adicionais.

Como adicionar um índice a um PDF

  1. Com o documento aberto no Acrobat, escolha Ferramentas > Processamento de documentos > Gerenciar índice incorporado.
  2. Na caixa de diálogo Gerenciar índice incorporado, clique em Incorporar índice.
  3. Leia as mensagens exibidas e clique em OK.

    Observação:

    No Outlook e no Lotus Notes, é possível incorporar um índice ao converter mensagens de e-mail ou pastas em PDF. Isso é recomendado principalmente para pastas que contêm muitas mensagens de e-mail.

Como atualizar ou remover o índice incorporado em um PDF

  1. Escolha Ferramentas > Processamento de documentos > Gerenciar índice incorporado.
  2. Clique em Atualizar índice ou Remover índice.

Sobre o recurso Catálogo (Acrobat Pro)

É possível definir um grupo específico de PDFs como um catálogo e criar um índice unificado para todo esse conjunto de documentos. Quando usuários pesquisam informações específicas em PDFs catalogados, o índice torna o processo de pesquisa muito mais rápido.

Ao distribuir ou publicar a coleção em um CD, você pode incluir o índice com os PDFs.

É possível catalogar documentos escritos em caracteres romanos, chineses, japoneses ou coreanos. Os itens que podem ser catalogados incluem textos de documentos, comentários, marcadores, campos de formulário, marcas, metadados de objetos e de documentos, anexos, informações de documentos, assinaturas digitais, metadados de imagens XIF (Extended Image File Format, formato estendido de arquivos de imagem) e propriedades de documentos personalizadas.

Preparação de PDFs para indexação (Acrobat Pro)

Comece criando uma pasta para armazenar os PDFs que deseja indexar. Todos os PDFs devem estar completos em conteúdo e em recursos eletrônicos, como links, marcadores e campos de formulário. Se os arquivos que serão indexados incluírem documentos digitalizados, verifique se o texto é pesquisável. Para melhorar o desempenho da pesquisa, divida documentos extensos em arquivos menores, separados em capítulos. Também é possível adicionar informações às propriedades de documento de um arquivo para melhorar o desempenho da pesquisa nesse arquivo.

Antes de indexar um conjunto de documentos, é essencial configurar a estrutura do documento na unidade de disco ou no volume do servidor de rede e verificar se os nomes de arquivos podem ser usados em diferentes plataformas. Os nomes dos arquivos podem ficar truncados e difíceis de serem recuperados em uma pesquisa que envolva diferentes plataformas. Para evitar esse problema, considere estas instruções:

  • Renomeie arquivos, pastas e índices usando a convenção de nomeação de arquivos do MS-DOS (oito caracteres ou menos seguidos por uma extensão de arquivo com três caracteres), principalmente se você estiver planejando distribuir o conjunto de documentos e o índice em um disco CD-ROM formatado no padrão ISO 9660.

  • Remova dos nomes dos arquivos e das pastas os caracteres estendidos, como caracteres acentuados e caracteres em idiomas diferentes do inglês. (A fonte usada pelo recurso Catálogo não oferece suporte para os códigos de caracteres 133 a 159.)

  • Não use pastas profundamente aninhadas ou nomes de caminhos com mais de 256 caracteres para os índices que serão pesquisados por usuários do Mac OS.

  • Se você estiver usando o Mac OS com um servidor de rede local (LAN) OS/2, configure o Servidor LAN para Macintosh (LSM) da IBM® para aplicar as convenções de nomeação de arquivos do MS-DOS, ou indexe apenas os volumes FAT (File Allocation Table). (Volumes HPFS [High Performance File System] podem conter nomes de arquivo extensos e irrecuperáveis.)

    Se a estrutura do documento incluir subpastas que você não deseja indexar, você poderá excluí-las durante o processo de indexação.

Adição de metadados às propriedades do documento (Acrobat Pro)

Para facilitar a pesquisa em um PDF, é possível adicionar informações do arquivo, denominadas metadados, às propriedades do documento. (Para ver as propriedades do PDF atualmente aberto, escolha Arquivo > Propriedades e clique na guia Descrição.)

Observação:

(Windows) Também é possível digitar e ler as informações de propriedades de dados a partir da área de trabalho. Clique com o botão direito do mouse no documento no Windows Explorer, escolha Propriedades e clique na guia PDF. As informações inseridas ou editadas nessa caixa de diálogo também serão exibidas na guia Descrição, em Propriedades do documento, quando o arquivo for aberto.

Ao adicionar dados para propriedades de documentos, considere as seguintes recomendações:

  • Use um bom título descritivo no campo Título. O nome do arquivo do documento deve ser exibido na caixa de diálogo Pesquisar resultados.

  • Sempre use a mesma opção (campo) para informações semelhantes. Por exemplo, não adicione um termo importante à opção Assunto para alguns documentos e à opção Palavras-chave para outros.

  • Use um termo único e consistente para as mesmas informações. Por exemplo, não use biologia para alguns documentos e ciências biológicas para outros.

  • Use a opção Autor para identificar o grupo responsável pelo documento. Por exemplo, o autor de um documento de diretrizes de contratação pode ser o departamento de Recursos Humanos.

  • Se você usar números de peças de documentos, adicione-os como palavras-chave. Por exemplo, adicionando doc#=m234 a Palavras-chave, você poderá indicar um documento específico em uma série de centenas de documentos sobre um assunto específico.

  • Use a opção Assunto ou Palavras-chave, individualmente ou em conjunto, para categorizar documentos por tipo. Você pode usar, por exemplo, relatório de status como uma entrada de Assunto e mensalmente ou semanalmente como uma entrada de Palavras-chave para um único documento.

    Se você estiver familiarizado com o formato Adobe PDF, poderá definir campos de dados personalizados, como Tipo de documento, Número do documento e Identificador do documento, ao criar o índice. Esse procedimento é recomendado apenas para usuários avançados e não está coberto na Ajuda completa do Acrobat.

Criar um índice para uma coleção (Acrobat Pro)

Quando você cria um novo índice, o Acrobat cria um arquivo com a extensão .pdx e uma nova pasta de suporte contendo um ou mais arquivos com as extensões .idx. Os arquivos IDX contêm as entradas de índice. Todos esses arquivos devem estar disponíveis aos usuários que desejam pesquisar no índice.

Caixas de diálogo no Acrobat Pro para o processo de criação de índice
Caixas de diálogo no Acrobat Pro para o processo de criação de índice

  1. Escolha Ferramentas > Processamento de documentos > Índice de texto completo com catálogo e, em seguida, clique em Novo índice.

    Observação:

    Se você não vir o painel Processamento de documentos, consulte as instruções para adicionar painéis em Painel de tarefas.

  2. Em Título do índice, digite um nome para o arquivo de índice.
  3. Em Descrição do índice, digite algumas palavras sobre o tipo de índice ou sua finalidade.
  4. Clique em Opções, selecione todas as opções avançadas que deseja aplicar ao índice e clique em OK.
  5. Em Incluir estes diretórios, clique em Adicionar, selecione uma pasta que contenha alguns ou todos os arquivos PDF que serão indexados e clique em OK. Para adicionar mais pastas, repita essa etapa.

    Observação:

    Todas as pastas aninhadas em uma pasta incluída também serão incluídas no processo de indexação. É possível adicionar pastas a partir de vários servidores ou unidades de disco, desde que você não planeje mover o índice ou quaisquer itens no conjunto de documentos.

  6. Em Excluir estes subdiretórios, clique em Adicionar e selecione todas as pastas aninhadas que contenham arquivos PDF que você não deseja indexar. Clique em OK e repita, conforme necessário.
  7. Verifique suas seleções. Para editar a lista de pastas que serão incluídas ou excluídas, selecione a pasta que deseja alterar e clique em Remover.
  8. Clique em Construir e, em seguida, especifique o local para o arquivo de índice. Clique em Salvar e, em seguida:
    • Clique em Fechar quando a indexação for concluída.

    • Clique em Interromper para cancelar o processo de indexação.

    Observação:

    Se você interromper a indexação, não poderá retomar a mesma sessão de indexação, mas não precisará refazer o trabalho. As seleções de opções e pastas permanecem intactas. É possível clicar em Abrir índice, selecionar o índice parcialmente concluído e revisá-lo.

    Observação:

    Se nomes extensos de caminhos estiverem truncados nas opções Incluir estes diretórios e Excluir estes subdiretórios, posicione o ponteiro do mouse sobre cada reticência (...) até que uma dica de ferramenta apareça, exibindo o caminho completo da pasta incluída ou excluída.

Caixa de diálogo Opções de indexação

Não incluir números

Selecione essa opção para excluir todos os números exibidos no texto do documento a partir do índice. A exclusão dos números pode reduzir significativamente o tamanho de um índice, agilizando as pesquisas.

Adicionar IDs a arquivos Adobe PDF v1.0

Selecione essa opção se o seu conjunto incluir PDFs criados em versões anteriores ao Acrobat 2.0, que não adicionou números de identificação automaticamente. Os números de ID são necessários quando nomes de arquivos extensos do Mac OS são abreviados após a conversão em nomes de arquivos do MS DOS. O Acrobat 2.0 e versões posteriores adicionam identificadores automaticamente.

Não avisar sobre documentos alterados ao pesquisar

Quando essa opção não estiver selecionada, será exibida uma mensagem durante a pesquisa de documentos que foram alterados desde a construção de índice mais recente.

Propriedades personalizadas

Use essa opção para incluir propriedades de documentos personalizadas no índice. São indexadas apenas as propriedades de documentos personalizadas já existentes nos PDFs. Digite a propriedade, faça uma seleção no menu Tipo e, em seguida, clique em Adicionar. Essas propriedades aparecem como uma opção de pesquisa nos menus pop-up de critérios adicionais da janela Pesquisar PDF, durante a pesquisa do índice resultante. Por exemplo, se você digitar a propriedade personalizada Nome do documento e escolher a propriedade da string no menu Tipo, um usuário que estiver pesquisando no índice também poderá pesquisar na propriedade personalizada, selecionando Nome do documento no menu Usar esses critérios adicionais

Observação:

Quando você cria campos personalizados em um aplicativo do Microsoft Office no qual a opção Converter informações do documento esteja selecionada no aplicativo PDFMaker, os campos são transferidos para quaisquer PDFs criados.  

Campos XMP

Use essa opção para incluir campos XMP personalizados. Esses campos são indexados e aparecem nos menus pop-up de critérios adicionais para que possam ser pesquisados nos índices selecionados.

Palavras de interrupção

Use para excluir palavras específicas (no máximo 500) dos resultados da pesquisa do índice. Digite a palavra, clique em Adicionar e repita, conforme necessário. A exclusão de palavras pode tornar o índice 10% a 15% menor. Uma palavra de interrupção pode conter até 128 caracteres e faz distinção entre letras maiúsculas e minúsculas.

Observação:

Para impedir que os usuários tentem pesquisar frases que contenham essas palavras, relacione as palavras que não são indexadas no arquivo Leia-me no catálogo.

Marcas de estrutura

Use essa opção para tornar pesquisáveis os nós específicos de marcas de elementos-folha nos documentos que apresentam uma estrutura lógica marcada.

Observação:

As configurações Propriedades personalizadas, Palavras de interrupção e Marcas aplicam-se somente ao índice atual. Para aplicá-las em nível geral a qualquer índice criado, é possível alterar as configurações padrão para campos personalizados, palavras de interrupção e marcas no painel Catálogo da caixa do diálogo Preferências.  

Arquivos Leia-me do catálogo (Acrobat Pro)

Normalmente, é uma boa ideia criar um arquivo Leia-me separado e colocá-lo na pasta com o índice. Esse arquivo Leia-me pode fornecer detalhes sobre o índice, tais como:

  • Os tipos de documentos indexados.

  • As opções de pesquisa suportadas.

  • A pessoa a ser contatada ou um número de telefone de assistência.

  • Uma lista de números ou palavras que são excluídos do índice.

  • Uma lista das pastas que contêm documentos incluídos em um índice com base em LAN ou uma lista dos documentos incluídos em um índice com base em disco. Também é possível incluir uma breve descrição do conteúdo de cada pasta ou documento.

  • Uma lista dos valores para cada documento, se forem atribuídos valores no campo Informações do documento.

    Se um catálogo tiver um número particularmente grande de documentos, considere a inclusão de uma tabela que mostre os valores atribuídos a cada documento. Essa tabela pode fazer parte do arquivo Leia-me ou pode ser um documento à parte. Durante o desenvolvimento do índice, é possível usá-la para manter a consistência.

Revisão de um índice (Acrobat Pro)

É possível atualizar, reconstruir ou expurgar um índice existente.

  1. Escolha Ferramentas > Processamento de documentos > Índice de texto completo com catálogo e, em seguida, clique em Abrir índice.
  2. Localize e selecione o arquivo de definição de índice (PDX) do índice e clique em Abrir.
  3. Se o índice foi criado com o Acrobat 5.0 ou com uma versão anterior, selecione Criar cópia para criar um novo índice (sem sobrescrever a versão anterior) ou selecione Sobrescrever índice antigo para sobrescrever o índice anterior.
  4. Na caixa de diálogo Definição do índice, faça as alterações desejadas e, em seguida, clique na função que você deseja que o Acrobat execute:

    Construir

    Cria um novo arquivo IDX com as informações existentes e o atualiza, adicionando novas entradas e marcando as entradas alteradas ou desatualizadas como inválidas. Se você fizer muitas alterações ou usar essa opção várias vezes em vez de criar um novo índice, os tempos de pesquisa poderão aumentar.

    Reconstruir

    Cria um novo índice, sobrescrevendo a pasta de índice existente e seu conteúdo (os arquivos IDX).

    Expurgar

    Exclui o conteúdo do índice (os arquivos IDX) sem excluir o próprio arquivo de índice (PDX).

Preferências de catálogo (Acrobat Pro)

É possível definir preferências de indexação que se apliquem em nível geral a todos os índices subsequentes criados. É possível substituir algumas dessas preferências para um índice individual, selecionando novas opções durante o processo de criação de índice.

Na caixa de diálogo Preferências, em Categorias, selecione Catálogo. Muitas das opções são idênticas àquelas descritas para o processo de criação de índice.

Observação:

A opção Impor compatibilidade com o ISO 9660 em pastas é útil quando não se deseja alterar nomes de arquivos PDF extensos para nomes de arquivos do MS-DOS durante a preparação de documentos para indexação. Entretanto, ainda é necessário usar as convenções de nomeação de arquivos do MS-DOS para os nomes de pastas (8 caracteres ou menos), mesmo que isso não seja necessário para os nomes de arquivos.

Atualizações de índice programadas (Acrobat Pro)

Use o recurso Catálogo e um arquivo PDX em lote (.bpdx) do catálogo para programar o momento e a frequência para construir, reconstruir, atualizar e expurgar um índice automaticamente. Um arquivo BPDX é um arquivo de texto que contém uma lista de sinalizadores e caminhos de arquivos de índices de catálogo dependentes da plataforma. Use um aplicativo de programação, como o Windows Scheduler, para exibir o arquivo BPDX no Acrobat. O Acrobat recria o índice de acordo com os sinalizadores no arquivo BPDX.

Para obter mais informações sobre como programar uma atualização de indexação, procure BPDX em www.adobe.com/br/support.

 

Observação:

Para usar arquivos BPDX, na caixa de diálogo Preferências, em Catálogo, selecione Permitir que arquivos em lote do catálogo (.bpdx) sejam executados.

Como mover coleções e seus índices (Acrobat Pro)

É possível desenvolver e testar um conjunto de documentos indexados em uma unidade de disco rígido local e, em seguida, mover o conjunto de documentos finalizados para um servidor de rede ou um disco. Uma definição de índice contém os caminhos relativos entre o arquivo de definição de índice (PDX) e as pastas que contêm os documentos indexados. Se esses caminhos relativos não forem alterados, não será necessário reconstruir o índice depois de mover o conjunto de documentos indexados. Se o arquivo PDX e as pastas que contêm os documentos indexados estiverem na mesma pasta, será possível manter o caminho relativo apenas movendo essa pasta.

Se o caminho relativo for alterado, será necessário criar um novo índice depois de mover o conjunto de documentos indexados. Entretanto, ainda será possível usar o arquivo PDX original. Para usá-lo, mova primeiro os documentos indexados. Em seguida, copie o arquivo PDX para a pasta na qual você deseja criar o novo índice e edite as listas de inclusão e de exclusão de diretórios e subdiretórios, conforme necessário.

Se o índice residir em uma unidade ou em um volume de servidor separado de qualquer parte do conjunto aplicável, a movimentação do conjunto ou do próprio índice dividirá o índice. Se você pretende mover um conjunto de documentos para outro local na rede ou para um CD, crie e construa o índice no mesmo local que o do conjunto.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online