Problema

Durante a instalação do AEM6.2 SP1, você vê esse erro no error.log:

Could not Install Package
"javax.jcr.nodetype.ConstraintViolationException: OakConstraint0001: /etc/cloudsettings/default/contexthub[[nt:folder]]: No matching definition found for child node relatedproducts with effective type [nt:unstructured]"

Causa

O tipo de nó da pasta /etc/cloudsettings/default/contexthub (nt:folder) é incompatível com as alterações incluídas no service pack.

Resolução

Antes de instalar o SP1, faça o seguinte:

  1. Acesse http://aem-host:port/crx/packmgr/index.jsp

  2. Crie um pacote de back-up de /etc/cloudsettings/default/contexthub

  3. Acesse http://aem-host:port/crx/de/index.jsp web app
     aplicativo web

  4. Procure e exclua a pasta /etc/cloudsettings/default/contexthub

  5. Salvar

  6. Instalar o SP1

  7. Reaplicar quaisquer alterações personalizadas que foram feitas para a configuração de hub do contexto padrão.

Gravidade

Gravidade 2

Mensagem especificada

javax.jcr.nodetype.ConstraintViolationException: OakConstraint0001: /etc/cloudsettings/default/contexthub[[nt:folder]]: No matching definition found for child node relatedproducts with effective type [nt:unstructured]

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online