Caracteres internacionais não exibidos em páginas atendidas pelo dispatcher

Sintomas

Você tem uma página que inclui alguns caracteres especiais (por exemplo, trema). Ao solicitar a página do dispatcher, não é possível ver os caracteres. No entanto, se você solicitar a mesma página diretamente da instância do Communiqué, poderá ver os caracteres.

Causa

Cabeçalhos HTTP não são armazenados em cache no dispatcher e você provavelmente está armazenando a codificação no cabeçalho.

Solução

Há duas soluções:

1. Se você usa apenas uma codificação, verifique se a codificação usada no servidor da Web é igual à codificação padrão da instância do Communiqué.

2. Use uma marca <META> no cabeçalho HTML para definir a codificação, como:

<META http-equiv="Content-Type" content="text/html; charset=EUC-JP">
Logotipo da Adobe

Fazer logon em sua conta