Atualização de sessão de login não está funcionando | AEM 6.x

Problema

No AEM quando Atualizar Token está ativado na configuração OSGi da Configuração do Token no Apache Jackrabbit Oak [1], o token de login não é atualizado. Esse problema se aplica ao LDAP e ao SAML 2, a autenticação padrão do Token.

[1]

http://aem-host:port/system/console/configMgr/org.apache.jackrabbit.oak.security.authentication.token.TokenConfigurationImpl

Causa

O token de login não é atualizado devido a um equívoco de como a atualização do token funciona ou se o token encapsulado está ativado.

Resolução

Verifique se o suporte ao token encapsulado está ativado. No momento de escrever este artigo (AEM v6.0-6.3), o mecanismo de login do token encapsulado não suportava atualização de token.

  1. Vá para a seguinte URL e faça o login como administrador: http://aem-host:port/system/console/configMgr/com.day.crx.security.token.impl.impl.TokenAuthenticationHandler

  2. Veja se Ativar suporte ao token encapsulado está ativado.

Se o suporte ao token encapsulado não estiver ativado, é provável que a atualização do token esteja funcionando, mas não funciona conforme o esperado. Quando os usuários efetuam login, o token não é atualizado, a menos que os usuários acessem o sistema após metade do tempo de expiração do token configurado na Configuração do Token no Oak [1] ter decorrido.

Por exemplo, se a expiração for definida para duas horas, o usuário poderá usar o sistema durante toda a primeira hora. Mas, se eles não acessarem o sistema após uma hora, o token não será atualizado. Então eles precisam fazer o login novamente depois de duas horas terem passado do seu login inicial.  No entanto, se eles fizerem login, aguardarem uma hora e acessarem o sistema novamente, seu token será atualizado para que a sessão seja estendida. 

 Adobe

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