Vá para http://aem-host:port/crx/de/index.jsp e faça logon como administrador.
Problema
Alguns arquivos .js e .css estão ausentes de suas páginas do AEM ou da interface do AEM.
Causa
Isso pode ser causado por alguns fatores:
- A consulta xpath [1] usada pelo AEM Client Library Manager (HTMLLibraryManager) está usando algum índice diferente do índice /oak:index/nodetype.
- O índice do nodetype não está atualizado ou está corrompido.
- As permissões de usuário de clientlibs-service estão ausentes.
[1]
/jcr:root//element(*, cq:ClientLibraryFolder)
Resolução
I. Verifique as permissões do usuário do serviço
Consulte novamente este artigo caso as permissões do usuário do serviço clientlibs estejam ausentes.
II. Verifique se a consulta está obtendo resultados corretos
-
-
Vá para Ferramentas => Consulta.
-
Na caixa de consulta inferior, insira esta consulta:
/jcr:root//element(*, cq:ClientLibraryFolder)
-
Valide se a biblioteca ausente do cliente está ou não nos resultados. Caso ela esteja lá, entre em contato com Atendimento ao Cliente AEM para obter ajuda com mais investigações. Caso contrário, vá para a etapa seguinte.
-
Se você descobriu que os resultados excluíram a biblioteca ausente do cliente, acesse http://aem-host:port/libs/granite/operations/content/diagnosis/tool.html/granite:queryperformance.
-
Insira a consulta novamente e clique em "Explicar".
-
O resultado mostra qual índice é usado para executar a consulta. Se o índice listado não for o índice "nodetype", algo estará errado.
-
Você precisaria depurar o que está causando um índice diferente para retornar uma estimativa de custo menor para a consulta. Consulte este artigo para saber como habilitar o log de depuração para análise de consulta.
-
Se o índice correto for escolhido, mas não retornar o resultado correto, ele estará corrompido. Você precisará reindexar o índice nodetype.
-
Siga os passos neste artigo para reindexar o índice de forma assíncrona.
Fazer logon em sua conta