Problemă

Eroarea „trebuie să instalați versiunea de tip vechi a Java SE 6 runtime” apare atunci când lansați orice aplicație Adobe.

Legacy Java error

Soluție

Pentru Mac OS 10.7 (Lion) și versiunile mai noi, Java runtime nu mai este instalat automat ca parte a instalării Sistemului de operare. Urmați oricare din metodele de mai jos pentru a instala Java runtime.

Metoda 1

Puteți descărca cea mai nou versiune Java runtime de pe pagina de internet Java - Descărcare gratuită soft Java.

Notă:

Pentru Mac OS 10.10 (Yosemite), atunci când lansați orice produs Adobe, puteți primi avertizarea „Aplicația a fost mutată iar adresa acesteia a fost schimbată...”.

Faceți clic pe butonul Repară acum sau Actualizare pentru actualizarea locului și rezolvarea problemei. Când vi se solicităparola, introduceți parola dvs. de sistem pentru a finaliza.

Mesaj de avertizare privind mutarea aplicației

Metoda 2

Dacă nu este instalat programul Java runtime, vi se solicită instalarea acesteia atunci când lansați prima dată produsul Adobe. Pentru a instala, urmați instrucțiunile de pe ecran din caseta de dialog de notificare a necesității programului Java.

Metoda 3 (Mac OS 10.7 și 10.8)

Utilizați metoda următoare pentru a iniția instalarea programului Java runtime sau pentru a confirma că este instalat.

  1. Accesați Aplicații > Utilități > Preferințe Java.
  2. Deschideți Preferințele Java.
  3. În cazul în care programul Java nu este instalat, primiți mesajul următor: „Pentru a deschide „Preferințele Java”, aveți nevoie de programul Java runtime. Doriți să-l instalați acum?”

    Mesajul „Programul Java nu este instalat”
  4. Faceți clic pe Instalare și acceptați acordul de licență. Programul Java runtime este descărcat și instalat.
    Progres de descărcare Java
    Preferințele Java arată că s-a instalat

Informații suplimentare

Multe aplicații Adobe depind de Oracle Java Runtime Environment (JRE) pentru ca anumite funcții să funcționeze. Recent, Apple a schimbat modul în care include Java în Mac OS, iar în cazul sistemului de operare Lion, Java nu mai este preinstalat. Acum, acesta este un program care poate fi instalat opțional dacă selectați acest lucru. 

Deoarece programele de instalare și aplicațiile Adobe au fost construite înainte de modificările efectuate de Apple, softul Adobe presupune faptul că programul Java este instalat. Adobe și Apple au colaborat pentru a se asigura că puteți instala Java în timpul instalării sistemului de operare. Sau acesta poate fi instalat ulterior, înainte de a instala aplicațiile Adobe. În faza execuției, atunci când lansați o aplicație Adobe, vi se solicită instalarea programului Java dacă nu este deja instalat. Dacă nu instalați Java înainte de a rula o aplicație Adobe, pot lipsi caracteristici sau acestea se pot comporta necorespunzător. Dacă întâmpinați probleme, instalați Java pentru a le corecta. Adobe recomandă organizațiilor corporative IT să preinstaleze Java (sau să se asigure că programul Java poate fi instalat prin paravanele de protecție/securitate) pentru a evita conflictele cu aplicațiile Adobe.

În cazul în care programul Java runtime nu este instalat, pot apărea unele probleme cunoscute, inclusiv -

  • Lansare nereușită.
  • Atunci când încercați să utilizați aplicațiile, vi se solicită instalarea programului Java runtime.
  • Aplicațiile se blochează sau se închid.

Această lucrare este oferită sub licență Atribuire-Necomercial-FărăModificări 3.0 Ne-adaptată Creative Commons  Postările pe Twitter™ şi Facebook nu sunt acoperite de condiţiile de licenţiere Creative Commons.

Prevederi legale   |   Politică de confidențialitate online