О геопространственных файлах PDF

Геопространственный файл PDF содержит информацию, необходимую для геопространственных данных местоположения. Во время импорта геопространственных данных в документ PDF программа Acrobat сохраняет геопространственные координаты. Благодаря им можно просматривать документ PDF и работать с ним, находя и отмечая данные о местоположении.

Геопространственные данные могут быть векторными, растровыми или сочетанием тех и других. После импорта геопространственных данных в Acrobat их можно использовать следующими способами:

  • Находить и отмечать координаты мест.

  • Измерять расстояние, периметр и площадь.

  • Изменять систему координат и единицы измерения.

  • Копировать координаты местоположения в буфер обмена и использовать их для указания местоположений в некоторых картографических веб-сервисах.

Создание геопространственных файлов PDF

Геопространственный файл PDF можно создать одним из следующих способов:

  • Откройте файл с геопространственной приводкой TIFF (GeoTIFF) или JPEG 2000

  • Выполните георегистрацию карты PDF или отсканированных геопространственных данных

При открытии импортированного файла измерения, положения точек и длины отображаются в виде географических координат, которые можно изменять, измерять и помечать. Можно также создать карту PDF из нескольких источников.

Открытие файлов GeoTIFF и JPEG 2000

Файлы GeoTIFF и JPEG 2000 являются растровыми изображениями, которые можно импортировать как новые документы или как новые слои существующих документов. Acrobat сохраняет встроенные в файл геопространственные координаты. Эти файлы сохраняют свои геопространственные данные при импорте. При импорте этих файлов в уже существующие документы их система координат будет преобразована в систему координат документа.

  1. Выберите меню «Файл» > «Создать» > PDF из файла.
  2. Выберите для импорта файл с геопространственной приводкой.
  3. Выберите настройки и нажмите «ОК».

Импорт файлов форм

Файл форм можно импортировать как новый слой в существующий документ PDF. Файл формы должен перекрывать текущую карту PDF. В противном случае он не импортируется. Если перекрытие частично, то импортируется только та часть, которая перекрывает текущий документ PDF.

Файл формы состоит из нескольких файлов, отличающихся расширениями имен. Для импорта в программу Acrobat необходимы файлы SHP и DBF.

  1. Откройте карту PDF и выберите Просмотр > Показать/Скрыть > Панели навигации > Слои.
  2. Выберите «Параметр» в боковом меню «Слой» и нажмите «Импортировать как слой».
  3. Перейдите к файлу SHP и выберите его.
  4. Нажмите «Параметры» и выберите в пункте «Свойства линии» сплошную линию голубого цвета.

Взаимодействие с геопространственными файлами PDF

При открытии геопространственного документа PDF можно находить местоположения, измерять расстояния и добавлять отметки местоположений. Можно также копировать координаты в буфер обмена, чтобы использовать их для картографического веб-сервиса.

Для просмотра инструментов геопространственных измерений выберите «Инструменты» > «Анализ».

Инструменты картографического местоположения на панели инструментов анализа
Инструменты картографического местоположения на панели инструментов анализа.

Используйте инструмент Картографическое местоположение для выполнения следующих задач:

  • Просмотр широты и долготы при нахождении курсора в области, содержащей геопространственную информацию.

  • Отметка местоположения с добавлением геопространственной аннотации.

  • Поиск местоположения в документе.

Поиск мест на карте

  1. Откройте геопространственный файл в формате PDF и выберите «Инструменты» > «Анализ» > Картографическое местоположение .
  2. Щелкните правой кнопкой мыши внутри карты, а затем нажмите «Найти местоположение».
  3. Введите значения широты и долготы (в градусах, минутах, секундах или десятичных дробях) в два текстовых поля и нажмите «Найти».

    Если доступно хотя бы одно местоположение, оно выделяется голубым квадратом, а центр страницы смещается к выделенному местоположению.

  4. Если файл PDF включает более одной карты, нажмите кнопку «Следующий» или «Предыдущий» для просмотра дополнительных результатов, если они есть. Несколько местоположений доступны в следующих случаях:
    • Если документ содержит несколько карт (если в файле PDF меньшая карта находится внутри большей, например карта города внутри карты области или страны). При поиске какого-либо местоположения в городе Acrobat находит его как на большей карте, так и на карте города.

    • Если документ содержит несколько страниц карты (например, на первой странице карта страны, а на второй – карта области или города в этой стране).

  5. (Необязательно) Чтобы добавить комментарий (например, название или адрес местоположения), нажмите отметку местоположения и добавьте сведения в поле комментариев.
  6. Для завершения поиска щелкните правой кнопкой мыши внутри карты. Нажмите «Скрыть поиск местоположения», чтобы удалить поля поиска.

Пометка геопространственных привязок

  1. Откройте геопространственный файл в формате PDF и выберите «Инструменты» > «Анализ» > Картографическое местоположение .
  2. Наведите указатель мыши на документ для просмотра значений широты и долготы в областях с геопространственной информацией. Щелкните правой кнопкой мыши внутри карты и выполните одно из следующих действий:
    • Чтобы найти местоположение, нажмите «Найти местоположение». Введите значения широты и долготы и нажмите «Найти».

    • Чтобы отметить местоположение с геопространственными данными, нажмите «Отметить местоположение».

  3. (Необязательно) Чтобы добавить комментарий (например, название или адрес местоположения), нажмите отметку местоположения и добавьте сведения в поле комментариев.

Измерение расстояний, периметров и площадей на карте

При открытии геопространственного файла PDF инструменты измерения Acrobat считывают геопространственные данные и выполняют измерения расстояния и площади, а не размеров страницы или объекта. Используйте эти инструменты измерения для расчета расстояния, периметра и площади в любом файле PDF с геопространственными данными. При передвижении указателя мыши по содержимому документа отображаются отметки привязки, которые указывают, что указатель находится на контуре или на конечной точке контура. Можно также увидеть широту и долготу положения курсора, когда указатель мыши находится в области геопространственных данных.

  1. Выберите «Инструменты» > «Анализ» > «Инструмент «Измерение» .
  2. На экране инструмента измерения выберите тип измерения: «Расстояние» , «Площадь» или «Периметр» .
  3. Выберите параметр привязки:
    • Привязать к контурам

    • Привязать к конечной точке

    • Привязать к срединным точкам

    • Привязать к пересечениям

  4. Выполните одно из следующих действий.
    • При использовании инструмента «Расстояние» щелкните в месте начала измерения, затем перейдите к конечной точке и щелкните в ней еще раз. Расстояние между точками отображается в нижнем правом углу.

    • При использовании инструмента «Периметр» щелкните один угол карты, а затем перемещайте указатель к каждому последующему углу. Щелкните мышью в каждом углу и дважды щелкните в конечной точке. В информационном окне отображается величина периметра.

    • При использовании инструмента «Площадь» щелкните мышью в одном углу карты, а затем переместите указатель в другой угол. Щелкните перед каждым изменением направления. Дважды щелкните в конце для отображения всей площади.

  5. Чтобы завершить измерение, щелкните правой кнопкой мыши и выберите «Завершить измерение». Можно также выбрать пункт Отменить измерение.

Копирование координат местоположения в буфер обмена для использования их с картографическим веб-сервисом

Координаты найденного местоположения в геопространственном файле PDF можно скопировать в буфер обмена. Из буфера обмена данные можно вставить в картографический веб-сервис, который считывает координаты широты и долготы.

  1. Выберите «Инструменты» > «Анализ» > Картографическое местоположение , а затем щелкните правой кнопкой мыши местоположение на карте и выберите «Отметить местоположение».
  2. Откройте комментарии местонахождения и скопируйте информацию о местонахождении.

    Acrobat копирует данные в следующем формате: широта и долгота, разделенные пробелом. Вставьте данные в адресную строку картографического веб-сервиса, чтобы интерпретировать данные местоположения.

Изменение единиц измерения в документе

Чтобы изменить тип единиц измерения, щелкните правой кнопкой мыши внутри карты, содержащей инструмент измерения, и выберите пункт «Единица расстояния» или «Единица площади». Выберите тип измерения.

Изменение настроек геопространственных измерений

В диалоговом окне «Установки» можно изменить единицы измерения для всех геопространственных файлов PDF. Нажмите кнопку «Измерение» (Geo) в разделе «Категории».

Включить разметку измерений

Добавляет метку к геопространственному измерению. Если выбран пункт «Включить разметку измерений», нажмите «Использовать метку» и введите метку для измерений.

Параметры привязки

Выберите части пути, чтобы привязать к ним измерения.

Отобразить значение как

Определяет способ расчета значений широты и долготы. Выберите «Десятичное» для отображения широты и долготы в виде десятичной дроби. Выберите «Градусы, минуты, секунды», чтобы разделить каждый градус долготы на 60 минут, каждая из которых делится на 60 секунд.

Отобразить направление как

Выберите между вариантами «Подписанное» и «Именованное». В именованном направлении рядом с пунктом «Широта» отображается N (север) или S (юг), а рядом с пунктом «Долгота» – E (восток) или W (запад).

Всегда показывать широту и долготу в формате WGS 1984

Выберите этот пункт, чтобы убедиться, что при измерении широты и долготы используется действующий картографический стандарт WGC (World Geodetic System 1984). В более старых картах, созданных на основе более ранней сетки (например, NAD 1927), этот параметр можно отменить для просмотра исходных значений карты. Если старая карта зарегистрирована в своей исходной системе координат, положения координат могут отличаться от текущих стандартов, используемых в устройствах GPS и картографических веб-сервисах.

Использовать единицу расстояния по умолчанию

Выберите единицу измерения.

Использовать единицу площади по умолчанию

Площадь можно измерять в единицах, отличных от единиц измерения расстояния.

Не показывать слои прозрачности в изображениях GeoTIFF и JPEG 2000

Форматы растровых изображений содержат слой прозрачности, который можно удалить.

Экспорт местоположения и пометка измерений

Можно экспортировать геопространственные данные местоположения и измерения в файл FDF. Каждая геопространственная аннотация содержит элемент GPTS. Этот элемент соответствует широте и долготе для каждой точки аннотации. Существуют следующие типы экспортируемой информации:

  • Отмеченные местоположения, введенные с помощью инструмента «Геопространственное положение»

  • Измерения расстояния, периметра (суммарного расстояния) и площади, введенные с помощью инструмента «Измерение» для геопространственных данных

Геопространственные данные можно экспортировать с помощью панели «Список комментариев».

  1. Чтобы экспортировать все комментарии, откройте панель «Список комментариев» и нажмите «Параметры» > «Экспорт всех элементов в файл данных».

  2. Чтобы экспортировать подмножество комментариев, выберите нужные комментарии, а затем нажмите «Параметры» > «Экспорт выбранных комментариев». Введите имя файла и нажмите «Сохранить». Файл FDF будет сохранен.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет