Узнайте о новых возможностях в последнем выпуске After Effects CC.
after-effects

В выпуске After Effects CC (версия 16.0) в октябре 2018 года внедрены новые потрясающие функции для разработчиков визуальных эффектов, редакторов графики и аниматоров. В статье приводятся сведения о новых функциях и ссылки на дополнительные ресурсы.


Усовершенствованный инструмент «Марионетка»: новые усовершенствованные булавки и булавки сгибания

Изучите новые способы анимации с помощью новых усовершенствованных булавок и булавок сгибания в инструменте «Марионетка».

FM_Banners_Ae_WhatsNew

Управляйте анимацией с более высокой точностью и возможностью переключения между типами булавок, используя усовершенствованную булавку, которая позволяет масштабировать и поворачивать сетку с высокой точностью. Булавка сгибания позволяет создавать различные деформации путем искривления и сгибания анимаций. Булавка сгибания вращает или масштабирует марионеточную сетку, но с учетом размещения других булавок в сетке.

Дополнительные сведения см. в разделе Типы булавок в усовершенствованном инструменте «Марионетка».

Фильтры глубины для 3D-композиций

Теперь эффекты 3D-канала способны извлекать данные о глубине 3D-сцены из вложенной композиции с 3D-слоями.


Этот и другие связанные с глубиной эффекты можно найти среди эффектов 3D-канала. Их можно использовать для применения к слою композиции 3D-эффектов глубины, таких как размытие глубины поля, или для создания подложки для формирования глубины или цветокоррекции.

Процесс рендеринга Classic 3D или Cinema 4D может генерировать фильтры глубины для 3D-слоев. Фильтр глубины позволяет комбинировать одни объекты за другими или применять эффекты, которые изменяются с расстоянием, такие как глубина поля.

Дополнительные сведения см. в разделе Каналы глубины для 3D-композиций.

Усовершенствования выражений

Новый движок JavaScript для выражений

After Effects использует обновленный движок JavaScript, что позволяет применять современные методы программирования. Выражения могут вычислять до 5 раз быстрее, в зависимости от выражения. Хотя новый движок JavaScript совместим с традиционным движком ExtendScript, между ними есть различия. Для использования нового движка JavaScript может потребоваться переписать некоторые выражения. Один из двух движков можно выбрать в настройках проекта.

Дополнительные сведения см. в разделе Выражения: движок JavaScript.

Улучшения редактора и пользовательского интерфейса

  • Улучшения редактора: поле выражения на панели «Таймлайн» получило следующие улучшения:
    • Моноширинный шрифт: в поле редактора выражений теперь используется шрифт Source Code Pro.
    • Автоматическое изменение размера: теперь, если щелкнуть поле редактора выражений, оно автоматически регулируется, чтобы показать как можно большую часть выражения.
  • Включение или отключение всех выражений на выбранных слоях: все выражения на слое теперь можно отключить или включить с помощью двух новых команд в подменю Слой > Переключатели или щелкнув слой правой кнопкой мыши и открыв подменю Переключатели.
  • Улучшения баннера ошибок выражений: баннер ошибок выражений (оранжевая полоса, которая появляется на панели «Композиция», когда выражение не удается оценить) обновлен.
    • Более темные кнопки на баннере.
    • Данный баннер можно скрыть с помощью кнопки «Скрыть баннер ошибок выражений». Эта кнопка отключает флажок Показывать баннер с предупреждением, когда проект содержит ошибки выражений в разделе Установки > Общие. Чтобы снова отобразить баннер ошибок выражений, установите этот флажок.

Новые методы и атрибуты

В этом выпуске появились следующие методы и атрибуты для справочника выражений:

Гибкий дизайн — время


Анимационная графика включает в себя ключевые кадры. Когда изменяется длина композиции, ключевые кадры также необходимо скорректировать. В случае итераций это ведет к повторяющейся работе. Возможности гибкого дизайна в After Effects позволяет создавать графику, которая адаптируется к последующим изменениям. Раздел «Гибкий дизайн — время» в After Effects делает возможным адаптивное растягивание по времени, когда композиция вкладывается или экспортируется как шаблон анимационного дизайна. При регулировании точек входа и выхода композиции длительность защищенных областей сохраняется, а незащищенные области растягиваются по времени.

Дополнительные сведения см. в разделе Добавление возможностей гибкого дизайна в графику .

Улучшения шаблонов анимационного дизайна

Инфографика и шаблоны анимационного дизайна (53 с)

Панель «Основные графические элементы» позволяет группировать элементы управления, управлять свойствами шрифтов и добавлять в шаблон анимационного дизайна элементы управления для источников данных электронных таблиц в формате CSV и TSV. Можно приложить файл данных электронной таблицы к композиции и добавить данные на соответствующую панель «Основные графические элементы». Можно редактировать эти данные на панели, а также экспортировать их как шаблоны анимационного дизайна в Premiere Pro. 

Теперь в Premiere Pro можно добавлять пользовательские таблицы в управляемый данными шаблон анимационного дизайна After Effects (MOGRT) и управлять анимацией или вносить изменения в данные MOGRT.

Дополнительные сведения см. в разделе Шаблоны анимационного дизайна в After Effects.

Элементы управления кривыми цвета Lumetri

Кривые цветового тона и насыщенности можно использовать для цветокоррекции изображений
Кривые цветового тона и насыщенности можно использовать для цветокоррекции изображений

Инновационные новые инструменты коррекции с помощью кривых делают выборочную цветокоррекцию простой и непосредственной операцией. Две оси позволяют настраивать значения от оттенка к оттенку и от оттенка к яркости с четким визуальным представлением. Такой подход обеспечивает точность, позволяющую использовать догадки на основе коррекции с помощью кривых.

Дополнительные сведения см. в разделе Селективная цветокоррекция с помощью кривых цветокоррекции.

Интеграция Adobe Animate и Adobe XD

Импорт из Adobe Animate

Документы Adobe Animate CC (.fla) теперь можно импортировать в After Effects как композиции многоуровневых файлов .swf. Убедитесь, что на том же компьютере установлена версия Animate 19.0.

Дополнительные сведения см. в разделе Импорт FLA-файлов в After Effects.

Экспорт в After Effects из Adobe XD

Экспорт в After Effects из Adobe XD
Экспорт в After Effects из Adobe XD

В этом выпуске Adobe XD CC реализована возможность экспорта слоев и монтажных областей в проект After Effects. Эта возможность обеспечивает беспроблемную передачу ресурсов между XD и After Effects. Данный процесс включает встроенное сопоставление слоев, монтажных областей, векторов, текста и графических объектов.

Дополнительные сведения см. в разделе Работа с Adobe XD и After Effects.

Улучшения VR

Поддержка VR 180

В этом выпуске After Effects есть возможность создания и предварительного просмотра содержимого с эффектом погружения с полем зрения 180 градусов. Композицию на головном дисплее можно просматривать в двух новых стереоскопических режимах с полем зрения 180 градусов:

  • 180 — вертикальная стереопара
  • 180 бок о бок

Новый театральный режим и стереоскопические режимы с полем зрения 180 градусов в среде Adobe с эффектом погружения

В этом выпуске After Effects введен театральный режим (прямолинейный) для предварительного просмотра композиции в форме плоского прямоугольника в пустой комнате, имитируя вид на киноэкран.

Дополнительные сведения см. в разделах Предпросмотр видеоряда в гарнитуре.

Новые свойства для управления эффектами погружения

Видеоэффекты с эффектом погружения (кроме конвертера VR и «сфера VR в плоскость») включают новые настройки для управления способом их применения.

  • Стереоскопический клип (горизонтальная видеопара): параметру «Расположение кадров» помимо существующих вариантов моноскопического или стереоскопического расположения (вертикальная стереопара) можно задать вариант «Стереоскопический клип (горизонтальная видеопара)».
  • Горизонтальное и вертикальное поле зрения: горизонтальное и вертикальное поле зрения можно задавать независимо. Значения по умолчанию: 360x180. Для содержимого VR 180 для обоих значений задано 180.

Дополнительные сведения см. в разделе Применение видеоэффектов с эффектом погружения.

Улучшения производительности

Новые эффекты с ускорением за счет графического процессора

Если параметру Настройки проекта > Рендеринг и эффекты видео > Использовать задать значение Ускорение Mercury с использованием ГП, теперь для рендеринга следующих эффектов используется графический процесс компьютера:

  • Цветовой баланс (HLS)
  • Кривые
  • Заливка
  • Экспозиция
  • Линейное стирание
  • Шум
  • Трехкрасочный
  • Настроить подложку
  • Жалюзи

Улучшение расчета эффекта «Волнообразная деформация»

Эффект «Волнообразная деформация» вычисляется с использованием нескольких потоков и визуализируется до 3 раз быстрее благодаря использованию нескольких процессорных ядер.

Улучшение алгоритма для эффекта «Медиана»

Эффект «Медиана» обновлен с учетом нового алгоритма, который ускоряет рендеринг по сравнению с прежним алгоритмом для эффекта «Медиана». Новый алгоритм поддерживает цвета глубиной 32 бита на канал. В нем по-другому выполняется рендеринг на границах слоев, поэтому After Effects сохраняет прежний алгоритм как отдельный эффект «Медиана» (предыдущая версия). В проектах, сохраненных в предыдущих версиях After Effects, для сохранения результатов рендеринга применяется эффект «Медиана (предыдущая версия)».

Улучшение поддержки форматов видео и аудио

Встроенное декодирование кодеков HAP в файлах QuickTime

Теперь версия After Effects 16.0 способна самостоятельно декодировать видеоряд с кодеками HAP, HAP Alpha, HAP Q и HAP Q в файлах QuickTime.

Дополнительные сведения см. в разделе Поддерживаемые форматы файлов | After Effects CC.

Новый внешний модуль Mocha AE CC

В состав After Effects 16.0 входит внешний модуль Mocha AE CC от компании Imagineer Systems из корпорации Boris FX. Он заменяет автономное приложение Mocha AE, которое было включено в предыдущие выпуски After Effects. Новый внешний модуль с новым интерфейсом обеспечивает такое же точное планарное отслеживание и поддерживает ускорение с использованием графического процессора.

Дополнительные сведения см. в разделе Работа с внешним модулем Mocha AE CC.

Другие улучшения

Улучшения пользовательского интерфейса

  • В After Effects теперь используется Adobe Clean UX в качестве пользовательского интерфейса.
  • Треугольник раскрытия (спиральная стрелка) обновлен до открытого треугольника.
  • Теперь легче найти и идентифицировать эффекты, ускоряемые с использованием графического процессора, или определить, включено ли ускорение Mercury с использованием ГП для открытого проекта.
    • На панели Эффекты и шаблоны, отфильтровав список эффектов, можно отобразить только эффекты, ускоряемые с использованием ГП. Нажмите меню панели и выберите Показать только эффекты с поддержкой ГП.
    • На панели Элементы управления эффектами рядом с именами эффектов, ускоряемых с использованием ГП, отображается эмблема ускорения с использованием ГП.
    • Внизу панели «Проект» значок ракеты показывает, настроен ли данный проект на ускорение Mercury с использованием ГП. Яркий значок ракеты означает, что проект настроен на ускорение Mercury с использованием ГП. Тусклый значок ракеты со значком кнопки питания указывает на то, что проект настроен только на программное ускорение Mercury. Щелкните значок ракеты, чтобы открыть вкладку Настройки проекта > Рендеринг и эффекты видео. Здесь можно включить или отключить ускорение Mercury с использованием ГП и выбрать используемую технологию ГП.

Задание положения направляющих линий

Для направляющих линий можно задать точное положение в пикселах. Создав направляющую линию (перетаскиванием от горизонтальной или вертикальной линейки), щелкните правой кнопкой мыши и выберите Изменить положение. Затем введите новое положение, указав число пикселов по горизонтали или вертикали от исходной точки композиции (левый верхний угол).

Установка сценариев и панелей ScriptUI из пользовательского интерфейса

Сценарии After Effects или панели ScriptUI можно установить, выбрав новые команды на панели Файл > Сценарии или перетащив файлы сценариев на панель Проект, удерживая нажатыми клавиши-модификаторы. Сценарии, установленные любым из этих методов, копируются в папку установок текущего пользователя и появляются в меню Файл > Сценарии или меню Окно (для панелей ScriptUI) после перезапуска After Effects.

В этом выпуске внесены изменения в метод перетаскивания. Если перетащить файл .jsx на панель «Проект» без использования клавиши-модификатора, файл импортируется как элемент видеоряда источника данных, а не устанавливается как сценарий. Возможность установки сценариев в папку установок путем перетаскивания появилась в After Effects 12.2. Однако она была отключена в After Effects 15.1, когда была добавлена поддержка библиотек пользовательских функций выражений в файлах .jsx.

Новый домашний экран и кнопка «Домой»

Домашний экран After Effects при первом запуске программы
Домашний экран After Effects при первом запуске программы

Теперь при запуске After Effects отображается домашний экран, на котором предусмотрены варианты создания нового проекта или открытия уже существующего проекта.

Можно также в любой момент открыть домашний экран, нажав кнопку с изображением дома на панели инструментов слева от инструмента выделения.

Возможности домашнего экрана расширяются по мере того, как вы используйте After Effects. Содержимое домашнего экрана изменяется в зависимости от того, насколько хорошо вы освоили After Effects и какой у вас вариант подписки Creative Cloud.

Дополнительные сведения см. в разделе Использование домашнего экрана и навигация по нему.

Новые панель и рабочее пространство «Обучение»

Панель «Обучение» помогает новым пользователям быстро создавать композиции и знакомит с возможностями панелей управления, таймлайном и эффектами.

Панель «Обучение» и рабочая среда «Обучение»
Панель «Обучение» и рабочая среда «Обучение»

Панель содержит следующую информацию:

  • Обзор After Effects
  • Основы «Обучения»

Новая рабочая среда «Обучение» — это упрощенный интерфейс, который содержит всего четыре панели (панель «Обучение», панель «Композиция», панель «Проект» и панель «Таймлайн») и помогает новым пользователям начать работу с After Effects. Панель «Обучение» закреплена сбоку, чтобы вы видели инструкции и при этом могли свободно пользоваться остальными функциями рабочей среды.

Дополнительные сведения см. в разделе Использование рабочей среды и панели «Обучение».

Другие изменения

  • Сохранение файлов проектов для предыдущей версии обновлено: введена команда «Сохранить копию в формате CC (15.x)» или «Сохранить копию в формате CC (14.x)». Чтобы в After Effects 16.0 сохранить проект для версии 13.x, сначала сохраните его для версии 15.x или 14.x, затем откройте проект в одной из этих версий и сохраните копию для версии 13.x.
  • Подтверждение удаления нескольких пустых папок на панели «Проект» больше не запрашивается, если все папки пусты.
  • Удален параметр «Согласовать с гаммой After Effects QuickTime старых версий» в разделе Настройки проекта > Цвет.
  • Панель «Создать пустые значения на основе контуров» теперь создает пустые значения прямо над слоями, содержащими выбранные контуры, а не наверху стека слоев.
  • Внешний модуль Synthetic Aperture Color Finesse не входит в состав After Effects.
  • Модуль рендеринга 3D-композиций с трассировкой лучей признан устаревшим. Для улучшения производительности рекомендуется создавать новые 3D-композиции только с помощью модулей рендеринга CINEMA 4D или Classic 3D.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет