Пользователи операционной системы Ubuntu 10.x и 11.x Linux иногда видят пустой или черный экран при воспроизведении защищенных видеоданных в Flash Player 11. (Например, проблема возникает в службах, таких как Amazon Instant Video.) Это происхдит из-за отсутствующего модуля Ubuntu HAL (Hardware Abstraction Layer), который не установлен по умолчанию. Если поставщик предоставляет сообщения об ошибках, пользователи видят ошибку DRM 3323 или 3322.

Предварительные условия для воспроизведения защищенного содержимого

Для Ubuntu 10.04 или более поздних версий удостоверьтесь, что модуль Hardware Abstraction Layer предварительно установлен с помощью apt-get.
(Внимательно следите за появлением ошибки с установкой «hal»,так как установка поврежденного пакета может продолжить влиять на воспроизведение видео.)

sudo apt-get install hal

После завершения установки библиотеки "libhal" (HAL) закройте браузер и очистите каталоги Adobe Access, выполнив следующую команду из оболочки:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Примечание.

Если модуль Hardware Abstraction Layer отсутствует, то Flash Player будет продолжать работать. Однако он не может воспроизвести защищенное содержимое, которое требует модуль Adobe Flash Access DRM (Digital Rights Management).

Поддержка целевых 64-разрядных версий Linux

Adobe указала поддержку платформы 32- и 64-разрядных версий Linux в системных требованиях на сайте Flash Player 11. В настоящее время поддерживаются дистрибутивы (32- и 64-разрядные версии) Redhat Enterprise Linux 5.6 или более поздние версии и Ubuntu 10.04 или более поздние версии.

Также поддерживается openSuse.

Установите правильную версию 32- или 64-разрядного внешнего модуля Flash Player

Перейдите на страницу http://www.adobe.com/go/flashplayer для установки последней версии Flash Player для вашей платформы и архитектуры.

Если вы не уверены, какой пакет Linux установить, щелкните У вас другая операционная система или браузер? для получения расширенного списка поддерживаемых операционных систем.

openSuse и другие версии Linux

Некоторые дистрибутивы Linux имеют собственный способ управления пакетами, в частности openSUSE. openSUSE использует RPM как исходный формат пакетов. Тем не менее, он имеет собственный высокоуровневый инструмент для управления установкой системного программного обеспечения.
.rpm не всегда «гладко» устанавливается в openSuse (32- и 64-разрядные версии). Иногда выдается общая ошибка «Сообщение осталось без ответа (ожидание шиной сообщений)».

В таких случаях вместо этого загрузите архив .tar.gz и поместите Flash Player (файл libflashplayer.so) в следующее место:

/usr/lib/adobe-flashplugin/libflashplayer.so

Тестирование воспроизведения защищенных видеоданных с помощью демо-версии проигрывателя

  1. Запустите контейнер демо-версии видеопроигрывателя Adobe: http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html
     
      Запишите версию Adobe Flash Player, находящуюся в левом нижнем углу оболочки. Убедитесь, что версия имеет номер 11.2 или выше
       
  2. Воспроизведение защищенного содержимого (для примера).
     
      Введите следующий адрес в поле "Input the video URL: (чувствительно к регистру)
      http://drmtest2.adobe.com:8080/Content/anonymous.f4v
       
  3. Нажмите кнопку [Воспроизведение] в нижней части видеоконтейнера.

Защищенное содержимоге anonymous.f4v воспроизводится. (Это видео называется видео Getty «train».)

 

Затронутые продукты

Adobe Flash Player 11, Flash Access (FAXS), Ubuntu 10.x и 11.x Linux

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет