В настоящем документе описан процесс установки дополнительного внешнего модуля OpenEXR Alpha.

Дополнительный модуль OpenEXR Alpha предоставляет альтернативный метод обработки данных канала 'A' при открытии файла OpenEXR. Вместо непосредственного преобразования данные канала 'A' в прозрачность (как происходит, например, в старой версии внешнего модуля OpenEXR), канал 'A' открывается в OpenEXR Alpha как альфа-канал.

Фон

Photoshop CS2 в целом не поддерживал прозрачность в 32-разрядной версии. В этой версии было реализовано обходное решение, с помощью которого можно преобразовать данные прозрачности в альфа-канал. В Photoshop CS3 была реализована поддержка прозрачности для 32-разрядной версии, обеспечивая совместимость со спецификацией OpenEXR. Прозрачность таким образом больше не преобразовывалась непосредственно в альфа-канал во время составления канала.

Приступая к работе

Для установки модуля OpenEXR Alpha требуются права локального администратора. Если вы используете Mac OS, Windows Vista или Windows 7, в системе иногда предлагается ввести имя и пароль учетной записи администратора. Если вы используете Windows XP, перед началом работы войдите в систему, используя локальную учетную запись администратора.

Пользователи Windows: в некоторых шагах, описанных в настоящей технической заметке, указываются файлы с полным именем, включая расширения (например, OpenEXR Alpha.8bi). В Windows расширения известных типов файлов не отображаются по умолчанию. Чтобы включить видимость для расширений файлов, выполните следующие действия:

  1. В проводнике Windows выберите «Инструменты» > «Свойства папки» (Windows XP) или «Упорядочить» > «Свойства папок и поиска» (Windows 7 и Vista).
  2. Выберите вкладку «Вид» вверху окна «Свойства папки».
  3. В области «Дополнительные настройки» на вкладке «Вид» снимите флажок «Скрывать расширения известных типов файлов».
  4. Нажмите кнопку «ОК».

Пользователи Windows: в некоторых из описанных в этом документе шагах требуется определить, какая используется версия Windows — 32- или 64-разрядная. Чтобы определить используемую версию Windows, см. раздел Как определить, используется ли 32- или 64-разрядная версия ОС Windows.

Совместимость

В ОС Windows внешний модуль OpenEXR Alpha не совместим с версиями Photoshop, предшествующими CS5. Он не загружается в Photoshop CS3 или CS4.

В Mac OS внешний модуль OpenEXR Alpha не загружается на компьютеры PPC.

Установка внешнего модуля OpenEXR Alpha для Photoshop CS5 в системе Mac или Windows (загрузка обновления с веб-сайта Adobe)

Чтобы установить внешний модуль OpenEXR Alpha путем загрузки обновления с веб-сайта Adobe, выполните следующие действия:

  1. Загрузите сжатый модуль:

  2. Выйдите из Photoshop CS5.
  3. Распакуйте загруженный файл.
  4. Перетащите внешний модуль в папку внешних модулей Photoshop.
    • Для 32-разрядной версии Windows: перетащите файл OpenEXR Alpha.8bi из папку Win32 в папку /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Для 64-разрядной версии Windows / 64-разрядной версии Photoshop: перетащите файл OpenEXR Alpha.8bi из папки Win64 в папку /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Для 64-разрядной версии Windows / 32-разрядной версии Photoshop: перетащите файл OpenEXR Alpha.8bi из папки Win32 в папку /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Mac OS: перетащите файл OpenEXR.plugin в папку /Applications/Adobe Photoshop CS5/Plug-ins/File Formats.
  5. Запустите приложение Photoshop CS5.

Использование внешнего модуля OpenEXR Alpha

Чтобы открыть файл EXR, выполните следующие действия:

  1. Запустите приложение Photoshop CS5.
  2. Выберите «Файл» > «Открыть».
  3. Перейдите к файлу EXR, который необходимо открыть. В списке файловых форматов выберите OpenEXR Alpha. В Photoshop данные канала 'A' обрабатываются в качестве альфа-канала вместо прозрачности.

Чтобы экспортировать файл EXR, выполните следующие действия:

  1. Выберите «Файл» > «Сохранить как».
  2. В списке файловых форматов выберите OpenEXR Alpha.

  3. Выберите параметр «Сохранять: альфа-каналы». Таким образом данные альфа-канала будут сохраняться.

Примечание. Прозрачность добавляется после сведения открытого файла.

Примечание. Даже после установки внешнего модуля OpenEXR Alpha остается возможность выбора старой версии OpenEXR в списке файловых форматов. Этот внешний модуль обрабатывает данные канала ‘A’ в качестве прозрачности. Это является поведением по умолчанию в Photoshop начиная с Photoshop CS3 (версия 10.0).

Дополнительные примечания

Другая примечательная особенность поведения при использовании дополнительного внешнего модуля:

  • Предварительно помноженные композиции не поддерживаются.
  • Если открывать файл двойным щелчком, в Photoshop CS5 всегда используется формат OpenEXR Alpha вместо OpenEXR.
  • При открытии файла с двумя или более альфа-каналами, в формате OpenEXR Alpha альфа-каналы не сохраняются. Они полностью удаляются.
  • (Mac OS): в диалоговом окне «Сохранить» элемент OpenEXR Alpha находится в самом верху. Он не отображается в алфавитном порядке рядом с элементом Open EXR.
  • (Windows): чтобы включить поведение OpenEXR, выберите пункт меню «Файл» > «Открыть как» и затем выберите OpenEXR.
     

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет