När du distribuerar ett formulär skapar Acrobat automatiskt en PDF-portfölj för att samla in data som skickas in av användarna. Som standard spara denna fil i samma mapp som originalformuläret och döps till filnamn_responses. Du kan använda denna fil för att bearbeta insända formulär.

Adobe recommends

Adobe recommends
<a href="https://tv.adobe.com/watch/acrobat-x/managing-form-data/">Videosjälvstudie: Hantera formulärdata</a>
Timothy Plumer, Jr.

Samla in användardata

  1. Öppna det insända formuläret när en användare har skickat det.
  2. Välj något av följande i dialogrutan Lägg till ifyllda formulär till svarsfilen:

    Lägg till i en befintlig svarsfil

    Kompilerar informationen i svarsfilen som du skapade när du använde guiden Distribuera formulär för att skicka ut formuläret. (Klicka vid behov på Bläddra för att leta reda på svarsfilen.)

    Skapa en ny svarsfil

    Skapar en ny svarsfil med det namn och på den plats du anger.

Svarsfilen öppnas när du klickar på OK. Varje returnerat formulär som läggs in i svarsfilen visas som en komponentfil i en PDF-portfölj.

Kompilera formulärdata

  1. Öppna Acrobat och välj Verktyg > Formulär > Fler formuläralternativ > Kompilera returnerade formulär.
  2. Gör något av följande i dialogrutan Kompilera data för att välja en PDF-svarsfil:
    • Klicka på Bläddra, leta reda på och välj svarsfilen.

    • Skriv sökvägen till svarsfilen.

  3. Klicka på Lägg till fil och navigera sedan till det returnerade formuläret.
  4. Upprepa föregående steg så många gånger som behövs för att lägga till ytterligare returnerade formulär.

När du klickar på OK infogas data från de valda formulären i svarsfilen. Varje returnerat formulär visas som en komponentfil i en PDF-portfölj.

Lägga till användardata i en befintlig svarsfil

  1. Öppna svarsfilen i Acrobat.
  2. Klicka på Lägg till i den vänstra navigeringspanelen.
  3. Klicka på Lägg till fil i dialogrutan Lägg till returnerade formulär. Leta reda på och välj de returnerade formulären och klicka sedan på Öppna.
  4. Upprepa föregående steg för att lägga till returnerade formulär som finns i andra mappar. Klicka på OK när du är klar.

När du är klar visas varje inlagt PDF-formulär som en komponentfil i PDF-portföljen.

Exportera användardata från en svarsfil

Använd den här processen när du vill spara alla poster i en PDF-portföljs svarsfil i en kalkylblads- eller XML-fil.

  1. Öppna svarsfilen i Acrobat och markera de data som ska exporteras.
  2. Klicka på Exportera i den vänstra navigeringspanelen.
  3. Ange namn, plats och filformat (CSV eller XML) för formulärdata i dialogrutan Välj mapp där filen ska sparas och klicka sedan på Spara.

Hantera formulärdatafiler

Du kan flytta svaren för ett PDF-formulär till och från andra filformat som kräver mindre utrymme än en fullständig PDF-fil.

Importera formulärdata

I vissa situationer kan personer skicka in ifyllda formulär som datafiler i stället för som fullständiga PDF-filer. Dessa filer är inte PDF-filer utan har ett annat filformat, t.ex. FDF eller XML. Du kan visa data som har skickats av en enskild person i ett PDF-sammanhang genom att öppna den ursprungliga PDF-filen och sedan importera informationen från datafilen.

  1. Gå till Acrobat och öppna PDF-formuläret som du vill importera data till.
  2. Välj Verktyg > Formulär > Rensa formulär.

    Obs!

    När du importerar data från en annan fil till ett PDF-formulär, ersätter importerade data den information som eventuellt redan finns i de olika formulärfälten. Om den importerade datafilen däremot innehåller ett eller flera tomma formulärfält, kommer importen inte att rensa bort ursprungliga data.

  3. Välj Verktyg > Formulär > Fler formuläralternativ > Hantera formulärdata > Importera data.
  4. Använd dialogrutan Välj filen som innehåller formulärdata för att välja ett filtypsformat som motsvarar den datafil du tänker importera. Leta reda på och markera filen och klicka sedan på Öppna.

    Obs!

    Vissa format är bara tillgängliga för specifika typer av PDF-formulär beroende på vilket program som har använts för att skapa formuläret, t ex Acrobat eller Designer ES2. Data som du importerar från en textfil (.txt) måste vara formaterade i tabbavgränsade rader uppställda i kolumner.

Exportera fildata

Du kan spara informationen i ett ifyllt PDF-formulär som en datafil i ett annat filformat. Senare kan du återanvända dessa data för att fylla i formuläret igen eller för att fylla i ett annat formulär som innehåller samma fält och fältnamn.

  1. Öppna den ifyllda formulärfilen i Acrobat.
  2. Välj Verktyg > Formulär > Fler formuläralternativ > Hantera formulärdata > Exportera data.
  3. Välj i vilket format (FDF, XFDF, XML eller TXT) formulärdata ska sparas i dialogrutan Exportera formulärdata. Välj plats och filnamn och klicka sedan på Spara.

    Obs!

    En del filformat är bara tillgängliga för specifika typer av PDF-formulär beroende på hur formuläret skapades.

Sammanfoga exporterade datafiler till ett kalkylblad

Om du vill kompilera data från formulär som inte redan finns i en datauppsättning följer du nedanstående instruktioner.

  1. Välj Verktyg > Formulär > Fler formuläralternativ > Hantera formulärdata > Sammanfoga datafiler i kalkylblad.
  2. Klicka på Lägg till filer i dialogrutan Exportera data från flera formulär.
  3. Välj ett filformat (Acrobat-formulärdatafiler eller Alla filer) i Fil av typen i dialogrutan Välj filen som innehåller formulärdata. Leta reda på formulärfilerna som du vill sammanfoga till kalkylbladet, markera dem och klicka sedan på Öppna.
  4. Upprepa föregående steg om du behöver lägga till formulärdatafiler som finns på andra platser.
  5. Klicka på Exportera. Välj mapp och filnamn för kalkylbladet och klicka sedan på Spara.
  6. I dialogrutan Exportförlopp klickar du på Visa fil nu om du vill öppna kalkylbladsfilen, eller på Stäng dialogrutan om du vill återgå till Acrobat.

Obs!

När returnerade formulär finns i en svarsfil, exporterar du smidigast informationen till ett kalkylblad genom att använda knappen Exportera data i vänstra navigeringsfältet för PDF-portföljens svarsfil.

Om Formulärspåraren

Använd Spåraren för att hantera de formulär som du har distribuerat eller tagit emot. Spåraren gör det möjligt för dig att visa och redigera plats för svarsfilen för ett formulär, hålla reda på vilka mottagare som har svarat, lägga till fler mottagare, skicka e-post till alla mottagare och se alla svar.

Spåra formulär

  1. I Acrobat väljer du Redigera > Formuläralternativ > Spåra eller Visa > Spårare.

  2. Expandera Formulär i den vänstra navigeringsrutan.

  3. Markera ett formulär och gör något av följande:

    • Om du vill visa alla svar för ett formulär klickar du på Visa svar.

    • Om du vill ändra svarsfilens plats går du till Svarsfilens plats och klickar på Redigera filplats.

    • Om du vill visa originalformuläret klickar du på Öppna originalformulär.

    • Om du vill skicka formuläret till fler mottagare klickar du på Lägg till mottagare.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy