Flash-filer

I Flash Professional kan du arbeta med ett flertal olika filtyper, som alla har olika syften:

  • FLA-filer, som är de filer du primärt arbetar med i Flash Professional, innehåller grundläggande medie-, tidslinje- och skriptinformation för Flash Professional-dokument. Medieobjekt är grafik-, text-, ljud- och videoobjekt som utgör innehållet i Flash Professional-dokument. Tidslinjen används för att ange för Flash Professional när de olika medieobjekten ska visas på scenen. Du kan lägga till ActionScript®-kod i Flash Professional-dokument för att mera noga styra deras beteende och få dem att svara på användarinteraktioner.

  • Okomprimerade XFL-filer påminner om FLA-filer. En XFL-fil, och andra associerade filer i samma mapp, är helt enkelt okomprimerade motsvarigheter till en FLA-fil. Detta format gör det enklare för användargrupper att arbeta med olika element i ett Flash-projekt samtidigt. Mer information finns i Arbeta med okomprimerade XFL-filer.

  • SWF-filer, de kompilerade versionerna av FLA-filer, är de filer som du visar på en webbsida. När du publicerar FLA-filen skapas en SWF-fil automatiskt i Flash Professional.

    SWF-filformatet i Flash Professional är en öppen standard som stöds av andra program. Mer information om filformat i Flash Professional finns i www.adobe.com/go/flashplayer_se.

  • AS-filer är ActionScript-filer. Du kan använda dessa filer för att hålla en del eller all ActionScript-kod utanför FLA-filerna, vilket är praktiskt för att hålla ordning på koden och för projekt där flera personer arbetar på olika delar av Flash Professional-innehållet.

  • SWC-filer innehåller återanvändbara Flash Professional-komponenter. Varje SWC-fil innehåller ett kompilerat filmklipp, ActionScript-kod och alla andra objekt som komponenten behöver.

    Obs! (Endast Flash Professional CC) Det går inte att importera SWC-filer till Flash Pro.

  • ASC-filer används för att lagra ActionScript som körs på en dator med Flash Media Server. Med dessa filer kan du implementera serversideslogik som fungerar i kombination med ActionScript i en SWF-fil.

    Obs! ASC-filer stöds inte i Flash Professional CC.

  • JSFL-filer är JavaScript-filer som du kan använda för att lägga till nya funktioner i utvecklingsverktyget Flash Professional.

Adobe rekommenderar

Adobe rekommenderar
<a href="http://goo.gl/1iL8L">Introduktion till Flash Professional</a>
Todd Perkins

I följande extrafilmer och självstudier visas hur du arbetar med Flash Professional. I vissa videofilmer kan Flash Professional CS3 eller CS4 visas, men de gäller trots detta även för Flash Professional CS5.

Arbeta med andra Adobe-program

Flash har utformats för att fungera med andra Adobe®-program, vilket ger ett brett intervall av kreativa arbetsflöden. Du kan importera Illustrator®- och Photoshop®-filer direkt till Flash. Du kan också skapa videoklipp i Flash och redigera dem i Adobe® Premiere® Pro eller After Effects®, eller importera videoklipp från dessa program till Flash. När du publicerar SWF-filer kan du använda Dreamweaver® för att bädda in innehållet på dina webbsidor, starta Flash direkt från Dreamweaver och redigera innehållet.

Öppna XFL-filer

Från och med Flash Professional CS5 är XFL det interna formatet på FLA-filer som du skapar. När du sparar en fil i Flash är standardformatet FLA, men filens interna format är XFL.

I andra Adobe®-program, t.ex. After Effects®, kan du exportera filer i XFL-format. De filerna har filtillägget XFL i stället för FLA. I InDesign® kan du exportera direkt i FLA-format, vilket är XFL internt. Det betyder att du kan börja arbeta med ett projekt i After Effects eller InDesign och sedan fortsätta med arbetet i Flash.

Du kan öppna och arbeta med XFL-filer i Flash på samma sätt som du öppnar en FLA-fil. När du öppnar en XFL-fil i Flash Professional kan du sedan välja att spara den som en FLA-fil eller som en okomprimerad XFL-fil.

I följande videofilmer visas hur du exporterar från InDesign och AfterEffects till Flash med hjälp av XFL och FLA:

Så här öppnar du en XFL-fil i Flash:

  1. Exportera arbetet som en XFL-fil i ett annat Adobe®-program, t.ex. InDesign eller After Effects.

    Alla lager och objekt i den ursprungliga filen bevaras i XFL-filen.

  2. Välj Arkiv > Öppna i Flash Professional och bläddra till XFL-filen. Klicka på Öppna.

    XFL-filen öppnas i Flash på samma sätt som en FLA-fil. Alla lager i originalfilen visas på tidslinjen och de ursprungliga objekten visas på bibliotekspanelen.

    Nu kan du arbeta med filen som vanligt.

  3. Spara filen genom att välja Arkiv > Spara.

    Du uppmanas att ge den nya FLA-filen ett namn i dialogrutan Spara som i Flash Professional.

  4. Skriv ett namn och spara FLA-filen.

Arbeta med okomprimerade XFL-filer

Från och med Flash Professional CS5 kan du välja att arbeta med Flash-filer i okomprimerat XFL-format. Det här filformatet ger dig möjlighet att se de olika delarna, eller underfilerna, som utgör Flash-filen. Bland dessa delar finns:

  • En XML-fil som beskriver Flash-filen i dess helhet.

  • Separata XML-filer som beskriver varje bibliotekssymbol.

  • Ytterligare XML-filer som innehåller bland annat publiceringsinställningar och mobilinställningar.

  • Mappar med externa resurser, som bitmappfiler, som används av Flash-filen.

Tack vare det okomprimerade XFL-formatet kan du låta flera olika personer arbeta med de olika delarna av Flash-filen. Du kan också använda ett system för källkontroll för att hantera ändringarna av alla underfiler i den okomprimerade XFL-filen. Sammantaget innebär detta att det blir betydligt enklare att samarbeta i stora projekt med många designers och utvecklare.

Använda direktuppdatering med XFL-filer

Med direktuppdatering för redigerbara resurser i okomprimerade XFL-dokument kan du redigera alla biblioteksresurser i det okomprimerade XFL-dokumentet samtidigt som dokumentet är öppet i Flash. Ändringarna återspeglas i Flash när du är klar med redigeringen av resursen i det andra programmet.

Så här redigerar du en resurs från ett okomprimerat XFL-dokument i ett annat program:

  1. Spara Flash-dokumentet i okomprimerat XFL-format.

  2. Använd ett lämpligt redigeringsprogram, som Photoshop, för att öppna den resurs som du vill redigera från mappen LIBRARY för det okomprimerade XFL-dokumentet.

  3. Redigera resursen och spara ändringarna.

  4. Gå tillbaka till Flash Pro.

    Uppdateringen av resursen visas direkt i Flash.

Redigera en SWF-fil från Dreamweaver i Flash

Om både Flash och Dreamweaver har installerats på datorn kan du markera en SWF-fil i ett Dreamweaver-dokument och sedan använda Flash om du vill redigera filen. Flash redigerar inte SWF-filen direkt, utan redigerar filens källdokument (FLA-fil) och exporterar SWF-filen igen.

  1. I Dreamweaver öppnar du egenskapskontrollen (Fönster > Egenskaper).
  2. Gör något av följande i Dreamweaver-dokumentet:
    • Klicka på SWF-filens platshållare för att markera den. Sedan klickar du på Redigera i egenskapskontrollen.

    • Högerklicka (Windows) eller Ctrl-klicka (Macintosh) på SWF-filens platshållare, och välj Redigera med Flash på snabbmenyn.

      Dreamweaver växlar fokus till Flash, och Flash försöker hitta Flash-redigeringsfilen (FLA) för den markerade SWF-filen. Om Flash inte hittar Flash-redigeringsfilen uppmanas du att söka rätt på den.

      Obs! Om FLA-filen eller SWF-filen är låst kontrollerar du filen i Dreamweaver.

  3. Redigera FLA-filen i Flash. Flash-dokumentfönstret anger att du ändrar filen inifrån Dreamweaver.
  4. När du är klar med ändringarna klickar du på Klar.

    Flash uppdaterar FLA-filen och exporterar den på nytt som en SWF-fil. Därefter avslutas Flash och fokus hamnar på Dreamweaver-dokumentet igen.

    Obs!

    Om du vill uppdatera SWF-filen och låta Flash vara öppet väljer du följande i Flash: Arkiv > Uppdatera för Dreamweaver.

  5. Om du vill visa den uppdaterade filen i dokumentet klickar du på Spela upp i egenskapskontrollen för Dreamweaver, eller trycker på F12 för att förhandsvisa sidan i ett webbläsarfönster.
  1. Starta Flash.
  2. Välj Skapa nytt > Flash-fil (mobil) på huvudskärmen i Flash.
  3. Välj en Player-version och ActionScript-version i Device Central.
  4. Välj en innehållstyp.
  5. Välj en eller flera enheter i listan Tillgängliga enheter (eller välj en uppsättning eller en enskild enhet i listan Enhetsuppsättningar).
  6. Klicka på Skapa.
  7. Lägg till innehåll i det nya Flash-dokumentet.
  8. Väl Kontroll > Testa om du vill testa dokumentet.

Skapa ett nytt dokument

Du kan skapa ett nytt dokument eller öppna ett redan sparat dokument i Flash Professional, och du kan öppna ett nytt fönster när du arbetar. Du kan ange egenskaper för nya eller befintliga dokument.

Skapa ett nytt dokument

  1. Välj Arkiv > Nytt.
  2. På fliken Allmänt väljer du vilken typ av Flash-dokument som du vill skapa.
  3. Gör något av följande:

Skapa ett nytt dokument från en mall

  1. Välj Arkiv > Nytt.
  2. Klicka på Mallar-fliken.
  3. Markera en kategori i listan med kategorier, markera ett dokument i listan med kategoriobjekt och klicka på OK. Du kan välja standardmallar som ingår i Flash Professional eller en egen mall som du har sparat.

Öppna ett befintligt dokument

  1. Välj Arkiv >Öppna.
  2. I dialogrutan Öppna, navigerar du till filen eller anger en sökväg till filen i rutan Gå till.
  3. Klicka på Öppna.

Visa ett dokument när flera dokument är öppna

Om du öppnar flera dokument, kan du med flikarna överst i dokumentfönstret identifiera de öppna dokumenten och lätt navigera mellan dem. Flikarna visas endast om dokumenten är maximerade i dokumentfönstret.

  1. Klicka på fliken för det dokument som du vill visa.

    Flikarna visas som standard i den ordning som dokumenten skapades. Du kan dra dokumentflikar för att ändra ordningen på dem.

Öppna ett nytt fönster för det aktuella dokumentet

  1. Välj Fönster°>Duplicera fönster.

Ange egenskaper för ett nytt eller befintligt dokument

  1. Med dokumentet öppet markerar du Ändra°> Dokument.

    Dialogrutan Dokumentinställningar visas.

  2. Gör något av följande för att ange scendimensionerna:
    • Om du vill ange scenstorleken i pixlar anger du värden i rutorna Bredd och Höjd. Minsta storlek är 1 x 1 pixlar. Max. är 2880 x 2880 pixlar.

    • Om du vill matcha scenstorleken till exakt så mycket utrymme som används av innehållet på scenen, väljer du alternativet Matcha innehåll.

    • Om du vill ange scenstorleken som det maximala tillgängliga utskriftsområdet väljer du Matcha skrivare. Detta område bestäms av pappersstorleken minus den aktuella marginalen som valdes i marignalområdet i dialogrutan Utskriftsformat (Windows) eller i dialogrutan Utskriftsmarginaler (Macintosh).

    • Om du vill ange scenstorleken till standardstorlek, 550 x 400 pixlar, väljer du Matcha: Standard.

  3. Om du vill ändra placeringen och orienteringen för 3D-objekt på scenen så att du behåller utseendet relativt till scenkanterna, väljer du Justera 3D-perspektivvinkeln för att bevara den aktuella scenprojektionen.

    Detta alternativ är bara tillgängligt om du ändrar scenstorleken.

  4. (Endast CS5.5) Om du automatiskt vill ändra skala för innehållet på scenen relativt till ändringen av scenstorleken, ska du välja Skala innehåll med scenen.

    Detta alternativ är bara tillgängligt om du ändrar scenstorleken. Du kan i inställningarna välja att skala innehållet i låsta eller dolda lager. Mer information finns i Ange allmänna inställningar.

  5. Om du vill ange en måttenhet för linjaler som visas på arbetsytan, ska du välja ett av alternativen på menyn Linjalenheter. (Den här inställningen bestämmer även måttenheterna som används på informationspanelen.)
  6. Om du vill ange bakgrundsfärgen för dokumentet klickar du på färgrutan Bakgrundsfärg och markerar en färg i paletten.
  7. För bildrutehastighet anger du antalet bildrutor för animering som ska visas varje sekund.

    För de flesta animeringar som visas på datorer, och särskilt de som spelas upp från en webbplats, är 8 bildrutor per sekund (fps) till 15 fps tillräckligt. Om du ändrar bildrutehastigheten används den nya hastigheten som standard för nya dokument.

  8. (Endast CS5.5) Om du vill spara dokumentet automatiskt med ett angivet tidsintervall markerar du alternativet Spara automatiskt och anger antal minuter för intervallet.
  9. Gör något av följande:
    • Klicka på OK om du vill använda de nya inställningarna på det aktuella dokumentet.

    • Om du vill göra de nya inställningarna till standardegenskaper för alla nya dokument klickar du på Använd som standard.

Ändra dokumentegenskaper med egenskapsinspektören

  1. Klicka på arbetsytan utanför scenen för att avmarkera alla objekt på scenen. Dokumentegenskaperna visas i egenskapsinspektören. Öppna egenskapsinspektören genom att välja (Fönster > Egenskaper).
  2. (Endast CS5.5) I avsnittet Publicera väljer du en Flash Player-version och en ActionScript-version för dokumentet. Om du vill öppna ytterligare publiceringsinställningar klickar du på knappen Publiceringsinställningar. Mer information finns i Publiceringsinställningar.

  3. I avsnittet Egenskaper, för FPS (bildrutor per sekund), anger du antalet animeringsbildrutor som ska spelas upp varje sekund.
  4. Om du vill ändra scenstorleken anger du värden för scenens bredd och höjd.
  5. Om du vill välja en bakgrundsfärg för scenen klickar du på färgrutan bredvid scenegenskapen och väljer en färg på paletten.
  6. Om du vill redigera ytterligare dokumentegenskaper klickar du på knappen Redigera bredvid storleksegenskaperna. Mer information om alla dokumentegenskaper finns i Ange egenskaper för ett nytt eller befintligt dokument.

Lägga till XMP-metadata i ett dokument

Du kan inkludera XMP-data (Extensible Metadata Platform), till exempel titel, författare, beskrivning och copyrightinformation, i dina FLA-filer. XMP är ett metadataformat som garanterat kan användas i andra Adobe®-program. Metadata kan visas i Flash Professional och i Adobe® Bridge. Mer information om XMP-metadata finns i Metadata och nyckelord i hjälpen om Bridge.

Obs! 32-bitarsversionen av Bridge stöds inte med Adobe Flash Professional CC.

Genom att bädda in metadata förbättras möjligheten för webbaserade sökmotorer att returnera meningsfulla sökresultat för Flash Professional-innehåll. Metadata för sökning är baserade på specifikationer för XMP (Extensible Metadata Platform) och är lagrade i FLA-filen i ett W3C-kompatibelt format.

Metadata för en fil innehåller information om filens innehåll, copyrightstatus, ursprung och historik. I dialogrutan Filinformation kan du visa och redigera metadata för den aktuella filen.

Beroende på vilken fil du har markerat kan följande typer av metadata visas:

Beskrivning

Innehåller information om författare, rubrik, copyright och annan information.

IPTC

Visar metadata som kan redigeras. Du kan lägga till beskrivningar och copyrightinformation i filer. IPTC Core är en specifikation som godkändes av IPTC (International Press Telecommunications Council) i oktober 2004. Den skiljer sig från den äldre IPTC-specifikationen (IIM, äldre) genom att nya egenskaper har lagts till, vissa egenskapsnamn har ändrats och vissa egenskaper har tagits bort.

Kameradata (Exif)

Visar information som tilldelas av digitalkameror, inklusive de kamerainställningar som användes när bilden togs.

Videodata

Visar metadata för videofiler, inklusive pixelförhållande, scen och tagning.

Ljuddata

Visar metadata för ljudfiler, inklusive artist, album, spårnummer och genre.

Mobil SWF

Visar information om SWF-filer, inklusive titel, författare, beskrivning och copyrightinformation.

Historik

Här sparas en logg över alla ändringar som har gjorts i bilder med Photoshop.

Obs! Om du vill att loggen ska sparas med filens metadata måste du ha aktiverat historikinställningen i Photoshop.

Version Cue

Här visas all eventuell filversionsinformation för Version Cue.

DICOM

Visar information om bilder som har sparats i DICOM-formatet (Digital Imaging and Communications in Medicine).

Så här lägger du till metadata:

  1. Välj Arkiv > Filinformation.
  2. Ange de metadata som du vill inkludera i dialogrutan Filinformation som visas. Du kan lägga till eller ta bort metadata i FLA-filen när som helst.

Spara Flash-dokument

Du kan spara ett FLA-dokument i Flash Professional med dess aktuella namn och plats eller med ett annat namn eller på en annan plats.

Om ett dokument innehåller ändringar som inte sparats visas en asterisk (*) efter dokumentnamnet i dokumenttitelfältet, programmets titelfält och dokumentfliken. Om du sparar dokumentet tas asterisken bort.

Spara ett Flash-dokument i standardformatet FLA

  1. Gör något av följande:
    • Om du vill skriva över den aktuella versionen på disken väljer du Arkiv°>Spara.

    • Om du vill spara dokumentet på en annan plats och/eller med ett annat namn, eller om du vill komprimera dokumentet, väljer du Arkiv°>°Spara som.

  2. Om du valde Spara som eller om dokumentet aldrig har sparats innan anger du filnamnet och platsen.
  3. Klicka på Spara.

Spara ett dokument i det okomprimerade formatet XFL

  1. Välj Arkiv > Spara som.
  2. Välj Flash CS5 eller Okomprimerat Flash CS5.5-dokument (*xfl) på menyn Filformat.
  3. Ange ett namn och en plats för filen och klicka på Spara.

Återgå till den senast sparade versionen ett dokument

  1. Välj Arkiv°>Återgå.

Spara ett dokument som en mall

  1. Välj Arkiv°>Spara som mall.
  2. I dialogrutan Spara som mall anger du ett namn för mallen i rutan för namn.
  3. Välj en kategori på popup-menyn för kategori eller ange ett namn för att skapa en ny kategori.
  4. Ange en beskrivning av mallen i rutan Beskrivning (upp till 255 tecken) och klicka på OK.

    Beskrivningen visas när mallen väljs i dialogrutan Nytt dokument.

    Om du vill ta bort en sparad mall går du till en av följande mappar och tar bort mall-FLA-filen från den kategorimapp som innehåller den.

    • Windows XP - C:\Documents and Settings\<användarnamn>\Lokala inställningar\Application Data\Adobe\Flash CS5\en_US\Configuration\Templates\

    • Windows Vista och 7 - C:\Användare\<användarnamn>\AppData\Local\Adobe\Flash CS5\<språk>\Configuration\Templates\

    • Mac OS - <Hårddisk>/Users/<användarnamn>/Library/Application Support/Adobe/Flash CS5/<språk>/Configuration/Templates/

Spara ett dokument som ett Flash CS4-dokument

  1. Välj Arkiv°>°Spara som.
  2. Ange filnamnet och platsen.
  3. Välj ett Flash CS4-dokument från popup-menyn Format och klicka på Spara.

    Obs!

    Om ett varningsmeddelande indikerar att innehållet tas bort om du sparar i Flash CS4-format klickar du på Spara som Flash CS4 för att fortsätta. Detta kan inträffa om dokumentet innehåller funktioner som endast är tillgängliga i Flash CS5. Dessa funktioner bevaras inte i Flash Professional när du sparar dokumentet i Flash CS4-format.

Spara dokument när du avslutar Flash

  1. Välj Arkiv > Avsluta (Windows) eller Flash > Avsluta Flash (Macintosh).
  2. Om du har öppna dokument med osparade ändringar visas en uppmaning om att spara eller ignorera ändringarna för varje dokument i Flash Professional.
    • Klicka på Ja för att spara ändringarna och stänga dokumentet.

    • Klicka på Nej för att stänga dokumentet utan att spara ändringarna.

Skriva ut Flash-dokument

Om du vill förhandsgranska och redigera dokument kan du skriva ut bildrutor från Adobe Flash Professional-dokument eller ange bildrutor som ska vara utskrivbara från Flash Player till ett visningsprogram.

När du skriver ut bildrutor från ett Flash Professional-dokument använder du dialogrutan Skriv ut för att ange ett intervall med scener eller bildrutor som ska skriva ut samt hur många kopior du vill ha. I dialogrutan Utskriftsformat i Windows anger du pappersstorlek, orientering och andra utskriftsalternativ, inklusive marginalinställningar och om alla bildrutor ska skrivas ut för varje sida. I Macintosh är dessa alternativ fördelade mellan dialogrutorna Utskriftsformat och Utskriftsmarginaler.

Dialogrutorna Skriv ut och Utskriftsformat är standard i respektive operativsystem. Dialogrutornas utseende beror på vilken skrivardrivrutin som används.

  1. Välj Arkiv > Utskriftsformat (Windows) eller Arkiv > Utskriftsmarginaler (Macintosh).
  2. Ange marginaler. Markera båda centreringsalternativen om du vill skriva ut bildrutan mitt på sidan.
  3. Ange på Bildrutor-menyn om alla bildrutor i dokumentet eller bara den första bildrutan i varje scen ska skrivas ut.
  4. Välj ett av följande alternativ på Layout-menyn:

    Aktuell storlek

    skriver ut bildrutan i full storlek. Ange ett värde för Skala om du vill förminska eller förstora den utskrivna bildrutan.

    Passa in på en sida

    förminskar eller förstorar varje bildruta så att den passar på sidans utskriftsområde.

    Bildmanus

    Skriver ut flera miniatyrbilder på en sida. Välj på Rutor, Rutnät eller Tomt. Ange hur många miniatyrbilder som ska skrivas på varje sida i rutan Bildrutor. Ange avståndet mellan miniatyrbilderna i rutan Bildrutemarginal och markera Bildruteetikett om du vill att bildruteetiketten ska skrivas ut som miniatyrbild.

  5. Välj Arkiv > Skriv ut när du vill skriva ut bildrutor.

Använda bildruteetiketter för att inaktivera utskrift

Om du inte vill skriva ut någon av bildrutorna på huvudtidslinjen ger du en bildruta etiketten !#p om du vill göra hela SWF-filen outskrivbar. Om en bildruta har etiketten !#p tonas kommandot Skriv ut ned på snabbmenyn i Flash Player. Du kan även ta bort snabbmenyn i Flash Player.

Om du inaktiverar utskrift från Flash Player kan användaren fortfarande skriva ut bildrutor med webbläsarens Skriv ut-kommando. Eftersom kommandot är en webbläsarfunktion går det inte att styra eller inaktivera det med Flash Professional.

Inaktivera utskrift på snabbmenyn i Flash Player

  1. Öppna eller aktivera det Flash Professional-dokument (FLA-fil) som ska publiceras.
  2. Markera den första nyckelbildrutan på huvudtidslinjen.
  3. Välj Fönster > Egenskaper för att visa egenskapsinspektören.
  4. I egenskapsinspektören anger du !#p för att ange att bildrutan inte ska skrivas ut.

    Ange bara en !#p-etikett för att tona ned kommandot Skriv ut på snabbmenyn.

    Obs!

    Du kan också markera en tom bildruta (i stället för en nyckelbildruta) och ge den etiketten #p.

Inaktivera utskrift genom att ta bort snabbmenyn i Flash Player

  1. Öppna eller aktivera det Flash Professional-dokument (FLA-fil) som ska publiceras.
  2. Välj Arkiv > Publiceringsinställningar.
  3. Markera HTML-fliken, avmarkera Visa meny och klicka på OK.

Ange ett utskriftsområde för bildruteutskrift

  1. Öppna Flash Professional-dokumentet (FLA-filen) som innehåller de bildrutor som ska skrivas ut.
  2. Markera en bildruta som du inte har angett för utskrift med en #p-etikett som finns i samma lager som en bildruta som har markerats med etiketten #p.

    Organisera arbetet genom att välja nästa bildruta efter en bildruta som har etiketten #p.

  3. Skapa en form som har det önskade utskriftsområdets storlek på scenen. Om du vill använda en bildrutas begränsningsram markerar du en bildruta som innehåller ett objekt med den önskade utskriftsstorleken.
  4. Markera bildrutan på tidslinjen som innehåller den form som ska användas som begränsningsram.
  5. I egenskapsinspektören (Fönster > Egenskaper) anger du #b som bildruteetikett för att ange att den markerade formen är utskriftsområdets begränsningsram.

    Det får bara finnas en #b-bildruteetikett per tidslinje. Det här alternativet är likvärdigt med att välja begränsningsramsalternativet Movie med åtgärden Print.

Ändra bakgrundsfärg för utskriften

Du kan skriva ut bakgrundsfärgen som ställts in i dialogrutan Dokumentegenskaper. Ändra bara bakgrundsfärgen för bildrutor som ska skrivas ut genom att placera ett färgat objekt i det understa lagret i tidslinjen som skrivs ut.

  1. Placera en fylld form som täcker scenen på den understa lagret i tidslinjen som ska skrivas ut.
  2. Markera formen och välj Ändra > Dokument. Välj en färg för utskriftsbakgrunden.

    Åtgärden ändrar hela dokumentets bakgrundsfärg, inklusive för filmklipp och inläsa SWF-filer.

  3. Gör något av följande:
    • Om du vill skriva ut färgen som dokumentets bakgrund, anger du att den bildruta som du placerade formen i ska skrivas ut.

    • Om du vill använda en annan bakgrundsfärg för bildrutor som inte ska skrivas ut upprepar du steg 2 och 3. Placera sedan formen i det understa lagret i tidslinjen i alla bildrutor som inte ska skrivas ut.

Använd kommandot Skriv ut på snabbmenyn i Flash Player för att skriva ut bildrutor från en Flash Professional SWF-fil.

Kommandot Skriv ut på snabbmenyn kan inte användas för att skriva ut genomskinlighet eller färgeffekter eller för att skriva ut bildrutor från andra filmklipp. Använd objektet PrintJob eller funktionen print().

  1. Öppna dokumentet.

    Kommandot skriver ut bildrutor med etiketten #p med scenen eller den angivna begränsningsramen som utskriftsområde.

    Om du inte har angett specifika bildrutor att skriva ut, skrivs alla bildrutor i dokumentets huvudtidslinje ut.

  2. Välj Arkiv > Förhandsgranska publicering > Standard eller tryck på F12 för att visa Flash Professional-innehållet i en webbläsare.
  3. Högerklicka (Windows) eller Control-klicka (Macintosh) på Flash Professional-innehållet i webbläsarfönstret för att visa snabbmenyn i Flash Player.
  4. Välj Skriv ut på snabbmenyn i Flash Player så att dialogrutan Skriv ut visas.
  5. I Windows väljer du utskriftsintervall för att ange vilka bildrutor som ska skrivas ut.
  6. I Macintosh väljer du sidor att skriva ut i dialogrutan Skriv ut.
  7. Välj andra utskriftsalternativ beroende på skrivarens egenskaper.
  8. Klicka på OK (Windows) eller Skriv ut (Macintosh).

Obs!

Utskrift från snabbmenyn samverkar inte med anrop till objektet PrintJob.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy