Detta dokument beskriver hur man installerar och använder det kompletterande plugin-programmet OpenEXR Alpha.

Det kompletterande plugin-programmet OpenEXR Alpha ger en alternativ metod för att hantera 'A'-kanaldata när du öppnar en OpenEXR-fil. Istället för att direkt konvertera 'A'-kanaldata till genomskinlighet (som det gamla tilläggsprogrammet OpenEXR gör) öppnar OpenEXR Alpha 'A'-kanaldata som en alfakanal.

Bakgrund

Photoshop CS2 stödde generellt inte genomskinlighet i 32-bitarsläge. I den versionen implementerades en lösning som låter dig läsa in genomskinlighetsdata till en alfakanal. I Photoshop CS3 implementerades genomskinlighet för 32-bitarsläge, vilket garanterar kompatibilitet med OpenEXR-specifikationen. Genomskinlighet lästes därför inte längre in i en alfakanal under rak kanalsammansättning.

Innan du börjar

Installation av plugin-programmet OpenEXR Alpha kräver lokala administrationsrättigheter. Om du använder Mac OS, Windows Vista eller Windows 7, uppmanar operativsystemet dig att mata in namn och lösenord för ett administratöranvändarkonto. Om du använder Windows XP, logga in på din dator med ett lokalt administratörskonto innan du börjar.

Windows-användare: Vissa av stegen i denna TechNote listar filer med sina fullständiga filnamn, vilket innefattar filnamnstillägg (till exempel, OpenEXR Alpha.8bi). I Windows visas inte filnamnstillägg för kända filtyper som standard. Gör följande för att göra filnamnstillägg synliga:

  1. I Utforskaren i Windows, välj Verktyg > Mappalternativ (Windows XP) eller Ordna > Mapp och sökalternativ (Windows 7 och Vista).
  2. Välj fliken Visning i den övre delen av fönstret för Mappalternativ.
  3. I Avancerade inställningar i fliken Visning, avmarkera Dölj filnamnstillägg för kända filtyper.
  4. Klicka på OK.

Windows-användare: Vissa av stegen i det här dokumentet kräver att du fastställer om du använder en 32-bitars- eller 64-bitarsversion av Windows. För att fastställa vilken systemtyp du har, se Fastställ om din dator kör en 32-bitars- eller en 64-bitarsversion av Windows.

Kompatibilitet

I Windows är plugin-programmet OpenEXR Alpha inte kompatibelt med versioner av Photoshop som är äldre än Photoshop CS5. Det laddar inte i Photoshop CS3 eller CS4.

I Mac OS laddar inte plugin-programmet OpenEXR Alpha på PPC-datorer.

Installera plugin-programmet OpenEXR Alpha för Photoshop CS5 på Mac eller Windows (ladda ned uppdateringen från Adobes webbplats)

Så här installerar du plugin-programmet OpenEXR Alpha genom att hämta en uppdatering från Adobes webbplats:

  1. Ladda ned det komprimerade plugin-programmet:

  2. Avsluta Photoshop CS5.
  3. Packa upp den nedladdade filen.
  4. Dra plugin-programmet till Photoshops mapp för plugin-program.
    • 32-bitars Windows: Dra OpenEXR Alpha.8bi från Win32-mappen till mappen /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • 64-bitars Windows/Photoshop: Dra OpenEXR Alpha.8bi från mappen Win64 till mappen /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • 64-bitars Windows/32-bitars Photoshop: Dra OpenEXR Alpha.8bi från Win32-mappen till mappen /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Mac OS: Dra OpenEXR.plugin till mappen /Applications/Adobe Photoshop CS5/Plug-ins/File Formats.
  5. Starta Photoshop CS5.

Använd plugin-programmet OpenEXR Alpha

Om du vill öppna en EXR-fil:

  1. Starta Photoshop CS5.
  2. Välj Arkiv > Öppna.
  3. Bläddra till EXR-filen som du vill öppna. Välj OpenEXR Alpha i listan för filformat. Photoshop hanterar 'A'-kanalinformationen som en alfakanal i stället för genomskinlighet.

Om du vill exportera en EXR-fil:

  1. Välj Arkiv > Spara som.
  2. Välj OpenEXR Alpha i listan för filformat.

  3. Välj alternativet Spara: Alfakanaler. Denna inställning bevarar alfakanaldata.

Obs: Genomskinlighet som har lagts till efter att filen öppnades har plattats ut.

Obs: Även efter installationen av plugin-programmet OpenEXR Alpha har du fortfarande möjligheten att välja gamla OpenEXR i listan för filformat. Detta plugin-program hanterar fortfarande data i ”A”-kanalen som genomskinlighet. Detta beteende har varit standard i Photoshop sedan Photoshop CS3 (version 10,0).

Ytterligare anmärkningar

Annat anmärkningsvärt beteende när du använder det kompletterande plugin-programmet:

  • Förmultiplicerad sammansättning stöds inte.
  • Om du dubbelklickar på en fil för att öppna den, använder Photoshop CS5 alltid OpenEXR Alpha i stället för OpenEXR.
  • Om du öppnar en fil med två eller fler alfakanaler, bevarar inte OpenEXR Alpha någon av alfakanalerna. De tas bort helt.
  • (Mac OS): I dialogrutan Spara är OpenEXR Alpha är det översta objektet. Det visas inte i bokstavsordning bredvid Öppna EXR.
  • (Windows): För att få det gamla OpenEXR-beteendet ska du välja Arkiv > Öppna som, och sedan välja OpenEXR.
     

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy