Learn how to publish OAM files from Animate to use in your Dreamweaver or Adobe Muse projects.

Create OAM files in Animate

To publish animations in the popular OAM file format from Adobe Animate, you first create the OAM files from your project in Animate and then import the OAM files into your web layouts in Dreamweaver, Adobe Muse or InDesign.    

From Animate choose File > Publish Settings... . In the Publish Settings dialog box select OAM Package. Identify where you'd like to publish your file, and click the Publish button. When finished, click OK.

Insert the animation into your Dreamweaver layout

In Dreamweaver, select Live from the View menu to allow you to see your animation in Dreamweaver once it's in place. Next, select where you would like to place your animation and choose Window > Insert.

In the Insert panel, choose Animated Composition.

If prompted, choose where you'd like the animation to go relative to your insertion point. In this example, we've decided to Nest the animation inside the <Div> we have chosen. Next, navigate to the .OAM file you saved earlier using the Open file dialog box, and click Open.

Your animation should now appear inside your layout.

Place the animation into your Adobe Muse layout

In Adobe Muse, choose File > Place....

Navigate to the .OAM file you saved earlier using the Open file dialog box and click Open.

Your cursor should now appear with a small thumbnail of the posterframe of your animation. Decide where you would like your animation to go and click. Note that the location you click is where the upper left-hand corner of your animation will appear. If necessary, reposition your animation.

Once your animation is in its proper position, click the Preview tab to watch your animation play.

01/13/2020
Was this page helpful?