Security updates available for Adobe Photoshop CC and Bridge CC

Release date: February 9, 2016

Vulnerability identifier: APSB16-03

Priority: 3

CVE number: CVE-2016-0951, CVE-2016-0952, CVE-2016-0953

Platform: Windows and Macintosh

Summary

Adobe has released updates for Photoshop CC and Bridge CC for Windows and Macintosh. These updates address critical security vulnerabilities that could potentially allow an attacker to take control of the affected system.

Affected software versions

Product Affected version Platform
Adobe Photoshop CC 16.1.1 (2015.1.1) and earlier versions Windows and Macintosh
Adobe Bridge CC 6.1.1 and earlier versions Windows and Macintosh

Solution

Adobe recommends users update their software installations via each application's update mechanism by launching each application, navigating to the Help menu, and clicking "Updates."  For more information, please reference this help page.

Product Updated version Platform Priority rating
Adobe Photoshop CC 2015 16.1.2 (2015.1.2) Windows and Macintosh 3
Adobe Photoshop CC 2014 15.2.4 (2014.2.4) Windows and Macintosh 3
Adobe Bridge CC 6.2 Windows and Macintosh 3

For managed environments, IT administrators can use the Creative Cloud Packager to create deployment packages. Refer to this help page for more information.

Patches for Adobe Photoshop CC 2014 (15.2.4) are also available at the following locations:

Note: These updates will not show in the Applications & Updates section of the Creative Cloud Packager. Please download the patches directly from the links above, and use the option to “Add Offline Media” as described in the workflow documented here.

Vulnerability details

  • These updates resolve memory corruption vulnerabilities that could lead to code execution (CVE-2016-0951, CVE-2016-0952, CVE-2016-0953).

Acknowledgments

Adobe would like to thank Francis Provencher of COSIG (CVE-2016-0951, CVE-2016-0952, CVE-2016-0953) for working with Adobe to help protect our customers.