Security update available for Adobe Shockwave Player

Release date: July 14, 2015

Vulnerability identifier: APSB15-17

Priority: See table below

CVE number: CVE-2015-5120, CVE-2015-5121

Platform: Windows and Macintosh


Adobe has released a security update for Adobe Shockwave Player for Windows and Macintosh. This update addresses critical vulnerabilities that could potentially allow an attacker to take control of the affected system.

Affected software versions

Product Affected versions Platform
Adobe Shockwave Player and earlier
Windows & Macintosh


Adobe categorizes this update with the following priority rating and recommends users update their installation to the newest version by following the instructions below:

Product Updated version Platform Priority rating Availability
Adobe Shockwave Player
Windows and Macintosh
1 Shockwave Player Download Center
  • Adobe recommends users of Adobe Shockwave Player and earlier versions for Windows and Macintosh update to Adobe Shockwave Player by visiting the Adobe Shockwave Player Download Center. 

Vulnerability Details

  • This update resolves memory corruption vulnerabilities that could lead to code execution (CVE-2015-5120, CVE-2015-5121). 


Adobe would like to thank Fortinet's FortiGuard Labs for reporting these issues and for working with Adobe to help protect our customers.