Vytvorenie a správa indexu v PDF

Vložením indexu slov do dokumentu môžete skrátiť čas potrebný na prehľadanie dlhého dokumentu PDF. Aplikácia Acrobat dokáže prehľadať index omnoho rýchlejšie než dokument. Vložený index je zahrnutý i do rozosielaných alebo zdieľaných kópií PDF. Užívatelia prehľadávajú PDF s vloženým indexom presne rovnako, ako bez vloženého indexu; nie sú potrebné žiadne kroky navyše.

Pridanie indexu do PDF

  1. S dokumentom otvoreným v aplikácii Acrobat vyberte voľby Nástroje > Spracovanie dokumentu > Správa vloženého indexu.
  2. V dialógovom okne Správa vloženého indexu kliknite na Vložiť index.
  3. Prečítajte si správu, ktorá sa zobrazí, a kliknite na tlačidlo OK.

    Poznámka:

    V aplikáciách Outlook a Lotus Notes máte možnosť vložiť index, keď prevádzate e-mailové správy alebo priečinky do formátu PDF. To sa odporúča hlavne pre priečinky obsahujúce veľké množstvo e-mailových správ.

Aktualizácie alebo odstránenie vloženého indexu v PDF

  1. Vyberte voľby Nástroje > Spracovanie dokumentu > Správa vloženého indexu.
  2. Kliknite buď na Aktualizovať index alebo na odstrániť index.

O funkcii Katalóg (Acrobat Pro)

Špecifickú skupinu súborov PDF môžete definovať ako katalóg a vytvoriť zjednotený index pre celú túto kolekciu dokumentov. Keď užívatelia hľadajú v katalógu dokumentov PDF určité informácie, proces prehľadávania je vďaka indexu oveľa rýchlejší.

Keď distribuujete kolekciu na disku CD, k súborom PDF môžete pridať aj index.

Katalóg môžete vytvoriť pre dokumenty písané latinkou alebo čínskymi, japonskými alebo kórejskými znakmi. Do katalógu môžete zahrnúť text dokumentu, poznámky, záložky, polia formulárov, tagy, metadáta objektov a dokumentu, prílohy, informácie o dokumente, digitálne podpisy, obrazové metadáta XIF (extended image file format) a užívateľské vlastnosti dokumentu.

Príprava súborov PDF na indexovanie (Acrobat Pro)

Začnite vytvorením priečinka, ktorý bude obsahovať súbory PDF, ktoré chcete indexovať. Všetky súbory PDF by mali mať dokončený obsah, aj elektronické vlastnosti, ako sú odkazy, záložky a polia formulárov. Ak sú medzi indexovanými súbormi aj skenované dokumenty, skontrolujte, či je možné ich text prehľadávať. Rozdeľte dlhé dokumenty do menších súborov podľa kapitol, aby ste zvýšili rýchlosť prehľadávania. Môžete tiež pridať informácie do vlastností dokumentu, aby ste zlepšili možnosť vyhľadania súboru.

Skôr ako začnete indexovať kolekciu dokumentov, je potrebné vytvoriť štruktúru dokumentov na diskovej jednotke alebo na zväzku sieťového servera a skontrolovať názvy súborov pre rôzne platformy. Názvy súborov sa môžu pri prehľadávaní na inej platforme skrátiť a ich vyhľadanie môže byť zložité. Ak chcete týmto problémom predísť, dodržujte tieto pravidlá:

  • Premenujte súbory, priečinky a indexy podľa konvencií pre pomenovávanie súborov systému MS-DOS (osem alebo menej znakov, po ktorých nasledujú tri znaky prípony názvu súboru), najmä ak plánujete dodávať kolekciu dokumentov a index na disku CD-ROM vo formáte ISO 9660.

  • Z názvov súborov a priečinkov odstráňte rozšírené znaky, ako sú napríklad znaky s diakritikou a neanglické znaky. (Písmo používané funkciou Katalóg nepodporuje znaky s kódmi 133 až 159.)

  • Nepoužívajte hlboko vnorené priečinky ani názvy ciest, ktoré sú dlhšie ako 256 znakov, pre indexy, ktoré budú prehľadávané užívateľmi systému Mac OS.

  • Ak používate systém Mac OS so serverom OS/2 LAN, nakonfigurujte server IBM® LAN Server Macintosh (LSM) tak, aby presadzoval konvencie pomenovania súborov pre systém MS-DOS, alebo indexujte len jednotky FAT (File Allocation Table). (Zväzky HPFS [High Performance File System] môžu obsahovať dlhé názvy súborov, ktoré nebude možné vyhľadať.)

    Ak štruktúra dokumentov obsahuje podpriečinky, ktorý nechcete indexovať, môžete ich počas procesu indexácie vylúčiť.

Pridávanie metadát do vlastností dokumentov (Acrobat Pro)

Ak chcete uľahčiť vyhľadávanie v súbore PDF, môžete do vlastností dokumentu pridať informácie o súbore nazývané metadáta. (Vlastnosti aktuálne otvoreného súboru PDF môžete zobraziť pomocou príkazu Súbor > Vlastnosti a kliknutím na kartu Opis.)

Poznámka:

(Windows) Vlastnosti dokumentu môžete tiež zobraziť alebo zadávať z pracovnej plochy. Kliknite na dokument v aplikácii Windows Prieskumník pravým tlačidlom myši, vyberte položku Vlastnosti a kliknite na kartu PDF. Všetky informácie, ktoré upravíte alebo zadáte v tomto dialógovom okne, sa objavia aj v opise vlastností dokumentu, keď súbor otvoríte.

Keď pridávate údaje do vlastností dokumentu, postupujte podľa nasledujúcich odporúčaní:

  • V poli Názov použite vhodný popisný názov. Názov súboru dokumentu by sa mal zobraziť v dialógovom okne Výsledky hľadania.

  • Pre podobné informácie používajte vždy rovnakú voľbu (pole). Nepridávajte napríklad dôležité informácie v niektorých dokumentoch do poľa Predmet a v iných dokumentoch do poľa Kľúčové slová.

  • Používajte stále ten istý termín pre tú istú informáciu. Nepoužívajte napríklad v niektorých dokumentoch termín geografia a v iných dokumentoch termín zemepis.

  • Na identifikáciu osoby alebo skupiny osôb, ktoré zodpovedajú za obsah dokumentu, použite pole Autor. Autorom dokumentu o náborovej politike firmy by mohlo byť napríklad Personálne oddelenie.

  • Ak používate evidenčné čísla dokumentov, pridajte ich ako kľúčové slová. Zadajte napríklad do poľa Kľúčové slová dok=m234, aby ste označili špecifický dokument medzi stovkami dokumentov na určitú tému.

  • Na kategorizáciu dokumentov podľa typu použite pole Predmet alebo Kľúčové slová alebo obidve tieto polia naraz. Ako hodnotu v poli Predmet dokumentu napríklad môžete použiť výraz správa o stave a ako hodnotu v poli Kľúčové slová mesačná alebo týždenná.

    Ak už máte špeciálne znalosti o dokumentoch Adobe PDF, môžete pri vytváraní indexu definovať vlastné dátové pole, napríklad Typ dokumentu, Číslo dokumentu alebo Identifikátor dokumentu. Tento postup sa odporúča iba pre pokročilých používateľov a nie je popísaný ani v úplnom pomocníkovi pre aplikáciu Acrobat.

Vytvorenie indexu pre kolekciu (Acrobat Pro)

Keď zostavujete nový index, aplikácia Acrobat vytvorí súbor s príponou .pdf a nový pomocný priečinok, ktorý obsahuje jeden alebo viac súborov s príponou .idx. Súbory IDX obsahujú položky indexu. Všetky tieto súbory musia byť dostupné pre užívateľa, ktorý chce index prehľadávať.

Dialógové okná v aplikácii Acrobat Pro pre proces vytvorenia indexu
Dialógové okná v aplikácii Acrobat Pro pre proces vytvorenia indexu

  1. Vyberte voľby Nástroje > Spracovanie dokumentu > Fulltextový index s katalógom a potom kliknite na tlačidlo Nový index.

    Poznámka:

    Ak panel Spracovanie dokumentu nie je zobrazený, pozrite si pokyny na pridávanie panelov v časti Pracovné tably.

  2. V poli Názov indexu zadajte názov pre súbor indexu.
  3. Do poľa Popis indexu napíšte pár slov o type indexu a jeho účelu.
  4. Kliknite na Voľby, vyberte ľubovoľné ďalšie voľby, ktoré chcete na index aplikovať, a kliknite na tlačidlo OK.
  5. Pod Zahrnúť tieto priečinky kliknite na Pridať, vyberte priečinok, ktorý obsahuje niektoré alebo všetky súbory PDF, ktoré chcete indexovať, a kliknite na tlačidlo OK. Ak chcete pridať viac priečinkov, zopakujte tento krok.

    Poznámka:

    Všetky priečinky vnorené pod zahrnutý priečinok budú tiež zahrnuté do procesu vytvárania indexu. Ak nebudete premiestňovať index ani jednotlivé súbory v kolekcii dokumentov, môžete pridať priečinky z viacerých serverov alebo diskov.

  6. Pod Vylúčiť tieto podpriečinky kliknite na Pridať a vyberte ľubovoľný vnorený priečinok obsahujúci súbory PDF, ktoré nechcete indexovať. Kliknite na tlačidlo OK a tento krok opakujte podľa potreby.
  7. Skontrolujte voľby. Ak chcete upraviť zoznam zahrnutých alebo vylúčených priečinkov, vyberte priečinok, ktorý chcete zmeniť, a kliknite na položku Odstrániť.
  8. Kliknite na Vytvoriť a potom určite umiestnenie súboru indexu. Kliknite na Uložiť a potom:
    • Kliknite na Zatvoriť, keď vytváranie indexu skončí.

    • Kliknite na Stop, ak chcete vytváranie indexu zrušiť.

    Poznámka:

    Ak vytváranie indexu zastavíte, nemôžete pokračovať v rovnakom procese indexovania, ale nemusíte voľby znova zadávať. Výber volieb a priečinkov zostane bez zmien. Môžete kliknúť na Otvoriť index, vybrať čiastočne dokončený index a opraviť ho.

    Poznámka:

    Ak sa názvy dlhých ciest vo voľbách Zahrnúť tieto priečinky a Vylúčiť tieto podpriečinky skrátia, podržte ukazovateľ nad tromi bodkami (...), kým sa neobjaví popis, v ktorom sa zobrazí celá cesta zahrnutého alebo vylúčeného priečinka.

Dialógové okno Voľby indexovania

Nezahrnúť čísla

Vyberte túto voľbu, ak chcete z indexu vylúčiť všetky čísla, ktoré sa vyskytujú v texte dokumentu. Vylúčením čísel môžete dosiahnuť podstatné zmenšenie indexu a tým zrýchlenie prehľadávania.

Pridať ID k súborom Adobe PDF v 1.0

Vyberte túto voľbu, ak vaša kolekcia obsahuje PDF vytvorené v staršej verzii aplikácie ako Acrobat 2.0, ktorá automaticky nepridávala identifikačné čísla. Identifikačné čísla sú potrebné, keď sa dlhé názvy súborov systému Mac OS skrátia pri ich prevode na názvy súborov systému MS-DOS. Aplikácia Acrobat 2.0 a novšie verzie pridávajú identifikátory automaticky.

Pri hľadaní neupozorňovať na zmenené dokumenty

Keď táto voľba nie je vybratá, pri prehľadávaní dokumentov, ktoré boli zmenené od posledného vytvorenia indexu, sa zobrazí správa.

Užívateľské vlastnosti

Použite túto voľbu, ak chcete do indexu zahrnúť užívateľské vlastnosti dokumentu. Budú sa indexovať iba užívateľské vlastnosti dokumentu, ktoré už v indexovaných PDF existujú. Zapíšte vlastnosť, vyberte z menu Typ a potom kliknite na Pridať. Tieto vlastnosti sa zobrazia ako ďalšie kritériá v rozbaľovacích menu volieb hľadania v okne Prehľadať PDF pri prehľadávaní výsledného indexu. Ak napríklad zadáte užívateľskú vlastnosť Názov dokumentu a v menu Typ vyberiete, že je to textová vlastnosť, môže potom užívateľ prehľadávajúci index hľadať v tejto užívateľskej vlastnosti, keď vyberiete Názov dokumentu z menu Použiť tieto ďalšie kritériá.

Poznámka:

Keď vytvoríte používateľské polia v aplikácii balíka Microsoft Office a v aplikácii PDFMaker je vybratá voľba Previesť informácie o dokumente, pole sa prenesie do všetkých súborov PDF, ktoré vytvoríte.  

Polia XMP

Použite túto voľbu, ak chcete zahrnúť užívateľské polia XMP. Užívateľské polia XMP sa budú indexovať a zobrazia sa v rozbaľovacích menu ďalších kritérií, aby ste ich mohli prehľadávať vo vybratých indexoch.

Vylúčené slová

Použite na vylúčenie určitých slov (maximálne 500) z výsledkov prehľadávania indexu. Zadajte slovo, kliknite na Pridať a opakujte to podľa potreby. Vylúčenie slov z indexu môže index zmenšiť o 10 až 15 %. Vylúčené slová môžu mať až 128 znakov a rozlišujú sa v nich malé a veľké písmená.

Poznámka:

Ak chcete predísť tomu, aby užívatelia skúšali hľadať frázy obsahujúce tieto slová, uveďte zoznam neindexovaných slov v súbore Readme (Čítajte) katalógu.

Tagy štruktúry

Použite túto voľbu, aby bolo možné prehľadávať špecifické tagy elementov v dokumentoch, ktoré majú tagovanú logickú štruktúru.

Poznámka:

Nastavenia pre Užívateľské vlastnosti, Vylúčené slová a Tagy sa vzťahujú iba na aktuálny index. Ak chcete aplikovať tieto nastavenia globálne na všetky vytvárané indexy, môžete zmeniť predvolené nastavenia pre užívateľské polia, vylúčené slová a tagy na paneli Katalóg v dialógovom okne Predvoľby.  

Súbory ReadMe (Čítajte) katalógu (Acrobat Pro)

Často je vhodné vytvoriť samostatný súbor ReadMe (Čítajte) a umiestniť ho do priečinka s indexom. Tento súbor ReadMe (Čítajte) môže obsahovať detaily o indexe, napríklad:

  • Druh indexovaných dokumentov.

  • Podporované voľby prehľadávania.

  • Kontaktná osoba alebo telefónne číslo pre prípadné otázky.

  • Zoznam čísiel alebo slov, ktoré sú z indexu vylúčené.

  • Zoznam priečinkov obsahujúcich dokumenty zaradené do indexu v sieti LAN alebo zoznam dokumentov zaradených do indexu na disku. Môžete pripojiť aj stručný popis obsahu každého priečinka alebo každého dokumentu.

  • Zoznam hodnôt pre každý dokument, ak ste hodnoty priradili do polí v dialógovom okne Informácie o dokumente.

    Ak katalóg obsahuje mimoriadne veľký počet dokumentov, zvážte vloženie tabuľky s prehľadom hodnôt priradených jednotlivým dokumentom. Táto tabuľka môže byť súčasťou súboru ReadMe (Čítajte) alebo môže byť v samostatnom súbore. Pri vytváraní indexu môžete túto tabuľku použiť na zabezpečenie jednotnosti.

Aktualizácia indexu (Acrobat Pro)

Existujúci index môžete aktualizovať, obnoviť alebo vyčistiť.

  1. Vyberte voľby Nástroje > Spracovanie dokumentu > Fulltextový index s katalógom a potom kliknite na tlačidlo Otvoriť index.
  2. Nájdite a vyberte súbor definície indexu (PDX) a kliknite na Otvoriť.
  3. Ak bol index vytvorený v aplikácii Acrobat 5.0 alebo staršej, vyberte Vytvoriť kópiu, ak chcete vytvoriť nový index (bez prepísania staršej verzie), alebo vyberte Prepísať starý index, ak chcete predchádzajúci index prepísať.
  4. V dialógovom okne Definícia indexu vykonajte požadované zmeny a potom kliknite na funkciu, ktorú má aplikácia Acrobat vykonať:

    Vytvoriť

    Vytvorí nový súbor IDX s existujúcimi informáciami a aktualizuje ho pridaním nových položiek a označením zmenených a zastaraných položiek ako neplatných. Ak ste vykonali veľké množstvo zmien alebo ste túto voľbu použili opakovane namiesto vytvorenia nového indexu, môžu sa časy prehľadávania predĺžiť.

    Znova vytvoriť

    Vytvorí nový index a pritom prepíše existujúci priečinok indexu a jeho obsah (súbory IDX).

    Vyčistiť

    Odstráni obsah indexu (súbory IDX), ale neodstráni vlastný súbor indexu (PDX).

Predvoľby katalógu (Acrobat Pro)

Môžete nastaviť predvoľby pre indexovanie, ktoré sa použijú globálne pre všetky ďalšie vytvárané indexy. Niektoré z týchto predvolieb potom môžete na jednotlivé indexy zmeniť, keď pri vytváraní indexu vyberiete nové voľby.

V dialógovom okne Predvoľby prejdite do časti Kategórie a vyberte voľbu Katalóg. Mnohé z volieb sú rovnaké ako tie popísané pre proces vytvárania indexu.

Poznámka:

Voľba Vynútiť kompatibilitu priečinkov s ISO 9660 je užitočná, keď nechcete pri príprave dokumentov na indexovanie meniť dlhé názvy súborov PDF na názvy MS‑DOS. Aj tak však musíte používať konvenciu názvov MS‑DOS pre názvy priečinkov (8 alebo menej znakov), aj keď pre názvy súborov to nie je nutné.

Plánované aktualizácie indexu (Acrobat Pro)

Pomocou funkcie Katalóg a dávkového súboru PDX katalógu (.bpdx) môžete naplánovať čas a interval automatického vytvárania, opakovaného vytvárania, aktualizácie a čistenia indexu. Súbor BPDX je textový súbor, ktorý obsahuje zoznam ciest a príznakov súborov indexov katalógu, ktoré sú závislé od platformy. Na zobrazenie súboru BPDX v aplikácii Acrobat použite aplikáciu na plánovanie úloh, ako napríklad Plánovač úloh systému Windows. Aplikácia Acrobat potom index znova vytvorí podľa príznakov v súbore BPDX.

Ak chcete získať ďalšie informácie o plánovaní aktualizácií indexovania, vyhľadajte výraz BPDX na stránke www.adobe.com/support.

 

Poznámka:

Ak chcete použiť súbory BPDX, vyberte v časti Katalóg dialógového okna Predvoľby voľbu Povoliť spustenie dávkových súborov pre katalóg (.bpdx).

Premiestnenie kolekcií a ich indexov (Acrobat Pro)

Kolekciu indexovaných dokumentov môžete vytvoriť a otestovať na lokálnom pevnom disku a potom dokončenú kolekciu dokumentov premiestniť na sieťový server alebo na iný disk. Definícia indexu obsahuje relatívne cesty medzi definičným súborom indexu (PDX) a priečinkami obsahujúcimi indexované dokumenty. Ak sa tieto relatívne cesty nezmenia, nie je potrebné index vytvárať znovu po tom, čo ste sadu indexovaných dokumentov premiestnili. Ak je súbor PDX v rovnakom priečinku ako priečinky obsahujúce indexované dokumenty, môžete zachovať ich relatívne cesty tým, že jednoducho premiestnite celý tento priečinok.

Ak sa relatívne cesty zmenia, musíte po premiestnení kolekcie indexovaných dokumentov vytvoriť nový index. Môžete k tomu ale použiť pôvodný súbor PDX. Aby ste tento pôvodný súbor PDX mohli ďalej používať, premiestnite najskôr indexované dokumenty. Potom skopírujte súbor PDX do priečinka, kde chcete vytvoriť nový index, a podľa potreby upravte zoznamy zahrnutých a vylúčených priečinkov a podpriečinkov indexu.

Ak je index umiestnený na lokálnom disku alebo na sieťovom disku nezávisle od akejkoľvek časti kolekcie indexovaných dokumentov, potom premiestnením indexu alebo sady dokumentov sa index poškodí. Ak chcete kolekciu dokumentov premiestniť na iné miesto na sieti alebo na disk CD, vytvorte index na rovnakom mieste, na ktorom je kolekcia dokumentov.

Licencia na používanie tohto diela sa poskytuje v súlade s podmienkami licencie Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Na príspevky v sociálnych sieťach Twitter™ a Facebook sa nevzťahujú podmienky licencií Creative Commons.

Právne upozornenia   |   Zásady ochrany osobných údajov online