Vytváranie polí formulára

V aplikácii Acrobat vytvoríte pole formulára tak, že vyberiete niektorý z nástrojov formulára. Pre každý typ poľa môžete prostredníctvom dialógového okna vlastností poľa formulára nastaviť množstvo volieb.

Aktivácia režimu úpravy formulára

V režime úpravy formulára sa zobrazí pracovná tabla Formuláre. Pomocou volieb na pracovnej table Formuláre môžete pridávať nové polia, upravovať existujúce polia a vykonávať iné úlohy týkajúce sa formulára.

  • Ak ste vytvorili nový formulár, štandardne sa otvorí v režime úpravy formulára.
  • Pri existujúcich formulároch vyberte voľby Nástroje > Formuláre > Upraviť.

Formulár sa teraz zobrazí v režime úpravy formulára a otvorí sa pracovná tabla Formuláre.

Vytvorenie poľa formulára

  1. Po prevedení dokumentu na formulár PDF otvorte pracovnú tablu Formuláre, ak ešte nie je otvorená (Nástroje > Formuláre > Upraviť).
  2. Vykonajte jeden z týchto úkonov:
    • Kliknite na voľbuPridať nové pole a následne vyberte typ poľa, ktoré chcete pridať.

    • Na paneli s nástrojmi Rýchly prístup vyberte pole formulára.

    • Kliknite pravým tlačidlom myši na stranu a vyberte nástroj.

    Kurzor sa zmení na vlasový kríž a zobrazí sa náhľad poľa.

  3. Na strane kliknite na miesto, na ktoré chcete pridať pole, aby sa vytvorilo pole s predvolenou veľkosťou. Ak chcete vytvoriť pole s prispôsobenou veľkosťou, posúvaním strán obdĺžnika myšou definujte veľkosť tohto poľa.
  4. Do poľa Názov poľa zadajte názov poľa a uveďte, či má byť toto pole povinné. Zvoľte zmysluplný a popisný názov, ktorý vám neskôr uľahčí usporiadanie a zhromažďovanie dát.
  5. Ak chcete zobraziť dialógové okno Vlastnosti a upraviť iné vlastnosti poľa, kliknite na voľbu Všetky vlastnosti.

    Poznámka:

    Ak ste na paneli s nástrojmi Formuláre (viditeľnom v režime úpravy formulára) vybrali voľbu Nechať nástroj vybratý, po pridaní poľa sa nezobrazí pole Názov poľa. Pri každom kliknutí na stranu sa do formulára pridá nové pole. Ak chcete skončiť tento režim, stlačte kláves Esc alebo kliknite na tlačidlo nástroja na výber objektu . Ak chcete upraviť vlastnosti poľa, dvakrát kliknite na toto pole.

  6. Ak chcete formulár odskúšať, kliknite na tlačidlo Náhľad na paneli s nástrojmi. Náhľad na formulár vám umožňuje zobraziť formulár rovnakým spôsobom, akým sa zobrazí jeho príjemcom, a poskytuje vám tak možnosť skontrolovať formulár. Ak zobrazujete náhľad formulára, kliknutím na tlačidlo Upraviť môžete prejsť späť do režimu úprav.
  7. Keď je formulár dokončený, kliknite na voľbu Zavrieť úpravu formulára.

Rozmiestnenie polí formulára v mriežke

Na presné umiestnenie polí formulára na strane môžete použiť mriežku. Môžete určiť veľkosť dielikov, farbu a polohu mriežky. Môžete tiež určiť, či sa majú pri úprave polí formulára hranice polí formulára priťahovať na najbližšiu čiaru mriežky. Čiary mriežky sa netlačia.

  1. Vyberte voľby Zobrazenie > Zobraziť/skryť > Pravítka a mriežky > Mriežka.
  2. Ak chcete, aby sa polia formulára priťahovali k najbližším čiaram mriežky, keď ich vytvárate alebo premiestňujete, vyberte voľby Zobrazenie > Zobraziť/skryť > Pravítka a mriežky > Priťahovať na mriežku.

Kopírovanie poľa formulára

Môžete vytvárať kópie poľa formulára na jednej strane formulára PDF. Pole formulára tiež môžete kopírovať a potom vkladať na iné strany. Pri vytváraní duplicitných polí formulára sa repliky pôvodného poľa pridávajú na jednu alebo viacero ostatných strán. Na každej z týchto strán sa duplicitné polia vždy nachádzajú na rovnakom mieste ako na pôvodnej strane. Kópie aj duplikáty môžete pretiahnuť do inej polohy na strane, ale nie z jednej strany na inú. Používanie

Kópie aj duplikáty sa vytvoria s rovnakým základným názvom, ako má pôvodné pole formulára. Kópie a duplikáty vložené pomocou príkazu Duplikovať na stranách majú tiež pripojené číslo. Všetky polia formulára s rovnakým základným názvom zdieľajú rovnaké užívateľské dáta a vlastnosti akcie. Ak teda užívateľ pridá alebo upraví odpoveď v poli kópie alebo duplikátu, odpoveď sa zobrazí vo všetkých poliach s rovnakým základným názvom.

Ak zmeníte vlastnosti niektorej z viacerých verzií poľa formulára s rovnakým základným názvom, tieto zmeny sa prejavia len v tejto kópii poľa formulára. Výnimkou sú iba zmeny v zozname akcií, ak spúšťačom nie je akcia myši.

Poznámka:

Ak chcete zabrániť tomu, aby duplicitné alebo skopírované pole formulára reagovalo v súlade s pôvodným poľom, zmeňte názov nového poľa formulára.

Vytvorenie kópie poľa formulára

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Vyberte pole formulára a vykonajte jeden z týchto úkonov:
    • Ak chcete skopírovať pole formulára do stredu aktuálneho zobrazenia, vyberte voľby Úpravy > Kopírovať a potom vyberte voľby Úpravy > Vložiť.

    • Ak chcete skopírovať pole formulára a presunúť ho na iné miesto na strane, podržte stlačený kláves Ctrl a presuňte ho myšou na požadované miesto.

      Tip: Ak chcete ťahanie obmedziť na vodorovný alebo zvislý pohyb, stlačte a podržte stlačený kláves Shift.

  3. Ak chcete, aby sa do poľa automaticky vypĺňali údaje, ktoré používateľ zadá do pôvodného poľa, ponechajte názov tak, ako je. Ak je skopírované pole určené pre jedinečné informácie používateľa, premenujte ho.

Vytvorenie viacerých kópií poľa formulára na strane

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Vykonajte jeden z týchto úkonov:
    • Kliknite pravým tlačidlom myši na pole formulára a vyberte voľbu Vytvoriť viac kópií.

    • Vyberte pole formulára a vyberte voľby Úlohy > Upraviť polia > Vytvoriť viac kópií.

  3. V dialógovom okne Vytvoriť viac kópií polí vyberte Náhľad a posuňte dialógové okno podľa potreby tak, aby ste videli pôvodné pole a jeho kópie na strane formulára.
  4. Vyberte voľby, ktoré chcete použiť:
    • Ak chcete zmeniť počet vytváraných kópií, zadajte iné hodnoty vo voľbách Kopírovať vybraté polia doleKopírovať vybraté polia naprieč.

    • Ak chcete zmeniť rozmery pôvodného poľa a všetkých jeho kópií, zadajte iné hodnoty vo voľbách Zmeniť šírkuZmeniť výšku.

    • Ak chcete posunúť pôvodné pole a všetky jeho kópie, kliknite na tlačidlá Hore, Dole, Doľava a Doprava.

  5. Ak chcete, aby sa do polí automaticky vypĺňali údaje, ktoré používateľ zadá do pôvodného poľa, ponechajte názvy tak, ako sú. Ak sú skopírované polia určené pre jedinečné informácie používateľa, premenujte ich.

Duplikovanie poľa formulára na viacerých stranách

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Vykonajte jeden z týchto úkonov:
    • Kliknite pravým tlačidlom myši na pole formulára a vyberte voľbu Duplikovať na stranách.

    • Vyberte pole formulára a vyberte voľby Formuláre > Úlohy > Upraviť polia > Duplikovať na stranách.

      poznámka: Príkaz Duplikovať nie je dostupný pre formuláre s iba jednou stranou.

  3. Vykonajte jeden z týchto úkonov:
    • Ak chcete duplikovať pole formulára na každej strane formulára, vyberte voľbu Všetky a kliknite na tlačidlo OK.

    • Ak chcete duplikovať pole formulára v obmedzenom rozsahu strán, kliknite na tlačidlo Od a zadajte počiatočnú a koncovú stranu rozsahu, v ktorom chcete pole formulára umiestniť. Potom kliknite na tlačidlo OK.

      poznámka: Zahrnutie alebo nezahrnutie strany, na ktorej sa pole formulára pôvodne vyskytuje, proces duplikovania neovplyvní. Pri zahrnutí tejto strany sa nevytvorí druhá kópia poľa nad originálom a pri jej nezahrnutí sa pôvodné pole formulára neodstráni.

  4. Ak chcete, aby sa do polí automaticky vypĺňali údaje, ktoré používateľ zadá do pôvodného poľa, ponechajte názvy tak, ako sú. Ak sú duplikované polia určené pre jedinečné informácie používateľa, premenujte ich.

Výber viacerých polí formulára

Výber viacerých polí formulára je prvým krokom vo viacerých úlohách, ako je napríklad vytváranie kópií, zarovnávanie polí formulára a upravovanie rozstupov medzi poľami formulára.

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Vykonajte ľubovolný z nasledujúcich úkonov:
    • Ak chcete vybrať všetky polia formulára všetkých typov, vyberte voľby Úpravy > Vybrať všetko.

    • Ak chcete vybrať určitý rozsah polí formulára, kliknite na prvé pole formulára z tohto rozsahu a potom so stlačeným klávesom Shift kliknite na posledné pole. Vyberú sa všetky polia formulára medzi týmito dvomi poľami.

    • Ak chcete vybrať jednotlivé polia formulára v rôznych častiach strany dokumentu PDF, podržte stlačený kláves Ctrl a kliknite na jednotlivé polia formulára.

    • Ak chcete vybrať všetky polia formulára v určitej oblasti strany, použite nástroj na výber objektu  a posúvaním myši vytvorte obdĺžnik výberu okolo tejto oblasti.

    • Ak chcete zrušiť výber určitého poľa formulára, podržte stlačený kláves Ctrl a kliknite na toto pole.

    Pole, ktoré je zvýraznené tmavomodrou farbou a zobrazuje sa s tiahlami ohraničenia, predstavuje kotvu. Keď kliknutím vyberiete viacero polí formulára, bude kotva posledné vybraté pole. Keď použijete rámček výberu, bude kotva to pole formulára, ktoré bolo vytvorené najskôr. Ak podržíte stlačený kláves Ctrl a kliknete na kotvu, aby ste zrušili jej výber, novou kotvou sa stane pole formulára umiestnené v ľavej hornej časti výberu.

Zmena veľkosti a usporiadanie polí formulára

Po vytvorení polí formulára môžete tieto polia znova usporiadať, zmeniť ich veľkosť alebo presunúť ich tak, aby strana získala prehľadnejší a profesionálnejší vzhľad.

Rozloženie polí formulára upravíte v režime úpravy formulára (vyberte voľby Nástroje  > Formuláre > Upraviť).

Zmena veľkosti poľa formulára

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Vyberte pole formulára, ktorého veľkosť chcete zmeniť.
  3. Vykonajte ľubovoľný z nasledujúcich úkonov:
    • Ak chcete manuálne zmeniť veľkosť poľa, potiahnite tiahlo ohraničenia. Podržte Shift a potiahnite rohové tiahlo, ak chcete zachovať aktuálny pomer strán poľa formulára.

    • Ak chcete zmeniť veľkosť poľa o jeden pixel, stlačte klávesy Ctrl+šípka. Ak chcete zmeniť veľkosť polí o desať pixelov, stlačte klávesy Ctrl+Shift+šípka.

    • Ak chcete zmeniť určitý rozmer, kliknite pravým tlačidlom myši na pole a vyberte položku Vlastnosti. Potom kliknite na kartu Poloha a upravte hodnoty Šírka a Výška.

Zmena veľkosti viacerých polí formulára podľa vybratého poľa formulára

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Vyberte všetky polia formulára, ktorých veľkosť chcete zmeniť.
  3. Kliknite pravým tlačidlom myši na pole formulára, s ktorým sa majú ostatné vybraté polia formulára zhodovať. Vyberte voľbu Nastaviť polia na rovnakú veľkosť a potom vyberte jednu z nasledujúcich možností:

    Výška

    Nastaví výšky polí bez zmeny ich šírky.

    Šírka

    Nastaví šírky polí bez zmeny ich výšky.

    Obidve

    Nastaví všetky výšky a šírky podľa vybratého poľa.

Premiestnenie jednotlivých polí formulára

Pole formulára môžete jednoducho presunúť potiahnutím myšou. Aby ste rýchlejšie získali presnejšie výsledky, môžete použiť špeciálne funkcie, ktoré polia navzájom zarovnajú, nastavia medzi nimi rovnaký odstup alebo ich vycentrujú na strane.

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Vyberte jedno alebo viac polí formulára, ktoré chcete presunúť.
  3. Vykonajte jeden z týchto úkonov:
    • Ak polia chcete premiestniť do približnej polohy, pretiahnite vybraté polia formulára na nové miesto.

      Tip: Ak chcete obmedziť pohyb iba na vodorovný alebo zvislý smer, začnite ťahať a potom stlačte Shift a pokračujte v ťahaní výberu.

    • Ak chcete pole premiestniť na konkrétne miesto, kliknite naň pravým tlačidlom myši a vyberte položku Vlastnosti. Potom kliknite na kartu Poloha a nastavte hodnoty Poloha.

    • Ak chcete pole posúvať vodorovne alebo zvislo po malých krokoch, nastavte polohu vybratých polí formulára stlačením klávesov so šípkami.

    • Ak chcete pole formulára umiestniť presne do stredu strany, vyberte Úpravy > Vystrihnúť, prejdite na požadovanú stranu, a potom vyberte Úpravy > Vložiť.

      poznámka: Pole sa umiestni do stredu strany iba pri prvom vložení. Ďalšie vložené polia budú posunuté vzhľadom k skôr vloženým poliam.

Zarovnanie a vycentrovanie viacerých polí formulára

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Vyberte dve alebo viac polí formulára, ktoré chcete zarovnať.
  3. Kliknite pravým tlačidlom myši na pole, podľa ktorého sa majú zarovnať ostatné polia. Vyberte voľbu Zarovnať, Rozmiestniť alebo Vystrediť a potom vyberte príslušný príkaz:
    • Ak chcete zarovnať stĺpec polí, vyberte príkaz Zarovnať doľava, doprava alebo zvisle. Polia sa zarovnajú k ľavému okraju, pravému okraju alebo podľa zvislej osi (na stred) poľa formulára, ktoré je kotvou.

    • Ak chcete zarovnať riadok polí, vyberte príkaz Zarovnať hore, dole alebo vodorovne. Polia sa zarovnajú k hornému okraju, dolnému okraju alebo podľa vodorovnej osi (na stred) poľa formulára, ktoré je kotvou.

    • Ak chcete polia zarovnať na stred, vyberte príkaz Vystrediť zvisle, vodorovne alebo Obidve.

    Poznámka:

    Ak kliknete pravým tlačidlom myši na niektoré z vybratých polí, zobrazia sa tiahla ohraničenia, ktoré naznačujú, že ide o kotevné pole formulára. Príkazy z menu Zarovnať posunú ostatné vybraté polia formulára tak, aby boli zarovnané podľa okraja alebo stredu kotevného poľa formulára.

Nastavenie medzier medzi poľami formulára

Rovnomerné rozmiestnenie skupiny polí formulára nastaví rovnomerné medzery medzi poľami formulára – merané medzi stredmi susedných polí. Príkazy Rozmiestnenie majú prednosť pred príkazom Priťahovať na mriežku.

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Vyberte polia formulára, ktoré chcete upraviť.
  3. Kliknite pravým tlačidlom myši na niektoré z vybratých polí formulára a vykonajte jeden z týchto úkonov:
    • Ak chcete polia rovnomerne rozmiestniť medzi najvyššie a najnižšie umiestneným poľom, vyberte voľby Zarovnať, Rozmiestniť alebo Vystrediť > Rozmiestniť zvisle.

    • Ak chcete polia rovnomerne rozmiestniť medzi poľom umiestneným úplne vľavo a poľom umiestneným úplne vpravo, vyberte voľby Zarovnať, Rozmiestniť alebo Vystrediť > Rozmiestniť vodorovne.

      poznámka: Príkaz Rozoslať pod položkou Nástroje > Formuláre má inú funkciu. Tento príkaz slúži na odoslanie formulára iným užívateľom, ktorí v ňom vyplnia príslušné polia a potom vám svoje dáta odošlú naspäť.

Odstránenie poľa formulára

  1. Ak nie ste v režime úprav formulára, vyberte voľby Nástroje > Formuláre > Upraviť.
  2. Na paneli Polia alebo v zobrazení strany vyberte polia formulára, ktoré chcete odstrániť.
  3. Stlačte Delete alebo vyberte Úpravy > Odstrániť.

Licencia na používanie tohto diela sa poskytuje v súlade s podmienkami licencie Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Na príspevky v sociálnych sieťach Twitter™ a Facebook sa nevzťahujú podmienky licencií Creative Commons.

Právne upozornenia   |   Zásady ochrany osobných údajov online