Akcie

Ak na svoje súbory pravidelne aplikujete jednu alebo viac rovnakých sérií príkazov, môžete ušetriť čas aj údery na klávesnici, keď použijete akciu – definovanú sériu príkazov so špecifickými nastaveniami a určeným poradím, ktorú aplikujete v jednom kroku. Akciu môžete aplikovať na jeden dokument, na niekoľko dokumentov alebo na celú sadu dokumentov. Dokonca môžete pred spustením akcie naskenovať dokumenty a zlúčiť niekoľko dokumentov do jedného dokumentu PDF.

Súčasťou aplikácie Acrobat je niekoľko vopred definovaných akcií. Môžete tiež vytvoriť svoje vlastné akcie. Akcie môžete zobraziť a spravovať po kliknutí na položky Súbor > Sprievodca akciami.

Aplikácia Adobe Acrobat tiež umožňuje exportovať a importovať akcie a príkazy, aby ste ich mohli zdieľať s ostatnými používateľmi.

Poznámka:

Rozhranie a architektúra akcií nahrádza režim dávkových skriptov dostupný v starších verziách aplikácie Acrobat. Väčšinu vašich dávkových skriptov aplikácie Acrobat XI môžete importovať ako akcie. Niektoré skripty vyžadujú menšie úpravy.

Spustenie akcie

Aplikácia Acrobat obsahuje niekoľko jednoduchých preddefinovaných akcií, ktoré môžete použiť na zvýšenie produktivity svojej práce. Tieto akcie predstavujú bežné úlohy, ktoré sa bežne vykonávajú pri príprave súborov na distribúciu. Pred spustením týchto akcií nemusíte otvárať žiadne súbory PDF.

Poznámka:

Pri spustení sekvencie na dokumentoch PDF, ktoré požadujú heslo, sa môžete vyhnúť zobrazovaniu výziev na zadanie hesla. Automatizujte zadávanie hesla alebo zadajte spôsob zabezpečenia pre tieto súbory na paneli Sprievodca akciou v dialógovom okne Predvoľby. Ak vyberiete položku Nepýtať sa na heslo, dokumenty PDF, ktoré požadujú heslo, sa nespracujú.

  1. Vyberte položky Nástroje > Sprievodca akciami. V zozname akcií na table vpravo sa zobrazí zoznam dostupných akcií.

  2. Vyberte akciu zo zoznamu. Tabla vpravo sa zmení a zobrazí všetky úlohy v rámci danej akcie, ako aj pokyny, ktoré poskytol autor danej akcie.

  3. Pod položkou Súbory na spracovanie kliknite na položku Pridať súbory a vyberte súbory, na ktorých chcete spustiť danú akciu. Akciu môžete spustiť v aktuálne otvorenom súbore alebo pridať ďalšie súbory, priečinky či e-mailové prílohy.

  4. Keď sa v zozname nachádzajú všetky súbory, ktoré chcete spracovať, kliknite na tlačidlo Spustiť.

  5. Ak vás aplikácia Acrobat vyzve, zadajte ďalšie informácie, napríklad výstupné umiestnenie a nastavenia.

Indikátor priebehu zobrazuje stav aktuálne spusteného procesu alebo úlohy. Značka začiarknutia označuje dokončené akcie alebo úlohy. Po úspešnom vykonaní všetkých úloh sa na paneli zobrazí stav „Dokončené“.

Poznámka:

Kliknutím na tlačidlo Stop na paneli môžete vykonanie akcie zastaviť. Aplikácia Acrobat uloží všetky súbory, ktoré už boli spracované podľa definície v akcii. V akcii môžete pokračovať kliknutím na položku Pokračovať alebo môžete ukončiť ďalšie vykonanie akcie kliknutím na ikonu krížika pred názvom činnosti na table vpravo. 

Vytvorenie vlastnej akcie

Aby bolo jednoduchšie sledovať vašu akciu, môžete zoskupiť kroky do panelov, pridať oddeľovacie čiary a vložiť pokyny. Akciu môžete obmedziť iba na konkrétne súbory, použiť na všetky súbory v priečinku alebo nechať používateľa vybrať súbor z rôznych zdrojov, ako je skener, webová stránka či schránka.

  1. Vyberte položky Nástroje > Sprievodca akciami.

    Na sekundárnom paneli s nástrojmi sa zobrazí súprava nástrojov sprievodcu akciami.

    Poznámka:

    V zozname akcií na table vpravo sa zobrazí zoznam dostupných akcií.

  2. Na sekundárnom paneli s nástrojmi kliknite na položku Nová akcia.

    Zobrazí sa dialógové okno Vytvoriť novú akciu.

  3. Ak chcete akciu použiť na špecifický súbor alebo na všetky súbory v priečinku, kliknite na položku Súbor  alebo Priečinok  pod možnosťou Súbory na spracovanie (v pravej časti). Prejdite na požadovaný súbor alebo priečinok a kliknite na tlačidlo Otvoriť.

  4. Na table Vyberte nástroje na pridanie rozbaľte panely a dvojitým kliknutím na úlohu danú úlohu pridajte. Môžete pridať viac úloh. Úlohy sa vykonávajú v poradí, v ktorom sú zobrazené v zozname Kroky akcií na zobrazenie v pravej časti.

  5. Ak chcete preddefinovať voľby pre úlohu, kliknite na položku  Zadanie nastavení.

  6. Ak chcete, aby akcia vyzvala používateľa na výber možností, kliknite na začiarkavacie políčko Spýtať sa používateľa.

  7. Podľa potreby pridajte ďalšie úlohy.

  8. Dolaďte akciu pomocou tlačidiel vpravo. Pridajte nové zoskupenie panelov, pokyny alebo oddeľovaciu čiaru, alebo premiestnite položky v zozname alebo ich odstráňte zo zoznamu.

    Vytvorí nové zoskupenie panelov v spodnej časti aktuálnej sady úloh. Po výzve zadajte názov panela a kliknite na položku Uložiť.

    Pridá pokyny pod aktuálne vybratou úlohou. Keď sa zobrazí výzva, zadajte pokyny a kliknite na položku Uložiť.

    Pridá oddeľovaciu čiaru pod aktuálne vybratou úlohou.

    Premiestni aktuálne vybratú položku vyššie v rámci zoznamu. Môžete premiestniť úlohu, pokyny, oddeľovaciu čiaru alebo celé zoskupenie panelov.

    Premiestni aktuálne vybratú položku nižšie v rámci zoznamu. Môžete premiestniť úlohu, pokyny, oddeľovaciu čiaru alebo celé zoskupenie panelov.

    Odstráni aktuálne vybratú položku. Položky vyberajte opatrne. Môžete odstrániť celé zoskupenie panelov.

  9. Kliknite na položku Uložiť.

  10. V dialógovom okne Uložiť akciu zadajte názov a popis akcie a potom kliknite na tlačidlo Uložiť.

Správa vlastných akcií

Pomocou dialógového okna Spravovať akcie môžete upravovať, premenúvať, kopírovať, odstraňovať, importovať alebo exportovať akcie.

Úprava akcie

  1. Vyberte položky Nástroje > Sprievodca akciami.

    Na sekundárnom paneli s nástrojmi sa zobrazí súprava nástrojov sprievodcu akciami.

    Poznámka:

    V zozname akcií na table vpravo sa zobrazí zoznam dostupných akcií.

  2. Na sekundárnom paneli s nástrojmi kliknite na položku Spravovať akcie.

    Zobrazí sa dialógové okno Spravovať akcie.

  3. V dialógovom okne Spravovať akcie vyberte akciu a kliknite na tlačidlo Upraviť na úpravu úloh alebo nastavení. Dialógové okno Upraviť akcie môžete použiť aj na zobrazenie akcie a ukončenie bez uloženia zmien.

    Poznámka:

    Akcie, ktoré sú dostupné mimo tohto okna, nie je možné upravovať.

  4. Ak chcete pridať úlohy, rozbaľte panely na table Vyberte nástroje na pridanie a kliknite na úlohu.

  5. Kliknite na položku Uložiť.

  6. V dialógovom okne Uložiť akciu v prípade potreby upravte popis a kliknite na tlačidlo Uložiť.

Premenovanie akcie

  1. Vyberte položky Nástroje > Sprievodca akciami.

  2. Na sekundárnom paneli s nástrojmi kliknite na položku Spravovať akcie.

  3. V dialógovom okne Spravovať akcie vyberte akciu a kliknite na tlačidlo Premenovať.

    Poznámka:

    Akcie, ktoré sú dostupné mimo tohto okna, nie je možné premenovať.

  4. V dialógovom okne Uložiť akciu v prípade potreby zadajte nový názov a popis a kliknite na tlačidlo Uložiť

Kopírovanie akcie

Môžete duplikovať akciu a pred uložením jej kópie môžete upraviť úlohy v akcii.

  1. Vyberte položky Nástroje > Sprievodca akciami.

  2. Na sekundárnom paneli s nástrojmi kliknite na položku Spravovať akcie.

  3. V dialógovom okne Spravovať akcie vyberte akciu a kliknite na tlačidlo Kopírovať.

  4. V dialógovom okne Uložiť akciu zadajte názov a popis akcie a kliknite na tlačidlo Uložiť.

    Vytvorí sa nová kópia vybranej akcie a pridá sa do zoznamu Vybrať akciu.

Odstránenie akcie

  1. Vyberte položky Nástroje > Sprievodca akciami.

  2. Na sekundárnom paneli s nástrojmi kliknite na položku Spravovať akcie.

  3. V dialógovom okne Spravovať akcie vyberte akciu a kliknite na tlačidlo Odstrániť.

    Poznámka:

    Akcie, ktoré sú dostupné mimo tohto okna, nie je možné odstrániť.

  4. V potvrdzovacom dialógovom okne kliknite na možnosť Áno.

Exportovanie akcie

  1. Vyberte položky Nástroje > Sprievodca akciami.

  2. Na sekundárnom paneli s nástrojmi kliknite na položku Spravovať akcie.

  3. V dialógovom okne Spravovať akcie vyberte akciu a kliknite na tlačidlo Exportovať.

  4. V dialógovom okne Uložiť ako zadajte názov a umiestnenie súboru na uloženie akcie. Súbory s akciami majú príponu .sequ.

  5. Kliknite na položku Uložiť.

Importovanie akcie

  1. Vyberte položky Nástroje > Sprievodca akciami.

  2. Na sekundárnom paneli s nástrojmi kliknite na položku Spravovať akcie.

  3. V dialógovom okne Spravovať akcie kliknite na tlačidlo Importovať.

    Poznámka:

    Akciu môžete importovať aj dvojitým kliknutím na súbor .sequ.

  4. V dialógovom okne Otvoriť vyberte súbor akcie, ktorý chcete importovať, a kliknite na položku Otvoriť. Súbory s akciami majú príponu .sequ.

  5. V potvrdzovacom dialógovom okne kliknite na možnosť OK.

    Poznámka:

    Ak akcia obsahuje JavaScript, zobrazí sa hlásenie s upozornením uvádzajúce, že vybraná akcia obsahuje JavaScript. Pokračujte kliknutím na možnosť Importovať alebo importovanie zrušte kliknutím na možnosť Zrušiť.

Automatické zadávanie hesla pre akcie

Pred spustením akcií pre súbory PDF, ktoré sú zašifrované alebo chránené heslom, môžete nastaviť svoj digitálny identifikátor tak, aby sa požadované heslá zadávali automaticky.

Poznámka:

 Na paneli Sprievodca akciami v dialógovom okne Predvoľby zadajte metódu zabezpečenia pre tieto súbory. Ak vyberiete položku Nepýtať sa na heslo, dokumenty PDF, ktoré požadujú heslo, sa nespracujú.

  1. Otvorte dialógové okno Predvoľby.

  2. V zozname Kategórie na ľavej strane kliknite na položku Podpisy.

  3. V časti Identity a dôveryhodné certifikáty kliknite na tlačidlo Viac.

  4. V ľavej časti otvorte položku Digitálne ID a vyberte voľbu Súbory digitálnych ID.

  5. Vyberte identifikátor zo zoznamu napravo a potom na hornej lište vyberte nasledujúce príkazy:

    Prihlásiť sa

    Prihlásenie pomocou určeného digitálneho identifikátora. Zadajte heslo a kliknite na tlačidlo OK.

    Odhlásiť sa

    Odhlásenie pomocou určeného digitálneho identifikátora pri dokončení vykonávania akcie.

Vytváranie a správa vlastných príkazov

Vlastné príkazy umožňujú vopred nakonfigurovať príkazy, napríklad Vodoznak a Hlavička a päta, na skrátenie času potrebného na nastavenie každého príkazu. Šetrí sa tým čas za opakované úlohy.

Vlastné príkazy majú jeden krok a možno ich aplikovať len na aktuálny dokument, zatiaľ čo akcie predstavujú sekvenciu viacerých krokov a možno ich aplikovať na viaceré súbory.

Vytvorenie vlastného príkazu

  1. Zvoľte Nástroje > Sprievodca akciami > Nový vlastný príkaz.

  2. V dialógovom okne Nový vlastný príkaz sa na ľavej table zobrazí zoznam prispôsobiteľných príkazov. Vyberte príkaz, ktorý chcete prispôsobiť.

  3. V prípade potreby zmeňte označenie a tip príkazu. Môžete tiež vybrať, či sa majú pri spustení príkazu zobrazovať voľby príkazov.

  4. Kliknite na položku Voľby príkazov. V dialógovom okne vyberte alebo zadajte príslušné hodnoty alebo voľby a kliknite na tlačidlo OK.

  5. Kliknutím na tlačidlo OK uložíte nový vlastný príkaz.

    Príkaz sa zobrazí na pravej table v časti Vlastné príkazy.

Spustenie vlastného príkazu

  1. Vyberte položky Nástroje > Sprievodca akciami.

  2. Na pravej table v časti Vlastné príkazy kliknite na názov príkazu.

Správa vlastných príkazov

Pomocou dialógového okna Spravovať vlastné príkazy môžete upravovať, kopírovať, premenovávať, odstraňovať, meniť poradie, importovať alebo exportovať príkazy.

  1. Vyberte položky Nástroje > Sprievodca akciami.

  2. V dialógovom okne Spravovať vlastné príkazy vyberte v zozname príkaz a kliknite na príslušné tlačidlo. Postupujte podľa pokynov alebo výziev na obrazovke a dokončite úlohu.

  3. Po dokončení kliknite na tlačidlo Zatvoriť.

Licencia na používanie tohto diela sa poskytuje v súlade s podmienkami licencie Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Na príspevky v sociálnych sieťach Twitter™ a Facebook sa nevzťahujú podmienky licencií Creative Commons.

Právne upozornenia   |   Zásady ochrany osobných údajov online