Brand Portal supports integration with AEM Assets to have approved brand assets seamlessly ingested (or published) from AEM Assets author instance. Once integrated, AEM Author uses a replication agent to replicate the selected asset(s) to Brand Portal cloud service for approved usage by Brand Portal users. Multiple replication agents are used AEM 6.2 SP1-CFP5, AEM CFP 6.3.0.2, and onwards to allow high-speed parallel publishing.

Not:

Adobe recommends upgrading to AEM 6.4.1.0 to ensure that AEM Assets Brand Portal is successfully integrated with AEM Assets. A limitation in AEM 6.4 gives an error while configuring integration with Brand Portal and replication fails.

On configuring cloud service for brand portal under /etc/cloudservice, all necessary users and token are auto-generated and saved in the repository- cloud service configuration is created, service users required for replication, and replication agents to replicate content. This creates four replication agents. So when you publish numerous assets from AEM to Brand Portal, these are queued and distributed among these replication agents through Round Robin.

However, publishing can fail intermittently due to- large sling jobs, increased Network and Disk I/O on AEM Author, or slowed AEM Author performance. It is, therefore, advised to test the connection with the replication agent(s) prior to beginning publishing.

Test-Connection

Troubleshoot failures in first time publishing: Validating your publish configuration

To validate your publish configurations:

  1. Check the error logs
  2. Check whether the replication agent is created
  3. Test connection

While creating Cloud Service

Check tail logs. Check whether the replication agent is created or not. If the replication agent creation fails, edit the cloud service by making minor changes in cloud service. Validate and check again whether the replication agent is created or not. If not, re-edit the service. 

Even if, on repeatedly editing the cloud service it is not configured properly, report a daycare ticket.

Test connection with replication agents

View log, if errors are found in replication log:

1. Contact Adobe Support

2. Retry clean-up and create publish configuration again

Cleaning up existing Brand Portal publish configurations

Most of the times when publish is not working, the reason is that the user who is publishing (mac-<tenantid>-replication) doesn't have the latest private key, and hence publish fails with "401 unauthorized" and no other error is reported in replication agent logs. You might want to avoid troubleshooting and create a new config instead. For the new config to work properly, you should clean up the following from AEM author setup:

  1. go to localhost:4502/crx/de (assumes you are running author on localhost:4502):
     i    delete /etc/replication/agents.author/mp_replication*
     ii    delete /etc/cloudservices/mediaportal/<config_name>
  2. go to localhost:4502/useradmin:
    i    search for user mac-<tenantid>-replication
    ii    delete this user

Now the system is all cleaned up. Now you can attempt creating a new cloudservice config and still use the already existing JWT application in https://legacy-oauth.cloud.adobe.io/. There is no need to create a new application, rather just the public key needs to be updated from the newly created cloud config. 

Developer connection JWT application tenant visibility issue

If on https://legacy-oauth.cloud.adobe.io/, all the orgs (tenants) for which the current users hold system administrator are listed. If you don't find the org name here or you can't create an application for a required tenant here, please check if you have sufficient (system administrator) rights to do this.

There is one known issue on this UI that for any tenant only top 10 applications are visible. When you create the application, stay on that page and bookmark the URL. You don't need to go to applications listing page and find out the application you created. you can hit this bookmarked URL directly and update/delete the application whenever needed.

The JWT application might not be listed appropriately. It is, therefore, advised to note/ bookmark the URL while creating JWT application.

Running Configuration stops working

If a replication agent (which was publishing to brand portal just fine) stops processing publish jobs, check replication logs. AEM has auto-retry built-in, so if a particular asset publish fails, it is retried automatically. If there is some intermittent issue like network error, it might succeed during re-try.

But if there are continuous publish failures and queue is blocked. then you should check "test connection" and try to solve the errors that are being reported.

Based on the errors, you are advised to log a support ticket, so that Brand Portal engineering team can help you resolve issues.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi