註解:

如需有關安全性的完整文章清單,請參閱 Acrobat 和 PDF 內容中的安全性概觀

為何將敏感性內容移除或標記為密文?

在分發 PDF 之前,您可能希望檢查文件中的敏感性內容或可追蹤到您的私人資訊。使用「封鎖並移除內容」工具 (又稱「密文」工具) 以移除或密文 PDF 中可見的敏感性影像與文字。

使用「移除隱藏的資訊」功能可在 PDF 中尋找並移除隱藏的內容。例如,如果您建立 PDF,文件元資料通常會將您的姓名列為作者。您可能還希望移除那些可以無法復原的方式變更或修改文件外觀的內容。JavaScript、動作及表格欄位均是此類變更的內容類型。

密文 (封鎖並移除) 敏感性內容 (Acrobat Pro)

密文是永久地移除文件中文字與圖形的程序。使用「封鎖並移除內容」工具 (又稱「密文」工具) 可以移除內容。在移除項目的位置,您可以將密文標記顯示為彩色方塊或使該區域顯示為空白。您可以指定顯示在密文標記上的自訂文字或密文編碼。

註解:

如果您要尋找並移除特定字彙、字元或片語,請改用「搜尋並移除文字」工具 

標記為密文的文字 (左) 和密文 (右)
標記為密文的文字 (左) 和密文 (右)

  1. 選擇「工具 > 保護 > 標記為密文」。(如果未顯示「保護」面板,請選擇「檢視 > 工具 > 保護」。)

  2. (可選) 若要設定密文標記的外觀,請按一下「密文內容」。(請參閱變更密文標記外觀。)

  3. 請執行以下任一動作來標記您要移除的記號:
    • 請連按兩下來選定一個字或一幅影像。
    • 拖曳以選擇線段、文字區塊、物件或區域。
    • 當您在一份掃描文件裡以拖曳選取區域時,請按一下 Ctrl 鍵。

    註解:

    若要預覽密文標記的顯示方式,請將指標停留在標記的區域上。

  4. 若要在單一密文內套用多重編碼項目,在密文標記上按一下右鍵並選取任一選項。如需更多詳細資料,請參閱密文套用編碼項目
  5. (可選) 若要重複密文標記,請在其上方按一下右鍵,並選擇「跨頁重複標記」。如果特定的頁首、頁尾或水印出現在許多頁面的相同位置,此功能便十分方便。

  6. 完成標記您要標記為密文的項目後,請選擇「工具 > 保護 > 套用密文」將項目移除,然後按一下「確定」

    在您儲存文件之前,項目將不會永久地從文件移除。

  7. 如果您要使用「移除隱藏的資訊」功能來搜尋並移除文件中隱藏的資訊,請在對話方塊內按一下「是」。否則,請按一下「否」

  8. 選擇「檔案 > 儲存」,然後指定檔名和位置。檔案名稱會附加字尾 “_Redacted”。如果您不準備覆寫原始檔案,請使用其它名稱、位置或兩者均異來儲存檔案。

搜尋並移除文字 (Acrobat Pro)

使用「搜尋並移除文字」工具可在一個或多個含有可搜尋文字的 PDF 中尋找並移除文字或片語。

註解:

「搜尋並移除文字」工具無法搜尋安全性 (加密) 的 PDF。

  1. 選擇「工具 > 保護」,然後選擇「搜尋並移除文字」工具 。(如果未顯示「保護」面板,請選擇「檢視 > 工具 > 保護」。)

  2. 請指定您欲搜尋目前的 PDF 或其它位置中的所有 PDF。
  3. 執行下列任一項作業:
    • 若僅搜尋一個字或片語,請選擇「單個字或片語」,然後在文字欄位中鍵入字或片語。
    • 若要搜尋多個字,請選擇「多個字或片語」,然後再按一下「選擇字」。在「新字或片語」文字欄位中鍵入每個字,再按一下「新增」。您也可讀入內含欲搜尋之文字或片語清單的文字檔。
    • 若要搜尋圖樣 (例如電話號碼、信用卡號碼、電子郵件地址、身分證號碼或日期等),請按一下「樣式」。請選擇一個可用的圖樣。您可以變更圖樣的語言版本。(請參閱選取其它圖樣語言版本。)
  4. 按一下「搜尋並移除文字」

  5. 在搜尋結果中,按一下文件名稱旁的加號 (+) 可查看所有出現的文字或片語。然後,請選擇您要標記為密問的實例。
    • 若要選擇清單中所有出現的結果,請按一下「全選」
    • 要選擇個別實例,請按一下要標記密文的項目旁邊的核取框。按一下核取框旁邊的文字可檢視頁面上的實例。
    • 若不要標記任何實例,請關閉「搜尋」視窗,或按一下「新建搜尋」來重新開始。
    • 若要標記全部文字或部分文字 (字元) 為密文,請選取在「密文標記選項」下的選項。針對部分文字,請按一下「設定」並指定密文的字元數量與位置。如果您要搜尋圖樣,例如信用卡號碼,並只想要顯示部分可見的號碼以做辨識之用,那麼字元密文的功能就非常好用。
  6. 如果您已選定要標記為密文的實例,請按一下「將選定的結果標記為密文」

    您在清單中選定的項目會顯示標記為密文。

    註解:

    如果尚未儲存檔案,則可以選擇文件中的密文標記,然後按「刪除」來移除密文標記。儲存檔案後,密文標記永久存在。

  7. 若要移除標記的項目,請按一下「工具 > 保護 > 套用密文」,然後按一下「確定」

    在您儲存文件之前,這些項目不會從文件永久移除。

  8. 如果您要使用「移除隱藏的資訊」功能來搜尋並移除文件中隱藏的資訊,請按一下「是」。否則,請按一下「否」

  9. 選擇「檔案 > 儲存」,然後指定檔名和位置。如果您不準備覆寫原始檔案,請使用其它名稱、位置或兩者均異來儲存檔案。

尋找與移除隱藏內容

使用「移除隱藏的資訊」功能可尋找並從文件移除您不需要的內容,如隱藏的文字、元資料、注釋和附件。移除項目時,其它項目會自動從文件移除。移除的項目包括數位簽名、協力廠商增效模組和應用程式新增的文件資訊,以及讓 Adobe Reader 使用者審核、簽署和填寫 PDF 文件的特殊功能。

註解:

若要先檢查每個 PDF 是否有隱藏內容,然後再關閉 PDF 或透過電子郵件加以傳送,請使用「偏好設定」對話方塊,在「文件」偏好設定中指定該選項。

  1. 選擇「工具 > 保護 > 移除隱藏的資訊」。(如果未顯示「保護」面板,請選擇「檢視 > 工具 > 保護」。)

    如果找到項目,項目便會列在「移除隱藏的資訊」面板中,且每個項目旁邊都會顯示一個已選取的核取框。

  2. 請確定您僅選取了想要從文件中移除的項目的核取框。(請參閱移除隱藏資訊選項。)
  3. 按一下「移除」刪除檔案中的選定項目,然後按一下「確定」

  4. 選擇「檔案 > 儲存」,然後指定檔名和位置。如果您不準備覆寫原始檔案,請使用其它名稱、位置或兩者均異來儲存檔案。

儲存檔案後,選定的內容即永久移除。如果您沒有儲存即關閉檔案,請重複此程序來確保儲存檔案。

移除隱藏資訊選項

「中繼資料」

元資料包含文件以及其內容的相關資訊,例如作者姓名、關鍵字和版權資訊。若要檢視元資料,請選擇「檔案 > 內容」

「檔案附件」

任何格式的檔案均可作為附件附加在 PDF 中。若要檢視附件,請選擇「檢視 > 顯示/隱藏 > 導覽窗格 > 附件」

「書籤」

書籤是包含顯示文字的連結,用於開啟 PDF 中的特定頁面。若要檢視書籤,請選擇「檢視 > 「顯示/隱藏 > 導覽窗格 > 書籤」

「注釋和標註」

此項目包括使用注釋和標註工具在 PDF 中新增的所有注釋,其中包括貼附為注釋的檔案。若要檢視注釋,請選擇「注釋」窗格。

「表格欄位」

此項目包括「表格欄位」(包括「簽名」欄位在內),和該表格欄位所關聯的所有「動作」和計算。如果您移除此項目,所有表格欄位被平面化,再也無法填寫、編輯或簽署。

「隱藏的文字」

此項目表示 PDF 中的文字或是透明,或是被其它內容遮蓋,或其色彩和背景相同。

「隱藏的圖層」

PDF 可包含能顯示或隱藏的多個圖層。移除隱藏的圖層將從 PDF 中移除這些圖層並將剩餘圖層平面化為單一圖層。若要檢視圖層,請選擇「檢視 > 顯示/隱藏 > 導覽窗格 > 圖層」

「嵌入的搜尋索引」

嵌入的搜尋索引可提昇在檔案中的搜尋速度。若要決定 PDF 是否包含搜尋索引,請選擇「檢視 > 工具 > 文件處理 > 管理內嵌索引」。移除索引將縮小檔案大小,但搜尋 PDF 所耗費的時間增加。

「刪除或裁切的內容」

PDF 有時包含已移除的以及不再顯示的內容 (如裁切、刪除的頁面或刪除的影像)。

「連結、動作和 JavaScript」

此項目包含網頁連結、「動作」精靈新增的動作以及整份文件的 JavaScript

「重疊物件」

此項目包含彼此重疊的物件。這類物件可以是影像 (像素構成)、向量圖形 (路徑構成)、漸層或圖樣。

針對模式選擇不同的語言版本 (Acrobat Pro)

「搜尋」面板中會顯示本地化樣式 (「保護 > 搜尋並移除文字」)。

  1. 選擇「編輯 > 偏好設定」(Windows) 或「Acrobat > 偏好設定」(Mac OS)。

  2. 從左側的「類別」中選擇「文件」

  3. 「密文」區域中,從「選擇搜尋並移除文字樣式的本地化」功能表選擇語言。然後按一下「確定」

變更密文標記外觀 (Acrobat Pro)

在預設狀態下,您所標記的密文影像或文字周圍會出現紅色細框,而您所標記的密文影像或文字底下會出現黑色方塊。您可以在您對項目標記密文前,先設定您要的密文標記預設外觀。您也可以在套用密文前,變更密文標記的外觀。

設定所有標記的預設外觀

  1. 按一下「工具 > 保護 > 密文內容」。(如果未顯示「保護」面板,請選擇「檢視 > 工具 > 保護」。)

  2. 在「外觀」標籤中,請選擇所需變更的選項,然後按一下「確定」。
    • 按一下「密文區域填充色彩」圖示,然後從色彩浮動視窗中,為取代被移除項目的方塊選擇填充色彩。選擇「無色彩」可保持密文區域空白。
    • 如果您要選擇自訂文字或密文編碼選項,請選擇「使用重疊文字」。請選擇字型、尺寸和文字對齊方式。
    • 選擇「自訂文字」,然後鍵入要顯示在密文區域的文字。
    • 選取「密文編碼」,然後選取現有編碼集內的編碼,或按一下「編輯」定義新的編碼集或新編碼。(請參閱建立密文編碼和編碼集。)
    • 「密文標記外觀」區域中,按一下「外框色彩」圖示或「填充色彩」圖示,或兩者。從調色盤裡選取你所標記影像或文字密文的顏色。移動滑桿以調整顏色的不透明度。選擇「無色彩」可保持已選取區域空白。

密文文字的內容 (Acrobat Pro)

「自訂文字」

在密文標記上顯示您在「自訂文字」選項中鍵入的文字。

「字型」

以選定的字型顯示自訂文字。

「字型尺寸」

以選定的字型尺寸顯示自訂文字。

「自動調整文字大小以符合密文區域」

調整自訂文字大小以符合密文區域。選定後,此選項將覆寫重疊文字的「字型尺寸」設定。

「字型色彩」

以選定的色彩顯示自訂文字,您可以按一下色票來變更色彩。

「重複覆蓋文字」

依照需要不斷重複自訂文字來填滿密文區域,字型尺寸維持不變。例如,若您指定字母 x 或連字符 (-) 作為自訂文字,這些字元會在密文區域不斷重複。

「文字對齊方式」

將文字靠左、靠右或置中對齊。

密文編碼 (Acrobat Pro)

Acrobat 使用重疊文字來疊印為密文選取的區域。重疊文字的其中一個範例就是密文編碼,由一個或多個來自編碼集編碼條目組合而成。您可以使用的編碼集包括 Acrobat 的 U.S. FOIA 與 U.S. Privacy Act 編碼集。您可以使用編碼或自定文字來建立重疊文字。不同之處在於密文編碼是您可以儲存、轉存和讀入的文字條目。一個編碼集可包含多套編碼。

註解:

編碼不會將重疊文字目前的屬性 (如色彩、字型特徵和文字的重複程度或大小) 儲存為編碼定義。編碼僅為了可重複使用重疊文字以及允許和您共用編碼集的其他使用者使用。您可以在「密文工具內容」對話方塊中設定編碼的其它屬性。

建立密文編碼和編碼集

  1. 按一下「工具 > 保護 > 密文內容」。(如果未顯示「保護」面板,請選擇「檢視 > 工具 > 保護」。)

  2. 請選擇「使用重疊文字」
  3. 選取「密文編碼」
    • 若要新增多重編碼條目至密文編碼,請從「編碼條目」清單中選擇一個條目,並按一下「新增選定條目」。如需更多,請重複步驟。選取「移除選定的條目」來刪除編碼項目。
    • 按一下「編輯編碼」來進行其它變更。
  4. 「密文編碼編輯器」對話方塊中,按一下「新增編碼集」

  5. (可選) 請在編碼集清單下面的文字欄位中鍵入該集的新名稱,然後按一下「重新命名編碼集」
  6. 按一下「新增編碼」,然後在編碼條目清單下面的文字欄位中鍵入要顯示為重疊文字的文字,然後按一下「重新命名編碼」

  7. 請重複以前步驟來新增其它編碼項目至編碼集,或重複以前三步來建立其它編碼集和編碼。

編輯密文編碼和編碼集 (Acrobat Pro)

  1. 按一下「工具 > 保護 > 密文內容」。(如果未顯示「保護」面板,請選擇「檢視 > 工具 > 保護」。)

  2. 請選擇「使用重疊文字」,然後選擇「密文編碼」
  3. 從左邊清單中選擇密文編碼集,然後按一下「編輯編碼」

  4. 「密文編碼編輯器」對話方塊中,請執行下列任一項作業:

    • 若要移除編碼集和其中的所有編碼條目,請選擇編碼集,然後按一下「移除編碼集」
    • 若要將編碼集轉存為可在其它 PDF 中重複使用或與其他使用者共用的單獨 XML 檔案,請選取編碼集。然後按一下「轉存編碼集」,指定檔名和位置,再按一下「儲存」
    • 若要讀入以前儲存的編碼集,請按一下「讀入編碼集」,找到並選擇該檔案,然後按一下「開啟」
    • 若要重新命名「編碼集」,請在清單下面的方塊中鍵入新名稱,然後按一下「重新命名編碼集」
  5. 在選定「編碼集」的情況下,選擇要編輯的編碼項目,然後執行下列任一項作業:

    • 若要移除編碼條目,請按一下「移除編碼」
    • 若要重新命名編碼條目,請在清單下面的方塊鍵入新名稱,然後按一下「重新命名編碼」

針對單一密文套用多重編碼項目

  1. 在密文標記上按一下右鍵。從上下文功能表中最底層的清單中,選擇「編碼集」或編碼條目。

  2. 從上下文功能表中最底層的清單中選擇「編碼集」,然後從下拉功能表中選擇編碼條目。當已套用編碼時,編碼項目旁會出現已核取記號。

  3. 若要新增其它編碼項目至密文,請重複前面步驟。

將您的指標指在密文標記上方以檢視編碼項目,每個由逗號隔開。

註解:

若要將相同編碼套用至多重密文,請在標記內容前先設定「密文內容」。在「保護」面板中,按一下「密文內容」。選擇「使用重疊文字」,然後選擇「密文編碼」。選擇「編碼集」以及編碼條目,然後按一下「新增選定的條目」

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策