Fireworks 可以匯入原生 Photoshop (PSD) 檔案並保留許多 Photoshop 功能。您也可以將 Fireworks 圖像匯出至 Photoshop 以進行細部影像編輯。

在 Fireworks 中放置 Photoshop 影像

若要將 Photoshop 影像放置到 Fireworks 中,請使用「檔案 > 匯入」及「檔案 > 開啟舊檔」命令,或將檔案拖曳到畫布上。「匯入」命令可提供背景圖層和圖層資料夾的獨特選項。相對的,「開啟舊檔」命令和檔案拖曳方法則可提供導引線和狀態的選項。

在 Fireworks 中已轉換和不支援的 Photoshop 功能

開啟或匯入 Photoshop 檔案時,Fireworks 會使用您指定的匯入偏好設定,將影像轉換為 PNG 格式。(請參閱「Photoshop 匯入和開啟偏好設定」)。

  • 個別的圖層遮色片可轉換為 Fireworks 物件遮色片。不支援群組遮色片。

  • 裁剪遮色片可轉換為物件遮色片,但其外觀會有輕微的變更。若要維持外觀但停用可編輯性,請選取「裁剪遮色片」偏好設定。

  • 如果存在對應的模式,圖層混合模式可轉換為 Fireworks 物件混合模式。

  • 依照預設,圖層效果會保留。如果您偏好將這些效果轉換為對應的「即時濾鏡」,請選取「圖層效果」偏好設定。但是請注意,類似的效果與濾鏡在外觀上可能會有輕微的差異。

  • 「色版」色盤中的第一個 Alpha 色版會轉換成 Fireworks 影像中的透明區域。Fireworks 不支援其他的 Photoshop Alpha 色版。

  • 將所有 Photoshop 色階和模式轉換為 8 位元的 RGB。

拖曳、開啟或匯入Photoshop 影像至 Fireworks

您拖曳、開啟或匯入的每個影像都會變成新的點陣圖物件。

註解:

在 Windows 中, 檔案名稱必須包含 PSD 副檔名,如此 Fireworks 才能辨識 Photoshop 的檔案類型。

  1. 請執行下列其中一項:

    • 將 Photoshop 影像或檔案拖曳到開啟的 Fireworks 文件中。

    • 選取「檔案 > 開啟舊檔」或「檔案 > 匯入」,並瀏覽到 Photoshop (PSD) 檔案。

  2. 按一下「開啟」。

  3. 在出現的對話方塊中設定影像選項,然後按一下「確定」。

  4. 如果您使用「檔案 > 匯入」命令,會出現反轉的 L 形游標。在畫布上按一下您要放置影像的位置 (影像的左上角會位於指標按下的位置)。

Photoshop 檔案匯入選項

當您在 Fireworks 匯入或開啟 Photoshop 檔案時,會出現對話方塊供您指定匯入影像的方式。您選擇的選項將決定匯入檔案的外觀和可編輯性。

  1. 以像素或百分比為單位指定影像尺寸,並指定像素解析度。若要保留目前的寬度和高度比例,請選取「強制等比例」。

  2. 如果 Photoshop 檔案包含圖層構圖,請選取要匯入的影像版本。選取「顯示預覽」以顯示所選構圖的預覽。「註解」文字方塊會顯示 Photoshop 檔案中的註解。

  3. 在底部的彈出式選單中,選擇 Photoshop 影像在 Fireworks 中的開啟方式:

    維持圖層的可編輯性優先於外觀

    在不影響影像外觀的前提下,盡可能保留圖層結構與文字的可編輯性。如果檔案包含 Fireworks 不支援的功能,Fireworks 將以合併及點陣化圖層的方式保留文件外觀。以下是一些範例:

    • CMYK 圖層、調整圖層與使用「穿透」選項的圖層會與下方的圖層合併。

    • 視圖層的混合模式與透明像素的存在與否而定,使用不支援的圖層效果的圖層可能會被合併。

    維持 Photoshop 圖層外觀

    會將每一個 Photoshop 圖層上的所有物件平面化,並讓每一個 Photoshop 圖層都轉換為點陣圖物件。這個選項會讓您無法在 Fireworks 中編輯 Photoshop 圖層。但是卻可維持圖層群組。

    使用自訂偏好設定

    會使用您在「偏好設定」對話方塊中指定的自訂檔案轉換設定匯入檔案。(請參閱「Photoshop 匯入和開啟偏好設定」)。

    將 Photoshop 圖層平面化為單一影像

    會將 Photoshop 檔案匯入為沒有圖層的平面化影像。轉換後的檔案不會保留個別物件。不透明度仍將保留,但不可編輯。

  4. 如果您使用「檔案 > 匯入」命令,可以選取下列選項:

    包含背景圖層

    從影像的背景圖層匯入物件。

    匯入至新資料夾

    將影像匯入至標示為「Photoshop 匯入」的新圖層資料夾。

  5. 如果您使用「檔案 > 開啟舊檔」命令,或將 Photoshop 檔案拖曳至 Fireworks 中,可以選取下列選項:

    包含導引線

    會將 Photoshop 導引線保留在原來的位置。

    將圖層轉換為狀態

    將每個 Photoshop 圖層群組放置在專屬的個別狀態中。

關於從 Photoshop 匯入文字

註解:

若要快速匯入特定文字至 Photoshop 檔案,請將其直接複製到 Fireworks 中。複製的文字會保留所有文字屬性。

當您匯入包含文字的 Photoshop 檔案時,Fireworks 會檢查您的系統上是否有必要的字體。如果沒有安裝字體,Fireworks 會提示您取代字體或維持其外觀。

如果 Photoshop 檔案中的文字套用了 Fireworks 支援的效果,這些效果在 Fireworks 中依然會套用。不過,由於 Fireworks 和 Photoshop 套用效果的方式不同,這些效果在每個應用程式中的外觀也會有所不同。

如果選取了「維持外觀」選項,則在 Fireworks 中開啟或匯入含有文字的 Photoshop 6 或 7 檔案時,將會顯示文字的快取影像,使其外觀與 Photoshop 中的外觀維持一致。一但您編輯這些文字,快取影像就會由實際文字取代。文字外觀可能與原始文字不同。但原始字體資料會儲存在 PNG 檔中,以供您在安裝有這些原始字體的系統上使用。

註解:

Fireworks 無法匯出 Photoshop 6 或 7 格式的文字。如果您編輯包含 Photoshop 6 或 7 文字的文件,然後將文件匯出回到 Photoshop,檔案將會以 Photoshop 5.5 格式匯出。但是,如果您沒有對文字進行任何修改,檔案則會以 Photoshop 6 格式匯出。

匯入/匯出 Photoshop 漸層

匯入與匯出後的漸層品質須視漸層類型而定。漸層的顏色與不透明度可能會有些微差異。

漸層

匯入品質

線性

幾乎完全符合。

放射狀

幾乎完全符合。

反射性

幾乎完全符合。

菱形

大致符合 (對應到矩形)

角度

大致符合 (對應到圓錐形)

   

漸層

匯出品質

線性

幾乎完全符合。

放射狀

幾乎完全符合。

條狀

幾乎完全符合。

矩形

大致符合 (對應到菱形)

圓錐形

大致符合 (對應到角度)

橢圓形

大致符合 (對應到放射狀)

漣漪

大致符合 (對應到放射狀)

光芒

不完全符合 (到應到放射式形狀)

輪廓、緞面、波浪

不完全符合 (到應到線性)

在匯入後維持調整圖層的外觀

若您匯入包含調整圖層的 PSD 檔案,則匯入後仍會維持個別圖層的外觀。

  1. 在「偏好設定」對話框中,選取「Photoshop 匯入/開啟」。

  2. 選取維持圖層調整後的外觀。

維持圖層調整後的外觀

若您匯入包含調整圖層的 PSD 檔案,則匯入後仍會維持個別圖層的外觀。請確定您選取對話框中的「來自偏好設定的自訂設定」。

使用 Photoshop 濾鏡和外掛程式

您可以在「即時濾鏡」視窗或「濾鏡」選單中使用許多 Photoshop 和其他協力廠商的濾鏡與外掛程式。

註解:

支援 Photoshop 5.5 (含) 以前版本的外掛程式和濾鏡。Photoshop 6 和之後版本的外掛程式和濾鏡不相容於 Fireworks.

使用「偏好設定」對話方塊啟用 Photoshop 外掛程式

  1. 請選擇「編輯 > 偏好設定」(Windows) 或「Fireworks > 偏好設定」(Mac OS)。

  2. 按一下「外掛程式」類別。

  3. 選取「Photoshop 外掛程式」。

    「選取資料夾」(Windows) 或「選擇資料夾」(Mac OS) 對話方塊便會開啟。

    註解:

    如果對話方塊並未開啟,請按一下「瀏覽」。

  4. 瀏覽到已安裝 Photoshop 或其他濾鏡及外掛程式的資料夾,然後按一下「選取」(Windows) 或「選擇」(Mac OS)。

  5. 按一下「確定」以關閉「偏好設定」對話方塊。

  6. 重新啟動 Fireworks。

使用「即時濾鏡」視窗啟用 Photoshop 外掛程式

  1. 選取畫布上的任何向量物件、點陣圖物件或文字區塊,然後在「屬性」檢視窗中,按一下「濾鏡」標籤旁的「加號 (+)」圖示。

  2. 從彈出式選單中選取「選項 > 指定外掛程式位置」。

  3. 瀏覽到已安裝 Photoshop 或其他濾鏡及外掛程式的資料夾,然後按一下「選取」(Windows) 或「選擇」(Mac OS)。如果出現詢問您是否要重新啟動 Fireworks 的訊息,請按一下「確定」。

  4. 重新啟動 Fireworks 以載入濾鏡及外掛程式。

    註解:

    或者,您也可以將外掛程式直接安裝到 Fireworks Plug-ins 資料夾中。

在 Photoshop 中放置 Fireworks 圖像

Fireworks 提供以 Photoshop (PSD) 格式匯出檔案的延伸支援。就像其他的 Photoshop 圖像一樣,匯出至 Photoshop 的 Fireworks 影像可以在 Fireworks 重新開啟時保持相同的可編輯性。Photoshop 使用者可以在 Fireworks 處理圖像,然後再到 Photoshop 中繼續編輯。

註解:

您可以使用「PSD 儲存」擴充功能,快速地將 Fireworks 文件中的頁面與狀態以不同的 PSD 檔案格式匯出。此擴充功能可於此網址取得: http://www.adobe.com/go/learn_fw_psdsave_tw

以 Photoshop 格式匯出檔案

  1. 請選取「檔案 > 另存新檔」。

  2. 為檔案命名,並從「另存新檔」選單中選擇「Photoshop PSD」。

  3. 若要指定物件、效果和文字的預設匯出設定,請按一下「選項」。然後從「設定」選單中選擇以下的預設內容。

    維持可編輯性優先於外觀

    會將物件轉換為圖層,使效果保持可編輯,並將文字轉換成可編輯的 Photoshop 文字圖層。如果您想要在 Photoshop 中進一步編輯這個影像,而不需要保留 Fireworks 影像的精確外觀,就請選擇這個選項。

    維持 Fireworks 外觀

    會將每個物件轉換成個別的 Photoshop 圖層,並使效果和文字成為無法編輯。如果您想要在 Photoshop 中維持對 Fireworks 物件的控制,而且也要維持 Fireworks 影像的原始外觀,就請選取這個選項。

    較小的 Photoshop 檔案

    會將每個圖層平面化為完全運算的影像。如果您要匯出包含大量 Fireworks 物件的檔案,就請選取這個選項。

    自訂

    可以讓您選擇物件、效果和文字的特定設定。

  4. 按一下「儲存檔案」以匯出 Photoshop 檔案。

    註解:

    Photoshop 5.5 和較舊版本無法開啟包含超過 100 個圖層的檔案。如果您匯出的 Fireworks 文件包含超過 100 個物件,您就必須刪除或合併物件。

自訂 Photoshop 匯出設定

  1. 在「另存新檔」對話方塊中,選取「Photoshop PSD」作為檔案類型,然後按一下「選項」。

  2. 從「設定」彈出式選單中選擇「自訂」。

  3. 從「物件」彈出式選單中選擇下列其中一項:

    轉換為 Photoshop 圖層

    會將個別的 Fireworks 物件轉換成 Photoshop 圖層,並將 Fireworks 遮色片轉換成 Photoshop 圖層遮色片。

    平面化每個 Fireworks 圖層

    會將每一個個別 Fireworks 圖層上的所有物件平面化,並讓每一個 Fireworks 圖層都成為 Photoshop 中的圖層。選擇這個選項時,就會無法在 Photoshop 中編輯 Fireworks 物件。有些與 Fireworks 物件關聯的功能 (例如混合模式) 也會喪失。

  4. 從「效果」彈出式選單中選擇下列其中一項:

    維持可編輯性

    會將 Fireworks 的「即時濾鏡」轉換成 Photoshop 中的相同效果。如果 Photoshop 中不存在這些效果,便會將它們捨棄。

    運算效果

    會將效果平面化至物件。當您選擇這個選項時,即可保留效果的外觀,不過卻會無法在 Photoshop 中編輯它們。

  5. 從「文字」彈出式選單中選擇下列其中一項:

    維持可編輯性

    會將文字轉換成可編輯的 Photoshop 圖層。Photoshop 不支援的文字格式將會遺失。

    運算效果

    會將文字轉換為影像物件。當您選擇這個選項時,即可保留文字的外觀,不過卻會無法編輯它。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策