Примітка.

Повний перелік статей щодо захисту див. Огляд можливостей захисту в Acrobat та типів вмісту PDF-файлів.

Навіщо видаляти або редагувати конфіденційний вміст?

Перед розповсюдженням документа PDF іноді є сенс перевірити наявність у ньому конфіденційного вмісту або відомостей, що не підлягають розголосу, і за якими цей документ міг би бути пов'язаний із вами. Використовуйте інструменти затемнення та видалення вмісту (інструменти «Редагування») для видалення конфіденційних зображень і тексту, що є видимими у PDF-документі.

Використовуйте функцію «Видалити приховану інформацію», щоб знаходити та видаляти прихований вміст у PDF-файлах. Наприклад, після створення PDF-документа в його метаданих зазвичай міститься прізвище автора цього документа. Можливо, доведеться видалити вміст, який випадково може змінити вигляд документа. Сценарії JavaScript, дії та поля форми є типами вмісту, що підлягають зміні.

Редагування (затемнення та видалення) делікатного вмісту (Acrobat Pro)

Редагування — це процес видалення із документа видимих тексту та графіки без можливості відновлення. Видалення вмісту виконується за допомогою інструментів затемнення та видалення вмісту (що також називаються інструментами редагування). На місці видалених елементів можна залишити позначки правки у вигляді кольорових прямокутників або пусту область. Можна вказати, щоб крізь позначки правки було видно додатковий текст або редакторські коди.

Примітка.

Якщо треба знайти та видалити певні слова, символи або речення, застосуйте інструмент «Пошук і видалення».

Текст, позначений для редагування (ліворуч) і редагований (праворуч)
Текст, позначений для редагування (ліворуч) і редагований (праворуч)

  1. Виберіть «Інструменти» > «Захист» > «Позначити для редагування» . (Якщо панелі «Захист» немає, виберіть «Перегляд» > «Інструменти» > «Захист».)

  2. (Необов’язково) Щоб задати вигляд позначок редагування, виберіть параметр «Властивості компонування». (Див. Зміна вигляду редакторських позначок.)

  3. Позначте елементи, які потрібно видалити, виконавши одну з наступних дій:
    • Двічі клацніть слово або зображення, щоб виділити його.
    • Виділіть лінію, блок тексту, об'єкт або область методом перетягування.
    • Натисніть Ctrl під час перетягування, щоб виділити області сторінки у сканованому документі.

    Примітка.

    Щоб попередньо переглянути позначки редагування, наведіть вказівник на область із позначкою.

  4. Щоб застосувати кілька записів коду до однієї редакції, клацніть редакторську позначку правою кнопкою миші та виберіть параметр. Додаткову інформацію можна знайти у розділі Застосування записів коду до редакції.
  5. (Необов'язково) Щоб забезпечити повторне відображення редакторської позначки, клацніть її правою кнопкою миші та виберіть пункт повтору позначки на всіх сторінках. Це зручно, якщо певний верхній або нижній колонтитул чи водяний знак відображаються у тому самому місці на багатьох сторінках.

  6. Завершивши маркування елементів, які слід відредагувати, виберіть панель «Інструменти» > «Захист» > «Застосувати редакції» для видалення елементів, після чого клацніть «OK».

    Ці елементи буде видалено остаточно лише під час збереження документа.

  7. Якщо за допомогою функції «Видалити приховану інформацію» в документі необхідно знайти приховану інформацію та видалити її, натисніть «Так» у діалоговому вікні. Якщо ні, то натисніть «Ні».

  8. Виберіть команду «Файл» > «Зберегти» й укажіть ім'я та розташування файлу. До імені файлу додається суфікс «_Redacted». Якщо небажано перезаписувати вихідний файл, збережіть його з іншим іменем чи в іншій папці, або зробіть і те, й інше.

Пошук і видалення тексту (Acrobat Pro)

Використовуйте інструмент «Пошук і видалення» для знаходження та видалення слів або фраз в одному або декількох PDF-файлах, які містять придатний для пошуку текст.

Примітка.

Інструмент «Пошук та видалення тексту» не здійснює пошук у захищених (зашифрованих) PDF-файлах.

  1. Виберіть «Інструменти» > «Захист», а потім — «Пошук і видалення тексту» . (Якщо панелі «Захист» немає, виберіть «Перегляд» > «Інструменти» > «Захист».)

  2. Укажіть, де потрібно здійснювати пошук — у поточному PDF-файлі або в усіх PDF-файлах в інших місцях.
  3. Виконайте·одну·з наведених нижче дій.
    • Для пошуку лише одного слова або фрази виберіть «Окреме слово або фразу» та введіть слово або фразу до текстового поля.
    • Для пошуку кількох слів виберіть «Кілька слів або фразу», потім клацніть «Вибрати слова». Введіть кожне слово до текстового поля «Нове слово або фраза» та натисніть «Додати». Також можна імпортувати текстовий файл зі списком слів або фраз для пошуку.
    • Щоб здійснити пошук шаблонів (наприклад, телефонних номерів, номерів кредитних карток, адрес електронної пошти, номерів соціального страхування або певних дат), клацніть «Шаблони». Оберіть один із доступних шаблонів. Можна змінити мовну версію шаблонів. (Див. Вибір іншої мовної версії для шаблонів.)
  4. Натисніть «Знайти та видалити текст».

  5. У результатах пошуку натисніть знак «плюс» (+) поряд з іменем документа, щоб переглянути всі випадки появи слова або фрази. Потім виберіть випадки вживання, які потрібно позначити для зміни:
    • Щоб виділити всі випадки у списку, натисніть «Виділити все».
    • Щоб вибрати окремі випадки вживання, встановіть прапорці біля кожного випадку, який потрібно змінити. Клацніть текст поруч із прапорцем, щоб переглянути відповідний випадок вживання на сторінці.
    • Щоб не позначати жодного випадку, закрийте вікно «Пошук», а щоб розпочати пошук знову, натисніть «Новий пошук».
    • Щоб позначити цілі слова або частини слів (символи) для редагування, виберіть потрібний пункт у розділі параметрів редакторської позначки. Для частин слів виберіть пункт «Налаштування» і вкажіть кількість та розташування символів для редагування. Редагування символів корисне, коли виконується пошук шаблона, наприклад номерів кредитних карток, і частину номера потрібно залишити видимою з метою ідентифікації.
  6. Виділивши випадки вживання, які підлягають зміні, виберіть параметр «Позначити перевірені результати для компонування».

    Вибрані в списку елементи відображаються позначеними для редагування.

    Примітка.

    Якщо файл не збережений, можна виділити в документі позначки правки й видалити їх, натиснувши «Видалити». Після збереження документа позначки правки залишаються постійними.

  7. Щоб видалити позначені елементи, клацніть «Інструменти» > «Захист» > «Застосувати редакції», а потім натисніть кнопку «OK».

    Ці елементи буде видалено остаточно лише під час збереження документа.

  8. Якщо за допомогою функції «Видалити приховану інформацію» в документі необхідно знайти приховану інформацію та видалити її, натисніть «Так». Якщо ні, то натисніть «Ні».

  9. Виберіть команду «Файл» > «Зберегти» й укажіть ім'я та розташування файлу. Якщо небажано перезаписувати вихідний файл, збережіть його з іншим іменем, в іншій папці, або зробіть і те, й інше.

Знаходження та видалення прихованого вмісту

Функція «Видалити приховану інформацію» застосовується для пошуку й видалення небажаного вмісту в документі, наприклад прихованого тексту, метаданих, коментарів і вкладених файлів. Під час видалення елементів із документа автоматично видаляються додаткові елементи. До елементів, що видаляються, належать цифрові підписи, відомості про документ, додані модулями та програмами від сторонніх розробників, а також спеціальні функції, що надають користувачам програми Adobe Reader змогу рецензувати, підписувати та заповнювати PDF-документи.

Примітка.

Щоб перевіряти кожний PDF-файл на наявність прихованого вмісту перед його закриттям або надсиланням електронною поштою, активуйте цю функцію в розділі «Документи» діалогового вікна «Параметри».

  1. Виберіть «Інструменти» > «Захист» > «Видалити приховану інформацію». (Якщо панелі «Захист» немає, виберіть «Перегляд» > «Інструменти» > «Захист».)

    У разі виявлення прихованих елементів вони виводяться на панелі «Видалити приховану інформацію» з відміткою у полі поруч із кожним елементом.

  2. Переконайтеся, що прапорці встановлені лише для елементів, що підлягають видаленню із документа. (Див. Параметри видалення прихованої інформації.)
  3. Клацніть «Видалити», щоб видалити вибрані елементи із файлу, і натисніть «OK».

  4. Виберіть команду «Файл» > «Зберегти» й укажіть ім'я та розташування файлу. Якщо небажано перезаписувати вихідний файл, збережіть його з іншим іменем, в іншій папці, або зробіть і те, й інше.

Виділений вміст видаляється остаточно після збереження файлу. Якщо файл закрито без збереження, повторіть цей процес і обов’язково збережіть файл.

Параметри видалення прихованої інформації

Метадані

Метадані містять інформацію про документ та його вміст, наприклад ім’я автора, ключові слова та відомості про авторські права. Щоб переглянути метадані, виберіть пункт меню «Файл» > «Властивості».

Вкладені файли

У документи PDF може бути вкладено файли будь-якого формату. Щоб переглянути вкладення, виберіть «Перегляд» > «Показати/сховати» > «Панелі навігації» > «Вкладення».

Закладки

Закладки – це посилання з репрезентативним текстом, яке відкриває певні сторінки в PDF. Щоб переглянути закладки, виберіть «Перегляд» > «Показати/сховати» > «Панелі навігації» > «Закладки».

Коментарі та позначки

Цей елемент містить усі коментарі, додані до документа PDF за допомогою інструментів коментування та розмітки, включаючи коментарі у вигляді вкладених файлів. Щоб переглянути коментарі, виберіть панель «Коментар».

Поля форм

Цей елемент містить поля форм (включаючи поля для підписів), а також усі пов'язані з ними дії й обчислення. Видалення цього елемента призведе до того, що всі поля форм будуть перетворені на звичайний текст, і їх не можна буде заповнювати, змінювати або підписувати.

Прихований текст

Цей елемент вказує на текст у PDF-файлі, що є прозорим, закривається іншим вмістом, або колір якого зливається з фоновим кольором.

Приховані шари

PDF-файли здатні містити декілька шарів, які можуть бути прихованими або видимими. Видалення прихованих шарів з PDF призводить до того, що документ залишається без них, а решта шарів зводяться в один. Щоб переглянути шари, виберіть «Перегляд» > «Показати/сховати» > «Панелі навігації» > «Шари».

Вбудований індекс пошуку

Вбудований індекс пошуку прискорює пошук у файлі. Щоб визначити, чи містить PDF-файл індекс пошуку, виберіть «Перегляд» > «Інструменти» > «Обробка документа» > «Керування вбудованим індексом». Видалення індексу пошуку призводить до зменшення розміру документа PDF, але разом із тим і до збільшення тривалості пошуку в ньому.

Видалений або обрізаний вміст

У PDF-документах іноді зберігається видалений вміст, який тепер є невидимим, наприклад обрізані або видалені сторінки чи видалені зображення.

Посилання, дії та JavaScript

Цей пункт стосується посилань, дій, доданих за допомогою майстра дій, та JavaScript по всьому документу.

Об'єкти, що накладаються

Цей пункт стосується об'єктів, що накладаються на інші об'єкти. Такими об'єктами можуть бути зображення (що складаються з пікселів), векторна графіка (що складається з контурів), градієнти або візерунки.

Вибір іншої мовної версії для шаблонів (Acrobat Pro)

Локалізовані шаблони відображаються на панелі пошуку Захист» > «Знайти та видалити текст»).

  1. Виберіть пункт меню «Правка» > «Налаштування» (у Windows) або пункт меню «Acrobat» > «Налаштування» (у Mac OS).

  2. У переліку категорій ліворуч виберіть «Документи».

  3. В області редагування оберіть мову в меню вибору локалізації для пошуку та видалення текстових шаблонів. Потім натисніть кнопку «OK».

Зміна вигляду редакторських позначок (Acrobat Pro)

За замовчуванням навколо зображень та тексту, позначених для редагування, відображаються тонкі червоні контури, а на місці відредагованих зображень та тексту з'являються чорні прямокутники. Перед позначенням об'єктів для редагування можна встановити вигляд редакторських позначок за замовчуванням. Змінити вигляд редакторських позначок можна також перед застосуванням редагувань.

Визначення вигляду за замовчуванням усіх позначок

  1. Виберіть «Інструменти» > «Захист» >«Властивості редагування». (Якщо панелі «Захист» немає, виберіть «Перегляд» > «Інструменти» > «Захист».)

  2. Виберіть на вкладці «Вигляд» параметри, які потрібно змінити, і натисніть «OK»:
    • Клацніть значок «Колір заливки компонованої області» і виберіть на палітрі колір заливки прямокутників, які відображаються замість видалених елементів. Щоб залишити змінену область порожньою, виберіть параметр «Без кольору».
    • Якщо потрібно вибрати додатковий текст або параметри редакторських кодів, виберіть параметр «Використовувати перекриття тексту». Виберіть шрифт, його розмір і вирівнювання тексту.
    • Виберіть параметр «Власний текст» і введіть текст, який має відображатися в зміненій області.
    • Виберіть «Код редакції», а потім виберіть код в існуючому наборі, або клацніть «Редагувати», щоб визначити новий набір кодів або код. (Див.Створення редакторських кодів та їхніх наборів.)
    • В області вигляду редакторських позначок, клацніть значок кольору контуру, значок кольору заливки або обидва значки. Виберіть колір із палітри кольорів для зображень та тексту, позначених вами для редагування. Перемістіть повзунок, щоб налаштувати непрозорість кольору. Щоб залишити вибрану область порожньою, виберіть параметр «Без кольору».

Властивості для редагування тексту (Acrobat Pro)

Власний текст

Текст, введений у полі «Власний текст» на чорному прямокутнику, відображається поверх мітки редагування.

Шрифт

Власний текст відображається вибраним шрифтом.

Розмір шрифту

Власний текст відображається шрифтом вибраного розміру.

Автоматичний вибір розміру тексту за розміром області компонування

Розмір власного тексту підбирається за розміром області компонування. Якщо цей параметр вибрано, то він застосовується для тексту перекриття замість параметра «Розмір шрифту».

Колір шрифту

Власний текст має вибраний колір, який можна змінити, клацнувши зразок кольору.

Повторювати текст перекриття

У області компонування власний текст повторюється стільки разів, скільки потрібно для її заповнення, без зміни розміру шрифту. Наприклад, якщо в якості додаткового тексту вказано літеру x або дефіс (-), ці знаки повторюються в усій області компонування.

Вирівнювання тексту

Вирівнювання тексту за лівим краєм, правим краєм або центром.

Коди редагування (Acrobat Pro)

Acrobat використовує текст накладання для областей накладання друку, вибраних для редагування. Одним із прикладів тексту накладання є код редагування, що складається з одного або кількох записів з набору кодів. Acrobat містить набори кодів U.S. FOIA та U.S. Privacy Act, якими ви можете скористатися. Для створення тексту накладання можна використати коди або власний текст. Різниця полягає в тому, що редакторські коди — це такий текст, який можна зберігати, експортувати та імпортувати. В одному наборі може бути декілька кодів.

Примітка.

У ході визначення коду такі атрибути тексту перекриття, як колір, параметри шрифту, повторення та розмір тексту, разом із ним не зберігаються. Визначення кодів лише дають змогу повторно використовувати текст перекриття у наступних сеансах або передати ці набори текстів для використання іншим користувачами. Інші атрибути кодів визначаються у діалоговому вікні «Параметри інструмента компонування».

Створення редакторських кодів і їхніх наборів

  1. Виберіть «Інструменти» > «Захист» «Властивості редагування». (Якщо панелі «Захист» немає, виберіть «Перегляд» > «Інструменти» > «Захист».)

  2. Виберіть параметр «Використовувати перекриття тексту».
  3. Виберіть код редагування.
    • Щоб додати кілька записів коду до коду редагування, виберіть запис зі списку записів коду та натисніть кнопку додавання вибраного запису. За бажання повторіть. Щоб видалити запис коду, виберіть пункт видалення вибраного запису.
    • Натисніть кнопку «Редагувати коди», щоб внести додаткові зміни.
  4. У діалоговому вікні «Заміна редакторських кодів» натисніть кнопку «Додати набір».

  5. (Необов’язково) Введіть нове ім’я набору до текстового поля, розташованого нижче від списку наборів кодів, а потім натисніть кнопку «Перейменувати набір».
  6. Натисніть кнопку «Додати код» і введіть до поля, розташованого нижче від списку кодів, той текст, що буде використаний як текст перекриття. Потім натисніть кнопку «Перейменувати код».

  7. Щоб додати інший код до цього набору, повторіть попередню дію. Щоб додати нові набори та коди, повторіть три попередні дії.

Внесення змін у редакторські коди й набори кодів (Acrobat Pro)

  1. Виберіть «Інструменти» > «Захист» «Властивості редагування». (Якщо панелі «Захист» немає, виберіть «Перегляд» > «Інструменти» > «Захист».)

  2. Виберіть параметр «Використовувати перекриття тексту», а потім виберіть «Редакторський код».
  3. Виберіть «Набір редакторських кодів» у списку ліворуч і натисніть кнопку «Змінити коди».

  4. У діалоговому вікні «Редактор коду редакції» виконайте одну з таких дій:

    • Щоб видалити набір кодів і всі коди, які він містить, виділить цей набір кодів і натисніть кнопку «Видалити набір».
    • Щоб експортувати код до окремого XML-файлу, який можна повторно використовувати в інших PDF-файлах або надавати іншим користувачам, виберіть набір кодів. Потім клацніть елемент «Експортувати набір», укажіть ім’я файлу та місце розташування й натисніть кнопку «Зберегти».
    • Щоб імпортувати раніше збережений набір кодів, натисніть кнопку «Імпорт набору», знайдіть і виберіть цей файл, а потім натисніть кнопку «Відкрити».
    • Щоб перейменувати набір кодів, введіть нове ім'я в поле, розташоване нижче від списку, і натисніть «Перейменувати набір».
  5. У виділеному наборі кодів виберіть код, який необхідно змінити, та виконайте одну з наведених нижче дій.

    • Щоб видалити елемент коду, натисніть «Видалити код».
    • Щоб перейменувати елемент коду, уведіть нове ім'я в поле, розташоване нижче від списку, і натисніть «Перейменувати код».

Застосування кількох записів коду до однієї редакції

  1. Клацніть редакторську позначку правою кнопкою миші. Виберіть набір кодів або запис коду зі списку внизу контекстного меню.

  2. Виберіть набір кодів зі списку контекстного меню, а потім виберіть запис коду в розкривному меню. Коли код застосовується, поруч із записом коду з'являється позначка.

  3. Повторіть попередній крок, щоб додати до редакції інший запис коду.

Наведіть вказівник на редакторську позначку, щоб побачити записи коду, розділені комами.

Примітка.

Щоб застосувати один код до декількох редакцій, перш ніж позначити вміст, задайте властивості редагування. На панелі «Захист» виберіть пункт властивостей редакції. Виберіть параметр «Використовувати перекриття тексту», а потім виберіть «Редакторський код». Виділіть набір коду та оберіть запис коду, після чого клацніть «Додати виділений запис».

Цей документ захищено ліцензією Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Публікації Twitter™ і Facebook не підпадають під умови ліцензії Creative Commons.

Юридична інформація   |   Політика мережевої конфіденційності