У цьому документі описано, як інсталювати й використовувати додатковий плагін OpenEXR Alpha.

Додатковий плагін OpenEXR Alpha забезпечує альтернативний спосіб обробки даних каналу «А» під час відкриття файлу OpenEXR. Замість того, щоб перетворювати дані каналу «А» безпосередньо в прозорість (як це робить попередній модуль OpenEXR), OpenEXR Alpha відкриває дані каналу «А» як альфа-канал.

Фон

Загалом, програма Photoshop CS2 не підтримувала прозорість у 32-розрядному режимі. У цій версії було впроваджено рішення, яке дозволило введення даних прозорості в альфа-канал. У Photoshop CS3 було впроваджено підтримку прозорості для 32-розрядного режиму, що забезпечило відповідність технічним вимогам OpenEXR. Таким чином, дані прозорості більше не записувалися в альфа-канал під час компонування прямого каналу.

Перш ніж почати

Щоб інсталювати модуль OpenEXR Alpha, потрібні локальні права адміністратора. Якщо ви використовуєте Mac OS, Windows Vista або Windows 7, операційна система відобразить запит щодо вказання імені й пароля облікового запису адміністратора. Якщо ви використовуєте Windows XP, перед початком роботи ввійдіть у систему комп’ютера за допомогою локального облікового запису адміністратора.

Користувачам Windows: у деяких кроках цих технічних приміток указано повні імена файлів, включно з їх розширеннями (наприклад, OpenEXR Alpha.8bi). У Windows розширення відомих типів файлів не відображаються за замовчуванням. Щоб розширення файлів відображалися, виконайте наведені нижче дії.

  1. У Windows Explorer виберіть «Інструменти» > «Параметри папки» (Windows XP) або «Організувати» > «Параметри папок і пошуку» (Windows 7 та Vista).
  2. Перейдіть на вкладку «Вигляд», що заходиться вгорі вікна «Параметри папки».
  3. У розділі «Додаткові параметри» вкладки «Вигляд» скасуйте вибір «Приховувати розширення для зареєстрованих типів файлів».
  4. Натисніть кнопку «OK».

Користувачам Windows: для виконання деяких кроків із цього документа потрібно визначити, яка версія Windows використовується: 32- чи 64-розрядна. Щоб визначити, який тип системи інстальовано, див. розділ Визначення розрядності інстальованої на комп’ютер версії Windows (32- чи 64-розрядна).

Сумісність

У Windows модуль OpenEXR Alpha не сумісний із версіями Photoshop, старішими за Photoshop CS5. Цей модуль не завантажується у Photoshop CS3 й CS4.

У Mac OS модуль OpenEXR Alpha не завантажується на комп’ютери PPC.

Інсталяція модуля OpenEXR Alpha для Photoshop CS5 у Mac або Windows (завантажте оновлення з веб-сайту Adobe)

Щоб інсталювати модуль OpenEXR Alpha, завантаживши оновлення з веб-сайту Adobe, виконайте наведені нижче дії.

  1. Завантажте стиснутий модуль:

  2. Вийдіть із Photoshop CS5.
  3. Розархівуйте завантажений файл.
  4. Перенесіть модуль у папку модулів Photoshop.
    • 32-розрядна версія Windows: перенесіть OpenEXR Alpha.8bi із папки Win32 в папку /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • 64-розрядна версія Windows/64-розрядна версія Photoshop: перенесіть OpenEXR Alpha.8bi із папки Win64 в папку /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • 64-розрядна версія Windows/32-розрядна версія Photoshop: перенесіть OpenEXR Alpha.8bi із папки Win32 в папку /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Mac OS: перенесіть OpenEXR.plugin у папку /Applications/Adobe Photoshop CS5/Plug-ins/File Formats.
  5. Запустіть Photoshop CS5.

Використання модуля OpenEXR Alpha

Щоб відкрити файл EXR, виконайте наведені нижче дії.

  1. Запустіть Photoshop CS5.
  2. Натисніть «Файл» > «Відкрити».
  3. Виберіть файл EXR, який потрібно відкрити. У списку форматів файлів виберіть OpenEXR Alpha. Photoshop трактує дані каналу «А» як альфа-канал замість прозорості.

Щоб експортувати файл EXR, виконайте наведені нижче дії.

  1. Виберіть «Файл» > «Зберегти як».
  2. У списку форматів файлів виберіть OpenEXR Alpha.

  3. Виберіть параметр «Зберегти: альфа-канали». Цей параметр зберігає дані альфа-каналу.

Примітка. Прозорість, додана після відкриття файлу, стає зведеною.

Примітка. Навіть після інсталяції модуля OpenEXR Alpha можна вибрати старий модуль OpenEXR зі списку форматів файлів. Цей модуль все ще обробляє дані в каналі «А» як прозорість. Така поведінка є типовою для Photoshop, починаючи з Photoshop CS3 (версія 10.0).

Додаткові примітки

Далі описано іншу варту уваги поведінку під час використання додаткового модуля.

  • Не підтримується помножене у зворотному порядку компонування.
  • Коли ви відкриваєте файл подвійним клацанням, Photoshop CS5 завжди використовує OpenEXR Alpha, а не OpenEXR.
  • Якщо ви відкриваєте файл із двома або більшою кількістю альфа-каналів, OpenEXR Alpha не зберігає альфа-канали. Вони повністю пропускаються.
  • (Mac OS): OpenEXR Alpha знаходиться вгорі діалогового вікна «Зберегти». Він не відображається в алфавітному порядку після Open EXR.
  • (Windows): щоб модуль функціонував як попередній модуль OpenEXR, натисніть «Файл» > «Відкрити як» і виберіть OpenEXR.

Цей документ захищено ліцензією Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Публікації Twitter™ і Facebook не підпадають під умови ліцензії Creative Commons.

Юридична інформація   |   Політика мережевої конфіденційності